Szybki start

Dokumentacja dotyczy następujących systemów:

  • - podstawowy system serii STANDARD zalecany dla małych i średnich firm oraz dla biur rachunkowych
    UWAGA. Brak kolorowej linii z lewej strony dokumentracji oznacza, że opis dotyczy wszystkich systemów, czyli serii STANDARD i PRO.

  • - rozbudowany system serii PRO rekomendowany dla średnich i dużych przedsiębiorstw oraz dla prężnie rozwijających się małych firm

    UWAGA. Czerwona linia z lewej strony dokumentacji oznacza, że opis dotyczy tylko systemu serii PRO.

Pełna dokumentacja systemów zawiera:

  • SZYBKI START - skrócona instrukcja obsługi pozwalająca na szybkie rozpoczęcie pracy

  • INSTRUKCJA UŻYTKOWNIKA - zagadnienia związane z obsługą systemu podczas codziennej pracy

  • INSTRUKCJA ADMINISTRATORA - zagadnienia związane z instalacją systemu, wdrożeniem, parametryzacją i nadzorem podczas pracy.

Dołożyliśmy wszelkich starań, by zawarte w dokumentacji informacje opisywały rzetelnie i kompletnie działanie programu, jednakże nie możemy zagwarantować, że instrukcja zaspokoi wszystkie wymagania użytkownika programu oraz że nie zawiera błędów.

W trosce o niezawodność oprogramowania, jego wysoki poziom techniczny oraz zgodność ze zmieniającym sie stanem prawnym zastrzegamy sobie prawo do aktualizowania w pierwszej kolejności programu, a dopiero potem jego dokumentacji.

(C) RESET2 Sp.z o.o. - wszystkie prawa zastrzeżone, łącznie z prawem do reprodukcji części lub całości publikacji w jakiejkolwiek formie.


Instalacja i uruchomienie programu

Szybki start

1. Upewniamy się czy na twardym dysku jest przynajmniej 300 MB wolnego miejsca.
2. Wkładamy firmową płytę z wersjami demonstracyjnymi do napędu CD-ROM.
3. Po ukazaniu się na ekranie obrazka z firmową płytą klikamy w pozycję [image] .
Jeśli obraz płyty się nie ukaże, to z menu Start wybieramy komendę Uruchom, klikamy w przycisk Przeglądaj i z głównego folderu płyty wybieramy Instaluj.exe po czym klikamy Otwórz i OK.

4. Po kliknięciu w przycisk Dalej instalacja standardowa spowoduje automatyczne zainstalowanie programu w folderze domyślnym. Wraz z programem zainstaluje się bezpłatna wersja serwera bazy danych Microsoft SQL (MSDE2000).

Jeśli chcemy określić własny folder docelowy, wykorzystać zainstalowany już wcześniej serwer MS SQL, albo jeśli chcemy zainstalować wersję sieciową to wybieramy instalację szczegółową.

5. Aby uruchomić program klikamy
Start / Programy / RESET2 / R2faktury / R2faktury w.7.0x

6. Aby wydrukować instrukcję obsługi (jeśli jej nie mamy) klikamy
Start / Programy / RESET2 / R2faktury / Instrukcja użytkownika.

7. Przy pierwszym uruchomieniu pobieramy licencję z internetu albo pracujemy na wersji demonstracyjnej. W przypadku wersji demonstracyjnej możemy od razu określić jej konfigurację (przycisk Konfiguracja).
UWAGA. Licencję możemy wczytać później (po zakupie programu), nie tracąc danych wprowadzonych w czasie pracy na wersji demonstracyjnej.

8. Przy pierwszym uruchomieniu program tworzy bazę danych na serwerze SQL. Jeśli serwer SQL zainstalowany został wraz z programem, parametry dostępowe serwera SQL podstawiają się automatycznie, wystarczy je zaakceptować.


Ogólne zasady pracy

Szybki start

Główne okno programu składa się z następujących elementów:

  1. Ikona programu - nazwa i numer wersji.

  2. Przyciski do minimalizacji i zamknięcia programu - tymczasowe opuszczenie i zakończenie pracy.

  3. Numer seryjny - nadany przy zakupie.

  4. Licencja - właściciel licencji na użytkowanie.

  5. Menu główne - wywołanie głównych funkcji.

  6. Okres pracy - wprowadzania i przeglądania danych.

  7. Bieżąca data - aktualna data w programie.

  8. Wybór [image] użytkownika - z możliwością wywołania bibliotek użytkowników.

  9. Wybór aktualnej [image] firmy - z możliwością wywołania listy obsługiwanych firm.

  10. Przyciski z podstawowymi oknami - ewidencje dla wybranej firmy:

    • PZ - przyjęcia do magazynu

    • Faktury, WZ, dokumenty sprzedaży i wydania z magazynu

    • MM - przesunięcia międzymagazynowe

    • kasa/bank - raporty kasowe i bankowe

    • windykacja należności

    • przelewy bankowe

    • lista kontrahentów

    • lista asortymentów

    • stan magazynu

Działanie i wywoływanie podstawowych funkcji jest podobne w większości okien programu:

  • F1 - wywołanie instrukcji obsługi związanej z danym oknem

  • F3 - lista wszystkich funkcji związanych z danym oknem, dostępna również po kliknięciu prawym klawiszem myszy w oknie

  • F5 - powiększenie okna na cały ekran, ponowne naciśnięcie przywraca pierwotny rozmiar

  • F12 - określenie okresu pracy, czyli przeglądania, wprowadzania i drukowania danych

  • Ins, F7 - wprowadzanie nowej pozycji (np. nowa faktura, nowy kontrahent)

  • F6,Enter - modyfikowanie pozycji

  • Del, F8 - usuwanie pozycji

  • Ctrl Ins - kopiowanie pozycji do bufora w celu wstawienia [image] podobnej pozycji z bufora klawiszami Shift Ins

  • Ctrl F5 - odświeżanie zawartości okna przydatne przy pracy sieciowej

  • Ctrl F4 - wybór kolumn widocznych w oknie

  • Ctrl Enter - podsumowanie kolumn w oknie

  • Ctrl F7, Ctrl F - wyszukiwanie pozycji w oknie, dostępne również po bezpośrednim rozpoczęciu pisania, Ctrl L wyszukuje następną pozycję

  • F2 - wydruki związane z danym oknem (np. wydruk faktury, rejestru VAT, zestawień)

  • F4 - właściwości, czyli uporządkowanie i zakres widocznych danych, szybkie przełączanie niektórych zakresów umożliwia Shift F4 (np. kontrahentów stałych, asortymentów stałych)

  • +/- z klawiatury numerycznej - wybór pozycji o zadanych kryteriach

  • - praca na wybranych (podświetlonych) pozycjach

  • - import pozycji i [image] eksport zawartości okna w wybranych formatach

W każdym oknie dostępne są również dodatkowe funkcje właściwe dla danego okna, np. w oknie FAKTURY eksport faktur do programu księgowego.


Rozpoczęcie pracy

Szybki start

1. Przed rozpoczęciem pracy należy uzupełnić dane firmy. Po kliknięciu w przycisk [image] Firmy pojawi się okno z listą firm. Klikamy na zakładkę Pozycja i wypełniamy wszystkie dane zgrupowane na zakładkach Dane, Przelewy (m.in. własny rachunek bankowy, bardzo istotny jeśli wystawiamy faktury na przelew) i Ustawienia (określamy m.in. z jakich modułów programu chcemy korzystać).
UWAGA. Jeśli posiadamy wersję programu umożliwiającą obsługę wielu firm, to [image] Ins tworzymy po kolei pozostałe firmy i uzupełniamy ich dane.

2. Określamy rodzaje dokumentów, z których będziemy korzystać w programie - menu główne Ustawienia-Definicje dokumentów. Usuwamy [image] Del definicje dokumentów, z których nie chcemy korzystać, np. Rachunek. Dla pozostałych dokumentów sprawdzamy ustawienia, a w szczególności sposób numerowania:

  • Układ - jak ma wyglądać pełny numer dokumentu (# - numer kolejny, RR rok wystawienia)

  • Pierwszy - numer pierwszego dokumentu, który będziemy wystawiać w programie

  • W roku - w którym roku rozpoczynamy wystawianie dokumentów

  • W miesiącu - w którym miesiącu rozpoczynamy wystawianie dokumentów.

3. Klikając w oknie głównym w odpowiednie przyciski uzupełniamy biblioteki asortymentów [image] i kontrahentów [image]. Wstępne uzupełnienie tych bibliotek ma na celu jedynie usprawnienie wystawiania dokumentów. Nic nie stoi na przeszkodzie, żeby uzupełniać je na bieżąco, w trakcie wystawiania PZ, faktur, WZ, RW lub MM.


Obsługa magazynu

Szybki start

1. Aby przyjąć towar do magazynu tworzymy dokument PZ, który jest odpowiednikiem faktury zakupu. W tym celu klikamy w oknie głównym w przycisk [image] i wchodzimy do okna PZ.

2. Nowy PZ tworzymy klawiszem Ins lub klikając w ikonę [image]. Wybieramy odpowiedni rodzaj dokumentu, magazyn, oraz dostawcę, a następnie wypełniamy wszystkie dane na zakładkach:

  • Pozycje

    • naciskając Enter w kolumnie Nazwa wywołujemy bibliotekę asortymentów, z której wybieramy odpowiedni asortyment Enter. Jeśli tego asortymentu nie ma jeszcze w bibliotece, to tworzymy go [image] Ins, zaznaczając, że jest to towar albo produkt.

    • naciskając Enter podajemy kolejno ilość Ile, cenę netto przed rabatem _C.netto i ewentualnie Rabat udzielony nam do tej pozycji.

  • Płatność

    • określamy Termin płatności

    • po przejściu Enter do tabelki z ratami ustalamy sposób płatności na taki, jaki zastosował na fakturze nasz dostawca.

W zależności od potrzeb wypełniamy jeszcze dane na pozostałych zakładkach i zatwierdzamy cały dokument klikając w przycisk [image] lub naciskając klawisze Alt PgDn.

3. Po uregulowaniu płatności za fakturę zakupu, odszukujemy w oknie odpowiadający tej fakturze PZ i na zakładce Płatności zaznaczamy kwotę, datę i sposób zapłaty - chyba, że korzystamy z modułu Kasa/Bank (patrz Rozliczanie płatności).

4. Po wprowadzeniu PZ możemy go wydrukować wybierając z menu drukowania [image] F2 pozycję PZ. Po zakończeniu miesiąca (lub w dowolnym innym momencie) możemy wystawione dokumenty automatycznie zaksięgować [image] w programie R2księga lub R2fk. Korzystając z pozycji Zestawienia w menu drukowania, możemy w każdej chwili wydrukować różne zestawienia za wybrany okres F12.

5. Klikając w odpowiednie przyciski okna głównego możemy przyjęty towar: wydać z magazynu na fakturze lub na osobnym dokumencie WZ albo RW, [image] przesunąć do innego magazynu dokumentem MM lub [image] sprawdzić jego bieżący stan.


Wystawianie faktur

Szybki start

1. Klikając w oknie głównym w przycisk [image] wchodzimy do okna FAKTURY, które umożliwia wystawianie wszelkich zdefiniowanych w programie dokumentów związanych ze sprzedażą oraz wydaniami towaru z magazynu (WZ, RW).

2. Nową fakturę tworzymy klawiszem Ins lub klikając w ikonę [image]. Wybieramy odpowiedni rodzaj dokumentu (faktura VAT, faktura proforma, paragon itp.) i nabywcę, a następnie wypełniamy wszystkie dane na zakładkach:

  • Pozycje

    • naciskając Enter w kolumnie Nazwa wywołujemy bibliotekę asortymentów, z której wybieramy odpowiedni asortyment Enter. Jeśli tego asortymentu nie ma jeszcze w bibliotece, to tworzymy go [image] Ins

    • naciskając Enter podajemy kolejno ilość Ile, cenę netto przed rabatem _C.netto i ewentualnie Rabat dotyczący tej pozycji.

  • Płatność

    • określamy Termin płatności

    • po przejściu Enter do tabelki z ratami możemy określić płatność w kilku ratach w różnych formach i terminach.

Jeśli korzystamy z magazynu, to na zakładce WZ możemy sprawdzić utworzony automatycznie dokument WZ, ściągający ze stanu magazynowego odpowiednią ilość towarów.

W zależności od potrzeb wypełniamy jeszcze dane na pozostałych zakładkach dokumentu. Szczegółowe określenie poszczególnych pozycji dokumentu (w tym np. określenie usługi bez konieczności wpisywania jej do biblioteki asortymentów) umożliwia przycisk [image]. Cały dokument zatwierdzamy klikając w przycisk [image] lub naciskając klawisze Alt PgDn.

3. Po uregulowaniu płatności za fakturę, odszukujemy tę fakturę w oknie i na zakładce Płatności zaznaczamy kwotę, datę i sposób zapłaty - chyba, że korzystamy z modułu Kasa/Bank (patrz Rozliczanie płatności).

4. Po wprowadzeniu faktury możemy ją wydrukować wybierając z menu drukowania [image] F2 pozycję Faktura. Po zakończeniu miesiąca (lub w dowolnym innym momencie) możemy wystawione dokumenty automatycznie zaksięgować [image] w programie R2księga lub R2fk. Korzystając z pozostałych pozycji menu drukowania, możemy w każdej chwili wydrukować rejestr sprzedaży VAT i inne zestawienia za wybrany okres F12.

UWAGA. Wprowadzanie dokumentów jest najczęściej powtarzającą się czynnością podczas pracy w programie. Aby skrócić czas niezbędny do wystawienia faktury można nie używać myszki. Przejście do następnego pola umożliwia klawisz Enter, a zatwierdzenie całego dokumentu klawisze Alt PgDn. W polach dostępnych z biblioteki (np. kontrahent) rozpoczęcie pisania rozpoczyna wyszukiwanie pozycji, natomiast Ins umożliwia dostawienie nowej. Zmianę aktualnej zakładki umożliwiają klawisze skrótów Alt P Pozycje, Alt W WZ, Alt T Płatności, Alt V Stawki VAT itd.


Rozliczanie płatności

Szybki start

Rozliczanie płatności możemy prowadzić bezpośrednio w oknie z fakturami lub PZ albo za pośrednictwem modułu Kasa/Bank. Pierwsze rozwiązanie jest wygodne jeśli wystawiamy niewiele dokumentów (kilkanaście miesięcznie), natomiast drugie jest niezbędne jeśli prowadzimy pełną księgowość lub wystawiamy dużo faktur i PZ (kilkadziesiąt lub więcej miesięcznie). Poniżej opiszemy jak zacząć korzystanie z tego drugiego sposobu.

1. Klikając w oknie głównym w przycisk [image] wchodzimy do okna Kasa/Bank, które umożliwia sporządzenie raportów kasowych i bankowych. Nowy raport tworzymy klawiszem Ins lub klikając w ikonę [image]. Wybieramy odpowiedni rodzaj raportu: kasowy (gotówka) lub bankowy (przelewy). Wybieramy odpowiednio kasę lub rachunek bankowy oraz okres, który ma obejmować ten raport (zwykle konkretny dzień, ale może to być również tydzień lub dowolny inny okres). Zatwierdzamy raport przyciskiem [image].

2. Naciskając Enter na wprowadzonym raporcie przechodzimy do okienka Pozycje raportu... gdzie możemy wprowadzać konkretne wpłaty i wypłaty. Po naciśnięciu Insert mamy do wyboru:

  • KP (wpłata gotówki), KW (wypłata gotówki) lub Inny (wpłata/wypłata przelew) - po wyborze kontrahenta przechodzimy na zakładkę Dokumenty, naciskając CtrlEnter otwieramy okno Rozrachunki i wybieramy fakturę/PZ, której dotyczy wprowadzana płatność. Na jednym KP/KW możemy wprowadzić zapłatę za dowolną liczbę faktur/PZ.

  • Automatyczne KP/KW - otworzy się lista faktur/PZ, które wystawiono w okresie obejmowanym przez raport i zaznaczono przy wystawianiu jako zapłacone gotówką (przelewem). Po podświetleniu wszystkich (CtrlA) możemy utworzyć do nich automatyczne KP.

3. Po wprowadzeniu KP/KW możemy je wydrukować wybierając z menu drukowania [image] F2 odpowiednią pozycję. Analogicznie możemy wydrukować cały raport z okna Raporty kasowe.


Windykacja należności

Szybki start

Klikając w oknie głównym w przycisk [image] wchodzimy do okna WINDYKACJA NALEŻNOŚCI, które umożliwia zbiorcze wystawianie przypomnień o zapłacie i wezwań do zapłaty do wszystkich przeterminowanych należności oraz not odsetkowych do faktur zapłaconych po terminie.

PRZYPOMNIENIA.
Aby wystawić przypomnienia do wszystkich faktur z terminem płatności, który minął np. 2 tygodnie temu należy:

  1. we właściwościach okna [image] ustawić Zakres na Należności-Przeterminowane, a Termin na 2 tygodnie temu

  2. kliknąć w ikonkę Wystaw przypomnienie

  3. w okienku Utwórz przypomnienie zaznaczyć odpowiednie opcje:

    • Zakres - czy tylko do aktualnej faktury, czy do wszystkich widocznych w oknie

    • Do zapłaty powyżej - przypomnienia zostaną wystawione tylko dla kontrahentów, u których łączna kwota do zapłacenia z tytułu niezapłaconych i przeterminowanych faktur będzie większa od podanej tu kwoty

    • Zapamiętaj wydrukowane w ewidencji - zapamiętaj datę wystawienia przypomnienia w ewidencji - przy fakturze w kolumnie P pojawi się litera "P"

    i kliknąć w przycisk OK

  4. w oknie Przegląd wydruku pojawią się przypomnienia dla wszystkich należności spełniających zadane kryteria. Można je tutaj przejrzeć i wydrukować pojedynczo lub od razu wszystkie.

WEZWANIA.
Chcąc wystawić wezwania do wszystkich należności z terminem płatności, który minął np. 4 tygodnie temu należy:

  1. we właściwościach okna ustawić Zakres na Przypomnienia-Niezapłacone, a Termin na 4 tygodnie temu

  2. kliknąć w ikonkę Wystaw wezwanie do zapłaty

Kolejne kroki analogicznie jak przy wystawianiu przypomnienia.

NOTY ODSETKOWE.
Chcąc wystawić noty odsetkowe do wszystkich faktur zapłaconych np. w poprzednim tygodniu należy:

  1. we właściwościach okna ustawić Zakres na Wezwania-Zapłacone, a Data zapłaty na 1 tydzień temu

  2. kliknąć w ikonkę Wystaw notę odsetkową

Kolejne kroki analogicznie jak przy wystawianiu przypomnienia.

Jeśli chcemy wystawić przypomnienie, wezwanie do zapłaty lub notę odsetkową indywidualnie dla jednej wybranej faktury, możemy to zrobić w oknie [image] Faktury, korzystając z funkcji [image] Windykacja należności dostępnej w menu pod prawym klawiszem myszy lub na zakładce Płatności przy każdej fakturze.


Instrukcja użytkownika

Dokumentacja dotyczy następujących systemów:

  • - podstawowy system serii STANDARD zalecany dla małych i średnich firm oraz dla biur rachunkowych
    UWAGA. Brak kolorowej linii z lewej strony dokumentracji oznacza, że opis dotyczy wszystkich systemów, czyli serii STANDARD i PRO.

  • - rozbudowany system serii PRO rekomendowany dla średnich i dużych przedsiębiorstw oraz dla prężnie rozwijających się małych firm

    UWAGA. Czerwona linia z lewej strony dokumentacji oznacza, że opis dotyczy tylko systemu serii PRO.

Pełna dokumentacja systemów zawiera:

  • SZYBKI START - skrócona instrukcja obsługi pozwalająca na szybkie rozpoczęcie pracy

  • INSTRUKCJA UŻYTKOWNIKA - zagadnienia związane z obsługą systemu podczas codziennej pracy

  • INSTRUKCJA ADMINISTRATORA - zagadnienia związane z instalacją systemu, wdrożeniem, parametryzacją i nadzorem podczas pracy

Dołożyliśmy wszelkich starań, by zawarte w dokumentacji informacje opisywały rzetelnie i kompletnie działanie programu, jednakże nie możemy zagwarantować, że instrukcja zaspokoi wszystkie wymagania użytkownika programu oraz że nie zawiera błędów.

W trosce o niezawodność oprogramowania, jego wysoki poziom techniczny oraz zgodność ze zmieniającym sie stanem prawnym zastrzegamy sobie prawo do aktualizowania w pierwszej kolejności programu, a dopiero potem jego dokumentacji.

(C) RESET2 Sp.z o.o. - wszystkie prawa zastrzeżone, łącznie z prawem do reprodukcji części lub całości publikacji w jakiejkolwiek formie.


WSTĘP

INSTRUKCJA UŻYTKOWNIKA

INSTRUKCJA UŻYTKOWNIKA została podzielona tematycznie na rozdziały zawierające następujące zagadnienia:

  • Specyfikacja programu

  • Rozpoczęcie pracy - na co należy zwrócić uwagę przed rozpoczęciem właściwej pracy, przegląd modułów programu

  • Biblioteki - przegląd bibliotek prowadzonych przez program

  • Magazyn - rozliczanie magazynu, przyjęcia PZ, wydania WZ, RW, przesunięcia MM

  • Sprzedaż - faktury i inne dokumenty sprzedaży

  • Kasa/Bank - rozliczanie płatności gotówkowych i przelewowych

  • Należności i zobowiązania - rozrachunki z kontrahentem, windykacja należności, restrykcje w obrotach

  • Przelewy bankowe - ewidencja przelewów i dowodów wpłat, wydruki i eksport do systemów bankowych

  • Zestawienia i statystyki - statystyka najważniejszych parametrów firmy, przegląd zestawień dostępnych w programie.

Zagadnienia związane z instalację systemu, wdrożeniem, parametryzacją i nadzorem podczas pracy zawarte zostały w INSTRUKCJI ADMINISTRATORA.

W trosce o niezawodność oprogramowania, jego wysoki poziom techniczny oraz zgodność ze zmieniającym sie stanem prawnym zastrzegamy sobie prawo do aktualizowania w pierwszej kolejności programu, a dopiero potem jego dokumentacji.


Specyfikacja

WSTĘP

to program komputerowy przeznaczony do obsługi sprzedaży i magazynu w małych i średnich firmach handlowych i usługowych. Umożliwia szybkie wystawianie faktur oraz ich szczegółowe rozliczanie. Prowadzi magazyn i umożliwia wystawianie wszystkich niezbędnych dokumentów magazynowych (PZ, MM, WZ, RW). Umożliwia rozliczanie płatności przy pomocy raportów kasowych i bankowych. Prowadzi rozrachunki z kontrahentami, pomaga w windykacji należności oraz ogranicza obrót z nierzetelnymi kontrahentami. Umożliwia szczegółową analizę prowadzonej działalności za pomocą rozbudowanych statystyk i definiowalnych zestawień. Sporządza, drukuje i eksportuje polecenia przelewów bankowych. Dzięki modułowej konstrukcji umożliwia dobre przystosowanie do specyfiki obsługiwanej firmy.

to rozbudowany system serii PRO rekomendowany dla średnich i dużych przedsiębiorstw oraz dla prężnie rozwijających się małych firm.

Szczegółowy opis możliwości programu R2faktury pozwala zorientować się w charakterystycznych cechach naszego systemu. Przy każdej funkcjonalności zaznaczono jej dostępność w wersjach MINI, STANDARD, MAXI i PRO, a zbiorcze zestawienie różnic pomiędzy tymi wersjami jest dostępne w rozdziale PORÓWNANIE WERSJI.

Specyfikacja systemu została podzielona na kilka części:

  • INSTALACJA I PARAMETRYZACJA

  • MAGAZYN

  • SPRZEDAŻ

  • KASA / BANK

  • NALEŻNOŚCI I ZOBOWIĄZANIA

  • PRZELEWY BANKOWE

  • CRM

  • KONTRAHENCI

  • ASORTYMENTY

  • DODATKOWE MOŻLIWOŚCI

  • MODUŁ WWW.

Aby program [image] pracował prawidłowo, musi być zainstalowany na komputerze spełniającym odpowiednie wymagania systemowe.


INSTALACJA I PARAMETRYZACJA

WSTĘP - Specyfikacja
Funkcjonalność | Wersja MINI | Wersja STANDARD | Wersja MAXI | Wersja PRO
Wprowadzanie danych firmy | + | + | + | +
możliwość obsługi wielu firm |  |  |  |
indywidualna konfiguracja parametrów każdej firmy |  |  |  |
dedykowane wersje dla biura rachunkowego |  |  |  |
obsługa różnych rodzajów księgowości: pełna księgowość, księga przychodów i rozchodów, ewidencja przychodów (ryczałt) |  |  |  |
obsługa wielu rachunków bankowych firmy |  |  |  |
możliwość umieszczenia loga każdej firmy |  |  |  |
Użytkownicy systemu |  |  |  |
możliwość nadania haseł i uprawnień poszczególnym użytkownikom | + | + | + | +
grupy praw dostępu ograniczające dostęp do wybranych danych i funkcji programu | + | + | + | +
szczegółowe prawa dostępu do wybranych ustawień, raportów oraz zestawień | - | - | - | +
ewidencja operacji wykonanych przez użytkowników | + | + | + | +
wysyłanie wewnętrznych komunikatów do poszczególnych użytkowników | + | + | + | +
konfiguracja przycisków szybkiego dostępu | + | + | + | +
własne ustawienie kolumn i uporządkowania w każdym oknie | + | + | + | +
wybór czcionki programu i jej wielkości umożliwiający powiększenie okien programu bez zmiany ogólnej rozdzielczości systemu | + | + | + | +
Instalowanie programu |  |  |  |
baza danych oparta na serwerze SQL | + | + | + | +
możliwość pracy na bezpłatnej wersji serwera Microsoft SQL | + | + | + | +
wykorzystanie możliwości architektury bazy danych typu klient-serwer | - | - | - | +
optymalizacja pod kątem pobierania tylko niezbędnych w danej chwili danych przyspieszająca pracę sieciową | - | - | - | +
wykorzystanie dodatkowych możliwości serwera SQL (np. procedury składowane) przyspieszających pracę stacji roboczych | - | - | - | +
praca w sieci lokalnej | + | + | + | +
trójwarstwowa architektura systemu umożliwiająca zdalną pracę w sieci rozległej (np. oddziały w różnych miastach) poprzez dostęp do serwera aplikacji, a nie serwera bazy danych | - | - | - | +
harmonogram zadań umożliwiający zaplanowanie dłuższych operacji oraz periodycznie wykonywanych funkcji (np. archiwizacja) | - | - | - | +
Konfiguracja bazy danych | - | - | - | +
dodatkowe pola ewidencjonowane w bazie danych |  |  |  |
dodatkowe tabele w bazie danych |  |  |  |
własne nazwy etykiet w oknach |  |  |  |
Bezpieczeństwo danych |  |  |  |
archiwizacja wszystkich danych z możliwością zabezpieczenia hasłem | + | + | + | +
w przypadku obsługi wielu firm możliwość archiwizacji danych wybranej firmy | + | + | + | +
kontrola nowych wersji i bezpośrednia aktualizacja programu przez internet | + | + | + | +
w przypadku wersji sieciowej mechanizm automatycznej aktualizacji programu na wszystkich stacjach roboczych | + | + | + | +
wbudowane funkcje serwisowania bazy danych przez internet | + | + | + | +
narzędzia (biblioteka API) umożliwiające innym aplikacjom dostęp do bazy danych programu | - | - | - | +


MAGAZYN

WSTĘP - Specyfikacja
Funkcjonalność | Wersja MINI | Wersja STANDARD | Wersja MAXI | Wersja PRO
Przyjęcia do magazynu | + | + | + | +
dokument BO umożliwiający wprowadzenie początkowego stanu magazynu |  |  |  |
dokument PZ - odpowiednik faktury zakupu umożliwiający przyjęcie pozycji "magazynowych" oraz usług |  |  |  |
przeliczanie kwot netto-brutto opcjonalnie wg netto lub brutto, zgodnie ze sposobem przeliczeń na fakturze zakupu |  |  |  |
zbiorcze kwoty netto, vat i brutto można zmienić ręcznie tak żeby odpowiadały dokładnie fakturze zakupu |  |  |  |
wprowadzenie udzielonego przez dostawcę rabatu, zarówno oddzielnie na poszczególnych pozycjach faktury zakupu, jak i dodatkowo zbiorczego rabatu dotyczącego całej faktury zakupu |  |  |  |
do trzech dowolnych uwag (z biblioteki lub wpisanych ręcznie) na wydruku PZ |  |  |  |
na każdym PZ dowolne notatki, niedrukowane na PZ |  |  |  |
możliwość zablokowania wprowadzonego towaru - towar jest w magazynie, ale nie można go wydać |  |  |  |
osoba przyjmująca towar |  |  |  |
przy pełnej księgowości - możliwość określenia konta księgowego na którym będzie księgowany zakup towaru, konto można określić dla każdej pozycji z osobna lub dla całego PZ |  |  |  |
Przyjęcia do magazynu na podstawie faktur (rachunków), dla których nabywca jest podatnikiem (odwrotne obciążenie) | - | + | + | +
Przyjęcia do magazynu na podstawie faktur RR (od rolników ryczałtowych) | - | + | + | +
wydruk faktury RR zawierającej wszystkie wymagane dane rolnika ryczałtowego |  |  |  |
Korekty przyjęć | + | + | + | +
dowolna liczba PZ korygujących do jednego PZ |  |  |  |
Wystawianie i drukowanie not korygujących | + | + | + | +
Przystosowanie dokumentów do własnych potrzeb |  |  |  |
możliwość zdefiniowania dowolnych innych dokumentów (np. Zamówienie do dostawcy, PW) i określania ich zawartości | - | + | + | +
możliwość pełnego dostosowania wyglądu wszystkich wydruków | - | + | + | +
możliwość określenia specjalnych wzorów PZ i WZ dla poszczególnych dokumentów | - | - | + | +
możliwość określenia specjalnych wzorów PZ i WZ dla poszczególnych kontrahentów | - | - | + | +
współdzielenie jednej definicji dokumentu przez wielu użytkowników lub wiele magazynów | - | - | - | +
Wiele magazynów, przesunięcia międzymagazynowe MM | + | + | + | +
przesunięcia w cenach nabycia netto, wydruk MM w cenach netto lub brutto albo bez cen (same ilości) |  |  |  |
zbiorcza waga przesuwanych towarów obliczona na podstawie wagi jednostkowej asortymentów |  |  |  |
uwagi i notatki, osoba wydająca i odbierająca towar |  |  |  |
Wydania WZ | + | + | + | +
WZ jako dokument samodzielny lub generowany automatycznie w trakcie wystawiania faktury sprzedaży |  |  |  |
wydania z kilku magazynów na jednym dokumencie WZ, wydruk WZ z podziałem na magazyny |  |  |  |
wydruk WZ w cenach nabycia, sprzedaży lub bez cen (same ilości) |  |  |  |
zbiorcza waga wydawanych towarów obliczona na podstawie wagi jednostkowej asortymentów |  |  |  |
koszt własny sprzedaży określany na podstawie zestawień lub wydruków WZ w cenach nabycia |  |  |  |
wydruk korekty kosztu sprzedaży dla każdego PZ korygującego ceny nabycia |  |  |  |
Rozchód wewnętrzny RW | - | - | + | +
automatyczne określanie cen nabycia na podstawie rozchodowanych dostaw |  |  |  |
Kontrola stanów magazynowych | + | + | + | +
algorytm FIFO, LIFO, konkretna dostawa |  |  |  |
ilości z dokładnością do 4 cyfr po przecinku |  |  |  |
Obliczanie marży i zysku, rozliczanie sprzedaży w cenach nabycia |  |  |  |
marża obliczana wg algorytmu "na sto" lub "w stu" | + | + | + | +
zysk i marża mogą uwzględniać koszty transportu nie ujęte w cenie nabycia | - | - | + | +
możliwość zablokowania wybranym użytkownikom dostępu do cen nabycia | - | - | + | +
Filtrowanie asortymentów wg bieżących stanów magazynowych | + | + | + | +
Kartoteki magazynowe | + | + | + | +
pełna historia operacji magazynowych na danym asortymencie, stan magazynu po każdej operacji |  |  |  |
Inwentaryzacja, protokoły rozbieżności PR+, PR- | - | - | + | +
arkusze inwentaryzacyjne ilościowe lub cenowo-wartościowe z podziałem na magazyny i grupy asortymentowe |  |  |  |
wydruk zestawienia różnic dla poszczególnych arkuszy |  |  |  |
automatyczne generowanie protokołów rozbieżności PR+ i PR- korygujących stan magazynu |  |  |  |
możliwość importu stanów magazynowych z kolektora danych |  |  |  |
Różne sposoby numerowania dokumentów | + | + | + | +
numerowanie roczne lub miesięczne, dowolny układ numeru, pilnowanie ciągłości numeracji |  |  |  |
Rozliczanie płatności za faktury zakupu | + | + | + | +
dowolna liczba rat |  |  |  |
różne formy płatności (gotówka, przelew, czek, karta kredytowa, pobranie pocztowe, kompensata lub dowolne inne) |  |  |  |
zestawienie wierzycieli |  |  |  |
szczegółowe zestawienie zobowiązań na dowolny dzień z podziałem na dni po terminie lub termin płatności |  |  |  |
Obsługa numerów seryjnych | + | + | + | +
przyjęcia oraz inne operacje magazynowe na konkretnych egzemplarzach danego asortymentu oznaczonych numerami seryjnymi |  |  |  |
Obsługa kontraktów | - | - | + | +
dokładne rozliczenie dostaw pochodzących z różnych PZ w ramach danego kontraktu (umowy, zlecenia, itp.) |  |  |  |
Współpraca z programem ELZAB kolektor CE | - | - | - | +
wysyłanie do kolektora bazy asortymentów wraz z kodami kreskowymi |  |  |  |
wydruk etykiet z kodem kreskowym |  |  |  |
pobieranie danych z kolektora zakończone wystawieniem odpowiednich dokumentów magazynowych |  |  |  |
Współpraca z programem INWENTARYZATOR Koncept-L dla kolektorów Argox PT-20 oraz Cipherlab 711, 800x, 8300 | - | - | - | +
wysyłanie do kolektora bazy asortymentów wraz z kodami kreskowymi |  |  |  |
wydruk etykiet z kodem kreskowym |  |  |  |
pobieranie danych z kolektora zakończone wystawieniem odpowiednich dokumentów magazynowych |  |  |  |
Rozliczanie kosztów transportu | - | - | + | +
określanie kosztów transportu związanych z danym PZ |  |  |  |
automatyczne obliczanie jednostkowych kosztów transportu poszczególnych pozycji z PZ |  |  |  |
Zlecenia transportowe | - | - | - | +
ewidencja i wydruk zleceń transportowych zawierających datę i miejsce załadunku i rozładunku oraz warunki płatności |  |  |  |
powiązanie zleceń transportowych z poszczególnymi dokumentami PZ |  |  |  |
Rejestr zakupów VAT | + | + | + | +
opcjonalnie wydruk rejestrów zakupu VAT dla poszczególnych oddziałów firmy |  |  |  |
Eksport danych do programów księgowych | + | + | + | +
eksport faktur zakupu umożliwiający ich automatyczne zaksięgowanie w programie R2księga (księga przychodów i rozchodów) lub R2fk (system finansowo księgowy) |  |  |  |


SPRZEDAŻ

WSTĘP - Specyfikacja
Funkcjonalność | Wersja MINI | Wersja STANDARD | Wersja MAXI | Wersja PRO
Faktury VAT i inne dokumenty sprzedaży |  |  |  |
wystawianie, drukowanie i ewidencjonowanie faktur VAT, faktur proforma, paragonów i rachunków | + | + | + | +
szybkie wystawianie faktury bez pomocy myszki (tylko z klawiatury) | + | + | + | +
wyszukiwanie asortymentów w bibliotece wg nazwy bądź indeksu (kodu kreskowego) | + | + | + | +
przeliczanie kwot netto-brutto opcjonalnie wg netto lub brutto, ustawiane niezależnie dla każdej zdefiniowanej numeracji faktur | + | + | + | +
wybór rodzaju ceny (cena 1,2 lub 3-cia - określone w bibliotece asortymentów), wg którego będzie wystawiana bieżąca faktura | + | + | + | +
możliwość udzielenia rabatu oddzielnie na poszczególnych pozycjach faktury i dodatkowo zbiorczego rabatu dotyczącego całej faktury | + | + | + | +
możliwość wydrukowania na fakturze trzech uwag (z biblioteki lub wpisanych ręcznie) | + | + | + | +
możliwość wprowadzenia notatek, niedrukowanych na fakturze | + | + | + | +
osoba wystawiająca i odbierająca fakturę | + | + | + | +
przy pełnej księgowości - możliwość określenia konta księgowego na którym będzie księgowana sprzedaż, konto można określić dla każdej pozycji z osobna lub dla całej faktury | + | + | + | +
możliwość wyboru rachunku bankowego na jaki ma być dokonana zapłata za fakturę | + | + | + | +
automatyczne powiązanie faktur z dokumentami WZ, bieżąca informacja o wartości sprzedaży w cenach nabycia, zysku i uzyskanej marży | + | + | + | +
seryjny wydruk faktur (podświetlonych, wszystkich z wybranego okresu itp.) | - | + | + | +
możliwość określania złotówkowej ceny sprzedaży na podstawie ceny walutowej i kursu | - | - | + | +
Faktury korygujące | + | + | + | +
dowolna liczba faktur korygujących do jednego dokumentu sprzedaży |  |  |  |
Faktury eksportowe w walutach obcych lub w PLN | - | - | + | +
biblioteka walut i kursów średnich NBP |  |  |  |
automatyczne pobieranie kursów ze strony internetowej NBP |  |  |  |
wybór rodzaju transakcji: wewnątrzwspólnotowa dostawa towarów, eksport towarów, eksport usług |  |  |  |
automatyczne tłumaczenie faktury na język angielski lub niemiecki, a po przygotowaniu własnego tłumaczenia na dowolny inny |  |  |  |
płatności w walucie przeliczane na PLN wg kursu z dnia zapłaty |  |  |  |
automatyczne obliczanie różnic kursowych |  |  |  |
Faktury krajowe w walutach obcych | - | - | + | +
opcjonalnie netto w walucie a VAT w PLN lub cała kwota brutto w walucie |  |  |  |
możliwość określania złotówkowej ceny sprzedaży na podstawie ceny walutowej i kursu |  |  |  |
waluty, kursy, tłumaczenia, płatności w walucie, różnice kursowe analogicznie jak wyżej w fakturach eksportowych |  |  |  |
Faktury uproszczone | + | + | + | +
wystawianie, drukowanie i ewidencjonowanie faktur VAT do 450 zł brutto lub 100 EURO bez pełnych danych nabywcy |  |  |  |
E-faktury | - | - | + | +
cyfrowe podpisywanie faktur w formacie PDF |  |  |  |
wysyłanie e-mailem podpisanych e-faktur |  |  |  |
ewidencjonowanie kopii wystawionych e-faktur |  |  |  |
operacje na pojedyńczych fakturach oraz seryjnie na wielu fakturach |  |  |  |
drukowanie i wysyłanie e-mailem formularza zgody |  |  |  |
Faktury zaliczkowe | - | - | + | +
zamówienia od odbiorców |  |  |  |
dowolna ilość faktur zaliczkowych do jednego zamówienia |  |  |  |
faktura końcowa z pełnym rozliczeniem zamówienia |  |  |  |
Faktury powtarzalne | - | + | + | +
automatyczne wystawianie powtarzających się co miesiąc faktur |  |  |  |
określenie daty początkowej i końcowej oraz częstotliwości wystawiania (miesiąc, tydzień) |  |  |  |
automatyczne pomijanie dni wolnych i świąt |  |  |  |
seryjny wydruk wystawionych faktur |  |  |  |
Faktury (rachunki) do transakcji, dla których nabywca jest podatnikiem | - | + | + | +
automatyczna adnotacja na fakturze "odwrotne obciążenie" |  |  |  |
Faktury związane z obrotem wyrobami węglowymi objętymi akcyzą | - | - | + | +
wystawianie, drukowanie i ewidencjonowanie faktur na wyroby węglowe dla podmiotów zwolnionych z akcyzy oraz nieposiadających zwolnienia |  |  |  |
wydruk dokumentów dostawy wyrobów węglowych DWW |  |  |  |
wydruk deklaracji AKC-WW |  |  |  |
Faktury związane z obrotem towarami, w których cenę wliczono koszt gospodarowania odpadami | + | + | + | +
wystawianie, drukowanie i ewidencjonowanie faktur za towary, w cenę których wliczono KGO |  |  |  |
automatyczna adnotacja na wydruku faktury o jednostkowym koszcie gospodarowania odpadami zawartym w cenie asortymentu |  |  |  |
Przystosowanie dokumentów do własnych potrzeb |  |  |  |
możliwość umieszczenia na dokumentach elementów graficznych (logo firmy) | + | + | + | +
możliwość zdefiniowania wielu niezależnych numeracji (serii) faktur, np. osobne numeracje dla każdego sprzedawcy lub przedstawiciela handlowego | - | + | + | +
możliwość zdefiniowania dowolnych dokumentów (np. Zamówienie) i określania ich zawartości | - | + | + | +
możliwość pełnego dostosowania wyglądu wszystkich wydruków | - | + | + | +
możliwość określenia specjalnych wzorów faktur dla poszczególnych kontrahentów | - | - | + | +
współdzielenie jednej definicji dokumentu przez wielu użytkowników lub w przypadku RW I WZ przez wiele magazynów | - | - | - | +
Dane dedykowane | - | - | + | +
dla każdego kontrahenta można sporządzić niezależny cennik sprzedaży obejmujący wszystkie bądź tylko wybrane asortymenty z listy asortymentów lub rabaty na wybrane grupy asortymentowe oraz zdefiniować pięć dodatkowych cech, np. nazwa asortymentu, jaką posługuje się dany kontrahent, indeks, jednostka miary itp. |  |  |  |
Automatyczna faktura do paragonu |  |  |  |
jedna faktura do jednego wystawionego wcześniej paragonu | + | + | + | +
jedna faktura do jednego lub kilku wybranych wystawionych wcześniej paragonów | - | - | + | +
Automatyczna faktura do WZ |  |  |  |
jedna faktura do jednego wystawionego wcześniej WZ | + | + | + | +
jedna faktura do jednego lub kilku wybranych wystawionych wcześniej WZ | - | - | + | +
Refakturowanie opłat (np. za energię elektryczną) | + | + | + | +
ceny sprzedaży z dokładnością do 4 cyfr po przecinku |  |  |  |
Szczególne ułatwienia przy fakturowaniu usług | + | + | + | +
opis usługi może mieć dowolną długość |  |  |  |
powtarzającą się część opisu można wybierać z biblioteki asortymentów, a zmienną wpisywać bezpośrednio na fakturze |  |  |  |
w przypadku fakturowania niepowtarzających się usług, możliwość wprowadzenia opisu usługi bezpośrednio na pozycji faktury, bez konieczności korzystania z biblioteki asortymentów |  |  |  |
Różne sposoby numerowania dokumentów | + | + | + | +
numerowanie roczne lub miesięczne, dowolny układ numeru, pilnowanie ciągłości numeracji |  |  |  |
Rozliczanie płatności za faktury sprzedaży | + | + | + | +
dowolna liczba rat |  |  |  |
różne formy płatności (gotówka, przelew, czek, karta kredytowa, pobranie pocztowe, kompensata lub dowolne inne) |  |  |  |
zestawienie dłużników |  |  |  |
szczegółowe zestawienie należności na dowolny dzień z podziałem na dni po terminie lub termin płatności |  |  |  |
Obsługa numerów seryjnych | + | + | + | +
możliwość wyszczególnienia numeru seryjnego przy każdej pozycji faktury |  |  |  |
Rozliczanie przedstawicieli handlowych | - | - | + | +
biblioteka opiekunów klienta (przedstawicieli handlowych) |  |  |  |
przypisanie kontrahentów do opiekunów |  |  |  |
przypisanie poszczególnych faktur do opiekunów |  |  |  |
zestawienie faktur wystawionych w danym okresie powiązanych z poszczególnymi opiekunami (przedstawicielami handlowymi) |  |  |  |
Współpraca ze skanerem kodów kreskowych | + | + | + | +
Obsługa drukarek fiskalnych (Posnet, Elzab i kompatybilne) oraz kas fiskalnych (Posnet Neo i kompatybilne) | + | + | + | +
ewidencja wszystkich urządzeń fiskalnych użytkowanych w firmie |  |  |  |
zestawienia paragonów wydrukowanych na poszczególnych drukarkach fiskalnych |  |  |  |
Rejestr sprzedaży VAT | + | + | + | +
sumaryczna dzienna sprzedaż na paragony jako jedna pozycja na wydruku rejestru |  |  |  |
opcjonalnie wydruk rejestrów sprzedaży VAT dla poszczególnych oddziałów firmy |  |  |  |
Eksport danych do programów księgowych | + | + | + | +
eksport faktur umożliwiający ich automatyczne zaksięgowanie w programie R2księga (księga przychodów i rozchodów) lub R2fk (system finansowo księgowy) |  |  |  |
Import faktur | - | - | - | +
import i eksport faktur umożliwiający ich automatyczne tworzenie w programie R2faktury |  |  |  |
Statystyka firmy | - | + | + | +
szybkie sprawdzenie aktualnych przychodów i zysku w poszczególnych miesiącach bieżącego roku oraz dla porównania w tych samych miesiącach roku poprzedniego |  |  |  |
wykresy porównujące sprzedaż z bieżącego roku z rokiem poprzednim |  |  |  |
szybki wgląd w sumaryczny stan należności i zobowiązań oraz aktualny stan kasy i rachunków bankowych |  |  |  |
szybkie sprawdzenie przychodów z wybranych grup lub kategorii asortymentowych |  |  |  |


KASA / BANK

WSTĘP - Specyfikacja
Funkcjonalność | Wersja MINI | Wersja STANDARD | Wersja MAXI | Wersja PRO
Raporty kasowe RK i bankowe | - | + | + | +
możliwość prowadzenia dowolnej liczby kas (osobna dla każdego kasjera) |  |  |  |
możliwość prowadzenia dowolnej liczby raportów bankowych (osobno dla każdego rachunku bankowego) |  |  |  |
osoba sporządzająca i sprawdzająca raport |  |  |  |
przy każdym raporcie drukowane uwagi oraz dowolne notatki |  |  |  |
kontrola rozłączności okresów obejmowanych przez kolejne raporty |  |  |  |
automatyczna numeracja raportów |  |  |  |
Wpłaty i wypłaty | - | + | + | +
dokumenty KP i KW na raportach kasowych i operacje "Przychód" "Rozchód" na raportach bankowych |  |  |  |
automatyczna numeracja KP i KW |  |  |  |
opis dokumentu wybierany z biblioteki lub wpisywany bezpośrednio |  |  |  |
dodatkowo dla każdej operacji uwagi oraz dowolne notatki |  |  |  |
automatyczne księgowanie wpłat i wypłat na podstawie rozrachunków z kontrahentem |  |  |  |
jeden dokument KP/KW może być powiązany z dowolną liczbą faktur kontrahenta (podobnie wpłata/wypłata na raporcie bankowym) |  |  |  |
KP do faktury lub faktur zapłaconych gotówką generowane są automatycznie (podobnie KW do gotówkowych PZ) |  |  |  |
automatyczne zbiorcze KP z dzienną sumą sprzedaży paragonowej |  |  |  |
łatwa identyfikacja wpłat bankowych na podstawie kwoty |  |  |  |
Możliwość prowadzenia kilku raportów kasowych w obrębie jednego dnia (dla kasjerów pracujących na zmiany) | - | - | + | +
Data i godzina płatności na raportach kasowych i bankowych | - | - | + | +
Raporty kasowe i bankowe w walutach obcych | - | - | + | +
płatności w walucie faktury przeliczane na PLN wg zadanego kursu |  |  |  |
płatności w EUR i innych walutach za faktury wystawione w PLN (krajowe i eksportowe) |  |  |  |
płatności w PLN za faktury walutowe |  |  |  |
Import płatności z systemów bankowości elektronicznej (m.in. BZWBK, Deutsche Bank, Idea Bank, mBank, Multibank, Pekao, PBSBank, Raiffeisen, VideoTEL) | - | + | + | +
Eksport danych do programów księgowych | - | + | + | +
eksport raportów kasowych i bankowych do programu R2księga (księga przychodów i rozchodów) lub R2fk (system finansowo księgowy) |  |  |  |


NALEŻNOŚCI I ZOBOWIĄZANIA

WSTĘP - Specyfikacja
Funkcjonalność | Wersja MINI | Wersja STANDARD | Wersja MAXI | Wersja PRO
Szybki dostęp do szczegółowej ewidencji rozrachunków z kontrahentem |  |  |  |
rozrachunki z kontrahentem | - | + | + | +
rozrachunki walutowe | - | - | + | +
Windykacja należności | - | + | + | +
indywidualne (do jednej faktury) lub globalne (do wszystkich przeterminowanych faktur) wystawianie przypomnień i wezwań do zapłaty wraz z ich seryjnym wydrukiem |  |  |  |
indywidualne lub globalne wystawianie not odsetkowych wraz z ich seryjnym wydrukiem |  |  |  |
protokoły nieściągalności należności |  |  |  |
Restrykcje w obrotach | + | + | + | +
ostrzeżenie przy wystawianiu faktur dla kontrahentów obsługiwanych warunkowo (m.in. z przekroczonym terminem płatności) |  |  |  |
zablokowanie wystawienia faktury dla kontrahenta nieobsługiwanego (m.in. wystawione i niezapłacone wezwanie do zapłaty) |  |  |  |
Zestawienie należności i zobowiązań na zadany dzień | + | + | + | +
Lista dłużników i wierzycieli | + | + | + | +
Kalkulator odsetkowy obliczający odsetki ustawowe i podatkowe | + | + | + | +


PRZELEWY BANKOWE

WSTĘP - Specyfikacja
Funkcjonalność | Wersja MINI | Wersja STANDARD | Wersja MAXI | Wersja PRO
Wydruk i ewidencjonowanie bankowych poleceń przelewów | + | + | + | +
uwzględnia trzy rodzaje druków przelewów: standardowy, przelew do ZUS i przelew do organu podatkowego |  |  |  |
wydruk polecenia przelewu na czystych kartkach z możliwością wydruku formularza w kolorze czerwonym lub czarnym |  |  |  |
nadruk treści przelewu na gotowych formularzach różnego typu |  |  |  |
wydruki zbiorówek i zbiorczego polecenia przelewów z dnia (pasek) |  |  |  |
możliwość samodzielnego wykonania dowolnego przelewu |  |  |  |
biblioteka odbiorców przelewów |  |  |  |
Automatyczne przelewy | + | + | + | +
automatyczne przelewy z płatnościami za faktury zakupowe generowane na podstawie PZ |  |  |  |
Współpraca z systemami bankowymi | - | + | + | +
przygotowany eksport przelewów do następujących systemów bankowych: BGŻ, Bank Spółdzielczy, Bank of America, BNP Paribas Bank, BSI VDB, BZWBK24, Citibank, DB-Direct, defCOM, e-Integrum, GBPZ, Getin Bank, Goniec, Heuthes-Baset, KB24, Minibank24, Multicash / Eliksir, Multicash INT (MT103), Netbank, Przelew KB, Sezam BPH, VideoTEL, Zorba PKO BP |  |  |  |
możliwość dostosowania programu do współpracy z dowolnym systemem bankowym |  |  |  |


CRM

WSTĘP - Specyfikacja
Funkcjonalność | Wersja MINI | Wersja STANDARD | Wersja MAXI | Wersja PRO
Ewidencja kontaktów z kontrahentem | - | - | + | +
szczegółowe notatki z przeprowadzonych rozmów, spotkań, wysłanych ofert itp. |  |  |  |
zadania do wykonania w przyszłości przez zadaną osobę w zadanym czasie wraz ze szczegółowym opisem |  |  |  |
zadania do wykonania w danym dniu przez danego użytkownika pokazywane automatycznie po otwarciu programu |  |  |  |
Sprawy serwisowe - wspomaganie pracy działu serwisu | - | - | - | +
tworzenie zleceń serwisowych |  |  |  |
protokoły otwarcia usługi serwisowej (przyjęcia zlecenia) |  |  |  |
ewidencjonowanie kontaktów (telefonów, spotkań) związanych z daną sprawą |  |  |  |
ustalanie zadań do wykonania w związku z daną sprawą serwisową |  |  |  |
zamykanie spraw serwisowych, protokoły wykonania usługi |  |  |  |
szybki dostęp do wszystkich aktywnych spraw serwisowych wraz z ich aktualnym stanem oraz historią kontaktów |  |  |  |
Kontrakty (leady) sprzedażowe - wspomaganie pracy działu sprzedaży | - | - | - | +
tworzenie kontraktów sprzedażowych wraz ze szczegółową informacją o asortymentach, którymi jest zainteresowany klient |  |  |  |
ewidencjonowanie kontaktów (telefonów, spotkań, ofert) związanych z kontraktem |  |  |  |
ustalanie zadań związanych z kontraktem |  |  |  |
szybki dostęp do wszystkich aktywnych kontraktów wraz z ich aktualnym poziomem oraz historią kontaktów |  |  |  |
Kampanie sprzedażowe | - | - | - | +
szczegółowe dane kampanii sprzedażowych (reklamowych) wraz z ich kosztem |  |  |  |
rozliczanie przychodów ze wszystkich przychodów związanych z daną kampanią (koszt, przychody, zysk, sumaryczna ilość kontraktów z podziałem na statusy oraz średni czas trwania kontraktu zakończonego sukcesem) |  |  |  |


KONTRAHENCI

WSTĘP - Specyfikacja
Funkcjonalność | Wersja MINI | Wersja STANDARD | Wersja MAXI | Wersja PRO
Pełny zestaw danych o kontrahencie |  |  |  |
dane kontaktowe: telefony, fax, e-mail, www | + | + | + | +
rachunek bankowy (do przelewów) | + | + | + | +
warunki współpracy: forma i termin płatności, stały rabat, zgoda na e-faktury | + | + | + | +
dodatkowe dane: adres do korespondencji, uwagi, dane rolnika ryczałtowego | + | + | + | +
podział na grupy i województwa | + | + | + | +
powiązanie z opiekunem klienta (przedstawicielem handlowym) | - | - | + | +
informacje o nałożonych restrykcjach w związku z przeterminowanymi płatnościami | + | + | + | +
przy pełnej księgowości możliwość określenia kont przydatnych do księgowania dokumentów w systemie finansowo-księgowym R2fk: konto rozrachunkowe dostawcy, konto rozrachunkowe odbiorcy, domyślne konto sprzedaży, domyślne konto zakupu | + | + | + | +
Dane dedykowane | - | - | + | +
dla każdego kontrahenta można sporządzić niezależny cennik sprzedaży obejmujący wszystkie bądź tylko wybrane asortymenty z listy asortymentów lub rabaty na wybrane grupy asortymentowe oraz zdefiniować pięć dodatkowych cech, np. nazwa asortymentu, jaką posługuje się dany kontrahent, indeks, jednostka miary itp. |  |  |  |
Szybki dostęp do szczegółowych zestawień |  |  |  |
obroty - pozycje asortymentowe zakupione przez tego (lub od tego) kontrahenta | + | + | + | +
rozrachunki - faktury wystawione temu kontrahentowi (lub przez tego kontrahenta) i płatności za nie | - | + | + | +
windykacja - wystawione temu kontrahentowi przypomnienia, wezwania do zapłaty oraz noty odsetkowe | - | + | + | +


ASORTYMENTY

WSTĘP - Specyfikacja
Funkcjonalność | Wersja MINI | Wersja STANDARD | Wersja MAXI | Wersja PRO
Pełny zestaw danych o asortymencie | + | + | + | +
nazwa skrócona, nazwa opisowa (dowolnej długości), indeks, waga jednostkowa |  |  |  |
domyślna ilość podstawiana na fakturze przy sprzedaży tego asortymentu |  |  |  |
adres strony www z opisem asortymentu |  |  |  |
Trzy różne ceny sprzedaży z dokładnością do 2 lub 4 miejsc po przecinku | + | + | + | +
Określanie cen sprzedaży na podstawie marży w stosunku do ceny nabycia lub ceny ewidencyjnej | + | + | + | +
automatyczna zmiana cen sprzedaży po zmianie ceny nabycia przy kolejnych PZ |  |  |  |
Określanie cen sprzedaży w walucie obcej | - | - | + | +
globalne przeliczanie cen sprzedaży po zmianie kursu waluty |  |  |  |
Dane dedykowane | - | - | + | +
dla każdego kontrahenta można sporządzić niezależny cennik sprzedaży obejmujący wszystkie bądź tylko wybrane asortymenty z listy asortymentów lub rabaty na wybrane grupy asortymentowe oraz zdefiniować pięć dodatkowych cech, np. nazwa asortymentu, jaką posługuje się dany kontrahent, indeks, jednostka miary itp. |  |  |  |
Grupy i kategorie asortymentowe przydatne do zestawień | + | + | + | +


DODATKOWE MOŻLIWOŚCI

WSTĘP - Specyfikacja
Funkcjonalność | Wersja MINI | Wersja STANDARD | Wersja MAXI | Wersja PRO
Dokumenty, zestawienia, raporty |  |  |  |
zestaw gotowych dokumentów, zestawień i raportów | + | + | + | +
modyfikacja istniejących oraz tworzenie własnych zestawień | - | + | + | +
tworzenie dowolnych własnych dokumentów np. Zamówienie do dostawcy, PW | - | + | + | +
pełne dostosowanie do własnych potrzeb wyglądu wszystkich dokumentów oraz większości zestawień | - | + | + | +
możliwość edycji na podglądzie wydruku pojedynczych słów | + | + | + | +
wysyłanie wydruków e-mailem w formacie HTML lub PDF (zwykły albo podpisany cyfrowo) za pośrednictwem serwera Reset2 lub domyślnego programu pocztowego | - | + | + | +
eksport zawartości okien (w całości lub wybranych pozycji) do Microsoft Excel | - | + | + | +
eksport zestawień do Microsoft Excel | - | + | + | +
specjalne wzory wydruku dla poszczególnych dokumentów | - | - | + | +
specjalne wzory dokumentów (faktura, wz, ...) dla poszczególnych kontrahentów | - | - | + | +
wydruki niektórych dokumentów na drukarkach igłowych (faktura, paragon, wz, pz, mm) | - | - | + | +
możliwość zablokowania wybranym użytkownikom dostępu do cen nabycia | - | - | + | +
współdzielenie jednej definicji dokumentu przez wielu użytkowników lub wiele magazynów | - | - | - | +
możliwość zapisania w bazie danych lub na dysku sieciowym skanów dokumentów związanych z daną pozycją, np. umów podpisanych z poszczególnymi kontrahentami | - | - | - | +
Wersja sieciowa | + | + | + | +
możliwość pracy w dowolnej sieci w środowisku Windows XP, Vista, 7, 8 |  |  |  |
możliwość nadania haseł i uprawnień poszczególnym użytkownikom |  |  |  |
kontrola wprowadzania i poprawiania danych przez różnych użytkowników |  |  |  |
Przydatne funkcje |  |  |  |
archiwizacja danych z możliwością wprowadzenia hasła | + | + | + | +
możliwość inicjalizacji bazy danych na podstawie pliku buforowego oraz programu Subiekt firmy Insert | + | + | + | +
możliwość bezpośredniej aktualizacji programu przez internet zapewniająca posiadanie zawsze aktualnej wersji zgodnej ze zmieniającymi się przepisami | + | + | + | +
pobieranie aktualnej tabeli odsetek ze strony internetowej producenta | + | + | + | +
możliwość zapoznania się bezpośrednio z poziomu programu z komunikatami serwisowymi, redagowanymi przez serwis producenta, mającymi na celu odpowiedzi na najczęściej zadawane pytania przez klientów | + | + | + | +
w przypadku awarii możliwość bezpośredniego serwisowania programu lub danych przez internet - krótki czas reakcji i minimalne koszty | + | + | + | +
możliwość konsolidacji baz danych, czyli łączenia baz danych, np. połączenia w jeden program wielofirmowy kilku baz danych prowadzonych w programach jednofirmowych | - | + | + | +


MODUŁ WWW

WSTĘP - Specyfikacja
Funkcjonalność | Wersja MINI | Wersja STANDARD | Wersja MAXI | Wersja PRO
Dostęp do funkcjonalności systemu R2faktury poprzez przeglądarkę internetową na dowolnym komputerze/tablecie/smartfonie z dowolnego miejsca na świecie | - | - | + | +
Przeglądanie danych w systemie oraz generowanie wydruków | - | - | + | +
Edycja oraz wprowadzanie danych do systemu | - | - | - | +


PORÓWNANIE WERSJI

WSTĘP - Specyfikacja

Program [image] występuje w kilku wersjach różniących się funkcjonalnością:

  • MINI - najprostsza wersja programu z ograniczonym dostępem do niektórych, rzadziej używanych funkcji. Umożliwia szybkie wystawienie faktur i innych najczęściej używanych dokumentów oraz sporządzenie podstawowych zestawień.

  • STANDARD - pełna wersja programu z dostępem do większości modułów i funkcji programu. Umożliwia dokładne przystosowanie programu do własnych potrzeb (rodzaje i wygląd dokumentów, zestawienia).

  • MAXI - pełna wersja wzbogacona o obsługę transakcji zagranicznych i kilka funkcji przydatnych w większych firmach lub przy większej liczbie dokumentów.

Program [image] oferuje funkcjonalność wersji MAXI wzbogaconą o wiele udogodnień istotnych dla dużych firm.

Poniżej przedstawiamy zestawienie RÓŻNIC pomiędzy wersjami MINI, STANDARD, MAXI i PRO.

Funkcjonalność | Wersja MINI | Wersja STANDARD | Wersja MAXI | Wersja PRO
INSTALACJA I PARAMERYZACJA
szczegółowe prawa dostępu do wybranych ustawień, raportów oraz zestawień | - | - | - | +
własne nazwy etykiet w oknach | - | - | - | +
dodatkowe pola ewidencjonowane w bazie danych | - | - | - | +
dodatkowe tabele w bazie danych umożliwiające prowadzenie własnych bibliotek i ewidencji | - | - | - | +
harmonogram zadań umożliwiający zaplanowanie dłuższych operacji oraz periodycznie wykonywanych funkcji (np. archiwizacja) | - | - | - | +
wykorzystanie możliwości architektury bazy danych typu klient-serwer | - | - | - | +
optymalizacja pod kątem pobierania tylko niezbędnych w danej chwili danych przyspieszająca pracę sieciową | - | - | - | +
wykorzystanie dodatkowych możliwości serwera SQL (np. procedury składowane) przyspieszających pracę stacji roboczych | - | - | - | +
trójwarstwowa architektura systemu umożliwiająca zdalną pracę w sieci rozległej (np. oddziały w różnych miastach) poprzez dostęp do serwera aplikacji, a nie serwera bazy danych | - | - | - | +
narzędzia (biblioteka API) umożliwiające innym aplikacjom dostęp do bazy danych programu | - | - | - | +
MAGAZYN
przyjęcia do magazynu na podstawie faktur RR (od rolników ryczałtowych) | - | + | + | +
możliwość zdefiniowania dowolnych dokumentów (np. Zamówienie do dostawcy, PW) i określenia ich zawartości | - | + | + | +
możliwość pełnego dostosowania wyglądu wszystkich wydruków | - | + | + | +
możliwość określenia specjalnych wzorów PZ i WZ dla poszczególnych dokumentów | - | - | + | +
współdzielenie jednej definicji dokumentu przez wielu użytkowników lub wiele magazynów | - | - | - | +
rozchód wewnętrzny RW | - | - | + | +
zysk i marża mogą uwzględniać koszty transportu nie ujęte w cenie nabycia | - | - | + | +
możliwość zablokowania wybranym użytkownikom dostępu do cen nabycia | - | - | + | +
inwentaryzacja, protokoły rozbieżności PR+, PR- | - | - | + | +
obsługa kontraktów | - | - | + | +
rozliczanie kosztów transportu | - | - | + | +
współpraca z programem ELZAB kolektor CE | - | - | - | +
współpraca z programem INWENTARYZATOR Koncept-L dla kolektorów Argox PT-20 oraz Cipherlab 711, 800x, 8300 | - | - | - | +
zlecenia transportowe | - | - | - | +
SPRZEDAŻ
seryjny wydruk faktur (podświetlonych, wszystkich z wybranego okresu itp.) | - | + | + | +
walutowe ceny sprzedaży | - | - | + | +
faktury eksportowe w walutach obcych lub w PLN | - | - | + | +
faktury krajowe w walutach obcych | - | - | + | +
e-faktury | - | - | + | +
faktury zaliczkowe | - | - | + | +
faktury powtarzalne | - | + | + | +
faktury (rachunki) do transakcji, dla których nabywca jest podatnikiem | - | + | + | +
faktury związane z obrotem wyrobami węglowymi objętymi akcyzą | - | - | + | +
możliwość zdefiniowania wielu niezależnych numeracji (serii) faktur, np. osobne numeracje dla każdego sprzedawcy lub przedstawiciela handlowego | - | + | + | +
możliwość zdefiniowania dowolnych dokumentów (np. Zamówienie) i określenia ich zawartości | - | + | + | +
możliwość pełnego dostosowania wyglądu wszystkich wydruków | - | + | + | +
możliwość określenia specjalnych wzorów faktur dla poszczególnych kontrahentów | - | - | + | +
współdzielenie jednej definicji dokumentu przez wielu użytkowników lub w przypadku RW i WZ przez wiele magazynów | - | - | - | +
dane dedykowane | - | - | + | +
automatyczne faktury do jednego lub kilku wybranych wystawionych wcześniej paragonów | - | - | + | +
automatyczne faktury do jednego lub kilku wybranych wystawionych wcześniej WZ | - | - | + | +
rozliczanie przedstawicieli handlowych | - | - | + | +
import i eksport faktur umożliwiający ich automatyczne tworzenie w programie R2faktury | - | - | - | +
statystyka firmy | - | + | + | +
KASA / BANK
raporty kasowe RK i bankowe | - | + | + | +
wpłaty i wypłaty (KP, KW) | - | + | + | +
możliwość prowadzenia kilku raportów kasowych w obrębie jednego dnia (dla kasjerów pracujących na zmiany) | - | - | + | +
data i godzina płatności na raportach kasowych i bankowych | - | - | + | +
raporty kasowe i bankowe w walutach obcych | - | - | + | +
import płatności z systemów bankowości elektronicznej (m.in. BZWBK, Deutsche Bank, Idea Bank, mBank, Multibank, Pekao, PBSBank, Raiffeisen, VideoTEL) | - | + | + | +
eksport danych do programów księgowych | - | + | + | +
NALEŻNOŚCI I ZOBOWIĄZANIA
rozrachunki z kontrahentem | - | + | + | +
rozrachunki walutowe | - | - | + | +
windykacja należności | - | + | + | +
PRZELEWY BANKOWE
eksport do systemów bankowych | - | + | + | +
CRM
ewidencja kontaktów z kontrahentem | - | - | + | +
sprawy serwisowe - wspomaganie pracy działu serwisu | - | - | - | +
kontrakty (leady) sprzedażowe - wspomaganie pracy działu sprzedaży | - | - | - | +
kampanie sprzedażowe | - | - | - | +
KONTRAHENCI
powiązanie z opiekunem klienta (przedstawicielem handlowym) | - | - | + | +
dane dedykowane | - | - | + | +
ASORTYMENTY
określanie cen sprzedaży w walucie obcej | - | - | + | +
dane(ceny) dedykowane | - | - | + | +
DODATKOWE MOŻLIWOŚCI
modyfikacja istniejących oraz tworzenie własnych zestawień | - | + | + | +
tworzenie dowolnych własnych dokumentów np. Zamówienie do dostawcy, PW | - | + | + | +
pełne dostosowanie do własnych potrzeb wyglądu wszystkich dokumentów oraz większości zestawień | - | + | + | +
wysyłanie wydruków e-mailem w formacie HTML lub PDF (zwykły albo podpisany cyfrowo) za pośrednictwem serwera Reset2 lub domyślnego programu pocztowego | - | + | + | +
eksport zawartości okien (w całości lub wybranych pozycji) do Microsoft Excel | - | + | + | +
eksport zestawień do pliku w formacie dbf, txt lub csv (akceptowany przez Microsoft Excel) | - | + | + | +
specjalne wzory wydruku dla poszczególnych dokumentów | - | - | + | +
specjalne wzory dokumentów (faktura, wz, ...) dla poszczególnych kontrahentów | - | - | + | +
wydruki niektórych dokumentów na drukarkach igłowych (faktura, paragon, wz, pz, mm) | - | - | + | +
współdzielenie jednej definicji dokumentu przez wielu użytkowników lub wiele magazynów | - | - | - | +
możliwość zapisania w bazie danych lub na dysku sieciowym skanów dokumentów związanych z daną pozycją, np. umów podpisanych z poszczególnymi kontrahentami | - | - | - | +
możliwość konsolidacji baz danych, czyli łączenia baz danych, np. połączenia w jeden program wielofirmowy kilku baz danych prowadzonych w programach jednofirmowych | - | + | + | +
MODUŁ WWW
dostęp do funkcjonalności systemu R2faktury poprzez przeglądarkę internetową na dowolnym komputerze/tablecie/smartfonie z dowolnego miejsca na świecie | - | - | + | +
przeglądanie danych w systemie oraz generowanie wydruków | - | - | + | +
edycja oraz wprowadzanie danych do systemu | - | - | - | +


ROZPOCZĘCIE PRACY

INSTRUKCJA UŻYTKOWNIKA

Po uruchomieniu programu pokaże się okno główne, zawierające wszystkie narzędzia i funkcje dostępne w programie.

Wciskając F1 w dowolnym miejscu programu, możemy uzyskać pomoc kontekstową, dotyczącą aktualnego okna programu.

Przed rozpoczęciem normalnej pracy należy określić użytkowników, którzy będą korzystali z programu oraz wprowadzić dane naszej firmy.

Kolejny krok to wybór oraz wstępne skonfigurowanie odpowiednich modułów programu w zależności od posiadanej wersji programu.

Jeśli testujemy wersję demonstracyjną, powinniśmy ją odpowiednio skonfigurować, tak aby pracować na wersji programu zapewniającej potrzebną nam funkcjonalność.


Okno główne

ROZPOCZĘCIE PRACY

Okno główne programu, zawiera najważniejsze narzędzia potrzebne do pracy.

Na górnym pasku obok nazwy programu odczytać możemy numer wersji. Poniżej menu główne (Zbiory, Okna, Raporty, ...) zawierające wszystkie podstawowe funkcje systemu.

Pod menu głównym zestawy narzędzi, umożliwiające:

  • wybór jednego z podstawowych okien systemu, dotyczących wybranej firmy:

    • PZ - przyjęcia do magazynu

    • Faktury, WZ - sprzedaż i wydania z magazynu

    • MM - przesunięcia międzymagazynowe

    • kasa/bank - raporty kasowe i bankowe

    • windykacja należności

    • przelewy bankowe

    • lista kontrahentów

    • lista asortymentów

    • stan magazynu

    • okna dotyczące modułu CRM, widoczne w głównym oknie dopiero po włączeniu - patrz Konfiguracja okna głównego

      • kontakty

      • kontrakty sprzedażowe lub sprawy serwisowe

      • kampanie sprzedażowe

  • - wybór aktualnej firmy z możliwością wywołania listy obsługiwanych firm

  • - wybór użytkownika z możliwością wywołania biblioteki użytkowników.

W dolnej części okna znajdziemy:

  • numer seryjny programu

  • właściciela programu o tym numerze seryjnym

  • aktualny okres

  • datę bieżącą.

Wygląd okna głównego programu możemy dostosować do własnych preferencji (patrz Konfiguracja okna głównego).

Do menu głównego możemy przejść klikając myszką w odpowiedniej pozycji menu. Możemy również wcisnąć klawisz F10 lub lewy Alt, a następnie klawiszami strzałek (lub naciskając podkreśloną literę) wybrać odpowiednią pozycję.

Żeby zakończyć pracę, należy w pozycji menu głównego Zbiory wybrać funkcję Zamknij lub wcisnąć Alt F4 w oknie głównym.

Przejść do innych aplikacji (bez wychodzenia z programu) możemy używając klawiszy Alt Tab. Musimy jednak pamiętać, że program cały czas pozostanie otwarty.

W pozycji menu Pomoc - Szybki start możemy wywołać skróconą instrukcję obsługi umożliwiającą szybkie rozpoczęcie pracy z programem.

W pozycji menu Pomoc - Instrukcja obsługi możemy wywołać pełną instrukcję obsługi.

W pozycji menu Pomoc - Instrukcja obsługi do wydrukowania możemy wywołać pełną instrukcję obsługi w formacie PDF. Opcja ta umożliwia łatwy wydruk całej instrukcji na drukarce. Można z niej skorzystać jeśli zakupiliśmy program bez drukowanej instrukcji obsługi.

Korzystając z opcji Pomoc - Komunikaty serwisu możemy przejrzeć komunikaty redagowane przez seriws producenta, mające na celu odpowiedzi na najczęściej zadawane pytania przez klientów.

Korzystając z opcji Pomoc - Zdalny serwis możemy w łatwy sposób udostępnić pulpit swojego komputera serwisantowi Reset2 w celu szybkiego rozwiązania problemu.

W kolejnych rozdziałach dowiemy się o ogólnych zasadach pracy z programem, funkcjach dostępnych w każdym oknie oraz o tym co można zrobić z każdym przygotowanym wydrukiem. Możemy te rozdziały przejrzeć teraz lub później, jeśli będziemy chcieli usystematyzować sobie wiedzę o zasadach obsługi programu.


Konfiguracja okna głównego

ROZPOCZĘCIE PRACY - Okno główne

Każdy [image] użytkownik może dostosować układ głównego okna programu w zakresie:

  • zmiany położenia każdego z pasków narzędzi (zestawu przycisków) z możliwością wyciągnięcia dowolnego zestawu na zewnątrz okna - przeciągając myszą początek każdego zestawu

  • uwidocznienia poszczególnych pasków narzędzi - prawy klawisz myszy

  • wyłączenia lub zmiany tła w programie - patrz niżej: Ustawienia tła.

Klikając prawym klawiszem myszy na dowolnym przycisku okna głównego uzyskujemy dostęp do włączenia lub wyłączenia dowolnego paska z przyciskami oraz tła.
UWAGA. Jeśli przypadkowo wyłączymy pewne paski narzędzi to najprostszą formą powrotu do ustawień oryginalnych jest skorzystanie z funkcji Przywróć wszystkie paski.

Ustawienia tła

Tło jest bardzo ważnym elementem, gdyż powoduje, że użytkownik widzi na pulpicie tylko okna uruchomionego systemu. Zaawansowany użytkownik, który pracuje na kilku aplikacjach jednocześnie może zrezygnować z tła. Wtedy będzie miał dostęp do wszystkich ikonek pulpitu i okiem innych programów.

Klikając prawym klawiszem myszy w dowolnym miejscu tła programu możemy je wyłączyć (Tło) lub zmienić Ustawienia tła, tzn. możemy ustalić własny obrazek tła (Zmień tło), przywrócić tło standardowe (Standardowe) lub uczynić tło półprzeźroczystym (Kontrast).
UWAGA. Dostęp do ustawień tła jest możliwy tylko wtedy, gdy tło jest włączone. Jeśli tło jest wyłączone to musimy je najpierw włączyć, klikając prawym klawiszem w obszarze okna głównego i wybierając z menu pozycję Tło.


Ogólne zasady pracy

ROZPOCZĘCIE PRACY - Okno główne

Wszystkie ewidencje i biblioteki prowadzone przez program (faktury, kontrahenci, asortymenty i inne) związane są z oddzielnymi oknami. Obsługa okien (większość przycisków i klawiszy) jest taka sama niezależnie od tego jaką ewidencję takie okno zawiera.

Okna dzielą się na dwa rodzaje: proste i złożone.

Okno proste składa się z paska narzędziowego udostępniającego najważniejsze funkcje (na górze) oraz listy pozycji (poniżej). Okna proste to np. grupy, banki.

Lista pozycji (rekordów) ma formę tabeli. W wierszach tabeli znajdują się kolejne pozycje (np. banki), a w kolumnach wielkości opisujące pozycje (w przypadku banków - nazwa banku i numer oddziału).

W oknach złożonych prowadzone są ewidencje wymagające określenia dla każdej pozycji wielu wartości.

Dlatego okno złożone zawiera dodatkowo zakładki Lista, Pozycja i Razem (w górnej części okna). Kliknięcie w zakładki lub naciśnięcie klawiszy Ctrl Tab przełącza okno na strony Lista, Pozycja i Razem. Zakładka Pozycja umożliwia wprowadzanie i modyfikacje pozycji z listy. Na zakładce Razem można równocześnie oglądać listę z pozycjami oraz poszczególne pola aktualnie wybranej pozycji.

Oknami złożonymi są np. okna z fakturami, kontrahentami, asortymentami itp.

Górna część okna wypełniona jest przyciskami, pozwalającymi wywoływać funkcje dostępne w każdym oknie.
UWAGA. Jeśli przyciski z funkcjami są niewidoczne to można je włączyć wciskając [image] Ctrl F4 i wyłączając opcję Ukryj pasek narzędzi lub szybko funkcją Ctrl F9.


Funkcje dostępne w każdym oknie

ROZPOCZĘCIE PRACY - Okno główne

Działanie i wywoływanie podstawowych funkcji jest podobne w większości okien programu:

  • F1 - wywołanie pomocy kontekstowej związanej z danym oknem

  • F12 - określenie daty bieżącej, daty zamknięcia oraz okresu pracy, czyli przeglądania, wprowadzania i drukowania danych

  • F3 - lista wszystkich funkcji związanych z danym oknem, dostępna również po kliknięciu prawym klawiszem myszy w oknie

  • F5 - powiększenie okna na cały ekran, ponowne naciśnięcie przywraca pierwotny rozmiar

  • Ins, F7 - wprowadzanie nowej pozycji (np. nowa faktura, nowy kontrahent)

  • F6, Enter - modyfikowanie pozycji

  • Del, F8 - usuwanie pozycji

  • Ctrl Ins - kopiowanie pozycji do bufora

  • Ctrl C - kopiuje podświetlone pozycje (jeśli takie są), lub wszystkie pozycje (jeśli nic nie jest podświetlone) do schowka w formacie Microsoft Excel. Można później poleceniem Ctrl-V wstawić zawartość schowka do dowolnego arkusza Excel'a.

  • Shift Ins - utworzenie nowej pozycji na bazie pozycji wpisanej wcześniej do bufora

  • Ctrl F5 - odświeżanie zawartości okna przydatne przy pracy sieciowej

  • F2 - wydruki związane z danym oknem (np. wydruk faktury, rejestru VAT)
    Dodatkowo w każdym oknie mamy możliwość wydruku zestawień dotyczących danego okna (patrz ZESTAWIENIA I STATYSTYKI - Zestawienia) oraz wydruków systemowych:

    • Wydruk listy - lista wszystkich pozycji uwidocznionych w oknie, przed wydrukiem możemy wybrać [image] kolumny, które chcemy uwidocznić

    • Wydruk pozycji - wydruk okna w takiej formie, jak widzimy na ekranie, jeśli przejdziemy na zakładkę Pozycja

  • Ctrl F7, Ctrl F - wyszukiwanie pozycji w oknie, dostępne również po bezpośrednim rozpoczęciu pisania na zakładce Lista, Ctrl L wyszukuje następną pozycję - patrz podrozdział Wyszukiwanie.

  • F4 - właściwości, czyli uporządkowanie i zakres widocznych danych, szybkie przełączanie niektórych zakresów umożliwia Shift F4 (np. kontrahentów i asortymentów stałych)

  • +/- z klawiatury numerycznej - wybór (podświetlenie) pozycji o zadanych kryteriach

  • Ctrl Enter - podsumowanie kolumn na zakładce Lista

  • Ctrl F4 - wybór kolumn widocznych w oknie, określenie właściwości tych kolumn (szerokość, nazwa, czcionka, kolor itp.) oraz ustalenie rozmiaru i położenia całego okna - patrz podrozdział Kolumny okna.

  • Podświetlenia - praca na wybranych (podświetlonych) pozycjach

    • Ctrl + – pokazuje tylko podświetlone pozycje

    • Ctrl - – pokazuje wszystkie pozycje

    • Ctrl A – podświetla wszystkie pozycje

    • Ctrl N – odświetla wszystkie pozycje

    • Ctrl R – zmienia podświetlenie wszystkich pozycji

    • Ctrl D - usuwa wszystkie podświetlone pozycje

    • Zapisz bieżące podświetlenia - zapamiętuje aktualny zestaw podświetleń

    • Odczytaj podświetlenia z definicji - przywraca zapamiętany wcześniej zestaw podświetleń

    UWAGA. Dowolne pojedyncze pozycje możemy podświetlić ręcznie wciskając klawisze Shift áâ na wybranej pozycji.

  • Export danych - eksport zawartości okna w wybranych formatach

  • Konfiguruj dokumenty załączane - lista rodzajów dokumentów załączanych do poszczególnych wpisów w oknie (patrz Załączane dokumenty).

W każdym oknie dostępne są również dodatkowe funkcje właściwe dla danego okna (np. w fakturach eksport faktur do programu księgowego).

Jeśli okno jest wywoływane z innego okna, na przykład kontrahenci z faktury, dodatkowo w górnym prawym rogu okna (np. kontrahenci) umieszczony jest przycisk [image], który po ustawieniu się na właściwym wpisie przypisze ten wpis (kontrahenta) do okna głównego (faktury). Szybki wybór umożliwia kombinacja klawiszy Alt Enter lub po prostu Enter.


Kolumny okna

ROZPOCZĘCIE PRACY - Okno główne - Funkcje dostępne w każdym oknie

Po naciśnięciu w każdym oknie z danymi przycisku [image] lub klawiszy Ctrl F4 pojawi się okienko Kolumny okna umożliwiające określenie zestawu i właściwości poszczególnych kolumn widocznych w oknie, a także położenia i rozmiaru całego okna.

Możemy określić:

  • Kolumny - wybieramy kolumny widoczne w oknie

    • Dostępne - lista wszystkich kolumn dostępnych w bieżącym oknie. Naciskając klawisz Ins lub klikając w przycisk Dodaj > przenosimy podświetloną kolumnę na koniec znajdującej się obok listy Aktywne. Przyciskiem Wszystkie >> możemy od razu przenieść wszystkie dostępne kolumny. Na uwagę zasługują kolumny:

      • Lp - liczba porządkowa pozycji w oknie, zawsze rozpoczyna się od 1 niezależnie od ustawienia kolejności wpisów

      • Ide - unikalny identyfikator pozycji, oznacza kolejność wprowadzania wpisów do bazy

      • Kol - numer pozycji w oknie wg własnego ułożenia, zmienia się automatycznie przy przeciąganiu pozycji; przeciąganie pozycji możliwe jest tylko wtedy, gdy [image] uporządkowanie (F4) ustawione jest na własne ułożenie (Kol) i nie jest dostępne we wszystkich oknach

    • Aktywne - lista aktywnych, tzn. widocznych, kolumn okna. Klawiszem Del lub przyciskiem < Skasuj możemy usunąć podświetloną kolumnę. Naciskając klawisze Shift áâ lub klikając w przyciski z niebieskimi strzałkami możemy zmienić pozycję (wyżej/niżej) podświetlonej kolumny na liście aktywnych kolumn.

    • Kolumny i pola systemowe - większość dostępnych w danym oknie kolumn odpowiada informacjom wprowadzanym przez użytkownika w tym oknie. Część kolumn odpowiada natomiast polom systemowym, tzn. takim które nie są widoczne w trakcie wprowadzania danych i zawierają wewnętrzne informacje niezbędne do prawidłowej pracy programu. Zaznaczając pole Kolumny i pola systemowe spowodujemy dodanie wszystkich kolumn systemowych do listy dostępnych kolumn. Nazwy pól systemowych zaczynają się zawsze od znaku @. Z kolumn systemowych korzysta się zwykle tylko w celach serwisowych. Wyjątkami, zawierającymi bezpośrednio przydatne informacje, są kolumny:

      • @F7, @F7DataCzas - odpowiednio: nazwa użytkownika, który utworzył daną pozycję okna oraz data i czas jej utworzenia

      • @F6, @F6DataCzas - odpowiednio: nazwa użytkownika, który jako ostatni modyfikował daną pozycję okna oraz data i czas tej modyfikacji

  • Właściwości kolumny - ustalamy właściwości bieżącej kolumny (bieżącej tzn. wybranej na liście aktywnych kolumn)

    • Nazwa kolumny - możemy zmienić nazwę kolumny na inną bardziej dla nas zrozumiałą (lub przydatną)

    • Nazwa pola - rzeczywista (występująca w bazie danych) nazwa pola związanego z tą kolumną. Zdarza się że nazwa pola w bazie danych jest inna niż nazwa kolumny w oknie.
      Rzeczywista nazwa pola przydaje się we własnych zestawieniach SQL i w funkcjach API.

    • Szerokość - szerokość kolumny w pikselach. Szerokość kolumny możemy również ustawić bezpośrednio w oknie przesuwając w lewo lub prawo krawędź kolumny.

    • Kolor tła - możliwość zmiany tła kolumny ze standardowego białego koloru na dowolny inny

    • Czcionka - właściwości czcionki używanej w kolumnie: typ, styl, rozmiar, kolor, itp.. Standardowo jest używana czcionka "MS Sans Serif", styl regularny, rozmiar 8.

    • Położenie - sposób justyfikacji kolumny, tzn.
      "Lewo "
      " Prawo"
      " Środek "

    • Sumowanie - określenie czy dane z tej kolumny mają być sumowane, a jeśli tak to w jaki sposób, tzn.
      Suma - suma poszczególnych pozycji z danej kolumny
      Brak - brak sumowania
      Średnia - średnia kwota z poszczególnych pozycji (w przeliczeniu na liczbę pozycji w kolumnie)

  • Parametry okna - określenie położenia lewego górnego rogu okna (Lewa krawędź, Górna krawędź) oraz Szerokości i Wysokości okna. Lewy górny róg ekranu ma współrzędne 0,0. Wartości, które można wpisać w tych czterech polach mieszczą się w zakresie odpowiednio:

    • Lewa krawędź, Szerokość - od 0 do poziomej rozdzielczości ekranu (zwykle 800, 1024 lub 1440)

    • Górna krawędź, Wysokość - od 0 do pionowej rozdzielczości ekranu (zwykle 600, 768 lub 900)

    • Ukryj pasek narzędzi - ukrycie przycisków z dostępnymi funkcjami w oknie w celu pozostawienia większej ilości miejsca na właściwą zawartość okna (skrót w oknie Ctrl F9)

    • Maksymalizuj do pełnego ekranu - powiększenie rozmiaru okna (skrótem w oknie F5) na pełny ekran lub tylko do wysokości okna głównego.

    • Zapamiętuj zakładkę - jeśli włączymy ten parametr, to okno będzie zawsze owierane na tej zakładce (Lista, Pozycja lub Razem), na której było zamknięte. Przy wyłączonym parametrze okno będzie się zawsze otwierało na zakładce Lista.

Wszystkie określone tu ustawienia pamiętane są niezależnie dla każdego użytkownika programu. Pozwala to na optymalne przystosowanie programu do upodobań użytkownika, rozdzielczości używanego przez niego monitora oraz rodzaju wykonywanych przez niego w programie działań.

Klikając w przycisk Domyślne możemy przywrócić domyślne właściwości okna, przewidziane przez producenta dla aktualnej rozdzielczości ekranu.

Przywrócenie domyślnych właściwości wszystkich okien programu umożliwia funkcja Domyślne konfiguracje okien z pozycji menu głównego Ustawienia.


Wyszukiwanie

ROZPOCZĘCIE PRACY - Okno główne - Funkcje dostępne w każdym oknie

Po naciśnięciu w każdym oknie z danymi przycisku [image] lub klawiszy Ctrl F albo Ctrl F7 pojawi się okienko Szukaj umożliwiające wyszukanie pozycji okna zawierającej określoną wartość we wskazanym polu. Dla ułatwienia okienko Szukaj wywołuje się również automatycznie po rozpoczęciu pisania szukanego tekstu na zakładce Lista.

W okienku określamy kryteria i parametry wyszukiwania:

  • Tekst - szukany tekst

  • Szukaj po - wybieramy z listy pól dostępnych w tym oknie pole, które powinno zawierać wpisany wyżej tekst. Lista pól zawiera zarówno pola dostępne dla użytkownika w trakcie wprowadzania danych w tym oknie jak i tzw. pola systemowe, zawierające informacje wewnętrzne programu. Nazwy pól systemowych zaczynają się od znaku @. Pola systemowe będą dostępne na liście pól, jeśli wcześniej włączyliśmy je w zestawie dostępnych kolumn okna [image] Ctrl F4. Z wyszukiwania po polach systemowych korzysta się zwykle tylko w celach serwisowych.
    UWAGA. Jeśli w ustawieniach środowiska (menu główne Ustawienia - Środowisko) włączymy na zakładce Interfejs pole Szukanie wg bieżącej kolumny, to pole Szukaj po będzie ustawiane automatycznie na nazwę kolumny, w której znajdował się kursor przed wywołaniem okienka Szukaj po.

  • Szybko - przyspiesza wyszukiwanie pierwszej pozycji spełniającej zadane kryteria, tzn. takiej w której pole Szukaj po zaczyna się od szukanego tekstu. Nie działa na polach pochodzących z bibliotek. Np. w oknie z fakturami można szybko wyszukać fakturę, której kwota netto równa się np. 51,67 zł, ale nie można wyszukać szybko nabywcy, bo pochodzi on z biblioteki kontrahentów i tam są zapamiętane jego pełne dane. Pole Szybko powinno być zawsze włączone. Jeśli program stwierdzi, że szybkie wyszukiwanie wg zadanych kryteriów jest niemożliwe, skorzysta automatycznie ze standardowego sposobu wyszukiwania. Wyłączamy pole Szybko przede wszystkim wtedy, gdy szukany tekst jest tylko fragmentem szukanej nazwy lub gdy chcemy skorzystać z innych opcjonalnych ustawień wyszukiwania.

Przycisk Ustawienia >> umożliwia określenie opcjonalnych parametrów wyszukiwania:

  • Opcje - opcje wyszukiwania

    • Uwaga na rozmiar liter - zaznaczamy jeśli istotny jest rozmiar liter w wyszukiwanym tekście

    • Początek nazwy - zaznaczamy, jeśli szukany tekst musi się znajdować na początku nazwy

    • Fragment nazwy - zaznaczamy, jeśli wystarczy, żeby szukany tekst był fragmentem nazwy.

      UWAGA. Wyłączenie parametrów Początek nazwy oraz Fragment nazwy oznacza, że chcemy wyszukać pozycje okna, które w zadanym polu mają dokładnie taką nazwę jak wpisany tekst.

  • Kierunek - kierunek wyszukiwania: Naprzód albo Do tyłu. Niedostępne jeśli zaznaczono parametr Szybko.

  • Zakres - zakres wyszukiwania: czy przeszukać Całość czy tylko Podświetlone pozycje. Niedostępne jeśli zaznaczono parametr Szybko.

  • Skąd - skąd rozpocząć wyszukiwanie: Od kursora, czyli od bieżącej pozycji albo Od początku. Niedostępne jeśli zaznaczono parametr Szybko.

Przycisk OK rozpoczyna wyszukiwanie. Jeśli chcemy wyszukać kolejną pozycję spełniającą zadane kryteria można wywołać ponownie okienko wyszukiwania [image] Ctrl F i kliknąć w przycisk Następny lub zamiast wywoływać okno wyszukiwania nacisnąć klawisze Ctrl L bezpośrednio w oknie z danymi.

Aby dobrze wyjaśnić działanie Opcji wyszukiwania prześledźmy szukanie tekstu piła po polu Nazwa w bibliotece asortymentów, w której znajdują się pozycje o nazwach:

  1. PIŁA ELEKTRYCZNA

  2. Piła elektryczna Bosch

  3. ZESTAW PROMOCYJNY: piła, szlifierka, wiertarka

Przy różnym ustawieniu opcji:

  • Uwaga na rozmiar liter:

    • włączony: znajdziemy tylko trzeci asortyment, bo tylko on zawiera słowo "piła" pisane małymi literami
    • wyłączony: znajdziemy wszystkie trzy asortymenty, bo wszystkie zawierają słowo "piła"

  • Początek nazwy:

    • włączony: znajdziemy pierwszy i drugi asortyment, bo zaczynają się one od słowa "piła"
    • wyłączony: nie znajdziemy żadnego, bo wszystkie nazwy zawierają dodatkowe wyrazy

  • Fragment nazwy:

    • włączony: znajdziemy wszystkie asortymenty, bo wszystkie zawierają słowo "piła"
    • wyłączony: nie znajdziemy żadnego, bo wszystkie nazwy zawierają dodatkowe wyrazy.


Właściwości

ROZPOCZĘCIE PRACY - Okno główne - Funkcje dostępne w każdym oknie

Po naciśnięciu w każdym oknie z danymi przycisku [image] lub klawisza F4 pojawi się okienko Właściwości umożliwiające określenie uporządkowania kolejnych wpisów oraz zakres widocznych danych.

Standardowo możemy określić:

  • Uporządkowanie - wybieramy kolumnę, według której posegregowane zostaną wpisy. Szybko możemy zmienić uporządkowanie, klikając bezpośrednio w wybraną kolumnę tabeli. Kolejne kliknięcie w tą samą kolumnę zmieni sposób uporządkowania z malejące na rosnące (lub odwrotnie). Wyjaśnienia wymaga segregacja wg kolumny Ide, która oznacza kolejności wprowadzania wpisów do bazy.

  • Filtr - w sekcji tej dostępne są pola umożliwiające filtrowanie danych według wybranych kryteriów, rodzaj tych pól oraz ich ilość zależy od okna, w którym wywołujemy Właściwości

  • Filtry kolumn są włączone - zawartość okna pozostanie ograniczona do pozycji ze wskazanymi wartościami wybranej kolumny (patrz niżej Filtry kolumn)

  • Filtr wyszukiwania jest włączony - zawartość okna pozostanie ograniczona do pozycji zafiltrowanych podczas ostatniego wyszukiwania.

W każdym oknie dostępne są inne standardowe możliwości filtrowania wpisów, właściwe dla danego okna. Przykładowo w oknie Asortymenty możemy wybrać tylko asortymenty będące na stanie danego magazynu, w oknie Faktury możemy zobaczyć tylko faktury wysłane elektronicznie.

Wszystkie określone tu ustawienia pamiętane są niezależnie dla każdego użytkownika programu. Klikając w przycisk Domyślne możemy przywrócić ustawienia pierwotne danego okna. Przywrócenie pierwotnych właściwości dla wszystkich okien umożliwia funkcja Domyślne konfiguracje okien z pozycji menu głównego Ustawienia.

Filtry kolumn

Obok filtrowania pozycji, które udostępnia okno [image] Właściwości (F4), można szybko pokazać te pozycje, których zawartość kolumny przyjmuje odpowiednie wartości. Po najechaniu myszą na wybranę kolumnę tabeli pojawia się przycisk, którego kliknięcie rozwinie okienko z wyszczególnionymi wartościami, jakie przyjmuje dana kolumna. Zaznaczając wybrane pozycje możemy pokazać tylko te pozycje w oknie, których zawartość przyjmuje wskazane wartości.

Filtr wyszukiwania

Obok filtrowania pozycji, które udostępnia okno [image] Właściwości (F4), można szybko pokazać te pozycje, których zawartość wybranego pola (np. pole Numer) przyjmuje odpowiednie wartości. Służy do tego przycisk szybkiego wyszukiwania widoczny w górnej części większości okien. Podczas wpisywania w tym polu szukanego tekstu następuje automatyczne zawężenie widoku okna do pozycji zawierających ten tekst.

Użytkownik może określić parametry tego wyszukiwania klikając prawym przyciskiem na tym polu i wybierając spośród następujących opcji:

  • Szukaj po naciśnięciu ENTER - wyszukiwanie następuje dopiero po kliknięciu ENTER

  • Szukaj po każdej literze - wyszukiwanie odbywa się po każdej wpisanej literze

  • Początek nazwy - zaznaczamy, jeśli szukany tekst musi się znajdować na początku nazwy

  • Fragment nazwy - zaznaczamy, jeśli wystarczy, żeby szukany tekst był fragmentem nazwy.

UWAGA. Szukanie po polu Data działa w zależności od ilośći wpisanych znaków:

  1. jeśli wpisano 1 albo 2 znaki: np.: 6 albo 06, wówczas traktowane jest to jako numer miesiąca i filtrowane są wszystkie daty należące do tego miesiąca z roku takiego jak bieżąca data

  2. jeśli wpisano 4 znaki: np.: 2014, 2013 wówczas traktowane jest to jako rok, filtrowane są wszystkie daty z takiego roku

  3. jeśli wpisano 5 znaków: np. 12-06, 31-12, wówczas traktowane jest to jako dzień-miesiąc

  4. jeśli wpisano 7 znaków: np. 12-2014, wówczas traktowane jest to jako miesiąc-rok

  5. jeśli wpisano 10 znaków: np. 01-07-2014, jest to konkretna data.

Wpisany tekst o długości innej niż ww. jest ignorowany.


Załączane dokumenty

ROZPOCZĘCIE PRACY - Okno główne - Funkcje dostępne w każdym oknie

W każdym oknie po wpisaniu nowej pozycji można dodatkowo zapamiętać dokumenty skojarzone z tą pozycją. Przykładowo jeśli podpisujemy ze swoimi dostawcami lub odbiorcami jakieś umowy, to przy poszczególnych kontrahentach możemy zapamiętać elektroniczne wersje tych umów (skan). Umożliwi to nam późniejszy szybki wgląd w oryginalne dokumenty.

Żeby dla danego okna skonfigurować załączane dokumenty, należy w zawartości okna kliknąć prawym klawiszem myszy i z menu wybrać pozycję Konfiguruj dokumenty załączane. Następnie w okienku Dokumenty załączane wprowadzamy [image] listę dokumentów. Lista taka może zawierać jedną lub kilka linii, w każdej powinna być wpisana Nazwa dokumentu oraz ograniczenie na Rozmiar załączanych plików.

UWAGA. Korzystanie z możliwości załączania plików wiąże się ze znacznym przyrostem fizycznego rozmiaru bazy danych, dlatego należy zadbać o prawidłowe ograniczenie na rozmiar załączanych dokumentów, które nie pozwoli wprowadzać zbyt dużych plików.

Właściwą konfigurację kończymy przyciskiem OK i zamykamy okno. Ponowne jego otwarcie ukaże dwa dodatkowe przyciski:

  • Wczytaj dokumenty

  • Pokaż dokumenty.

Wczytanie dokumentu rozpoczynamy od przygotowania go w formie pliku. Plik może być dowolnego formatu rozpoznawalnego przez system, czyli np. png, gif, doc, pdf, txt, htm. W przypadku skanowania dokumentu zapisujemy go w dowolnym folderze i po wczytaniu pliku możemy go usunąć. Program zapamiętuje w bazie zawartość pliku, więc nie jest konieczne dodatkowe jego przechowywanie na dysku. Należy jednak dbać o to, żeby wczytywane pliki nie miały zbyt dużych rozmiarów, gdyż baza danych może się nadmiernie rozrosnąć.

Żeby załączyć dokument należy ustawić się na właściwej pozycji i po kliknięciu w przycisk [image] Wczytaj dokumenty wybrać właściwy rodzaj dokumentu. Ukaże się okno Dokumenty załączone, w którym wprowadzamy:

  • Data - data załączenia dokumentu

  • Nazwa - podstawia się wybrana nazwa dokumentu

  • Opis - podstawia się nazwa załącznego pliku wraz z rozszerzeniem, którego nie możemy zmienić

  • Wstaw dokument - wybieramy z katalogu przygotowany wcześniej właściwy plik do załączenia

  • Uwagi - dowolne uwagi na temat załącznika, na przykład miejsce przchowywania oryginału.

Po załączeniu dokumentu mamy do niego szybki dostęp, klikając w przycisk [image] Pokaż dokumenty.


Przegląd wydruku

ROZPOCZĘCIE PRACY - Okno główne

Każdy przygotowany w programie wydruk (np. faktura VAT, PZ, Rejestr sprzedaży VAT, zestawienia itd.) pojawia się w oknie Przegląd wydruku, gdzie można go przejrzeć oraz klikając w odpowiednie przyciski:

  • Drukuj - wydrukować na drukarce, ten sam efekt uzyskamy naciskając klawisz Enter lub klawisze Ctrl P albo Alt D. Wydruk otrzymany z drukarki może się różnić od tego, który pokazany jest w oknie. Dzieje się tak dlatego, że w oknie Przegląd wydruku wydruk jest automatycznie dopasowywany do rozmiaru okna, a w trakcie wydruku na drukarce jest dostosowywany do parametrów drukarki. W związku z tym dobrze jest przystosować rozmiar okna (przesuwając myszą jego krawędzie) do wydruku otrzymanego z drukarki. Ustawiony rozmiar będzie zapamiętany niezależnie dla każdego użytkownika programu.

  • Eksportuj do edytora tekstu lub arkusza kalkulacyjnego - wysłać do zewnętrznego edytora po to, aby przed wydrukiem dokonać jakichś drobnych modyfikacji. Chodzi tu o edytor, który potrafi edytować pliki w formacie HTML. Może to być Microsoft Word lub np. NVu - dobry darmowy edytor HTML. Wcześniej należy wskazać plik wykonywalny edytora w menu Ustawienia - Środowisko na zakładce Eksport.

    • UWAGA. Drobnych modyfikacji przed wydrukiem możemy dokonać bezpośrednio przy przeglądzie wydruku, klikając dwukrotnie myszą na tekście, który chcemy zmodyfikować. Teks ten podświetli się na żółto, modyfikację powinien zakończyć Enter

  • Eksportuj do pliku w formacie PDF - zapisać na dysku w formacie PDF, np. po to, żeby komuś go przekazać lub przesłać. Wcześniej przy instalacji systemu musi być zainstalowany sterownik PDF-XChange. Jeśli posiadamy podpis elektroniczny, możemy zapisywany plik od razu podpisać cyfrowo, zabezpieczając go tym samym przed nieautoryzowanymi zmianami.

  • Wyślij jako e-mail - wysłać pocztą internetową jako załącznik w formacie PDF lub HTML. Zalecamy PDF, gdyż uniemożliwia nieautoryzowaną modyfikację przesłanego wydruku. Wcześniej należy prawidłowo ustawić parametry serwera SMTP w menu Ustawienia - Środowisko na zakładce Internet.

  • Zapisz wydruk jako... - zapisać na dysku w formacie HTML.

Wszystkie wymienione wyżej funkcje dostępne są również w menu podręcznym (prawy klawisz myszy). Dodatkowo możemy skorzystać z pozycji:

  • Edytuj źródło - umożliwia poprawę źródła wydruku w notatniku systemowym. Różnica między [image] Eksportuj do edytora tekstu a [image] Edytuj źródło polega na tym, że w [image] edytujemy wydruk graficznie, a w [image] poprawiamy źródłowy kod HTML, co jest trudniejsze i wymaga pobieżnej choćby znajomości języka HTML.

Wydruki seryjne faktur można dodatkowo:

  • Wydrukować zbiorczo - przycisk [image] Drukuj wszystko.

  • Rozesłać kontrahentom pocztą elektroniczną - przycisk [image] Wyślij jako e-mail do poszczególnych kontrahentów.
    UWAGA. Wcześniej należy ustawić parametry serwera SMTP w menu Ustawienia - Środowisko na zakładce Internet.

Przed wydrukiem lub wykonaniem innej z opisanych wcześniej operacji możemy:

  • Poprzednia strona, [image] Następna strona - przejrzeć poszczególne strony przygotowanego do wydruku dokumentu, o ile oczywiście dokument składa sie z kilku stron. Celowo mówimy tu o stronach dokumentu, a nie wydruku, bo np. w przypadku faktury VAT zarówno krótka faktura z jedną pozycją jak i długa faktura ze stoma pozycjami, składa się w oknie Przegląd wydruku z tylu samo stron dokumentu - jedna strona na oryginał i jedna strona na kopię. Podział każdej ze stron dokumentu na strony wydruku następuje dopiero w trakcie faktycznego wydruku na drukarce - wtedy przy długiej fakturze zarówno oryginał jak i kopia mogą się składać np. z trzech stron wydruku.

  • Powiększ czcionkę, [image] Pomniejsz czcionkę - zmienić wielkość liter. Funkcja ta działa tylko na niektórych rodzajach dokumentów i zestawień. Zmiana wielkości czcionki zapamiętana będzie przy kolejnych wydrukach danego dokumentu.

  • Ustawienia drukarki - zmienić ustawienia drukarki lub wybrać inną drukarkę. Jeśli chcemy tylko zmienić drukarkę, to wygodniej jest to zrobić przed samym wydrukiem w oknie Wydruk - patrz dalej.

  • Właściwości F4 - zmienić czcionkę, marginesy, orientację oraz odcienie szarości. Zmiany te dotyczą tylko bieżącego rodzaju dokumentu i będą wykorzystane przy kolejnych wydrukach tego rodzaju dokumentu. Zmiany odcieni szarości dla wszystkich wydruków możemy dokonać w menu Ustawienia - Środowisko na zakładce Wydruki.

Po kliknięciu przycisku [image] Drukuj pojawia się okienko Wydruk, w którym określamy opcje i parametry wydruku:

  • Drukarka - drukarka na jaką zostanie wysłany wydruk. Wszystkie wydruki drukują się prawidłowo na dowolnych drukarkach laserowych lub atramentowych. Przy wydrukach dokumentów (faktura vat, paragon, itp.) możemy również korzystać z drukarek igłowych, które lepiej sprawdzają się w warunkach zwiększonej wilgotności lub zapylenia oraz np. niższej temperatury (często w takich właśnie warunkach jest prowadzona sprzedaż). Jeśli decydujemy się na wybór drukarki igłowej należy zaznaczyć niżej parametr Drukuj znakowo.

  • Strony wydruku - określamy czy chcemy drukować Wszystkie, czy tylko wybrane Od-do strony wydruku. Możemy również wybrać strony tylko Parzyste lub Nieparzyste co jest przydatne jeśli chcemy wydrukować dwustronnie jakieś wielostronicowe zestawienie, a nie posiadamy drukarki z dupleksem, więc sami musimy przekładać kartki w drukarce

  • Kopie - po określeniu Ilości kopii program sam wyliczy Ile kartek zajmie w całości nasz wydruk

  • Parametry

    • Drukuj jako jeden dokument - zaznaczamy przy wydrukach na drukarce z dupleksem, tzn. takiej która sama potrafi wydrukować na obu stronach jednej kartki

    • Wstaw brakujące parzyste strony (duplex) - zaznaczamy w przypadku wydruku na dupleksie dokumentu wielostronicowego. Dzięki temu jeśli np. oryginał faktury VAT będzie się składał z trzech stron wydruku, to zostanie dodana czwarta pusta strona po to, żeby kopia faktury zaczęła się drukować na nowej kartce papieru, a nie na odwrocie drugiej kartki oryginału.

    • Drukuj znakowo (na drukarce igłowej) - zaznaczamy jeśli chcemy wydrukować dokument na drukarce igłowej w trybie znakowym, a nie graficznym.
      UWAGI:

      1. Przed wydrukiem w trybie znakowym należy koniecznie ustawić parametry takiego wydruku (patrz ROZPOCZĘCIE PRACY - Okno główne - Przegląd wydruku - Wydruki znakowe).

      2. Nie należy zaznaczać tego parametru, jeśli wyżej w polu Drukarka wybraliśmy drukarkę laserową lub atramentową. Program nie rozpoznaje automatycznie typu drukarki i wyśle wydruk znakowy na wybrana drukarkę laserową lub atramentową, co może spowodować albo zawieszenie systemu, albo niepotrzebny, nieczytelny wydruk wielu kartek.

Po kliknięciu przycisku [image] Wyślij jako e-mail pojawia się okienko Wysyłanie wydruku, w którym określamy adresata poczty, treść wiadomości i inne parametry:

  • Adres e-mail - adres na jaki wysłać pocztę. Można wysłać wiadomość jednocześnie do kilku adresatów, w tym wypadku adresy należy rozdzielić przecinkami. Po kliknięciu przycisku [image] pojawi się okno Książka adresowa, z którego możemy wprost wybrać adresata.

  • Temat - temat wiadomości

  • Opis - zawartość tekstową wiadomości

  • Format - format załączonego wydruku - HTML lub PDF.


Wydruki znakowe

ROZPOCZĘCIE PRACY - Okno główne - Przegląd wydruku

Program wykona wydruk w trybie znakowym, jeżeli w oknie Wydruk zaznaczymy opcję Drukuj znakowo (na drukarce igłowej) (patrz ROZPOCZĘCIE PRACY - Okno główne - Przegląd wydruku).
UWAGA. Zaznaczenie tej opcji ma sens tylko wtedy, gdy w polu Drukarka wybraliśmy drukarkę igłową (lub inną, ale obsługującą tryb znakowy). Wykonanie wydruku znakowego na nieprzystosowanej drukarce może spowodować wydrukowanie się wielu kartek papieru przypadkowymi znakami a nawet zawieszenie się programu.

Wydruki w programie [image] zostały zaprojektowane na bazie języka HTML i generalnie wymagają drukarek graficznych - laserowych lub atramentowych. Na takich drukarkach wydruki wyglądają elegancko, przejrzyście i dokładnie tak, jak widać je na podglądzie na ekranie monitora. Jednak ze względu na istotne zalety drukarek igłowych, takie jak np. znacznie niższe koszty eksploatacji czy możliwość jednoczesnego drukowania w kilku kopiach, niektóre wydruki zostały specjalnie dostosowane do drukowania na drukarkach igłowych - w trybie znakowym, gdyż tylko wydruk znakowy pozwala w pełni na wykorzystanie zalet drukarki igłowej. Drukarki igłowe mają co prawda często możliwość drukowania w trybie graficznym, jednak drukowanie takie jest bardzo niepraktyczne ze względu na hałas, powolną pracę i znacznie szybsze zużycie. Wydruk w trybie znakowym polega na korzystaniu ze znaków (liter i kresek) wbudowanych na stałe w pamięć drukarki, zamiast przesyłania na drukarkę każdej literki jako zbioru odpowiednio ułożonych punktów (kropek), tak jak się to dzieje w trybie graficznym. Dzięki temu wydruk na drukarce igłowej w trybie znakowym jest o wiele szybszy od graficznego i czasami zapobiega zniekształceniom, gdyż zdarza się, że przy wydrukach graficznych na drukarce 9-igłowej część wydruku jest pomijana, bo nie da się jej po prostu utworzyć korzystając z mechanizmu mających określone położenie 9 igieł. Pamiętać należy jednak, że nie wszystkie wydruki mogą być drukowane w trybie znakowym. Wydruk znakowy ma ograniczenia mogące powodować różne problemy związane z czytelnością wydruku, podziałem na poszczególne strony i inne. Wydruki zbyt szerokie lub ze zbyt skomplikowaną strukturą mogą w ogóle nie dać się wydrukować w trybie znakowym - dostaniemy wówczas komunikaty o błędach, tzn. Za szeroki wydruk. Maksymalna szerokość wydruku wynosi .. znaków albo Błąd konwersji wydruku do trybu znakowego. Drukowanie znakowe najlepiej więc wykorzystać do wykonywania prostych wydruków, które są wykonywane w dużej ilości, takie jak faktury, dokumenty MM, WZ, PZ, RW, RK, KP/KW i potwierdzenia sald dla kontrahentów. Te właśnie wydruki zostały dostosowane do trybu znakowego (oczywiście, mogą być też drukowane w trybie graficznym).

Zanim rozpoczniemy drukowanie w trybie znakowym należy koniecznie ustawić parametry wydruku na drukarce igłowej (patrz INSTRUKCJA ADMINISTRATORA - PARAMETRYZACJA SYSTEMU - Wydruki znakowe ).


Książka adresowa

ROZPOCZĘCIE PRACY - Okno główne - Przegląd wydruku

Książka adresowa zawiera 2 rodzaje adresów e-mail:

  • adres firmy - adres ten wypełniamy w oknie z firmami

  • adresy własne - adresy wpisujemy w oknie książki adresowej.

Nowego własnego adresata [image] wprowadzamy klawiszem Ins i uzupełniamy:

  • Nazwa - dowolna nazwa identyfikująca adresata poczty

  • E-mail - adres poczty e-mail.

Po kliknięciu przycisku Wybierz zaznaczony adres zostanie przepisany do okienka edycyjnego wysyłania wydruku.


Bieżąca data i okres

ROZPOCZĘCIE PRACY - Okno główne

Niezależnie od ustawień w systemie operacyjnym w pozycji menu głównego Ustawienia - Bieżąca data i okres możemy określić aktualną datę dla programu:

  • Data systemowa - gdy opcja ta jest włączona, przy wejściu do programu Data bieżąca programu jest ustawiana na aktualną datę systemową, w przeciwnym wypadku ostatnio wpisana Data bieżąca nie zmienia się

  • Data bieżąca - data traktowana przez program jako data bieżąca; można ją przestawić i będzie ona zapamiętana przez program, jeśli Data systemowa jest wyłączona.

Tu również określamy OKRES pracy, czyli wprowadzania danych, przeglądania i wydruków:

  • Tylko bieżący dzień - ustawia okres na dzień z daty bieżącej

  • Rok, Miesiąc - wybieramy okres w jakim chcemy pracować. W polu Miesiąc oprócz poszczególnych miesięcy możemy wybrać pozycje: Cały rok, Od - Do i Wszystko.

  • Od, Do - daty podstawiają się na podstawie wybranego wyżej roku i miesiąca. Jeśli w polu Miesiąc wybraliśmy Od - Do, możemy datami ustalić dowolny inny okres (np. cały kwartał, jeden tydzień lub fragment miesiąca).

Daty zamknięcia - Dokumenty - wprowadzona tu data daje nam pewność, że w żadnej ewidencji nie dokonamy wpisów z datą wcześniejszą i nie zmienimy i nie wykasujemy wprowadzonych wcześniej wpisów. Jeśli z jakichś szczególnych względów chcemy poprawić coś w okresie zamkniętym, należy datę zamknięcia przestawić na datę sprzed tego okresu i po wykonanych korektach ponownie zamknąć okres.

Daty zamknięcia - Płatności - dotyczy tylko dokumentów sprzedaży i zakupów (PZ); wprowadzona tu data umożliwia modyfikacje płatności w dokumentach, których nie można edytować ze względu na parametr Daty zamknięcia - Dokumenty, np. daty wpisane tak jak w okienku powyżej oznaczają, że:

  • w dokumentach sprzed 31-07-2012 (włącznie) nie możemy nic poprawiać

  • w dokumentach wystawionych w okresie od 01-08-2012 do 31-08-2012 (włącznie) możemy poprawiać tylko płatności

  • dokumenty wystawione 01-09-2012 i później mogą być dowolnie modyfikowane.

Jeżeli do rozliczania płatności wykorzystujemy moduł Kasa/Bank, korzystanie z daty zamknięcia płatności nie ma sensu. W takim przypadku data ta powinna być zawsze pusta.

UWAGA. Okienko DATY możemy szybko wywołać z wszystkich okien zależnych od okresu przeglądania (PZ, faktury, MM, kasa/bank, przelewy) wciskając klawisz F12.


Wybór użytkownika

ROZPOCZĘCIE PRACY

W przypadku, gdy na liście istnieje kilku użytkowników, przy wejściu do programu program prosi o wprowadzenie nazwy użytkownika (identyfikatora) oraz hasła. W dolnej części okna logowania widnieje nazwa bazy danych i serwer sql, do którego się podłączamy. Gdy na liście użytkowników jest tylko jedna pozycja (ADMIN czyli Administrator), przy wejściu program nie wymaga nazwy.

Zmiany użytkownika można również dokonać podczas pracy, wywołując z menu głównego funkcję Zbiory - Wybór użytkownika.

Listę użytkowników można modyfikować (patrz INSTRUKCJA ADMINISTRATORA - PARAMETRYZACJA SYSTEMU - Użytkownicy), jednak może tego dokonać tylko Administrator.

Każdy użytkownik może zmienić swoje hasło (patrz Hasło użytkownika).


Hasło użytkownika

ROZPOCZĘCIE PRACY - Wybór użytkownika

W pozycji menu głównego Ustawienia - Hasło użytkownika każdy użytkownik może zmienić swoje własne hasło.

Program prosi o hasło zawsze przy wyborze użytkownika, czyli podczas rozpoczęcia programu oraz przy zmianie użytkownika podczas pracy - menu Zbiory - Wybór użytkownika.

Zmiany haseł innych użytkowników może dokonać tylko Administrator (patrz INSTRUKCJA ADMINISTRATORA - PARAMETRYZACJA SYSTEMU - Użytkownicy).


Wprowadzanie danych firmy

ROZPOCZĘCIE PRACY

Przed rozpoczęciem pracy należy wpisać dane własnej firmy. Po kliknięciu w oknie głównym w przycisk [image] lub w menu Zbiory - Wybór firmy pojawi się na ekranie okienko z listą firm. Po naciśnięciu F6 lub kliknięciu w zakładkę Pozycja lub [image] należy wpisać nazwę firmy (Skrócona nazwa firmy) oraz wypełnić wszystkie dane firmy:

  • Skrócona nazwa firmy - podstawowa nazwa, służąca do identyfikacji firmy:

    • występuje w oknie z listą firm

    • pojawia się na wydrukach

  • Grupa - dzięki przypisaniu firmy do grupy istnieje możliwość nadania użytkownikom praw dostępu do firm z danej grupy, informacja szczególnie przydatna w wersji dla biura rachunkowego

  • Logo - klikając podwójnie we wklęsły prostokąt możemy określić znak graficzny firmy w formacie BMP lub PNG. Logo będzie drukowane w nagłówku dokumentów. Ze względów technicznych logo powinno mieć wysokość 121 pikseli, mniejsze pliki będą rozciągane do wysokości 121 pikseli.

  • DANE - podstawowe dane firmy:

    • Nagłówek dokumentów - pełna nazwa firmy, drukuje się w nagłówku faktury jako dane sprzedawcy, w PZ jako dane nabywcy itd.

    • NIP, REGON

    • Płatnik VAT - zaznaczamy, jeśli firma jest płatnikiem podatku VAT

    • Rodzaj jednostki - dla jednostek służba zdrowia (NFZ) drukowana jest trochę zmieniona wersja faktury korygującej

    • Rozliczenia - określamy formę rozliczenia firmy z urzędem skarbowym (księga przychodów, ewidencja przychodów (ryczałt), pełna księgowość (FK)); forma rozliczenia ma wpływ m.in. na możliwość eksportu faktur, PZ oraz raportów kasa/bank do różnych systemów księgowych

    • Metoda kasowa - zaznaczany, jeśli płatnik VAT wybrał kasową metodę rozliczania podatku VAT. Wpływa na dostępne sposoby rozliczenia VAT, co jest istotne przy automatycznym księgowaniu dokumentów do programów księgowych. Jeśli włączono to pole, wówczas pod numerem faktury pojawi się adnotacja "metoda kasowa".

  • PRZELEWY - informacje potrzebne do prawidłowego wypełnienia druków poleceń przelewów bankowych:

    • Nazwa i adres - wprowadzamy nazwę i adres firmy w formie, jaką chcemy mieć na wydruku przelewów

    • Rachunki bankowe - uzupełniamy wszystkie rachunki bankowe firmy, będzie można z nich korzystać przy wystawianiu przelewów, ale również przy wystawianiu faktur oraz w raportach bankowych przy wprowadzaniu płatności wpływających na te rachunki

  • ADRES - dane adresowe niezbędne do wypełnienia niektórych formularzy. Aktualnie (wersja 7.0x) wykorzystywane są tylko pola Fax (w przypomnieniu) i Sąd gospodarczy (w wezwaniu do zapłaty)

  • USTAWIENIA - parametry konfiguracyjne poszczególnych modułów programu. Szczegółowe wyjaśnienie ich znaczenia znajduje się w rozdziałach opisujących konfigurację poszczególnych modułów: Magazyn, Sprzedaż, Kasa/Bank oraz Należności i zobowiązania.

  • UDOSTĘPNIANIE - parametry umożliwiające zdalny dostęp do tej firmy przez moduł WWW.

    • Dostęp przez moduł WWW - włączenie dostępu

    • Identyfikator firmy - nazwa identyfikująca tę firmę w trakcie logowania do modułu WWW.

    • Konfiguracja dla użytkownika typu "kontrahent" - kontrahenci zalogowani do modułu WWW będą widzieli takie kolumny okien Faktury, Kontrahenci i Rozrachunki jakie zostaną określone dla wybranego tutaj użytkownika

  • DOKUMENTY - parametr określający miejsce przechowywania dokumentów załączanych. Zakładka widoczna tylko jeśli w menu głównym Ustawienia - Środowisko - Eksport podano ścieżkę do katalogu, w którym chcemy przechowywać dokumenty załączane.

  • NOTATKI - dowolne notatki, nie pojawiają się na żadnych wydrukach.

UWAGI:

  1. Jeśli posiadamy wersję programu obsługującą wiele firm, wpisujemy dane każdej z nich (po kliknięciu w ikonę [image] lub naciśnięciu klawisza Ins, żeby utworzyć nową firmę).

  2. Jeśli mamy już zainstalowany inny program firmy RESET2, np. R2fk lub R2płatnik, to zamiast wprowadzać od nowa dane swojej firmy (lub wszystkich firm w przypadku biura rachunkowego), możemy skorzystać z biblioteki firm wprowadzonej np. w R2płatniku. W momencie otwarcia okna Firmy program R2faktury automatycznie wykrywa czy na bieżącym serwerze SQL znajdują się bazy danych programów R2fk i R2płatnik, a jeśli tak, to proponuje integrację z nimi. W zintegrowanym programie R2faktury pojawią się automatycznie firmy (wraz z rachunkami bankowymi) wprowadzone wcześniej np. w R2płatniku. Zmiany wprowadzane w danych firmy w dowolnym ze zintegrowanych programów, będą od razu widoczne w pozostałych programch. Integrację można również skonfigurować ręcznie (patrz INSTRUKCJA ADMINISTRATORA - INSTALOWANIE PROGRAMU - R2firma - integracja modułów).


Korzystanie z bazy GUS

ROZPOCZĘCIE PRACY - Wprowadzanie danych firmy

Jeśli posiadamy wersję programu obsługującą wiele firm, w oknie Firmy wpisujemy dane każdej z nich (po kliknięciu w ikonę [image] lub naciśnięciu klawisza Ins).

Zamiast wpisywać ręcznie dane każdej nowej firmy możemy je wyszukać w internetowej bazie firm prowadzonej przez GUS i skopiować automatycznie do okna Firmy.

W tym celu należy w oknie Firmy nacisnąć przycisk [image] Znajdź firmę w internetowej bazie GUS (REGON).

W otwartym w ten sposób oknie Znajdź firmę w GUS wpisujemy NIP, REGON lub KRS szukanej firmy (w zależności od określonego niżej kryterium Szukaj wg).

Kolejny krokiem jest podanie wymaganego przez GUS kodu weryfikacyjnego w polu Wpisz kod z obrazka.

Jeśli wpisaliśmy prawidłowy kod, to możemy:

  • Wstaw - utworzyć nową firmę i wstawić do niego wyszukane dane

  • Pokaż - sprawdzić dane wyszukanej firmy

Jeśli chcemy, aby domyślnym sposobem tworzenia firm było kopiowanie z bazy GUS, zaznaczamy pole Nowa firma zawsze z GUS. Przy tworzeniu nowej firmy (kliknięcie w przycisk [image] lub naciśnięcie klawisza Ins) w oknie Firmy nastąpi automatyczne otwarcie okna Znajdź firmę w GUS.

Przycisk Format adresu [image] określa sposób składania danych adresowych z elementów takich jak: Nazwa, Ulica, Miasto itp.

UWAGI:

  1. Jeśli pokazany kod weryfikacyjny jest nieczytelny, można za pomocą przycisku Pokaż inny obrazek wygenerować nowy kod.

  2. Kod weryfikacyjny podajemy jednorazowo przy pierwszym wyszukiwaniu. Przy kolejnych wyszukiwaniach nie będzie on wymagany.

  3. Jeśli podamy numer NIP firmy, na której aktualnie stoimy w oknie Firmy, to kliknięcie przycisku Wstaw nie spowoduje utworzenia nowej firmy lecz wpisanie wyszukanych danych do bieżącej firmy.


Rachunki bankowe firmy

ROZPOCZĘCIE PRACY - Wprowadzanie danych firmy

W oknie Rachunki bankowe powinniśmy wprowadzić tyle pozycji, ile rachunków posiada nasza firma. Będą one wykorzystywane przy wystawianiu faktur, w raportach bankowych przy wprowadzaniu płatności wpływających na te rachunki oraz przy sporządzaniu poleceń przelewów bankowych.

Nowy rachunek [image] wprowadzamy klawiszem Ins.

Uzupełniamy:

  • Nazwa rachunku - dowolna nazwa identyfikująca rachunek

  • Waluta - waluta rachunku, pole dostępne tylko w wersji programu umożliwiającej obsługę transakcji zagranicznych

  • Lk - liczba kontrolna rachunku obliczana automatycznie, powinna się zgadzać z dwoma pierwszymi cyframi numeru konta. Jeśli się nie zgadza, to znaczy, że numer konta zawiera błędy.

  • Konto - wprowadzamy pełny numer rachunku bankowego firmy. Aktualnie wszystkie rachunki bankowe w Polsce są zgodne ze standardem NRB i składają się z 26 cyfr, z których dwie pierwsze to cyfry kontrolne, cyfry od 3-ej do 10-tej to numer banku, a kolejne to numer rachunku w danym banku. W zależności od upodobań wpisujemy nasz rachunek bez odstępów lub w grupach po 4 albo 8 cyfr, np.: 26 2030 2081 1254 8723 5698 1245 lub 26 20302081 12548723 56981245 albo 26203020811254872356981245. Jeśli korzystamy z wersji programu umożliwiającej obsługę transakcji zagranicznych, to przed właściwym numerem konta musimy podać prefiks kraju w którym prowadzony jest rachunek (zwykle PL).

  • Bank - bank, w którym jest prowadzony określony wyżej rachunek, podstawia się automatycznie z biblioteki banków na podstawie wprowadzonego wyżej numeru konta.

  • SWIFT - kod SWIFT wybranego banku, dostępny tylko w wersji programu umożliwiającej obsługę transakcji zagranicznych.

  • WYDRUKI/EKSPORT - parametry wydruków lub eksportu do systemu bankowego

    • Przelewy z tego rachunku są

      • drukowane

        • Parametry określone w menu Ustawienia - Przelewy - zaznaczenie opcji oznacza zaakceptowanie szczegółowych ustawień wydruków przelewów, ustawionych globalnie w konfiguracji przelewów, w przeciwnym wypadku ustalamy indywidualne parametry wydruku dla danego rachunku

        • Zwykły, Podatki, ZUS - indywidualne parametry wydruku dla poszczególnego konta, wyjaśnione w INSTRUKCJA ADMINISTRATORA - PARAMETRYZACJA SYSTEMU - Konfiguracja przelewów

      • eksportowane do systemu bankowego

        • Wybierz system bankowy - ustalamy system bankowy, z którym ma współpracować program. Program współpracuje z większością dostępnych systemów bankowych. Jeśli danego systemu nie ma na liście, należy skontaktować się z dystrybutorem lub producentem programu.

    • Import płatności z - automatyczny import płatności z systemu bankowego, co znacznie ułatwia i przyspiesza wprowadzanie raportów bankowych. Więcej na ten temat w rozdziale KASA/BANK - Import płatności.

  • INNE

    • Nr klienta - pole pomocnicze przydatne przy eksporcie do niektórych systemów bankowych, np. Sezam i Paribas

    • Numer raportu bankowego (wyciągu) - sposób numerowania kolejnych raportów bankowych, istotne tylko jeśli korzystamy z modułu Kasa/Bank. Numerowanie dokumentów jest szczegółowo opisane w INSTRUKCJA ADMINISTRATORA - PARAMETRYZACJA SYSTEMU - Definicje dokumentów - Dokumenty sprzedaży.

    • Makieta - makieta wydruku raportu bankowego związanego z tym rachunkiem. Wypełniamy tylko wtedy, jeśli ma być inna niż standardowa.

  • Ustaw jako domyślny - zaznaczamy przy głównym rachunku bankowym naszej firmy, tzn. takim, na który mają być kierowane zapłaty za większość faktur. Będzie się on podstawiał domyślnie na wszystkich fakturach jako nasz rachunek bankowy (na fakturze zakładka Inne pole Płatne na rachunek). W wersji programu umożliwiającej obsługę transakcji zagranicznych można ustawić domyślny rachunek dla każdej waluty. W zależności od waluty faktury będzie się na niej podstawiał rachunek domyślny dla danej waluty.


Moduły programu

ROZPOCZĘCIE PRACY

Program [image] składa się z kilku modułów. Wybierając i prawidłowo konfigurując odpowiednie moduły możemy w pełni przystosować program do specyfiki naszej firmy i naszych potrzeb. Dzięki temu skrócimy do minimum czas niezbędny na wdrożenie programu i wykorzystamy optymalnie jego możliwości.

Przede wszystkim musimy odpowiedzieć sobie na pytanie z jakich modułów i możliwości programu chcemy korzystać i wyłączyć od razu te, które będą dla nas nieprzydatne. Wybraną konfigurację można później w trakcie pracy z programem dostosowywać do naszych rosnących umiejętności i zmieniających się wymagań.

Najważniejsze moduły programu (i jednocześnie rozdziały instrukcji) to:

  • MAGAZYN - rozliczanie stanów magazynowych, przyjęcia zewnętrzne PZ, przesunięcia międzymagazynowe MM, wydania zewnętrzne WZ, rozchód wewnętrzny RW

  • SPRZEDAŻ - fakturowanie sprzedaży (faktury, rachunki, paragony, korekty)

  • KASA/BANK - raporty kasowe i bankowe, ewidencjonowanie przepływów środków pieniężnych

  • NALEŻNOŚCI I ZOBOWIĄZANIA - rozliczanie należności i zobowiązań, rozrachunki, windykacja należności, restrykcje w obrotach z nierzetelnymi nabywcami

  • PRZELEWY BANKOWE - ewidencja, wydruki i eksport poleceń przelewów bankowych

  • CRM - ewidencja i zarządzanie kontaktami z klientami.

Każdy z tych modułów można włączyć lub wyłączyć oraz odpowiednio skonfigurować. Szczegółowy opis poszczególnych modułów znajduje się w odpowiednich rozdziałach instrukcji.

Wersja demonstracyjna programu zawiera wszystkie moduły. Decydując się na zakup należy wybrać wersję programu zawierającą interesujące nas moduły i funkcjonalność.


Wersje programu

ROZPOCZĘCIE PRACY

Program [image] występuje w kilku wersjach różniących się funkcjonalnością:

  • MINI - najprostsza wersja programu z ograniczonym dostępem do niektórych, rzadziej używanych funkcji. Umożliwia szybkie wystawienie faktur i innych najczęściej używanych dokumentów oraz sporządzenie podstawowych zestawień.

  • STANDARD - pełna wersja programu z dostępem do większości modułów i funkcji programu. Umożliwia dokładne przystosowanie programu do własnych potrzeb (rodzaje i wygląd dokumentów, zestawienia).

  • MAXI - pełna wersja wzbogacona o transakcje zagraniczne i kilka innych funkcji przydatnych w większych firmach lub przy większej liczbie dokumentów.

Każdą z tych wersji możemy kupić z opcją obsługi magazynu lub bez.

Jeśli chcemy wystawiać faktury krajowe w EUR bądź faktury eksportowe (wewnątrzwspólnotowa dostawa towarów, eksport usług, eksport towarów) zarówno w PLN jak i w walutach obcych, należy zakupić program w wersji MAXI lub PRO.

Program [image] oferuje funkcjonalność wersji MAXI wzbogaconą o wiele udogodnień istotnych dla dużych firm.

Pełna specyfikacja możliwości programu opisana jest w rozdziale WSTĘP - Specyfikacja, a zestawienie różnic pomiędzy wersjami MINI, STANDARD, MAXI i PRO w rozdziale WSTĘP - Specyfikacja - Porównanie wersji.

Wersja demonstracyjna

Wersja demonstracyjna umożliwia normalną pracę w ciągu 60 dni od daty zainstalowania. Po tym czasie blokowane są wydruki i eksport danych. W trakcie testowania wersji demonstracyjnej możemy określić jej konfigurację (w serii Standard - Mini, Standard albo Maxi), liczbę obsługiwanych firm, liczbę użytkowników, liczbę zdalnych użytkowników oraz opcje dodatkowe (magazyn). Dzięki temu będziemy mieli pewność, że po zakupie programu będziemy mieli dokładnie taką samą wersję jak w trakcie testowania.


BIBLIOTEKI

INSTRUKCJA UŻYTKOWNIKA

Aby przyspieszyć wystawianie dokumentów, program prowadzi różne biblioteki, np. kontrahentów lub asortymentów.

Raz wprowadzone pozycje istnieją na liście, z której są później w trakcie sporządzania dokumentów już tylko wybierane, bez konieczności każdorazowego wpisywania.

Biblioteki możemy uzupełniać na bieżąco w trakcie sporządzania dokumentów. Możemy je również wstępnie wypełnić przed rozpoczęciem wystawiania dokumentów.

Program prowadzi następujące biblioteki:

  • Kontrahenci

  • Asortymenty

  • Magazyny

  • Kontrakty

  • Uwagi

  • Oddziały

oraz predefiniowane (tzn. zawierające już odpowiednie dane) biblioteki ogólne, wspólne dla wszystkich firm obsługiwanych w programie:

  • Banki

  • Urzędy skarbowe

  • Kody pocztowe.

Dostęp do bibliotek umożliwia menu główne Okna. Można się do nich również dostać bezpośrednio z odpowiednich pól w trakcie sporządzania dokumentów.


Kontrahenci

BIBLIOTEKI

Klikając w oknie głównym w przycisk [image] wejdziemy do okna z kontrahentami. Biblioteka kontrahentów jest jednym z głównych okien programu, czyli może być niezależnie otwarta obok innych głównych okien, na przykład faktur. Dzięki temu mamy cały czas bezpośredni wgląd we wszystkie dane kontrahenta i możemy szybko odszukać na przykład numer telefonu, czy osobę z którą należy się kontaktować.

Listę kontrahentów możemy przygotować sobie wcześniej, niezależnie od wprowadzanych dokumentów, ale możemy również wprowadzać kontrahentów bezpośrednio podczas wystawiania faktur, PZ itp.

W bibliotece kontrahentów figurować muszą wszyscy kontrahenci naszej firmy, zarówno ci, którzy często pojawiają się na dokumentach, jak i ci, którzy występują sporadycznie. Dzięki bibliotece w kolejnych wpisach będziemy wybierać kontrahenta z biblioteki, zamiast wielokrotnie wpisywać jego dane na kolejnych dokumentach.

Wprowadzając nowego kontrahenta na listę (Ins, [image]) określamy następujące dane:

  • Nazwa i adres - pełna nazwa i adres drukowane na dokumentach, przejście do nowej linii umożliwia Shift Enter. Wpisujemy tu wszystko co powinno się znaleźć w danych kontrahenta na fakturze, tzn. nazwę firmy, ulicę, miejscowość i kod pocztowy

  • Skrót - skrót nazwy kontrahenta, pod którym będzie on figurował w bibliotece

  • Osoba - imię i nazwisko osoby odbierającej najczęściej faktury VAT

  • Płatnik VAT - zaznaczamy, jeśli kontrahent jest płatnikiem podatku VAT

  • Kraj - określamy kraj (przedrostek przy NIPie) dla płatników VAT zarejestrowanych w Unii Europejskiej, z którymi prowadzimy transakcje wewnątrzwspólnotowe (patrz ROZPOCZĘCIE PRACY - Wersje programu) oraz zaznaczenie w danych firmy na zakładce Ustawienia - Ogólne opcji Transakcje zagraniczne. Dostępne tylko w wersji MAXI i PRO.

  • NIP - Numer Identyfikacji Podatkowej

  • Waluta - określamy walutę w jakiej prowadzone będą rozrachunki z tym kontrahentem, tzn. w jakiej walucie będą wystawiane faktury dla tego kontrahenta i w jakiej walucie będą rozliczane płatności związane z tymi fakturami; warunkiem jest posiadanie wersji MAXI lub PRO. W obecnej wersji programu rozrachunki walutowe dotyczą tylko odbiorców i faktur sprzedaży. Dokumenty PZ można wprowadzać tylko w PLN.
    UWAGA. Z jednym kontrahentem można prowadzić rozrachunki w kilku walutach. Ustawiana tutaj waluta jest jedynie walutą domyślną, która będzie się podstawiać na fakturze po wybraniu tego kontrahenta. W razie potrzeby można ją zmienić na dowolną inną.

  • Stały - należy zakreślić w przypadku, gdy kontrahent będzie się często pojawiał na fakturach lub innych dokumentach, stałych kontrahentów można później [image] wyfiltrować na liście (F4 Właściwości lub w szybki sposób kombinacją klawiszy Shift F4).

Dodatkowo kontrahentom stałym określamy dla własnej wygody i informacji dodatkowe dane. Nie są to dane niezbędne do wystawienia faktury lub innego dokumentu więc jeśli nie widzimy potrzeby, to nie musimy ich wypełniać. Określamy:

  • KONTAKT

    • numery telefonów i faxu

    • adres E-mail z możliwością wysłania [image] poczty elektronicznej.

    • adres firmowej strony Www kontrahenta z możliwością jej otwarcia [image].

  • WARUNKI - forma płatności, termin i rabat - jeśli kontrahent ma u nas (sprzedaż) lub my u niego (zakup) na stałe określone warunki sprzedaży, możemy je tu wpisać - będą podstawiane automatycznie przy wyborze tego kontrahenta na fakturze lub PZ. Dodatkowo jeśli kontrahent wyraził zgodę na otrzymywanie e-Faktur, zaznaczamy pole e-Faktury (patrz SPRZEDAŻ - e-Faktury).

  • PRZELEWY - dane przydatne przy regulowaniu zobowiązań dla dostawców

    • Nazwa i adres do przelewów - domyślnie podstawia się z pola Nazwa i adres

    • Lk - liczba kontrolna rachunku obliczana automatycznie, wyliczona tu liczba powinna się zgadzać z dwoma pierwszymi cyframi konta

    • Konto - wprowadzamy pełny numer rachunku bankowego kontrahenta,
      np. 87 1090 1522 0000 0000 1423 4892
      lub 87 10901522 00000000 14234892
      lub 87109015220000000014234892.
      W przypadku rozliczeń walutowych przed numerem konta wpisujemy dodatkowo prefiks kraju, w którym prowadzony jest rachunek bankowy kontrahenta.

    • Bank - bank, w którym jest prowadzony określony wyżej rachunek, podstawia się automatycznie z biblioteki banków

    • SWIFT - w przypadku rozliczeń walutowych wprowadzamy numer SWIFT banku, w którym prowadzony jest rachunek bankowy kontrahenta

  • UWAGI - dowolne uwagi tylko dla naszej informacji i wygody, np. osoba z którą należy się kontaktować lub charakterystyka kontrahenta (Shift Enter nowa linia)

  • INNE

    • Nazwa i adres do korespondencji - jeśli adres korespondencyjny jest inny niż określony w polu Nazwa i adres (Shift Enter nowa linia)

    • Kod pocztowy - kod pocztowy określony automatycznie na podstawie danych wpisanych w polu Nazwa i adres

    • Województwo - dodatkowa informacja, przydatna do regionalnej analizy sprzedaży. Określane automatycznie na podstawie kodu pocztowego.

    • Grupa - grupa kontrahentów, podział kontrahentów na grupy umożliwi późniejsze zestawienia sprzedaży (lub zakupów) z podziałem na grupy (kolumna NabywcaGrupa w oknie Faktury i Okna - Zestawienia - Pozycje faktur oraz DostawcaGrupa w PZ). Grupa jest również jednym z kryteriów przy tworzeniu Zestawienia należności i zobowiązań w menu Raporty - Należności i zobowiązania.

    • Opiekun - opiekun kontrahenta, przypisanie opiekunów umożliwi późniejsze zestawienia sprzedaży z podziałem na opiekunów. Dostępne tylko w wersji MAXI i PRO.

    • Cecha 1, Cecha 2 - dowolna dodatkowa informacja o kontrahencie, która może służyć jako kryterium do grupowania kontrahentów i wystawionych dla nich faktur

  • WYDRUKI

    • Język - język którym posługuje się kontrahent. Jeśli posiadamy wersję MAXI lub PRO to będziemy mogli wystawiać faktury eksportowe oraz przypomnienia i wezwania do zapłaty tłumaczone automatycznie na określony tutaj język.

    • Płatność od daty - czy przy nieuregulowanych płatnościach ma się pojawiać informacja:

      • wystawienia - np. DO ZAPŁATY 200,00 zł PRZELEWEM do dnia 24-09-2012 (14 dni od daty wystawienia)

      • otrzymania - np. DO ZAPŁATY 200,00 zł PRZELEWEM w ciągu 14 dni od daty otrzymania

      UWAGA. Jeśli pole to pozostawimy puste, to dokument zostanie wydrukowany zgodnie z parametrem Płatność od daty określonym na zakładce Wydruk w definicji tego dokumentu.

    • Makiety - jeśli dla tego kontrahenta chcemy drukować dokumenty w innej formie niż dla pozostałych kontrahentów, np. na stałe dodatkowa kolumna z wagą towaru lub dodatkowa uwaga, możemy przygotować odpowiednie makiety dla poszczególnych rodzajów dokumentów i przypisać je do tego kontrahenta. Dostępne tylko w wersji MAXI i PRO.

  • RESTRYKCJE - restrykcje nałożone na obroty z tym kontrahentem związane z nieterminowymi płatnościami (patrz NALEŻNOŚCI I ZOBOWIĄZANIA - Restrykcje w obrotach). Faktury, z których wynikają nałożone restrykcje, można łatwo sprawdzić w okienku [image] Windykacja.

    • Obsługa warunkowa - jeszcze kontrahenta obsługujemy, ale już zwracamy uwagę na jego przeterminowane płatności. Kontrahent z takimi restrykcjami jest wyróżniony na liście kontrahentów szarym kolorem. Jeśli w trakcie wystawiania nowej faktury wybierzemy go jako nabywcę, pojawi się informacja o opisanych niżej zastrzeżeniach:

      • Z powodu - program sam podstawia tu wyjaśnienie, w zależności od konfiguracji restrykcji może to być zwłoka w płatnościach, wystawione przypomnienie o płatnościach lub wystawiona i niezapłacona nota odsetkowa

      • Inny powód - inny dowolny powód wpisany ręcznie, np. informacja o nierzetelności kontrahenta uzyskana od zaprzyjaźnionej firmy

    • Nie obsługiwać - tego kontrahenta już nie obsługujemy, do czasu uregulowania zaległych płatności. Kontrahent z takimi restrykcjami jest wyróżniony na liście kontrahentów czarnym kolorem. Wystawienie temu kontrahentowi nowej faktury będzie niemożliwe - pojawi się komunikat zawierającym opisane niżej zastrzeżenia:

      • Z powodu - program sam podstawia tu wyjaśnienie, w zależności od konfiguracji restrykcji może to być zwłoka w płatnościach, wystawione wezwanie do zapłaty, wystawiona i niezapłacona nota odsetkowa

      • Inny powód - inny powód wpisany ręcznie, np. zaległość za faktury wystawione przed rozpoczęciem pracy z programem

      • Jednak obsługujemy - jeśli mimo np. wystawionego wezwania do zapłaty chcemy nadal obsługiwać tego kontrahenta

    Modyfikacja pól Inny powód i Jednak obsługujemy jest dozwolona w zależności od ustawienia parametru Zmiana restrykcji w prawach dostępu w danej grupie użytkowników

  • RR - dane dotyczące dowodu osobistego rolnika ryczałtowego niezbędne do wystawienia faktury RR. Zakładka dostępna tylko jeśli korzystamy z wersji programu umożliwiającej obsługę magazynu i w danych firmy na zakładce Ustawienia - Magazyn włączymy pole Faktury RR.

  • FK - dane dotyczące kont, na których będą księgowane dokumenty wystawione dla/od tego kontrahenta w trakcie exportu danych do programu [image] (patrz EKSPORT DANYCH). Zakładka dostępna tylko jeśli prowadzimy pełną księgowość - w danych firmy na zakładce Dane pole Rozliczenia ustawione na pełna księgowość (FK).

    • Konto odbiorcy - rozrachunkowe konto odbiorcy (np. 201-123)

    • Konto dostawcy - rozrachunkowe konto dostawcy (np. 202-123)

    • Konto sprzedaży - domyślne konto sprzedaży, czyli (np. 701)

    • Konto zakupów - domyślne konto zakupów (np. 310)

  • AKCYZA (patrz SPRZEDAŻ - Akcyza wyrobów węglowych). Dostępna tylko w wersji MAXI i PRO.

  • UDOSTĘPNIANIE - parametry umożliwiające temu kontrahentowi zdalny dostęp do programu przez moduł WWW.

    • Dostęp przez moduł WWW - włączenie dostępu

    • Login, Hasło - identyfikator i hasło używane do logowania

Dla kontrahentów stałych możemy również określić dodatkowe cechy, służące nam później do [image] F4 wyfiltrowania z listy wszystkich kontrahentów:

  • Dostawca - zaznaczamy, że dany kontrahent jest dostawcą

  • Odbiorca - odbiorca

    • Uprawniony do odwr. obc. VAT - odbiorca uprawniony do zakupów z odwrotnym obciążeniem VAT, tzn. takich, dla których podatnikiem VAT jest nabywca (zgodnie z art. 17 ust. 1 pkt 7 ustawy o VAT)

  • Inny - dowolne własne kryterium wyboru kontrahentów

  • UE - z takim kontrahentem prowadzimy transakcje wewnątrzwspólnotowe (unijne). Dostępne tylko w wersji MAXI i PRO.

Poprawę wpisanych danych, np. po to żeby zmienić dane adresowe kontrahenta, umożliwia przycisk [image] lub klawisz F6.

Możliwe jest również usunięcie kontrahenta [image] z listy (klawisz Del), ale tylko w przypadku, gdy dany kontrahent nie został przypisany do żadnego dokumentu.

W razie potrzeby możemy klikając w odpowiednie ikony szybko uzyskać pełną informację dotyczącą aktywności danego kontrahenta:

  • Rozrachunki - szczegółowa ewidencja płatności, czyli tego co kontrahent powinien nam zapłacić (albo my jemu jeśli to nasz dostawca) i tego co zostało zapłacone

  • Windykacja - szczegółowa ewidencja wystawionych temu kontrahentowi przypomnień, wezwań oraz not odsetkowych.

W wersji MAXI i PRO dostępne są dwie dodatkowe ikony:

  • Osoby - biblioteka osób pracujących u kontrahenta wraz z danymi adresowymi

  • Kontakty - ewidencja kontaktów (patrz CRM - Kontakty).

Jeśli korzystamy z mechanizmu danych dedykowanych, to wybierając z menu podręcznego (prawy przycisk myszy lub klawisz F3) pozycję Ceny dedykowane możemy określić lub sprawdzić ceny dedykowane obowiązujące dla tego kontrahenta na wybrane asortymenty lub grupy asortymentowe. Natomiast jeżeli chcemy danemu kontrahentowi indywidualnie zdefiniować pewne cechy dedykowane, które będziemy następnie wypełniać dla sprzedawanych mu asortymentów, to należy wypełnić zakładkę Dedykowane. Dostępne tylko w wersji MAXI i PRO.

Jeśli korzystamy z mechanizmu integracji modułów, to wybierając z menu podręcznego (prawy przycisk myszy lub klawisz F3) pozycję Odczytaj konta rozrachunkowe możemy ze zintegrowanego programu R2fk pobrać konta rozrachunkowe poszczególnych kontrahentów. Dostępne tylko jeśli prowadzimy pełną księgowość - w danych firmy na zakładce Dane pole Rozliczenia ustawione na pełna księgowość (FK).

Możliwe jest szybkie wyszukanie danego kontrahenta [image] Ctrl F7 poprzez wpisanie skrótu nazwy (lub fragmentu danych), będąc w oknie z listą kontrahentów. Pojawi się okienko Szukaj, w którym przy pierwszym poszukiwaniu musimy określić, jakie pola ma brać pod uwagę przy wyszukiwaniu (Szukaj po). Najczęściej jest to Skrót nazwy, Dane lub NIP (pole NIP1 umożliwia wyszukanie nipu bez kresek), ale nic nie stoi na przeszkodzie, żeby wyszukać kontrahenta po numerze telefonu lub uwagach. Kursor automatycznie ustawi się na właściwej pozycji. Żeby wyszukać kolejnego kontrahenta z tym samym skrótem (lub fragmentem danych) - należy wcisnąć Ctrl L.

Dodatkowa funkcja [image] F4 określa uporządkowanie kontrahentów na liście: alfabetycznie wg skrótu nazwy lub według numeru NIP. Tu również możemy ograniczyć kontrahentów do samych odbiorców lub dostawców, kontrahentów z nałożonymi odpowiednimi restrykcjami bądź do kontrahentów stałych. Shift F4 umożliwia szybkie przełączenie pomiędzy kontrahentami stałymi lub wszystkimi.

W bibliotece kontrahentów dostępne są następujące wydruki [image] F2:

  • Koperty - adresowanie kopert dla jednego lub wybranych kontrahentów. Określamy:

    • Drukarka - wybieramy drukarkę, na której chcemy zaadresować koperty

    • Rozmiar - wybieramy typ koperty z listy kopert obsługiwanych przez wybraną wyżej drukarkę

    • Ustawienia - jakie dane mają być wydrukowane na kopercie, do wyboru mamy dane Nadawcy i dane Adresata

    • Zakres - czy drukować tylko kopertę dla bieżącego kontrahenta wybrana pozycja czy dla wszystkich kontrahentów wszystkie pozycje

    • Umowa z pocztą - jeśli mamy podpisaną umowę z pocztą na wysyłanie listów bez konieczności naklejania znaczków, wpisujemy numer, datę i inne dane tej umowy (Shift Enter - nowa linia), po czym zaznaczamy Drukuj oraz Tylko do odczytu, żeby zabezpieczyć się przed przypadkowymi zmianami opisu umowy. Wpisany tekst będzie się drukował w prawym górnym rogu koperty.

  • Naklejki adresowe - jeśli chcemy wydrukować adresy kontrahentów na papierze samoprzylepnym w formie naklejek. Drukują się adresy wszystkich kontrahentów, chyba że przed wydrukiem podświetlimy wybranych (Shift á lub Shift â) i tylko ich pokażemy w oknie (Ctrl +).

  • Zgoda na e-Faktury - druk formularza z wyrażeniem zgody na wysyłanie dokumentów w formie elektronicznej. Jest to wydruk makietowy, więc w razie potrzeby można go samodzielnie zmienić (menu Ustawienia - Makiety dokumentów).

  • Potwierdzenia sald - seryjny wydruk potwierdzeń sald dla wszystkich kontrahentów posiadających nieuregulowane płatności. Przed wydrukiem określamy w okienku Potwierdzenia sald:

    • Salda na dzień - podajemy dzień, na który mają być obliczone drukowane salda

    • Drukować tylko wtedy, gdy:

      • salda są niezerowe - jeżeli chcemy drukować potwierdzenia sald tylko dla tych kontrahentów, którzy mają jakieś nieuregulowane płatności na podany dzień

      • są jakieś płatności w danym roku - potwierdzenie wydrukowane zostanie tylko dla tych kontrahentów, którzy mają jakieś nieuregulowane płatności na podany dzień bądź uregulowaną płatność powstałą w danym roku i przed dniem podanym w parametrze "Salda na dzień".

      • zawsze - jeżeli chcemy drukować potwierdzenia sald dla wszystkich kontrahentów w kartotece

    • Tekst "Na dobro nasze/wasze" - możliwość zmiany stron nasze/wasze na wydruku potwierdzenia sald

      • jednakowy na częściach A i B

      • zamienione strony na części B.

    Potwierdzenie salda dla wybranego konrahenta możemy wydrukować w oknie Rozrachunki. Wydruk ten można wykonać na drukarce igłowej w trybie znakowym (patrz ROZPOCZĘCIE PRACY - Okno główne - Przegląd wydruku - Wydruki znakowe).

  • Lista Kontrahentów - lista kontrahentów zawierająca nazwę, dane, nip, telefon i uwagi

  • Obroty magazynowe - rozbudowany raport umożliwiający wydrukowanie obrotów magazynowych związanych z danym kontrahentem

  • Sprzedaż - pozycje dokumentów - pozycje z dokumentów sprzedaży (faktury, paragony) wystawionych dla tego kontrahenta

  • Wydania - pozycje dokumentów - pozycje z dokumentów WZ wystawionych dla tego kontrahenta

  • Zakup - pozycje dokumentów - pozycje z dokumentów PZ wystawionych dla tego kontrahenta

  • Wydruk listy - lista wszystkich kontrahentów zawierająca kolumny aktywne w oknie Kontrahenci

  • Wydruk pozycji - zebrane w jednym miejscu wszystkie dane kontrahenta.


Korzystanie z bazy GUS

BIBLIOTEKI - Kontrahenci
ch

Zamiast wpisywać ręcznie dane nowych kontrahentów możemy je wyszukać w internetowej bazie firm prowadzonej przez GUS i skopiować automatycznie do biblioteki kontrahentów.

W tym celu należy w oknie Kontrahenci nacisnąć przycisk [image] Znajdź firmę w internetowej bazie GUS (REGON).

W otwartym w ten sposób oknie Znajdź firmę w GUS wpisujemy NIP, REGON lub KRS szukanej firmy (w zależności od określonego niżej kryterium Szukaj wg).

Kolejny krokiem jest podanie wymaganego przez GUS kodu weryfikacyjnego w polu Wpisz kod z obrazka.

Jeśli wpisaliśmy prawidłowy kod, to możemy:

  • Wstaw - utworzyć nowego kontrahenta i wstawić do niego wyszukane dane

  • Pokaż - sprawdzić dane wyszukanej firmy

Jeśli chcemy, aby domyślnym sposobem tworzenia kontrahentów było kopiowanie z bazy GUS, zaznaczamy pole Nowy kontrahent zawsze z GUS. Przy tworzeniu nowego kontrahenta (kliknięcie w przycisk [image] lub naciśnięcie klawisza Ins) w oknie Kontrahenci nastąpi automatyczne otwarcie okna Znajdź firmę w GUS.

Przycisk Format adresu [image] określa sposób składania danych adresowych z elementów takich jak: Nazwa, Ulica, Miasto itp.

UWAGI:

  1. Jeśli pokazany kod weryfikacyjny jest nieczytelny, można za pomocą przycisku Pokaż inny obrazek wygenerować nowy kod.

  2. Kod weryfikacyjny podajemy jednorazowo przy pierwszym wyszukiwaniu. Przy kolejnych wyszukiwaniach nie będzie on wymagany.

  3. Jeśli podamy numer NIP firmy, na której aktualnie stoimy w oknie Kontrahenci, to kliknięcie przycisku Wstaw nie spowoduje utworzenie nowego kontrahenta lecz wpisanie wyszukanych danych do bieżącego kontrahenta.


Zmiana danych adresowych

BIBLIOTEKI - Kontrahenci

Jeżeli kontrahent, który już wcześniej został wprowadzony do biblioteki, zmieni dane adresowe, to poprawiamy je w polu Nazwa i adres. Przy akceptacji wprowadzonych zmian program poprosi o potwierdzenie, czy chcemy zapamiętać dotychczasowy adres w historii adresów tego kontrahenta.

Odpowiadamy TAK, dzięki temu we wszystkich dokumentach wystawionych do momentu zmiany adresu będą widoczne dane adresowe kontrahenta aktualne w momencie wystawienia dokumentu (czyli nie ulegną zmianie). Nowy adres będzie uwzględniany na wszystkich nowych dokumentach (wystawionych po zmianie adresu).

Odpowiedź Nie należy wybrać tylko wtedy, jeśli nie wystawiono jeszcze żadnych dokumentów z tym kontrahentem lub wystawiono, ale okazało się, że adres był błędny i dokumentów tych nie wyeksportowano jeszcze do programu księgowego. W takim wypadku zmieniony adres będzie od razu uwzględniony we wszystkich wystawionych do tej pory dokumentach.

Jeśli kontrahent ma jakieś adresy zapamiętane w historii adresów, to obok pola Nazwa i adres widoczny jest pasek narzędziowy umożliwiający przeglądanie tych adresów:

Poszczególne przyciski umożliwiają:

  • sprawdzenie poprzedniego adresu wraz z okresem jego obowiązywania
  • sprawdzenie następnego adresu wraz z okresem jego obowiązywania
  • powrót do aktualnego adresu, [image] oznacza, że pokazany jest ostatni (czyli aktualny) adres
  • usunięcie adresu z historii adresów (pod warunkiem, że nie jest wykorzystany w żadnym wprowadzonym dokumencie).


Grupy kontrahentów

BIBLIOTEKI - Kontrahenci

Biblioteka grup kontrahentów umożliwia grupowanie kontrahentów wg dowolnego kryterium. Grupowanie kontrahentów przydatne może być później do różnego rodzaju zestawień i analiz.

Po przypisaniu kontrahentów do poszczególnych grup możemy sporządzić zestawienia sprzedaży (lub zakupów) z podziałem na grupy. W definicji zestawienia należy wybrać w polu Z podziałem na pole NabywcaGrupa (źródło danych Faktury i Faktury - pozycje) lub DostawcaGrupa (źródło danych PZ i Pz - pozycje).

Grupa jest również jednym z kryteriów przy tworzeniu Zestawienia należności i zobowiązań w menu Raporty - Należności i zobowiązania.


Osoby

BIBLIOTEKI - Kontrahenci

Okno OSOBY to ewidencja wszystkich osób reprezentujących kontrahenta, z którymi się kontaktujemy. Oprócz funkcji "książki telefonicznej" z telefonami poszczególnych pracowników kontrahenta, biblioteka osób jest wykorzystywana w module CRM w oknie KONTAKTY do określania osoby, z którą nastąpił kontakt. Zastosowanie znajduje również na fakturach, gdy chcemy podać imię i nazwisko osoby odbierającej fakturę (okno FAKTURY, zakładka Inne, pole Odebrał).

Biblioteka osób jest dostępna tylko w wersjach Maxi i PRO.

Oprócz imienia i nazwiska oraz danych kontaktowych możemy również wprowadzić:

  • Stanowisko - z biblioteki stanowisk wybieramy stanowisko, na jakim pracuje dana osoba

  • Uwagi - dowolne uwagi

  • Prowadzący - kto z użytkowników programu zajmuje się zwykle kontaktami z daną osobą.


Opiekunowie

BIBLIOTEKI - Kontrahenci

Biblioteka opiekunów (dostępna tylko w wersji MAXI i PRO) umożliwia powiązanie kontrahentów z opiekunami. Opiekunem może być dosłownie opiekun klienta, czyli nasz pracownik zajmujący się kontaktami i obsługą tego klienta. Może to być również nasz przedstawiciel handlowy, sprzedający towar temu klientowi. Powiązanie z opiekunami jest przydatne do rozliczania opiekunów z obrotów uzyskanych z danym kontrahentem.

Opiekun przypisany do kontrahenta będzie się domyślnie podstawiał do faktury wystawianej temu kontrahentowi (zakładka Inne). W razie potrzeby można go na fakturze zmienić na innego opiekuna.

Po przypisaniu opiekunów możemy sporządzać zestawienia sprzedaży z podziałem na opiekunów. W definicji zestawienia należy wybrać w polu Z podziałem na pole Opiekun (źródło danych Faktury lub WZ - pozycje).

Pole Opiekun można również wykorzystać w oknie Faktury jako kryterium selekcji [image] +/- do podświetlenia faktur wystawionych wybranemu opiekunowi.


Asortymenty

BIBLIOTEKI

Klikając w oknie głównym w przycisk [image] wejdziemy do okna z asortymentami. Biblioteka asortymentów jest jednym z głównych okien programu, czyli może być niezależnie otwarta obok innych głównych okien, na przykład faktur. Dzięki temu mamy cały czas bezpośredni wgląd we wszystkie dane asortymentów i możemy szybko odszukać na przykład ich cenę sprzedaży.

Listę asortymentów możemy przygotować sobie wcześniej, niezależnie od wprowadzanych faktur (PZ, WZ, itd.), ale możemy również wprowadzać asortymenty bezpośrednio podczas sporządzania dokumentów.

W bibliotece asortymentów figurować muszą wszystkie asortymenty, z których chcemy korzystać na różnych dokumentach. Asortymenty (szczególnie opisy usług), występujące tylko na jednej fakturze, można wpisać bezpośrednio na fakturze bez konieczności wprowadzania ich do biblioteki (patrz SPRZEDAŻ - Wystawianie faktur - Pozycje).

Wprowadzając nowy asortyment na listę (Ins, [image]) określamy następujące dane:

  • Nazwa - nazwa asortymentu, składa się z 2 części, druga część służy do wprowadzania długich opisowych nazw (szczególnie istotna dla usług), jeśli w części opisowej nie ma nic, na fakturach drukowana jest pierwsza część, w przeciwnym wypadku drukowana jest część opisowa, przejście do nowej linii w części opisowej umożliwia Shift Enter

  • Indeks - indeks przydatny jest gdy operujemy dużą ilością asortymentów, gdyż o wiele łatwiej jest wyszukać z listy asortyment podając jego krótki indeks cyfrowy np. 1200 niż wpisywać jego nazwę np. zeszyt w kratkę 60 kartek. Jako indeks możemy też np. wpisać kod kreskowy asortymentu i dzięki temu korzystać z wyszukiwania asortymentów przy pomocy czytnika kodów kreskowych. Przy małej liczbie asortymentów można się indeksem w ogóle nie zajmować, będzie się wtedy nadawał automatycznie jako kolejny numer.

  • J.m. - wybieramy z biblioteki jednostkę miary

  • Rodzaj - towar, produkt, usługa. Jeśli prowadzimy magazyn, to dla towarów i produktów będą ewidencjonowane stany magazynowe, tzn. nie da się ich sprzedać, jeśli nie ma ich aktualnie w magazynie. Usług nie można przyjąć do magazynu, ale można je wpisywać na Pz, wówczas będą się one sumowały wartościowo z pozycjami "magazynowymi", dzięki czemu uzyskamy prawidłowe rozrachunki z dostawcą i możliwość automatycznego zaksięgowania faktury zakupu w programie księgowym. Ponadto pole to ma znaczenie przy eksporcie faktur do programu księgowego (wpływa na opis zdarzenia gospodarczego oraz na wysokość opodatkowania jeśli firma rozlicza się w formie ryczałtowej ewidencji przychodów). W wersji z obsługą magazynu nie można zmienić tego pola w asortymentach użytych już na jakimś dokumencie.

  • PKWiU - wybieramy z biblioteki pozycję Polskiej Klasyfikacji Wyrobów i Usług 2008, określająca stawkę VAT, którą opodatkowana jest sprzedaż tego asortymentu. Jeśli asortyment podlega stawce 23%, wybieramy pozycję - (myślnik).

  • Vat% - stawka Vat ustawiona w bibliotece PKWiU

  • Stały - należy zakreślić w przypadku, gdy asortyment będzie się często pojawiał na fakturach i innych dokumentach. Stałe asortymenty można później wyfiltrować na liście ustawiając właściwości [image] F4 okna (lub w szybki sposób kombinacją klawiszy Shift F4).

Asortymentom stałym określamy dodatkowe dane:

  • Ceny

    • Obliczanie marży

      • Marża ind. - marża indywidualna. Zaznaczamy jeśli chcemy, aby ten asortyment miał obliczane marże i ceny sprzedaży w inny sposób niż wszystkie asortymenty. Globalny, czyli obowiązujący wszystkie asortymenty, sposób obliczania marż i cen sprzedaży określony jest w konfiguracji programu (menu główne Ustawienia - Konfiguracja).

      • Przeliczenia - dostępne tylko jeśli wyżej określiliśmy marże indywidualne

        • marża -> cena - ustawiamy tę opcję jeśli najistotniejsza jest dla nas marża. Dla każdego rodzaju cen określamy (w tabelce obok) marżę procentową w stosunku do (Marża od) ceny nabycia lub ceny ewidencyjnej. Ceny sprzedaży obliczą się same. Jeśli w polu Marża od wybierzemy cenę nabycia, to wraz ze zmianą tej ceny w trakcie kolejnych przyjęć tego asortymentu będą automatycznie przeliczane ceny sprzedaży tak, żeby zachować zadaną przy asortymencie marżę.

        • cena -> marża - ustawiamy jeśli najważniejsze są dla nas ceny, a marże traktujemy tylko informacyjnie. Marże wyliczą sie same jako stosunek cen sprzedaży do ceny nabycia lub ceny ewidencyjnej.

      • Marża - sposób obliczania marży określony w ustawieniach firmy (zakładka Ustawienia - Ogólne - Marża (patrz SPRZEDAŻ - Konfiguracja)). Pole tylko do odczytu.

      • Marża od - podstawa do wyliczenia marży. Dostępne tylko jeśli wyżej określiliśmy marże indywidualne.

        • c.nabycia - cena nabycia. Marża będzie wyliczana w stosunku do ceny nabycia.

        • c.ewidenc. - cena ewidencyjna. Marża będzie wyliczana w stosunku do ceny ewidencyjnej.

      • C.nab.netto/brutto - ceny nabycia netto/brutto. Podstawia się automatycznie w momencie przyjęcia towaru do magazynu. Możemy je wstępnie wypełnić ręcznie, nie czekając na dokumenty przyjęcia. Jeśli ustawiliśmy Przeliczenia na marża -> cena, a pole Marża od na c.nabycia, to w momencie zmiany ceny nabycia przeliczą się automatycznie ceny sprzedaży tak, żeby zachować zadane marże.

      • C.ewidenc. - cena ewidencyjna. Wypełniamy jeśli chcemy określać ceny sprzedaży na podstawie marż (Marża od) w stosunku do np. cen katalogowych, a nie do cen nabycia. Cenę ewidencyjną możemy łatwo ustawić dla wszystkich asortymentów korzystając z opisanej niżej funkcji menu podręcznego (prawy klawisz myszy) Ustaw cenę ewidencyjną. Z cen ewidencyjnych oraz wartości wg cen ewidencyjnych możemy korzystać w oknach "Zestawienia - Pozycje PZ/faktur/WZ/MM" oraz w oknie "Stan magazynu". Dostępne są w nich kolumny "C.ewid." oraz "W.ewid.". "C.ewid." to cena ewidencyjna danego asortymentu, a "W.ewid." to wartość pozycji wg ceny ewidencyjnej.

    • Ceny sprzedaży

      • Precyzja - ile cyfr po przecinku mają ceny sprzedaży (2 lub 4) tego asortymentu. 4 cyfry są przydatne np. przy refakturowaniu opłat za energię elektryczną.

      • Waluta - waluta cen sprzedaży. Ceny sprzedaży możemy określić w walucie innej niż PLN. Dzięki temu możemy ustalić cennik na wszystkie asortymenty np. w EUR. W momencie zmiany kursu możemy wywołać funkcję Przelicz ceny walutowe dostępną w menu pomocniczym wywoływanym przez naciśnięcie prawego klawisza myszy na liście asortymentów. Funkcja ta przeliczy wg zadanego kursu ceny złotówkowe wszystkich asortymentów, w których wybrano określoną walutę cen sprzedaży. Z cen sprzedaży określonych w walucie można korzystać zarówno na fakturach krajowych jak i eksportowych. Na faktury krajowe wystawiane w PLN będą podstawiane z asortymentu ceny złotówkowe (przeliczone wcześniej w asortymencie z cen walutowych wg zadanego kursu), a na faktury zagraniczne, bądź krajowe ale wystawiane w walucie obcej, będą podstawiane z asortymentu ceny walutowe. Walutowe ceny sprzedaży dostępne są tylko w wersji Maxi i PRO po włączeniu w danych firmy na zakładce Ustawienia - Sprzedaż pola Walutowe ceny sprzedaży.

      • Kurs - kurs wg którego zostaną obliczone ceny złotówkowe na podstawie cen walutowych. Pole dostępne tylko jeśli wybrana waluta jest inna niż PLN (w wersji MAXI i PRO).

      • Ceny - można określić trzy rodzaje cen sprzedaży. Nazwy standardowych rodzajów cen możemy zmienić wg własnego uznania np. na detal, półhurt i hurt, korzystając z polecenia menu głównego Ustawienia - Konfiguracja - Asortymenty. W trakcie wystawiania faktury można łatwo wybrać właściwą cenę sprzedaży - pole Rodzaj na zakładce Pozycje. Ceny netto-brutto przeliczają się wzajemnie wg podstawy określonej w menu głównym Ustawienia - Konfiguracja - Asortymenty - Podstawa. Program udostępnia również mechanizm danych dedykowanych umożliwiający określenie różnych cen sprzedaży na ten sam asortyment sprzedawany różnym kontrahentom.

  • Inne

    • Grupa - wybieramy z biblioteki grupę, do której należy ten asortyment. Grupa umożliwia analizowanie sprzedaży i zakupów przy pomocy zestawień.

    • Ilość - domyślna ilość podstawiana na fakturze przy sprzedaży tego asortymentu; przyśpiesza wystawienie faktury

    • Ilość na palecie, Ilość palet - jeśli handlujemy całymi kontenerami (samochodami, tirami) danego asortymentu, możemy określić ile jednostek tego asortymentu mieści sie na jednej palecie. Po wpisaniu w polu Ilość ilości jednostek mieszczącej się w jednym samochodzie obliczy się Ilość palet mieszczących się w tym samochodzie. Pola te mają charakter wyłącznie informacyjny. Nie ma możliwości sprzedaży/przyjęć w paletach.

    • Waga - tylko dla towarów i produktów. Waga jednostkowa w kg tego asortymentu tzn. ile waży jedna jednostka miary. Dzięki wadze jednostkowej można określić wagę towaru wystawionego na konkretnej pozycji faktury lub na całej fakturze (kolumna Waga w oknie z fakturami) - dotyczy to również dokumentów przyjęcia, wydania i przesunięcia.

    • KGO - jednostkowy koszt gospodarowania odpadami zawarty w cenie

    • Www - strona www z opisem tego asortymentu. Jeśli np. handlujemy jakimś towarem, który jest dokładnie opisany na stronie internetowej producenta, to możemy tu wpisać jej adres i dzięki przyciskowi [image] szybko ją otworzyć. Ten sam przycisk dostępny jest również w menu podręcznym (prawy klawisz myszy) na liście asortymentów.

    • Indeks1, Indeks2 - dodatkowe indeksy asortymentowe.

    • Tekst dodatk. - tekst dodatkowy, w którym można wpisać tagi określające okres wystawienia faktury (np. {Okres} - miesiąc, rok wystawienia faktury, {M} - miesiąc wystawienia faktury itp., pełna lista tagów jest dostępna w menu po naciśnięciu prawego klawisza myszy w tym polu). Po wstawieniu takiego asortymentu na pozycję faktury tagi są tłumaczone na odpowiednie zwroty uzależnione od daty wystawienia faktury. Tekst dodatkowy z przetłumaczonymi tagami podstawia się do pola Nazwa c.d., dzięki temu zostanie wydrukowany na fakturze pod nazwą asortymentu. Z tekstu dodatkowego można również korzystać we wzorcach faktur powtarzalnych. W takim przypadku tagi będą tłumaczone na właściwy tekst dopiero w momencie wystawienia faktury na podstawie takiego wzorca. Analogicznie działa pole Tekst dodatkowy w bibliotece uwag.

    • Kod CN - kod asortymentu wg klasyfikacji CN. Kod ten jest wymagany, jeżeli asortyment jest wyrobem węglowym objętym akcyzą (patrz opis biblioteki CN oraz SPRZEDAŻ - Akcyza wyrobów węglowych).

    • PKWiU 2004 - wybieramy z biblioteki pozycję Polskiej Klasyfikacji Wyrobów i Usług, określająca stawkę VAT, którą opodatkowana jest sprzedaż tego asortymentu. Jeśli asortyment podlega stawce 22%, wybieramy pozycję - (myślnik).
      UWAGA. Ta pozycja dotyczy biblioteki PKWIU 2004 obowiązującej do końca 2010 roku. Od 2011 korzystamy z biblioteki PKWiU 2008 dostępnej w polu PKWiU obok nazwy asortymentu.

    • Odwrotne obciążenie - towar wymieniony w załączniku 11 do ustawy o VAT, dla którego podatnikiem VAT jest nabywca (zgodnie z art. 17 ust. 1 pkt 7 ustawy o VAT)

    • Vat% - stawka Vat ustawiona w bibliotece PKWiU

  • FK - jeśli chcemy eksportować wystawione faktury i PZ do programu finansowo-księgowego R2fk z wyszczególnieniem przychodów/kosztów związanych z poszczególnymi asortymentami znajdującymi sie na fakturze, określamy każdemu asortymentowi:

    • Konto sprzedaży - numer konta z grupy "7"

    • Konto zakupów - numer konta z grupy "3", wykorzystywane do księgowania zakupu po stronie Wn i/lub RW po stronie Ma. W koncie zakupów możemy używać symbolu [M] oznaczającego numer konta magazynu, na który jest przyjmowana dana pozycja (lub w przypadku RW wydawana). Czyli możemy tu wpisać np. [M]-123 albo wręcz samo [M].

    • Konto kosztów - numer konta z grupy "4", wykorzystywane do księgowania RW po stronie Wn

    Zakładka FK widoczna jest tylko jeśli w danych firmy, na zakładce Dane w polu Rozliczenia wybrano wartość pełna księgowość (FK).

Poprawę wpisanych danych [image] umożliwia klawisz F6.
UWAGA. Przy poprawie należy być bardzo ostrożnym, gdyż spowoduje ona poprawę asortymentu we wszystkich (dotychczasowych) dokumentach, na których figuruje ten asortyment. Dlatego też, zamiast zmieniać nazwę asortymentu (bo np. się zmieniła lub już tego asortymentu nie używamy) należy wprowadzić nowy asortyment z nowymi danymi, pozostawiając dotychczasowe dane bez zmian.

Możliwe jest również usunięcie asortymentu [image] z listy (klawisz Del), ale tylko w przypadku, gdy dany asortyment nie został użyty na żadnym dokumencie.

W menu podręcznym dostępnym po kliknięciu prawym klawiszem myszy w tabelkę na zakładce Lista (również klawisz F3) dostępne są funkcje:

  • Stan magazynu - lista dostaw składających się na stan bieżący tego asortymentu. Ta sam funkcja dostępna jest bezpośrednio z paska narzędziowego w górnej części okienka.

  • Dane dedykowane - ewidencja danych dedykowanych obowiązujących na ten asortyment dla poszczególnych kontrahentów.

  • Kasa fiskalna (patrz SPRZEDAŻ - Urządzenia fiskalne).

  • Otwórz stronę WWW - otwiera przeglądarkę internetową z ustawioną w adresie stroną wpisaną w danych o asortymencie (pole Www na zakładce Inne).

  • Przelicz ceny walutowe - przeliczanie cen sprzedaży określonych w zadanej walucie wg podanego kursu. Jeśli mamy określony cennik w walucie obcej, to w ten sposób możemy go w odpowiednim dla nas momencie uaktualniać. Może to być kurs podany ręcznie lub wybrany średni kurs NBP - w zależności od ustawienia w danych firmy na zakładce Ustawienia-Sprzedaż pola wg średniego kursu NBP.

  • Ustaw cenę ewidencyjną - ustawia cenę ewidencyjną jako cenę nabycia netto lub wybraną cenę sprzedaży netto lub brutto. Dzięki temu można wydrukować dokumenty magazynowe (PZ, WZ, PR+, PR-) w odpowiednich cenach ewidencyjnych.

Dodatkowa funkcja [image] F4 umożliwia:

  • określenie uporządkowania asortymentów na liście alfabetycznie wg nazwy lub według indeksu - Uporządkowanie

  • wyfiltrowania asortymentów spełniających odpowiednie kryteria - Filtr:

    • Magazyn - w kolumnie Stan na zakładce Lista pokazywane są stany bieżące towarów znajdujących się w wybranym tu magazynie. Jeśli pole jest puste (po naciśnięciu klawiszy Delete lub Backspace) w kolumnie Stan widzimy łączne stany ze wszystkich magazynów.

    • Aktualnie na stanie

      • Tak - na liście asortymentów będą się znajdować tylko te, które są aktualnie w wybranym magazynie

      • Nie - na liście asortymentów będą się znajdować tylko te, których nie ma aktualnie w wybranym magazynie

      • Kiedyś - na liście asortymentów będą się znajdować tylko te, które kiedykolwiek były na stanie w wybranym magazynie

      • Nigdy - na liście asortymentów będą się znajdować tylko te, których nigdy nie było na stanie w wybranym magazynie

      • Wszystkie - naciskając klawisz Delete lub Backspace usuwamy dotychczasowe kryterium wpisane w tym polu, co oznacza, że na liście asortymentów będą się znajdować wszystkie asortymenty, bez względu na to czy są aktualnie w wybranym magazynie czy ich nie ma.

    • Stały/Niestały - stałe, niestałe lub wszystkie asortymenty. Shift F4 umożliwia szybkie przełączenie pomiędzy asortymentami stałymi lub wszystkimi.

    • TPU - na liście będą widoczne zgodnie z zaznaczeniem: towary, produkty lub usługi.

Szybkie wyszukanie asortymentu możliwe jest [image] Ctrl F7 poprzez wpisanie fragmentu nazwy. Pojawi się okienko Szukaj, w którym przy pierwszym poszukiwaniu musimy określić, jakie pola ma brać pod uwagę przy wyszukiwaniu (Szukaj po). Najczęściej jest to Nazwa lub Indeks. Kursor automatycznie ustawi się na właściwej pozycji. Żeby wyszukać kolejny asortyment z tą samą nazwą (lub indeksem) - należy wcisnąć Ctrl L.

Menu drukowania [image] (F2) udostępnia przydatne wydruki:

  • Cennik - cennik asortymentów

  • Cennik - grupy - jak wyżej, tylko że z podziałem na grupy

  • Cennik dedykowany - asortymenty - cennik dedykowany dla konkretnego asortymentu

  • Cennik dedykowany - grupy - cennik dedykowany dla grupy asortymentów

  • Cennik dedykowany - nabywcy - cennik dedykowany dla konkretnego nabywcy

  • Metki - zestawienie wybranych asortymentów w postaci metek asortymentowych

  • Obroty magazynowe - rozbudowany raport umożliwiający wydrukowanie obrotów magazynowych w wybranym okresie wg różnych kryteriów

  • Sprzedaż - pozycje dokumentów - pozycje z dokumentów sprzedaży (faktury, paragony), na których figuruje dany asortyment

  • Stan magazynu - rozbudowany raport umożliwiający wydrukowanie stanu magazynu (bieżącego lub historycznego na zadany dzień) wg różnych kryteriów

  • Wydania - pozycje dokumentów - pozycje z dokumentów WZ, na których figuruje dany asortyment

  • Zakup - pozycje dokumentów - pozycje z dokumentów PZ, na których figuruje dany asortyment

  • Wydruk listy - lista wszystkich dokumentów zawierających się w aktualnym oknie

  • Wydruk pozycji - wydruk szczegółowych informacji na temat konkretnej pozycji asortymentowej.

Opisane wyżej zestawienia wykonywane są na podstawie przgotowanej wcześniej definicji. Korzystając z polecenia menu głównego Ustawienia - Definicje zestawień wywołujemy okno DEFINICJE ZESTAWIEŃ, w którym możemy poprawić [image] (F6) definicję istniejącego zestawienia lub utworzyć [image] (Ins) definicję zupełnie nowego zestawienia odpowiadającego naszym specyficznym potrzebom (patrz INSTRUKCJA ADMINISTRATORA - PARAMETRYZACJA SYSTEMU - Definicje zestawień).


Jednostki miary

BIBLIOTEKI - Asortymenty

Jednostki miary to pomocnicza biblioteka do wpisywania nazw jednostek miary wykorzystywanych w asortymentach.

W bibliotece jednostek dostępne są standardowe funkcje:

  • Ins [image] - dopisanie pozycji do biblioteki

  • F6 [image] - poprawa danych już istniejącej pozycji

  • Del [image] - wykasowanie pozycji z biblioteki.

UWAGA. Przy poprawie należy być bardzo ostrożnym, gdyż spowoduje ona poprawę jednostki miary we wszystkich (dotychczasowych) asortymentach, do których jest przypisana ta jednostka. Dlatego też, zamiast zmieniać nazwę jednostki (bo np. się zmieniła lub już z tej jednostki nie korzystamy), należy wprowadzić nową jednostkę, pozostawiając dotychczasowe dane bez zmian.


Grupy i kategorie

BIBLIOTEKI - Asortymenty

Grupy asortymentowe służą do analizowania sprzedaży (i zakupów). Dzięki nim możemy np. sporządzić zestawienie sprzedaży poszczególnych grup (w oknie Faktury) lub cennik z podziałem na grupy (w oknie Asortymenty). Biblioteka grup jest dostępna z menu Okna - Biblioteki - Grupy lub bezpośrednio z biblioteki asortymentów.

Jeśli mamy niewiele asortymentów, grupami można się w ogóle nie zajmować.

Natomiast jeśli mamy dużo asortymentów i zależy nam na wielopłaszczyznowych analizach, możemy dodatkowo przypisać każdą grupę do różnych kategorii i sporządzać, korzystając ze statystyki, analizy sprzedaży z podziałem na te kategorie (patrz ZESTAWIENIA I STATYSTYKI - Statystyka). Kolumny z kategoriami (Kategoria1, Kategoria2) można włączyć standardową funkcją [image] Ctrl F4. Po ustawieniu się na kolumnie z kategorią wybieramy konkretną kategorię z biblioteki kategorii (menu Okna - Biblioteki - Kategorie). Biblioteka kategorii zawiera wszystkie kategorie, bez względu na to czy będziemy z nich korzystać jako Kategoria1 czy Kategoria2.

Kategorie 1 i 2 są można traktować jako strukturę hierarchiczną Kategoria2->Kategoria1->Grupa np.:

Asortyment | Grupa | Kategoria1 | Kategoria2
chleb zwykły | chleb | pieczywo | spożywcze
chleb "5 ziaren" | chleb | pieczywo | spożywcze
jabłko krajowe | jabłka | owoce | spożywcze
jabłko importowane | jabłka | owoce | spożywcze
bateria R6 | baterie | elektryczne | przemysłowe
bateria R6 Duracell | baterie | elektryczne | przemysłowe
patelnia 20cm | patelnie | agd | przemysłowe
patelnia 20cm teflon | patelnie | agd | przemysłowe

Można je również traktować jako przekroje w różnych płaszczyznach np.:

Asortyment | Grupa | Kategoria1 | Kategoria2
chleb zwykły | chleb | pieczywo | podstawowe
chleb "5 ziaren" | chleb | pieczywo | lux
jabłko krajowe | jabłka | owoce | podstawowe
jabłko importowane | jabłka | owoce | lux
bateria R6 | baterie | elektryczne | podstawowe
bateria R6 Duracell | baterie | elektryczne | lux
patelnia 20cm zwykła | patelnie | agd | podstawowe
patelnia 20cm teflon | patelnie | agd | lux

W bibliotekach grup i kategorii dostępne są standardowe funkcje:

  • Ins [image] - dopisanie pozycji do biblioteki

  • F6 [image] - poprawa danych już istniejącej pozycji

  • Del [image] - wykasowanie pozycji z biblioteki.

Wybierając z menu podręcznego (prawy przycisk myszy lub klawisz F3) pozycję Dane dedykowane możemy określić rabaty obowiązujące na tę grupę asortymentową dla poszczególnych kontrahentów.

UWAGA. Przy poprawie należy być bardzo ostrożnym, gdyż spowoduje ona poprawę grupy we wszystkich (dotychczasowych) asortymentach, do których jest przypisana ta grupa. Dlatego też, zamiast zmieniać nazwę grupy (bo np. się zmieniła lub już z tej grupy nie korzystamy) należy wprowadzić nową grupę, pozostawiając dotychczasowe dane bez zmian.


PKWiU

BIBLIOTEKI - Asortymenty

Biblioteka PKWiU zawiera wybrane elementy z Polskiej Klasyfikacji Wyrobów i Usług wraz z odpowiadającymi im stawkami podatku VAT. Bibliotekę należy uzupełnić samodzielnie wpisując do niej sukcesywnie pozycje z PKWiU związane z asortymentami, które są w sprzedaży w naszej firmie.

Dzięki bibliotece można je łatwo wyszukać i wykorzystać w kolejnych asortymentach.

Od roku 2011 obowiązuje biblioteka PKWiU 2008, wcześniej obowiązywała bibloteka PKWiU 2004.

Obie biblioteki PKWiU są dostępne w menu Okna - Biblioteki - PKWiU lub bezpośrednio z biblioteki asortymentów.

Dla asortymentów opodatkowanych stawką podstawową (do końca 2010 - 22%, od 2011 - 23%) podawanie numeru PKWiU nie jest wymagane. Asortymentom takim przypisujemy "sztuczną" pozycję PKWiU o numerze - (myślnik) i stawce 23% (do końca 2010 - 22%).

W bibliotece PKWiU dostępne są standardowe funkcje:

  • Ins [image] - dopisanie pozycji do biblioteki

  • F6 [image] - poprawa danych już istniejącej pozycji

  • Del [image] - wykasowanie pozycji z biblioteki.

UWAGI:

  1. Przy poprawie należy być bardzo ostrożnym, gdyż spowoduje ona poprawę nr PKWiU we wszystkich (dotychczasowych) asortymentach, do których jest przypisana ta pozycja PKWiU. Zmiana stawki Vat będzie uwzględniona przy ewentualnej poprawie istniejących już faktur, na których jest asortyment, przypisany do zmienianej pozycji PKWiU.

  2. Przechodząc na nowe stawki VAT w 2011 nie zmieniamy stawek w dotychczasowej bibliotece PKWiU 2004 lecz określamy je w bibliotece PKWiU 2008.


CN

BIBLIOTEKI - Asortymenty

CN jest pomocniczą biblioteką zawierającą klasyfikację CN dla sprzedawanych asortymentów (tylko w wersji MAXI i PRO). Wypełnienie tej biblioteki jest konieczne w przypadku, gdy korzystamy z opcji związanych z ewidencją akcyzy wyrobów węglowych (patrz SPRZEDAŻ - Akcyza wyrobów węglowych).

W bibliotece kodów CN dostępne są standardowe funkcje:

  • Ins [image] - dopisanie pozycji do biblioteki

  • F6 [image] - poprawa danych już istniejącej pozycji

  • Del [image] - wykasowanie pozycji z biblioteki.


Nazwy asortymentu

BIBLIOTEKI - Asortymenty

Na wydrukach faktur w językach obcych mogą znajdować się nazwy asortymentów w języku polskim i dodatkowo w języku obcym.
Do przygotowania nazw w językach obcych służy okno Nazwy asortymentu wywoływane klawiszami Ctrl+Enter lub przyciskiem [image] znajdującym się obok głównej nazwy asortymentu w oknie Asortymenty.

Nazwy obcojęzyczne są wybierane w zależności od języka faktury i drukowane poniżej nazwy polskiej.

W bibliotece nazw asortymentu dostępne są standardowe funkcje:

  • Ins [image] - dopisanie pozycji do biblioteki

  • F6 [image] - poprawa danych już istniejącej pozycji

  • Del [image] - wykasowanie pozycji z biblioteki.


Magazyny

BIBLIOTEKI

Jeśli włączymy moduł MAGAZYN, program będzie umożliwiał niezależne ewidencjonowanie towarów znajdujących się w różnych magazynach. Jako "magazyn" możemy traktować każdy z magazynów, w których przechowujemy towar, jak również dowolną inną lokalizację towarów, dla której chcemy prowadzić osobną ewidencję - np. wzorcownia, handlowiec (a w zasadzie jego samochód, którym rozwozi towar), serwis itp.

Przyjmując towar określamy do jakiego ma trafić magazynu, wydając towar określamy z jakiego magazynu ma pochodzić. Możemy również przesuwać towary między różnymi magazynami. Każda z tych operacji modyfikuje ilość towaru w magazynie. W każdej chwili możemy sprawdzić i wydrukować stany towarów w poszczególnych magazynach, z wyszczególnieniem cen nabycia, dat przyjęcia, dostawców, kontraktów itp.

Jeśli prowadzimy małą firmę możemy korzystać z jednego magazynu (standardowo o nazwie "Główny", ale oczywiście można tę nazwę zmienić). Magazyn ten będzie się automatycznie podstawiał we wszystkich wymaganych polach w trakcie wystawiania dokumentów.

Biblioteka magazynów dostępna jest z pozycji menu głównego Okna - Biblioteki - Magazyny lub bezpośrednio z dokumentów PZ, faktura, WZ, MM i innych.

Listę magazynów możemy przygotować przed rozpoczęciem wystawiania dokumentów. Nowy magazyn możemy również wprowadzić bezpośrednio podczas wystawiania PZ lub MM.

Korzystając z funkcji Kolumny okna [image] Ctrl F4 możemy dodać do listy aktywnych kolumn:

  • Konto zak. - jeśli korzystamy z automatycznego księgowania do systemu R2fk, możemy każdemu magazynowi przypisać konto, które będzie wykorzystywane w trakcie księgowania pozycji PZ oraz RW.

  • Symbol - symbol magazynu używany w układzie numeru we współdzielonych definicjach dokumentów (patrz DEFINICJE DOKUMENTÓW - Współdzielenie definicji)

W bibliotece magazynów dostępne są standardowe funkcje:

  • Ins [image] - dopisanie pozycji do biblioteki

  • F6 [image] - poprawa danych już istniejącej pozycji

  • Del [image] - wykasowanie pozycji z biblioteki.

W menu drukowania (klawisz F2) dostępna jest pozycja Etykiety, która ma za zadanie ułatwić inwentaryzację oraz współpracę z kolektorem danych. Umożliwia ona wydrukowanie zestawienia magazynów w postaci etykiet z kodami kreskowymi. Etykiety można przykleić w odpowiednich magazynach lub w dowolnym innym miejscu np. na automacie sprzedającym itp. Kod kreskowy drukowany jest w formacie Code39 plus.
UWAGA. Jeśli skaner czyta tylko zwykły Code39 to w nazwie magazynu należy unikać małych liter oraz znaków specjalnych, bo zamiast małych liter zeskanują się litery poprzedzone znacznikami +, np. zamiast a będzie +A, zamiast b będzie +B itd., a zamiast np. / zeskanuje się /O.

Wygląd, rozmiar i zawartość etykiety zależy od wybranej makiety. Makietę określamy w menu głównym Ustawienia - Makiety dokumentów. Możemy wybrać makietę proponowaną przez program. Jeśli jednak nie odpowiada ona naszym potrzebom, możemy ją dowolnie zmodyfikować lub utworzyć własną makietę. Wyboru właściwej makiety dokonujemy korzystając z przycisku Ustaw jako aktywną w oknie Makiety dokumentów.

Program proponuje makietę umożliwiającą wydruk 10 wierszy po 2 etykiety na jednej kartce formatu A4.

Przed wydrukiem określamy:

  • Zakres

    • Magazyny - jakie magazyny zostaną uwzględnione na wydruku

    • Prefiks - symbol używany do identyfikacji poszczególnych rodzajów dokumentów, który ma na celu ułatwić współpracę z kolektorem danych. Jeśli nie korzystamy z kolektora wówczas pole prefiks pomijamy.

  • Definicja

    • Wysokość kodu (w pikselach), Liczba etykiet w wierszu - ustawiamy odpowiednio do wybranej makiety

    • Kod kreskowy na podstawie pola

      • Nazwa - nazwy magazynu, czyli kolumny o nazwie Magazyn

      • Symbol - symbolu magazynu, czyli kolumny o nazwie Symbol.

Wydruk etykiet dostępny jest tylko w wersji PRO.


Kontrakty

BIBLIOTEKI

Jeśli chcemy kontrolować obrót wybraną partią towarów możemy skorzystać z biblioteki kontraktów (dostępna tylko w wersji MAXI i PRO).

Kontrakty można traktować dosłownie jako np. umowę (kontrakt) podpisaną z jakimś dostawcą, w ramach której kupujemy od niego przez jakiś czas towar w specjalnych cenach. Można je również traktować jako dowolne inne kryterium podziału do celów analitycznych.

Kontrakty przypisuje się do towaru w momencie sporządzania dokumentu PZ czyli przyjęcia do magazynu. Kilka PZ może mieć określony ten sam kontrakt. Każda dostawa z takiego PZ pamięta określony w nim kontrakt. Dzięki temu, możemy w każdej chwili sprawdzić ile towarów z tego kontraktu zostało jeszcze w magazynie (okno Stan Magazynu) oraz ile i z jakim zyskiem (lub stratą) do tej pory sprzedaliśmy (zestawienie w menu głównym Raporty - Rozliczenie kontraktów).

Kontrakty tworzy się wpisując ich nazwy do biblioteki kontraktów.

Bibliotekę możemy uzupełnić przed rozpoczęciem pracy (menu Okna - Biblioteki - Kontrakty) lub dopisywać odpowiednie pozycje w trakcie wystawiania PZ.

Prowadzenie biblioteki kontraktów i ich rozliczanie jest opcjonalne. Standardowo po zainstalowaniu programu obsługa kontraktów jest wyłączona. Można ją włączyć w ustawieniach bieżącej firmy [image] na zakładce Ustawienia - Magazyn w polu Kontrakty.

W bibliotece kontraktów dostępne są standardowe funkcje:

  • Ins [image] - dopisanie pozycji do biblioteki

  • F6, zakładka Pozycja, [image] - poprawa danych już istniejącej pozycji

  • Del [image] - wykasowanie pozycji z biblioteki.


Uwagi

BIBLIOTEKI

Biblioteka uwag ułatwia wprowadzanie powtarzających się informacji, które powinny się pojawić na fakturze lub innych dokumentach.

Zamiast np. pisać na każdej fakturze od nowa uwagę o naliczaniu odsetek za nieterminowe płatności, wpisujemy taką uwagę raz do biblioteki, a na fakturze wstawiamy gotową pozycję z biblioteki uwag.

Wprowadzając uwagę, oprócz właściwej treści możemy określić również tekst dodatkowy. Można w nim wpisać tagi określające okres wystawienia faktury (np. {Okres} - miesiąc, rok wystawienia faktury, {M} - miesiąc wystawienia faktury itp., pełna lista tagów jest dostępna w menu po naciśnięciu prawego klawisza myszy w tym polu). Po wstawieniu takiej uwagi na fakturę tagi są tłumaczone na odpowiednie zwroty uzależnione od daty wystawienia faktury. Tekst dodatkowy z przetłumaczonymi tagami podstawia się do pola c.d. na zakładce Uwagi, dzięki temu zostanie wydrukowany na fakturze pod właściwą uwagą. Z tekstu dodatkowego można również korzystać we wzorcach faktur powtarzalnych. W takim przypadku tagi będą tłumaczone na właściwy tekst dopiero w momencie wystawienia faktury na podstawie takiego wzorca. Analogicznie działa pole Tekst dodatk. w bibliotece asortymentów.

Po wprowadzeniu uwag do biblioteki możemy określić reguły, powodujące automatyczne dołączanie określonych uwag do określonych faktur. Np. jeśli chcemy żeby uwaga o naliczaniu odsetek była dodawana do każdej niezapłaconej faktury, korzystamy z polecenia menu głównego Ustawienia - Konfiguracja - Faktury - Domyślne uwagi i przypisujemy odpowiednią uwagę jak na ekranie poniżej.

Bibliotekę możemy uzupełnić przed rozpoczęciem pracy lub dopisywać odpowiednie pozycje w trakcie wystawiania faktur.

W bibliotece uwag dostępne są standardowe funkcje:

  • Ins [image] - dopisanie pozycji do biblioteki

  • F6, zakładka Pozycja, [image] - poprawa danych już istniejącej pozycji

  • Del [image] - wykasowanie pozycji z biblioteki.

UWAGA. Przy poprawie należy być bardzo ostrożnym, gdyż spowoduje ona poprawę uwagi we wszystkich (dotychczasowych) dokumentach, na których występuje ta uwaga. W przypadku zmiany treści uwagi lepiej jest zrobić nową uwagę, pozostawiając dotychczasową pozycję bez zmian.


Oddziały

BIBLIOTEKI

Biblioteka oddziałów umożliwia prowadzenie odrębnych rejestrów sprzedaży VAT dla poszczególnych oddziałów firmy (miejsc prowadzenia sprzedaży).

Jeśli chcemy korzystać z takiej możliwości należy:

  • wpisać do biblioteki wszystkie oddziały, dla których chcemy prowadzić odrębne rejestry vat

  • w oknie Definicje dokumentów utworzyć dla każdego oddziału osobny rodzaj dokumentu typu Faktura, któremu na zakładce Zawartość w polu VAT-Oddział należy przypisać odpowiedni oddział

  • wystawiać faktury z poszczególnych oddziałów korzystając z odpowiedniego, zdefiniowanego wyżej, rodzaju dokumentów

  • przed wydrukiem rejestru sprzedaży VAT (w oknie Faktury nacisnąć F2 - Rejestr sprzedaży VAT) wybrać odpowiedni oddział.

W bibliotece oddziałów dostępne są standardowe funkcje:

  • Ins [image] - dopisanie pozycji do biblioteki

  • F6, zakładka Pozycja, [image] - poprawa danych już istniejącej pozycji

  • Del [image] - wykasowanie pozycji z biblioteki.


Biblioteki ogólne

BIBLIOTEKI

Program prowadzi bibliotekę urzędów skarbowych, a także pomocnicze biblioteki banków i kodów pocztowych. Biblioteki są wstępnie przygotowane przez producenta, co znacznie usprawnia pracę.

Biblioteki ogólne są wspólne dla wszystkich firm obsługiwanych w programie, tzn. jeśli będąc w jednej firmie wprowadzimy nowy bank na listę banków, będzie on również widziany po zmianie firmy.

Do bibliotek możemy się dostać poprzez menu główne (Okna - Biblioteki - Banki, Urzędy skarbowe, Kody pocztowe).

W bibliotece banków i urzędów skarbowych dostępne są standardowe funkcje:

  • Ins [image] - dopisanie pozycji do biblioteki

  • F6, zakładka Pozycja, [image] - poprawa danych już istniejącej pozycji

  • Del [image] - wykasowanie pozycji z biblioteki.


Banki

BIBLIOTEKI - Biblioteki ogólne

Biblioteka banków zawiera numery rozliczeniowe wszystkich banków w Polsce. Służy ona wyłącznie do celów pomocniczych, dzięki niej po wprowadzeniu numeru rachunku bankowego firmy lub rachunku bankowego kontrahenta automatycznie wyświetlona zostanie nazwa banku, w którym jest prowadzony dany rachunek.

Biblioteka banków jest wstępnie wypełniona przez producenta programu. Jeśli w bibliotece brakuje jakiegoś banku, należy dopisać go samodzielnie.

Wprowadzając nowy bank na listę (Ins, [image]) uzupełniamy:

  • Nazwa banku - nazwą tą posługujemy się w programie

  • Nr banku - jest to pierwszy człon numeru rachunku w tym banku.

Będąc w liście banków korzystamy ze standardowych funkcji dostępnych w bibliotekach.


Urzędy skarbowe

BIBLIOTEKI - Biblioteki ogólne

Biblioteka urzędów skarbowych jest pomocniczą biblioteką ułatwiającą wypełnianie przelewów podatkowych.

Biblioteka jest wstępnie wypełniona przez producenta programu i zawiera dane wszystkich urzędów oraz izb skarbowych. Dane te odpowiadają informacjom dostępnym na stronie internetowej Ministerstwa Finansów. Ze względu na fakt, że dane te mogły ulec zmianie od momentu powstania tej wersji programu, producent nie może zagwarantować, że są one w 100% aktualne.

Biblioteka zawiera adresy, telefony oraz numery rachunków bankowych, na które należy przelewać należności z tytułu podatków CIT, VAT, PIT i innych.

Poprawność danych możemy sprawdzić klawiszem F6 lub klikając [image].

Na liście urzędów skarbowych korzystamy ze standardowych funkcji dostępnych w bibliotekach.


Kody pocztowe

BIBLIOTEKI - Biblioteki ogólne

Bibliotekę kodów pocztowych wywołujemy z menu Okna - Biblioteki - Kody pocztowe. Umożliwia ona automatyczne określanie województwa, w którym mieści się siedziba kontrahenta, na podstawie kodu pocztowego wpisanego w danych kontrahenta.

Dzięki określeniu każdemu kontrahentowi województwa możemy w oknie z fakturami zdefiniować i sporządzić zestawienie sprzedaży z podziałem na województwa (w definicji zestawienia należy wybrać w polu Z podziałem na pole NabywcaWojew.), co da nam pogląd na strukturę geograficzną naszych odbiorców i może pomóc np. w planowaniu działań marketingowych. Oczywiście ma to sens tylko wtedy, gdy prowadzimy sprzedaż w całym kraju lub przynajmniej w kilku województwach.

Biblioteka jest przygotowana przez producenta programu. Użytkownik nie może jej modyfikować.


MAGAZYN

INSTRUKCJA UŻYTKOWNIKA

Moduł MAGAZYN umożliwia prowadzenie samodzielnej gospodarki magazynowej lub rozliczanie magazynu w połączeniu z działalnością handlową (czyli w połączeniu z modułem SPRZEDAŻ).

Najważniejsze funkcje i możliwości modułu magazynowego to:

  • przyjęcia do magazynu PZ, korekty przyjęć, faktury VAT RR

  • możliwość zdefiniowania dowolnych innych dokumentów (np. Zamówienie do dostawcy, PW) i określania ich zawartości

  • wiele magazynów, przesunięcia MM

  • wydania WZ

  • kontrola stanów magazynowych (FIFO, LIFO, konkretna dostawa), ilości z dokładnością do 4 cyfr po przecinku

  • automatyczne WZ do faktury

  • obliczanie marży i zysku, rozliczanie sprzedaży w cenach nabycia

  • filtrowanie asortymentów wg bieżących stanów magazynowych

  • kartoteki magazynowe

  • inwentaryzacja, protokoły rozbieżności PR+, PR- (dostępne tylko w wersji MAXI i PRO)

  • roczne lub miesięczne numerowanie dokumentów

  • dowolna liczba PZ korygujących do jednego PZ

  • ewidencjonowanie płatności do faktury zakupu, dowolna liczba rat, różne formy płatności (gotówka, przelew, czek, karta kredytowa, pobranie pocztowe, kompensata lub dowolne inne)

  • obsługa numerów seryjnych i kontraktów

  • możliwość pełnego dostosowania wyglądu wszystkich dokumentów do własnych potrzeb, łącznie z możliwością określenia specjalnych wzorów PZ i WZ dla poszczególnych kontrahentów

  • wysyłanie WZ e-mailem w formacie HTML lub PDF (podobnie jak wszystkich innych wydruków)

  • obsługa zleceń transportowych.

Moduł MAGAZYN jest dostępny po zakupieniu licencji na odpowiednią wersję programu.

Jeśli chcemy korzystać z modułu MAGAZYN, należy go wstępnie skonfigurować.

Po skonfigurowaniu możemy rozpocząć wykonywanie operacji magazynowych tj.:

  • przyjmować towar do magazynu (dokumenty PZ)

  • przesuwać towar do innego magazynu (dokumenty MM)

  • wydawać towar z magazynu (dokumenty WZ i RW).

Ewentualne brakujące rodzaje dokumentów można w każdej chwili samodzielnie zdefiniować.

Możemy również na bieżąco kontrolować stanu magazynu wszystkich lub wybranych asortymentów.


PRZYJĘCIA DO MAGAZYNU

MAGAZYN

Przyjęcie towarów do magazynu sprowadza się do wystawienia dokumentu przyjęcia PZ ("Przyjęcie Zewnętrzne") na podstawie faktury lub rachunku zakupu. Oprócz przyjęcia towaru do magazynu, PZ umożliwia również rozliczenie zobowiązań (płatności) związanych z zakupem towaru. Jeśli chcemy traktować PZ jako dokładne odpowiedniki faktur zakupu, to możemy wpisywać na PZ również usługi. Nie będą one oczywiście przyjmowane na magazyn. Będą się natomiast sumowały wartościowo z pozycjami "magazynowymi", dzięki czemu uzyskamy prawidłowe rozrachunki z dostawcą i możliwość automatycznego zaksięgowania faktury zakupu w programie księgowym.

Dokumenty PZ wprowadzamy w oknie PZ - Przyjęcia do magazynu, które możemy otworzyć klikając w oknie głównym w przycisk [image] .

W oknie PZ możemy również wprowadzić bilans otwarcia BO (początkowy stan magazynu w momencie rozpoczęcia pracy z programem) oraz dowolne inne zdefiniowane przez nas dokumenty przyjęcia np. PW (przyjęcie wewnętrzne).

Jeśli prowadząc do tej pory magazyn nie korzystaliśmy z dokumentów PZ, bo dowodem przyjęcia towaru do magazynu były dla nas po prostu faktury lub rachunki zakupu, możemy pozostać przy naszych przyzwyczajeniach. Wystawionych PZ nie musimy drukować, ewidencjonować ani zajmować się nimi w jakikolwiek inny sposób.

Przed przystąpieniem do wystawienia PZ należy wstępnie przygotować odpowiednie biblioteki.


Wystawianie PZ

MAGAZYN - PRZYJĘCIA DO MAGAZYNU

Przed wystawieniem PZ należy wybrać właściwy okres, obejmujący datę wystawienia PZ. W tym celu wybieramy z menu głównego Ustawienia - Bieżąca data i okres. Szybką zmianę okresu umożliwia klawisz F12.

Wystawiając [image] nowy dokument (Ins) najpierw określamy Rodzaj dokumentu, tzn. PZ, BO (bilans otwarcia) lub ewentualnie inny zdefiniowany w oknie Definicje dokumentów.

Po wybraniu rodzaju dokumentu wypełniamy następujące dane (przy niektórych rodzajach dokumentów program może nie wymagać wszystkich wymienionych pozycji, np. dla BO nie określamy dostawcy):

  • Numer - numer kolejny dokumentu, najlepiej nie wypełniać tego pola ręcznie - program automatycznie w momencie akceptacji dokumentu podstawi kolejny, unikalny numer. Dzięki temu, że numer jest nadawany dopiero w momencie akceptacji, dokumenty będą prawidłowo numerowane przy równoczesnym sieciowym wystawianiu kilku PZ przez różnych użytkowników programu. Pole Numer składa się z 2 części: białej i szarej, w części szarej pokazany jest pełny numer dokumentu, w układzie określonym w definicji tego rodzaju dokumentu, np. 11/01/14/PZ, a w części białej właściwy numer kolejny, czyli np. 11. Po dwukrotnym kliknięciu myszką w białą część pole Numer zmienia się na pole Układ umożliwiając zmianę układu numeru na inny niż określony w definicji dokumentu, np. jeśli z jakiegoś powodu chcemy zmienić pełny numer PZ z 11/01/14/PZ na 11/01/14/PZ/A:

    • klikamy dwukrotnie w białą część pola numer

    • w uzyskanym w ten sposób polu Układ wyłączamy przełącznik oznaczający zgodność układu numeru z definicją dokumentu

    • poprawiamy układ z #"/01/14/PZ" na #"/01/14/PZ/A"

    • zapamiętujemy zmiany akceptując cały PZ.

  • Data wystawienia - data wystawienia PZ.
    UWAGI:

    1. Data wystawienia musi mieścić się w wybranym okresie pracy (patrz ROZPOCZĘCIE PRACY - Okno główne - Bieżąca data i okres). Jeśli chcemy wystawić PZ z datą spoza wybranego okresu, musimy najpierw zmienić okres przeglądania. Inaczej program pokaże ostrzeżenie i nie pozwoli wprowadzić takiej daty.

    2. Data wystawienia musi być większa od daty zamknięcia (patrz ROZPOCZĘCIE PRACY - Okno główne - Bieżąca data i okres). Nie da się zatwierdzić nowego PZ z datą wystawienia należącą do zamkniętego okresu. Podobnie nie da się poprawić ani usunąć istniejącego już PZ, którego data wystawienia należy do zamkniętego okresu.

  • Do faktury - numer faktury (lub rachunku zakupu), do której sporządzamy ten PZ

  • Z dnia - data wystawienia faktury, do której sporządzamy ten PZ. Stanowi ona podstawę do określania terminu i dat płatności na zakładce Płatności.

  • Data sprz. - data sprzedaży, ustawia się na taką datę, jak data wystawienia, ale można ją zmienić na inną, zgodnie z datą sprzedaży widoczną na fakturze, do której sporządzamy ten PZ

  • Księg. - jak będzie księgowany ten dokument. Wpływa na domyślną stawkę VAT.

    • Z - Zakup - po przesłaniu do programu R2księga lub R2fk dokument zostanie zaksięgowany jako Z - zakup

    • B - Odwrotne obciążenie (zakup) - po przesłaniu do programu R2księga lub R2fk dokument zostanie zaksięgowany jako B - Odwrotne obciążenie (zakup). Dzięki temu zostanie prawidłowo ujęty w rejestrach zakupu i sprzedaży. Jeśli chcielibyśmy dedykować osobną serię dokumentów PZ wyłącznie do zakupów z "odwrotnym obciążeniem", należy w definicji dokumentów utworzyć nową definicję PZ z polem Księgowany jako ustawionym na B - Odwrotne obciążenie (zakup).

  • Do WZ, Z dnia - wypełniamy jeśli przyjęcie jest na podstawie WZ a nie faktury zakupu. Pola informacyjne, nie są drukowane na PZ.

  • Magazyn - wybieramy magazyn z biblioteki magazynów w zależności od tego, gdzie fizycznie znajdzie się towar przyjmowany tym PZ (patrz BIBLIOTEKI - Magazyny)

  • Dostawca - wybieramy dostawcę z biblioteki kontrahentów. Aby szybko wyszukać kontrahenta zaczynamy pisać w polu ze skrótem nazwy lub z numerem NIP (w zależności od tego czego szukamy). Jeśli kontrahent jeszcze nie istnieje w bibliotece, to możemy go wprowadzić klawiszem Ins (z rozwiniętej klawiszem â listy kontrahentów), możemy również przejść do pełnej biblioteki kontrahentów (klawisz F2 lub kliknięcie w [image]), żeby na przykład przejrzeć dane lub wyszukać po części danych. Jeśli otworzyliśmy okno z biblioteką kontrahentów i odnaleźliśmy w nim szukanego kontrahenta, można go szybko przypisać do PZ naciskając klawisze Alt Enter.
    Jeśli chcemy, program może podpowiadać na nowych dokumentach dostawcę z ostatnio wystawionego dokumentu. W tym celu należy zaznaczyć pole Podpowiadać dostawcę/nabywcę w konfiguracji programu (menu główne Ustawienia - Konfiguracja - Ogólne).

  • Kontrakt - jeśli chcemy kontrolować obrót towarem przyjętym na tym PZ, wybieramy kontrakt z biblioteki kontraktów (patrz BIBLIOTEKI - Kontrakty). Dostępne tylko w wersji MAXI i PRO.

  • Pozycje - wprowadzamy na PZ poszczególne asortymenty podając ich ilość i cenę jednostkową; istnieje kilka sposobów wprowadzania pozycji na PZ (patrz Pozycje)

  • Płatności - szczegółowe określenie i rozliczenie płatności związanych z tym PZ (patrz Płatności)

  • Stawki VAT

    • Netto, Vat i Brutto wg stawek VAT - sumy netto, vat i brutto wg stawek vat występujących na tym PZ. Sumy pokazane są w dwóch tabelkach. Górna, ciemnoszara, zawiera sumy wynikające z przeliczeń pozycji PZ. Dolna, jasnoszara, umożliwia ewentualną modyfikację tych sum tak, żeby odpowiadały dokładnie fakturze zakupu. Rozbieżności w kwotach pomiędzy PZ a fakturą zakupu mogą wynikać albo z błędów popełnionych przy wystawianiu faktury zakupu przez dostawcę, albo z przyjętego przez niego algorytmu sumowania wartości wg stawek. Program R2faktury liczy tak, że w zależności od ustawionej poniżej podstawy (Netto/Brutto) oblicza najpierw sumę np. netto dla każdej stawki vat, a potem na podstawie tej sumy oblicza łączne kwoty vat i brutto (nie sumuje ich z poszczególnych pozycji PZ). Może sie zdarzyć, że dostawca wystawiając fakturę stosował inny algorytm, tzn. sumował niezależnie kwoty netto, vat i brutto z poszczególnych pozycji PZ. Dostosowując kwoty w dolnej jasnoszarej tabelce do kwot z faktury zakupu, zapewnimy jej prawidłowe automatyczne księgowanie do programu księgowego oraz prawidłowe rozliczenie płatności.

    • Podstawa Netto/Brutto - informacja o sposobie przeliczania Vat na tym dokumencie. Ustawiamy podstawę na taką, wg której została wystawiona faktura zakupu, tzn. tak, żeby kwoty netto, vat i brutto z poszczególnych pozycji PZ odpowiadały dokładnie pozycjom faktury zakupu.

    • Kiedy rozliczyć - sposób rozliczenia vat, istotny przy automatycznym księgowaniu dokumentu zakupu w programie księgowym oraz wpływający na wydruk rejestru zakupu vat. Wybieramy jeśli ten dokument ma być księgowany w szczególny sposób. Jeśli ma być księgowany z domyślnym sposobem rozliczenia vat (np. od 2014 roku data otrzymania/sprzedaży), pozostawiamy to pole puste. Jeśli szczególny sposób rozliczania vat ma dotyczyć wszystkich dokumentów z danej definicji dokumentów, wybieramy go w analogicznym polu w oknie DEFINICJE DOKUMENTÓW na zakładce Zawartość.

    • Data rozliczenia - faktyczna data umieszczenia danej pozycji w rejestrze VAT i na deklaracji

    • Dostawca (rejestr VAT) - kontrahent występujący w rejestrze VAT, który może być różny od kontrahenta z pozycji Dostawca (inny płatnik, inny dostawca). Pole dostępne tylko dla firm, które jako formę rozliczenia wybrały pełna księgowość (FK).

  • Inne - dodatkowe informacje:

    • Wystawił - imię i nazwisko osoby wystawiającej PZ, podstawiane automatycznie z danych użytkownika zalogowanego do programu

    • Makieta - makieta wg której będzie wydrukowany ten dokument, określamy w szczególnych przypadkach, jeśli ma to być makieta inna niż standardowo używana dla tego typu dokumentów. Pole dostępne tylko w wersji MAXI i PRO.

  • Uwagi - wszelkie dodatkowe informacje, które mają być wydrukowane na PZ

    • Uwaga - wybieramy uwagę z biblioteki uwag, jeśli chcemy wpisać uwagę, która będzie przydatna również na innych PZ, a nie ma jej jeszcze w bibliotece, to na rozwiniętej liście uwag (klawisz â ) naciskamy klawisz Ins i wpisujemy uwagę do biblioteki

    • Uwaga c.d. - wpisujemy ciąg dalszy (związany tylko z tym konkretnym PZ) uwagi wybranej z biblioteki lub wpisujemy w całości uwagę charakterystyczną tylko dla tego PZ (tzn. taką której nie ma sensu wpisywać do biblioteki)

  • Notatki - wszelkie dodatkowe informacje związane z tym PZ, które nie będą drukowane na PZ, np. z kim się kontaktować w sprawie tego PZ, dlaczego dostaliśmy rabat w takiej a nie innej wysokości itp.; do wyboru mamy:

    • jedno duże opisowe pole, do którego można wpisać dowolny tekst

    • lub 10 pól po 10 znaków, do których możemy wpisywać wg ustalonego przez siebie systemu różne znaczniki. Notatki te mogą być później wykorzystane do szybkiego wyszukania lub sporządzenia zestawień PZ pogrupowanych wg notatek (pola N1...N10)

  • Transport - rozliczanie kosztów transportu (patrz Transport). Dostępne tylko w wersji MAXI i PRO po włączeniu w danych firmy na zakładce Ustawienia - Magazyn pola Transport.

  • FK, Księga, Ewidencja - dane związane z automatycznym księgowaniem tego dokumentu do programu księgowego (patrz MAGAZYN - PRZYJĘCIA DO MAGAZYNU - Eksport PZ do programu księgowego). Nazwa zakładki zależy od rodzaju rozliczeń ustawionego w oknie FIRMY na zakładce DANE.

    • Konto dostawcy - dla pełnej księgowości - przepisane z danych kontrahenta konto rozrachunkowe dostawcy, nie można go zmienić

    • Konto zakupów - dla pełnej księgowości - przepisane z danych kontrahenta domyślne konto zakupów, można je zmienić na dowolne inne

    • Data księgowania - dokument zostanie zaksięgowany z określoną tu datą wpisu. Jeśli data księgowania będzie pusta, dokument zostanie zaksięgowany z domyślną datą wpisu, czyli taką jak data wystawienia.

  • Rabat - rabat procentowy lub kwotowy (brutto), który udzielono nam do całego PZ; rabat kwotowy zamieniany jest de facto na rabat procentowy (z dokładnością do 4 cyfr po przecinku), który po zastosowaniu do przeliczenia wszystkich pozycji PZ, może spowodować nieznaczną zmianę wprowadzonej kwoty rabatu

  • Zablokowany - znacznik, określający czy pozycje z tego PZ są widoczne w oknie Stan magazynu, a co za tym idzie można na nich wykonywać operacje magazynowe (wydania, przesunięcia), czy też są zablokowane, tzn. przyjęte, ale jeszcze nie można na nich wykonywać operacji magazynowych. Standardowo w trakcie tworzenia nowego PZ znacznik Zablokowany jest automatycznie włączany. Oznacza to, że zanim nie zaakceptujemy całego PZ i nie odblokujemy go (przy akceptacji) towar na nim przyjęty nie może zostać wydany ani przesunięty. Istniejący już PZ, który został już odblokowany można ponownie zablokować, ale tylko jeśli pochodzący z niego towar jest jeszcze w całości w magazynie. Jeśli dodajemy do istniejącego już odblokowanego PZ nowe pozycje, to są one automatycznie blokowane do momentu zaakceptowania całego PZ.

    Znacznik Zablokowany umożliwia tworzenie zamówień do dostawcy. Jeśli chcemy korzystać z zamówień do dostawcy wystarczy je zdefiniować na bazie dokumentu Inny (zakup). Takie zamówienie wystawiamy analogicznie do zwykłego PZ, z tym że pozostawiamy je jako zablokowane. Po faktycznym otrzymaniu zamówionego towaru zamieniamy zamówienie na zwykły PZ (w polu Rodzaj dokumentu), modyfikujemy ewentualnie jego pozycje i akceptując cały PZ wyłączamy znacznik Zablokowany.

Przed zaakceptowaniem danych możemy sprawdzić pod tabelką z pozycjami:

  • Lp - liczba wprowadzonych pozycji

  • Waga [kg] - łączna waga wszystkich pozycji z dokumentu

  • Netto, Vat, Brutto - w polach ciemnoszarych - podsumowanie wartości netto, vat i brutto z wszystkich pozycji dokumentu, w polach jasnoszarych - miejsce na wprowadzenie wartości netto, vat, brutto takich jak na fakturze zakupu. Jeśli różnią się od wartości wyliczonych przez program, to trzeba również podać odpowiednie wartości na zakładce Stawki VAT.

Wprowadzone dane akceptujemy przyciskiem [image]. Do szybkiej akceptacji służy również klawisz PgDn.

UWAGA. Wprowadzanie danych może odbywać się tylko z klawiatury, bez użycia myszki. Przejście do kolejnego pola umożliwia Enter lub Tab, a zatwierdzenie całego okna Alt PgDn.

Poprawę danych [image] umożliwia klawisz F6, natomiast usunięcie [image] wpisu klawisz Del. Poprawa i usuwanie PZ są możliwe tylko wtedy, gdy okres nie jest zamknięty.

Datę zamknięcia (i okres przeglądania) ustawiamy w pozycji menu głównego Ustawienia - Bieżąca data i okres (F12).

Możliwe jest szybkie wyszukanie dowolnego dokumentu [image] Ctrl F7 poprzez wpisanie numeru PZ (lub nazwy dostawcy itp.). Pojawi się okienko Szukaj, w którym należy określić, jakie pola ma brać pod uwagę przy wyszukiwaniu (Szukaj po). Kursor automatycznie ustawi się na właściwej pozycji. Żeby wyszukać kolejną pozycję (np. z tym samym kontrahentem) - należy wcisnąć Ctrl L.

UWAGA. W polach, po których można wyszukiwać PZ znajdują się m.in. pola:

  • Numer - pełny nr dokumentu, np. 11/01/14/PZ

  • Nr - tylko nr kolejny, np. 11. Szukanie wg tego pola jest o wiele szybsze niż wg pola Numer.

We właściwościach okna [image] F4 można ustawić stały filtr na dokumenty spełniające zadane kryteria:

  • Zakup - tylko takie dokumenty, które dotyczą faktycznych zakupów (czyli bez BO, zamówień itp.).

  • Dokument - dokumenty jednego rodzaju (np. tylko BO)

  • Tylko własne - dotyczy dokumentów wystawionych ze współdzielonych definicji, w oknie będą dostępne tylko te, które wystawił aktualny użytkownik programu. W zależności od uprawnień nadanych użytkownikowi (pole Tylko własne dokumenty w uprawnieniach grupy użytkowników) będzie on mógł zmienić wartość tego parametru i przeglądać również współdzielone dokumenty wystawione przez innych użytkowników.

  • Księgowany jako - jak będzie księgowany ten dokument:

    • nieksięgowany - dokumenty nieksięgowane, np. Zamówienie, Inny zakup

    • Z - Zakup - po przesłaniu do programu R2księga lub R2fk dokument zostanie zaksięgowany jako Z - zakup

    • B - Odwrotne obciążenie (zakup) - po przesłaniu do programu R2księga lub R2fk dokument zostanie zaksięgowany jako B - Odwrotne obciążenie (zakup). Dzięki temu możemy łatwo wyfiltrować w oknie Pz faktury z odwrotnym obciążeniem.

  • Kontrahent - wszystkie PZ od określonego dostawcy

  • Magazyn - wszystkie PZ przyjęte do określonego magazynu

  • Kasa/Bank - dokumenty, które:

    • Tak - zostały zapłacone w całości i w całości zaksięgowane w kasie/banku

    • Częściowo - zostały częściowo zaksięgowane w kasie/banku

    • Nie - nie zostały w ogóle zaksięgowane w kasie/banku

  • Terminowy - dokumenty, które:

    • Tak - nie zostały zapłacone w dniu wystawienia

    • Nie - zostały zapłacone w dniu wystawienia.

Filtr [image] umożliwia wybranie dokumentów według dowolnych kryteriów, na przykład żeby wyróżnić wszystkie dokumenty, na których zastosowano rabat, możemy wywołać klawiszami +/- z klawiatury numerycznej.

Klawisz F2 [image] udostępnia różne wydruki (patrz MAGAZYN - PRZYJĘCIA DO MAGAZYNU - Wydruki).

W menu podręcznym dostępnym po kliknięciu prawym klawiszem myszy w tabelkę z PZ na zakładce Lista (również klawisze F3) dostępne są funkcje:

  • Eksport do programu R2księga/R2fk - umożliwia eksport dokumentów zakupu do programu księgowego. Ta sama funkcja jest dostępna na pasku narzędziowym w górnej części okna PZ.

  • Podświetl pozycje w oknie ASORTYMENTY - podświetla w oknie Asortymenty wszystkie asortymenty występujące na pozycjach bieżącego PZ. Dzięki temu po ustawieniu w oknie Asortymenty filtra na tylko podświetlone pozycje (Ctrl + z klawiatury numerycznej), możemy wydrukować listę (F2 - Lista) tych asortymentów w cenach sprzedaży po to, żeby na przykład ometkować nowo przyjęty towar. Przed wykonaniem tej funkcji należy wcześniej odświetlić w oknie Asortymenty wszystkie podświetlone pozycje (Ctrl N), aby upewnić się, że na liście podświetlonych pozycji będą rzeczywiście tylko te, które znajdują się na bieżącym PZ.

  • Przygotuj przelew - umożliwia przygotowanie przelewu z kwotą pozostającą do zapłaty z aktualnego PZ (opcja dostępna od wersji STANDARD):

    Po określeniu Daty przelewu oraz Nazwy rachunku bankowego, zostanie automatycznie utworzony przelew dostępny w oknie PRZELEWY. Przelew utworzony w ten sposób będzie miał wypełnione wszystkie dane. Wystarczy go wydrukować lub wyeksportować do systemu bankowego.

  • Noty korygujące - umożliwia wystawianie i drukowanie not w sytuacji, gdy otrzymamy od naszego dostawcy fakturę VAT, która ma niepoprawne dane nie związane z kwotami tej faktury (czyli np. błędne dane adresowe, pomyłkę w nazwisku itp)

  • Kontakty - dostępne tylko w wersji MAXI i PRO, ewidencja kontaktów z dostawcą z bieżącego PZ

  • Dodatkowe funkcje

    • Aktualizuj konta - przepisuje konto rozrachunkowe dostawcy z biblioteki kontrahentów do PZ oraz domyślne konto zakupów z biblioteki grup lub asortymentów na pozycje PZ. Patrz Eksport danych. Przydatne w pełnej ksiegowości jeśli:

      • w trakcie wystawiania PZ zmieniliśmy numer konta dostawcy lub konta zakupów na zakładce FK

      • po wystawieniu dokumentów zmieniliśmy numer konta dostawcy w bibliotece kontrahentów lub kont zakupów w bibliotece asortymentów lub grup.

      UWAGA: Funkcja dotyczy wszystkich dokumentów widocznych w oknie. Jeśli chcemy poprawić konto na jednym lub wybranych dokumentach, nalezy je podświetlić, przejść do trybu Tylko podświetlone i dopiero wtedy wywołać tę funkcję.

    • Aktualizuj ceny na PR+ - aktualizuje ceny na dokumencie PR+ kompensującym stan księgowy, aby osiągnąć zgodność ze stanem faktycznym.


Pozycje

MAGAZYN - PRZYJĘCIA DO MAGAZYNU - Wystawianie PZ

Wprowadzanie pozycji jest kluczowym elementem wystawiania PZ.

Pozycje można wpisywać na dwa sposoby:

  1. zalecany - bezpośrednio na PZ w tabelce na zakładce Pozycje

    • zalety:

      • szybkie wprowadzanie najpotrzebniejszych danych (asortyment, ilość, cena)

      • podgląd na bieżący stan asortymentów w momencie wyboru asortymentu

      • możliwość wprowadzenia wszystkich danych bezpośrednio z klawiatury (bez używania myszy)

    • wady:

      • brak lub utrudniony dostęp do pełnych informacji na temat pozycji (ceny i wartości netto/brutto przed i po rabacie, łączna waga przyjętych jednostek itp.)

  2. w dodatkowym oknie Pozycje, wywołanym przyciskiem

    • zalety:

      • pełna informacja dotycząca pozycji PZ

    • wady:

      • konieczność wywołania osobnego okna

      • utrudniony dostęp do bieżących stanów magazynowych.

W zależności od wybranego sposobu:

  1. zakładka Pozycje:

    • przechodzimy do tabelki z pozycjami znajdującej się na zakładce Pozycje

    • ustawiamy się w kolumnie Indeks lub Nazwa asortymentu i wywołujemy bibliotekę asortymentów naciskając klawisz Enter, klikając w przycisk [image] lub rozpoczynając pisanie indeksu lub nazwy szukanego asortymentu. Kolumna Indeks będzie dostępna jeśli włączyliśmy obsługę indeksów w ustawieniach - okno [image] FIRMY - F6 - Ustawienia - Ogólne - Indeksy. Po odszukaniu w oknie Asortymenty odpowiedniego asortymentu wybieramy go na PZ klawiszem Enter lub klikając w przycisk [image].
      UWAGA. Jeśli wystawiamy dokumenty z dużą liczbą pozycji, warto przed rozpoczęciem wystawiania PZ otworzyć okno Asortymenty (przycisk [image] w oknie głównym). Dzięki temu wybór asortymentu na pozycje dokumentu będzie dużo szybszy, gdyż program nie będzie przy każdej pozycji tracił czasu na otwieranie i zamykanie okna Asortymenty. Zamiast tego będzie się ono przełączało w tryb wyboru (w prawym górnym rogu okna pojawi się przycisk [image]), a po wybraniu asortymentu będzie wracać do normalnego trybu (zniknie przycisk [image]).

    • po wybraniu asortymentu wypełniamy (i zatwierdzamy Enter) kolejne kolumny:

      • Ile - wpisujemy odpowiednią ilość, domyślnie podpowiada się sugerowana ilość określona w bibliotece asortymentów

      • _C.netto - cena nabycia netto przed rabatem, domyślnie podpowiada się ostatnia cena nabycia tego asortymentu (zapamiętana automatycznie z poprzedniego PZ lub wpisana ręcznie w bibliotece asortymentów). Jeśli podstawą przeliczeń netto/brutto na tym dokumencie jest brutto, to zamiast _C.netto dostępna będzie w tym miejscu _C.brutto czyli cena nabycia brutto przed rabatem.

      • Rabat - rabat procentowy udzielany na tę pozycję; cena po rabacie jest przeliczana przy uwzględnieniu rabatu wpisanego do pozycji i rabatu określonego dla całego dokumentu, tzn. C.netto = _C.netto * (1-Rabat/100) * (1-RabatPZ/100). Oznacza to że jeśli np. w pozycji będzie rabat 20%, a w całym PZ 10%, to łączny rabat uwzględniony przy obliczeniu ceny będzie wynosił (1-(1-20/100)*(1-10/100))*100=28%, a nie, jak by się mogło wydawać na pierwszy rzut oka, 30%. Taki właśnie łączny rabat w wysokości 28% zostanie wydrukowany na PZ przy tej pozycji.

      • Nr seryjny - nr seryjny tej pozycji. Kolumna Nr seryjny będzie dostępna jeśli włączyliśmy obsługę numerów seryjnych w ustawieniach - okno [image] FIRMY - F6 - Ustawienia - Ogólne - Nr seryjne - Włączone.

    • wciśnięcie klawisza Enter w ostatniej kolumnie (Rabat albo Nr seryjny) spowoduje zatwierdzenie tej pozycji PZ i rozpoczęcie wprowadzania następnej pozycji. Rozpoczęcie wprowadzania nowej pozycji możemy również uzyskać naciskając klawisz Ins lub po ustawieniu się na ostatniej pozycji i naciśnięciu klawisza â.

    • dodatkowe kolumny oznaczone szarym kolorem zawierają głównie informacje tylko do odczytu, określone przez program na podstawie wprowadzonych wcześniej danych:

      • C.netto - cena netto po rabacie, uwzględnia zarówno rabat wpisany w tej pozycji jak i zbiorczy rabat od całego dokumentu

      • W.netto - wartość netto po rabacie

      • Nr dost. - numer dostawy, tylko do odczytu. Jest to unikalny numer nadawany przez program każdej pozycji PZ (tzw. dostawie) wprowadzonej w programie. Pozwala on później identyfikować taką dostawę i m.in. jej cenę nabycia w stanie magazynowym oraz na WZ. Nr dostawy jest nadawany chronologicznie w momencie rozpoczęcia tworzenia pozycji PZ. Jeśli zrezygnowano z zatwierdzenia jakiejś dostawy (pozycji PZ) lub usunięto istniejącą już dostawę, to jej numer przepada, tzn. nie będzie wykorzystany w kolejnych dostawach. Mogą w ten sposób powstać luki w numerowaniu dostaw. Występowanie takich luk nie stanowi nieprawidłowości w działaniu programu lecz jest efektem celowym, gdyż przyspiesza pracę programu, który nie musi marnować czasu na sprawdzanie ewentualnych luk i wyszukiwanie pierwszego wolnego numeru. W trakcie sieciowej pracy programu może się również zdarzyć, że nie będzie luk, ale kolejne numery dostaw będą występowały w różnych wystawianych w tym samym czasie PZ-ach. Takie zachowanie programu jest również celowe i nie świadczy o nieprawidłowej pracy.

      • C.brutto - cena brutto po rabacie, uwzględnia zarówno rabat wpisany w tej pozycji jak i zbiorczy rabat od całego dokumentu

      • W.brutto - wartość brutto po rabacie

      • tylko w wersji MAXI i PRO:

        • C.transp - jednostkowy koszt transportu, obliczony na podstawie zbiorczego kosztu transportu wpisanego na zakładce Transport

        • W.transp - całkowity koszt transportu dotyczący bieżącej pozycji

      • Marża% - marża pomiędzy aktualną ceną sprzedaży (pierwszą, drugą lub trzecią w zależności od ustawienia w menu Ustawienia - Konfiguracja na zakładce Asortymenty w polu Cena) a bieżącą ceną nabycia. W zależności od aktualnego ustawienia parametrów kosztów transportu marża może uwzględniać koszty transportu lub nie (dane firmy, zakładka Ustawienia - Magazyn, pole Zysk uwzględnia transport).

    • jeśli wprowadziliśmy już wszystkie pozycje i nie chcemy wprowadzać innych danych (płatności, uwagi, itp.), możemy od razu zaakceptować cały PZ naciskając klawisze Alt PgDn.

    • pod tabelką z pozycjami znajdują się jeszcze dodatkowe pola sumaryczne:

      • Lp - liczba pozycji wpisanych na tym PZ

      • Waga [kg] - łączna waga towarów z tego PZ

      • Netto, Vat, Brutto - sumy kwot netto, vat i brutto z wszystkich pozycji PZ. Kwoty te występują podwójnie:

        • w ciemnoszarych polach znajdują się wartości wyliczone automatycznie przez program. Nie można ich modyfikować. Sumowanie przeprowadzane jest w ten sposób, że najpierw są sumowane z wszystkich pozycji PZ kwoty będące podstawą przeliczeń vat, czyli w zależności od ustawienia pola Podstawa na zakładce Stawki VAT, albo netto albo brutto (z podziałem na stawki vat). Potem na podstawie tych sum obliczane są brakujące sumy vat i brutto lub netto.

        • w jasnoszarych podstawiają się takie same wartości jak powyżej, ale można je w razie potrzeby zmodyfikować tak, żeby odpowiadały kwotom z faktury zakupu (patrz opis dotyczący zakładki Stawki VAT). Dzięki takiemu dostosowaniu kwota zobowiązań (płatności) wynikająca z tego PZ, będzie odpowiadała dokładnie wartości brutto faktury zakupu. Zmienione wartości netto, vat i brutto muszą odpowiadać zmodyfikowanym sumom wg stawek vat określonym na PZ na zakładce Stawki Vat. To z kolei jest potrzebne do prawidłowego zaksięgowania tego PZ w programie księgowym.

  2. okno Pozycje:

    • klikamy w przycisk [image] lub naciskamy klawisze Alt C żeby otworzyć okno z pozycjami dokumentu:

    • wprowadzamy [image] Ins nową pozycję dokumentu

      wypełniając poszczególne pola:

      • Asortyment

        • Nazwa - wybieramy asortyment z listy asortymentów podając jego nazwę np. towar G.
          Jeśli odpowiedniego asortymentu nie ma w bibliotece, możemy go wprowadzić klawiszem Ins (z rozwiniętej klawiszem â listy asortymentów), możemy również przejść do pełnej biblioteki asortymentów klikając w napis [image] lub naciskając F2. Jeżeli pełna nazwa wybranego asortymentu jest dłuższa niż 1 linijka, to pojawi się ona w całości w szarym polu pod nazwą asortymentu.

        • Indeks - wybieramy asortyment z listy asortymentów podając jego indeks

        • J.m., Rodzaj, PKWiU, Vat% - pozostałe dane wybranego asortymentu (tylko do odczytu, można je zmienić tylko w bibliotece asortymentów)

      • Magazyn - określony na PZ magazyn, do którego przyjmujemy tę pozycję

      • Nr seryjny - nr seryjny tej pozycji. Pole Nr seryjny będzie dostępne jeśli włączyliśmy obsługę numerów seryjnych w ustawieniach - okno [image] FIRMY - F6 - Ustawienia - Ogólne - Nr seryjne - Włączone.

      • Netto - zakładka umożliwiająca wprowadzenie ilości (Ilość) oraz ceny netto przed rabatem (Cena) i rabatu dotyczącego tej pozycji (Rabat%). Na podstawie wprowadzonych wartości wyliczają się Wartość netto oraz Cena i Wartość netto po rabacie. Ponadto możemy od razu sprawdzić jaką marżę Marża% osiągniemy pomiędzy aktualną ceną sprzedaży Cena sprz. (pierwszą, drugą lub trzecią w zależności od ustawienia w menu Ustawienia - Konfiguracja na zakładce Asortymenty w polu Cena) a bieżącą ceną nabycia.

      • Brutto - analogicznie j.w., z tym że dotyczy cen i wartości brutto (zawierających podatek VAT)

      • Inne

        • Kontrakt - kontrakt, do którego należy ta pozycja, określony w oknie PZ. Dostępny tylko w wersji MAXI i PRO.

      • FK - tylko dla pełnej księgowości - zakładka umożliwiająca wprowadzenie numeru konta, na którym będzie księgowany zakup tej pozycji w programie finansowo-księgowym R2fk. Domyślnie numer jest przepisany z biblioteki asortymentów, biblioteki grup asortymentowych lub z PZ. Można go zmienić. Ten numer konta ma znaczenie tylko wtedy, jeśli dokumenty zostaną wyeksportowane z zaznaczonym parametrem Księguj każdą pozycję dokumentu osobno.

      • Nr dost. - nadawany automatycznie numer dostawy - patrz wyjaśnienie wyżej w opisie dotyczącym zakładki Pozycje.

      • Waga [kg] - łączna waga w kilogramach tej pozycji. Obliczana jako iloczyn ilości jednostek z tej pozycji PZ i określonej w bibliotece asortymentów wagi jednostkowej tego asortymentu (tzn. wagi jednej jednostki asortymentu).

    • po wprowadzeniu wszystkich danych zatwierdzamy całą pozycję klikając w przycisk OK lub naciskając klawisze Alt PgDn.

UWAGA. Nic nie stoi na przeszkodzie, żeby w zależności od potrzeb korzystać z kombinacji przedstawionych wyżej sposobów. Ze względu na łatwość i szybkość wprowadzania danych warto wprowadzać pozycje bezpośrednio w tabelce na zakładce Pozycje i korzystać z okna Pozycje tylko w razie potrzeby. Np. jeśli chcemy sprawdzić szczegółowe dane jakiejś pozycji ustawiamy się na niej w tabelce i naciskamy Alt F6 - wywołamy w ten sposób okno Pozycje w trybie edycji (poprawy) tej pozycji PZ. Podobnie, jeśli naciśniemy w tabelce klawisze Alt Ins, wywołamy okno Pozycje w trybie wprowadzania nowej pozycji. W obu przypadkach po akceptacji lub rezygnacji ze zmian okno Pozycje zostanie zamknięte i wrócimy do tabelki z pozycjami dokumentu.


Płatności - PZ

Płatności

MAGAZYN - PRZYJĘCIA DO MAGAZYNU - Wystawianie PZ

Program umożliwia szczegółowe określenie sposobu oraz formy płatności oraz pełne rozliczenie zobowiązań związanych z PZ.

Standardowo przy wystawianiu PZ, po wpisaniu pozycji dokumentu, ustawiana jest automatycznie domyślna forma i termin płatności PZ, określona przez:

  • indywidualną formę i termin płatności określone w danych dostawcy (w bibliotece kontrahentów na zakładce Warunki w danych tego dostawcy)

  • jeśli dostawca jest nieokreślony lub nie ma indywidualnych ustawień, to w zależności od parametru menu głównego Ustawienia - Konfiguracja - PZ - Przelew:

    • jeśli włączony, to dokument będzie się domyślnie ustawiał jako "Do zapłacenia przelewem w ciągu X dni" gdzie X to liczba dni określona parametrem Ustawienia - Konfiguracja - PZ - Przelew - Dni

    • jeśli jest wyłączony, to dokument będzie domyślnie "Zapłacony gotówką".

Jeśli domyślne ustawienie płatności nam odpowiada, możemy przy wystawianiu nowego dokumentu pominąć zakładkę Płatności. W przeciwnym wypadku ustalamy:

  • Termin, Dni - wprowadzamy termin rozliczenia w formie daty lub ilości dni od daty wystawienia

  • Jedna rata - przycisk umożliwiający połączenie kilku rozbitych wcześniej płatności na jedną zbiorczą

  • Dni zwłoki, Odsetki - informacja o przekroczeniu terminu płatności, wysokość odsetek nalicza się na podstawie ilości dni przekroczenia oraz ustawionej (w menu Ustawienia - Odsetki) procentowej wartości odsetek (patrz INSTRUKCJA ADMINISTRATORA - PARAMETRYZACJA SYSTEMU - Odsetki). Stojąc kursorem na poszczególnych ratach pokazywane są tu dni zwłoki i wysokość odsetek od bieżącej raty. Po kliknięciu w jakikolwiek element poza tabelką z ratami, pokażą się łączne odsetki od wszystkich rat oraz ilość dni zwłoki z najbardziej przeterminowanej raty.

W przypadku płatności ratalnych możemy ustalić wysokość i termin płatności każdej raty dokładnie tak jak ustalił nasz dostawca (ilość rat jest dowolna). Dla każdej raty wprowadzamy:

  • Rodzaj - określany automatycznie. Należy go traktować jako znak płatności, tzn.:

    • Ma (-) znak ujemny - to co my mamy zapłacić dostawcy

    • Wn (+) znak dodatni - to co dostawca ma nam zapłacić, np. w związku ze zwrotem na fakturze korygującej wystawionej przez dostawcę

  • Do zapłaty - wysokość raty podstawia się automatycznie jako sumaryczna wartość brutto PZ, po zmniejszeniu tej kwoty automatycznie utworzy się druga rata z dopełnieniem do wartości brutto PZ

  • Termin - termin płatności danej raty podstawia się automatycznie z ustalonego wcześniej (wyżej) terminu rozliczenia całości

  • Forma - formę zapłaty wybieramy z ustalonych w konfiguracji form płatności (patrz INSTRUKCJA ADMINISTRATORA - PARAMETRYZACJA SYSTEMU - Formy płatności), automatycznie proponuje taką formę jak opisana wyżej domyślna forma płatności dokumentu)

  • Zapłacono, Data, KP/KW - w przypadku spłaty danej raty (lub całości) uzupełniamy kwotę i datę spłaty oraz dodatkowo możemy zapamiętać numer dowodu wypłaty KW (lub ewentualnie wpłaty KP).
    UWAGA. Jeśli prowadzimy raporty kasowe/bankowe, to kolumny te będą wypełniane automatycznie na podstawie wpisów do raportów kasowych lub bankowych.
    Ponadto jeśli płatność do tego PZ była wykonana jako zaliczka zapłacona przez nas dostawcy przed wystawieniem PZ i została już zaksięgowana do kasy, możemy klikając w kolumnie KW w przycisk [image] wywołać okno Rozrachunki z filtrem ustawionym automatycznie na zapłaty niepowiązane jeszcze z żadnymi PZ:

    i klikając w przycisk [image] powiązać tę wpłatę z bieżącym PZ.

  • K - znak X jeśli ta płatność jest zaksięgowana w raporcie kasowym lub bankowym.

Pod tabelką z płatnościami znajduje się podsumowanie z kwotami Brutto, Zapłacono i Do zapłaty.

Dodatkowo pod tabelką z płatnościami pokazane jest pole Terminowy informujące o tym, czy PZ został zapłacony w całości w dniu wystawienia czy też nie.

Ponadto jeśli korzystamy z automatycznego księgowania w raportach kasowych lub bankowych, pod tabelką z płatnościami pojawi się również pole Kasa/bank informujące o tym, czy PZ został zapłacony w całości i wszystkie płatności zostały zaksięgowane w raportach kasowych lub bankowych (X), czy też został zaksięgowany do kasy tylko częściowo (x). Ta sama informacja może być również widoczna bezpośrednio na liście PZ po włączeniu kolumny Kasa/Bank. Dokumentów zaksięgowanych do kasy nie można usunąć, a ich poprawa jest możliwa tylko w ograniczonym zakresie.

W momencie dokonania zapłaty za wystawiony wcześniej PZ należy:

  • jeśli korzystamy z modułu Kasa/Bank: wprowadzić płatność do raportu kasowego lub bankowego, korzystając z automatycznego powiązania z PZ

  • jeśli nie korzystamy z modułu Kasa/Bank: odszukać PZ w oknie PZ i odnotować fakt zapłaty poprawiając odpowiednio zapisy na zakładce Płatności.


Transport - PZ

Transport

MAGAZYN - PRZYJĘCIA DO MAGAZYNU - Wystawianie PZ

Program umożliwia szczegółowe rozliczenie kosztów transportu związanych z danym PZ, a nie wliczanych do ceny nabycia towarów przyjętych na tym PZ. Mechanizm ten jest dostępny w wersji MAXI i PRO po włączeniu w danych firmy na zakładce Ustawienia - Magazyn pola Transport. Dzięki niemu możemy na bieżąco kontrolować marże i zysk uzyskiwany na sprzedaży poszczególnych asortymentów uwzględniając koszty transportu.

Koszty transportu wprowadzamy na PZ na zakładce Transport w polu Koszt transportu. Można je wpisać tam bezpośrednio lub wybierając odpowiednie zlecenie transportowe związane z tym PZ. Aby wybrać takie zlecenie należy kliknąć w przycisk [image] znajdujący się w polu Powiązane zlecenie transportowe. Zlecenia transportowe są dostępne tylko w wersji PRO.

W przykładzie powyżej wpisano koszt transportu 15 zł. Został on przeliczony na jednostkowe koszty transportu wszystkich pozycji z tego PZ proporcjonalnie do ich wartości. Po zsumowaniu jednostkowych kosztów transportu, koszt łączny wynosi 15,03. Jest on pokazany w szarym polu pod kosztem zadanym.

Jednostkowe koszty transportu (kolumna C.transp.) oraz koszty zbiorcze przypadające na daną pozycję PZ (kolumna W.transp.) są wyszczególnione na zakładce Pozycje:

Koszt łączny to faktyczny koszt jaki będzie uwzględniany przy obliczaniu marży oraz zysku ze sprzedaży towarów pochodzących z tego PZ - dotyczy to wartości pokazywanych w kolumnach Zysk oraz Marża w oknie Faktury na liście faktur oraz na zakładce WZ, w oknie Pozycje dokumentu na zakładce Wz, w oknie PZ w kolumnie Marża% na zakładce Pozycje oraz w statystyce firmy.


PZ korygujący

MAGAZYN - PRZYJĘCIA DO MAGAZYNU

Jeśli dostawca wystawił nam fakturę korygującą, dokumentującą np. zwrot uszkodzonych towarów, musimy wystawić analogiczny PZ korygujący. Aby go wystawić musimy najpierw odszukać PZ, który ma zostać skorygowany.

Jeśli ten PZ wystawiono przed rozpoczęciem użytkowania programu, musimy odszukać odpowiedni dokument BO, na którym znajdował się towar pochodzący z tego PZ i odpowiednio skorygować dokument BO.

Po ustawieniu się na takim dokumencie (PZ lub BO) przechodzimy na zakładkę Pozycja, na której z kolei przechodzimy na zakładkę Korekty. Znajduje się na niej tabelka z korektami wystawionymi do aktualnego dokumentu (można wystawić dowolną ilość korekt do jednego dokumentu). Po przejściu do tej tabelki naciskając klawisz Insert lub klikając w przycisk [image] rozpoczynamy wystawianie dokumentu korygującego:

Zamiast aktualnego dokumentu na ekranie pojawi się nowy dokument korygujący. Na dokumencie korygującym zakładka Pozycje podzielona jest na trzy dodatkowe zakładki 1.Było, 2.Powinno być i 3.Różnica.

Program ustawi się automatycznie na tabelce z pozycjami dokumentu oryginalnego (zakładka 1.Było). Klikając podwójnie lub naciskając Enter na pozycji, którą chcemy skorygować, przejdziemy na zakładkę 2.Powinno być, gdzie można określić właściwą ilość i cenę. Jeśli chcemy dodać nową pozycję, taką której nie było na oryginalnym PZ, możemy to zrobić bezpośrednio na zakładce 2.Powinno być naciskając Ins lub klikając [image]. W obu przypadkach program sam wyliczy różnicę w stosunku do oryginalnej pozycji (na zakładce 3.Różnica). Przed zaakceptowaniem dokumentu powinniśmy jeszcze określić przyczynę dokonania korekty. Wpisuje się ją na zakładce Uwagi jako Uwaga1. Pamiętajmy jeszcze o prawidłowym określeniu sposobu płatności (zakładka Płatności).

Korekta ilości polegająca na zmniejszeniu oryginalnej ilości jakiejś pozycji może być wykonana pod warunkiem, że w magazynie, do którego oryginalnie przyjęto ten towar jest jeszcze jego wystarczająca ilość. Np. jeśli oryginalnie na jednej z pozycji PZ było przyjętych 25 szt. jakiegoś asortymentu i chcemy zwrócić dostawcy 10 szt, to przynajmniej 10 szt. pochodzące z tej dostawy musi być jeszcze w magazynie. Jest to bardzo istotne zastrzeżenie, gdyż może sie okazać, że mamy w magazynie aktualnie 10 szt. tego asortymentu, ale z innej dostawy i wykonanie korekty nie będzie możliwe.

Jeśli były już jakieś wcześniejsze korekty do tego samego PZ, to na zakładce 1.Było pojawią się pozycje oryginalnego PZ odpowiednio skorygowane przez wszystkie poprzednie korekty. Np. jeśli oryginalnie przyjęto 10 szt. jakiegoś asortymentu, po czym na jednej korekcie zwrócono 3 szt. a na następnej korekcie jeszcze 2 szt., to na trzeciej korekcie na zakładce 1.Było pokaże sie ilość tego asortymentu równa 5 szt. Dokładnie tak jak na zakładkach tak wydrukowany zostanie PZ korygujący, tzn. każdy następny będzie zawierał w części "Było" korekty wynikające z wszystkich wcześniejszych PZ korygujących.


Fatura VAT RR

Faktura VAT RR

MAGAZYN - PRZYJĘCIA DO MAGAZYNU

Fakturę VAT RR wystawiamy w imieniu rolnika ryczałtowego kupując od niego produkty rolne. Fakturę RR wprowadzamy w oknie PZ, gdyż jest ona dla nas zakupem i powoduje przyjęcie towaru do magazynu.

Przed pierwszym wystawieniem faktury Vat RR upewniamy się, czy w danych firmy na zakładce Ustawienia - Magazyn zaznaczony jest parametr Faktury RR oraz czy w oknie Definicje dokumentów znajduje się definicja faktury RR. Jeśli tak, to możemy przystąpić do wystawiania faktury RR. Jest to czynność bardzo podobna do wystawiania dokumentu przyjęcia PZ. Musimy jedynie zwrócić uwagę czy rolnik, od którego kupujemy towar ma w bibliotece kontrahentów na zakładce RR uzupełnione wymagane dane identyfikacyjne. Określana przepisami 6% stawka vat nadaje się automatycznie na wszystkich pozycjach faktury RR niezależnie od stawki VAT określonej w bibliotece asortymentów.


Wydruki

MAGAZYN - PRZYJĘCIA DO MAGAZYNU

Po wystawieniu dokumentu PZ można go wydrukować. W tym celu wciskamy klawisz F2 lub klikamy w ikonkę [image] i wybieramy z menu wydruków PZ.

W okienku WYDRUK ustawiamy odpowiednie opcje:

  • Oryginał/Kopia

    • Oryginał + Kopia - wydrukują się 2 egzemplarze dokumentu - jeden z napisem Oryginał i drugi z napisem Kopia

    • Oryginał - wydrukuje się jeden egzemplarz dokumentu z napisem Oryginał

    • Kopia - wydrukuje się jeden egzemplarz dokumentu z napisem Kopia

    • Oryginał/Kopia - wydrukuje się jeden egzemplarz dokumentu z napisem Oryginał / Kopia

    • Duplikat - wydrukuje się jeden egzemplarz dokumentu z napisem Duplikat z dnia ....

    • Oryginał + 2 Kopie - wydrukują się 3 egzemplarze dokumentu - jeden z napisem Oryginał i dwa z napisem Kopia

    • Oryginał + 3 Kopie - wydrukują się 4 egzemplarze dokumentu - jeden z napisem Oryginał i trzy z napisem Kopia

  • Cena - standardowo PZ drukujemy w cenach nabycia, odpowiada on wtedy dokładnie fakturze zakupu. Jeśli rozliczamy magazyn w cenie ewidencyjnej lub w cenach sprzedaży, możemy wydrukować (wycenić) PZ w takiej właśnie cenie. Opcja dostępna tylko jeśli w definicji dokumentu na zakładce Wydruki zaznaczono parametr Dodatkowe ceny.

  • Tylko magazyn. - tylko towary i produkty przyjęte do magazynu (bez usług). Opcja dostępna tylko jeśli na dokumencie znajdują się zarówno pozycje "magazynowe" jak i usługi.

  • Typ ceny sprzedaży - jeśli drukujemy PZ w cenach sprzedaży, możemy dodatkowo sprecyzować, czy chodzi nam o cenę netto, czy brutto. Opcja dostępna tylko jeśli w definicji dokumentu na zakładce Wydruki zaznaczono parametr Dodatkowe ceny

i przygotowujemy do druku [image] bieżący dokument. Przygotowany wydruk pokaże się w oknie Przegląd wydruku. Możemy również skorzystać z funkcji bezpośredniego wydruku na drukarce (domyślnej lub ostatnio wybranej) [image], z pominięciem okna Przegląd wydruku.

Jeśli chcielibyśmy coś zmienić w wyglądzie PZ, możemy sprawdzić ustawienia parametrów w oknie Definicje dokumentów (menu główne Ustawienia - Definicje dokumentów) na zakładce Wydruki. Możemy również utworzyć własną makietę dokumentu wprowadzając w niej praktycznie dowolne zmiany (menu główne Ustawienia - Makiety dokumentów). Taką makietę możemy:

  • wybrać jako makietę wydruku tylko dla tego konkretnego dokumentu PZ - wybieramy ją w PZ na zakładce Inne w polu Makieta

  • ustawić jako obowiązującą dla wszystkich dokumentów PZ - w oknie Definicje dokumentów (menu Ustawienia - Definicje dokumentów) odszukujemy definicję PZ i na zakładce Makiety ustawiamy własną makietę

  • ustawić jako obowiązującą dla wszystkich dokumentów PZ od wybranego kontrahenta - przypisujemy ją temu kontrahentowi w oknie Kontrahenci na zakładce Wydruki.

Oprócz dokumentu możemy również wydrukować:

  • KP/KW

    • wydruk KW (lub KP) wystawionych w kasie do tego PZ (jeśli posiadamy wersję programu umożliwiającą prowadzenie raportów kasowych)

    • wydruk KW (lub KP) do płatności zaznaczonych na PZ jako zapłacone gotówką (jeśli posiadamy wersję programu bez kasy lub wyłączyliśmy moduł KASA/BANK w ustawieniach (okno FIRMY - F6 - Ustawienia - Ogólne - Moduły - Kasa/Bank))

  • Korekta kosztu sprzedaży - pozycja dostępna tylko na dokumentach korygujących jeśli firma prowadzi pełną księgowość (tzn. jeśli w danych bieżącej firmy [image] na zakładce Dane ustawiono w polu Rozliczenia pełną księgowość). Pokazuje dostawy skorygowane na tym dokumencie, które zostały częściowo lub w całości wydane z magazynu przed sporządzeniem tej korekty, z wyszczególnieniem cen nabycia w jakich wydano te pozycje z magazynu, a w jakich powinny być wydane w związku z tą korektą. Korzystając z wydruku F2 Wydruk listy, możemy wydrukować listę tych dostaw i na tej podstawie sporządzić w systemie finansowo-księgowym dokument PK korygujący koszt własny sprzedaży (patrz MAGAZYN - WYDANIA Z MAGAZYNU - Koszt własny sprzedaży).

  • Rejestr zakupów VAT - pomocniczy raport do rozliczenia naliczonego podatku VAT. Przed wydrukiem należy wybrać odpowiedni okres (menu główne Ustawienia - Bieżąca data i okres lub klawisz F12). Bez względu na ustawienia filtru [image] F4 rejestr będzie zawierał tylko dokumenty związane z faktycznym zakupem (bez BO, zamówień itp). Wydruk ma charakter pomocniczy gdyż obejmuje tylko zakupy handlowe oraz sporządzany jest wg stawek vat a nie celów zakupu. Pełny rejestr zakupów VAT można wydrukować z programu R2fk lub R2księga po zaimportowaniu dokumentów PZ.

  • Zakup - asortymenty - zestawienie zakupów poszczególnych asortymentów uporządkowane wg wielkości obrotów

  • Zakup - asortymenty z podziałem na grupy - jak wyżej, tylko że z podziałem na grupy

  • Zakup - dokumenty - lista dokumentów

  • Zakup - dokumenty z podziałem na dostawców - lista dokumentów podzielona alfabetycznie na poszczególnych dostawców

  • Zakup - dostawcy - sumaryczne obroty z dostawcami uporządkowane wg wielkości obrotów

  • Zakup - grupy - sumaryczne zestawienia zakupów poszczególnych grup asortymentowych

  • Zakup - PKWiU - sumaryczne zakupy z podziałem na grupy PKWiU

  • Zakup - pozycje dokumentów - pozycje z dokumentów PZ

  • Zakup - stawki vat - sumaryczne zakupy z podziałem na stawki VAT

  • Zakup - wierzyciele wg kwot - lista niezapłaconych PZ uporządkowana w kolejności kwot do zapłaty

  • Zakup - wierzyciele wg terminów płatności - lista niezapłaconych PZ uporządkowana w kolejności terminów płatności

  • Wydruk listy - lista wszystkich dokumentów zawierających się w aktualnym oknie

  • Wydruk pozycji - wydruk szczegółowych informacji na temat konkretnej pozycji, znajdującej się w oknie Pz.

Opisane wyżej zestawienia wykonywane są na podstawie przgotowanej wcześniej definicji. Korzystając z polecenia menu głównego Ustawienia - Definicje zestawień wywołujemy okno DEFINICJE ZESTAWIEŃ, w którym możemy poprawić [image] (F6) definicję istniejącego zestawienia lub utworzyć [image] (Ins) definicję zupełnie nowego zestawienia odpowiadającego naszym specyficznym potrzebom (patrz INSTRUKCJA ADMINISTRATORA - PARAMETRYZACJA SYSTEMU - Definicje zestawień).

Wydruki PZ oraz KP / KW można wykonać na drukarce igłowej w trybie znakowym (patrz ROZPOCZĘCIE PRACY - Okno główne - Przegląd wydruku - Wydruki znakowe).


Eksport PZ do programu księgowego

MAGAZYN - PRZYJĘCIA DO MAGAZYNU

Program R2faktury umożliwia eksport danych do programów księgowych R2księga - księga przychodów i rozchodów, ryczałt oraz R2fk - pełna księgowość (patrz EKSPORT DANYCH). Jednym z elementów tego eksportu jest opisany poniżej eksport PZ.

Wystawione dokumenty PZ możemy w każdej chwili, a najlepiej po zakończeniu miesiąca, wyeksportować do programu R2księga (księga przychodów i rozchodów lub ryczałtowa ewidencja przychodów), systemu R2fk (pełna księgowość) lub innego programu księgowego.
Programy R2księga i R2fk potrafią zaimportować dokumenty PZ wyeksportowane z programu [image] i automatycznie je zaksięgować uwzględniając odpowiednie konta, dane kontrahenta, rozbicie na stawki vat oraz płatności.

Przed eksportem PZ do programu księgowego należy w danych firmy określić parametry współpracy, tzn. rodzaj prowadzonej księgowości (pole Rozliczenia) i nazwę programu, do którego chcemy eksportować dane (pole Eksport do na zakładce Ustawienia - Ogólne).

Dokumenty PZ do zaksięgowania wysyłamy z okna PZ przy pomocy funkcji [image] (również z menu podręcznego wywołanego klawiszem F3 lub prawym klawiszem myszy). W wywołanym w ten sposób okienku określamy:

  • Docelowa baza danych - baza, do której zostaną wyeksportowane PZ

  • Wyczyść bufor przed zapisaniem danych - po zaznaczeniu tej opcji bufor będzie zawsze zawierał tylko aktualnie eksportowane dokumenty. W przeciwnym wypadku dokumenty będą do bufora dodawane - umożliwia to przygotowanie wspólnego bufora z PZ i fakturami. Korzystając z takiego wspólnego bufora, możemy w programie księgowym wykonać jedną operację importu danych, zamiast osobnej dla PZ i osobnej dla faktur. Dokumenty prawidłowo zaimportowane do programu księgowego są przez ten program automatycznie usuwane z bufora.

  • w przypadku eksportu do R2fk:

    • Księguj każdą pozycję dokumentu osobno - jeśli chcemy zaksięgować każdą pozycję PZ na osobnym koncie związanym z tą pozycją - takie konto określamy w bibliotece asortymentów w polu Konto zakupów na zakładce FK lub w analogicznym polu bezpośrednio w pozycji PZ w oknie Pozycje PZ

    • Wymagaj konta przy każdej pozycji - jeśli decydujemy się na osobne księgowanie każdej pozycji dokumentu, powinniśmy określić konto zakupu przy każdej pozycji PZ. Aby zabezpieczyć się przed zaksięgowaniem dokumentów, które mają nieokreślone konta w pozycjach włączamy ten właśnie parametr. Jeśli wyłączymy ten parametr to pozycje z nieokreślonym kontem zakupu zostaną zaksięgowane na domyślne konto zakupu określone w programie R2fk.

    • Opis przy każdej pozycji - jeśli decydujemy się na osobne księgowanie każdej pozycji dokumentu, możemy dla każdej pozycji wyeksportować nazwę asortymentu. Pojawi się ona w opisie tej pozycji na zaksięgowanym dokumencie.

  • Zakres - co ma być wyeksportowane

  • Opis zdarzenia - sposób tworzenia opisu zdarzenia gospodarczego; wybieramy Pierwsza pozycja z dokumentu, jeśli ma to być pierwsza pozycja z PZ lub Zakup towarów/produktów - w zależności od rodzaju asortymentów na danym PZ będzie to zakup towarów lub zakup produktów itp.

UWAGI:

  1. Przed eksportem dokumentów wybieramy odpowiedni okres, obejmujący datę wystawienia wszystkich dokumentów, które chcemy zaksięgować (menu główne Ustawienia - Bieżąca data i okres lub szybciej klawisz F12). Zwykle będzie to cały miesiąc lub fragment miesiąca obejmujący nowe dokumenty, które nie zostały jeszcze zaksięgowane.
    W szczególnych przypadkach, jeśli wprowadzając dokumenty określiliśmy na zakładce FK/Księga/Ewidencja w polu Data księgowania datę z innego miesiąca niż datę wystawienia, należy powtórzyć eksport danych dla miesiąca (okresu) obejmującego datę księgowania. Przed powtórnym eksportem należy wyłączyć parametr Wyczyść bufor przed zapisaniem danych, dzięki czemu będziemy mieli w tym samum buforze wszystkie dokumenty, które mają być zaksięgowane w danym miesiącu (tzn. zarówno te które mają datę wystawienia z danego miesiąca, jak i te które mają inną datę wystawienia, ale datę ksiegowania z tego miesiąca).
    Np. jeśli wystawiliśmy we wrześniu PZ z datą księgowania z 31.08, to aby prawidłowo zaksięgować PZ-ty za sierpień należy najpierw wybrać w okresie miesiąc sierpień (zostaną wyeksportowane wszystkie PZ-ty z datą wystawienia z sierpnia i z dowolnymi datami księgowania), a potem dodatkowo wszystkie z września (zostaną wyeksportowane wszystkie z datą wystawienia z września i z dowolnymi datami księgowania). Przed importem ustawiamy w programie księgowym w okresie miesiąc sierpień. Program księgowy sprawdzi, które dokumenty z bufora należy zaksięgować w sierpniu. Będą to te, które mają datę księgowania z sierpnia lub, w przypadku nieokreślonej daty księgowania, te które mają datę wystawienia z sierpnia. Pozostałe dokumenty zostaną pominięte.

  2. Jeśli korzystamy z eksportu danych do programu R2fk lub R2księga lecz nie dokonaliśmy integracji modułów, wówczas zamiast pola Docelowa baza danych widoczne będzie pole Plik docelowy, w którym należy określić do jakiego pliku zostaną wyeksportowane dane. Taki sam plik należy wskazać w R2księdze lub w R2fk przy imporcie danych.


Import/Eksport PZ

MAGAZYN - PRZYJĘCIA DO MAGAZYNU

Program [image] umożliwia import PZ z pliku tekstowego o określonym formacie oraz eksportowanie wybranej grupy PZ do pliku tekstowego o tym samym formacie. Format ten opisano szczegółowo w specyfikacji importu dokumentów PZ, znajdującej się w załączniku do instrukcji wywoływanej w programie.

Opcje importu oraz eksportu PZ mogą być przydatne w różnych sytuacjach, np:

  • do automatycznego tworzenia PZ wygenerowanych z dowolnego zewnętrznego systemu

  • do przesyłania PZ pomiędzy przedstawicielami i centralą, np. gdy firma korzysta z akwizytorów wystawiających PZ w terenie

  • do automatycznego tworzenia PZ na podstawie zamówień przysyłanych przez oddział firmy lub zamówień przysyłanych od klientów

IMPORT PZ

Można importować dokumenty PZ przygotowane w dowolnym zewnętrznym programie, jeżeli tylko przygotowane zostaną w formacie opisanym w załączniku do INSTRUKCJI ADMINISTRATORA - Specyfikacja importu dokumentów PZ. Można również importować dokumenty PZ, które zostały wyeksportowane w innym programie [image] za pomocą opcji Eksport PZ do programu RESET2 - R2faktury.

Operację importu możemy wykonać poleceniem menu głównego Zbiory - Import danych - Import PZ z programu RESET2 - R2faktury lub z menu podręcznego wywołanego klawiszem F3 (lub prawym klawiszem myszy) z okna PZ. Przed wykonaniem importu należy określić następujące parametry:

  • Dane zostaną wczytane z pliku - lokalizacja i nazwa źródłowego pliku z danymi do importu (można go wpisać ręcznie lub odnaleźć klikając przycisk [image]). Po wskazaniu pliku możemy obejrzeć jego zawartość za pomocą przycisku Podgląd.

  • Rodzaj dokumentu - służy do określenia definicji dokumentu, którą mają otrzymać wczytane dokumenty. Jeżeli w pliku źródłowym rodzaje te są poprawnie określone, możemy wybrać wartość Automatycznie. Wówczas odczytane dokumenty będą miały taki sam rodzaj, jaki podany został w pliku źródłowym. Natomiast jeżeli w pliku źródłowym rodzaje nie zostały określone lub z jakichś innych powodów chcemy zmienić rodzaj importowanych dokumentów, wtedy należy wybrać konkretny rodzaj z listy. Czyli jeżeli np. wybierzemy rodzaj PZ, to wtedy wszystkie zaimportowane dokumenty będą miały rodzaj PZ, niezależnie od tego, jaki rodzaj miały te dokumenty oryginalnie.

  • Identyfikacja asortymentów - służy do określenia jednoznacznego identyfikatora asortymentu, by zapobiec dublowaniu asortymentów już istniejących w bazie danych. W trakcie importu dokumentów PZ program sprawdza bowiem, czy asortymenty tych PZ istnieją już w bazie danych w tabeli Asortymenty. Jeżeli asortymentu nie ma jeszcze w tabeli, to zostanie on do niej dodany automatycznie w trakcie importu. O tym, czy dany asortyment w pliku źródłowym jest nowym asortymentem, czy też już istniejącym w bazie danych, decyduje zgodność pól Skrót nazwy lub Indeks, w zależności od wartości omawianego parametru.

  • Identyfikacja kontrahentów - służy do określenia jednoznacznego identyfikatora kontrahenta, by zapobiec dublowaniu kontrahentów już istniejących w bazie danych. W trakcie importu dokumentów PZ program sprawdza bowiem, czy kontrahenci tych PZ istnieją już w bazie danych w tabeli Kontrahenci. Jeżeli kontrahenta nie ma jeszcze w tabeli, to zostanie on do niej dodany automatycznie w trakcie importu. O tym, czy dany kontrahent w pliku źródłowym jest nowym kontrahentem, czy też już istniejącym w bazie danych, decyduje zgodność pól NIP i/lub Skrót, w zależności od wartości omawianego parametru.
    UWAGI:

    1. W przypadku, gdy wybierzemy opcję NIP lub NIP,Skrót może się zdarzyć, że program dopisze kontrahenta, którego NIP co prawda jest unikalny, ale jego Skrót jest identyczny z jakimś już istniejącym w kartotece kontrahentem. Ze względu na to, że w programie R2faktury pole Skrót musi być polem jednoznacznym (dwaj różni kontrahenci nie mogą mieć takiej samej wartości w polu Skrót), to w takim przypadku program wyświetli komunikat i do pola Skrót tego kontrahenta dodany zostanie przyrostek z kolejnym numerem (_1, _2 itd).

    2. Podczas porównywania pól NIP brane są pod uwagę tylko cyfry, czyli np. 652-111-22-33 i 6521112233 zostaną uznane za jednakowe pola NIP.

  • Kontrahent - pole dostępne jeśli wcześniej w polu Identyfikacja kontrahentów wybraliśmy opcję Kontrahent z biblioteki. Ma to sens wtedy, gdy importujemy sobie Faktury do PZ, wówczas nie ma sensu, żeby dodbiorca z Faktury stawał się dostawcą PZ. Wybieramy więc konkretnego kontrahenta w tym dialogu.
    UWAGA. Jeśli mamy więcej dokumentów, należy wówczas utworzyć jakiegoś kontrahenta tymczasowego, wskazać go z biblioteki w tym dialogu, a potem ręcznie pozamieniać kontrahentów bezpośrednio na utworzonych dokumentach PZ.

  • Ceny - dotyczy cen znajdujących się na zakładce Pozycje na dokumentach PZ. Mamy do wyboru dwie możliwości:

    1. Takie jak w pliku - tę opcję należy wybrać, jeżeli w pliku źródłowym ceny zostały określone dla poszczególnych dokumentów i chcemy, aby dokumenty uzyskały takie właśnie ceny po zaimportowaniu

    2. Ostatnia cena nabycia - spowoduje, że wszystkie odczytywane dokumenty zostaną przeliczone wg ostatniej ceny nabycia określonej w programie w oknie Asortymenty, niezależnie od tego, co podano w pliku źródłowym.

  • Płatności - dotyczy ustawień znajdujących się na zakładce Płatności na dokumentach PZ. Mamy do wyboru dwie możliwości:

    1. Takie jak w pliku - tę opcję należy wybrać, jeżeli w pliku źródłowym płatności zostały określone dla poszczególnych dokumentów i chcemy, aby dokumenty uzyskały takie właśnie płatności po zaimportowaniu

    2. Domyślne - spowoduje, że wszystkie odczytywane dokumenty zostaną oznaczone wg domyślnych ustawień określonych w programie w oknie Konfiguracja na zakładce PZ, niezależnie od tego, co podano w pliku źródłowym.

  • Blokuj Pz - znacznik, określający czy pozycje z tego PZ będą widoczne w oknie Stan magazynu, a co za tym idzie czy będzie można na nich wykonywać operacje magazynowe (wydania, przesunięcia), czy też będą zablokowane, tzn. przyjęte, ale jeszcze nie będzie można na nich wykonywać operacji magazynowych

  • Podświetl utworzone dokumenty - umożliwia łatwe odnalezienie (i ewentualną weryfikację) zaimportowanych dokumentów. Przed wykonaniem tej funkcji dobrze jest wcześniej odświetlić w oknie PZ wszystkie podświetlone pozycje, aby upewnić się, że po wykonaniu importu na liście podświetlonych pozycji będą rzeczywiście tylko te, które zostały zaimportowane z pliku.

UWAGA. Istnieje możliwość importowania krzyżowego, tzn. importowania pliku z Fakturami do okna PZ (np. gdy jeden klient drugiemu wypisał fakturę w naszym programie, i dał mu plik, dzięki czemu ten będzie mógł sobie go zaimportować i zrobić z niego PZ zamiast wprowadzać ręcznie) oraz możliwość importowania pliku z dokumentami PZ do okna Faktury (co mogłoby się ewentualnie przydać w firmie produkcyjnej, która zrobiła jakieś produkty pod konkretną fakturę/zamówienie, albo w hurtowni, która sprowadziła coś na PZ tylko po to, aby to od razu sprzedać). W obu tych krzyżowych przypadkach trzeba koniecznie pamiętać o tym, że parametr Rodzaj dokumentu musi być konkretnie podany, (nie może być ustawiony na opcję Automatycznie, bo PZ na fakturę się automatycznie nie zamieni). Trzeba też uważać z przekazywaniem cen i płatności (czyli parametry Ceny i Płatności powinny mieć wartości Domyślne). Ponieważ dostawca PZ to nie jest odbiorca na fakturze, więc być może będzie potrzebne ręczne wybranie Kontrahenta z biblioteki.

EKSPORT PZ

Operację eksportu możemy wykonać poleceniem menu głównego Zbiory - Eksport danych - Eksport PZ do programu RESET2 - R2faktury lub z menu podręcznego wywołanego klawiszem F3 (lub prawym klawiszem myszy) z okna PZ. Przed wykonaniem eksportu należy określić lokalizację i nazwę pliku, do którego mają zostać zapisane dane, oraz zakres tych danych, tzn. które PZ mają zostać wyeksportowane. Mamy do wyboru 4 możliwości:

  • Aktualny dokument - eksport aktualnego dokumentu

  • Takie jak w oknie - zostaną wyeksportowane tylko dokumenty widoczne aktualnie w oknie PZ

  • Podświetlone - zostaną wyeksportowane tylko dokumenty, które są aktualnie podświetlone w oknie PZ (bez względu na to czy w oknie pokazywane są wszystkie, czy tylko podświetlone pozycje)

  • Wszystkie - zostaną wyeksportowane wszystkie dokumenty.

Wykonanie operacji eksportu spowoduje zapisanie w podanym pliku danych na temat wybranych PZ.

Operacja importu PZ nigdy nie modyfikuje ani nie kasuje żadnych danych już istniejących w bazie systemu. Może wyłącznie dodawać nowe elementy do bazy danych (PZ, kontrahentów, asortymenty). Np. w przypadku, gdy w pliku źródłowym znajdzie się dokument PZ wystawiony dla pana Adamskiego, który figuruje już w tabeli Kontrahenci, to program pozostawi dane pana Adamskiego w niezmienionej postaci - nawet gdyby w pliku źródłowym dane te były inne, ale jeżeli adres podany na PZ nie będzie zgodny z żadnym z dotychczasowych adresów pana Adamskiego, to zostanie utworzony dla niego kolejny adres w tabeli adresów kontrahentów i wpisany na zaimportowany dokument.

Program blokuje też możliwość dwukrotnego zaimportowania tego samego dokumentu PZ. Numer importowanego PZ jest zapamiętywany w polu Nr zewn., które jest niedostępne do edycji. Nie ma możliwości ponownego odczytu PZ o takim numerze. Nr zewn. jest wyświetlany w oknie głównym PZ po prawej stronie pola Numer, ale tylko wtedy, gdy PZ pochodzi z importu.
UWAGA. Podczas importu dokumenty PZ otrzymują kolejne numery w ramach danego rodzaju. Nie muszą więc być to numery zgodne z numerem, który znajduje się w pliku źródłowym. Aby numeracja ta była zgodna, konieczne jest przestrzeganie pewnych reguł pracy z programem (programami), tzn. np. PZ danego rodzaju muszą być wyłącznie importowane, a nie wypisywane ręcznie, musi być zachowana odpowiednia chronologia wypisywania PZ i ich eksportu/importu itp.

UWAGA. W obecnej wersji programu PZ korygujące nie mogą być importowane.

Eksport i import PZ przy użyciu pliku XML dostępny jest tylko w wersji PRO.


Zlecenia transportowe

MAGAZYN - PRZYJĘCIA DO MAGAZYNU

Jeśli zlecamy transport towaru zakupionego u dostawcy zewnętrznej firmie transportowej, to moduł zleceń transportowych może nam znacznie ułatwić pracę. Pozwala on na wystawienie zlecenia dla firmy transportowej, rozliczenie zlecenia po otrzymaniu faktury a także powiązanie kosztów transportu z konkretnym dokumentem PZ i dzięki temu uwzględnianie kosztów transportu przy obliczaniu marży i zysku ze sprzedaży. Zlecenia transportowe dostępne są tylko w wersji PRO.

Zlecenia transportowe wystawiamy w oknie Zlecenia transportowe wywoływanym z menu Okna - Zlecenia transportowe.

Przed wystawieniem zlecenia należy wybrać właściwy okres, obejmujący datę wystawienia zlecenia. W tym celu wybieramy z menu głównego Ustawienia - Bieżąca data i okres. Szybką zmianę okresu umożliwia klawisz F12.

Po wybraniu rodzaju dokumentu wypełniamy następujące dane:

  • Numer - numer kolejny dokumentu, najlepiej nie wypełniać tego pola ręcznie - program automatycznie w momencie akceptacji dokumentu podstawi kolejny, unikalny numer. Dzięki temu, że numer jest nadawany dopiero w momencie akceptacji, dokumenty będą prawidłowo numerowane przy równoczesnym sieciowym wystawianiu kilku zleceń przez różnych użytkowników programu. Pole Numer składa się z 2 części: białej i szarej, w części szarej pokazany jest pełny numer dokumentu, w układzie określonym w definicji tego rodzaju dokumentu, np. 9/12/ZT, a w części białej właściwy numer kolejny, czyli np. 9.

  • Data wystawienia - data wystawienia zlecenia.
    UWAGI:

    1. Data wystawienia musi mieścić się w wybranym okresie pracy (patrz ROZPOCZĘCIE PRACY - Okno główne - Bieżąca data i okres). Jeśli chcemy wystawić zlecenie z datą spoza wybranego okresu, musimy najpierw zmienić okres przeglądania. Inaczej program pokaże ostrzeżenie i nie pozwoli wprowadzić takiej daty.

    2. Data wystawienia musi być większa od daty zamknięcia (patrz ROZPOCZĘCIE PRACY - Okno główne - Bieżąca data i okres). Nie da się zatwierdzić nowego zlecenia z datą wystawienia należącą do zamkniętego okresu. Podobnie nie da się poprawić ani usunąć istniejącego już zlecenia, którego data wystawienia należy do zamkniętego okresu.

  • Zleceniobiorca - wybieramy zleceniobiorcę z biblioteki kontrahentów

  • Załadunek / rozładunek - wprowadzamy podstawowe dane zlecenia czyli datę i miejsce lub miejsca załadunku oraz rozładunku

  • Wartość

    • Zlecenie - podajemy wartość zlecenia wg ustalonego wcześniej ze zleceniobiorcą cennika

    • Faktura - wprowadzamy dane faktury wystawionej przez zleceniobiorcę po wykonaniu zlecenia, na tej podstawie będziemy mogli rozliczać płatności do tej faktury

  • Płatności - szczegółowe określenie i rozliczenie płatności do faktury wystawionej przez zleceniobiorcę, analogicznie jak w przypadku płatności do PZ

  • Inne - dodatkowe informacje:

    • Wystawił - imię i nazwisko osoby wystawiającej zlecenie, podstawiane automatycznie z danych użytkownika zalogowanego do programu

  • Uwagi - wszelkie dodatkowe informacje, które mają być wydrukowane na zleceniu

  • Notatki - wszelkie dodatkowe informacje związane z tym zleceniem, które nie będą drukowane na zleceniu, do wyboru mamy:

    • jedno duże opisowe pole, do którego można wpisać dowolny tekst

    • lub 10 pól po 10 znaków, do których możemy wpisywać wg ustalonego przez siebie systemu różne znaczniki. Notatki te mogą być później wykorzystane do szybkiego wyszukania lub sporządzenia zestawień zleceń pogrupowanych wg notatek (pola N1...N10).

  • Powiązany PZ - dane dokumentu PZ, z którym powiązano to zlecenie transportowe (patrz Wystawianie PZ - Transport).

Wprowadzone dane akceptujemy przyciskiem [image]. Do szybkiej akceptacji służy również klawisz PgDn.

UWAGA. Wprowadzanie danych może odbywać się tylko z klawiatury, bez użycia myszki. Przejście do kolejnego pola umożliwia Enter lub Tab, a zatwierdzenie całego okna Alt PgDn.

Poprawę danych [image] umożliwia klawisz F6, natomiast usunięcie [image] wpisu klawisz Del. Poprawa i usuwanie zlecenia są możliwe tylko wtedy, gdy okres nie jest zamknięty.

Datę zamknięcia (i okres przeglądania) ustawiamy w pozycji menu głównego Ustawienia - Bieżąca data i okres (F12).

Możliwe jest szybkie wyszukanie dowolnego dokumentu [image] Ctrl F7 poprzez wpisanie numeru zlecenia (lub nazwy zleceniobiorcy itp.). Pojawi się okienko Szukaj, w którym należy określić, jakie pola ma brać pod uwagę przy wyszukiwaniu (Szukaj po). Kursor automatycznie ustawi się na właściwej pozycji. Żeby wyszukać kolejną pozycję (np. z tym samym kontrahentem) - należy wcisnąć Ctrl L.

UWAGA. W polach, po których można wyszukiwać zlecenie znajdują się m.in. pola:

  • Numer - pełny nr dokumentu, np. 9/12/ZT

  • Nr - tylko nr kolejny, np. 9. Szukanie wg tego pola jest o wiele szybsze niż wg pola Numer.

Dodatkowa funkcja [image] F4 umożliwia ustawienie stałego filtru na dokumenty spełniające zadane kryteria:

  • Dokument - dokumenty jednego rodzaju

  • Tylko własne - dotyczy dokumentów wystawionych ze współdzielonych definicji, w oknie będą dostępne tylko te, które wystawił aktualny użytkownik programu. W zależności od uprawnień nadanych użytkownikowi (pole Tylko własne dokumenty w uprawnieniach grupy użytkowników) będzie on mógł zmienić wartość tego parametru i przeglądać również współdzielone dokumenty wystawione przez innych użytkowników.

  • Kontrahent - wszystkie zlecenia od określonego dostawcy

  • Kasa/Bank - dokumenty, które:

    • Tak - zostały zapłacone w całości i w całości zaksięgowane w kasie/banku

    • Częściowo - zostały częściowo zaksięgowane w kasie/banku

    • Nie - nie zostały w ogóle zaksięgowane w kasie/banku.

Filtr [image] umożliwia wybranie dokumentów według dowolnych kryteriów, na przykład żeby wyróżnić wszystkie dokumenty, na których zastosowano rabat, możemy wywołać klawiszami +/- z klawiatury numerycznej.

Klawisz F2 [image] umożliwia wydrukowanie zlecenia.

Oprócz dokumentu możemy również wydrukować:

  • Wydruk listy - lista wszystkich dokumentów zawierających się w aktualnym oknie

  • Wydruk pozycji - wydruk szczegółowych informacji na temat konkretnej pozycji, znajdującej się w oknie Zlecenia transportowe.


Noty korygujące

MAGAZYN

Notę korygującą wystawiamy w sytuacji, gdy otrzymamy od naszego dostawcy fakturę VAT, która ma niepoprawne dane nie związane z kwotami tej faktury (czyli np. błędne dane adresowe, pomyłkę w nazwisku itp). Program umożliwia wystawianie i drukowanie takich not, oraz zapamiętuje je w osobnej tabeli o nazwie Noty korygujące.

Notę korygującą najwygodniej wystawić wtedy, gdy korygowany dokument został wpisany do naszej bazy danych do kartoteki Przyjęcia do magazynu (patrz Magazyn - Przyjęcia do magazynu). W takiej sytuacji należy ustawić się w oknie PZ na tym dokumencie, który chcemy skorygować, a następnie wybrać z menu podręcznego (prawy klawisz myszy lub klawisz F3) opcję Noty korygujące. Jeżeli teraz wystawimy [image] nową notę (Ins), to program zapyta, czy do noty tej wpisać dane bieżącego dokumentu. Jeżeli odpowiemy twierdząco, program wypełni poszczególne pola domyślnymi danymi, a mianowicie:

  • w pole Numer wpisany zostanie kolejny numer noty zgodnie z parametrami numeracji określonymi we właściwościach [image] F4 okna Noty korygujące (numer zostanie nadany po zatwierdzeniu noty przyciskiem [image])

  • w pole Data wystawienia wpisana zostanie bieżąca data

  • do pól z grupy Dane korygowanego dokumentu zostaną wpisane odpowiednie dane z korygowanego dokumentu, tzn:

    • w pole Numer - zawartość pola Do faktury z dokumentu PZ

    • w pole Data wystawienia - zawartość pola Z dnia znajdującego się pod polem Do faktury na dokumencie PZ

    • w pole Data sprzedaży - zawartość pola Z dnia znajdującego się pod polem Do Wz na dokumencie PZ jeżeli jest ono wypełnione, a w przeciwnym wypadku - ta sama data, która znalazła się w polu Data wystawienia

  • do pól grupy Sprzedawca i Adresat zostaną przepisane dane dostawcy korygowanego dokumentu PZ

  • do pól grupy Nabywca, Treść korygowana oraz Treść prawidłowa zostaną wpisane dane adresowe bieżącej firmy znajdujące się w oknie FIRMY - Dane - Nagłówek dokumentów (pełna nazwa)

  • w pole Wystawił zostanie wpisane Imię oraz Nazwisko aktualnego użytkownika (patrz ROZPOCZĘCIE PRACY - Użytkownicy).

Oczywiście, wszystkie wpisane dane domyślne możemy zmodyfikować. Możemy również wypisać notę korygującą do dokumentu, którego nie mamy w ewidencji. W tym przypadku możemy wywołać edycję not korygujących z menu głównego Okna - Noty korygujące. W takim przypadku do nowo wpisywanej noty nie podstawią się dane dotyczące korygowanego dokumentu.

We właściwościach [image] F4 okna określamy makietę (patrz INSTRUKCJA ADMINISTRATORA - PARAMETRYZACJA SYSTEMU - Makiety dokumentów), na podstawie której wykonany będzie wydruk noty. Program udostępnia dwie gotowe makiety do wyboru. Domyślną makietą jest makieta o nazwie Standard, która powoduje, że zarówno kopia jak i oryginał zostaną wydrukowane na jednej kartce formatu A4. Drugą dostępną makietą jest makieta o nazwie osobne kartki. Makiety tej należy użyć, gdy będziemy chcieli wydrukować oryginał i kopię noty na osobnych kartkach papieru (przed wydrukiem określamy Ilość kopii równą 2). Z takiej makiety musimy korzystać w sytuacji gdy dane naszej firmy są długie i nie mieszczą się na jednej stronie na wydruku wg standardowej makiety.


PRZESUNIĘCIA MIĘDZYMAGAZYNOWE

MAGAZYN

Jeśli prowadzimy kilka magazynów, to na pewno będziemy chcieli korzystać z możliwości zmiany lokalizacji towaru jaką oferują dokumenty przesunięć międzymagazynowych MM.

Dokumenty MM będziemy wystawiać w oknie MM - Przesunięcia międzymagazynowe, które można otworzyć klikając w oknie głównym w przycisk [image] .

Przed przystąpieniem do wystawiania MM należy wstępnie przygotować odpowiednie biblioteki.


Wystawianie MM

MAGAZYN - PRZESUNIĘCIA MIĘDZYMAGAZYNOWE

Przed wystawieniem MM należy wybrać właściwy okres, obejmujący datę wystawienia MM. W tym celu wybieramy z menu głównego Ustawienia - Bieżąca data i okres. Szybką zmianę okresu umożliwia klawisz F12.

Wystawiając [image] nowy dokument (Ins) najpierw określamy Rodzaj dokumentu, tzn. MM albo inny zdefiniowany przez nas dokument typu MM.

Po wybraniu rodzaju dokumentu wypełniamy następujące dane:

  • Numer - numer kolejny dokumentu - sprawdź opis dotyczący pola Numer w rozdziale PRZYJĘCIA DO MAGAZYNU - Wystawianie PZ

  • Data wystawienia - data wystawienia MM - sprawdź opis dotyczący pola Data wystawienia w rozdziale PRZYJĘCIA DO MAGAZYNU - Wystawianie PZ

  • Do MM, Z dnia - pomocnicze pola do ewentualnego wykorzystania

  • Z magazynu - wybieramy magazyn z biblioteki magazynów w zależności od tego, skąd ma pochodzić towar przesuwany na tym MM. Po zatwierdzeniu pierwszej pozycji MM nie ma już możliwości zmiany magazynu źródłowego.

  • Do magazynu - wybieramy magazyn z biblioteki magazynów w zależności od tego, dokąd chcemy przesunąć towar. Magazyn docelowy można zmienić w dowolnym momencie, pod warunkiem, że na przesuniętym towarze nie wykonano jeszcze żadnych operacji magazynowych.

  • POZYCJE - wprowadzamy na MM poszczególne asortymenty podając ich ilość, program automatycznie odnajduje ceny nabycia. Istnieje kilka sposobów wprowadzania pozycji na MM - sprawdź w rozdziale Pozycje.

  • STAWKI VAT

    • Netto, Vat i Brutto wg stawek VAT - sumy netto, vat i brutto wg stawek vat występujących na tym MM

    • Podstawa Netto/Brutto - informacja o sposobie przeliczania Vat na tym dokumencie

  • INNE - dodatkowe informacje:

    • Wystawił - imię i nazwisko osoby wystawiającej MM, podstawiane automatycznie z danych użytkownika zalogowanego do programu

    • Odebrał - imię i nazwisko osoby odbierającej towar

  • UWAGI - wszelkie dodatkowe informacje, które powinny być wydrukowane na MM

  • NOTATKI - wszelkie dodatkowe informacje związane z tym MM, które nie powinny być wydrukowane, np. z kim się kontaktować w sprawie tego MM itp.; do wyboru mamy:

    • jedno duże opisowe pole, do którego można wpisać dowolny tekst

    • lub 10 pól po 10 znaków, do których możemy wpisywać wg ustalonego przez siebie systemu różne znaczniki.

Wprowadzone dane akceptujemy przyciskiem [image]. Do szybkiej akceptacji służy również klawisz PgDn.

Poprawę danych [image] umożliwia klawisz F6, natomiast usunięcie [image] wpisu klawisz Del. Poprawa i usuwanie wpisów są możliwe tylko wtedy, gdy okres nie jest zamknięty.

Datę zamknięcia (i okres przeglądania) ustawiamy w pozycji menu głównego Ustawienia - Bieżąca data i okres (F12).

Możliwe jest szybkie wyszukanie dowolnego dokumentu [image] Ctrl F7 poprzez wpisanie numeru MM (lub magazynu docelowego itp.). Pojawi się okienko Szukaj, w którym należy określić, jakie pola ma brać pod uwagę przy wyszukiwaniu (Szukaj po). Kursor automatycznie ustawi się na właściwej pozycji. Żeby wyszukać kolejną pozycję (np. z tym samym magazynem docelowym) - należy wcisnąć Ctrl L.

UWAGA. W polach, po których można wyszukiwać MM znajdują się m.in. pola:

  • Numer - pełny nr dokumentu, np. 2/12/MM

  • Nr - tylko nr kolejny, np. 2. Szukanie wg tego pola jest o wiele szybsze niż wg pola Numer.

Dodatkowa funkcja [image] F4 umożliwia ustawienie stałego filtru na dokumenty spełniające zadane kryteria:

  • Dokument - dokumenty jednego rodzaju

  • Z magazynu - wszystkie MM z określonego magazynu

  • Do magazynu - wszystkie MM do określonego magazynu.

Filtr [image] umożliwia wybranie dokumentów według dowolnych kryteriów.

Klawisz F2 udostępnia następujące [image] wydruki:

  • MM - wydruk bieżącego dokumentu MM

  • Przesunięcia - dokumenty - lista wystawionych w wybranym okresie dokumentów MM

  • Przesunięcia - dokumenty z podziałem na magazyn docelowy – lista dokumentów MM wystawionych w wybranym okresie z podziałem na magazyn docelowy, czyli pole "Do magazynu"

  • Przesunięcia - dokumenty z podziałem na magazyn źródłowy – lista dokumentów MM wystawionych w wybranym okresie z podziałem na magazyn źródłowy, czyli pole "Z magazynu"

  • Przesunięcia - pozycje dokumentów - pozycje z dokumentów MM

  • Wydruk listy - lista wszystkich dokumentów zawierających się w aktualnym oknie

  • Wydruk pozycji - wydruk szczegółowych informacji na temat konkretnej pozycji, znajdującej się w oknie MM.


Pozycje MM

Pozycje

MAGAZYN - PRZESUNIĘCIA MIĘDZYMAGAZYNOWE - Wystawianie MM

Wprowadzanie pozycji jest kluczowym elementem wystawiania MM.

Pozycje można wpisywać na dwa sposoby:

  1. zalecany - bezpośrednio na MM w tabelce na zakładce Pozycje

    • zalety:

      • szybkie wprowadzanie najpotrzebniejszych danych (asortyment, ilość)

      • podgląd na bieżący stan asortymentów w momencie wyboru asortymentu

      • możliwość wprowadzenia wszystkich danych bezpośrednio z klawiatury (bez używania myszy)

    • wady:

      • brak lub utrudniony dostęp do pełnych informacji na temat pozycji (ceny i wartości netto/brutto, łączna waga przesuwanych jednostek itp.)

  2. w dodatkowym oknie Pozycje, wywołanym przyciskiem

    • zalety:

      • pełna informacja dotycząca pozycji MM

    • wady:

      • konieczność wywołania osobnego okna

      • utrudniony dostęp do bieżących stanów magazynowych.

W zależności od wybranego sposobu:

  1. zakładka Pozycje:

    • przechodzimy do tabelki z pozycjami znajdującej się na zakładce Pozycje

    • ustawiamy się w kolumnie Indeks lub Nazwa asortymentu i wywołujemy bibliotekę asortymentów naciskając klawisz Enter, klikając w przycisk [image] lub rozpoczynając pisanie indeksu lub nazwy szukanego asortymentu. Kolumna Indeks będzie dostępna jeśli włączyliśmy obsługę indeksów w ustawieniach - okno [image] FIRMY - F6 - Ustawienia - Ogólne - Indeksy. Po odszukaniu w oknie Asortymenty odpowiedniego asortymentu wybieramy go na MM klawiszem Enter lub klikając w przycisk [image].
      UWAGA. Jeśli wystawiamy dokumenty z dużą liczbą pozycji, warto przed rozpoczęciem wystawiania MM otworzyć okno Asortymenty (przycisk [image] w oknie głównym). Dzięki temu wybór asortymentu na pozycje dokumentu będzie dużo szybszy, gdyż program nie będzie przy każdej pozycji tracił czasu na otwieranie i zamykanie okna Asortymenty. Zamiast tego będzie się ono przełączało w tryb wyboru (w prawym górnym rogu okna pojawi się przycisk [image]), a po wybraniu asortymentu będzie wracać do normalnego trybu (zniknie przycisk [image]).

    • po wybraniu asortymentu wypełniamy (i zatwierdzamy Enter) kolejne kolumny:

      • Ile - wpisujemy odpowiednią ilość, domyślnie podpowiada się sugerowana ilość określona w bibliotece asortymentów

      • C.netto, W.netto - podstawione automatycznie cena i wartość nabycia netto

      • Nr dost. - określony automatycznie nr dostawy

      • Nr seryjny - określony automatycznie nr seryjny tej pozycji. Kolumna Nr seryjny będzie dostępna jeśli włączyliśmy obsługę numerów seryjnych w ustawieniach - okno [image] FIRMY - F6 - Ustawienia - Ogólne - Nr seryjne - Włączone.

    • wciśnięcie klawisza Enter w kolumnie Ile powoduje zatwierdzenie tej pozycji MM. Może się okazać, że po zatwierdzeniu pozycji powstanie kilka pozycji, z których łączna ilość będzie równa ilości zatwierdzanej pierwotnie pozycji. Dzieje się tak dlatego, że pozycje MM pochodzą z poszczególnych dostaw (patrz PRZYJĘCIA DO MAGAZYNU - Wystawianie PZ - Pozycje) danego asortymentu znajdujących sie aktualnie w magazynie źródłowym. Jeśli np. przesuwamy na MM 20 szt. jakiegoś asortymentu, to program odszukuje w stanie magazynu źródłowego pierwszą dostawę (wg algorytmu FIFO lub LIFO określonego w danych firmy) i sprawdza czy jest w niej wystarczająca ilość towaru.
      Jeśli w tej dostawie będzie np. 25 szt., to zostanie utworzona pozycja MM pochodząca z tej dostawy z ilością 20 szt., a stan bieżący dostawy w magazynie źródłowym zostanie zmniejszony do 5 szt.
      Jeśli natomiast okazałoby się, że w pierwszej znalezionej dostawie jest np. tylko 8 szt., to powstałaby pozycja MM z tymi właśnie 8 szt., znaleziona dostawa zostałaby usunięta z magazynu źródłowego, a program szukałby następnej dostawy pobierając z niej odpowiednią ilość. W skrajnym przypadku może się nawet zdarzyć, że np. zatwierdzając jedną pozycję MM, na której przesuwane jest 20 szt., powstanie 20 pozycji MM, z których każda będzie przesuwała 1 szt. pochodzącą z różnych dostaw.
      Takie rozwiązanie zostało przyjęte w programie ze względu na możliwość szczegółowego rozliczania poszczególnych dostaw (ważne bo każda dostawa może mieć inną cenę nabycia, numer seryjny i kontrakt).
      W analogiczny sposób tworzone są pozycje WZ w trakcie wystawiania faktury.

    • kolumny oznaczone szarym kolorem (C.netto, W.netto itd.) zawierają informacje tylko do odczytu, określone przez program na podstawie wprowadzonych wcześniej danych.

    • jeśli wprowadziliśmy już wszystkie pozycje i nie chcemy wprowadzać innych danych (uwagi, notatki itp.), możemy od razu zaakceptować cały dokument naciskając klawisze Alt PgDn.

    • pod tabelką z pozycjami znajdują się jeszcze dodatkowe pola sumaryczne:

      • Lp - liczba pozycji wpisanych na tym MM

      • Waga - łączna waga towarów z tego dokumentu

      • Netto, Vat, Brutto - sumy kwot netto, vat i brutto z wszystkich pozycji MM. Sumowanie przeprowadzane jest w ten sposób, że najpierw są sumowane z wszystkich pozycji MM kwoty będąca podstawą przeliczeń vat, czyli w zależności od ustawienia pola Podstawa na zakładce Stawki VAT, albo netto albo brutto (z podziałem na stawki vat). Potem na podstawie tych sum obliczane są brakujące sumy vat i brutto lub netto. Może się zdarzyć, że obliczona w ten sposób suma wartości vat lub brutto może się różnić od sumy vat lub brutto z poszczególnych pozycji dokumentu. Różnica ta wynika z jednostkowych zaokrągleń kwot vat i brutto na poszczególnych pozycjach MM i jest księgowo jak najbardziej prawidłowa oraz nie świadczy bynajmniej o nieprawidłowym działaniu programu.

  2. okno Pozycje:

    • klikamy w przycisk [image] lub naciskamy klawisze Alt C żeby otworzyć okno z pozycjami dokumentu:

    • wprowadzamy [image] (Ins) nową pozycję

      wypełniając poszczególne pola:

      • Asortyment

        • Nazwa - wybieramy asortyment z listy asortymentów podając jego nazwę np. towar C.
          Jeżeli pełna nazwa wybranego asortymentu jest dłuższa niż 1 linijka, to pojawi się ona w całości w szarym polu pod nazwą asortymentu.

        • Indeks - wybieramy asortyment z listy asortymentów podając jego indeks np. 4.

        • J.m., Rodzaj, PKWiU, Vat% - pozostałe dane wybranego asortymentu (tylko do odczytu, można je zmienić tylko w bibliotece asortymentów)

      • Z magazynu - określony na MM magazyn, z którego przesuwany jest towar

      • Do magazynu - określony na MM magazyn, do którego przesuwany jest towar

      • Nr seryjny - określony automatycznie nr seryjny tej pozycji. Pole Nr seryjny będzie dostępne jeśli włączyliśmy obsługę numerów seryjnych w ustawieniach - okno [image] FIRMY - F6 - Ustawienia - Ogólne - Nr seryjne - Włączone.

      • Netto - zakładka umożliwiająca wprowadzenie ilości (Ilość) oraz odczytanie znalezionej ceny nabycia netto i wartości. Dodatkowo w polu Podstawa przypomniana jest określona w dokumencie podstawa przeliczeń netto/brutto.

      • Brutto - analogicznie j.w., z tym że dotyczy cen i wartości nabycia brutto (zawierających podatek VAT)

      • Inne

        • Kontrakt - kontrakt, do którego należy ta pozycja. Dostępny tylko w wersji MAXI i PRO.

      • Nr dost. - nadawany automatycznie numer dostawy

      • Waga [kg] - łączna waga w kilogramach tej pozycji. Obliczana jako iloczyn ilości jednostek z tej pozycji MM i określonej w bibliotece asortymentów wagi jednostkowej tego asortymentu (tzn. wagi jednej jednostki asortymentu).

    • po wprowadzeniu wszystkich danych zatwierdzamy całą pozycję klikając w przycisk OK lub naciskając klawisze Alt PgDn.

UWAGA. Nic nie stoi na przeszkodzie, żeby w zależności od potrzeb korzystać z kombinacji przedstawionych wyżej sposobów. Ze względu na łatwość i szybkość wprowadzania danych warto wprowadzać pozycje bezpośrednio w tabelce na zakładce Pozycje i korzystać z okna Pozycje tylko w razie potrzeby. Np. jeśli chcemy sprawdzić szczegółowe dane jakiejś pozycji ustawiamy się na niej w tabelce i naciskamy Alt F6 - wywołamy w ten sposób okno Pozycje w trybie edycji(poprawy) tej pozycji MM. Podobnie, jeśli naciśniemy w tabelce klawisze Alt Ins, wywołamy okno Pozycje w trybie wprowadzania nowej pozycji. W obu przypadkach po akceptacji lub rezygnacji ze zmian okno Pozycje zostanie zamknięte i wrócimy do tabelki z pozycjami dokumentu.


Wydruki

MAGAZYN - PRZESUNIĘCIA MIĘDZYMAGAZYNOWE

Po wystawieniu MM można go wydrukować. W tym celu wciskamy klawisz F2 lub klikamy w ikonkę [image] i wybieramy z menu wydruków MM.

W okienku WYDRUK ustawiamy odpowiednie opcje:

  • Ceny nabycia

    • Bez vatu - przy poszczególnych pozycjach MM będzie wyszczególniona tylko cena i wartość nabycia netto

    • Z vatem - j.w., dodatkowo vat i wartość nabycia brutto

    • Brak - bez ceny nabycia

  • Oryginał/Kopia

    • Oryginał + Kopia - wydrukują się 2 egzemplarze dokumentu - jeden z napisem Oryginał i drugi z napisem Kopia

    • Oryginał - wydrukuje się jeden egzemplarz dokumentu z napisem Oryginał

    • Kopia - wydrukuje się jeden egzemplarz dokumentu z napisem Kopia

    • Oryginał/Kopia - wydrukuje się jeden egzemplarz dokumentu z napisem Oryginał / Kopia

    • Duplikat - wydrukuje się jeden egzemplarz dokumentu z napisem Duplikat z dnia ....

    • Oryginał + 2 Kopie - wydrukują się 3 egzemplarze dokumentu - jeden z napisem Oryginał i dwa z napisem Kopia

    • Oryginał + 3 Kopie - wydrukują się 4 egzemplarze dokumentu - jeden z napisem Oryginał i trzy z napisem Kopia

i przygotowujemy do druku [image] bieżący dokument. Przygotowany wydruk pokaże się w oknie Przegląd wydruku. Możemy również skorzystać z funkcji bezpośredniego wydruku na drukarce (domyślnej lub ostatnio wybranej) [image], z pominięciem okna Przegląd wydruku.

Jeśli chcielibyśmy coś zmienić w wyglądzie MM możemy sprawdzić ustawienia parametrów w oknie Definicje dokumentów (menu główne Ustawienia - Definicje dokumentów) na zakładce Wydruki. Możemy również samodzielnie zmodyfikować standardową makietę dokumentu wprowadzając w niej praktycznie dowolne zmiany (menu główne Ustawienia - Makiety dokumentów).

Oprócz dokumentu możemy również wydrukować:

  • Przesunięcia - dokumenty - lista wystawionych w wybranym okresie dokumentów MM

  • Przesunięcia - dokumenty z podziałem na magazyn docelowy - lista dokumentów MM wystawionych w wybranym okresie z podziałem na magazyn docelowy, czyli pole "Do magazynu"

  • Przesunięcia - dokumenty z podziałem na magazyn źródłowy - lista dokumentów MM wystawionych w wybranym okresie z podziałem na magazyn źródłowy, czyli pole "Z magazynu"

  • Przesunięcia - pozycje dokumentów - pozycje z dokumentów MM

  • Wydruk listy - lista wszystkich dokumentów zawierających się w aktualnym oknie

  • Wydruk pozycji - wydruk szczegółowych informacji na temat konkretnej pozycji, znajdującej się w oknie MM.

Opisane wyżej zestawienia wykonywane są na podstawie przgotowanej wcześniej definicji. Korzystając z polecenia menu głównego Ustawienia - Definicje zestawień wywołujemy okno DEFINICJE ZESTAWIEŃ, w którym możemy poprawić [image] (F6) definicję istniejącego zestawienia lub utworzyć [image] (Ins) definicję zupełnie nowego zestawienia odpowiadającego naszym specyficznym potrzebom (patrz INSTRUKCJA ADMINISTRATORA - PARAMETRYZACJA SYSTEMU - Definicje zestawień).

Wydruk MM można wykonać na drukarce igłowej w trybie znakowym (patrz ROZPOCZĘCIE PRACY - Okno główne - Przegląd wydruku - Wydruki znakowe).


WYDANIA Z MAGAZYNU

MAGAZYN

Wydanie towarów z magazynu odbywa się za pomocą dokumentów WZ ("Wydanie Zewnętrzne") lub dokumentów RW ("Rozchód Wewnętrzny").

Dokumenty wydania wprowadzamy w oknie Faktury. Jest to wspólne okno dla dokumentów sprzedaży i dokumentów wydania z magazynu. Okno Faktury możemy otworzyć klikając w oknie głównym w przycisk [image] .

Jeśli korzystamy z modułu SPRZEDAŻ, tzn. wystawiamy również dokumenty sprzedaży (faktury), to oprócz wystawiania dokumentów WZ, które są niezależne od faktur, możemy również korzystać z dokumentów WZ tworzonych automatycznie w trakcie wystawiania faktury. To drugie rozwiązanie jest bardzo atrakcyjne w przypadku, gdy WZ jest dla nas tylko dokumentem dodatkowym do faktury, służącym zdjęciu z magazynu zafakturowanych pozycji.

W kolejnych rozdziałach znajdziemy opisy wystawiania niezależnych dokumentów WZ oraz dokumentów WZ sporządzanych automatycznie w trakcie wystawiania faktury, a także opis wystawiania dokumentów RW.


Wystawianie WZ

MAGAZYN - WYDANIA Z MAGAZYNU

Opis zawarty w tym rozdziale dotyczy dokumentów WZ wystawianych celowo jako osobny, niezależny dokument wydania z magazynu. Jeśli interesują nas WZ wystawiane automatycznie w trakcie wystawiania faktury VAT, należy się zapoznać z opisem dotyczącym zakładki WZ w rozdziale MAGAZYN - WYDANIA Z MAGAZYNU - Automatyczny WZ do faktury.

Wystawianie WZ nie różni się niczym od wystawiania faktury czy dowolnego innego dokumentu sprzedaży. Po prostu w polu Rodzaj dokumentu wybieramy WZ lub inny zdefiniowany wcześniej dokument typu WZ.

Podobnie jak na fakturze, wpisujemy na zakładce Pozycje pozycje WZ w cenach sprzedaży, a na zakładce WZ tworzone są automatycznie pozycje WZ zdejmujące towar z poszczególnych dostaw znajdujących się w magazynie.

Różnica polega jedynie na formie wydruku (z menu wydruków dostępna jest tylko pozycja WZ) oraz sposobie księgowania i rozliczania dokumentu (nie jest traktowany jako sprzedaż).

Dzięki temu, że określamy z góry ceny sprzedaży, możemy łatwo w przyszłości wystawić do tego WZ fakturę sprzedaży (patrz SPRZEDAŻ - Faktura do WZ). Jeśli do WZ wystawiono już fakturę, to jej numer i data wystawienia widoczne są w grupie pól Powiązana faktura po lewej stronie przycisku OK.

Jeśli w zależności od potrzeb wystawiamy zarówno niezależne dokumenty WZ jak i dokumenty WZ sporządzane automatycznie w trakcie wystawiania dokumentów sprzedaży, to jeżeli w obu przypadkach korzystają one z tej samej definicji WZ, będą one numerowane w sposób ciągły bez względu na sposób wystawienia.
Korzystanie z tej samej definicji oznacza:

  • w przypadku WZ niezależnego - wybór tej definicji w trakcie wystawiania WZ w polu Rodzaj dokumentu

  • w przypadku WZ automatycznego - wybór tej samej definicji WZ w definicji faktury (menu Ustawienia - Definicje dokumentów - F6 - Zawartość - WZ - WZ).

Numerowanie w sposób ciągły oznacza, że niezależnym i automatycznym dokumentom WZ nadawane zostają numery kolejne w porządku chronologicznym, np. tak jak w poniższym oknie po włączeniu do zestawu aktywnych kolumn [image] Ctrl F4 na zakładce Lista kolumny Numer WZ.

Kolumna Numer to numer dokumentu sprzedaży lub niezależnego WZ, a kolumna Numer WZ to numer WZ bez względu na sposób jego wystawienia (automatyczny czy niezależny):

Numer | Numer WZ | Uwagi
1/12/RW | 1/12/RW | Rozchód wewnętrzny 1/12/RW
9/12 | 9/12/WZ | Faktura 9/12, automatyczny WZ nr 9/12/WZ
10/12/WZ | 10/12/WZ | Niezależny WZ nr 10/12/WZ
11/12/WZ | 5/07/WZ | Niezależny WZ nr 11/12/WZ
11/12 |  | Faktura 11/12, bez automatycznego WZ
12/12/WZ | 12/12/WZ | Niezależny WZ nr 12/12/WZ
1/12/PG | 13/12/WZ | Paragon 1/12/PG, automatyczny WZ nr 13/12/WZ
10/12 | 14/12/WZ | Faktura 10/12, automatyczny WZ nr 14/12/WZ

Pole Numer WZ może być również bardzo pomocne przy wyszukiwaniu [image] Ctrl F7 dokumentów WZ.

Przed wydrukiem WZ [image] F2 możemy określić:

  • Cena - rodzaj cen, które pojawią się na wydruku

    • brak - bez żadnych cen, ta forma wydruku WZ jest przydatna, jeśli np. wystawiamy klientowi WZ w magazynie i na podstawie tego WZ klient udaje się do działu sprzedaży po fakturę

    • nabycia - WZ wystawiony na nasze potrzeby wewnętrzne, np. po to żeby zaksięgować prawidłowo sprzedaż w cenach nabycia (pełna księgowość)

    • sprzedaży - jeśli np. dostarczamy klientowi towar codziennie na podstawie WZ, pobieramy od razu za dostarczony towar zapłatę (po to ceny sprzedaży), a np. raz na tydzień wystawiamy fakturę zbiorczą do wszystkich wystawionych WZ.

    • ewidencyjna, sprzedaży - 1, sprzedaży - 2, sprzedaży - 3 - dla celów księgowych możemy wydrukować WZ wyceniony wg tych cen. Opcja dostępna tylko jeśli w definicji WZ na zakładce Wydruk zaznaczyliśmy parametr Dodatkowe ceny.

  • Każdy magazyn osobno - jeśli towar na jednym WZ pochodzi z kilku magazynów, możemy automatycznie wydrukować osobne WZ dla każdego z magazynów występujących na WZ. Opcja dostępna tylko dla wydruku w cenach nabycia lub bez cen.

Wydruk WZ można wykonać na drukarce igłowej w trybie znakowym (patrz ROZPOCZĘCIE PRACY - Okno główne - Przegląd wydruku - Wydruki znakowe).


Automatyczny WZ do faktury

MAGAZYN - WYDANIA Z MAGAZYNU

Opis zawarty w tym rozdziale dotyczy głównie dokumentów WZ sporządzanych automatycznie w trakcie wystawiania faktury, ale częściowo również zakładki WZ na niezależnych dokumentach WZ i RW (patrz MAGAZYN - WYDANIA Z MAGAZYNU).

Jeśli prowadzimy magazyn, chcemy aby program automatycznie aktualizował stany magazynowe poszczególnych asortymentów w trakcie wystawiania faktur. Odbywa się to przez automatyczne tworzenie dokumentu WZ do faktury. Szczegółowe informacje dotyczące automatycznego WZ zawiera znajdująca się na fakturze zakładka WZ.

W przypadku dokumentów WZ i RW zakładka WZ pokazuje z jakich dostaw został faktycznie wydany towar na tych dokumentach.

Poszczególne pola oznaczają:

  • WZ - czy WZ do tej faktury jest włączony. Standardowo to pole jest włączone i w momencie zatwierdzania pozycji faktury jest tworzona automatycznie odpowiednia pozycja WZ zdejmująca towar z magazynu. Jeśli z jakichś powodów wyłączymy to pole, towar znajdujący się już na pozycjach tego WZ zostanie zwrócony do magazynu. Ponowne włączenie pola WZ spowoduje wydanie z magazynu towaru znajdującego się na pozycjach faktury. Włączenie pola WZ jest możliwe tylko wtedy, gdy każda z pozycji faktury figuruje w odpowiedniej ilości w magazynie. W przypadku niezależnych dokumentów WZ i RW pole WZ jest zawsze włączone.

  • Magazyn - magazyn, z którego pochodzi towar wydawany na tym WZ. Pole to należy traktować tylko orientacyjnie, gdyż każda z pozycji faktury może pochodzić z innego magazynu, a nawet każda dostawa dotycząca tej samej pozycji faktury może pochodzić z różnych magazynów.
    Domyślnie Magazyn ustawia się na taki, jaki jest aktualnie wybrany w oknie z asortymentami. Jeśli jednak pozycje faktury będą w całości wydane z innych magazynów, pole Magazyn będzie odpowiednio zmienione.

  • z kilku magaz. - zaznaczone jeśli towar na WZ został wydany z kilku magazynów

  • Numer - numer kolejny dokumentu WZ, najlepiej nie wypełniać tego pola ręcznie - program automatycznie w momencie akceptacji dokumentu podstawi kolejny, unikalny numer. Dzięki temu, że numer jest nadawany dopiero w momencie akceptacji, dokumenty będą prawidłowo numerowane przy równoczesnym sieciowym wystawianiu kilku WZ przez różnych użytkowników programu. Pole Numer składa się z 2 części: białej i szarej, w części szarej pokazany jest pełny numer dokumentu, w układzie określonym w definicji dokumentu WZ związanego z wystawianą właśnie fakturą, np. 9/12/WZ, a w części białej właściwy numer kolejny, czyli np. 9. Po dwukrotnym kliknięciu myszką w białą część pole Numer zmienia się na pole Układ umożliwiając zmianę układu numeru na inny niż określony w definicji dokumentu. W przypadku niezależnych dokumentów WZ i RW pole Numer odpowiada zawsze głównemu numerowi dokumentu WZ lub RW.
    UWAGA. Kolumnę Numer WZ można włączyć do zestawu aktywnych kolumn ( [image] Ctrl F4) na zakładce Lista. Dzięki temu można szybko zlokalizować dokument WZ bez względu na to, czy został wystawiony automatycznie do faktury, czy ręcznie jako niezależny dokument.

Poniżej tych pól znajduje się tabelka zawierająca pozycje WZ. Powstają one automatycznie w momencie zatwierdzania poszczególnych pozycji faktury.

Każdej pozycji faktury odpowiada jedna lub więcej pozycji WZ. Pozycje WZ pochodzą z poszczególnych dostaw (patrz PRZYJĘCIA DO MAGAZYNU - Wystawianie PZ - Pozycje) danego asortymentu znajdujących się aktualnie w magazynie. Jeśli np. sprzedajemy na fakturze 20 szt. jakiegoś asortymentu, to program odszukuje w stanie magazynu pierwszą dostawę (wg algorytmu FIFO lub LIFO określonego w danych firmy) i sprawdza czy jest w niej wystarczająca ilość towaru.
Jeśli w tej dostawie będzie np. 25 szt., to zostanie utworzona pozycja WZ pochodząca z tej dostawy z ilością 20 szt., a stan bieżący dostawy w magazynie zostanie zmniejszony do 5 szt.
Jeśli natomiast okazałoby się, że w pierwszej znalezionej dostawie jest np. tylko 8 szt., to powstałaby pozycja WZ z tymi właśnie 8 szt., znaleziona dostawa zostałaby usunięta z magazynu, a program szukałby następnej dostawy pobierając z niej odpowiednią ilość. W skrajnym przypadku może się nawet zdarzyć, że np. jednej pozycji faktury, na której sprzedane jest 20 szt., będzie odpowiadało 20 pozycji WZ, z których każda będzie zdejmowała ze stanu 1 szt. pochodzącą z róznych dostaw.
Takie rozwiązanie zostało przyjęte w programie ze względu na możliwość szczegółowego wyliczenia marży i zysku oraz rozliczenia sprzedaży w cenach nabycia (ważne przy pełnej księgowości) - przy tej samej cenie sprzedaży każda dostawa może mieć inną cenę nabycia. Powiązanie pozycji WZ z dostawami umożliwia również rozliczenie kontraktów oraz prawidłową obsługę numerów seryjnych - każda dostawa może mieć inny nr seryjny i należeć do innego kontraktu.

Szare kolumny tabelki są tylko do odczytu, białe można modyfikować. Oto znaczenie poszczególnych kolumn:

  • Indeks - określony na pozycji faktury indeks asortymentu. Kolumna Indeks będzie dostępna, jeśli włączyliśmy obsługę indeksów w ustawieniach - okno [image] FIRMY - F6 - Ustawienia - Indeksy.

  • Nazwa - określona na pozycji faktury nazwa asortymentu.

  • Ile - ilość wydana na tej pozycji. Suma ilości ze wszystkich pozycji WZ odpowiadających jednej pozycji faktury jest zawsze równa łącznej ilości określonej na tej pozycji faktury. Można zmienić ilość wydaną z danej dostawy wpisując tu właściwą ilość.

  • Magazyn - magazyn, z którego wydawany jest towar. Domyślnie podstawiany jest magazyn określony na pozycji faktury. Można go zmienić [image] wybierając dostawę znajdującą się w innym magazynie.

  • Nr dost. - numer dostawy, z której pochodzi towar. Dostawa odpowiada pozycji PZ. Ma konkretną określoną w momencie przyjęcia cenę nabycia oraz ewentualnie nr seryjny. Możemy zmienić wybrana dostawę [image] na inną znajdującą się aktualnie w magazynie.

  • Nr seryjny - nr seryjny tej dostawy. Kolumna Nr seryjny będzie dostępna jeśli włączyliśmy obsługę numerów seryjnych w konfiguracji - menu główne Ustawienia - Konfiguracja - Ogólne - Nr seryjne. Jeśli chcemy wydać towar o innym nr seryjnym, czyli zmienić dostawę, klikamy w przycisk [image].

  • C.n.netto - cena nabycia netto

  • W.nab.netto - wartość nabycia netto

  • jeśli korzystamy z rozliczania kosztów transportu (patrz PRZYJĘCIA DO MAGAZYNU - Wystawienie PZ - Transport). Dostępne tylko w wersji MAXI i PRO.

    • C.transp. - jednostkowy koszt transportu

    • W.transp. - zbiorczy koszt transportu tej pozycji

  • W.sprz.netto - wartość sprzedaży netto

  • Zysk Wz - zysk od towarów i produktów obliczony jako różnica między wartością sprzedaży towarów i produktów a wartością nabycia

  • Zysk - zysk od całego dokumentu (towary, produkty i usługi)

  • Marża% - marża uzyskana na sprzedaży tej pozycji WZ. Marża jest obliczana zgodnie z algorytmem określonym w ustawieniach firmy.

  • Kontrakt - nazwa kontraktu, do którego należy ta pozycja. Kolumna Kontrakt będzie dostępna jeśli włączyliśmy obsługę kontraktów w konfiguracji - menu główne Ustawienia - Konfiguracja - Ogólne - Kontrakty (dostępne tylko w wersji MAXI i PRO).

Pod tabelką znajdują się dodatkowe pola (W.nabycia, W.sprzedaży, Zysk, Marża%), zawierające sumaryczne dla całego WZ wartości odpowiednich wielkości.

Zakładka WZ jest również dostępna w oknie z pozycjami faktury. W tym przypadku zawiera ona tabelkę z pozycjami WZ związanymi z jedną, aktualną pozycją faktury. Informacje zawarte w tej tabelce oraz zasady ich modyfikacji są analogicznie jak w tabelce na zakładce WZ bezpośrednio na dokumencie - patrz opis powyżej.

Na fakturze wystawionej do istniejącego wcześniej dokumentu WZ, zakładka WZ zamiast danych sporządzonego automatycznie WZ zawiera listę dokumentów WZ, na podstawie których wystawiono tę fakturę (patrz SPRZEDAŻ - Faktura do WZ).


Wystawianie RW

MAGAZYN - WYDANIA Z MAGAZYNU

Dokumentów RW (rozchód wewnętrzny) używamy wtedy, gdy wydajemy z magazynu towar, który będzie wykorzystany na potrzeby własne naszej firmy (nie będzie sprzedany).

Wystawianie RW różni się od wystawiania WZ kilkoma szczegółami:

  • pole Rodzaj ceny na zakładce Pozycje jest na sztywno ustawiony na wartość N czyli cenę nabycia - RW nie będzie zamieniany w przyszłości na fakturę VAT, ani żaden inny dokument sprzedaży, a magazyn rozliczamy w cenach nabycia, stąd takie właśnie ceny

  • z podobnego powodu jak powyżej nie można udzielić rabatu ani na pozycji ani na całym dokumencie

  • nie określamy pola Nabywca - rozchód odbywa się na potrzeby wewnętrzne, więc nabywca nie ma sensu.

Aby wystawić RW w polu Rodzaj dokumentu wybieramy RW lub inny zdefiniowany wcześniej dokument typu RW.

Podobnie jak na WZ, wpisujemy na zakładce Pozycje pozycje RW, a na zakładce WZ tworzone są automatycznie pozycje zdejmujące towar z poszczególnych dostaw znajdujących się w magazynie.

Po wybraniu asortymentu na zakładce Pozycje, jako cena sprzedaży netto przed rabatem (_C.netto) podstawi się ostatnia cena nabycia tego asortymentu zapamiętana w bibliotece asortymentów. Po zaakceptowaniu tej pozycji RW, w momencie gdy zostanie ona wydana z magazynu, cena zostanie automatycznie dopasowana do ceny nabycia wynikającej z konkretnej dostawy, z której pochodzi towar. Jeśli towar będzie pochodził z kilku dostaw, cena nabycia zostanie obliczona jako średnia cena nabycia (łączna Wartość nabycia policzona jako suma wartości z poszczególnych dostaw podzielona przez sumaryczną Ilość).

Na dokumentach RW na zakładce FK oprócz możliwości przypisania Konta zakupów i Konta kosztów w przypadku włączonej integracji modułów (R2firma) dostępne jest także pole MPK, czyli Miejsca Powstawania Kosztów. Pole to będzie automatycznie uwzględniane przy imporcie RW do programu R2fk.

Dokumenty RW są dostępne tylko w wersji MAXI i PRO.

Można je eksportować automatycznie do programu finansowo-księgowego R2fk.


Koszt własny sprzedaży

MAGAZYN - WYDANIA Z MAGAZYNU

Jeśli prowadzimy pełną księgowość, to na pewno będzie nam potrzebne rozliczenie sprzedaży w cenach nabycia, czyli rozliczenie kosztu własnego sprzedaży (KWS). Dzięki temu będziemy mogli obliczyć zysk ze sprzedaży, który jest równy wartości w cenach sprzedaży pomniejszonej właśnie o KWS. Ponadto KWS jest pomocny do kontroli bilansu magazynu, gdyż wartość towarów w magazynie powinna być równa wartości z wszystkich przyjęć pomniejszonej o KWS.

KWS obliczany jest na bieżąco na każdej wystawionej fakturze. Na zakładce WZ znajduje się lista dostaw, z których pochodzi towar wydany na WZ do tej faktury. Przy każdej dostawie jest wyszczególniona cena nabycia (kolumna C.n.netto) i wartość w cenach nabycia (kolumna W.nab.netto). Pod tabelką z dostawami znajduje się podsumowanie z łączną wartością nabycia (pole W.nabycia) towaru sprzedanego na tej fakturze. Łączna wartość nabycia jest również dostępna na liście faktur przy każdej fakturze jako kolumna W.nabycia.

Opisane wyżej wartości nabycia pochodzą z momentu wystawienia danej pozycji faktury, z uwzględnieniem ewentualnych dokumentów PZ korygujących cenę nabycia. Np. jeśli wydaliśmy towar z tej samej dostawy na fakturach wystawionych w dniu 10.07.2008 i 20.07.2008, a pomiędzy nimi z datą 15.07.2008 został wystawiony PZ korygujący cenę nabycia tej dostawy, to na fakturze z 10.07 będzie figurowała pierwotna cena nabycia, a na fakturze z 20.07 cena skorygowana. Oznacza to, że jeśli chcemy zbilansować wartościowo magazyn, musimy skorygować KWS za dany okres o różnicę w cenach nabycia spowodowaną wystawionymi w tym okresie PZ korygującymi. Do tego celu służy dostępne w menu wydruków F2 przy każdym PZ korygującym okno Korekta kosztu sprzedaży.

Okno Korekta kosztu sprzedaży zawiera listę dostaw skorygowanych na danym PZ korygującym, które zostały wydane w całości albo częściowo przed datą sporządzenia PZ korygującego. Przy każdej dostawie wyszczególniona jest wartość nabycia obowiązująca w dniu wydania tej dostawy (kolumna BYŁO (wartość)) oraz wartość nabycia jaka powinna być po uwzględnieniu bieżącej korekty (kolumna JEST (wartość)). Różnica pomiędzy tymi wartościami (kolumna KOREKTA (wartość)) daje po zsumowaniu kwotę, o którą należy skorygować KWS. Pod przyciskiem F2 dostępny jest wydruk Korekta kosztu sprzedaży, na podstawie którego możemy przygotować w systemie finansowo-księgowym dokument PK korygujący KWS.

Jeśli z jakichś powodów zmienimy ceny lub daty wystawienia na dokumentach PZ lub PZ korygujących, a wydaliśmy już towar przyjęty na tych PZ-ach, to ceny i wartości nabycia na odpowiednich dokumentach sprzedaży, na zakładce WZ, zostaną automatycznie zaktualizowane. Nie zostaną natomiast, ze względu na czasochłonność takiej operacji, zaktualizowane automatycznie łączne wartości nabycia na tych dokumentach sprzedaży (pole W.nabycia w podsumowaniu tabelki na zakładce WZ). Aby je zaktualizować, należy skorzystać z dostępnej w menu podręcznym okna z fakturami (prawy klawisz myszy) funkcji Dodatkowe funkcje - Aktualizuj ceny nabycia - we wszystkich dokumentach z aktualnego zakresu. Jako zakres należy ustawić wszystkie (pusty filtr w F4) dokumenty z okresu F12 od daty zmienianego PZ do daty bieżącej.

Łączny i zawsze aktualny KWS możemy zawsze sprawdzić w polu W.nab.netto w podsumowaniu okna wywołanego jako zestawienie Wz - pozycje dokumentów dostępne z menu głównego Raporty. Jest on na bieżąco aktualizowany po każdej zmianie dokumentów PZ i nie wymaga opisanej wyżej aktualizacji cen nabycia.

UWAGI:

  1. Nie powinniśmy nigdy wydawać towaru z dostaw, których nie powinno być na stanie magazynu ze względu na chronologię dokumentów. Np. jeśli przyjęliśmy w dniu 10.08.2008 jakąś dostawę towaru, tzn. wystawiliśmy PZ z taką datą, to nie możemy wydać tego towaru na fakturze z datą wcześniejszą niż 10.08.2008. Przy próbie takiej operacji program pokaże odpowiednie ostrzeżenie, ale pozwoli na jej wykonanie. W efekcie, koszt własny sprzedaży towaru z takiej dostawy będzie równy zero, bo w momencie wydania cena takiej dostawy była jeszcze nieokreślona. W konsekwencji będziemy mieli źle rozliczony koszt własny sprzedaży.
  2. Magazyn jest wartościowo zbilansowany jeśli:
    PZ-KWS-KWS(korekty)=STAN
    gdzie:

    • PZ - wartość z wszystkich przyjęć w cenach nabycia (łącznie z PZ korygującymi) - suma kolumny Netto w oknie PZ

    • KWS - koszt własny sprzedaży z wszystkich wydań - suma kolumny W.nab.netto w oknie Zestawienia - Pozycje WZ

    • KWS(korekty) - korekta kosztu sprzedaży wynikająca z dokumentów PZ korygujących cenę nabycia - dla każdego PZ korygującego trzeba wydrukować F2 okno KOREKTA KOSZTU SPRZEDAŻY, suma pól KOREKTA (wartość) z tych wydruków daje właśnie łączną korektę kosztu sprzedaży

    • STAN - wartość magazynu w cenach nabycia - suma kolumny W.nab.netto - pole Wartość netto

    Równanie bilansowe może wyglądać np. tak:
    2000-1000-(-200)=1200
    gdzie:

    • 2000 - wartość z wszystkich przyjęć

    • 1000 - koszt własny sprzedaży z wszystkich wydań

    • -200 - korekta kosztu sprzedaży wynikająca z dokumentów PZ korygujących cenę nabycia

    • 1200 - wartość magazynu w cenach nabycia

  3. Jako podstawę księgowania KWS za dany okres można przyjąć np. dokumenty WZ wydrukowane w cenach nabycia albo zestawienie Wydania - pozycje z podziałem na dokumenty dostępne w menu głównym Raporty oraz w menu drukowania okna Faktury. Dodatkowo wydruki Korekta kosztu sprzedaży z każdego PZ korygującego.


STAN MAGAZYNU

MAGAZYN

Aby sprawdzić bieżący stan magazynu wystarczy kliknąć w oknie głównym w przycisk [image]. Wywołamy w ten sposób okno Stan magazynu, które zawiera szczegółowe informacje o znajdujących się aktualnie w wybranym magazynie dostawach.

Słowo "aktualnie" należy tu traktować dosłownie, gdyż informacje zawarte w oknie Stan magazynu nie odświeżają się automatycznie, lecz pokazują zawsze stan magazynu aktualny w momencie otwarcia okna. Jeśli chcemy odświeżyć zawartość okna, możemy nacisnąć klawisze Ctrl F5 lub skorzystać z funkcji [image] Odśwież w menu podręcznym (prawy klawisz myszy).

Poszczególne wiersze w oknie Stan magazynu odpowiadają właśnie dostawom, czyli poszczególnym pozycjom z dokumentów przyjęć PZ, które zostały przyjęte (bądź przesunięte - MM) do bieżącego magazynu, ale nie zostały z niego jeszcze w całości wydane (bądź przesunięte). Bieżący magazyn jest widoczny w pasku statusu w lewym dolnym rogu okna. Określamy go we [image] F4 właściwościach okna.

Na przykładzie zamieszczonego wyżej okienka widzimy np. że w magazynie Główny znajdują się aktualnie trzy dostawy (nr 19, 20 i 23) asortymentu o indeksie 12 i nazwie towar G. Pozycje w oknie są standardowo uporządkowane wg algorytmu, czyli w przypadku FIFO wg narastających numerów dostaw. Jeśli chcemy zmienić to uporządkowanie, np. na takie, które jest zgodne z nazwą asortymentu, wystarczy kliknąć w nagłówek odpowiedniej kolumny, czyli w tym przypadku kolumny Nazwa.

Przewijając okno Stan magazynu w prawo, możemy sprawdzić szczegóły dotyczące pochodzenia danej dostawy (kolumny Dostawca, PZ nr oraz PZ data):

Ponadto w kolumnach Blok.przez PZ nr (blokada założona przez PZ nr) oraz Data blok. (data blokady) możemy sprawdzić jaki dokument i kiedy zablokował daną dostawę. Zablokowana dostawa jest zaznaczona w oknie Stan magazynu na czerwono. Dostawy takiej nie można przesunąć ani wydać, a ilość z niej pochodząca nie wchodzi w skład dostępnej ilości danego asortymentu w wybranym magazynie (kolumna Stan w oknie Asortymenty).

Dostawa jest blokowana gdy:

  • zablokowany jest dokument PZ, z którego ta dostawa pochodzi - bo np. jest dopiero w trakcie sporządzania

  • dostawa pochodzi z "Zamówienia do dostawcy", czyli dokumentu, który zdefiniowaliśmy na bazie dokumentu Inny (zakup) i który jest celowo zablokowany do czasu faktycznego otrzymania zamówionego towaru

  • dostawa została właśnie poprawiona na istniejącym już PZ, ale PZ nie został jeszcze zaakceptowany.

Może się zdarzyć, że dostawa została zablokowana przez program, który w wyniku awarii nieprawidłowo zakończył swoje działanie. Taka dostawa nie zostanie odblokowana automatycznie. Aby ją odblokować, a co za tym idzie umożliwić korzystanie z niej, należy wyedytować [image] F6 i zatwierdzić blokujący ją dokument PZ.

Zmieniając właściwości [image] F4 okna możemy:

  • pokazać tylko dostawy należące do wybranego asortymentu - Nazwa, Indeks

  • pokazać tylko dostawy znajdujące się w wybranym magazynie - Magazyn

  • pokazać tylko dostawy należące do wybranego kontraktu - Kontrakt

  • sprawdzić lub ustawić (Według algorytmu) aktualny sposób uporządkowania pozycji w oknie - Uporządkowanie

  • pokazać wszystkie lub tylko podświetlone Shift áâ pozycje - Selekcja.

Okno Stan magazynu można również wywołać klikając w przycisk [image] w oknie Asortymenty, po to żeby szybko sprawdzić dostawy z wybranego asortymentu. Suma ilości ze wszystkich dostaw poszczególnych asortymentów znajdujących się aktualnie na stanie magazynu jest dostępna na bieżąco w oknie Asortymenty w kolumnie Stan bez konieczności otwierania okna Stan magazynu.

W każdej chwili możemy wydrukować stan magazynu (bieżący lub na zadany dzień). W tym celu wciskamy klawisz F2 lub klikamy w ikonkę [image] i wybieramy z menu wydruków Stan magazynu.


INWENTARYZACJA

MAGAZYN

Jeżeli prowadzimy komputerową ewidencję stanów magazynowych asortymentów, to często pojawiają się różnice pomiędzy stanem księgowym wynikającym z zapisów w bazie danych a faktycznym stanem magazynowym. Przyczyny tych różnic są rozmaite: mogą to być naturalne zmiany cech przedmiotów (ulatnianie się, wysychanie, przeterminowanie), błędy popełnione przez człowieka bądź komputer, ewentualnie kradzieże i inne nadużycia.

Moduł Inwentaryzacja wspomaga uzgadnianie rzeczywistych stanów magazynowych z zapisami księgowymi w bazie danych systemu oraz kompensowanie i rozliczanie ewentualnych różnic pomiędzy tymi stanami. Aby uzyskać dostęp do funkcji modułu należy wybrać z menu głównego opcję Okna - Inwentaryzacja. Dostępna tylko w wersji MAXI i PRO.

Najważniejsze funkcje i możliwości modułu INWENTARYZACJA to:

  • Tworzenie arkuszy inwentaryzacyjnych

  • Automatyzacja odczytu spisu z natury

  • Tworzenie dokumentów kompensujących PR+ i PR-

  • Drukowanie arkuszy oraz zestawienia niedoborów/nadwyżek.


Arkusz inwentaryzacyjny

MAGAZYN - INWENTARYZACJA

Inwentaryzacja rozpoczyna się od utworzenia arkusza inwentaryzacyjnego. Aby uzyskać dostęp do edycji arkuszy należy wybrać z menu głównego opcję Okna - Inwentaryzacja. Dostępna tylko w wersji MAXI i PRO. Podczas wypisywania nowego arkusza należy wypełnić następujące pola:

  • Numer - pole to wypełni się automatycznie liczbą o 1 większą od największego numeru już istniejącego arkusza. Numer ten można zmienić, z tym że system nie pozwoli na to, aby dwa różne arkusze miały ten sam numer; numer nie może też być pusty.

  • Data wystawienia - wypełni się automatycznie datą bieżącą. Datę tę można zmienić.

  • Magazyn - jest polem obowiązkowym. Dany arkusz obejmuje wyłącznie stany asortymentowe na jednym magazynie.

  • Grupa - na arkuszu znajdą się wyłącznie asortymenty z podanej w tym polu grupy

  • Maska indeksu - na arkusz wpisane zostaną tylko indeksy zgodne z ciągiem znaków wprowadzonym w to pole. Wprowadź fragment indeksu asortymentu i znak *, np.:
    *332 - ciąg "332" i coś przed nim, np. "130332", "100/332" itp.
    *332* - ciąg "332" na dowolnym miejscu,
    332* - ciąg "332" i coś po nim, np. "332091", "332/100" itp.
    Wielkość liter nie ma znaczenia.

  • Uporządkowanie pozycji na arkuszu:

    • wg indeksu

    • wg nazwy

  • Arkusz cenowo-wartościowy - w trakcie inwentaryzacji możemy wskazać konkretną dostawę i związaną z nią cenę nabycia

  • Uwagi - jest polem nieobowiązkowym, w którym wpisujemy dowolny tekst.

Po wypełnieniu wszystkich pól i zatwierdzeniu arkusza za pomocą przycisku [image] pojawi się okienko Określ parametry arkusza, w którym będziemy mogli określić jakie asortymenty mają być wpisane na arkusz:

  • Stany magazynowe

    • bieżące - wg bieżącego stanu magazynu. Bieżącego, czyli bez żadnego przeliczania, wg stanu po wszystkich operacjach magazynowych wykonanych w programie, bez względu na ich datę. Jeśli np. ustawimy datę bieżącą na 01.10.2013, a wcześniej wykonaliśmy przyjęcia/wydania z datą 30.10.2013, to arkusz inwentaryzacyjny wg bieżącego stanu magazynu będzie odpowiadał wydrukowi na dzień 30.10.2013, a nie na 01.10.2013.

    • na dzień - wg stanu magazynu na zadany dzień. Ta opcja umożliwia przygotowanie arkusza inwentaryzacyjnego wg stanu magazynu na dowolny zadany dzień z przeszłości. Dla każdego drukowanego asortymentu program sprawdza wszystkie operacje magazynowe (PZ, WZ, MM) do zadanej daty włącznie i na tej podstawie wylicza stan magazynu.

  • Asortymenty do wpisania na arkusz

    • Wszystkie - zostaną wpisane wszystkie asortymenty z kartoteki. Wybór pierwszej z tych możliwości może spowodować, że w pewnych sytuacjach na arkusz zapisze się nam dużo niepotrzebnych asortymentów, np. wówczas, gdy prowadzimy kilka magazynów i na każdym z nich znajdują się inne asortymenty, albo gdy w kartotece asortymentów mamy dużo pozycji, które już dawno zeszły z magazynu.

    • Tylko mające niezerowy stan w magazynie - zostaną wpisane tylko asortymenty z niezerowy stanem w podanym magazynie

    • Mające jakikolwiek obrót - zostaną wpisane asotrtymenty z niezerowym obrotem w podanym magazynie

    • Mające jakikolwiek obrót w podanym okresie - zostaną wpisane asotrtymenty z niezerowym obrotem w podanym magazynie w wybranym poniżej okresie.

Po udzieleniu odpowiedzi na powyższe pytanie system automatycznie wpisze na arkusz odpowiednie asortymenty, które możemy obejrzeć naciskając przycisk [image] znajdujący się na górnej belce okna ARKUSZE INWENTARYZACJI. Pojawi się wówczas okno ARKUSZE INW. – ASORTYMENTY.

Po utworzeniu arkusza możemy przystąpić do spisu z natury faktycznych stanów magazynowych. Spisu tego możemy dokonać dwoma różnymi sposobami:

  1. automatycznie, np. za pomocą elektronicznego kolektora danych wykorzystującego kody kreskowe,

  2. w sposób tradycyjny, czyli poprzez ręczne wpisanie danych na arkusz - w takim przypadku musimy najpierw wydrukować arkusz na drukarce (patrz Wydruk arkusza inwentaryzacji).

Wyniki spisu z natury należy zapisać do arkusza w oknie ARKUSZE INW. – ASORTYMENTY.

Dla każdego asortymentu znajdującego się na arkuszu należy wpisać jego faktyczny stan wynikający ze spisu z natury oraz opcjonalnie zamieścić komentarz w polu Uwagi - można tam np. wyjaśnić przyczyny powstania ewentualnych różnic.

Jeżeli spis z natury wykonany został automatycznie, tzn. dane o stanach są umieszczone w pliku, to należy odczytać ten plik naciskając przycisk [image]. Aby dane mogły być odczytane, plik musi mieć odpowiedni format, a mianowicie:

  1. Plik musi się składać z linii oddzielonych znakami CR i LF.

  2. Każda linia powinna zawierać indeks asortymentu oraz jego stan.

Możliwe są dwa formaty linii. W pierwszym indeks musi być oddzielony od stanu spacją, a w drugim indeks i stan powinny znajdować się w cudzysłowach i być oddzielone przecinkiem. Poniżej zamieszczone są przykłady poprawnych linii pliku z danymi:

W obu tych przypadkach system odczyta, że na magazynie znajduje się 15 asortymentów o indeksie LAMPA, itd.

Przed odczytem pliku wyświetli się okno Automatyczny odczyt spisu z natury, w którym należy podać nazwę pliku z danymi, określić czy wpisywać na arkusz nadmiarowe pozycje. Chodzi o sytuację, gdy w pliku znajdzie się asortyment, którego brak na arkuszu. Jeżeli zaznaczymy pole wyboru Wpisuj na arkusz nadmiarowe pozycje, to takie pozycje będą dopisywane do arkusza (ze stanem księgowym równym 0). Jeżeli nie zaznaczymy tego pola, to pozycje takie będą pomijane podczas odczytu pliku. Następnie należy uruchomić wczytywanie danych z pliku przyciskiem Start. Możliwe jest wykonanie kilku odczytów z kilku plików na jeden arkusz.

Jeżeli spis z natury wykonany został tradycyjnie, to należy przepisać odpowiednie wartości z arkuszy spisowych do okna do pól Stan spisany. Jeżeli liczba asortymentów wykazujących niedobory lub nadwyżki jest niewielka, to możemy ułatwić sobie wypełnianie arkusza ustawiając automatycznie wszystkie pola Stan spisany na wartością zgodną z polem Stan księgowy, a następnie zająć się tylko tymi asortymentami, które podczas spisu z natury okazały się mieć różnice. Automatyczne ustawianie wszystkich asortymentów na arkuszu wykonamy naciskając przycisk [image] w oknie ARKUSZE INW. – ASORTYMENTY. Możemy też korzystać z przycisku [image]. Wciśnięcie go spowoduje, że pole Stan spisany zmieni się na wartość pola Stan księgowy tylko dla bieżącego asortymentu.

Jeżeli podczas spisu z natury wykryto asortyment, który znajduje się na stanie w danym magazynie, ale nie ma go na arkuszu, należy dopisać ten asortyment do arkusza (przycisk [image]). Jeżeli asortymentu tego nie ma jeszcze w kartotece, należy go najpierw dopisać do kartoteki asortymentów.

Po zakończeniu nanoszenia na arkusz danych wynikających z przeprowadzonego spisu z natury, można arkusz zamknąć (przyciskiem [image]). Zamknięcie arkusza zapobiegnie możliwości przypadkowego skasowania lub edycji danych na arkuszu. Aby obejrzeć niedobory i nadwyżki wynikłe podczas przeprowadzania spisu z natury należy wykonać wydruk Zestawienie różnic.


Dokumenty PR

Dokumenty PR+ i PR-

MAGAZYN - INWENTARYZACJA

Jeżeli na arkuszu inwentaryzacyjnym znajdują się asortymenty, dla których występują nadwyżki bądź niedobory, to należy odpowiednio skompensować stan księgowy, aby osiągnąć zgodność ze stanem faktycznym. Do tego celu służą dokumenty PR+ i PR–.

Różnica pomiędzy stanem rzeczywistym a księgowym może być niedoborem (stan faktyczny jest niższy niż księgowy) bądź nadwyżką (stan faktyczny jest wyższy). W związku z tym mamy dwa rodzaje dokumentów kompensujących, czyli PR+ i PR-. Niedobory korygowane są za pomocą dokumentu PR–. Dokument ten powoduje zmniejszenie stanu księgowego i tworzony jest w związku z tym w kartotece Faktury, Wz - sprzedaż i wydania z magazynu. Nadwyżki z kolei korygowane są za pomocą dokumentu PR+. Dokument PR+ powoduje zwiększenie stanu księgowego i tworzony jest w kartotece PZ - Przyjęcia do magazynu.

Definicje dokumentów PR+ i PR– znajdują się w kartotece Definicje Dokumentów. W najprostszym przypadku, jeżeli potrzebujemy tylko jednego dokumentu PR+ i PR–, możemy skorzystać ze standardowych dokumentów udostępnianych przez system i nie musimy wykonywać żadnej czynności. Natomiast jeżeli chcielibyśmy mieć po kilka różnych dokumentów typu PR+ i PR– (np. wtedy, gdy chcemy mieć osobny typ dokumentu dla każdego magazynu), musimy je zdefiniować zgodnie z ogólnymi zasadami definiowania dokumentów.

Dokumenty PR+ i PR- mogą być tworzone tylko dla zamkniętych arkuszy inwentaryzacyjnych. Zamknięcie arkusza (przyciskiem [image]) spowoduje udostępnienie przycisku [image] w oknie ARKUSZE INWENTARYZACJI. Po naciśnięciu tego przycisku pojawia się okno:

W oknie tym należy wybrać odpowiednie typy dokumentów PR i nacisnąć przycisk Wykonaj. Spowoduje to utworzenie dokumentów PR+ i PR- kompensujących wszystkie niedobory i nadwyżki dla wszystkich asortymentów z bieżącego arkusza inwentaryzacyjnego. Po zakończeniu procedury zostanie wyświetlony komunikat o numerach utworzonych dokumentów.

Ceny w pozycjach dokumentu PR+ są automatycznie ustawiane na ostatnie ceny nabycia danego asortymentu. Aby uniknąć ewentualnych nieścisłości nie są to ceny zapamiętane w bibliotece asortymentów lecz odszukane z ostatniego dokumentu, na którym był przyjęty dany asortyment. Pomijane są ceny z dokumentów, które w definicji mają wyłączony parametr Zmienia cenę nabycia.

Ceny w pozycjach dokumentów PR- są automatycznie ustawiane na ceny nabycia z poszczególnych dostaw znajdujących sie aktualnie w magazynie. Dostawy są uwzględniane w kolejności określonej ustalonym algorytmem (FIFO/LIFO), tak jak na wszystkich pozostałych dokumentach wydania z magazynu (WZ, RW).


Wydruki

MAGAZYN - INWENTARYZACJA

W ramach modułu Inwentaryzacja (dostępny tylko w wersji MAXI i PRO) możemy wykonać dwa wydruki - wydruk Arkusza inwentaryzacyjnego oraz Zestawienia różnic do arkusza. Oba te wydruki znajdują się w oknie, które otwieramy naciskając przycisk [image] w oknie ARKUSZE INWENTARYZACJI i są drukowane na podstawie makiet, dzięki czemu możemy w zależności od potrzeb dowolnie zmieniać kształt wydruków.

Wydruk arkusza inwentaryzacyjnego musimy wykonać w sytuacji, gdy przeprowadzamy tradycyjny spis z natury, tzn. komisyjnie zapisujemy długopisem stany asortymentów na przygotowane wcześniej arkusze spisowe. Wydruk arkusza wykonany wg standardowej makiety udostępnianej przez system wygląda jak poniżej.

Dzięki wykorzystaniu mechanizmu makiet możemy np. zmienić treść nagłówka i stopki, dodać do arkusza kolumnę ze stanem księgowym, jeżeli chcemy znać ten stan podczas przeprowadzania spisu, zrezygnować z kolumny J.m. jeżeli wszystkie asortymenty prowadzimy w sztukach, zwęzić lub rozszerzyć niektóre kolumny itd.

Zestawienie różnic możemy wykonać już po wpisaniu danych na arkusz inwentaryzacji. Zestawienie pokaże nam te asortymenty z arkusza, dla których podczas spisu ujawnione zostały nadwyżki bądź niedobory stanu magazynowego. W kolumnie Lp znajdują się dwie liczby: numer kolejny na bieżącym wydruku, oraz (w nawiasie) liczba porządkowa, z którą dany asortyment występuje na arkuszu inwentaryzacyjnym.

Podobnie jak w przypadku wydruku arkusza inwentaryzacji, również zestawienie różnic możemy wykonać albo wg makiety standardowej instalowanej wraz z systemem, albo utworzyć własną makietę dostosowując go do własnych potrzeb.


SPRZEDAŻ

INSTRUKCJA UŻYTKOWNIKA

Moduł SPRZEDAŻ jest trzonem programu [image]. Jego podstawowym zadaniem jest wystawianie, drukowanie i ewidencjonowanie dokumentów sprzedaży. Zapewnia również mechanizmy umożliwiające analizowanie sprzedaży pod praktycznie każdym kątem.

Najważniejsze funkcje i możliwości modułu sprzedaży to:

  • wystawianie, drukowanie i ewidencjonowanie faktur VAT, faktur proforma, paragonów, rachunków i dokumentów korygujących

  • faktury krajowe i eksportowe w walutach obcych z przeliczaniem na PLN wg średnich kursów NBP (dostępne tylko w wersji MAXI i PRO)

  • wystawianie e-faktur (dostępne tylko w wersji MAXI i PRO)

  • możliwość zdefiniowania dowolnych innych dokumentów (np. Zamówienie) i określania ich zawartości

  • automatyczne wystawianie powtarzających się co miesiąc faktur z możliwością seryjnego wydruku

  • automatyczna faktura do WZ

  • współpraca ze skanerem kodów kreskowych

  • refakturowanie opłat za np. energię elektryczną (ceny sprzedaży z dokładnością do 4 cyfr po przecinku)

  • możliwość umieszczenia na dokumentach elementów graficznych (logo firmy)

  • szczególne ułatwienia przy fakturowaniu usług:

    • opis usługi może mieć dowolną długość

    • powtarzającą się część opisu można wybierać z biblioteki asortymentów, a zmienną wpisywać bezpośrednio na fakturze

  • roczne lub miesięczne numerowanie dokumentów

  • dowolna liczba faktur korygujących do jednej faktury

  • rozbijanie płatności do faktury na dowolną liczbę rat, różne formy płatności (gotówka, przelew, czek, karta kredytowa, pobranie pocztowe, kompensata lub dowolne inne)

  • wyboru rachunku bankowego na jaki ma być dokonana zapłata za fakturę

  • obsługa numerów seryjnych

  • rozliczanie przedstawicieli handlowych (dostępne tylko w wersji MAXI i PRO)

  • możliwość pełnego dostosowania wyglądu faktury do własnych potrzeb

  • możliwość określenia specjalnych wzorów faktur dla poszczególnych kontrahentów (dostępne tylko w wersji MAXI i PRO)

  • wysyłanie faktur e-mailem w formacie HTML lub PDF (podobnie jak wszystkich innych wydruków)

  • rejestr sprzedaży VAT.

Jeśli chcemy korzystać z modułu SPRZEDAŻ, należy go wstępnie skonfigurować.

Po skonfigurowaniu możemy kliknąć w oknie głównym w przycisk [image] i rozpocząć wystawianie faktur oraz innych dokumentów sprzedaży.

Okno Faktury jest wspólnym oknem dla dokumentów sprzedaży oraz dokumentów wydania z magazynu.

Oprócz standardowych rodzajów dokumentów sprzedaży (faktury, rachunki, paragony, faktury i rachunki proforma, faktury i rachunki korygujące) w oknie FAKTURY możemy również wprowadzać dowolne inne zdefiniowane przez nas dokumenty sprzedaży (np. Zamówienie).

Przed przystąpieniem do wystawiania dokumentów należy wstępnie przygotować odpowiednie biblioteki.


Wystawianie faktur

SPRZEDAŻ

Przed wystawieniem faktury należy wybrać właściwy okres, obejmujący datę wystawienia faktury. W tym celu wybieramy z menu głównego Ustawienia - Bieżąca data i okres. Szybką zmianę okresu umożliwia klawisz F12.

Wystawiając [image] nowy dokument (Ins) najpierw określamy Rodzaj dokumentu, tzn. np. faktura VAT, paragon, faktura proforma, itp. Dostępne rodzaje dokumentów opisane są w INSTRUKCJA ADMINISTRATORA - PARAMETRYZACJA SYSTEMU - Definicje dokumentów.

Po wybraniu rodzaju dokumentu wypełniamy następujące dane (przy niektórych rodzajach dokumentów program może nie wymagać wszystkich wymienionych pozycji, np. dla paragonu nie określamy nabywcy):

  • Numer - numer kolejny dokumentu, najlepiej nie wypełniać tego pola ręcznie - program automatycznie w momencie akceptacji dokumentu podstawi kolejny, unikalny numer. Dzięki temu, że numer jest nadawany dopiero w momencie akceptacji, dokumenty będą prawidłowo numerowane przy równoczesnym sieciowym wystawianiu kilku faktur przez różnych użytkowników programu. Pole Numer składa się z 2 części: białej i szarej, w części szarej pokazany jest pełny numer dokumentu, w układzie określonym w definicji tego rodzaju dokumentu, np. 9/05/13/F a w części białej właściwy numer kolejny, czyli np. 9. Po dwukrotnym kliknięciu myszką w białą część pole Numer zmienia się na pole Układ umożliwiając zmianę układu numeru na inny niż określony w definicji dokumentu, np. jeśli z jakiegoś powodu chcemy zmienić pełny numer faktury z 9/05/13/F na 9/05/13/F/A:

    • klikamy dwukrotnie w białą część pola numer

    • w uzyskanym w ten sposób polu Układ wyłączamy przełącznik oznaczający zgodność układu numeru z definicją dokumentu

    • poprawiamy układ z #"/05/13/F" na #"/05/13/F/A"

    • zapamiętujemy zmiany akceptując całą fakturę

  • Data wystawienia - data wystawienia faktury.
    UWAGI:

    1. Data wystawienia musi mieścić się w wybranym okresie pracy (patrz ROZPOCZĘCIE PRACY - Okno główne - Bieżąca data i okres). Jeśli chcemy wystawić fakturę z datą spoza wybranego okresu, musimy wpierw zmienić okres przeglądania. Inaczej program zwróci ostrzeżenie i nie pozwoli wprowadzić takiej daty.

    2. Data wystawienia musi być większa od daty zamknięcia (patrz ROZPOCZĘCIE PRACY - Okno główne - Bieżąca data i okres). Nie da się zatwierdzić nowej faktury z datą wystawienia należącą do zamkniętego okresu. Podobnie nie da się poprawić ani usunąć istniejącej już faktury, której data wystawienia należy do zamkniętego okresu.

  • Data sprzedaży - ustawia się na taką datę jak data wystawienia, ale można ją zmienić na inną; w zależności od ustawień w definicji dokumentu (zakładka Wydruk pole Miesiąc) na fakturze będzie drukowana ta data np. 10-05-2013 lub tylko miesiąc wynikający z tej daty np. maj 2013. Data sprzedaży będzie drukowana na fakturze tylko wówczas, gdy będzie ona różna od Daty wystawienia.

  • Waluta - waluta, w której wystawiamy fakturę, dostępna tylko w wersji MAXI i PRO. Jeśli waluta jest różna od PLN to dodatkowo pojawią się pola Kurs i Kurs VAT. Umożliwiają one przeliczanie kwot walutowych na PLN odpowiednio dla potrzeb podatku dochodowego (Kurs) i podatku VAT (Kurs VAT). Domyślnie ustawiane są na średni kurs NBP z dnia poprzedzającego dzień dokonania lub zakończenia dostawy towarów lub wykonania usługi (w niektórych przypadkach dzień wystawienia faktury).

  • Waluta cen - jeśli wystawiamy fakturę krajową w PLN i mamy włączoną obsługę transakcji zagranicznych, to możemy określać ceny sprzedaży w walucie obcej. Zostaną one przeliczone na PLN wg kursu podanego obok w polu Kurs cen (w zależności od ustawienia w danych firmy na zakładce Ustawienia - Sprzedaż-wg średniego kursu NBP będzie to średni kurs NBP z dnia dokonania lub zakończenia dostawy towarów lub wykonania usługi lub w niektórych przypadkach dzień wystawienia faktury albo kurs wpisywany ręcznie). Na wydruku faktury będzie wyszczególniona cena w walucie oraz przeliczona wg kursu cena w PLN. Wartości netto, vat i brutto będą wyliczane na podstawie ceny złotówkowej. Jeśli ceny sprzedaży w asortymencie wybieranym na fakturę są określone w takiej samej walucie jak Waluta cen, to zostaną przepisane z asortymentu na fakturę bez żadnych zmian, natomiast jeśli są w asortymencie określone w PLN lub w innej walucie niż waluta cen faktury, to zostaną przeliczone na walutę cen faktury. Jeśli chcemy prowadzić cennik walutowy, ale nie wyszczególniać cen walutowych na fakturze, należy Walutę cen ustawić na PLN, a ceny w walucie określać tylko w bibliotece asortymentów. Jeśli Waluta faktury jest inna niż PLN, to waluta cen jest zawsze taka sama jak waluta faktury. Dostępna tylko w wersji MAXI i PRO.

  • Typ - typ faktury

    • Zwykła - zwykła faktura

    • Uproszczona - faktura o wartości brutto nie przekraczającej 450 PLN lub 100 EUR, która nie musi posiadać pełnych danych nabywcy (wystarczy jego NIP) - szczegóły w rozdziale Faktura uproszczona

    • Zaliczkowa - faktura zaliczkowa wystawiana w przypadku otrzymania zaliczki Kwota zal. do zamówienia Zamówienie - szczegóły w rozdziale Faktura zaliczkowa

    • Końcowa - faktura końcowa wystawiania w przypadku opłacenia przez nabywcę całej kwoty zamówienia Zamówienie, uwzględnia wszystkie zapłacone wcześniej zaliczki (patrz SPRZEDAŻ - Faktura zaliczkowa)

  • Księg. - sposób księgowania tego dokumentu, wpływa na stawki vat, przeliczenia netto/brutto oraz wygląd dokumentu. Odpowiada dokładnie rodzajowi wpisu w programie R2fk i R2księga.

    • S - Sprzedaż krajowa - faktury wystawiane kontrahentom krajowym, zwykle w złotówkach, ale mogą też być w walutach obcych

    • D - Wewn.dost.tow. - wewnątrzwspólnotowa dostawa towarów - faktury wystawiane kontrahentom z Unii Europejskiej.

    • E - Eksport tow. - eksport towarów - faktury wystawione kontrahentom zagranicznym spoza UE

    • U - Eksport usług - faktury dotyczące usług wystawiane kontrahentom zagranicznym (zarówno z krajów UE, jak i spoza UE) jako usługi nie podlegające VAT (stawka VAT np).

    W trzech ostatnich rodzajach stawka VAT wszystkich asortymentów na fakturze ustawiana jest automatycznie na 0% bez względu na stawkę vat określoną w bibliotece asortymentów. W przypadku faktury wystawianej w walucie obcej na dole faktury wydrukuje się obliczenie kwoty netto w PLN wg zadanego kursu, ułatwiające zaksięgowanie takiej faktury. Trzy ostatnie rodzaje księgowania dostępne tylko w wersji MAXI i PRO.

  • Język - język, na który zostanie przetłumaczony wydruk tej faktury. Podpowiada się język określony w danych kontrahenta. Można go zmienić na dowolny inny określony w bibliotece języków. Dostępny tylko w wersji MAXI i PRO.

  • Nabywca - wybieramy nabywcę z biblioteki kontrahentów. Aby szybko wyszukać kontrahenta zaczynamy pisać w polu ze skrótem nazwy lub z numerem NIP (w zależności od tego czego szukamy). Jeśli kontrahent jeszcze nie istnieje w bibliotece, to możemy go wprowadzić klawiszem Ins (z rozwiniętej klawiszem â listy kontrahentów), możemy również przejść do pełnej biblioteki kontrahentów (klawisz F2 lub kliknięcie w [image]), żeby na przykład przejrzeć dane lub wyszukać po części danych. Jeśli aktywny jest mechanizm restrykcji, to po wyborze nierzetelnego nabywcy pojawi się albo komunikat z ostrzeżeniem albo wybór tego nabywcy zostanie zablokowany, w zależności od stopnia zastrzeżeń do tego kontrahenta. Szybko wybrać kontrahenta z pełnej biblioteki można klawiszami Alt Enter.
    Jeśli chcemy, program może podpowiadać na nowych dokumentach nabywcę z ostatnio wystawionego dokumentu. W tym celu należy zaznaczyć pole Podpowiadać dostawcę/nabywcę w konfiguracji programu (menu główne Ustawienia - Konfiguracja - Ogólne).

  • e-Faktura - pole informacyjne zaznaczane automatycznie, jeśli faktura jest wystawiona dla kontrahenta, który wyraził zgodę na otrzymywanie e-faktur (patrz SPRZEDAŻ - e-Faktury). Dostępne tylko w wersji MAXI i PRO. Ułatwia filtrowanie e-faktur we właściwościach okna F4 - Filtr - Rodzaj dokumentu - e-Faktury.

  • POZYCJE - wprowadzamy na fakturę poszczególne asortymenty podając ich ilość i cenę jednostkową. Istnieje kilka sposobów wprowadzania pozycji na fakturę - sprawdź w rozdziale Pozycje.

  • WZ - zakładka związana z dokumentem WZ wystawionym automatycznie do tej faktury. Umożliwia podgląd i ewentualną zmianę dostaw, z których pochodzi towar wydany do tej faktury. Zakładka jest widoczna tylko wtedy, gdy korzystamy z modułu MAGAZYN i bieżący dokument ma w definicji włączone powiązanie z magazynem czyli wystawianie WZ.

  • PŁATNOŚCI - szczegółowe określenie i rozliczenie płatności związanych z tą fakturą (patrz Płatności)

  • STAWKI VAT

    • Netto, Vat i Brutto wg stawek VAT - sumy netto, vat i brutto wg stawek vat występujących na tej fakturze. Sumy obliczane są w ten sposób, że w zależności od ustawionej obok podstawy (Netto/Brutto), obliczana jest najpierw suma np. netto dla każdej stawki vat, a potem na podstawie tej sumy obliczane są łączne kwoty vat i brutto (nie są sumowane z poszczególnych pozycji faktury). Może sie zdarzyć, że nasz odbiorca księgując naszą fakturę, refakturując ją lub sporządzając na jej podstawie dokument PZ wyliczy w swoim programie księgowym lub magazynowym sumy netto, vat lub brutto różniące się o kilka groszy od wyliczonych na naszej fakturze. Rozbieżności te mogą wynikać albo z błędów popełnionych przez odbiorcę, albo z przyjętego przez niego algorytmu sumowania wartości wg stawek tzn. niezależnego sumowania kwot netto, vat i brutto z poszczególnych pozycji faktury. Występowanie takich rozbieżności nie świadczy bynajmniej o błędnym działaniu programu R2faktury. Przyjęty w programie sposób wyliczania sum netto, vat i brutto wg stawek zapewnia prawidłowe księgowanie i odprowadzanie podatku VAT.

    • Podstawa Netto/Brutto - informacja o sposobie przeliczania Vat na tym dokumencie

    • VAT w PLN - dostępne tylko na fakturach krajowych wystawianych w walucie obcej (tylko w wersji MAXI i PRO). Domyślnie ustawia się zgodnie z polem VAT w PLN określonym w definicji dokumentu w grupie VAT na zakładce Zawartość

      • zaznaczone - wartość do zapłaty podzielona jest na dwie części: netto w walucie i VAT w PLN

      • odznaczone - wartość brutto do zapłaty wykazana jest w całości w walucie, vat wyszczególniony jest jedynie do celów księgowych w PLN

    • Odwrotne obciążenie - zaznaczamy jeśli dokument dotyczy transakcji, dla której nabywcą jest podatnik (np. sprzedaż surowców wtórnych). Vat będzie naliczany wg stawki "np" - nie podlega. Faktura będzie drukowana bez informacji o VAT za to z adnotacją o konieczności rozliczenia podatku vat od tej transakcji przez nabywcę. Jeśli zaznaczono to pole, pod numerem faktury pojawi się adnotacja "odwrotne obciążenie".

    • Kiedy rozliczyć - sposób rozliczenia vat, istotny przy automatycznym księgowaniu dokumentu sprzedaży w programie księgowym oraz wpływający na wydruk rejestru sprzedaży vat i zestawienia sprzedaży vat. Wybieramy jeśli ten dokument ma być księgowany w szczególny sposób. Jeśli ma być księgowany z domyślnym sposobem rozliczenia vat (np. od 2014 roku data sprzedaży (data dost.tow. lub wykon.usł.)), pozostawiamy to pole puste. Jeśli szczególny sposób rozliczania vat ma dotyczyć wszystkich dokumentów z danej definicji dokumentów, wybieramy go w analogicznym polu w oknie DEFINICJE DOKUMENTÓW na zakładce Zawartość.

    • Nabywca (rejestr VAT) - kontrahent występujący w rejestrze VAT, który może być różny od kontrahenta z pozycji Nabywca (inny płatnik, inny nabywca). Pole dostępne tylko dla firm, które jako formę rozliczenia wybrały pełna księgowość (FK).

  • INNE - dodatkowe informacje:

    • Wystawił - imię i nazwisko osoby upoważnionej do wystawiania faktur, podstawiane automatycznie z danych użytkownika zalogowanego do programu

    • Odebrał - imię i nazwisko osoby upoważnionej do odbierania faktur, podstawiane automatycznie z danych nabywcy

    • Odbiorca - jeśli odbiorcą faktury jest inny kontrahent niż nabywca, wybieramy odbiorcę z biblioteki kontrahentów

    • Płatne na rachunek - jeśli faktura ma być płatna na inny niż domyślny rachunek bankowy, wybierz rachunek bankowy z listy firmowych rachunków bankowych

    • Makieta - makieta wg której będzie wydrukowany ten dokument, określamy w szczególnych przypadkach, jeśli ma to być makieta inna niż standardowo używana dla tego typu dokumentów. Pole dostępne tylko w wersji MAXI i PRO.

    • Opiekun - wybieramy opiekuna klienta z biblioteki opiekunów (patrz BIBLIOTEKI - Kontrahenci - Opiekunowie). Dostępne tylko w wersji MAXI i PRO.

    • Akcyza wyrobów węglowych (patrz SPRZEDAŻ - Akcyza wyrobów węglowych). Dostępna tylko w wersji MAXI i PRO.

  • UWAGI - wszelkie dodatkowe informacje, które powinny być wydrukowane na fakturze, np. o naliczaniu odsetek za zwłokę;

    • Uwaga - wybieramy uwagę z biblioteki uwag, jeśli chcemy wpisać uwagę, która będzie przydatna również na innych fakturach, a nie ma jej jeszcze w bibliotece, to na rozwiniętej liście uwag (klawisz â ) naciskamy klawisz Ins i wpisujemy uwagę do biblioteki

    • Uwaga c.d. - wpisujemy ciąg dalszy (związany tylko z tą konkretną fakturą) uwagi wybranej z biblioteki lub wpisujemy w całości uwagę charakterystyczną tylko dla tej faktury (tzn. taką której nie ma sensu wpisywać do biblioteki)

  • NOTATKI - wszelkie dodatkowe informacje związane z tą fakturą, które nie powinny być wydrukowane na fakturze, np. z kim się kontaktować w sprawie tej faktury, dlaczego udzielono rabatu w takiej a nie innej wysokości itp.; do wyboru mamy:

    • jedno duże opisowe pole, do którego można wpisać dowolny tekst

    • lub 10 pól po 10 znaków, do których możemy wpisywać wg ustalonego przez siebie systemu różne znaczniki np. możemy przyjąć, że notatka 1 oznacza nr zlecenia, z którym związana jest ta faktura, a notatka 2, że wysłaliśmy kontrahentowi oryginał i kopię faktury i czekamy na zwrot podpisanej kopii itp. Notatki te mogą być później wykorzystane do szybkiego wyszukania lub sporządzenia zestawień faktur pogrupowanych wg notatek (pola N1...N10)

  • FK, Księga, Ewidencja - dane związane z automatycznym księgowaniem tego dokumentu do programu księgowego (patrz SPRZEDAŻ - Eksport faktur do programu księgowego). Nazwa zakładki zależy od rodzaju rozliczeń ustawionego w oknie FIRMY na zakładce DANE.

    • Konto odbiorcy - dla pełnej księgowości - przepisane z danych kontrahenta konto rozrachunkowe odbiorcy, nie można go zmienić.

    • Konto sprzedaży - dla pełnej księgowości - przepisane z danych kontrahenta domyślne konto sprzedaży, można je zmienić na dowolne inne

    • Księgowany wg daty sprzedaży - zaznaczamy jeśli dokument ma być księgowany automatycznie z datą wpisu do księgi taką jak data sprzedaży, a nie jak data wystawienia. Domyślna wartość tego pola ustawiana jest automatycznie wg pola o tej samej nazwie określonego w definicji dokumentu na zakładce Zawartość.

    • Data księgowania - dokument zostanie zaksięgowany z określoną tu datą wpisu. Jeśli data księgowania będzie pusta, dokument zostanie zaksięgowany z domyślną datą wpisu, czyli taką jak data wystawienia.

  • RABAT - rabat procentowy lub kwotowy (brutto) udzielany wartościowo od całej faktury; rabat kwotowy zamieniany jest de facto na rabat procentowy (z dokładnością do 4 cyfr po przecinku), który po zastosowaniu do przeliczenia wszystkich pozycji faktury i zsumowaniu rabatów z poszczególnych pozycji może spowodować nieznaczną zmianę wprowadzonej kwoty rabatu

  • Fiskalny - pole zaznaczane automatycznie, jeśli do bieżącego dokumentu wydrukowano paragon fiskalny. Dzięki temu takie dokumenty można potem odpowiednio filtrować (F4 - Fiskalny), wykazywać na rejestrze sprzedaży vat oraz odpowiednio księgować w programie R2księga lub R2fk.

Wprowadzone dane akceptujemy przyciskiem [image]. Klikając w strzałkę [image] możemy określić sposób działania przycisku OK:

  • OK - zatwierdza wprowadzone zmiany

  • OK (wydruk) - zatwierdza wprowadzone zmiany i jeśli dotyczą one nowego dokumentu, a nie poprawy dokumentu wystawionego już wcześniej, to po zatwierdzeniu automatycznie go drukuje. Taki sposób działania przycisku OK jest szczególnie przydatny przy wystawianiu dużej ilości dokumentów. Wydruk następuje wg ustawień określonych w pozycji Ustawienia wydruku.

Do szybkiej akceptacji (lub akceptacji i wydruku - j.w.) służy również klawisz Alt PgDn (przy wciśniętym klawiszu Alt wciskamy dodatkowo klawisz PgDn /Page Down/).

Poprawę danych [image] umożliwia klawisz F6, natomiast usunięcie [image] dokumentu klawisz Del. Poprawa i usuwanie dokumentów są możliwe tylko wtedy, gdy okres nie jest zamknięty.

Datę zamknięcia (i okres przeglądania) ustawiamy w pozycji menu głównego Ustawienia - Bieżąca data i okres (F12).

Możliwe jest szybkie wyszukanie dowolnego dokumentu [image] Ctrl F7 poprzez wpisanie numeru faktury (lub nazwy nabywcy itp.). Pojawi się okienko Szukaj, w którym należy określić, jakie pola ma brać pod uwagę przy wyszukiwaniu (Szukaj po). Kursor automatycznie ustawi się na właściwej pozycji. Żeby wyszukać kolejną pozycję (np. z tym samym kontrahentem) - należy wcisnąć Ctrl L.

UWAGA. W polach, po których można wyszukiwać faktury znajdują się m.in. pola:

  • Numer - pełny nr dokumentu, np. 9/05/13

  • Nr - tylko nr kolejny, np. 9. Szukanie wg tego pola jest o wiele szybsze niż wg pola Numer.

Dodatkowa funkcja [image] F4 umożliwia ustawienie stałego filtru na dokumenty spełniające zadane kryteria:

  • Sprzedaż - rodzaj dokumentów

    • Tak - tylko takie dokumenty, które dotyczą faktycznej sprzedaży - czyli będą księgowane jako sprzedaż (bez faktur wewnętrznych, proform, WZ, RW itp.)

    • Nie - tylko takie dokumenty, które nie dotyczą faktycznej sprzedaży - czyli nie będą księgowane (faktury wewnętrzne, proformy, WZ, RW itp.)

    • Tak, bez powiązanych paragonów - tylko takie dokumenty, które dotyczą faktycznej sprzedaży, ale bez paragonów, do których wystawiono faktury

    • Tak, bez faktur do paragonów - tylko takie dokumenty, które nie dotyczą faktycznej sprzedaży, ale bez faktur, które zostały wystawione do paragonów

    • Tak, tylko powiązane paragony - tylko paragony, do których wystawiono faktury

    • Tak, tylko faktury do paragonów - tylko faktury wystawione do paragonów.

    Cztery ostatnie pozycje służą do szczegółowej analizy wystawionych dokumentów, a w szczególności do weryfikacji danych wyeksportowanych do R2fk z zaznaczoną opcją Dokumenty nieterminowe jako sprzedaż dzienna.

  • Wz

    • Tak (niezależne i automatyczne) - wszystkie dokumenty WZ, zarówno wystawione jako niezależne WZ jak i jako automatyczne WZ do faktury

    • Tak (automatyczne) - tylko automatyczne WZ do faktury

    • Tak (niezależne) - tylko niezależne WZ

    • Nie (niemagazynowe) - dowolne dokumenty niemagazynowe, czyli faktury, które nie mają automatycznych WZ, ani nie są zbiorczymi fakturami oraz wszelkie inne dokumenty. Opcja odwrotna do Tak (niezależne i automatyczne) (za wyjątkiem faktur wystawionych do WZ, których nie obejmuje ani jedno ani drugie kryterium).

    • Oprócz niezależnych - dowolne dokumenty, które nie są niezależnymi WZ

    • Oprócz powiązanych - dowolne dokumenty (WZ, faktury i inne) oprócz niezależnych WZ powiązanych z fakturami. Powiązanych tzn. takich, do których wystawiono później fakturę

    • Tylko niepowiązane - tylko niezależne WZ niepowiązane z fakturami

    • Tylko powiązane - tylko niezależne WZ powiązane z fakturami

  • Wzorce - tylko wzorce faktur powtarzalnych

  • Dokument - dokumenty jednego rodzaju (np. tylko faktury korygujące)

  • Typ - typ faktury

    • Zwykła - zwykła faktura

    • Uproszczona - faktura o wartości brutto nie przekraczającej 450 PLN lub 100 EUR, która nie musi posiadać pełnych danych nabywcy (wystarczy jego NIP)

    • Zaliczkowa - faktura zaliczkowa wystawiana w przypadku otrzymania zaliczki Kwota zal. do zamówienia Zamówienie - szczegóły w rozdziale Faktura zaliczkowa

    • Końcowa - faktura końcowa wystawiania w przypadku opłacenia przez nabywcę całej kwoty zamówienia Zamówienie, uwzględnia wszystkie zapłacone wcześniej zaliczki (patrz SPRZEDAŻ - Faktura zaliczkowa)

  • Fiskalny - tylko paragony fiskalne lub faktury, do których wydrukowano paragony fiskalne

  • Zamówienia

    • Tak - tylko zamówienia od odbiorców (patrz Faktura zaliczkowa)

    • Nie - wszystko oprócz zamówień

    • Wystawione, W realizacji, Zrealizowane, Anulowane - zamówienia o wybranym statusie

  • Księgowany jako - sposób księgowania dokumentu

    • nieksięgowany - dokumenty nieksięgowane, np. Proforma, Zamówienie

    • S - Sprzedaż krajowa - faktury wystawiane kontrahentom krajowym, zwykle w złotówkach, ale mogą też być w walutach obcych

    • D - Wewn.dost.tow. - wewnątrzwspólnotowa dostawa towarów - faktury wystawiane kontrahentom z Unii Europejskiej

    • E - Eksport tow. - eksport towarów - faktury wystawione kontrahentom zagranicznym spoza Unii Europejskiej

    • U - Eksport usług - faktury dotyczące usług wystawiane kontrahentom zagranicznym (zarówno z krajów UE, jak i spoza UE) jako usługi nie podlegające VAT (stawka VAT np)

  • e-Faktury - faktury z zaznaczonym polem e-Faktury (dostępne tylko w wersji MAXI i PRO)

  • Tylko własne - dotyczy dokumentów wystawionych ze współdzielonych definicji, w oknie będą dostępne tylko te, które wystawił aktualny użytkownik programu. W zależności od uprawnień nadanych użytkownikowi (pole Tylko własne dokumenty w uprawnieniach grupy użytkowników) będzie on mógł zmienić wartość tego parametru i przeglądać również współdzielone dokumenty wystawione przez innych użytkowników.

  • Kontrahent - wszystkie faktury wystawione określonemu nabywcy

  • Nip - faktury uproszczone wystawione nabywcy o określonym numerze NIP (pole dostępne tylko jeśli w polu Typ wybrano Uproszczone)

  • Kasa/Bank - dokumenty, które:

    • Tak - zostały zapłacone w całości i w całości zaksięgowane w kasie/banku

    • Częściowo - zostały częściowo zaksięgowane w kasie/banku

    • Nie - nie zostały w ogóle zaksięgowane w kasie/banku

  • Terminowy - dokumenty, które:

    • Tak - nie zostały zapłacone w dniu wystawienia

    • Nie - zostały zapłacone w dniu wystawienia.

Filtr [image] umożliwia wybranie dokumentów według dowolnych kryteriów, na przykład żeby wyróżnić wszystkie dokumenty, na których zastosowano rabat, możemy wywołać klawiszami +/- z klawiatury numerycznej:

Klawisz F2 [image] udostępnia różne wydruki (patrz SPRZEDAŻ - Wydruki).

W menu podręcznym dostępnym po kliknięciu prawym klawiszem myszy w tabelkę z fakturami na zakładce Lista (również klawisze F3) dostępne są funkcje:

  • Eksport do programu księgowego - eksport dokumentów sprzedaży do programu księgowego. Ta sama funkcja jest dostępna na pasku narzędziowym w górnej części okna.

  • Dokumenty powtarzalne

    • Wystaw dokumenty powtarzalne - wystawianie faktur powtarzalnych na podstawie utworzonych wcześniej wzorców. Ta sama funkcja jest dostępna na pasku narzędziowym w górnej części okna.

    • Utwórz wzorzec na podstawie bieżącego dokumentu - tworzy wzorzec faktury powtarzalnej na podstawie bieżącej faktury. Aktywne tylko dla faktur krajowych, które w definicji mają włączone pole Powtarzalny.

    • Aktualizacja cen - aktualizuje ceny na fakturach wzorcowych zgodnie z aktualnymi cenami w kartotece asortymentów oraz z cenami i rabatami dedykowanymi dla danego kontrahenta.

  • Faktura do WZ

    • Wystaw do wybranych - wystawianie faktur do wszystkich lub wybranych dokumentów WZ, które nie są jeszcze powiązane z żadną fakturą ani innym dokumentem sprzedaży. Ta sama funkcja jest dostępna na pasku narzędziowym w górnej części okna.

    • Wystaw do bieżącego - wystawia fakturę do bieżącego WZ. Aktywne tylko na dokumentach WZ niepowiązanych jeszcze z fakturą.

  • Faktura do paragonu

    • Wystaw do wybranych - wystawianie faktur do wszystkich lub wybranych paragonów, które nie są jeszcze powiązane z żadną fakturą ani innym dokumentem sprzedaży

    • Wystaw do bieżącego - wystawia fakturę do bieżącego paragonu. Aktywne tylko na paragonach niepowiązanych jeszcze z fakturą.

  • Windykacja należności - dostęp do mechanizmu windykacji przeterminowanych należności związanych z bieżącą fakturą (przypomnienie, wezwanie do zapłaty i nota odsetkowa)

  • Kontakty - w wersji MAXI i PRO, dostęp do ewidencji kontaktów z nabywcą faktury

  • Zamień proformę na fakturę - zamienia fakturę proforma na zwykłą fakturę. Funkcja przydatna gdy stosujemy następujący model sprzedaży:

    1. wystawiamy fakturę proforma

    2. czekamy aż klient za nią zapłaci (zwykle przelewem)

    3. odnotowujemy zapłatę za pośrednictwem raportu bankowego (lub kasowego) wiążąc ją z odpowiednią fakturą proforma

    4. zamieniamy fakturę proforma na zwykłą fakturę.

    Dokumentu zaksięgowanego w raporcie bankowym/kasowym nie można normalnie poprawiać, gdyż mogłoby to doprowadzić do nieścisłości między dokumentem a raportem. Stąd właśnie konieczność posługiwania się taką pomocniczą funkcją.

  • Odśwież restrykcje - odświeża informacje o restrykcjach w obrotach z nierzetelnymi kontrahentami. Funkcja przydatna tylko wtedy, gdy chcemy się upewnić, że program prawidłowo interpretuje informacje o przeterminowanych fakturach (podświetlenia na szaro lub czarno).

  • Dodatkowe funkcje

    • Aktualizuj ceny nabycia - aktualizuje wartości nabycia, a co za tym idzie zysk i marże, we wszystkich dokumentach wydania i sprzedaży. Funkcja przydatna tylko wtedy, gdy chcemy się upewnić, że program zapamiętał we wszystkich dokumentach prawidłowe wartości nabycia - np. po awarii.

    • Aktualizuj konta - przepisuje konto rozrachunkowe odbiorcy z biblioteki kontrahentów do faktury oraz domyślne konto sprzedaży z biblioteki asortymentów na pozycje faktury. Patrz Eksport danych. Przydatne w pełnej ksiegowości jeśli:

      • w trakcie wystawiania dokumentów zmieniliśmy numer konta odbiorcy lub konta sprzedaży na zakładce FK

      • po wystawieniu dokumentów zmieniliśmy numer konta odbiorcy w bibliotece kontrahentów lub kont sprzedaży w bibliotece asortymentów lub grup.

      UWAGA: Funkcja dotyczy wszystkich dokumentów widocznych w oknie. Jeśli chcemy poprawić konto na jednym lub wybranych dokumentach, nalezy je podświetlić, przejść do trybu Tylko podświetlone i dopiero wtedy wywołać tę funkcję.

    • Edycja danych do statystyki - dane do statystyki edytujemy normalnie na zakładce Inne w grupie Statystyka. Jeśli edycja faktury jest niemożliwa (np.: faktura zaksięgowana w kasie lub skorygowana), korzystamy z tej funkcji.

    • Zaznacz jako FISKALNY - zaznacza pole Fiskalny - przydatne jeśli drukarka fiskalna wydrukowała paragon, ale program nie odnotował tej informacji w dokumencie z powodu awarii programu lub drukarki (brak papieru) w trakcie wydruku paragonu. Aby pole było dostępne, należy w menu Ustawienia - Konfiguracja - Faktury - Paragony fiskalne włączyć parametr Edycja zafiskalizowanych dokumentów.


Pozycje

SPRZEDAŻ - Wystawianie faktur

Wprowadzanie pozycji jest kluczowym elementem wystawiania faktury.

Pozycje można wpisywać na trzy sposoby:

  1. zalecany - bezpośrednio na fakturze w tabelce na zakładce Pozycje

    • zalety:

      • szybkie wprowadzanie najpotrzebniejszych danych (asortyment, ilość, cena)

      • podgląd na bieżący stan asortymentów w momencie wyboru asortymentu

      • możliwość wprowadzenia wszystkich danych bezpośrednio z klawiatury (bez używania myszy)

    • wady:

      • brak lub utrudniony dostęp do pełnych informacji na temat pozycji (ceny i wartości netto/brutto przed i po rabacie, łączna waga sprzedanych jednostek itp.)

  2. w dodatkowym oknie Pozycje, wywołanym przyciskiem

    • zalety:

      • pełna informacja dotycząca pozycji faktury

    • wady:

      • konieczność wywołania osobnego okna

      • utrudniony dostęp do bieżących stanów magazynowych

  3. najszybszy - korzystając ze skanera kodów kreskowych (patrz Skaner kodów kreskowych).

W zależności od wybranego sposobu:

  1. zakładka Pozycje:

    • przechodzimy do tabelki z pozycjami znajdującej się na zakładce Pozycje

    • ustawiamy się w kolumnie Indeks lub Nazwa asortymentu i wywołujemy bibliotekę asortymentów naciskając klawisz Enter, klikając w przycisk [image] lub rozpoczynając pisanie indeksu lub nazwy szukanego asortymentu. Kolumna Indeks będzie dostępna jeśli włączyliśmy obsługę indeksów w ustawieniach - okno [image] FIRMY - F6 - Ustawienia - Indeksy. Po odszukaniu w oknie Asortymenty odpowiedniego asortymentu wybieramy go na fakturę klawiszem Enter lub klikając w przycisk [image].
      UWAGA. Jeśli wystawiamy dokumenty z dużą liczbą pozycji, warto przed rozpoczęciem wystawiania faktury otworzyć okno Asortymenty (przycisk [image] w oknie głównym). Dzięki temu wybór asortymentu na pozycje dokumentu będzie dużo szybszy, gdyż program nie będzie przy każdej pozycji tracił czasu na otwieranie i zamykanie okna Asortymenty. Zamiast tego będzie się ono przełączało w tryb wyboru (w prawym górnym rogu okna pojawi się przycisk [image]), a po wybraniu asortymentu będzie wracać do normalnego trybu (zniknie przycisk [image]).

    • po wybraniu asortymentu wypełniamy (i zatwierdzamy Enter) kolejne kolumny:

      • Magazyn - magazyn, z którego wydawany jest towar. Domyślnie podstawiany jest magazyn określony we właściwościach ( [image] F4) okna Asortymenty. Można go zmienić na inny. Przy sprzedaży usług pole Magazyn jest nieokreślone.

      • Ile - wpisujemy odpowiednią ilość, domyślnie podpowiada się sugerowana ilość określona w bibliotece asortymentów. Po kliknięciu w przycisk [image] lub naciśnięciu klawiszy Ctrl Enter możemy skorzystać z kalkulatora umożliwiającego wprowadzenie ilości poprzez podanie wartości, która zostanie podzielona przez zadaną cenę (patrz Kalkulator Ilość/Cena/Wartość)

      • Rodz - rodzaj ceny sprzedaży. Domyślnie podpowiada się rodzaj ceny określony w polu Rodzaj pod tabelką z pozycjami.

        • 1, 2, 3 - wybieramy jedną z 3 cen sprzedaży określonych w bibliotece asortymentów

        • N - cena nabycia. Cena nabycia dotyczy oczywiście tylko towarów i produktów i ma sens tylko jeśli prowadzimy magazyn. Po wybraniu rodzaju N, jako cena sprzedaży netto przed rabatem (_C.netto) podstawi się ostatnia cena nabycia tego asortymentu określona w bibliotece asortymentów. Po zaakceptowaniu tej pozycji faktury, w momencie gdy zostanie ona wydana z magazynu, cena zostanie automatycznie dopasowana do ceny nabycia wynikającej z konkretnej dostawy, z której pochodzi towar. Jeśli towar będzie pochodził z kilku dostaw, cena nabycia zostanie obliczona jako średnia cena nabycia (Wartość nabycia podzielona przez Ilość).

        • — - cena sprzedaży inna niż powyższe. Oznaczenie to pojawi się wówczas, gdy cena zostanie przez nas wpisana ręcznie, lub gdy zostanie wpisana przez system jako jedna z cen dedykowanych dla konkretnego nabywcy i asortymentu (usługi).

      • _C.netto - cena sprzedaży netto przed rabatem, określana automatycznie na podstawie wybranego wcześniej rodzaju ceny (Rodz). Jeśli chcemy, możemy ją dowolnie zmienić. W takim przypadku program automatycznie sprawdzi czy wprowadzona cena nie odpowiada jednej z cen sprzedaży wpisanych w bibliotece asortymentów, a jeśli tak, to zostanie odpowiednio określone pole Rodz - rodzaj ceny. Jeśli wprowadzona cena sprzedaży nie odpowiada żadnej z cen określonych w bibliotece asortymentów, zostanie ustawiony rodzaj ceny - (myślnik). Jeśli wybrano rodzaj ceny N, czyli cenę nabycia, to cena sprzedaży określana jest automatycznie w momencie zaakceptowania pozycji i ręczne modyfikowanie tej ceny nie ma sensu.

      • _C.net.wal. - cena sprzedaży netto przed rabatem, ale wyrażona w walucie obcej. Dostępna jeśli Waluta lub Waluta cen faktury jest inna niż PLN (tylko w wersji MAXI i PRO). Źródłową ceną pozycji na takiej fakturze jest ta właśnie cena walutowa, cena złotówkowa jest przeliczana z tej ceny wg zadanego kursu waluty.

      • Rabat - rabat procentowy udzielany na tę pozycję; cena po rabacie jest przeliczana przy uwzględnieniu rabatu wpisanego do pozycji i rabatu określonego dla całego dokumentu, tzn. C.netto = _C.netto * (1-Rabat/100) * (1-RabatDokument/100). Oznacza to że jeśli np. w pozycji będzie rabat 20%, a w całej fakturze 10%, to łączny rabat uwzględniony przy obliczeniu ceny będzie wynosił (1-(1-20/100)*(1-10/100))*100=28%, a nie, jak by się mogło wydawać na pierwszy rzut oka, 30%. Taki właśnie łączny rabat w wysokości 28% zostanie wydrukowany na fakturze przy tej pozycji.

      • Nr seryjny - nr seryjny tej pozycji. Kolumna Nr seryjny będzie dostępna jeśli włączyliśmy obsługę numerów seryjnych w konfiguracji - menu główne Ustawienia - Konfiguracja - Ogólne - Nr seryjne. W przypadku usług możemy numer seryjny wpisać ręcznie. Natomiast jeśli prowadzimy magazyn i sprzedawany towar został wcześniej przyjęty do magazynu i określono mu odpowiedni numer seryjny, to w momencie zaakceptowania pozycji faktury zostanie podstawiony nr seryjny wynikający z wydawanej dostawy. Jeśli towar będzie pochodził z kilku dostaw nr seryjny na fakturze zostanie określony jako np. 123456 i inne. Takie rozwiązanie nie jest oczywiście zbyt sensowne. W przypadku gdy decydujemy się na korzystanie z numerów seryjnych, powinniśmy sprzedawać na jednej pozycji faktury jeden egzemplarz numerowanego towaru.

    • wciśnięcie klawisza Enter w ostatniej kolumnie (Rabat albo Nr seryjny) spowoduje zatwierdzenie tej pozycji faktury i rozpoczęcie wprowadzania następnej pozycji. Rozpoczęcie wprowadzania nowej pozycji możemy również uzyskać naciskając klawisz Ins lub po ustawieniu sie na ostatniej pozycji klawisz â.

    • kolumny oznaczone szarym kolorem (C.netto, W.netto itd.) zawierają informacje tylko do odczytu, określone przez program na podstawie wprowadzonych wcześniej danych.

    • jeśli wprowadziliśmy już wszystkie pozycje i nie chcemy wprowadzać innych danych (płatności, uwagi, itp.), możemy od razu zaakceptować cały dokument naciskając klawisze Alt PgDn.

    • pod tabelką z pozycjami znajdują się jeszcze:

      • Rodzaj - rodzaj ceny sprzedaży podstawiany domyślnie przy wprowadzaniu pozycji na fakturę - patrz opis wyżej przy polu Rodz

      oraz dodatkowe pola sumaryczne:

      • Lp - liczba pozycji wpisanych na tej fakturze

      • Ile - łączna ilość ze wszystkich pozycji na fakturze, przydatna np. przy sprawdzaniu poprawności wydawania towaru do tej faktury

      • Waga - łączna waga towarów z tego dokumentu

      • Netto, Vat, Brutto - sumy kwot netto, vat i brutto z wszystkich pozycji faktury. Sumowanie przeprowadzane jest w ten sposób, że najpierw są sumowane z wszystkich pozycji faktury kwoty będąca podstawą przeliczeń vat, czyli w zależności od ustawienia pola Podstawa na zakładce Stawki VAT, albo netto albo brutto (z podziałem na stawki vat). Potem na podstawie tych sum obliczane są brakujące sumy vat i brutto lub netto. Może się zdarzyć, że obliczona w ten sposób suma wartości vat lub brutto może się różnić od sumy vat lub brutto z poszczególnych pozycji dokumentu. Różnica ta wynika z jednostkowych zaokrągleń kwot vat i brutto na poszczególnych pozycjach faktury i jest księgowo jak najbardziej prawidłowa oraz nie świadczy bynajmniej o nieprawidłowym działaniu programu.

  2. okno Pozycje:

    • klikamy w przycisk [image] lub naciskamy klawisze Alt C żeby otworzyć okno z pozycjami dokumentu:

    • wprowadzamy [image] nową pozycję (Ins):

      • Asortyment

        • Nazwa - wybieramy asortyment z listy asortymentów podając jego nazwę np. ŁOŻYSKO 6000.
          Jeśli odpowiedniego asortymentu nie ma w bibliotece i jest to usługa (towary i produkty muszą być przed wydaniem przyjęte do magazynu), to możemy go wprowadzić klawiszem Ins (z rozwiniętej klawiszem â listy asortymentów), możemy również przejść do pełnej biblioteki asortymentów klikając w napis [image] lub naciskając F2. Jeżeli pełna nazwa wybranego asortymentu jest dłuższa niż 1 linijka, to pojawi się ona w całości w szarym polu pod nazwą asortymentu.

        • Nazwa c.d. - dopisujemy dalszy ciąg wybranej z biblioteki nazwy asortymentu. Jeśli np. fakturujemy usługę, która w bibliotece asortymentów jest wpisana jako Montaż instalacji alarmowej, możemy tu dopisać w centrali firmy we Wrocławiu oraz w oddziałach w Warszawie i Gdańsku - dlatego dopisujemy w polu Nazwa c.d., bo montujemy te instalacje w różnych miejscach i nie chcemy niepotrzebnie mnożyć wpisów w bibliotece. Co więcej, jeżeli fakturujemy usługę, której opis jest na tyle unikalny, że nie ma sensu wprowadzać go do biblioteki asortymentów, gdyż na pewno nigdy więcej się już nie powtórzy, możemy wpisać go w całości w pole Nazwa c.d. (w tym wypadku pole Nazwa pozostawiamy puste, natomiast uzupełniamy pola PKWiU, Rodzaj, J.m. i Vat%) - dotyczy to oczywiście tylko usług.
          UWAGA. Jeśli wpisany tekst jest dłuższy niż jedna linijka, zostanie on automatycznie "połamany" tak, aby zmieścił się w okienku Nazwa c.d.. Ten sam tekst na wydruku faktury może być jednak "połamany" zupełnie inaczej w zależności od szerokości kolumny "Nazwa towaru lub usługi". Jeśli chcemy, żeby na wydruku tekst wyglądał dokładnie tak jak go tu wprowadzamy, musimy "połamać" go sami w odpowiednich miejscach korzystając z klawiszy Shift Enter.

        • Indeks - wybieramy asortyment z listy asortymentów podając jego indeks np. 12.

        • J.m., Rodzaj, PKWiU - pozostałe dane wybranego asortymentu (tylko do odczytu, można je zmienić tylko w bibliotece asortymentów)

        • Vat% - stawka podatku Vat wynikająca z grupy PKWiU określonej dla tego asortymentu w bibliotece. W szczególnych przypadkach można zmienić stawkę vat na inną niż w asortymencie. Obowiązuje ona wówczas tylko na tej pozycji faktury.

        • C.nab.netto - ostatnia cena nabycia netto

      • Magazyn - magazyn, z którego wydawany jest towar. Domyślnie podstawiany jest magazyn określony we właściwościach ( [image] F4) okna Asortymenty. Można go zmienić na inny. Przy sprzedaży usług i asortymentów nie powiązanych z biblioteką asortymentów pole Magazyn jest nieokreślone.

      • Rodzaj - analogicznie jak kolumna Rodz w tabelce na zakładce Pozycje - patrz opis wcześniej.

      • Nr seryjny - analogicznie jak kolumna Nr seryjny w tabelce na zakładce pozycje - patrz opis wcześniej.

      • Netto - zakładka umożliwiająca wprowadzenie ilości (Ilość) oraz ceny netto przed rabatem (Cena) i rabatu dotyczącego tej pozycji (Rabat%); na podstawie wprowadzonych wartości wyliczają się Wartość netto oraz Cena i Wartość netto po rabacie. Dodatkowo w polu Podstawa przypomniana jest określona w dokumencie podstawa przeliczeń netto/brutto.

      • Brutto - analogicznie j.w., z tym że dotyczy cen i wartości brutto (zawierających podatek VAT)

      • Netto wal., Brutto wal. - zakładki z cenami walutowymi, dostępne na fakturach które w polach Waluta lub Waluta cen mają walutę inną niż PLN (tylko w wersji MAXI i PRO). Na takich fakturach ceny podajemy właśnie na tych zakładkach, a na zakładkach Netto i Brutto możemy sprawdzić ceny złotówkowe przeliczone z walutowych wg zadanego kursu.

      • WZ - zakładka umożliwiająca podgląd i ewentualną zmianę dostaw, z których pochodzi towar wydany do tej pozycji faktury. Zakładka jest widoczna tylko wtedy, gdy prowadzimy obsługę magazynu i bieżący dokument ma w definicji włączone wystawianie WZ. Znaczenie poszczególnych kolumn oraz zasady edycji dostaw są analogiczne jak opisane w rozdziale dotyczącym zakładki WZ znajdującej się bezpośrednio na fakturze.

      • Inne - zakładka widoczna od 2011 roku. Zawiera pola dotyczące PKWIU 2004 oraz stawki vat Vat% obowiązującej do końca 2010 roku. W polu Akywne PKWiU, określamy jaka biblioteka PKWiU, a co za tym idzie, jaka stawka VAT zostanie użyta na fakturze. Domyślnie na fakturach z datą sprzedaży z 2010 roku lub starszych używana jest biblioteka PKWiU 2004 i stawka vat obowiązująca do 31.12.2010, a na fakturach z datą sprzedaży z 2011 lub nowszą biblioteka PKWIU 2008 i stawka vat obowiązująca od 01.01.2011.

      • FK - jeśli nasza firma prowadzi pełną księgowość, to możemy tu określić numer konta sprzedaży, na którym zostanie zaksięgowana wartość netto tej pozycji. Domyślnie numer jest przepisany z biblioteki asortymentów, biblioteki grup asortymentowych lub z faktury. Można go zmienić. Ten numer konta ma znaczenie tylko wtedy, jeśli dokumenty zostaną wyeksportowane z zaznaczonym parametrem Księguj każdą pozycję dokumentu osobno.

      • Waga [kg] - łączna waga w kilogramach tej pozycji. Obliczana jako iloczyn ilości jednostek z tej pozycji faktury i określonej w bibliotece asortymentów wagi jednostkowej tego asortymentu (tzn. wagi jednej jednostki asortymentu).

      • KGO - jednostkowy koszt gospodarowania odpadami zawarty w cenie

    • po wprowadzeniu wszystkich danych zatwierdzamy całą pozycję klikając w przycisk OK lub naciskając klawisze Alt PgDn.

UWAGA. Nic nie stoi na przeszkodzie, żeby w zależności od potrzeb korzystać z kombinacji przedstawionych wcześniej dwóch pierwszych sposobów (oczywiście jeśli nie korzystamy ze skanera kodów kreskowych). Ze względu na łatwość i szybkość wprowadzania danych warto wprowadzać pozycje bezpośrednio w tabelce na zakładce Pozycje i korzystać z okna Pozycje tylko w razie potrzeby. Np. jeśli chcemy sprawdzić szczegółowe dane jakiejś pozycji ustawiamy się na niej w tabelce i naciskamy Alt-F6 - wywołamy w ten sposób okno Pozycje w trybie edycji(poprawy) tej pozycji faktury. Podobnie, jeśli naciśniemy w tabelce klawisze Alt-Ins, wywołamy okno Pozycje w trybie wprowadzania nowej pozycji. W obu przypadkach po akceptacji lub rezygnacji ze zmian okno Pozycje zostanie zamknięte i wrócimy do tabelki z pozycjami dokumentu.


Kalkulator Ilość/Cena/Wartość

SPRZEDAŻ - Wystawianie faktur - Pozycje

Kalkulator Ilość/Cena/Wartość ułatwia przeliczanie wartości na pozycji faktury. Warto z niego korzystać przede wszystkim w sytuacji, gdy wystawiając fakturę bazujemy na wartościach, a nie na ilości i cenie jednostkowej. Taka sytuacja ma miejsce np. w przypadku sprzedaży benzyny na stacji paliw, gdy na podstawie wartości obliczonej przez dystrybutor paliwa obliczamy ilość przy ustalonej wcześniej cenie sprzedaży.

Kalkulator wywołujemy z faktury z zakładki Pozycje klikając w przycisk [image] lub naciskając klawisze Ctrl Enter w kolumnie Ile lub w kolumnie z ceną przed rabatem (netto, brutto, lub walutową w zależności od typu faktury).

W zależności od potrzeb możemy:

  • podać Ilość, która pomnożona przez cenę wybraną w polu Cena netto lub Cena brutto da nam odpowiednie wartości

  • podać Wartość netto lub Wartość brutto, która podzielona przez cenę wybraną w polu Cena netto lub Cena brutto da nam odpowiednią Ilość. Tak właśnie jest na przykładzie powyżej - podano wartość brutto 200 zł, która przeliczona przez cenę jednostkową 4,48 zł dała ilość 44,671. Dodatkowo udzielono jeszcze 10% rabatu.

  • podać Cenę netto lub Cenę brutto albo wybrać Rodzaj ceny. Ceny pomnożone przez zadaną Ilość dadzą odpowiednie wartości.

  • podać Rabat, który pomniejszy wprowadzone ceny i po pomnożeniu przez Ilość da końcowe wartości netto i brutto.

Klikając w przycisk OK zamykamy kalkulator i przechodzimy do wprowadzania kolejnej pozycji faktury.


Skaner kodów kreskowych

SPRZEDAŻ - Wystawianie faktur

Program umożliwia współpracę ze skanerem kodów kreskowych. Może to być dowolny skaner (czytnik) emulujący klawiaturę. Zeskanowane przez taki skaner kody kreskowe są przesyłane do programu dokładnie tak, jakby zostały wprowadzone z klawiatury i zakończone klawiszem Enter.

Korzystanie ze skanera znacznie przyspiesza i ułatwia pracę z programem. Jeśli uzupełnimy bibliotekę asortymentów wpisując w polu Indeks kod kreskowy danego asortymentu, to później będziemy mogli korzystać ze skanera wszędzie tam, gdzie wyszukujemy asortyment wpisując z klawiatury jego indeks, czyli np. w bibliotece asortymentów oraz w tabelkach z pozycjami dokumentów dowolnego typu (PZ, MM, faktura).

Aby w pełni wykorzystać możliwości skanera, program oferuje specjalny mechanizm przyspieszający wystawianie faktury. Pozwala on na szybkie wstawienie do faktury nowej pozycji wyłącznie na podstawie zeskanowanego kodu, bez konieczności używania klawiatury ani myszy.

Aby skorzystać z takiej możliwości należy włączyć tryb obsługi skanera, tzn. zaznaczyć w konfiguracji (menu Ustawienia - Konfiguracja), że program ma współpracować ze skanerem (pole Skaner kodów kreskowych na zakładce Faktury). Dzięki temu, jeśli rozpoczniemy wystawianie nowego dokumentu i przejdziemy na zakładkę Pozycje, każde zeskanowanie kodu przez skaner będzie powodowało automatyczne utworzenie nowej pozycji faktury z asortymentem o indeksie takim jak zeskanowany kod. Cena sprzedaży będzie określona na podstawie pola Rodzaj ceny, znajdującego się pod lewym dolnym rogiem tabelki z pozycjami. Natomiast ilość będzie określona w zależności od ustawienia parametru Domyślna ilość (menu Ustawienia - Konfiguracja na zakładce Faktury): zaznaczony - podstawi się domyślna ilość określona przy danym asortymencie w bibliotece asortymentów, odznaczony - podstawi się 1 jednostka.

Jeśli będziemy chcieli poprawić utworzoną w ten sposób pozycję faktury, żeby np. zmienić ilość, będziemy musieli przed rozpoczęciem pisania przełączyć tabelkę z pozycjami w tryb edycji, tzn. kliknąć pod tabelką z pozycjami w przycisk [image] lub nacisnąć klawisz F6. Jeśli tego nie zrobimy, to wszystkie wprowadzane przez nas z klawiatury znaki będą traktowane przez program jak kod ze skanera, uniemożliwiając poprawę istniejącej już pozycji. Podobny problem możemy napotkać przy próbie ręcznego wprowadzenia pozycji - należy wówczas wcześniej kliknąć w przycisk w przycisk [image] lub nacisnąć klawisz Ins.

Z analogicznego mechanizmu szybkiego wystawiania pozycji można korzystać w oknie Pozycje zawierającym pozycje faktury.

Jak łatwo zauważyć przełączenie programu w tryb obsługi skanera może być również przydatne nawet jeśli nie posiadamy skanera. Pracując w tym trybie, aby utworzyć nową pozycję faktury, wystarczy przejść na zakładkę Pozycje, wpisać z klawiatury indeks asortymentu i potwierdzić go klawiszem Enter.


Płatności

SPRZEDAŻ - Wystawianie faktur

Program umożliwia szczegółowe określenie i rozliczenie sposobu oraz formy płatności.

Standardowo przy wystawianiu faktury, po wpisaniu pozycji dokumentu, ustawiana jest automatycznie domyślna forma i termin płatności faktury, określona przez:

  • indywidualną formę i termin płatności określone w danych nabywcy (w bibliotece kontrahentów na zakładce Warunki w danych tego nabywcy)

  • jeśli nabywca nie ma indywidualnych ustawień, to w zależności od parametru menu głównego Ustawienia - Konfiguracja - Faktury - Przelew:

    • jeśli włączony, to dokument będzie się domyślnie ustawiał jako "Do zapłacenia przelewem w ciągu X dni" gdzie X to liczba dni określona parametrem Ustawienia - Konfiguracja - Faktury - Przelew - Dni

    • jeśli wyłączony, to dokument będzie domyślnie "Zapłacony gotówką".

Jeśli domyślne ustawienie płatności nam odpowiada, możemy przy wystawianiu nowego dokumentu pominąć zakładkę Płatności. W przeciwnym wypadku ustalamy:

  • Termin, Dni - wprowadzamy termin rozliczenia w formie daty lub ilości dni od daty wystawienia

  • Jedna rata - przycisk umożliwiający połączenie kilku rozbitych wcześniej płatności na jedną zbiorczą

  • Dni zwłoki, Odsetki - informacja o przekroczeniu terminu płatności, wysokość odsetek nalicza się na podstawie ilości dni przekroczenia oraz ustawionej (w menu Ustawienia - Odsetki) procentowej wartości odsetek (patrz INSTRUKCJA ADMINISTRATORA - PARAMETRYZACJA SYSTEMU - Odsetki). Stojąc kursorem na poszczególnych ratach pokazywane są tu dni zwłoki i wysokość odsetek od bieżącej raty. Po kliknięciu w jakikolwiek element poza tabelką z ratami, pokażą się łączne odsetki od wszystkich rat oraz ilość dni zwłoki z najbardziej przeterminowanej raty. Przycisk [image] umożliwia wystawienie i wydrukowanie noty odsetkowej.

W przypadku płatności ratalnych możemy ustalić wysokość i termin płatności każdej raty (ilość rat jest dowolna). Dla każdej raty wprowadzamy:

  • Rodzaj - określany automatycznie. Należy go traktować jako znak płatności, tzn.:

    • Wn (+) znak dodatni - to co kontrahent ma nam zapłacić

    • Ma (-) znak ujemny - to co my mamy zapłacić kontrahentowi, np. w związku ze zwrotem na fakturze korygującej,

  • Do zapłaty - wysokość raty podstawia się automatycznie jako sumaryczna wartość brutto faktury, po zmniejszeniu tej kwoty automatycznie utworzy się druga rata z dopełnieniem kwoty

  • Termin - termin płatności danej raty podstawia się automatycznie z ustalonego wcześniej (wyżej) terminu rozliczenia całości

  • Forma - formę zapłaty wybieramy z ustalonych w konfiguracji form płatności (patrz INSTRUKCJA ADMINISTRATORA - PARAMETRYZACJA SYSTEMU - Formy płatności), automatycznie proponuje taką formę jak opisana wyżej domyślna forma płatności dokumentu

  • Zapłacono, Data, KP - w przypadku spłaty danej raty (lub całości) uzupełniamy kwotę i datę spłaty oraz dodatkowo możemy zapamiętać numer dowodu wpłaty (KP).
    UWAGA. Jeśli prowadzimy raporty kasowe/bankowe, to kolumny te będą wypełniane automatycznie na podstawie wpisów do raportów kasowych lub bankowych.
    Ponadto jeśli płatność do tej faktury była wykonana jako zaliczka przed wystawieniem faktury i została już zaksięgowana do kasy, możemy klikając w kolumnie KP w przycisk [image] wywołać okno Rozrachunki z filtrem ustawionym automatycznie na zapłaty niepowiązane jeszcze z żadnymi fakturami:

    i klikając w przycisk [image] powiązać tę wpłatę z bieżącą fakturą.

  • K - znak X jeśli ta płatność jest zaksięgowana w raporcie kasowym lub bankowym

  • kolumny dotyczące windykacji należności:

    • P - litera P w tej kolumnie oznacza, że do tej płatności wystawiono już przypomnienie o zapłacie

    • W - litera W w tej kolumnie oznacza, że do tej płatności wystawiono już wezwanie do zapłaty

    • O - litera O w tej kolumnie oznacza, że do tej płatności wystawiono już notę odsetkową

    • N - litera N w tej kolumnie oznacza, że tę płatność uznano za nieściągalną.

Dodatkowo pod tabelką z płatnościami pokazane jest pole T informujące o tym, czy dokument został zapłacony w całości w dniu wystawienia czy też nie.

Pod tabelką z płatnościami znajduje się podsumowanie z kwotami Brutto, Zapłacono i Do zapłaty.

Jeśli korzystamy z automatycznego księgowania w raportach kasowych lub bankowych, pod tabelką z płatnościami pojawi się również pole K/B informujące o tym, czy faktura została zapłacona w całości i wszystkie płatności zostały zaksięgowane w raportach kasowych lub bankowych (X), czy też zostały zaksięgowane do kasy tylko częściowo (x). Ta sama informacja może być również widoczna bezpośrednio na liście faktur po włączeniu kolumny Kasa/Bank. Dokumentów zaksięgowanych do kasy nie można usunąć, a ich poprawa jest możliwa tylko w ograniczonym zakresie.

W przypadku faktur wystawianych w walutach obcych (tylko w wersji MAXI i PRO) w tabelce z płatnościami dostępne są dodatkowe kolumny:

  • Do zapł. wal. - kwota do zapłaty w walucie faktury

  • Zapł. wal. - kwota jaką zapłacono w walucie faktury

  • Kurs - kurs, po którym przeliczono zapłaconą kwotę na PLN.

Pod tabelką oprócz podsumowania wartości walutowych (Do zapłaty wal., Zapłacono wal. i Pozostaje wal.) znajdują się również podsumowania złotówkowe, a w nich między innymi naliczona automatycznie różnica kursowa Różn.kurs..

W przypadku faktur krajowych w walutach obcych z zaznaczonym na zakładce Stawki VATpolem VAT w PLN w tabelce z płatnościami dostępna jest ponadto kolumna określająca walutę płatności (Waluta). Pozycje w walucie obcej dotyczą płatności za kwotę netto natomiast pozycje w PLN dotyczą płatności za podatek VAT:

W momencie otrzymania zapłaty za wystawioną wcześniej fakturę należy:

  • jeśli korzystamy z modułu Kasa/Bank: wprowadzić płatność do raportu kasowego lub bankowego, korzystając z automatycznego powiązania z fakturami,

  • jeśli nie korzystamy z modułu Kasa/Bank: odszukać fakturę w ewidencji faktur i odnotować fakt zapłaty poprawiając odpowiednio zapisy na zakładce Płatności.


Faktury powtarzalne

SPRZEDAŻ

Program umożliwia automatyczne wystawianie powtarzających się co miesiąc faktur.

Jest to bardzo przydatny mechanizm w przypadku, gdy mamy np. podpisane z klientami umowy, na podstawie których co miesiąc obciążamy ich tą samą kwotą za np. obsługę księgową lub prawną, serwis urządzeń elektrycznych, serwis oprogramowania itp. Zamiast wystawiać co miesiąc kilka (lub co gorsza kilkadziesiąt lub kilkaset) takich samych faktur wystarczy wprowadzić jednorazowo tzw. wzorce takich faktur i określić datę początkową i końcową oraz częstotliwość i sposób ich wystawiania. Dzięki temu przy otwieraniu okna z fakturami program będzie sprawdzał codziennie czy w danym dniu powinniśmy wystawić jakieś faktury i po naszym potwierdzeniu wystawi te faktury automatycznie. Jeśli zdarza się, że faktury powinny zawierać pewne modyfikacje w stosunku do wzorców (np. liczbę godzin wykorzystanych w miesiącu, liczbę zaksięgowanych dokumentów itp.), nic nie stoi na przeszkodzie, aby przed wydrukiem faktur odpowiednio je zmodyfikować.

Wszystkie wystawione w ten sposób faktury można łatwo wydrukować korzystając z mechanizmu seryjnego wydruku faktur.

Mechanizm wystawiania dokumentów wg wzorców włączamy zaznaczając w danych firmy [image] parametr Ustawienia - Sprzedaż - Dokumenty powtarzalne - Włączone. Oprócz tego określamy w jakich rodzajach dokumentów sprzedaży (menu główne Ustawienia - Definicje dokumentów) chcemy korzystać z tego mechanizmu (pole Powtarzalny).

Teraz możemy przystąpić do określenia wzorców i automatycznego wystawiania faktur.


Tworzenie wzorca

SPRZEDAŻ - Faktury powtarzalne

Jeśli chcemy skorzystać z możliwości automatycznego wystawiania faktur powtarzalnych musimy najpierw utworzyć wzorce tych faktur.

Utworzenie wzorców możliwe jest na dwa sposoby:

  1. na podstawie istniejącej już faktury:
    ustawiamy się na takiej fakturze i z menu Alt F3 (lub prawy klawisz myszy) wybieramy pozycję [image] Utwórz wzorzec na podstawie tego dokumentu.
    W okienku Tworzenie wzorca określamy:

    • Data początkowa - od kiedy mają być wystawiane dokumenty wg tego wzorca

    • Data końcowa - do kiedy, jeśli do odwołania to zostawiamy pustą datę

    • Data sprzedaży

      • jak data wyst. - taka jak data wystawienia

      • ostatni dzień poprz. miesiąca - ostatni dzień miesiąca poprzedzającego miesiąc wystawienia

      • inna - na wskazany tu dzień z zachowaniem takiego przesunięcia miesięcznego w stosunku do daty wystawienia, jak teraz w stosunku do daty początkowej

    • Płatność

      • jak w oryginale - z zachowaniem rat płatności takich jak w oryginale. Oczywiście termin płatności poszczególnych rat będzie odpowiednio poprzesuwamy w stosunku do daty wystawienia faktury.

      • domyślnie - do zapłaty w jednej racie w terminie i w sposób określony albo w danych kontrahenta na zakładce Warunki albo w menu Ustawienia - Konfiguracja na zakładce Faktury

    • Termin płatności na wskazany dzień - zaznaczamy jeśli chcemy wystawiać faktury z terminem płatności na wskazany dzień (np. 20-tego każdego miesiąca), niezależny od daty wystawienia faktury, która może się zmieniać np. ze względu na weekendy lub święta

    • Utwórz co - częstotliwość wystawiania:

      • M-c (wsk. dzień) - co miesiąc, na wskazany w dacie początkowej dzień

      • M-c (pierw. dnia) - co miesiąc, pierwszego dnia miesiąca

      • M-c (ostat. dnia) - co miesiąc, ostatniego dnia miesiąca

      • Tydzień - co tydzień.

      Przy określaniu dnia, w którym należy wystawić fakturę, program może automatycznie pomijać weekendy i święta, jeśli włączymy odpowiedni parametr na zakładce Ustawienia - Sprzedaż w danych firmy [image].

  2. bezpośrednio w ewidencji wzorców:
    w oknie z fakturami uaktywniamy ewidencję wzorców (filtr [image] F4 Wzorce) i wystawiamy wzorzec analogicznie do "normalnej" faktury, określając dodatkowo opisane wyżej pola.

    Ponadto w polu Wystawienie możemy odczytać określone automatycznie daty wystawienia dokumentów wg tego wzorca:

    • nast. - następnego wystawienia

    • ostat. - data ostatniego wystawienia
      UWAGA. Porównując bieżącą datę z datą ostatniego wystawienia, program określa datę następnego wystawienia oraz ewentualne dokumenty zaległe (tzn. takie, które powinny być wystawione pomiędzy tą datą a bieżącą).
      W szczególnych przypadkach, np. jeśli przy automatycznym wystawianiu przez pomyłkę wybraliśmy opcję usuwania zaległych dokumentów, można tę datę ręcznie zmodyfikować wpisując faktyczną datę ostatniego wystawienia.

UWAGI:

  • Jeśli chcemy wystawiać faktury z terminem płatności na wskazany dzień (np. 20-tego każdego miesiąca), niezależny od daty wystawienia faktury, która może się zmieniać np. ze względu na weekendy lub święta, należy włączyć we wzorcu na zakładce Płatności parametr Wskazany dzień. Analogiczny parametr jest dostępny przy tworzeniu nowych wzorców na podstawie istniejących już faktur.

  • Jeśli chcemy, aby w fakturach wystawianych na podstawie wzorca pojawiał się automatycznie jakiś tekst związany z datą wystawienia faktury, np. "Opłata za miesiąc wrzesień 2012" gdzie "wrzesień 2012" zmieniałby się automatycznie na odpowiedni miesiąc w zależności od daty wystawienia, wystarczy we wzorcu w pozycji faktury (Alt F6) wpisać w polu Nazwa c.d. tekst "opłata za {M}". W fakturze wystawionej na podstawie tego wzorca w miejsce {M} podstawi się nazwa odpowiedniego miesiąca. Pełna lista tagów ({M} jest właśnie tagiem) dostępna jest po naciśnięciu prawego klawisza myszy w polu "Tekst dodatk." na zakładce Inne w bibliotece asortymentów. W zależności od potrzeb żądany tekst możemy wpisać albo w pozycji wzorca (wtedy wydrukuje się pod tą pozycją faktury), albo w uwagach na zakładce Uwagi pole c.d. (wtedy wydrukuje się pod podsumowaniem faktury).


Automatyczne wystawianie

SPRZEDAŻ - Faktury powtarzalne

Po utworzeniu wzorców możemy przystąpić do automatycznego wystawiania faktur powtarzalnych.

Możemy w tym celu w dowolnym momencie skorzystać z dostępnej w oknie Faktury funkcji [image] Wystaw dokumenty powtarzalne.

W wywołanym w ten sposób okienku możemy odczytać Informacje:

  • Data ostatniego wystawienia - data ostatniego wystawienia dokumentów powtarzalnych, tzn. kiedy ostatni raz korzystaliśmy z tej funkcji

  • Bieżących dokumentów - ile dokumentów powtarzalnych powinno być dzisiaj wystawionych (dzisiaj tzn. w dniu określonym przez datę bieżącą)

  • Zaległych dokumentów - ile dokumentów powtarzalnych powinno być wystawionych wcześniej (tzn. z datą wcześniejszą niż data bieżąca), ale nie zostało wystawionych (bo nie uruchamialiśmy w tych dniach tej funkcji).

Po zapoznaniu się z tymi informacjami możemy zadecydować jaką Czynność ma wykonać program:

  • Wystaw bieżące dokumenty - wystawione zostaną tylko bieżące dokumenty, jeśli dodatkowo zaznaczymy pole Usuń zaległe wówczas podczas wystawiania dokumentów bieżących jednocześniej zostaną usunięte dokumenty zaległe

  • Wystaw zaległe dokumenty z datą - zostaną wystawione z wybraną datą tylko zaległe dokumenty (bez względu na określoną we wzorcach datę). Może się zdarzyć, że zostanie wystawionych kilka takich samych faktur, jeśli zaległości są na tyle duże, że z jednego wzorca powinno już być wystawionych kilka dokumentów.

  • Usuń zaległe dokumenty do dnia - jeśli rezygnujemy z wystawienia zaległych faktur.

Aby później szybko sprawdzić jakie faktury zostały wystawione, dobrze jest włączyć parametr Podświetl wystawiane dokumenty. Jeśli wcześniej były już podświetlone jakieś dokumenty, to ich podświetlenia się nie zmieniają.

Jeśli zaznaczone zostało pole Archiwizuj dane przed rozpoczęciem operacji wystawiania/usuwania dokumentów powtarzalnch zostanie wykonana archiwizacja danych, dzięki czemu w razie potrzeby będziemy mieli możliwość anulowania całej operacji poprzez odtworzenie takiego archiwum.

Przycisk Start uruchamia wybraną wyżej czynność.

Jeśli włączymy w konfiguracji (menu główne Ustawienia - Konfiguracja zakładka Faktury) parametr Sprawdzać powtarzalne, to opisane wyżej okienko będzie się pojawiało automatycznie przy otwarciu okna Faktury, jeśli w danym dniu będą jakieś dokumenty powtarzalne do wystawienia. Jeśli pole to zostało wyłączone wówczas użytkownik sam może wystawiać dokumenty powtarzalne w dogodnym dla siebie momencie.

Jeśli pomyłkowo usunęliśmy zaległe faktury lub z innych powodów chcemy, aby program wystawił jeszcze raz faktury na podstawie wzorców, można odtworzyć dane z archiwum lub poprawić ręcznie pole Wystawienie ostatn. na wcześniejszą datę. Od tej daty zostanie obliczona data wystawienia następnego dokumentu z tego wzorca.

Wystawianie faktur na podstawie wzorców ma sens przede wszystkich w przypadku faktur usługowych - dlatego, że zwykle to właśnie usługi wykonujemy cyklicznie, a także dlatego, że nie ma pewności czy w magazynie byłaby odpowiednia ilość towarów do wystawienia wszystkich faktur powtarzalnych. Z tych powodów faktury wystawione na podstawie wzorców mają zawsze wyłączone operacje magazynowe (pole WZ na zakładce WZ), nawet jeśli ich definicja ma włączone operacje magazynowe.


Faktura korygująca

SPRZEDAŻ

Aby wystawić fakturę korygującą (lub inny dokument korygujący) należy najpierw odszukać dokument, który ma zostać skorygowany.

Jeśli ten dokument wystawiono przed rozpoczęciem użytkowania programu, należy go najpierw wystawić w programie z datą, numerem i zawartością tak jak na oryginalnym dokumencie.

Po ustawieniu się na takim dokumencie przechodzimy na zakładkę Pozycja, na której z kolei przechodzimy na zakładkę Korekty. Znajduje się na niej tabelka z korektami wystawionymi do aktualnego dokumentu. Po kliknięciu prawym klawiszem myszy na wybranej f-rze korygującej można ją szybko obejrzeć w okienku Przegląd wydruku. Można wystawić dowolną ilość korekt do jednego dokumentu.

Po przejściu do tej tabelki z korektami rozpoczynamy wystawianie dokumentu korygującego naciskając klawisz Insert lub klikając w przycisk [image]:

Zamiast aktualnego dokumentu na ekranie pojawi się nowy dokument korygujący. Na dokumencie korygującym zakładka Pozycje podzielona jest na trzy dodatkowe zakładki 1.Było, 2.Powinno być i 3.Różnica.

Program ustawi się automatycznie na tabelce z pozycjami dokumentu oryginalnego (zakładka 1.Było). Klikając podwójnie lub naciskając Enter na pozycji, którą chcemy skorygować, przejdziemy na zakładkę 2.Powinno być, gdzie można określić właściwą ilość i cenę. Na zakładce 3.Różnica program sam wyliczy różnicę w stosunku do oryginalnej pozycji. Różnica jest liczona niezależnie dla każdej wartości, np. ilość na zakładce Różnica to ilość z zakładki Powinno być pomniejszona o ilość z zakładki Było. Analogicznie cena i wartość. Oznacza to, że na zakładce Różnica wartość różni się od ilości pomnożonej przez cenę i nie jest to bynajmniej błąd.

Jeśli chcemy dodać do faktury korygującej nową pozycję, taką której nie było na korygowanej fakturze, należy przejść na zakładkę 2.Powinno być, kliknąć [image] lub nacisnąć Ins w tabelce z pozycjami, po czym przejść do kolumny z nazwą lub indeksem asortymentu, kliknąć w przycisk [image], wybrać asortyment z listy asortymentów i określić pozostałe pola (ilość, cena).

Jeśli chcemy skorygować pozycję faktury, na której zastosowano błędną stawkę podatku VAT, należy skorygować ilość na zero w błędnej pozycji (tak jakby był to zwrot tej pozycji), po czym utworzyć nowy asortyment na liście asortymentów z właściwą już stawką VAT i następnie utworzyć nową pozycję faktury korygującej z tym właśnie nowym asortymentem oraz z ilością i ceną netto taką jak w korygowanej pozycji.

Przed zaakceptowaniem dokumentu powinniśmy jeszcze określić przyczynę dokonania korekty. Wpisuje się ją na zakładce Uwagi jako Uwaga1. Pamiętajmy jeszcze o prawidłowym określeniu sposobu płatności (zakładka Płatności).


Faktura do paragonu

SPRZEDAŻ

Jeśli jesteśmy płatnikiem VAT i wystawiamy paragony fiskalne, to na życzenie nabywcy musimy wystawić do takiego paragonu fakturę VAT.

Możemy ją wystawić na dwa sposoby:

  1. jeśli chcemy wystawić jedną fakturę do jednego konkretnego paragonu:

    ustawiamy się na takim paragonie i z menu Alt F3 (lub prawy klawisz myszy) wybieramy pozycję [image] Faktura do paragonu - Wystaw do bieżącego. W wywołanym w ten sposób okienku określamy Datę wystawienia faktury i typ tej faktury (jeśli korzystamy z różnych rodzajów faktur sprzedaży) oraz Nabywcę, a także decydujemy czy utworzona faktura ma zostać podświetlona oraz czy ma mieć skopiowane uwagi, które znajdowały się na paragonie. Po kliknięciu w przycisk Start zostanie utworzona odpowiednia faktura.

  2. jeśli chcemy wystawić faktury do wybranych paragonów niepowiązanych jeszcze z żadną fakturą (tylko w wersji MAXI i PRO):

    klikając w oknie Faktury w przycisk [image] (lub prawy klawisz myszy i [image] Faktura do paragonu - [image] Wystaw do wybranych) uruchamiamy funkcję Wystaw faktury do wybranych paragonów. W wywołanym w ten sposób okienku określamy, podobnie jak wyżej, datę i typ faktury oraz dodatkowo nabywcę, dla którego mają być wystawione faktury.

    W tabelce widzimy listę paragonów wystawionych do daty Data wystawienia włącznie.

    Pod tabelką mamy jeszcze pole Łączyć paragony, które zaznaczmy jeśli chcemy wystawić jedną zbiorczą fakturę, odpowiadającą wszystkim podświetlonym paragonom. Pozycje takiej zbiorczej faktury są pogrupowane wg asortymentów i cen sprzedaży, tzn. że np. jeśli jakiś asortyment figurował na wszystkich łączonych paragonach w tej samej cenie sprzedaży, to na zbiorczej fakturze będzie figurował jako jedna pozycja ze zsumowaną ilością z wszystkich paragonów.

    Po określeniu wszystkich parametrów klikamy w przycisk Start, aby rozpocząć wystawianie faktur. Faktura zostanie wystawiona albo do bieżącego paragonu albo do wszystkich podświetlonych. Podświetlać możemy klawiszami Shift áâ lub funkcjami z menu podręcznego (prawy klawisz myszy na liście paragonu). Wszystkie paragony można szybko podświetlić naciskając klawisze Ctrl A.

Faktury wystawione do paragonów przy pomocy jednego z opisanych wyżej sposobów, można odróżnić od innych faktur dzięki widocznej na zakładce Lista kolumnie Do paragonu. Mają one również dodatkową zakładkę Paragony zawierającą tabelkę z listą paragonów, na podstawie których utworzono tę fakturę.

Korzystając z przycisków znajdujących się pod tabelką możemy:

  • Ins - powiązać tę fakturę z kolejnymi paragonami. Po kliknięciu pojawi się okienko zawierające listę paragonów wystawionych przed lub w dniu wystawienia tej faktury, do których nie była jeszcze wystawiona faktura. Wybierając odpowiednie dokumenty dodamy je do tabelki z paragonami powiązanymi z tą fakturą.

  • - przejść do wybranego w tabelce paragonu

  • Del - usunąć powiązanie z bieżącym paragonem.

Paragony, do których utworzono fakturę przy pomocy jednego z opisanych wyżej sposobów, mają odnotowany numer i datę tej faktury na zakładce Pozycja w polu Powiązana faktura (przycisk [image] umożliwia przejście do powiązanej faktury). Analogiczne informacje znajdziemy na zakładce Lista w kolumnach Nr pow.fakt (numer powiązanej faktury) oraz Data pow.fakt. (data powiązanej faktury).


Faktura do WZ

SPRZEDAŻ

Jeśli korzystamy z modułu MAGAZYN i wydawaliśmy towar z magazynu na podstawie dokumentu WZ, to na pewno będziemy chcieli skorzystać z możliwości automatycznego wystawienia faktury do takiego WZ.

Fakturę do WZ możemy wystawić na dwa sposoby:

  1. jeśli chcemy wystawić jedną fakturę do jednego konkretnego WZ:

    ustawiamy się na takim WZ i z menu Alt F3 (lub prawy klawisz myszy) wybieramy pozycję [image] Faktura do WZ - Wystaw do bieżącego. W wywołanym w ten sposób okienku określamy datę wystawienia dokumentu sprzedaży i typ tego dokumentu (jeśli korzystamy z różnych rodzajów faktur sprzedaży). Po kliknięciu w przycisk Start zostanie utworzona odpowiednia faktura.

    Jeśli chcielibyśmy wystawić fakturę jeszcze w tym samym dniu, w którym wystawiono WZ, to zamiast korzystania z opisanej tu funkcji wystarczy zmienić rodzaj dokumentu z WZ na fakturę. WZ zostanie wtedy zamieniony na automatyczny WZ skojarzony z fakturą, a jego dane, w tym również niezmieniony numer, będą widoczne na zakładce WZ.

  2. jeśli chcemy wystawić faktury do wszystkich lub wybranych WZ niepowiązanych jeszcze z żadną fakturą (tylko w wersji MAXI i PRO):

    klikając w oknie Faktury w przycisk [image] (lub prawy klawisz myszy i [image] Faktura do WZ - [image] Wystaw do wybranych) uruchamiamy funkcję Wystaw faktury do wybranych WZ. W wywołanym w ten sposób okienku określamy, podobnie jak wcześniej, datę i typ dokumentu sprzedaży oraz dodatkowo nabywcę dla którego mają być wystawione faktury. Możemy także zaznaczyć pole Nabywca podatnikiem (odwrotne obciążenie) jeśli program ma wystawić jedną zbiorczą fakturę dla wszystkich Wz danego nabywcy w trybie "Nabywca podatnikiem", czyli z adnotacją "odwrotne obciążenie".

    W tabelce widzimy listę dokumentów WZ wystawionych do daty Data wystawienia włącznie. Jeśli wybraliśmy nabywcę w polu Nabywca, to będą to tylko dokumenty WZ wystawione dla tego nabywcy (szybko wybrać WZ dla danego nabywcy można klikając podwójnie na jednym z jego WZ).

    Jeśli wybraliśmy nabywcę możemy również wybrać odbiorcę w pole Odbiorca. Odbiorcę określamy jeśli:

    • nie określiliśmy go w trakcie wystawiania WZ lub określiliśmy, ale chcemy aby faktura miała innego odbiorcę

    • określiliśmy go w trakcie wystawiania poszczególnych WZ i chcemy zawęzić listę WZ wystawionych danemu nabywcy do wybranego odbiorcy (pole Filtruj) i utworzyć fakturę (lub faktury) tylko dla takich WZ.

    Jeśli zostawimy pustego, czyli nieokreślonego odbiorcę, to w przypadku faktury łączonej z kilku WZ (zaznaczone pole Łączyć WZ), będzie miała ona nieokreślonego odbiorcę, a w przypadku pojedynczych faktur (wyłączone pole Łączyć WZ), będą miały one takiego odbiorcę jak na źródłowych WZ.

    Pod tabelką mamy jeszcze pole Łączyć WZ, które zaznaczmy jeśli chcemy wystawić jedną zbiorczą fakturę dla wybranego (lub każdego) nabywcy, odpowiadającą wszystkim WZ wystawionym temu nabywcy. Pozycje takiej zbiorczej faktury są pogrupowane wg asortymentów i cen sprzedaży, tzn. że np. jeśli jakiś asortyment figurował na wszystkich łączonych WZ w tej samej cenie sprzedaży, to na zbiorczej fakturze będzie figurował jako jedna pozycja ze zsumowaną ilością z wszystkich WZ.

    Po określeniu wszystkich parametrów klikamy w przycisk Start, aby rozpocząć wystawianie faktur. Faktura zostanie wystawiona albo do bieżącego WZ albo do wszystkich podświetlonych. Podświetlać możemy klawiszami Shift áâ lub funkcjami z menu podręcznego (prawy klawisz myszy na liście WZ). Wszystkie WZ można szybko podświetlić naciskając klawisze Ctrl A.

Faktury wystawione do WZ przy pomocy jednego z opisanych wcześniej sposobów, można odróżnić od innych faktur dzięki widocznej na zakładce Lista kolumnie Do WZ. Mają one również inną zawartość zakładki WZ niż normalne faktury. W normalnych fakturach zakładka WZ zawiera dane (numer, magazyn, pozycje) automatycznego WZ sporządzonego w trakcie wystawiania faktury. W przypadku faktur wystawionych do WZ, zakładka WZ zawiera tabelkę z listą dokumentów WZ, na podstawie których utworzono tę fakturę.

Korzystając z przycisków znajdujących się pod tabelką możemy:

  • Ins - powiązać tę fakturę z kolejnymi dokumentami WZ. Po kliknięciu pojawi się okienko zawierające listę dokumentów WZ wystawionych temu samemu nabywcy przed lub w dniu wystawienia tej faktury, do których nie była jeszcze wystawiona faktura. Wybierając odpowiednie dokumenty dodamy je do tabelki z WZ powiązanymi z tą fakturą.

  • - przejść do wybranego w tabelce dokumentu WZ

  • Del - usunąć powiązanie z bieżącym WZ.

Pod przyciskami znajdują się dodatkowe pola (W.nabycia, W.sprzedaży, Zysk, Marża%), zawierające sumaryczne dla całej faktury wartości odpowiednich wielkości.

Dokumenty WZ, do których utworzono fakturę przy pomocy jednego z opisanych wyżej sposobów, mają odnotowany numer i datę tej faktury na zakładce Pozycja w polu Powiązana faktura (przycisk [image] umożliwia przejście do powiązanej faktury). Analogiczne informacje znajdziemy na zakładce Lista w kolumnach Nr pow.fakt (numer powiązanej faktury) oraz Data pow.fakt. (data powiązanej faktury).


Faktura zaliczkowa

SPRZEDAŻ

Program R2faktury w wersji Maxi lub PRO umożliwia pełną obsługą faktur zaliczkowych. Obejmuje ona:

  1. wystawianie zamówień
  2. wystawianie faktur zaliczkowych do konkretnego zamówienia, ewentualne korekty tych faktur
  3. wystawianie faktur końcowych.

Jeśli chcemy korzystać z mechanizmu faktur zaliczkowych, należy włączyć parametr Faktury zaliczkowe w danych firmy [image] na zakładce Ustawienia - Sprzedaż.

1. ZAMÓWIENIA.

W oknie z definicjami dokumentów (menu Ustawienia - Definicje dokumentów) musimy zdefiniować zamówienia, do których będziemy wystawiać później faktury zaliczkowe. W tym celu klikamy [image] Ins i wybieramy z menu pozycję Zamówienie (sprzedaż). Wypełniamy odpowiednie dane (analogicznie jak przy definicjach innych dokumentów).

Po zdefiniowaniu zamówienia możemy je już wypisać. Postępujemy przy tym analogicznie jak w przypadku wystawiania innych dokumentów sprzedaży.

W polu Stan (obok pola z numerem faktury) pokazywany będzie na bieżąco aktualny status tego zamówienia - najpierw Wystawione, później po wystawieniu faktury zaliczkowej W realizacji, a po wystawieniu faktury końcowej Zrealizowane. Jeśli chcemy anulować wystawione już zamówienie, zmieniamy jego stan na Anulowany. Dodatkowo musimy pamiętać o wystawieniu faktur korygujących do istniejących już faktur zaliczkowych do tego zamówienia.

Natomiast na zakładce Zaliczki możemy w każdej chwili sprawdzić aktualne rozliczenie tego zamówienia, tzn. wszystkie wystawione faktury zaliczkowe i kwotę pozostającą do zapłaty.

Dzięki filtrowi Zamówienia we właściwościach [image] F4 okna Faktury możemy w każdej chwili zobaczyć wszystkie zamówienia lub zamówienia o wybranym statusie.

2. FAKTURY ZALICZKOWE.

Zgodnie z obowiązującymi przepisami, po otrzymaniu zaliczki musimy wystawić odpowiednią fakturę zaliczkową. W tym celu w trakcie wystawiania faktury określamy w polu Typ (obok numeru faktury) wartość Zaliczkowa, ewentualnie zaznaczamy jeszcze pole Zadatek, jeśli chcemy by na fakturze zamiast słowa zaliczka pojawiło się określenie zadatek. Ponadto wybieramy odpowiednie Zamówienie oraz podajemy kwotę otrzymanej zaliczki (Kwota zal.). Program sprawdzi jakie stawki vat i w jakiej proporcji występują na wskazanym zamówieniu i na tej podstawie utworzy automatycznie odpowiednie pozycje faktury zaliczkowej.

Na wydruku faktury zaliczkowej poza standardową treścią wyszczególnione zostaną wszystkie pozycje powiązanego zamówienia wraz z jego aktualnym rozliczeniem.

Faktury zaliczkowe można w razie potrzeby korygować wystawiając standardową fakturę korygującą.

UWAGA. Zgodnie z przepisami faktury zaliczkowe są zawsze przeliczane od brutto, niezależnie od aktualnego ustawienia podstawy w definicji faktury.

3. FAKTURY KOŃCOWE.

Aby sfinalizować zamówienie należy wystawić fakturę końcową - w polu Typ wybieramy Końcowa. Po wskazaniu zamówienia zostaną automatycznie wygenerowane pozycje faktury. Będą się one składać z pozycji zamówienia oraz z rozliczenia dotychczasowych faktur zaliczkowych. Jeśli faktura końcowa będzie miała zaznaczone pole WZ na zakładce WZ, to zostanie do niej wygenerowany automatyczny dokument WZ wydający towar z magazynu. Chyba że wcześniej zaznaczono pole Wz na zamówieniu. W razie potrzeby można dowolnie zmodyfikować pozycje faktury, oprócz pozycji dotyczących rozliczenia zaliczek. Fakturę końcową należy wystawić również jeśli suma dotychczasowych zaliczek była równa wartości zamówienia. W takim wypadku faktura końcowa będzie miała wartość zerową.

Fakturę końcową można wystawić również jeśli nie wystawiono żadnych faktur zaliczkowych do danego zamówienia.

UWAGA. Jeśli do zamówienia wystawiono faktury zaliczkowe, to sumaryczne wartości netto, vat i brutto na fakturze końcowej mogą się nie zgadzać, tzn. netto+vat może być o kilka groszy różne od brutto. Wynika to z faktu, że od kwot netto, vat i brutto wyliczonych i zsumowanych prawidłowo dla wszystkich stawek vat występujących na fakturze odejmowane są sumy kwot netto, vat i brutto wyliczone na fakturach zaliczkowych.


Faktura uproszczona

SPRZEDAŻ

Zgodnie z obowiązującymi przepisami, jeśli wartość brutto faktury nie przekracza 450 PLN lub 100 EUR, to faktura może mieć formę uproszczoną. Oznacza to, że m.in. nie musi posiadać pełnych danych nabywcy - wystarczy jego NIP. Program R2faktury umożliwia wystawianie faktur uproszczonych.

W celu wystawienia faktury uproszczonej w trakcie jej wystawiania, przed wybraniem kontrahenta, określamy w polu Typ (obok numeru faktury) wartość Uproszczona. Program udostępni wówczas pole umożliwiające wpisanie bezpośrednio na fakturze numeru NIP nabywcy. Pozostałe pola wypełniamy analogicznie jak w przypadku zwykłej faktury.

Podobnie jak na paragonie na fakturze uproszczonej nie ma dostępu do płatności, są one ustawiane automatycznie na "zapłacono gotówką". Przy zatwierdzeniu faktury program sprawdza czy wartość brutto nie przekracza dopuszczalnego limitu.

Jeśli wystawiane przez nas faktury nie przekraczają wartości, o której mowa, i chcemy domyślnie korzystać z mechanizmu faktur uproszczonych, należy włączyć dla dokumentu Faktura parametr Uproszczony w oknie Definicje dokumentów na zakładce Ogólne. W takim przypadku wszystkie faktury wystawione w ramach tej definicji dokumentu będą miały formę uproszczoną.

Poprawę danych [image] umożliwia klawisz F6, natomiast usunięcie [image] dokumentu klawisz Del. Poprawa i usuwanie dokumentów są możliwe tylko wtedy, gdy okres nie jest zamknięty.

Datę zamknięcia (i okres przeglądania) ustawiamy w pozycji menu głównego Ustawienia - Bieżąca data i okres (F12).

Możliwe jest szybkie wyszukanie faktury uproszczonej dla kontrahenta o konkretnym numerze NIP [image] Ctrl F7 poprzez wpisanie numeru NIP. Pojawi się okienko Szukaj, w którym należy określić pole, po którym program ma wyszukiwać, w tym przypadku będzie to NabywcaNip (Szukaj po). Kursor automatycznie ustawi się na właściwej pozycji. Żeby wyszukać kolejną pozycję (np. z tym samym numerem NIP kontrahenta) - należy wcisnąć Ctrl L.

Funkcja [image] F4 Właściwości umożliwia wyfiltrowanie wszystkich faktur uproszczonych (pole Typ) lub tylko faktur wystawionych dla kontrahenta o zadanym numerze Nip (pole Nip).

Faktury uproszczone można w razie potrzeby korygować wystawiając standardową fakturę korygującą.


Wydruki

SPRZEDAŻ

Po wystawieniu faktury można ją wydrukować. W tym celu wciskamy klawisz F2 lub klikamy w ikonkę [image] i wybieramy z menu wydruków Faktura.

W wywołanym w ten sposób okienku WYDRUK ustawiamy odpowiednie opcje:

  • Zakres

    • Aktualny dokument - wydruk aktualnego dokumentu

    • Wszystkie dokumenty - seryjny wydruk wszystkich dostępnych dokumentów, jeśli chcemy wydrukować tylko kilka podświetlonych dokumentów, należy wcześniej przełączyć okno do trybu Tylko podświetlone za pomocą klawiszy Ctrl + (plus z klawiatury numerycznej). Seryjny wydruk dokumentów dotyczy tylko faktur, paragonów i ewentualnie rachunków. Pozostałe dokumenty (proformy, WZ, zamówienia) zostaną pominięte.

  • Oryginał/Kopia

    • Oryginał + Kopia - wydrukują się 2 egzemplarze dokumentu - jeden z napisem Oryginał i drugi z napisem Kopia

    • Oryginał - wydrukuje się jeden egzemplarz dokumentu z napisem Oryginał

    • Kopia - wydrukuje się jeden egzemplarz dokumentu z napisem Kopia

    • Oryginał/Kopia - wydrukuje się jeden egzemplarz dokumentu z napisem Oryginał / Kopia

    • Duplikat - wydrukuje się jeden egzemplarz dokumentu z napisem Duplikat z dnia ....

    • Oryginał + 2 Kopie - wydrukują się 3 egzemplarze dokumentu - jeden z napisem Oryginał i dwa z napisem Kopia

    • Oryginał + 3 Kopie - wydrukują się 4 egzemplarze dokumentu - jeden z napisem Oryginał i trzy z napisem Kopia

i przygotowujemy do druku [image] bieżący dokument. Przygotowany wydruk pokaże się w oknie Przegląd wydruku. Możemy również skorzystać z funkcji bezpośredniego wydruku na drukarce (domyślnej lub ostatnio wybranej) [image], z pominięciem okna Przegląd wydruku.

Jeśli chcielibyśmy coś zmienić w wyglądzie faktury możemy sprawdzić ustawienia parametrów w oknie Definicje dokumentów (menu główne Ustawienia - Definicje dokumentów) na zakładce Wydruki. Możemy również samodzielnie zmodyfikować standardową makietę dokumentu wprowadzając w niej praktycznie dowolne zmiany (menu główne Ustawienia - Makiety dokumentów).

Oprócz faktury (lub innego dokumentu sprzedaży) możemy również wydrukować:

  • WZ - wydruk WZ wystawionego automatycznie do tego dokumentu

  • KP/KW

    • wydruk KP (lub KW) wystawionych w kasie do tej faktury (jeśli posiadamy wersję programu umożliwiającą prowadzenie raportów kasowych).

    • wydruk KP (lub KW) do płatności zaznaczonych na fakturze jako zapłacone gotówką (jeśli posiadamy wersję programu bez kasy lub wyłączyliśmy kasę w ustawieniach (okno [image] FIRMY - F6 - Ustawienia - Kasa/Bank - Wyłączona)).

  • DWW - Dokument dostawy wyrobów węglowych, który wypisujemy, gdy na fakturze lub Wz znajdzie się asortyment będący wyrobem węglowym objętym akcyzą, a kontrahent określony na tym dokumencie jest zwolniony z akcyzy wyrobów węglowych (patrz SPRZEDAŻ - Akcyza wyrobów węglowych). Dostępny tylko w wersji MAXI i PRO.

  • Koperty, Naklejki adresowe - wydruk adresów na kopertach lub wydruk naklejek adresowych dla bieżącej lub dla wszystkich faktur widocznych w oknie. Opcja przydatna dla faktur wysyłanych pocztą. Po podświetleniu ( [image] lub Shift áâ) takich faktur i uwidocznieniu tylko podświetlonych Ctrl + możemy wydrukować adresy bezpośrednio na kopertach lub ułatwić sobie adresowanie kopert drukując na papierze samoprzylepnym naklejki adresowe.

  • Deklaracja AKC-WW - deklaracja, którą obowiązane są składać wszystkie podmioty gospodarcze dokonujące czynności podlegających akcyzie wyrobów węglowych (patrz SPRZEDAŻ - Akcyza wyrobów węglowych). Dostępna tylko w wersji MAXI i PRO.

  • Rejestr sprzedaży VAT - może służyć jako podstawa do rozliczenia należnego podatku VAT. Przed wydrukiem należy wybrać odpowiedni okres (menu główne Ustawienia - Bieżąca data i okres lub klawisz F12). Bez względu na ustawienia filtru [image] F4 rejestr będzie zawierał tylko dokumenty związane z faktyczną sprzedażą oraz faktury wewnętrzne (bez proform itp).

  • Zestawienie sprzedaży VAT - uproszczona wersja rejestru vat (wydruk pionowy, jedna linijka odpowiada jednemu dokumentowi, możliwość wyboru stawek).

  • Sprzedaż - asortymenty - zestawienie sprzedaży poszczególnych asortymentów uporządkowane wg wielkości obrotów

  • Sprzedaż - asortymenty z podziałem na grupy - jak wyżej, tylko że z podziałem na grupy

  • Sprzedaż - dłużnicy wg kwot - lista niezapłaconych faktur uporządkowana w kolejności kwot do zapłaty

  • Sprzedaż - dłużnicy wg terminów płatności - lista niezapłaconych faktur uporządkowana w kolejności terminów płatności

  • Sprzedaż - dokumenty - lista dokumentów wystawionych w wybranym okresie

  • Sprzedaż - dokumenty z podziałem na nabywców - lista dokumentów podzielona alfabetycznie na poszczególnych nabywców

  • Sprzedaż - grupy - sumaryczne zestawienia sprzedaży poszczególnych grup asortymentowych

  • Sprzedaż - nabywcy - sumaryczne obroty z nabywcami uporządkowane wg wielkości obrotów

  • Sprzedaż - PKWiU - sumaryczna sprzedaż z podziałem na grupy PKWiU

  • Sprzedaż - pozycje dokumentów - pozycje z dokumentów sprzedaży (faktury, paragony)

  • Sprzedaż - stawki vat - sumaryczne obroty z podziałem na stawki Vat

  • Sprzedaż - średnia cena sprzedaży - średnia cena sprzedaży poszczególnych asortymentów

  • Wydania - asortymenty - zestawienie wydań poszczególnych asortymentów uporządkowane wg wielkości obrotów

  • Wydania - asortymenty z podziałem na grupy - jak wyżej, tylko że z podziałem na grupy

  • Wydania - dokumenty - lista dokumentów WZ wystawionych w wybranym okresie

  • Wydania - grupy - sumaryczne zestawienia wydań poszczególnych grup asortymentowych

  • Wydania - pozycje dokumentów - pozycje z dokumentów WZ

  • Wydania - pozycje z podziałem na dokumenty - pozycje poszczególnych dokumentów WZ, zestawienie przydatne do rozliczania kosztu własnego sprzedaży.

  • Wydruk listy - lista wszystkich dokumentów zawierających się w aktualnym oknie

  • Wydruk pozycji - wydruk szczegółowych informacji na temat konkretnej pozycji, znajdującej się w oknie Faktury.

Opisane wyżej zestawienia wykonywane są na podstawie przgotowanej wcześniej definicji. Korzystając z polecenia menu głównego Ustawienia - Definicje zestawień wywołujemy okno DEFINICJE ZESTAWIEŃ, w którym możemy poprawić [image] (F6) definicję istniejącego zestawienia lub utworzyć [image] (Ins) definicję zupełnie nowego zestawienia odpowiadającego naszym specyficznym potrzebom (patrz INSTRUKCJA ADMINISTRATORA - PARAMETRYZACJA SYSTEMU - Definicje zestawień).

Wydruk faktury oraz KP / KW można wykonać na drukarce igłowej w trybie znakowym (patrz ROZPOCZĘCIE PRACY - Okno główne - Przegląd wydruku - Wydruki znakowe).


Urządzenia fiskalne

SPRZEDAŻ

Program umożliwia współpracę z:

  • drukarkami fiskalnymi Posnet Thermal firmy POSNET oraz drukarkami Mera, Omega i FP600 firmy ELZAB lub kompatybilnymi

  • kasą fiskalną Posnet NEO.

Zasady konfigurowania tych urządzeń opisano w INSTRUKCJA ADMINISTRATORA - PARAMETRYZACJA SYSTEMU - Urządzenia fiskalne.

Drukarki fiskalne

Jeśli prawidłowo skonfigurujemy drukarkę, to przed wydrukiem dokumentu pojawi się okienko umożliwiające wybór drukarki fiskalnej:

  • Zwykła - standardowy wydruk dokumentu na zwykłej drukarce

  • Fiskalna - wydruk na drukarkę fiskalną (wybieramy przy wydruku paragonów - wystarczy nam paragon fiskalny)

  • Fiskalna+Zwykła - wydruk na obie drukarki (najlepsze rozwiązanie jeśli drukujemy paragon fiskalny do faktury VAT).

Jeśli wystawiliśmy jednorazowo dużo paragonów lub faktur dla osób fizycznych (np. jako faktury powtarzalne wystawiane na podstawie wzorca), możemy je wszystkie seryjnie wydrukować na drukarce fiskalnej. Wystarczy podświetlić odpowiednie faktury, przejść do trybu "Tylko podświetlone" (Ctrl +) i z menu drukowania wybrać Zakres - Wszystkie dokumenty.

Dokumenty wydrukowane na drukarce fiskalnej będą wyróżnione na liście dokumentów znakiem X w kolumnie Fiskalny, a w kolumnie Drukarka fiskalna będzie wyszczególniona nazwa drukarki na której wydrukowano paragon fiskalny. Dokumentów zafiskalizowanych nie można poprawiać ani ponownie drukować na drukarce fiskalnej. W szczególnych przypadkach, jeśli dokument jest zafiskalizowany, ale paragon fiskalny się nie wydrukował, można włączyć możliwość edycji i ponownego wydruku zafiskalizowanych dokumentów. Służy do tego parametr Edycja zafiskalizowanych dokumentów w menu Ustawienia - Konfiguracja na zakładce Faktury. Od razu po wydrukowaniu takiego paragonu należy wyłączyć możliwość edycji zafiskalizowanych dokumentów, po to żeby zabezpieczyć się przed ewentualnymi rozbieżnościami pomiędzy drukarka fiskalną a programem.

Korzystając z pola Fiskalny można zmodyfikować definicje zestawienia sprzedaży tak, aby osobno sumować dokumenty fiskalne i zwykłe.

Pole Fiskalny służy również jako kryterium filtrowania we właściwościach F4 okna FAKTURY.

Kasa fiskalna

Współpraca z kasą fiskalną obejmuje przesłanie do niej bazy asortymentów wraz z ich cenami sprzedaży, bieżące aktualizowanie tych cen oraz po zakończeniu wybranego okresu (dnia, tygodnia) automatyczne utworzenie paragonu zawierającego dane o ilości i wartości sprzedanych na kasie asortymentów.

Wszystkie opcje komunikujące się z kasą znajdują się w oknie Asortymenty, w menu podręcznym, dostępnym po kliknięciu prawym klawiszem myszy w listę asortymentów (również klawisz F3). W tym menu należy wybrać pozycję Kasa fiskalna, a uzyskamy wówczas dostęp do funkcji opisanych poniżej:

  • Wyślij asortymenty.
    Wysyła do kasy listę wszystkich widocznych w oknie asortymentów razem z cenami sprzedaży, przy czym mamy możliwość określenia pól, z których wysłać dane do kasy:

    • Nazwa PLU, gdzie do wyboru mamy następujące pola: Nazwa, Indeks, Indeks1 oraz Indeks2

    • Kod kreskowy, gdzie możemy wybrać jedno z następujących pól: Indeks, Indeks1 oraz Indeks2.

    Jeżeli chcemy wysłać do kasy tylko część asortymentów znajdujących się w bazie danych, należy skorzystać z dostępnych opcji filtrujących z dialogu wywoływanego klawiszem F4, lub skorzystać z mechanizmów podświetlania pozycji.

  • Aktualizuj ceny sprzedaży.
    Aktualizuje ceny sprzedaży w asortymentach, które zostały już wcześniej wysłane do kasy. Jeżeli chcemy dopisać do kasy nowe asortymenty, należy skorzystać z opcji Wyślij asortymenty. Po wybraniu opcji Aktualizuj ceny sprzedaży pojawi się identyczne okienko z wyborem pól, jak w przypadku opcji Wyślij asortymenty.

  • Utwórz paragon.
    Tworzy paragon zbiorczy ze wszystkimi asortymentami sprzedanymi za pomocą kasy w okresie, jaki upłynął od czasu ostatniego wyzerowania statystyk sprzedaży (opcja ta jest opisana poniżej). Aby móc utworzyć taki paragon, należy go uprzednio zdefiniować w oknie Ustawienia - Definicje dokumentów. Musi to być paragon, który na ramce Zawartość - VAT - Podstawa przeliczeń ma zaznaczony przycisk brutto. Po określeniu, z jakiej definicji dokumentu chcemy utworzyć paragon pojawi się identyczne okienko z wyborem pól, jak w przypadku opcji Wyślij asortymenty. W utworzonym paragonie dla każdego asortymentu znajdzie się jedna pozycja z łączną ilością i wartością, na jaką asortyment ten został sprzedany (w wyjątkowych wypadkach, gdyby dany asortyment sprzedawany był po różnych cenach i gdyby nie udało się znaleźć średniej ceny sprzedaży w pełnych groszach, to na paragonie mogą się pojawić dwie osobne pozycje, których suma będzie łączną ilością i wartością sprzedanego asortymentu.) Po utworzeniu i sprawdzeniu poprawności paragonu, należy wyzerować statystyki sprzedaży. Jeśli korzystamy z wersji programu z obsługą magazynu, to paragon ze sprzedażą z kasy zaktualizuje nam automatycznie stany magazynowe.

  • Wyzeruj statystyki.
    Zeruje statystyki sprzedaży po odczytaniu sprzedaży za dany okres.
    UWAGA. Po utworzeniu i sprawdzeniu poprawności paragonu, należy koniecznie wyzerować statystyki sprzedaży. Jeżeli tego nie zrobimy, to kolejny paragon będzie zawierał kwoty sprzedaży, które obejmował poprzedni paragon.

UWAGA. Jeśli decydujemy się na współpracę programu z drukarką fiskalną, to kasa fiskalna nie jest nam potrzebna. Program komputerowy w połączeniu z drukarką fiskalną funkcjonuje z punktu widzenia urzędu skarbowego dokładnie tak jak kasa fiskalna.


e-Faktury

SPRZEDAŻ

Zgodnie z Rozporządzeniem Ministra Finansów z dnia 14 lipca 2005 r. (Dz. U. 2005 r., nr 133, poz. 1119) istnieje możliwość wystawiania i przesyłania faktur w formie elektronicznej (tzw. e-faktur) pod warunkiem, że będą one podpisane podpisem elektronicznym (tzw. e-podpisem).

Program R2faktury w wersji MAXI i PRO umożliwia pełną obsługą e-faktur.

Przed rozpoczęciem wystawiania e-faktur, należy włączyć parametr e-Faktury w danych firmy [image] na zakładce Ustawienia - Sprzedaż. Ponadto należy określić folder w którym będą przechowywane kopie wystawionych e-faktur - parametr Kopie e-faktur w oknie Ustawienia - Środowisko, na zakładce Inne.

Zgodnie z Rozporządzeniem e-faktury mogą być wysyłane tylko tym kontrahentom, którzy wyrażą na to pisemną zgodę. Przykładowy wydruk formularza z wyrażeniem takiej zgody dostępny jest na liście wydruków w oknie Kontrahenci. Jest to wydruk makietowy, więc w razie potrzeby można go samodzielnie zmienić (menu Ustawienia - Makiety dokumentów).

W danych kontrahenta, na zakładce Warunki pojawiło się pole e-Faktury. Zaznaczenie tego pola informuje system, że dany kontrahent może otrzymywać e-faktury (wyraził zgodę). Faktury wystawiane temu kontrahentowi będą miały automatycznie zaznaczone pole e-Faktura. System będzie wyświetlał ostrzeżenie, gdy będziemy próbowali podpisać elektronicznie fakturę dla kontrahenta, który nie ma zaznaczonej zgody na e-faktury. Ostrzeżenie zostanie wyświetlone także wtedy, gdy będziemy próbowali wysłać e-mailem niepodpisane faktury kontrahentowi, który ma zaznaczoną zgodę na e-faktury. Oczywiście, aby móc wysłać taką fakturę kontrahentowi, musimy wcześniej wpisać jego adres w polu E-mail na zakładce Kontakt.

Przed przystąpieniem do sporządzania e-faktur należy upewnić się, czy na komputerze zostało zainstalowane całe niezbędne oprogramowanie służące do obsługi czytnika kart kryptograficznych. Program wymaga, aby na dysku znajdował się tzw. sterownik karty, umożliwiający dostęp do znajdującego się na niej certyfikatu. Najprawdopodobniej jest to plik o nazwie CCPkiP11.dll (dla kart z firm KIR oraz Sigillum PCCE) lub cryptoCertum3PKCS.dll albo cryptoCertumPKCS11.dll lub 3PKCS.dll albo PKCS11.dll (dla kart z firmy Certum Unizeto) i domyślnie powinien znajdować się w folderze C:\WINDOWS\SYSTEM32. Ścieżka do tego sterownika jest określana w dialogu Ustawienia - Środowisko - Inne, w parametrze Sterownik karty. Ponadto, wymagane jest również, aby w systemie operacyjnym był zainstalowany prawidłowo skonfigurowany, mający dostęp do internetu program Internet Explorer.

Podpisywanie faktur odbywa się w trakcie wysyłania faktury e-mailem. Po przygotowaniu wydruku pojedynczej faktury klikamy w oknie Przegląd wydruku w przycisk [image] Wyślij jako e-mail i wybieramy format PDF (podpis elektroniczny).

Przed wysłaniem e-maila pokaże się jeszcze okienko e-Podpis. Upewniamy się czy czytnik kart kryptograficznych (wraz z kartą) jest podłączony do portu USB i wybieramy właściwy certyfikat, a następnie podajemy numer PIN.

Możemy również seryjnie przygotować wiele e-faktur. W tym celu po wystawieniu odpowiednich faktur ustawiamy we właściwościach [image] F4 okna Faktury filtr e-Faktury na wartość Tak. Dzięki temu w oknie będą widoczne tylko faktury dla kontrahentów, którzy wyrazili zgodę na otrzymywanie e-faktur. Następnie przygotowujemy wydruk wszystkich faktur.

Po przygotowaniu wydruków klikamy w oknie Przegląd wydruku w przycisk [image] Wyślij jako e-mail do poszczególnych kontrahentów.

W okienku Wysyłanie wydruku zostawiamy puste pole Adres DO - dzięki temu program automatycznie podstawi adres e-mail nabywcy odpowiedniej faktury (pod warunkiem, że adresy te są wpisane w kartotece Kontrahentów dla każdego nabywcy). Aby wysłać podpisane elektronicznie faktury, należy teraz wybrać Format PDF (podpis elektroniczny) i kliknąć przycisk Wyślij. Ukaże się wtedy okno e-podpisu, które należy wypełnić odpowiednimi danymi (jak np. PIN) a wtedy faktury zostaną podpisane i wysłane.

Istnieje również możliwość podpisania faktury bez wysyłania jej mailem. W tym celu w oknie podglądu wydruku faktury należy kliknąć przycisk [image] i zaznaczyć parametr podpis elektroniczny.

Aby obejrzeć podpisaną fakturę należy otworzyć ją w programie Adobe Reader. Program ten umożliwi obejrzenie szczegółowych informacji dotyczących osoby podpisującej fakturę, daty wykonania podpisu, jego wiarygodności, certyfikatu itd.

Zgodnie z wymogami Rozporządzenia program zapamiętuje kopie podpisanych elektronicznie faktur w folderze podanym w oknie Ustawienia - Środowisko na zakładce Eksport w polu Kopie e-faktur. Domyślnym katalogiem jest podkatalog EFAKTURY w głównym katalogu programu R2Faktury (można oczywiście wybrać dowolny inny katalog). W wybranym katalogu znajdą się osobne podkatalogi dla każdej używanej w systemie firmy, w nich z kolei - podkatalogi dla każdego kontrahenta z osobna (nazwą podkatalogu jest nadawany automatycznie kod kontrahenta). Dopiero w tych podkatalogach zostaną umieszczone e-faktury.


Windykacja należności

SPRZEDAŻ - Wystawianie faktur

Aby dochodzić naszych należności za przeterminowane faktury, możemy skorzystać z globalnego mechanizmu windykacji (patrz NALEŻNOŚCI I ZOBOWIĄZANIA - Windykacja należności) lub z analogicznych funkcji udostępnianych indywidualnie dla każdej faktury.

Jeśli interesuje nas ten drugi przypadek, to po kliknięciu prawym klawiszem myszy na wybranej fakturze (na liście faktur) wybieramy z menu polecenie [image] Windykacja należności. Ten sam przycisk dostępny jest również na zakładce Płatności. Uzyskamy w ten sposób dostęp do okna Windykacja należności zawierającego wyłącznie płatności związane z bieżącą fakturą.

Korzystając z odpowiednich przycisków możemy wystawić: przypomnienie o zapłacie, [image] wezwanie do zapłaty i [image] notę odsetkową.

Kliknięcie w przycisk [image] spowoduje zaznaczenie danej płatności jako nieściągalnej. W takim przypadku należy sporządzić odpowiedni protokół. Ze względu na trudności z ustaleniem jednolitego wzoru takiego protokołu, nie można go wydrukować z programu.

Na zakładce Płatności przy każdej płatności widoczna jest na bieżąco informacja o wystawionych do niej przypomnieniach P, wezwaniach W i notach odsetkowych O (O - wystawionych, ale niezapłaconych, Z - zapłaconych, U - umorzonych w całości lub częściowo) lub o zaliczeniu danej płatności do nieściągalnych N.


Eksport dokumentów do programu księgowego

SPRZEDAŻ

Program R2faktury umożliwia eksport danych do programów księgowych R2księga - księga przychodów i rozchodów, ryczałt oraz R2fk - pełna księgowość (patrz EKSPORT DANYCH). Jednym z elementów tego eksportu jest opisany poniżej eksport dokumentów sprzedaży oraz RW.

Wystawione faktury i inne dokumenty sprzedaży możemy w każdej chwili, a najlepiej po zakończeniu miesiąca, wyeksportować do programu R2księga (księga przychodów i rozchodów lub ryczałtowa ewidencja przychodów), systemu R2fk (pełna księgowość) lub innego programu księgowego.
Programy R2księga i R2fk potrafią zaimportować faktury wyeksportowane z programu [image] i automatycznie je zaksięgować uwzględniając odpowiednie konta, dane kontrahenta, rozbicie na stawki vat, rodzaj sprzedaży (towar, produkt, usługa - istotne w ryczałcie) oraz płatności.

Do systemu R2fk możemy dodatkowo wyeksportować dokumenty RW.

Przed eksportem faktur do programu księgowego należy w danych firmy określić parametry współpracy, tzn. rodzaj prowadzonej księgowości (pole Rozliczenia) i nazwę programu, do którego chcemy eksportować dane (pole Eksport do na zakładce Ustawienia - Ogólne).

Faktury do zaksięgowania wysyłamy z okna Faktury przy pomocy funkcji [image] (również z menu podręcznego wywołanego klawiszem F3 lub prawym klawiszem myszy). W wywołanym w ten sposób okienku określamy:

  • Docelowa baz danych - baza, do której zostaną wyeksportowane faktury

  • Wyczyść bufor przed zapisaniem danych - po zaznaczeniu tej opcji bufor będzie zawsze zawierał tylko aktualnie eksportowane dokumenty. W przeciwnym wypadku dokumenty będą do bufora dodawane - umożliwia to przygotowanie wspólnego bufora z PZ i fakturami. Korzystając z takiego wspólnego bufora, możemy w programie księgowym wykonać jedną operację importu danych, zamiast osobnej dla PZ i osobnej dla faktur. Dokumenty prawidłowo zaimportowane do programu księgowego są przez ten program automatycznie usuwane z pliku importowego.

  • w przypadku eksportu do R2fk:

    • Typ dokumentów - dostępny tylko w wersji MAXI i PRO

      • Sprzedaż - faktury i inne dokumenty sprzedaży

      • RW - dokumenty RW (rozchód wewnętrzny)

      • Wszystkie - sprzedaż + RW

    • Księguj każdą pozycję dokumentu osobno - jeśli chcemy zaksięgować każdą fakturę na osobnym koncie związanym z tą pozycją - takie konto określamy w bibliotece asortymentów w polu Konto sprzedaży na zakładce FK lub w analogicznym polu bezpośrednio w pozycji faktury w oknie Pozycje faktur

    • Wymagaj konta przy każdej pozycji - jeśli decydujemy się na osobne księgowanie każdej pozycji dokumentu, powinniśmy określić konto sprzedaży przy każdej pozycji faktury. Aby zabezpieczyć się przed zaksięgowaniem dokumentów, które mają nieokreślone konta w pozycjach włączamy ten właśnie parametr. Jeśli wyłączymy ten parametr to pozycje z nieokreślonym kontem sprzedaży zostaną zaksięgowane na domyślne konto sprzedaży określone w programie R2fk.

    • Opis przy każdej pozycji - jeśli decydujemy się na osobne księgowanie każdej pozycji dokumentu, możemy dla każdej pozycji wyeksportować nazwę asortymentu. Pojawi się ona w opisie tej pozycji na zaksięgowanym dokumencie.

  • Zakres - co ma być wyeksportowane

  • Opis zdarzenia - sposób tworzenia opisu zdarzenia gospodarczego; wybieramy Pierwsza pozycja z dokumentu, jeśli ma to być pierwsza pozycja z faktury lub Sprzedaż towarów/produktów/usług - w zależności od rodzaju asortymentów na danej fakturze będzie to sprzedaż towarów lub sprzedaż usług albo sprzedaż towarów, usług itp.

UWAGI:

  1. Sposób księgowania paragonów i faktur nieterminowych (zapłaconych gotówką lub w inny sposób od razu w dniu wystawienia) zależy od parametru Eksport danych do programu księgowego określonego na zakładce Ogólne w konfiguracji programu (patrz INSTRUKCJA ADMINISTRATORA - PARAMERYZACJA SYSTEMU - Konfiguracja).

  2. Przed eksportem dokumentów wybieramy odpowiedni okres, obejmujący datę wystawienia wszystkich dokumentów, które chcemy zaksięgować (menu główne Ustawienia - Bieżąca data i okres lub szybciej klawisz F12). Zwykle będzie to cały miesiąc lub fragment miesiąca obejmujący nowe dokumenty, które nie zostały jeszcze zaksięgowane.
    W szczególnych przypadkach, jeśli wprowadzając dokumenty określiliśmy na zakładce FK/Księga/Ewidencja w polu Data księgowania datę z innego miesiąca niż datę wystawienia, należy powtórzyć eksport danych dla miesiąca (okresu) obejmującego datę księgowania. Przed powtórnym eksportem należy wyłączyć parametr Wyczyść bufor przed zapisaniem danych, dzięki czemu będziemy mieli w tym samum buforze wszystkie dokumenty, które mają być zaksięgowane w danym miesiącu (tzn. zarówno te które mają datę wystawienia z danego miesiąca, jak i te które mają inną datę wystawienia, ale datę ksiegowania z tego miesiąca).
    Np. jeśli wystawiliśmy we wrześniu fakturę z datą księgowania z 31.08, to aby prawidłowo zaksięgować faktury za sierpień należy najpierw wybrać w okresie miesiąc sierpień (zostaną wyeksportowane wszystkie faktury z datą wystawienia z sierpnia i z dowolnymi datami księgowania), a potem dodatkowo wszystkie z września (zostaną wyeksportowane wszystkie z datą wystawienia z września i z dowolnymi datami księgowania). Przed importem ustawiamy w programie księgowym w okresie miesiąc sierpień. Program księgowy sprawdzi, które dokumenty z bufora należy zaksięgować w sierpniu. Będą to te, które mają datę księgowania z sierpnia lub, w przypadku nieokreślonej daty księgowania, te które mają datę wystawienia z sierpnia. Pozostałe dokumenty zostaną pominięte.

  3. Jeśli korzystamy z eksportu danych do programu R2fk lub R2księga lecz nie dokonaliśmy integracji modułów, wówczas zamiast pola Docelowa baza danych widoczne będzie pole Plik docelowy, w którym należy określić do jakiego pliku zostaną wyeksportowane dane. Taki sam plik należy wskazać w R2księdze lub w R2fk przy imporcie danych.

  4. Jeśli korzystamy z eksportu danych do programu R2fk w wersji 2.0x lub R2księga w wersji 3.0x, wówczas w oknie Eksport danych do programu RESET2... należy dodatkowo zaznaczyć odpowiednio pole w.2.0x lub w.3.0x.


Import/Eksport faktur

SPRZEDAŻ

Program [image] umożliwia import faktur z pliku tekstowego o określonym formacie oraz eksportowanie wybranej grupy faktur do pliku tekstowego o tym samym formacie. Format ten opisano szczegółowo w specyfikacji importu faktur, znajdującej się w załączniku do instrukcji wywoływanej w programie.

Opcje importu oraz eksportu faktur mogą być przydatne w różnych sytuacjach, np:

  • do automatycznego tworzenia faktur wygenerowanych z dowolnego zewnętrznego systemu

  • do przesyłania faktur pomiędzy przedstawicielami i centralą, np. gdy firma korzysta z akwizytorów wystawiających faktury w terenie

  • do automatycznego tworzenia faktur na podstawie faktur pro-forma przysyłanych przez oddział firmy lub zamówień przysyłanych od klientów

IMPORT FAKTUR

Można importować faktury przygotowane w dowolnym zewnętrznym programie, jeżeli tylko przygotowane zostaną w formacie opisanym w załączniku do INSTRUKCJI ADMINISTRATORA - Specyfikacja importu faktur. Można również importować faktury, które zostały wyeksportowane w innym programie [image] za pomocą opcji Eksport faktur do programu RESET2 - R2faktury.

Operację importu możemy wykonać poleceniem menu głównego Zbiory - Import danych - Import faktur z programu RESET2 - R2faktury lub z menu podręcznego wywołanego klawiszem F3 (lub prawym klawiszem myszy) z okna FAKTURY. Przed wykonaniem importu należy określić następujące parametry:

  • Dane zostaną wczytane z pliku - lokalizacja i nazwa źródłowego pliku z danymi do importu (można go wpisać ręcznie lub odnaleźć klikając przycisk [image]). Po wskazaniu pliku możemy obejrzeć jego zawartość za pomocą przycisku Podgląd.

  • Rodzaj dokumentu - służy do określenia definicji dokumentu, którą mają otrzymać wczytane dokumenty. Jeżeli w pliku źródłowym rodzaje te są poprawnie określone, możemy wybrać wartość Automatycznie. Wówczas odczytane dokumenty będą miały taki sam rodzaj, jaki podany został w pliku źródłowym. Natomiast jeżeli w pliku źródłowym rodzaje nie zostały określone lub z jakichś innych powodów chcemy zmienić rodzaj importowanych dokumentów, wtedy należy wybrać konkretny rodzaj z listy. Czyli jeżeli np. wybierzemy rodzaj FakturaVat, to wtedy wszystkie zaimportowane dokumenty będą miały rodzaj FakturaVat, niezależnie od tego, jaki rodzaj miały te dokumenty oryginalnie.

  • Identyfikacja asortymentów - służy do określenia jednoznacznego identyfikatora asortymentu, by zapobiec dublowaniu asortymentów już istniejących w bazie danych. W trakcie importu faktur program sprawdza bowiem, czy asortymenty tych faktur istnieją już w bazie danych w tabeli Asortymenty. Jeżeli asortymentu nie ma jeszcze w tabeli, to zostanie on do niej dodany automatycznie w trakcie importu. O tym, czy dany asortyment w pliku źródłowym jest nowym asortymentem, czy też już istniejącym w bazie danych, decyduje zgodność pól Skrót nazwy lub Indeks, w zależności od wartości omawianego parametru.

  • Identyfikacja kontrahentów - służy do określenia jednoznacznego identyfikatora kontrahenta, by zapobiec dublowaniu kontrahentów już istniejących w bazie danych. W trakcie importu faktur program sprawdza bowiem, czy kontrahenci tych faktur istnieją już w bazie danych w tabeli Kontrahenci. Jeżeli kontrahenta nie ma jeszcze w tabeli, to zostanie on do niej dodany automatycznie w trakcie importu. O tym, czy dany kontrahent w pliku źródłowym jest nowym kontrahentem, czy też już istniejącym w bazie danych, decyduje zgodność pól NIP i/lub Skrót, w zależności od wartości omawianego parametru.
    UWAGI:

    1. W przypadku, gdy wybierzemy opcję NIP lub NIP,Skrót może się zdarzyć, że program dopisze kontrahenta, którego NIP co prawda jest unikalny, ale jego Skrót jest identyczny z jakimś już istniejącym w kartotece kontrahentem. Ze względu na to, że w programie R2faktury pole Skrót musi być polem jednoznacznym (dwaj różni kontrahenci nie mogą mieć takiej samej wartości w polu Skrót), to w takim przypadku program wyświetli komunikat i do pola Skrót tego kontrahenta dodany zostanie przyrostek z kolejnym numerem (_1, _2 itd).

    2. Podczas porównywania pól NIP brane są pod uwagę tylko cyfry, czyli np. 652-111-22-33 i 6521112233 zostaną uznane za jednakowe pola NIP.

  • Kontrahent - pole dostępne jeśli wcześniej w polu Identyfikacja kontrahentów wybraliśmy opcję Kontrahent z biblioteki. Ma to sens wtedy, gdy importujemy sobie Pz do Faktur, wówczas nie ma sensu, żeby dostawca z PZ stawał się odbiorcą faktury. Wybieramy więc konkretnego kontrahenta w tym dialogu.
    UWAGA. Jeśli mamy więcej dokumentów, należy wówczas utworzyć jakiegoś kontrahenta tymczasowego, wskazać go z biblioteki w tym dialogu, a potem ręcznie pozamieniać kontrahentów bezpośrednio na utworzonych fakturach.

  • WZ - dotyczy pola WZ znajdującego się na zakładce WZ na fakturach. Mamy do wyboru trzy możliwości:

    1. Takie jak w pliku - tę opcję należy wybrać, jeżeli w pliku źródłowym zaznaczenie pola WZ zostało określone (Tak/Nie) dla poszczególnych dokumentów i chcemy, aby dokumenty uzyskały takie właśnie zaznaczenie po zaimportowaniu

    2. Takie jak w definicji dokumentu - spowoduje, że wszystkie odczytywane dokumenty otrzymają takie oznaczenie WZ, jakie określono w defincji danego rodzaju dokumentu, niezależnie od tego, co podano w pliku źródłowym. Może to mieć zastosowanie np. wtedy, gdy importujemy dokumenty od przedstawiciela, który wypisywał dokumenty z wyłączonym polem WZ, a my chcemy aby podczas importu te WZ-ki utworzyły się nam automatycznie i mamy pewność, że stan na magazynie jest wystarczający.

    3. Zawsze wyłączone - spowoduje, że wszystkie odczytywane dokumenty będą miały wyłączone pole WZ. Tę opcję należy wybrać np. wówczas, gdy mamy nieuzupełnione stany magazynowe i obawiamy się, że import faktur może powodować komunikat o braku na stanie odpowiednich asortymentów.

  • Ceny - dotyczy cen znajdujących się na zakładce Pozycje na fakturach. Mamy do wyboru dwie możliwości:

    1. Takie jak w pliku - tę opcję należy wybrać, jeżeli w pliku źródłowym ceny zostały określone dla poszczególnych dokumentów i chcemy, aby dokumenty uzyskały takie właśnie ceny po zaimportowaniu

    2. Domyślna cena sprzedaży - spowoduje, że wszystkie odczytywane dokumenty zostaną przeliczone wg domyślnych cen sprzedaży określonych w programie w oknie Asortymenty, niezależnie od tego, co podano w pliku źródłowym.

  • Płatności - dotyczy ustawień znajdujących się na zakładce Płatności na fakturach. Mamy do wyboru dwie możliwości:

    1. Takie jak w pliku - tę opcję należy wybrać, jeżeli w pliku źródłowym płatności zostały określone dla poszczególnych dokumentów i chcemy, aby dokumenty uzyskały takie właśnie płatności po zaimportowaniu

    2. Domyślne - spowoduje, że wszystkie odczytywane dokumenty zostaną oznaczone wg domyślnych ustawień określonych w programie w oknie Konfiguracja na zakładce Faktury, niezależnie od tego, co podano w pliku źródłowym.

  • Twórz brakujące asortymenty - jeżeli zaznaczymy ten parametr, to w trakcie importu faktur program będzie sprawdzał, czy asortymenty z tych faktur istnieją już w bazie danych w tabeli Asortymenty. Jeżeli któregoś asortymentu nie będzie jeszcze w tabeli, to zostanie on do niej dodany automatycznie podczas importu. O tym, czy dany asortyment istnieje już w bazie danych decyduje zgodność pól Indeks lub pierwszych 50 znaków pola Nazwa, tzn. jeżeli w tabeli znajduje się asortyment o zgodnym indeksie, lub o nazwie zgodnej z nazwą podaną w pliku, to program uzna, że jest to ten właśnie asortyment i jego identyfikator zostanie wpisany na zaimportowany dokument. W przeciwnym wypadku, asortyment zostanie dodany do tabeli Asortymenty.
    Jeżeli natomiast parametr Twórz brakujące asortymenty pozostawimy niezaznaczony, to program będzie traktował wszystkie asortymenty znajdujące się w pliku źródłowym jako jednorazowe usługi, które nie będą dodawane do kartoteki Asortymenty, a ich nazwy będą zapisywane w pozycjach faktury w polu Nazwa cd.

  • Podświetl utworzone dokumenty - umożliwia łatwe odnalezienie (i ewentualną weryfikację) zaimportowanych dokumentów. Przed wykonaniem tej funkcji dobrze jest wcześniej odświetlić w oknie FAKTURY wszystkie podświetlone pozycje, aby upewnić się, że po wykonaniu importu na liście podświetlonych pozycji będą rzeczywiście tylko te, które zostały zaimportowane z pliku.

UWAGA. Istnieje możliwość importowania krzyżowego, tzn. importowania pliku z Fakturami do okna PZ (np. gdy jeden klient drugiemu wypisał fakturę w naszym programie, i dał mu plik, dzięki czemu ten będzie mógł sobie go zaimportować i zrobić z niego PZ zamiast wprowadzać ręcznie) oraz możliwość importowania pliku z dokumentami PZ do okna Faktury (co mogłoby się ewentualnie przydać w firmie produkcyjnej, która zrobiła jakieś produkty pod konkretną fakturę/zamówienie, albo w hurtowni, która sprowadziła coś na PZ tylko po to, aby to od razu sprzedać). W obu tych krzyżowych przypadkach trzeba koniecznie pamiętać o tym, że parametr Rodzaj dokumentu musi być konkretnie podany, (nie może być ustawiony na opcję Automatycznie, bo PZ na fakturę się automatycznie nie zamieni). Trzeba też uważać z przekazywaniem cen i płatności (czyli parametry Ceny i Płatności powinny mieć wartości Domyślne). Ponieważ dostawca PZ to nie jest odbiorca na fakturze, więc być może będzie potrzebne ręczne wybranie Kontrahenta z biblioteki.

EKSPORT FAKTUR

Operację eksportu możemy wykonać poleceniem menu głównego Zbiory - Eksport danych - Eksport faktur do programu RESET2 - R2faktury lub z menu podręcznego wywołanego klawiszem F3 (lub prawym klawiszem myszy) z okna FAKTURY. Przed wykonaniem eksportu należy określić lokalizację i nazwę pliku, do którego mają zostać zapisane dane, oraz zakres tych danych, tzn. które faktury mają zostać wyeksportowane. Mamy do wyboru 4 możliwości:

  • Aktualny dokument - eksport aktualnego dokumentu

  • Takie jak w oknie - zostaną wyeksportowane tylko dokumenty widoczne aktualnie w oknie FAKTURY

  • Podświetlone - zostaną wyeksportowane tylko dokumenty, które są aktualnie podświetlone w oknie FAKTURY (bez względu na to czy w oknie pokazywane są wszystkie, czy tylko podświetlone pozycje)

  • Wszystkie - zostaną wyeksportowane wszystkie dokumenty.

Wykonanie operacji eksportu spowoduje zapisanie w podanym pliku danych na temat wybranych faktur.

Operacja importu faktur nigdy nie modyfikuje ani nie kasuje żadnych danych już istniejących w bazie systemu. Może wyłącznie dodawać nowe elementy do bazy danych (faktury, kontrahentów, asortymenty). Np. w przypadku, gdy w pliku źródłowym znajdzie się faktura wystawiona dla pana Adamskiego, który figuruje już w tabeli Kontrahenci, to program pozostawi dane pana Adamskiego w niezmienionej postaci - nawet gdyby w pliku źródłowym dane te były inne, ale jeżeli adres podany na fakturze nie będzie zgodny z żadnym z dotychczasowych adresów pana Adamskiego, to zostanie utworzony dla niego kolejny adres w tabeli adresów kontrahentów i wpisany na zaimportowany dokument.

Program blokuje też możliwość dwukrotnego zaimportowania tej samej faktury. Numer importowanej faktury jest zapamiętywany w polu Nr zewn., które jest niedostępne do edycji. Nie ma możliwości ponownego odczytu faktury o takim numerze. Nr zewn. jest wyświetlany w oknie głównym faktury po prawej stronie pola Numer, ale tylko wtedy, gdy faktura pochodzi z importu.
UWAGA. Podczas importu faktury otrzymują kolejne numery w ramach danego rodzaju. Nie muszą więc być to numery zgodne z numerem, który znajduje się w pliku źródłowym. Aby numeracja ta była zgodna, konieczne jest przestrzeganie pewnych reguł pracy z programem (programami), tzn. np. faktury danego rodzaju muszą być wyłącznie importowane, a nie wypisywane ręcznie, musi być zachowana odpowiednia chronologia wypisywania faktur i ich eksportu/importu itp.

UWAGA. W obecnej wersji programu faktury korygujące nie mogą być importowane.

Eksport i import faktur przy użyciu pliku XML dostępny jest tylko w wersji PRO.


Dane dedykowane

SPRZEDAŻ

Program umożliwia korzystanie z danych dedykowanych, tzn. określanie indywidualnie dla każdego nabywcy pewnych cech poszczególnych asortymentów (oraz grup asortymentowych). Dzięki temu mechanizmowi możemy ustalić na przykład, że dla nabywcy Odbiorca A cena sprzedaży na asortyment towar A wynosi 100 złotych, mimo iż wszyscy inni kontrahenci będą go kupować po 120 zł, bo taka właśnie cena jest wpisana w cenniku głównym, czyli w bibliotece asortymentów.

Mechanizm danych dedykowanych dostępny jest tylko w wersji MAXI i PRO. Aby go uaktywnić, należy włączyć parametr Dane dedykowane w ustawieniach bieżącej firmy [image] (patrz SPRZEDAŻ - Konfiguracja).

W zależności od potrzeb, okno Dane dedykowane możemy wywołać w trzech różnych miejscach programu: z okna Kontrahenci, z okna Asortymenty lub z okna Grupy. W każdym z tych okien dostęp do edycji danych dedykowanych umożliwia menu podręczne otwierane po kliknięciu prawym klawiszem myszy lub po naciśnięciu klawisza F3.

Jeżeli okno Dane dedykowane wywołamy z okna Kontrahenci, to wpisując dane dedykowane należy określić, którego asortymentu dana pozycja dotyczy (podając Nazwę lub Indeks asortymentu). Zamiast asortymentu możemy też określić grupę asortymentową - wówczas wpisy dokonane w tej pozycji będą dotyczyć wszystkich asortymentów w ramach tej grupy.

Jeśli zamiast określania danych dedykowanych na różne asortymenty dla wybranego kontrahenta wolelibyśmy określić różnych kontrahentów, którzy powinni mieć np. ceny dedykowane na wybrany asortyment, wystarczy ustawić się na tym asortymencie w oknie Asortymenty i z tego miejsca wywołać okno Dane dedykowane (prawy klawisz myszy lub F3). Należy wówczas określić, którego kontrahenta dotyczy dany wpis (podając Skrót lub NIP kontrahenta).

Analogicznie jeśli chcemy określić różnych kontrahentów, którzy powinni mieć specjalne rabaty na wybraną grupę asortymentową, należy ustawić się na tej grupie w oknie Grupy i z tego miejsca wywołać okno Dane dedykowane.

Dane dedykowane zgrupowane są w dwóch zakładkach:

  • Na zakładce Ceny wpisujemy cenę (netto i/lub brutto), którą przypisujemy dla danej pary kontrahent-asortyment (lub kontrahent-grupa asortymentowa). Zamiast ceny możemy określić rabat procentowy od normalnej ceny określonej w cenniku, czyli na liście asortymentów.
    UWAGA. W przypadku, gdy dana pozycja dotyczy grupy asortymentowej, to wpisywanie cen nie jest możliwe - możemy wpisać wyłącznie rabat, jaki na asortymenty danej grupy ma uzyskiwać kontrahent. Jeśli korzystamy z walutowych cen sprzedaży, to przeliczenia dedykowanych cen walutowych na PLN i na odwrót dokonywane są wg kursu określonego w asortymencie.

  • Na zakładce Cechy wpisujemy dodatkowe, definiowane cechy asortymentu, które interesują danego kontrahenta. Jeżeli chcemy korzystać z tej zakładki, powinniśmy najpierw zdefiniować te cechy (ich nazwy) na zakładce Dane dedykowane w kartotece Kontrahenci. Każdemu z kontrahentów należy wpisać indywidualnie te cechy, które są przez niego wymagane. Dzięki temu mechanizmowi możemy poradzić sobie w sytuacji, gdy jeden z kontrahentów wymaga od nas podawania na wystawianych mu fakturach jego własnego, dodatkowego indeksu asortymentu oraz np. numeru fabrycznego, a inny kontrahent z kolei potrzebuje np. rozmiaru i producenta asortymentu. Program umożliwia zdefiniowanie maksymalnie 5 cech każdemu kontrahentowi.

Dodatkowo, możemy określić zakres czasowy, w którym dany wpis obowiązuje. Możemy wypełnić obie daty, tylko jedną z nich lub żadną. Jeżeli nie wypełnimy żadnej daty, to wpis obowiązuje bezterminowo. Jeżeli podamy Datę od, to wpis obowiązuje od podanego dnia włącznie. Jeżeli podamy Datę do, to wpis obowiązuje do podanego dnia włącznie.

Jeżeli wywołaliśmy Dane dedykowane z okna Kontrahenci, to dostępna jest opcja kopiowania danych dedykowanych. Opcję tę można uruchomić kilkoma sposobami - za pomocą kombinacji klawiszy Ctrl-Shift-D, klikając przycisk [image] na ramce, ewentualnie wybierając opcję Kopiuj dane dedykowane z innego nabywcy w menu podręcznym (prawy klawisz myszy lub przycisk F3). Wywołanie funkcji spowoduje wyświetlenie okna, w którym należy określić nabywcę, z którego zamierzamy skopiować dane dedykowane. Wykonanie kopiowania spowoduje, że na bieżącego kontrahenta zostaną przepisane wszystkie dane dedykowane dla wszystkich asortymentów z nabywcy wzorcowego. Dzięki temu możemy w prosty sposób powielać np. raz wpisany komplet promocyjnych cen i rabatów.

Pozycje wpisane w oknie Dane dedykowane są zawsze widoczne, bez względu na to gdzie je wprowadziliśmy. Jeśli np. kontrahentowi Odbiorca A wpisaliśmy na asortyment towar A jakąś cenę dedykowaną w oknie Dane dedykowane wywołanym z okna Kontrahenci, to ta sama cena będzie widoczna w ewidencji cen dedykowanych wywołanej z okna Asortymenty na pozycji towar A.

Ceny i rabaty wpisane w tabeli Dane dedykowane brane są pod uwagę podczas wystawiania faktury. Na przykład jeżeli dla nabywcy Odbiorca A i asortymentu towar A przypisano cenę 100 złotych netto, to gdy będziemy wypisywać Odbiorcy A fakturę i wpiszemy na nią towar A, to bez względu na wybrany dla tej pozycji rodzaj ceny w pole Cena netto wpisana zostanie kwota 100 zł. Analogicznie, jeżeli nabywca Odbiorca B ma określony rabat 6% dla grupy asortymentowej Grupa A, to gdy będziemy wypisywać Odbiorcy B fakturę sprzedaży i wpiszemy na nią towar A (lub jakikolwiek inny asortyment z grupy Grupa A), to w tej pozycji w pole Rabat wpisana zostanie wartość 6%. Oczywiście, dane te będziemy mogli zmienić w razie potrzeby.

Dane wpisane na zakładkę Cechy mogą być drukowane na fakturach i innych dokumentach wykonywanych na podstawie makiet. Makietę taką należy samodzielnie zdefiniować (patrz INSTRUKCJA ADMINISTRATORA - PARAMETRYZACJA SYSTEMU - Makiety dokumentów). Mnemoniki, które spowodują wydrukowanie odpowiedniej cechy asortymentu na fakturze dla danego kontrahenta nazywają się DKP_Cecha1 ... 2, 3, 4, 5.

UWAGA. Dla danego nabywcy i asortymentu (oraz nabywcy i grupy asortymentowej) można wpisać tylko jedną pozycję w danym okresie czasu. Natomiast jeżeli dany nabywca ma wpis dedykowany zarówno dla danego asortymentu, jak i dla grupy, do której należy ten asortyment, to pierwszeństwo ma wpis dokonany dla konkretnego asortymentu. Na przykład, jeżeli nabywca Odbiorca A będzie miał określoną cenę 100 złotych netto dla asortymentu towar A oraz rabat 6% dla grupy asortymentowej Grupa A, to gdy na fakturze dla Odbiorcy A wpiszemy asortyment towar A, wówczas na pozycję tę wpisana zostanie cena 100 złotych, natomiast rabat pozostanie równy 0.00.

Dane na temat cen i rabatów dedykowanych można wydrukować za pomocą trzech gotowych zestawień, lub skonstruować dowolne własne zestawienie. Zestawienia te dostępne są pod przyciskiem F2 w oknie Asortymenty.


e-Faktury

Akcyza wyrobów węglowych

SPRZEDAŻ

1 stycznia 2012 roku zakończyło się ogólne zwolnienie od akcyzy dla węgla i koksu przeznaczonych do celów opałowych. W związku z tym od 2 stycznia 2012 roku wyroby te podlegają opodatkowaniu akcyzą na zasadach określonych w ustawie z dnia 6 grudnia 2008r. o podatku akcyzowym (Dz. U. Nr 108, poz. 626, z późn. zm.). Program R2faktury w wersji MAXI i PRO umożliwia ewidencję i rozliczanie tej akcyzy.

Aby włączyć w programie [image] funkcje dotyczące akcyzy na wyroby węglowe, należy w danych firmy [image] wejść na zakładkę Ustawienia - Sprzedaż i kliknąć przycisk Akcyza wyrobów węglowych. Ukaże się wówczas okno Akcyza wyrobów węglowych, w którym należy:

  • zaznaczyć parametr Włączona

  • w pole Miejsce wydania wpisać domyślne miejsce, z którego najczęściej wydajemy wyroby węglowe (podczas wypisywania faktur oraz dokumentów Wz będziemy mogli podać inne miejsce w razie potrzeby)

  • określić parametry dotyczące automatycznej numeracji dowodów wydania wyrobów węglowych (patrz wyjaśnienie dla dokumentów sprzedaży).

Dla każdego asortymentu podlegającego akcyzie w polu Kod CN na zakładce Inne należy wpisać odpowiedni kod CN. Wyroby węglowe objęte akcyzą mają kody 2701, 2702 oraz 2704 (np. węgiel objęty jest kodem 2701, węgiel brunatny - kodem 2702, a koks - 2704). Biblioteka kodów CN znajduje się w oknie Okna - Biblioteki - CN. Ponadto, każdy asortyment podlegający akcyzie powinien mieć wypełnione pole Waga [kg].

Każdy kontrahent, któremu dostarczamy wyroby węglowe a jest zwolniony z akcyzy na te wyroby, powinien nas o tym fakcie poinformować, podając tytuł prawny tego zwolnienia. Takiemu kontrahentowi powinniśmy na zakładce Akcyza w kartotece Kontrahenci wypełnić następujace pola:

  • zaznaczyć parametr Zwolniony

  • w pole Miejsce odbioru wpisać domyślne miejsce, w którym ów kontrahent będzie od nas odbierał wyroby węglowe (w razie potrzeby, będzie je można modyfikować podczas wypisywania konkretnych faktur lub Wz)

  • wypełnić pole Tytuł zwolnienia.

Jeżeli wypisujemy fakturę lub dokument Wz, na którym znajdzie się asortyment będący wyrobem węglowym objętym akcyzą, a kontrahent określony na tym dokumencie jest zwolniony z akcyzy wyrobów węglowych, to mamy obowiązek wystawić tzw. Dokument dostawy wyrobów węglowych (w skrócie DWW). Dane związane z tym dokumentem znajdują się w oknie Faktury na zakładce Inne i zgrupowane są w ramce Akcyza wyrobów węglowych. Znajdują się tam pola:

  • Drukuj DWW - pole to powinno być zaznaczone, jeżeli na dokumencie znajdą się wyroby węglowe objęte akcyzą, a kontrahent jest zwolniony z tej akcyzy. Zaznaczenie tego pola udostępni do edycji wszystkie pozostałe opisywane pola. Dla kontrahentów zwolnionych z akcyzy pole to zaznaczy się automatycznie.
    Uwaga. Jeżeli na dokumencie nie ma wyrobów węglowych objętych akcyzą, pole Drukuj DWW należy pozostawić niezaznaczone.

  • Zwolnij z akcyzy bez DWW - pole to powinno być zaznaczone, jeżeli na dokumencie znajdą się wyroby węglowe zwolnione z akcyzy bez konieczności wystawiania dokumentu DWW, np. wyroby węglowe zakupione w ilości nieprzekraczającej 200kg.

  • Numer - jeżeli pole Drukuj DWW jest zaznaczone, to program automatycznie nada kolejny numer DWW zgodnie z układem podanym w okienku Akcyza wyrobów węglowych wywołanym z okna FIRMY - Ustawienia - Sprzedaż. W razie potrzeby, numer ten można do pewnego stopnia modyfikować (analogicznie, jak opisano to dla numeru faktury).

  • Miejsce wydania - miejsce, z którego wydane zostaną wyroby węglowe (domyślnie przepisana zostanie wartość pola z okna Akcyza wyrobów węglowych wpisana w danych firmy)

  • Miejsce odbioru - miejsce, do którego zostaną dostarczone wyroby węglowe (domyślnie, przepisana zostanie tam zawartość pola Miejsce odbioru z zakładki Akcyza z danych kontrahenta)

  • Tytuł zwolnienia - tytuł prawny, na podstawie którego kontrahent zwolniony jest z akcyzy (domyślnie przepisany z danych kontrahenta).

Dokument dostawy wyrobów węglowych drukujemy wywołując z okna Faktury menu drukowania [image] (F2) i wybierając opcję DWW.

W menu drukowania [image] (F2) w oknie Faktury znajduje się też wydruk Deklaracja AKC-WW. Deklarację tą obowiązane są składać wszystkie podmioty gospodarcze dokonujące czynności, które podlegają akcyzie wyrobów węglowych. Podczas pierwszego generowania deklaracji należy uzupełnić Dane podatnika. Wydruk tej deklaracji dostępny jest również z menu Raporty.


KASA/BANK

INSTRUKCJA UŻYTKOWNIKA

Moduł KASA/BANK służy do prowadzenia raportów kasowych (RK, KP, KW) w celu rozliczenia płatności realizowanych gotówką, kartą płatniczą lub w inny sposób. Umożliwia również prowadzenie raportów bankowych (odpowiedników wyciągów bankowych) do rozliczania płatności realizowanych za pomocą przelewów bankowych.

Jeśli posiadamy wersję programu umożliwiającą obsługę transakcji zagranicznych (dostępne tylko w wersji MAXI i PRO), to raporty mogą być prowadzone w dowolnej walucie obcej, z automatycznym przeliczaniem na PLN i obliczaniem różnic kursowych.

Najważniejsze funkcje i możliwości modułu KASA/BANK to:

  • Raporty kasowe RK, dokumenty wpłaty KP i wypłaty KW

  • Możliwość prowadzenia jednocześnie kilku kas

  • Możliwość prowadzenia kilku raportów w obrębie jednego dnia. Dostępne tylko w wersji MAXI i PRO.

  • Raporty bankowe dla dowolnej liczby rachunków bankowych

  • Automatyczne księgowanie wpłat i wypłat na podstawie wystawionych faktur i PZ

  • Automatyczne księgowanie wpłat i wypłat na podstawie rozrachunków z kontrahentem

  • Raporty można prowadzić w PLN lub w walutach obcych. Raporty w walutach dostępne są tylko w wersji MAXI i PRO.

Jeśli firma prowadzi pełną księgowość, prowadzenie raportów kasowych jest obligatoryjne. Dla mniejszych firm jest dobrowolne. Bez względu jednak na wielkość firmy prowadzenie raportów kasowych i bankowych jest przede wszystkim wygodne, gdyż umożliwia szybkie i bezbłędne rozliczanie płatności za wystawione faktury sprzedaży oraz zakupu (PZ). Ponadto daje możliwość szybkiego sprawdzenia stanu wszystkich zasobów finansowych firmy.

Moduł KASA/BANK umożliwia ścisłe powiązanie raportów z wystawionymi fakturami oraz innymi dokumentami sprzedaży i zakupu. Korzystać z niego może ta sama osoba, która wystawia faktury (w mniejszych firmach) lub osoba, która zajmuje się tylko i wyłącznie prowadzeniem kasy, np. na innym komputerze z uruchomionym tym samym programem w wersji sieciowej (większe firmy).
Faktury i PZ wystawiane jako zapłacone są natychmiast widoczne w kasie jako Automatyczne KP/KW. Można je wpisywać do kasy na bieżąco po wystawieniu każdej faktury (PZ) lub zbiorczo np. na koniec każdego dnia pracy.
Jeśli wpłata do kasy dotyczy wystawionej wcześniej faktury terminowej, to można w trakcie wprowadzania wpisu do raportu skorzystać z okna Rozrachunki i powiązać tę wpłatę z odpowiednią fakturą lub fakturami wystawionymi danemu kontrahentowi. Dotyczy to analogicznie sytuacji, gdy to my płacimy naszemu dostawcy za wystawione przez niego faktury (PZ).
Jeśli wpłata za fakturę terminową dokonana jest przelewem i na podstawie wyciągu trudno nam skojarzyć ją z konkretnym kontrahentem, możemy skojarzyć ją np. po numerze faktury, jeśli oczywiście kontrahent powołał się na niego w treści przelewu. Wystarczy w tym celu skorzystać ze wspomnianego już mechanizmu Automatyczne KP/KW i skojarzyć wpłatę z dowolną pozycją na wykazie wszystkich niezapłaconych faktur wystawionych w danym okresie.

Dzięki mechanizmowi praw dostępu (patrz INSTRUKCJA ADMINISTRATORA - PARAMETRYZACJA SYSTEMU - Użytkownicy - Grupy użytkowników) można tak skonfigurować program, żeby inna osoba (np. kasjer) mogła wprowadzać raporty kasowe, a inna (np. księgowy) raporty bankowe. Nic nie stoi również na przeszkodzie, żeby przystosować program do pracy np. z kilkoma kasami, tak żeby każdy kasjer miał dostęp tylko do swoich raportów.

Moduł KASA/BANK jest dostępny po zakupieniu licencji na odpowiednią wersję programu.

Jeśli chcemy korzystać z modułu KASA/BANK, należy go odpowiednio skonfigurować.

Po skonfigurowaniu możemy kliknąć w głównym oknie programu w przycisk [image] i rozpocząć wprowadzanie raportów w oknie Kasa/Bank.


Raporty kasowe i bankowe

KASA/BANK

Ogólne zasady korzystania z raportów kasowych i bankowych opisane zostały w rozdziale Kasa/Bank.

Okna z raportami i pozycjami raportów, podobnie jak wszystkie inne okna w programie, zostały zaprojektowane pod kątem maksymalnej szybkości pracy. Wprowadzanie danych może odbywać się tylko z klawiatury, bez użycia myszki, wykorzystując pomocną część numeryczną klawiatury. Przejście do kolejnego pola umożliwia Enter lub Tab, a zatwierdzenie całego okna Alt PgDn. Zmianę sposobu wprowadzania danych umożliwia zakładka Nawigacja w pozycji menu głównego Ustawienia - Środowisko.

Przed wprowadzeniem raportu kasowego lub bankowego należy wybrać właściwy okres, obejmujący okres raportu. W tym celu wybieramy z menu głównego Ustawienia - Bieżąca data i okres. Szybką zmianę okresu umożliwia klawisz F12.

Wprowadzając [image] nowy raport (Ins) najpierw określamy jego typ, tzn. Raport kasowy (gotówka) lub Raport bankowy (przelew). Następnie w zależności od dokonanego wyboru wybieramy w polu Kasa rodzaj raportu kasowego (patrz INSTRUKCJA ADMINISTRATORA - PARAMETRYZACJA SYSTEMU - Definicje dokumentów - Raporty kasowe) lub w polu Rachunek jeden z rachunków bankowych firmy (patrz ROZPOCZĘCIE PRACY - Wprowadzanie danych firmy - Rachunki bankowe firmy).

Po wybraniu kasy lub banku wypełniamy następujące dane:

  • Numer - numer kolejny raportu, najlepiej nie wypełniać tego pola ręcznie - program automatycznie w momencie akceptacji raportu podstawi kolejny, unikalny numer; pole to składa się z 2 części: białej i szarej, w części szarej pokazany jest pełny numer dokumentu, w układzie określonym w definicji tego rodzaju dokumentu, np. 1/12/RK a w części białej właściwy numer kolejny, czyli np. 1; po dwukrotnym kliknięciu myszką w białą część pole Numer zmienia się na pole Układ umożliwiając zmianę układu numeru na inny niż określony w definicji dokumentu

  • Od, Do - okres obejmowany przez raport, w zależności od ustawienia w danych firmy parametru Ustawienia - Kasa/Bank - Godziny wprowadzamy same daty lub daty z godzinami. Opcja Godziny dostępna tylko w wersji MAXI i PRO.
    UWAGI:

    1. Data Od musi mieścić się w wybranym okresie pracy (patrz ROZPOCZĘCIE PRACY - Okno główne - Bieżąca data i okres). Jeśli chcemy wprowadzić raport z datą początkową spoza wybranego okresu, musimy najpierw zmienić okres przeglądania.

    2. Przy wprowadzeniu nowego raportu program podstawia jako daty Od i Do datę bieżącą. Jeśli data bieżąca jest wcześniejsza niż data końcowa ostatniego raportu w danym rodzaju, to podstawiona zostanie taka data, aby wprowadzany raport był kontynuacją ostatniego.

    3. Data Od musi być większa od daty zamknięcia. Podobnie nie da się poprawić ani usunąć raportu z datą Od należącą do zamkniętego okresu.

  • Waluta - waluta, w której będzie prowadzony ten raport. Przepisuje się z definicji raportu kasowego lub rachunku bankowego. Aktywne na raporcie walutowym tylko w wersji MAXI i PRO.

  • Kasjer - wpisujemy kto Sporządził i kto Sprawdził ten raport

  • Uwagi - wszelkie dodatkowe informacje, które powinny być wydrukowane na raporcie

  • Notatki - wszelkie dodatkowe informacje związane z tym raportem, które nie powinny być na nim wydrukowane

  • Dokumenty - KP, KW, Inne - Liczba dowodów wpłaty KP, wypłaty KW oraz innych dokumentów np. faktur kosztowych (zakup paliwa, materiałów biurowych, itp.); dodatkowo informacja o numerach KP i KW (Od nr, Do nr) wystawionych w tym raporcie

  • Obrót - wyliczona na podstawie wprowadzonych do raportu pozycji suma wpłat Wn (+) i wypłat Ma (-)

  • Saldo - różnica między sumą wpłat Wn (+) i sumą wypłat Ma (-), czyli ile z tego raportu wpłynęło pieniędzy.

Na raporcie prowadzonym w walucie obcej dostępne są również pola Obrót wal. i Saldo wal. zawierające odpowiednie wartości walutowe.

Wprowadzone dane akceptujemy przyciskiem [image] OK. Do szybkiej akceptacji służy również klawisz PgDn.

Po zaakceptowaniu raportu możemy przystąpić do wprowadzania na ten raport pozycji (KP, KW i innych). W tym celu należy kliknąć w przycisk [image] lub nacisnąć na liście raportów klawisz Enter.

Po wpisaniu wszystkich pozycji i wydrukowaniu raportu, możemy ten raport zamknąć, żeby zabezpieczyć się przed przypadkowymi zmianami. Raportów zamkniętych nie można poprawić ani usunąć. Aby zamknąć raport należy kliknąć w przycisk [image] lub nacisnąć na liście raportów klawisze Shift F4. Zamykanie raportów jest możliwe tylko w porządku chronologicznym, tzn. nie da się zamknąć raportu, którego poprzednik jest niezamknięty. Analogicznie klikając w przycisk [image] lub naciskając na liście raportów klawisze Shift F4 można uprzednio zamknięty raport otworzyć (pod warunkiem, że wszystkie następne raporty są otwarte).

Poprawę danych [image] umożliwia klawisz F6, natomiast usunięcie [image] raportu klawisz Del. Poprawa i usunięcie raportu jest możliwe tylko wtedy, gdy raport i okres nie są zamknięte. Datę zamknięcia (i okres przeglądania) ustawiamy w pozycji menu głównego Ustawienia - Bieżąca data i okres (F12).

Możliwe jest szybkie wyszukanie dowolnego raportu [image] Ctrl F7 poprzez wpisanie numeru raportu (lub np. daty początkowej). Pojawi się okienko Szukaj, w którym należy określić, jakie pola ma brać pod uwagę przy wyszukiwaniu (Szukaj po). Kursor automatycznie ustawi się na właściwej pozycji.

Dodatkowa funkcja [image] F4 umożliwia ustawienie stałego filtru na raporty spełniające zadane kryteria:

  • Rodzaj - raporty jednego rodzaju (np. tylko raporty bankowe)

  • Rachunek bankowy - jeśli w polu Rodzaj wybraliśmy raporty bankowe, to tutaj możemy jeszcze określić z jakiego rachunku bankowego

  • Kasa - jeśli w polu Rodzaj wybraliśmy raporty kasowe, to tutaj możemy jeszcze określić z jakiej kasy

  • Tylko własne - dotyczy raportów wystawionych ze współdzielonych definicji, w oknie będą dostępne tylko te, które wystawił aktualny użytkownik programu. W zależności od uprawnień nadanych użytkownikowi (pole Tylko własne dokumenty w uprawnieniach grupy użytkowników) będzie on mógł zmienić wartość tego parametru i przeglądać również współdzielone raporty wystawione przez innych użytkowników.

Klawisz F2 udostępnia następujące [image] wydruki:

  • Raport kasowy/bankowy - wydruk bieżącego raportu

  • Wydruk listy - lista wszystkich raportów kasowych/bankowych widocznych w oknie

  • Wydruk pozycji - wydruk szczegółowych informacji na temat konkretnej pozycji znajdującej się w oknie Kasa/bank.

Wydruki RK, KP i KW można wykonać na drukarce igłowej w trybie znakowym (patrz ROZPOCZĘCIE PRACY - Okno główne - Przegląd wydruku - Wydruki znakowe).


Wpłaty i wypłaty (KP, KW, Inne)

KASA/BANK

Dokumenty KP, KW i inne dokumenty kasowe wprowadzane są w oknie Pozycje raportu. Wywoływane jest ono z okna Kasa/Bank przez naciśnięcie na odpowiednim raporcie klawisza Enter bądź kliknięciu w przycisk Pozycje [image].

Wprowadzając [image] nową pozycję (Ins) najpierw określamy jej typ, tzn.:

  • dla raportów typu Raport kasowy:

    • KP - dowód wpłaty, np. zapłata za wystawioną przez nas fakturę

    • KW - dowód wypłaty, np. zapłata za fakturę zakupu (PZ) lub zwrot pieniędzy w związku z wystawioną przez nas fakturą korygującą

    • Inny - zwykle obca faktura kosztowa, którą traktujemy jako dokument kasowy, żeby nie wystawiać niepotrzebnie dodatkowego dokumentu KW, np.: zakup paliwa, zakup artykułów biurowych itp.

    • Automatyczne KP (X), Automatyczne KW (X) - zapłata za dokumenty zakupu i sprzedaży, które wystawiono jako zapłacone i które nie zostały jeszcze wpisane do kasy - w ten sposób można szybko utworzyć odpowiednie KP/KW bez konieczności wyszukiwania kontrahenta i faktury. W miejsce znaku X podstawiana jest liczba zapłat z datą mieszczącą się w okresie bieżącego raportu i z formą płatności właściwą dla bieżącego raportu.

    • Automatyczne KP do paragonów (X), Automatyczne KW do paragonów (X) - zapłata za paragony, które nie zostały jeszcze wpisane do kasy - w ten sposób można szybko utworzyć jedno zbiorcze KP/KW bez konieczności sumowania kwot z wszystkich paragonów. W miejsce znaku X podstawiana jest liczba paragonów z datą mieszczącą się w okresie bieżącego raportu i z formą płatności właściwą dla bieżącego raportu. KW wystawiane jest w przypadku paragonów korygujących (zwroty).

  • dla raportów typu Raport bankowy:

    • Przychód - wpłata np. zapłata za wystawioną przez nas fakturę

    • Rozchód - wypłata np. zapłata za fakturę zakupu (PZ) lub zwrot pieniędzy w związku z wystawioną przez nas fakturą korygującą

    • Inny - dowolna pozycja wyciągu bankowego, bez względu na to czy jest to uznanie (przychód) czy obciążenie (rozchód) rachunku

    • Automatyczny przychód (X), Automatyczny rozchód (X) - analogicznie jak w raportach kasowych, ale ze względu na specyfikę raportów bankowych, tzn. że najpierw jest wpłata a dopiero później zaznaczamy ją w fakturze, opcje te mają inne zastosowanie niż w raportach kasowych. A mianowicie służą do odnajdywania faktury, za którą otrzymaliśmy płatność, ale którą trudno zidentyfikować, bo w tytule przelewu nie ma numeru faktury. Przeglądając listę wszystkich niezapłaconych faktur, możemy znaleźć właściwą porównując kontrahenta i kwotę.

Jeśli wybraliśmy KP, KW albo Inny wprowadzamy następujące dane:

  • Numer - numer dokumentu. W przypadku KP, KW najlepiej nie wypełniać tego pola ręcznie - program automatycznie w momencie akceptacji pozycji podstawi kolejny, unikalny numer. Jeśli wprowadzamy pozycję typu Inny wpisujemy tu np.: numer faktury lub numer albo datę wyciągu. To co zostanie wpisane w tym polu pojawi się w fakturach na zakładce Płatności w kolumnie Kp/Kw.

  • Kontrahent

    • Skrót - wybieramy kontrahenta z biblioteki kontrahentów; aby szybko wyszukać kontrahenta zaczynamy pisać w tym polu; jeśli kontrahent jeszcze nie istnieje w bibliotece, to możemy go wprowadzić klawiszem Ins (z rozwiniętej klawiszem â listy kontrahentów), możemy również przejść do pełnej biblioteki kontrahentów (kliknąć w napis Biblioteka (F2)), żeby na przykład przejrzeć dane lub wyszukać po części danych; szybko wybrać kontrahenta z pełnej biblioteki można klawiszami Alt Enter;

    • NIP - umożliwia łatwy wybór kontrahenta przez wybranie NIP-u

    • Osoba - imię i nazwisko osoby, która dokonuje wpłaty (KP) lub wypłaty (KW).

  • Opis - wybieramy opis z biblioteki opisów lub wprowadzamy go ręcznie, np.: "Za fakturę VAT nr", "Zaliczka za..." itp. Wprowadzenie opisu nie jest wymagane.

  • Waluta raportu - waluta w jakiej prowadzony jest raport. Aktywne na raporcie walutowym tylko w wersji MAXI i PRO.

  • Waluta rozrachunków - waluta rozrachunków, które będziemy chcieli powiązać na zakładce Dokumenty z tą pozycją raportu (zapłatą). Kontrahent może mieć rozrachunki prowadzone w różnych walutach, ale dostępne do powiązania z tą zapłatą będą tylko należności/zobowiązania powstałe w określonej tu walucie rozrachunków. Jeśli raport jest prowadzony w PLN, to waluta rozrachunków może być dowolna, natomiast na raportach walutowych może to być tylko taka waluta jak określona wyżej waluta raportu lub PLN. W ten sposób możemy na przykład zapłacić na raporcie walutowym prowadzonym w EUR za fakturę złotówkową. Analogicznie możemy na raporcie złotówkowym zapłacić za fakturę wystawioną w EUR. Nie możemy natomiast zapłacić na raporcie walutowym za fakturę wystawioną w innej walucie niż waluta raportu, chyba że w PLN. Dostępne na raporcie walutowym tylko w wersji MAXI i PRO.

  • Kurs - kurs wg którego zostanie przeliczona płatność walutowa na PLN. Dostępny na raporcie walutowym tylko w wersji MAXI i PRO.

  • Konto - istotne przy księgowaniu do R2fk - rodzaj konta analitycznego, które zostanie użyte do wygenerowania dekretu. Opcja "Określ w pozycjach" pozwala na wprowadzenie dowolnego konta bezpośrednio w pozycjach dokumentu. Wybór konta Dostawcy lub Odbiorcy wyłącza dostęp do kolumny Konto w tabelce z dokumentami, a odpowiednie konto będzie określone w programie R2fk na podstawie odpowiednich kont wybranego kontrahenta.

  • Dokumenty - lista faktur, których dotyczy ta pozycja raportu

    • Rodzaj - wpłata Wn (+) lub wypłata Ma (-)

    • Opis (nr dokumentu) - nr faktury lub dowolny inny opis. Jeśli chcemy powiązać wpisywaną płatność z fakturą należy kliknąć w tym polu w przycisk [image] lub nacisnąć klawisze Ctrl Enter

      i wywołać okno z rozrachunkami kontrahenta, w którym będziemy mogli wybrać odpowiednią fakturę. Po wybraniu takiej faktury (lub kilku faktur) pojawią się one w okienku z dokumentami z automatycznie wypełnionymi wszystkimi polami.

    • P - powiązanie - pokazuje znak X dla wpłat powiązanych automatycznie z wystawionymi fakturami

    • Kwota wal. - kwota wpłaty/wypłaty w walucie. Dostępne na raporcie walutowym tylko w wersji MAXI i PRO.

    • Kwota - kwota wpłaty/wypłaty

    • Konto - w pełnej księgowości konto analityczne przeciwstawne do konta Kasa lub Bank

    • Komp - kompensata - w starszych wersjach programu to pole było wykorzystywane do kompensowania zapłat. Teraz do tego celu służy funkcja Skojarz bezpośrednio w rozrachunkach kontrahenta. Pole Komp zostawiono w celu kompatybilności z danymi wprowadzonymi we wcześniejszych wersjach programu.

    • Akt nr fakt. - aktualny numer faktury. Jeśli wpłata dotyczyła proformy, która później została zamieniona na właściwą fakturę, to tu właśnie widać numer tej właściwej faktury - nr proformy jest wpisany wcześniej w kolumnie Opis (nr dokumentu).

    • Obrót Wn (+) - suma wpłat wpisanych w tabelce z dokumentami

    • Obrót Ma (-) - suma wypłat wpisanych w tabelce z dokumentami

    • Saldo - suma wpłat minus suma wypłat

  • Uwagi - dowolne uwagi, które mają się wydrukować na KP/KW

  • Notatki - dowolne notatki dla własnej informacji, nigdzie nie drukowane

  • Liczba dokum. - liczba dokumentów wpisanych do tabelki z dokumentami.

Wprowadzone dane akceptujemy przyciskiem [image]. Do szybkiej akceptacji służy również klawisz PgDn.

Poprawę danych [image] umożliwia klawisz F6, natomiast usunięcie [image] wpisu klawisz Del. Poprawa i usunięcie pozycji raportu jest możliwe tylko wtedy, gdy raport i okres nie są zamknięte. Datę zamknięcia (i okres przeglądania) ustawiamy w pozycji menu głównego Ustawienia - Bieżąca data i okres (F12).

Klawisz F2 udostępnia następujące [image] wydruki:

  • Dowód wpłaty KP lub Dowód wypłaty KW - wydruk bieżącego dokumentu KP/KW

  • Wydruk listy - lista wszystkich dokumentów zawierających się w aktualnym Raporcie kasowym

  • Wydruk pozycji - wydruk szczegółowych informacji na temat konkretnej pozycji znajdującej się w oknie Pozycje raportu kasowego.

Jeśli pomyliliśmy się wybierając rodzaj dokumentu i wprowadziliśmy np. KW zamiast Inny, to możemy to łatwo naprawić korzystając z funkcji menu podręcznego (prawy klawisz myszy lub F3) Zmień rodzaj na ....


Powiązanie z rozrachunkami

KASA / BANK - Wpłaty i wypłaty (KP, KW, inne)

W trakcie wprowadzania kwoty wpłaty/wypłaty na zakładce Dokumenty pozycji raportu kasowego lub bankowego możemy wywołać okno Rozrachunki (kliknąć przycisk [image] lub nacisnąć klawisze Ctrl Enter). Pojawi się ono wówczas w trybie umożliwiającym wybór niezapłaconych pozycji (czyli zaksięgowanych wcześniej faktur zakupu/sprzedaży) i wpisanie ich na dokument KP, KW lub inny.

Klikając w przycisk [image] Wybierz możemy wpisać do bieżącego dokumentu KP/KW/Inny zapłaty za wszystkie podświetlone pozycje. Wszystkie pozycje można łatwo podświetlić naciskając klawisze Ctrl A, a wybrane naciskając klawisze Shift á lub Shift â na wybranych pozycjach. W efekcie uzyskamy dokument kasowy z automatycznie wypełnionymi pozycjami:


Automatyczne KP / KW

KASA/BANK - Wpłaty i wypłaty (KP, KW i inne)

Okno Automatyczne KP / KW (lub Automatyczny przychód/rozchód na raporcie bankowym) wywoływane jest z okna Pozycje raportu w trakcie tworzenia nowej pozycji i służy do:

  1. szybkiego księgowania w kasie zapłat za faktury gotówkowe:
    Standardowo okienko zawiera listę zapłat za faktury lub faktury korygujące, które wystawiono w oknie Faktury zaznaczając im na zakładce Płatności, że są zapłacone i które nie zostały jeszcze wpisane do kasy(banku). Analogicznie dotyczy to również dokumentów PZ (odpowiedników faktur zakupu) wystawionych w oknie PZ. Domyślnie uwzględniane są tylko zapłaty z datą mieszczącą się w okresie bieżącego raportu i z formą płatności właściwą dla bieżącego raportu - zwykle gotówka (patrz INSTRUKCJA ADMINISTRATORA - PARAMETRYZACJA PROGRAMU - Definicje dokumentów - Raporty kasowe).

    Klikając w przycisk [image] możemy utworzyć automatyczne KP/KW do wszystkich podświetlonych pozycji. Wszystkie pozycje można łatwo podświetlić naciskając klawisze Ctrl A, a wybrane naciskając klawisze Shift á lub Shift â na wybranych pozycjach.

  2. łatwego wyszukiwania i księgowania faktur terminowych:
    Wywołując [image] F4 Właściwości okna, możemy zmienić kryteria filtrowania tak, żeby na przykład pokazać niezaksięgowane jeszcze w kasie zapłaty wykonane z datą nie obejmowaną przez bieżący raport lub z inną formą płatności. Podświetlenie i wybranie pozycji, które nie mieszczą się w domyślnych ustawienia filtra (odpowiednia forma i data zapłaty) spowoduje automatyczne wystawienie dokumentów KP/KW/Inny z datami i formami płatności przystosowanymi do bieżącego raportu.

    Możemy określić następujące kryteria filtrowania:

    • Zakres

      • Zapłacone - takie, które w kolumnie Zapłacono mają określoną kwotę

      • Niezapłacone - takie, które w kolumnie Zapłacono mają kwotę 0 (zero) lub kwotę nieokreśloną

      • Przeterminowane - takie, którym minął już termin płatności, a nie są jeszcze zapłacone

      • Nierozliczone - faktury niepowiązane z wpłatami lub wpłaty zaliczek niepowiązane z fakturami

      • Wszystkie - naciskając klawisz Del lub Backspace usuwamy dotychczasowe kryterium określone w tym polu co oznacza, że będą wyświetlane wszystkie płatności, bez względu na to czy są zapłacone, niezapłacone, czy przeterminowane

    • Wn(+)/Ma(-)

      • Wn(+) - wpłaty

      • Ma(-) - wypłaty

      • Wszystkie

    • Waluta - waluta raportu. Dostępna tylko w wersji MAXI i PRO.

    • Typ dokum. - Z rozrachunkami, bez rozrachunków (w zależności od ustawienia w definicji dokumentów) lub wszystkie

    • Nr dokum. - pokazane zostaną tylko rozrachunki pochodzące z dokumentu o podanym tu numerze

    • Forma płatności właściwa dla tego raportu - tylko płatności z taką samą formą jak określona w definicji raportu kasowego. W przypadku raportu bankowego będzie to zawsze przelew.

    • Forma - jeśli odznaczymy opisane wyżej pole, to tutaj możemy wpisać interesującą nas formę płatności lub zostawić wolne miejsce (Del lub Backspace), co będzie oznaczało dowolną formę płatności

    • Płatności niepowiązane z dokumentami - np. wpłacone nadpłaty lub zaliczki niepowiązane jeszcze z żadnymi fakturami/PZ - puste kolumny Data wyst., Do zapłaty i Termin

    • Data operacji - pozycje z datą wystawienia lub datą zapłaty mieszczącą się w wybranym tu okresie

    • Termin płatności - płatności z terminami mieszczącymi się w wybranym tu okresie

    • Data wystawienia - płatności dotyczące faktur/PZ wystawionych w wybranym tu okresie

    • Data zapłaty - płatności z datą zapłaty mieszczącą się w wybranym tu okresie

    • Selekcja - wybór wszystkich lub tylko podświetlonych pozycji

    • Uporządkowanie - sposób uporządkowania pozycji w oknie

      • Data operacji/Nr/Kolejność rat - jeśli chcemy sprawdzić rozrachunki wg chronologii operacji (wystawienia i zapłat)

      • Data wyst./Nr/Kolejność rat - jeśli chcemy sprawdzić rozrachunki wg daty wystawienia dokumentów

      • Data zapł./Nr/Kolejność rat - w kolejności regulowania należności, wszystkie płatności nieuregulowane mają pustą datę zapłaty i znajdą się na początku listy

      • Wybrana kolumna - jeżeli klikając w nagłówek jakiejś kolumny, ustaliliśmy uporządkowanie wg tej właśnie kolumny (np. Do zapłaty).

    Np. wyobraźmy sobie, że na wyciągu bankowym znajdujemy wpłatę od kontrahenta, którego trudno nam odnaleźć na liście kontrahentów, gdyż jego dane podane na przelewie są niekompletne. W takiej sytuacji, możemy ustawić kryteria filtrowania jak pokazano niżej, tak żeby zobaczyć listę wszystkich nieuregulowanych płatności za faktury wystawione w roku 2010 (lub w innym roku, którego może dotyczyć ta zapłata).

    Teraz będziemy mogli szybko wyszukać dowolną płatność [image] Ctrl F7 poprzez wpisanie numeru faktury (lub np. kwoty Do zapłaty). Pojawi się okienko Szukaj, w którym należy określić, jakie pola ma brać pod uwagę przy wyszukiwaniu (Szukaj po). Kursor automatycznie ustawi się na właściwej pozycji. Wyszukanie następnej pozycji zawierającej szukaną wartość umożliwiają klawisze Ctrl L.
    Możemy również kliknąć w nagłówek kolumny Do zapłaty i uporządkować niezapłacone faktury wg kwoty do zapłaty. W ten sposób najszybciej dopasujemy wpłatę do faktury nie znając numeru tej faktury.

Klawisz F2 udostępnia następujące [image] wydruki:

  • Wydruk listy - lista wszystkich pozycji znajdujących się w aktualnym oknie

  • Faktura - wydruk dokumentu, np. faktury, którego dotyczy ta płatność.


Automatyczne KP / KW do paragonów

KASA / BANK - Wpłaty i wypłaty (KP, KW, inne)

Jeśli prowadzimy kasę i wystawiamy dużo paragonów będziemy chcieli na koniec każdego dnia zaksięgować w kasie wpłatę utargu z paragonów. Służy do tego pozycja Automatyczne KP do paragonów dostępna po naciśnięciu klawisza Ins w oknie Pozycje raportu kasowego.

Po wybraniu tej pozycji pojawi się okno Automatyczne KP do paragonów zawierające wpłaty do wszystkich paragonów obejmowanych przez bieżący raport kasowy.

Po podświetleniu wszystkich (Ctrl A) lub wybranych paragonów i kliknięciu w przycisk Wybierz zostanie automatycznie utworzony dokument KP zawierający wpłaty z wszystkich podświetlonych paragonów.

W zależności od potrzeb możemy korzystać z Automatycznego KP do paragonów raz dziennie lub wielokrotnie, tworząc nowe KP z wpłatami za paragony wystawione od czasu utworzenia ostatniego automatycznego KP.

Wszystkie powyższe uwagi odnoszą się również do funkcji Automatyczne KW do paragonów, z tym że dotyczy ona paragonów korygujących, czyli zwrotów i związanych z nimi wypłat.


Raporty walutowe

KASA / BANK

Jeśli prowadzimy kasę walutową lub rachunki bankowe walutowe, będziemy korzystać z raportów kasowych i bankowych w walucie (dostępne tylko w wersji MAXI i PRO). Pozwalają one na prowadzenie równoległych rozliczeń w PLN i w walucie, co wiąże się z wyliczaniem i księgowaniem różnic kursowych. Różnice kursowe powstają wtedy, gdy kursy waluty z dnia wystawienia faktury i jej zapłaty różnią się. A będzie tak w zasadzie zawsze, bo nawet faktury gotówkowe płatne w dniu wystawienia generują różnice kursowe, ponieważ kurs księgowania takiej faktury to średni kurs NBP z dnia poprzedniego, zaś kurs zapłaty to kurs naszego banku z dnia płatności (czyli wystawienia). Poniżej przedstawiamy przykład księgowania zapłaty przez rachunek bankowy faktury walutowej wystawionej kilka dni wcześniej.

W rozrachunkach z kontrahentem mamy niezapłaconą fakturę wystawioną dla niego w dniu 07.09.2012. Średni kurs NBP z dnia poprzedniego wynosił 4,1580 (możemy go sprawdzić włączając kolumnę Kurs wystaw. - [image] Ctrl F4).

Raport bankowy jest zrobiony na dzień 10.09.2012, a kurs z naszego banku wynosił w tym dniu 4,1275. Robimy nowy wpis w raporcie i wybieramy z rozrachunków tego kontrahenta niezapłaconą fakturę. Otrzymamy następującą pozycję:

Kwoty do zapłaty i zapłacono w walucie są takie same (329,16 EUR), a zatem saldo walutowe tego kontrahenta będzie wynosić zero, natomiast w PLN powstanie różnica, która wyniesie 1358,61-1368,65=10,04 PLN. Będzie to ujemna różnica kursowa, ponieważ "straciliśmy" na tej transakcji (było do zapłaty w PLN więcej niż faktycznie nam zapłacono). Dodatnia różnica kursowa powstanie w przeciwnym przypadku.


Eksport raportów do programu księgowego

KASA/BANK

Program R2faktury umożliwia eksport danych do programów księgowych R2księga - księga przychodów i rozchodów, ryczałt oraz R2fk - pełna księgowość (patrz EKSPORT DANYCH). Jednym z elementów tego eksportu jest opisany poniżej eksport raportów kasowych i bankowych.

Wprowadzone raporty kasowe i bankowe możemy po ich zamknięciu wyeksportować do programu R2księga (księga przychodów i rozchodów lub ryczałtowa ewidencja przychodów), systemu R2fk (pełna księgowość) lub innego programu księgowego.
Programy R2księga i R2fk potrafią zaimportować raporty wyeksportowane z programu [image] i automatycznie powiązać je z odpowiednimi dokumentami zakupu i sprzedaży.

Przed eksportem raportów do programu księgowego należy w danych firmy określić parametry współpracy, tzn. rodzaj prowadzonej księgowości (pole Rozliczenia) i nazwę programu, do którego chcemy eksportować dane (pole Eksport do na zakładce Ustawienia - Ogólne).

Raporty eksportujemy z okna KASA/BANK przy pomocy funkcji [image] Eksport do programu..., dostępnej z menu podręcznego wywołanego klawiszem F3 lub prawym klawiszem myszy. W wywołanym w ten sposób okienku określamy:

  • Docelowa baza danych - baza, do której zostaną wyeksportowane raporty

  • Wyczyść bufor przed zapisaniem danych - po zaznaczeniu tej opcji bufor będzie zawsze zawierał tylko aktualnie eksportowane dokumenty. W przeciwnym wypadku dokumenty będą do bufora dodawane.

  • Zakres - co ma być wyeksportowane.

UWAGI:

  1. Sposób księgowania zapłat za paragony i faktury nieterminowe (zapłacone gotówką lub w inny sposób od razu w dniu wystawienia) zależy od parametru Eksport danych do programu księgowego określonego na zakładce Ogólne w konfiguracji programu (patrz INSTRUKCJA ADMINISTRATORA - PARAMETRYZACJA SYSTEMU - Konfiguracja).

  2. Przed eksportem raportów należy wyeksportować dokumenty sprzedaży i zakupu. W takiej samej kolejności należy wykonać import danych w programie księgowym, tzn. najpierw dokumenty zakupu/sprzedaży a potem raporty kasa/bank. Tylko postępując w ten sposób zapewnimy w programie księgowym prawidłowe powiązanie dokumentów sprzedaży/zakupu z płatnościami wpisanymi do raportów kasa/bank.

  3. Jeśli korzystamy z eksportu danych do programu R2fk lub R2księga lecz nie dokonaliśmy integracji modułów, wówczas zamiast pola Docelowa baza danych widoczne będzie pole Plik docelowy, w którym należy określić do jakiego pliku zostaną wyeksportowane dane. Taki sam plik należy wskazać w R2księdze lub w R2fk przy imporcie danych.


Import płatności

KASA / BANK

W programie [image] istnieje możliwość automatycznego importu płatności z systemu bankowego, co znacznie ułatwia i przyspiesza wprowadzanie raportów bankowych.

Jeśli chcemy korzystać z tej możliwości należy określić w definicji rachunku bankowego odpowiedni system bankowy, a co za tym idzie format pliku z importowanymi płatnościami. Określamy go w danych firmy [image] - zakładka Przelewy - przycisk Rachunki bankowe - zakładka Wydruk/Eksport/Import - pole Import płatności z (patrz ROZPOCZĘCIE PRACY - Wprowadzanie danych firmy - Rachunki bankowe firmy). Program współpracuje z większością dostępnych systemów bankowych. Jeśli danego systemu nie ma na liście, należy skontaktować się z dystrybutorem lub producentem programu.

Import płatności uruchamiany jest w oknie Pozycje raportu bankowego, w którym należy wywołać funkcję [image] i określić następujące parametry:

  • Plik źródłowy - lokalizacja i nazwa pliku z płatnościami w wybranym formacie (np. w formacie VideoTEL). Plik ten można również odnaleźć klikając [image]. Przycisk Podgląd umożliwia obejrzenie zawartości wybranego pliku.

  • Podświetl zaimportowane pozycje - umożliwia łatwe odnalezienie (i ewentualną weryfikację) zaimportowanych pozycji raportu

  • Nadawanie kont - tylko w przypadku gdy firma prowadzi pełną księgowość - parametr decyduje o tym, które konto rozrachunkowe kontrahenta ma zostać przypisane do importowanej płatności w przypadku, gdy dany kontrahent jest zarówno naszym odbiorcą jak i dostawcą. Mamy do wyboru cztery możliwości:

    • w zależności od rodzaju - w tym wypadku, dla przelewów stanowiących przychód na nasz rachunek, zostanie przypisane konto odbiorcy, w przeciwnym wypadku - konto dostawcy

    • zawsze konto odbiorcy

    • zawsze konto dostawcy

    • zadawaj pytanie - w tym wypadku program będzie zadawał pytanie za każdym razem, gdy napotka w pliku na płatność powiązaną z kontrahentem, który jest zarówno dostawcą jak i odbiorcą.

Identyfikacja, do którego kontrahenta przypisać daną płatność dokonywana jest wg pola Konto, które znajduje się na zakładce Przelewy w oknie Kontrahenci. Identyfikacja czasami może się nie udać, np. dlatego, że kontrahent w naszej bazie danych nie ma wpisanego konta bankowego, albo przysłał nam przelew z innego konta. W takich sytuacjach pomocny może okazać się specjalny, tymczasowy kontrahent, który zostanie przypisany do odczytanej płatności do czasu, aż nie ustalimy o którego kontrahenta chodzi. Dzięki temu będziemy mogli szybko odczytać wiele płatności, a dopiero później stopniowo zająć się kojarzeniem tych płatności, których program nie potrafił zidentyfikować automatycznie. Przed rozpoczęciem importu płatności należy więc określić tego specjalnego tymczasowego kontrahenta. Można to zrobić w oknie Ustawienia - Konfiguracja - Kasa/Bank wypełniając pole Kontrahent (import płatności). Należy pamiętać, że wybrany kontrahent musi posiadać konta odbiorcy i dostawcy.

Jeżeli nie wypełnimy pola Kontrahent (import płatności) i uruchomimy odczyt płatności, to ukaże się nam okno dialogowe Uzupełnij dane. W tym oknie musimy zdecydować, czy chcemy aby funkcję tymczasowego kontrahenta pełnił któryś z kontrahentów z kartoteki, czy też program ma utworzyć automatycznie kontrahenta o nazwie Nieznany (import płatności). Ponieważ kontrahent ten musi posiadać konta odbiorcy i dostawcy, to program tworząc kontrahenta nada mu również kolejne numery kont dostawcy i odbiorcy.

Po określeniu kontrahenta tymczasowego program może przystąpić do właściwego odczytu danych. Jeżeli kontrahent zostanie zidentyfikowany, to w raporcie bankowym zostanie zapisana odpowiednia pozycja zawierająca kwotę, datę i treść operacji (treść zostanie zapisana w pole Notatki). Jeżeli w pliku podany został numer operacji, to znajdzie się on w polu Numer.

Jeżeli jednak kontrahent nie zostanie przez program zidentyfikowany, to ukaże się dialog Wybierz kontrahenta. Jeżeli wiemy, którego kontrahenta dotyczy dana płatność, możemy go teraz wybrać z kartoteki, wpisując go w pole Kontrahent odpowiadający opisowi operacji. Jeżeli nie wiemy lub nie chcemy na razie określać kontrahentów, możemy pominąć tę pozycję i przejść do odczytu następnej (przyciskiem Pomiń), lub z menu rozwijanego uruchamianego przyciskiem obok wybrać opcję Pomiń we wszystkich kolejnych. "Pominięcie" pozycji spowoduje jej odczyt do raportu, ale kontrahentem tej operacji będzie specjalny kontrahent tymczasowy opisany wyżej. Do tych pozycji należy potem wrócić i zastąpić kontrahenta tymczasowego właściwym kontrahentem - pomocna tu będzie funkcja menu podręcznego (prawy klawisz myszy lub AltF3) Określ kontrahenta.

Opisaliśmy powyżej sposób importu płatności i powiązania z nimi odpowiednich kontrahentów. Jeśli płatności dotyczą faktur zaksięgowanych już w programie, kolejną czynnością jaką musimy wykonać jest powiązanie zaimportowanych płatności z istniejącymi już należnościami/zobowiązaniami kontrahenta. W tym celu należy przy każdej zaimportowanej pozycji przejść na zakładkę Pozycja i na zakładce Dokumenty kliknąć w kolumnie Opis (nr dokumentu) w przycisk [image]. W wywołanym w ten sposób oknie Rozrachunki należy wybrać odpowiednią należność lub zobowiązanie.

W ramach danego raportu bankowego możemy wielokrotnie odczytywać dane z pliku za konkretny okres. Np. jeżeli odczytaliśmy płatności z danego dnia już o godzinie 12.00, a potem pod koniec dnia chcemy "doczytać" pozostałe płatności, to możemy to zrobić podając plik zawierający wszystkie płatności z tego dnia. Program odczyta wtedy tylko te płatności, których nie odczytał wcześniej.


NALEŻNOŚCI I ZOBOWIĄZANIA

INSTRUKCJA UŻYTKOWNIKA

Moduł NALEŻNOŚCI I ZOBOWIĄZANIA zawiera rozbudowane mechanizmy do rozliczania należności i zobowiązań. Korzystanie z niego w przypadku należności minimalizuje ryzyko obrotów z nierzetelnymi kontrahentami i zwiększa ściągalność przeterminowanych należności. W przypadku zobowiązań pozwala na łatwe sprawdzenie prawidłowości rozliczeń.

Najważniejsze funkcje i możliwości modułu NALEŻNOŚCI I ZOBOWIĄZANIA to:

  • szybki dostęp do szczegółowej ewidencji rozrachunków z kontrahentem

  • rozrachunki wielowalutowe (dostępne tylko w wersji MAXI i PRO)

  • windykacja należności

    • indywidualne lub globalne wystawianie przypomnień i wezwań do zapłaty wraz z ich seryjnym wydrukiem

    • indywidualne lub globalne wystawianie not odsetkowych wraz z ich seryjnym wydrukiem

    • protokoły nieściągalności należności

  • możliwość nałożenia restrykcji na kontrahentów zalegających z płatnościami

  • informacja o zaleganiu w płatnościach w momencie wyboru kontrahenta na fakturę

  • lista dłużników

  • kalkulator odsetkowy.

Bardzo przydatnym narzędziem do kontrolowania stanu należności i zobowiązań jest Zestawienie należności i zobowiązań dostępne w menu Raporty Należności i zobowiązania. Umożliwia ono wydruk należności i zobowiązań wg stanu na zadany dzień z podziałem na pogrupowane dni po terminie lub na terminy płatności.

Jeśli chcemy korzystać z modułu NALEŻNOŚCI I ZOBOWIĄZANIA, należy go wstępnie skonfigurować.

Po skonfigurowaniu możemy korzystać z odpowiadających naszym potrzebom elementów modułu, czyli z:

  • rozrachunków z kontrahentem - szczegółowa ewidencja płatności, czyli tego co nabywca powinien nam zapłacić i tego co zapłacił oraz tego co my powinniśmy zapłacić dostawcy i co faktycznie zapłaciliśmy.
    Jest to najlepszy sposób na szybkie sprawdzenie rozrachunków z kontrahentem. Zestawienie rozrachunków można wydrukować i np. przesłać kontrahentowi w celu ustalenia rozbieżności.

  • windykacji przeterminowanych należności - seryjny wydruk przypomnień, wezwań do zapłaty, kwalifikowanie długów jako nieściągalne, noty odsetkowe.
    Dzięki windykacji na pewno nie przegapimy żadnych przeterminowanych należności i łatwo zweryfikujemy rzetelność kontrahenta na podstawie historii zaległości.

  • restrykcji w obrotach z nierzetelnymi kontrahentami - informacja o aktualnych zaległościach w momencie wystawiania kolejnych faktur, blokady w obrotach.
    Dzięki restrykcjom nierzetelny kontrahent nie będzie już mógł powiększać swojego zadłużenia.


Rozrachunki z kontrahentem

NALEŻNOŚCI I ZOBOWIĄZANIA

Rozrachunki z kontrahentami są jednym z elementów mechanizmu rozliczania należności i zobowiązań.

Okno Rozrachunki zawiera szczegółową ewidencję płatności do wszystkich faktur wystawionych kontrahentowi wraz z zapłatami za te faktury (sprzedaż) oraz wszystkich PZ od tego kontrahenta wraz z zapłatami za nie (zakup). Można je wywołać bezpośrednio z biblioteki kontrahentów po ustawieniu się na odpowiednim kontrahencie, można je również wykorzystać do automatycznego wprowadzania płatności na raport kasowy lub bankowy.

Informacje w poszczególnych kolumnach oznaczają:

  • Nr dokumentu - nr faktury/PZ, której dotyczy ta płatność

  • Data oper. - data operacji. W przypadku dokumentów jest to data wystawienia faktury/PZ, a w przypadku wpłat/wypłat do/z kasy banku niepowiązanych jeszcze z żadnym dokumentem jest to data wpłaty/wypłaty.

  • Rodzaj - rodzaj płatności

    • Wn (+) - kontrahent ma nam zapłacić

    • Ma (-) - my mamy zapłacić kontrahentowi

  • Do zapłaty - kwota do zapłaty

  • Termin - termin płatności

  • Forma - forma płatności

  • Zapłacono - zapłacona kwota

  • Data zapłaty - data uregulowania zapłaty

  • K - znak X jeśli zapłata została regulowana za pośrednictwem raportu kasowego / bankowego

  • KP - nr dokumentu KP lub KW

  • kolumny dotyczące windykacji należności:

    • P - litera P w tej kolumnie oznacza, że do tej płatności wystawiono już przypomnienie o zapłacie

    • W - litera W w tej kolumnie oznacza, że do tej płatności wystawiono już wezwanie do zapłaty

    • O - litera O w tej kolumnie oznacza, że do tej płatności wystawiono już notę odsetkową

    • N - litera N w tej kolumnie oznacza, że tę płatność uznano za nieściągalną.

Jeśli korzystamy z wersji programu umożliwiającej rozliczanie transakcji zagranicznych (dostępne tylko w wersji MAXI i PRO), to w standardowym zestawie kolumn w rozrachunkach dostępne będą dodatkowo:

  • Do zapł. wal. - kwota do zapłaty w walucie

  • Zapł.wal. - kwota zapłacona w walucie

  • Różn. kurs. - różnica kursowa powstała w momencie zapłaty

  • Waluta - waluta w jakiej została zaksięgowana ta płatność.

Wpisy widniejące w oknie Rozrachunki należy rozumieć jako wpisy z zakładki Płatności z okna FAKTURY z wszystkich faktur wystawionych temu kontrahentowi połączone z analogicznymi wpisami z płatności z wszystkich PZ. Np. poszczególne wpisy w okienku powyżej oznaczają (w kolejności wierszy od góry):

  1. zapłacona gotówką 13-08-2012 faktura nr 3/12 - faktura gotówkowa (termin zapłaty taki jak data wystawienia), nie wpisana jeszcze do raportu kasowego (brak znaku X w kolumnie K) - taka płatność pojawi się w trakcie tworzenia KP w RK z 13-08-2012 jako Automatyczne KP

  2. zapłacona kartą płatniczą w dniu 15-08-2012 faktura nr 4/12 (termin zapłaty taki jak data wystawienia), nie wpisana jeszcze do raportu kasowego (brak znaku X w kolumnie K)

  3. wpisana do raportu banowego (X w polu K) otrzymana przez nas przelewem w tym samym dniu pierwsza rata w wysokości 130 zł do faktury nr 9/12

  4. zapłacona gotówką w dniu 10-09-2012 (KP nr 6/12/KP) druga rata w wysokości 250 zł do faktury nr 9/12 z dnia 06-09-2012

  5. niezapłacona jeszcze trzecia rata w wysokości 300,39 zł do faktury nr 9/12 z dnia 06-09-2012 - ta zapłata powinna być dokonana przelewem

  6. wpisana do raportu bankowego (X w polu K) otrzymana przez nas przelewem w dniu 10-09-2012 zaliczka na poczet przyszłych usług w wysokości 250,00 zł, niepowiązana jeszcze z żadną fakturą (puste kolumny Do zapłaty i Termin) - gdy będziemy wystawiać fakturę na tę zaliczkę, będziemy mogli powiązać z nią tę płatność

  7. nieuregulowana płatność do faktury korygującej nr 1/12/FK wystawionej przez nas dnia 10-09-2012 na kwotę 26,54 zł - ta płatność powinna być wykonana przelewem ale, uwaga, to my musimy zapłacić kontrahentowi (w kolumnie Rodzaj jest wpisane Ma(-)).

W podsumowaniu na dole okienka widzimy:

  • Do zapłaty - łączną kwotę należności (to co kontrahent powinien nam zapłacić minus to co my jemu)

  • Zapłacono - łączną kwotę zapłat (to co kontrahent nam zapłacił minus to co my zapłaciliśmy jemu)

  • Pozostaje - kwotę pozostającą do zapłaty (saldo), jeśli ze znakiem +, tzn. że kontrahent nam ma tyle jeszcze zapłacić, jeśli ze znakiem -, tzn. że to my mamy zapłacić kontrahentowi. Kwota ujemna może także być związana z innymi powodami, np. jeśli otrzymaliśmy od kontrahenta zaliczkę, ale nie wystawiliśmy jeszcze faktury, która będzie powiązana z tą zaliczką.

W oknie Rozrachunki możemy również bezpośrednio wprowadzać pozycje, które nie wynikają z płatności do faktur lub PZ ani z wpisów do raportu kasowego bankowego. Mogą to być np. niezapłacone raty do faktur/PZ wystawionych przed rozpoczęciem użytkowania programu [image] (tzw. bilans otwarcia) lub dowolne inne obciążenia, które nie są automatycznie generowane przez program np. nota odsetkowa.
Czasem zdarza się również, że kontrahent jest jednocześnie naszym odbiorcą i dostawcą. W takiej sytuacji często będziemy kompensowali nasze wzajemne należności bezgotówkowo. Aby w takim przypadku saldo naszych obrotów, czyli kwota Pozostaje, było prawidłowe możemy ręcznie wpisać do rozrachunków obciążenie fakturą od tego, w tym przypadku, dostawcy. Oczywiście fakturą, która nie dotyczy zakupów handlowych, bo takie faktury są już ujęte w rozrachunkach jako PZ.

Aby wprowadzić np. obciążenie kontrahenta niezapłaconą jeszcze fakturą z poprzedniego roku (2011) naciskamy klawisz Ins [image] i wypełniamy odpowiednie pola:

Ręcznie dodane pozycje możemy poprawiać F6 [image] oraz usuwać Del [image].

Korzystając z funkcji dostępnych w menu wywoływanym prawym klawiszem myszy możemy m.in. kompensować ze sobą płatności dotyczące faktury i korekty do tej faktury lub faktury zakupu i faktury sprzedaży, itp.:

  • Skojarz - łączy dokument z zapłatą wpisaną do kasy/banku (oba wpisy muszą mieć tę samą wartość Wn+ lub Ma- w polu Rodzaj) lub kompensuje ze sobą dwa niezapłacone dokumenty, np. fakturę z fakturą korygującą (oba muszą mieć różne wartości w polu Rodzaj)

  • Rozłącz – rozłącza skojarzone wcześniej pozycje

  • Scal – scala w jedną pozycję płatności do tego samego dokumentu rozbite wcześniej na kilka pozycji.

Skojarz i Rozłącz działają na podświetlonych pozycjach. Można jednorazowo podświetlić wiele pozycji do skojarzenia lub rozłączenia. Scal ignoruje podświetlenia.

Wywołując [image] F4 Właściwości okna Rozrachunki, możemy dowolnie zmienić kryteria filtrowania, czyli zakres pozycji pokazywanych w oknie:

  • Typ

    • Sprzedaż - należności za dokumenty sprzedaży

    • Zakup - zobowiązania wynikające z dokumentów zakupu

    • Inne - wpłaty/wypłaty z raportów bankowych i kasowych, niepowiązane z dokumentami

  • Zakres

    • Zapłacone - takie, które w kolumnie Zapłacono mają określoną kwotę

    • Niezapłacone - takie, które w kolumnie Zapłacono mają kwotę 0 (zero) lub kwotę nieokreśloną

    • Przeterminowane - takie, którym minął już termin płatności, a nie są jeszcze zapłacone

    • Nierozliczone - dokumenty bez zapłat lub zapłaty bez powiązanych dokumentów

    • Wszystkie - naciskając klawisz Del lub Backspace usuwamy dotychczasowe kryterium określone w tym polu co oznacza, że będą wyświetlane wszystkie płatności, bez względu na to czy są zapłacone, niezapłacone, czy przeterminowane

  • Wn(+)/Ma(-)

    • Wn(+) - wpłaty

    • Ma(-) - wypłaty

    • Wszystkie

  • Waluta - waluta rozrachunków. Dostępna tylko w wersji MAXI i PRO.

  • Typ dokum. - Z rozrachunkami, bez rozrachunków (w zależności od ustawienia w definicji dokumentów) lub wszystkie

  • Nr dokum. - pokazane zostaną tylko rozrachunki pochodzące z dokumentu o podanym tu numerze

  • Tylko własne - dotyczy dokumentów wystawionych ze współdzielonych definicji, w oknie będą dostępne tylko płatności dotyczące dokumentów, które wystawił aktualny użytkownik programu. W zależności od uprawnień nadanych użytkownikowi (pole Tylko własne dokumenty w uprawnieniach grupy użytkowników) będzie on mógł zmienić wartość tego parametru i przeglądać również płatności do współdzielonych dokumentów wystawionych przez innych użytkowników.

  • Forma - tutaj możemy wpisać interesującą nas formę płatności lub zostawić wolne miejsce (Del lub Backspace), co będzie oznaczało dowolną formę płatności.

  • Płatności niepowiązane z dokumentami - np. wpłacone nadpłaty lub zaliczki niepowiązane jeszcze z żadnymi fakturami/PZ - puste kolumny Data wyst., Do zapłaty i Termin

  • Data operacji - pozycje z datą wystawienia lub datą zapłaty mieszczącą się w wybranym tu okresie

  • Termin płatności - płatności z terminami mieszczącymi się w wybranym tu okresie

  • Data wystawienia - płatności dotyczące faktur/PZ wystawionych w wybranym tu okresie

  • Data zapłaty - płatności z datą zapłaty mieszczącą się w wybranym tu okresie

  • Selekcja - wybór wszystkich lub tylko podświetlonych pozycji

  • Uporządkowanie - sposób uporządkowania pozycji w oknie

    • Data operacji/Nr/Kolejność rat - jeśli chcemy sprawdzić rozrachunki wg chronologii operacji (wystawienia i zapłat)

    • Data wyst./Nr/Kolejność rat - jeśli chcemy sprawdzić rozrachunki wg daty wystawienia dokumentów

    • Data zapł./Nr/Kolejność rat - w kolejności regulowania należności, wszystkie płatności nieuregulowane mają pustą datę zapłaty i znajdą się na początku listy

    • Wybrana kolumna - jeżeli klikając w nagłówek jakiejś kolumny, ustaliliśmy uporządkowanie wg tej właśnie kolumny (np. Do zapłaty).

Klawisz F2 udostępnia następujące [image] wydruki:

  • KP/KW - jeśli ta płatność jest zaksięgowana w kasie możemy wydrukować dokument KP lub KW

  • Faktura/PZ - wydruk dokumentu, np. faktury, którego dotyczy ta płatność

  • Potwierdzenie sald - potwierdzenie salda obejmujące nieuregulowane płatności. Seryjne potwierdzenia sald dla wszystkich kontrahentów możemy drukować w oknie Kontrahenci.

  • Wydruk listy - lista pozycji znajdujących się aktualnie w oknie.


Windykacja należności

NALEŻNOŚCI I ZOBOWIĄZANIA

Windykacja jest jednym z elementów mechanizmu rozliczania należności. Polega na wystawieniu do przeterminowanej płatności przypomnienia o zapłacie, a po upływie zadanego terminu wezwania do zapłaty. Gdy kontrahent ureguluje należność możemy mu wystawić notę odsetkową. Jeśli natomiast nie chce płacić, to dzięki mechanizmowi restrykcji nie pozwolimy mu na zwiększenie zadłużenia i możemy np. rozpocząć procedurę dochodzenia należności na drodze sądowej (poza programem).

W zależności od tego jaką posiadamy wersję programu i jaki model pracy przyjmiemy możemy wybrać jedną z dwóch możliwości:

  1. windykować indywidualnie należności za poszczególne faktury - korzystamy w tym celu z odpowiednich możliwości udostępnionych w oknie z fakturami (patrz Sprzedaż - Windykacja).

  2. zastosować mechanizm seryjnego wystawiania przypomnień, wezwań i not odsetkowych wg zadanego schematu - możemy przyjąć np. że w wybrany dzień tygodnia wystawiamy przypomnienia o zapłacie do wszystkich faktur, którym termin płatności minął 2 tygodnie temu i wezwania do zapłaty do wszystkich faktur, którym wystawiono wcześniej przypomnienia i którym termin płatności minął 4 tygodnie temu.

Ten drugi model pracy jest o wiele bardziej efektywny, gdyż przy minimalnych nakładach czasu i pracy umożliwia regularne ponaglanie wszystkich nierzetelnych kontrahentów, co zapobiega powiększaniu przez nich długów oraz skutecznie wpływa na zwiększenie ściągalności naszych należności. I właśnie temu modelowi poświecony jest zamieszczony poniżej opis.

Wszystkie niezbędne operacje wykonujemy w oknie Windykacja. Można z niego korzystać globalnie dla wszystkich faktur (wywołanie z głównego okna programu) lub tylko dla faktur konkretnego kontrahenta (wywołanie z biblioteki kontrahentów) albo wreszcie tylko dla płatności związanych z wybraną fakturą (wywołanie z okna FAKTURY). Niżej zajmiemy się tą pierwszą możliwością.

ZAWARTOŚĆ OKNA
Kolumny widoczne w oknie zmieniają się w zależności od ustawienia we właściwościach okna F4 pola Zakres - Co. Informacje w poszczególnych kolumnach oznaczają:

  • P - litera "P" jeśli wystawiono przypomnienie do tej należności

  • W - litera "W" jeśli wystawiono wezwanie do tej należności

  • O - litera "O" jeśli należność została uregulowana po terminie i wystawiono notę odsetkową, która jeszcze nie została zapłacona
    lub litera "Z" jeśli nota była wystawiona i została już zapłacona
    albo litera "U" jeśli nota była wystawiona i została umorzona w całości lub częściowo

  • N - litera "N" jeśli tą płatność zakwalifikowano jako nieściągalną

  • Przypomnienie z dnia, Wezwanie z dnia, itd. - data wystawienia przypomnienia, wezwania, noty lub protokołu nieściągalności. Rodzaj daty uzależniony jest od ustawienia w filtrze Zakres - Co.

  • Zapłacona - data zapłaty noty odsetkowej, dostępna jeśli w filtrze wybrano Noty odsetkowe w polu Zakres - Co

  • Numer faktury - numer faktury lub innego dokumentu, z którego pochodzi należność

  • Data wyst. - data wystawienia faktury

  • Nabywca - nabywca

  • Termin - termin płatności

  • Do zapłaty - kwota do zapłaty

  • Data zapł. - data zapłaty, pojawia się tylko przy płatnościach zapłaconych

  • Dni zwł. - dni zwłoki w płatności. Szarym kolorem oznaczone są dni zwłoki od należności jeszcze nie zapłaconych, a czarnym, od należności już uregulowanych.

  • Odsetki - kwota do zapłaty.

Wpisy widniejące w oknie Windykacja należy rozumieć jako wyfiltrowane wg różnych kryteriów płatności do poszczególnych faktur. Dlatego jedna faktura może się tu pojawić kilka razy, tak jak np. faktura nr 9/12 w okienku powyżej figuruje dwa razy bo ma przeterminowane dwie płatności (raty). Może się również zdarzyć, że windykacja będzie obejmowała częściową płatność do faktury, bo tej płatności minie już termin, a pozostała płatność do tej samej faktury będzie jeszcze w terminie. Oprócz płatności do faktur wystawionych w programie okno Windykacja zawiera również należności wpisane ręcznie do rozrachunków kontrahenta, dotyczące np. jego wcześniejszych faktur, tzn. wystawionych przed rozpoczęciem pracy z programem R2faktury i do dzisiaj niezapłaconych.

Domyślnie należności uporządkowane są alfabetycznie wg skrótów nazw nabywców. Dzięki temu w trakcie drukowania przypomnień, wezwań i not na jednym dokumencie będą zbierane wszystkie należności dla danego nabywcy. Np. przy należnościach takich jak w okienku powyżej dla nabywcy o nazwie Odbiorca B zostanie wydrukowane jedno przypomnienie o płatnościach, zawierające należności z faktur 2/12, 6/12, 8/12 i 12/12.

Można windykować należności w walutach obcych. Jeśli kontrahent ma przeterminowane należności w wielu walutach, to będą one zbierane na jednym przypomnieniu lub wezwaniu. Po wyborze we właściwościach okna F4 konkretnej waluty, należności wraz z odsetkami są podsumowane na dole okna, kwoty podsumowania są kwotami w wybranej walucie. Jeśli wybierzemy wszystkie waluty (puste pole F4 Waluta), wówczas podsumowanie nie jest dostępne.

Jeśli korzystamy z wersji programu umożliwiającej obsługę transakcji zagranicznych, to przypomnienia, wezwania i noty będą automatycznie tłumaczone na język określony w danych kontrahenta na zakładce Wydruki.

KRYTERIA FILTROWANIA
Wywołując [image] F4 Właściwości okna, możemy dowolnie zmienić kryteria filtrowania:

  • Zakres

    • Co

      • Należności, Przypomnienia, Wezwania, Noty odsetkowe, Nieściągalne (protokoły nieściągalności)

    • Jakie

      • Zapłacone, Niezapłacone

      • Przeterminowane - termin płatności jest późniejszy niż pole Data - patrz niżej

      • Wszystkie - naciskając klawisz Del lub Backspace usuwamy dotychczasowe kryterium określone w tym polu co oznacza, że będzie wyświetlane wszystko to co zostało wybrane w polu Co, bez względu na to czy są to należności zapłacone, niezapłacone, czy przeterminowane.

  • Waluta - waluta należności, dostępna tylko w wersji MAXI i PRO. Po wybraniu odpowiedniej waluty pokazane zostaną tylko należności wystawione w tej walucie. Kwoty w kolumnach Do zapłaty, Odsetki oraz w podsumowaniu okna będą kwotami walutowymi. Naciskając klawisz Del lub Backspace usuwamy wybraną walutę co oznacza, że będą wyświetlane wszystkie należności bez względu na walutę. W takiej sytuacji podsumowanie kwoty do zapłaty oraz odsetek nie będzie dostępne. Na przypomnieniu i wezwaniu będzie drukowany rachunek bankowy zaznaczony jako domyślny dla danej waluty. W przypadku gdy na przypomnieniu lub wezwaniu będą występowały należności w różnych walutach, to dla każdej waluty będzie obliczona odrębna suma i wyszczególniony będzie odpowiedni dla danej waluty rachunek bankowy.

  • Kwota min. - kwota minimalna. Umożliwia wyłączenie z windykacji groszowych lub kilkuzłotowych "resztówek" wynikających z nieprawidłowych kwot wpłaconych przez kontrahentów. Jeśli np. kontrahent zapłacił 122,00 zł, podczas gdy powinien zapłacić 122,70 to raczej nie ma ekonomicznego uzasadnienia do przypominania mu o konieczności zapłaty 70 gr, bo drożej wyniesie nas koszt listu poleconego.

  • Nabywca - tylko faktury tego nabywcy. Można to pole szybko przełączać klikając podwójnie na konkretnej fakturze, co spowoduje pokazanie wszystkich faktur tego kontrahenta spełniających wybrane kryteria.

  • Nr faktury - tylko płatności związane z fakturą o takim numerze. To kryterium ustawia się automatycznie, jeśli wywołujemy okno Windykacja bezpośrednio z wybranej faktury.

  • Selekcja - jeśli wcześniej podświetliliśmy wybrane pozycje (np. naciskając na wybranych pozycjach klawisze Shift á lub Shift â), tu określamy czy na ekranie mają być widoczne Wszystkie czy tylko Podświetlone

  • Uporządkowanie - sposób uporządkowania pozycji w oknie

    • Nabywca/Data wyst./Nr - nabywca / data wystawienia / nr faktury. To uporządkowanie jest niezbędne do seryjnego wystawiania i drukowania przypomnień i innych dokumentów. Dzięki niemu należności od tego samego nabywcy będą zbierane na jedno przypomnienie, wezwanie lub notę odsetkową.

    • Data wyst./Nr - data wystawienia / nr faktury

    • Termin/Data wyst./Nr - termin płatności / data wystawienia / nr faktury

    • Data - data powstania należności (wystawienia faktury), przypomnienia, wezwania, noty lub protokołu, w zależności od tego co wybraliśmy wyżej w polu Zakres-Co.

    • Wybrana kolumna - jeżeli klikając w nagłówek jakiejś kolumny, ustaliliśmy uporządkowanie wg tej właśnie kolumny (np. Do zapłaty)

  • Data - data traktowana jako data bieżąca:

    • przy kwalifikowaniu należności jako przeterminowane

    • przy określaniu daty wystawienia nowego przypomnienia, wezwania, noty lub protokołu nieściągalności

    • przy określaniu w polach Termin płatności i Data zapłaty dat granicznych tygodnia bieżącego, poprzedniego itd.

  • Data wystawienia - tylko należności pochodzące z faktur wystawionych w wybranym tu okresie

  • Termin płatności - tylko należności z terminami płatności upływającymi w wybranym tu okresie. Jeśli chcemy podać konkretny termin płatności, to wybieramy inny termin i w polach Od i Do wpisujemy ten sam dzień.

  • Data zapłaty - tylko należności zapłacone w wybranym tu okresie. Jeśli chcemy podać konkretną datę zapłaty, to wybieramy inna data i w polach Od i Do wpisujemy ten sam dzień. Datę zapłaty możemy określić tylko, jeśli wcześniej w polu Zakres-Jakie wybraliśmy Zapłacone lub wszystkie.

PRZYPOMNIENIA
Aby np. wystawić przypomnienia do wszystkich należności z terminem płatności, który minął 2 tygodnie temu należy:

  1. we właściwościach okna ustawić Zakres na Należności-Przeterminowane, a Termin na 2 tygodnie temu

  2. kliknąć w ikonkę Wystaw przypomnienie

  3. w okienku Utwórz przypomnienie zaznaczyć odpowiednie opcje:

    • Zakres - czy tylko do aktualnej należności, czy do wszystkich widocznych w oknie

    • Do zapłaty powyżej - przypomnienia zostaną wystawione tylko dla kontrahentów, u których łączna kwota do zapłacenia z tytułu niezapłaconych i przeterminowanych należności będzie większa od podanej tu kwoty. Domyślnie podpowiada się kwota określona w restrykcjach w polu Uwzględniać należności powyżej.

    • Zapamiętaj wydrukowane w ewidencji - zapamiętaj datę wystawienia przypomnienia w ewidencji - przy należności w kolumnie P pojawi się litera "P"

    i kliknąć w przycisk OK.

  4. w oknie Przegląd wydruku pojawią się przypomnienia dla wszystkich faktur spełniających zadane kryteria.

    Można je tutaj przejrzeć i wydrukować pojedynczo [image] lub od razu wszystkie [image].

    Jeśli posiadamy wersję MAXI lub PRO oraz w danych kontrahenta na zakładce Wydruki w polu Język określono inny język niż polski (PL), to przypomnienie będzie automatycznie przetłumaczone na ten język zgodnie ze słownikiem określonym w bibliotece języków (menu Ustawienia - Języki).

WEZWANIA
Chcąc wystawić wezwania do wszystkich należności z terminem płatności, który minął 4 tygodnie temu i do których wcześniej wystawiono już przypomnienia należy:

  1. we właściwościach okna ustawić Zakres na Przypomnienia-Niezapłacone, a Termin na 4 tygodnie temu

  2. kliknąć w ikonkę Wystaw wezwanie do zapłaty [image].

Kolejne kroki tak jak przy wystawianiu przypomnienia.

NOTY ODSETKOWE
Chcąc wystawić noty odsetkowe do wszystkich należności zapłaconych w poprzednim tygodniu należy:

  1. we właściwościach okna ustawić Zakres na Zapłacone, a Data zapłaty na 1 tydzień temu

  2. kliknąć w ikonkę Wystaw notę odsetkową [image].

Kolejne kroki tak jak przy wystawianiu przypomnienia. Wystawione zostaną tylko takie noty, których łączna wartość odsetek będzie przynajmniej taka, jak określona w okienku Wystaw notę odsetkową w polu Odsetki powyżej kwoty. Domyślnie podpowiada się tam kwota taka jak w danych firmy na zakładce Ustawienia - Należności i zobowiązania w polu Minimalna wartość odsetek.

PROTOKOŁY NIEŚCIĄGALNOŚCI
Sporządzając protokół nieściągalności do konkretnej należności:

  1. odszukać żądaną należność

  2. kliknąć w ikonkę Utwórz protokół nieściągalności [image].

W obecnej wersji programu możliwe jest tylko zapamiętanie daty wystawienia protokołu. Nie ma możliwości wydrukowania go.

WYDRUKI
Klawisz F2 udostępnia następujące [image] wydruki:

  • Przypomnienie, Wezwanie do zapłaty, Nota odsetkowa - ponowny wydruk odpowiednich dokumentów w zależności od aktualnego ustawienia F4 Zakres-Co. Ponowny, gdyż pierwotny powinien się odbyć w trakcie wystawiania tych dokumentów - patrz wyżej.

  • Wydruk listy - lista pozycji znajdujących się aktualnie w oknie

  • Faktura Vat - wydruk dokumentu, np. faktury VAT, z którego pochodzi aktualna należność

  • Koperty, Naklejki adresowe - wydruk adresów na kopertach lub naklejkach adresowych do wszystkich przypomnień, wezwań lub not widocznych w oknie

DODATKOWE FUNKCJE
W każdej chwili możemy sprawdzić pełne rozrachunki [image] z kontrahentem, do którego należy bieżąca należność.
Pozostałe dodatkowe funkcje dostępne są w menu podręcznym (prawy klawisz myszy lub klawisze Alt F3):

  • Usuń - usuwa wystawione przypomnienia, wezwania, noty odsetkowe i protokoły nieściągalności z ewidencji

  • Zapłać notę odsetkową - dla wystawionych not odsetkowych możemy odnotować fakt zapłaty noty (Zapłata) przez kontrahenta lub umorzenia albo częściowej zapłaty (Częściowa zapłata / umorzenie) tej noty. Dzięki temu wystawiona i niezapłacona nota odsetkowa nie będzie powodowała restrykcji w obrotach z tym kontrahentem. W razie potrzeby informację o zapłacie/umorzeniu noty odsetkowej można usunąć (Usunięcie zapłaty).


Restrykcje w obrotach

NALEŻNOŚCI I ZOBOWIĄZANIA

Restrykcje w obrotach z nierzetelnymi kontrahentami są jednym z elementów mechanizmu rozliczania należności.

Nakładane restrykcje są dwustopniowe. W zależności od m.in. długości zaległości w płatnościach, kontrahent zostaje zakwalifikowany do jednej z dwóch grup:

  • Obsługa warunkowa

    • przy wystawianiu faktury temu kontrahentowi pojawi się komunikat z ostrzeżeniem o zaległościach

    • na liście kontrahentów będzie wyróżniony szarym kolorem

    • przeterminowana faktura, będąca przyczyną zastrzeżeń, będzie w oknie z fakturami wyróżniona szarym kolorem

  • Nie obsługiwać

    • wystawienie faktury dla tego kontrahenta jest niemożliwe, przy próbie wystawienia otrzymamy komunikat o błędzie z odpowiednim wyjaśnieniem

    • na liście kontrahentów będzie wyróżniony czarnym kolorem

    • przeterminowana faktura, będąca przyczyną zastrzeżeń, będzie w oknie z fakturami wyróżniona czarnym kolorem.

Konfigurację restrykcji umożliwia polecenie menu głównego Ustawienia - Restrykcje (patrz INSTRUKCJA ADMINISTRATORA - PARAMETRYZACJA SYSTEMU - Restrykcje).

UWAGA. Ze względu na szybkość działania programu, dane o przeterminowanych płatnościach na potrzeby mechanizmu restrykcji są aktualizowane automatycznie tylko przy każdym uruchomieniu programu oraz przy zatwierdzeniu okienka z konfiguracją restrykcji.
Aby odświeżyć te informacje można w dowolnym momencie w oknach Faktury lub Kontrahenci skorzystać z funkcji menu podręcznego (prawy klawisz myszy lub z klawiatury klawiszeAlt F3) Odśwież restrykcje.


Kalkulator odsetkowy

NALEŻNOŚCI I ZOBOWIĄZANIA

Kalkulator odsetkowy jest jednym z elementów modułu NALEŻNOŚCI I ZOBOWIĄZANIA. Służy do obliczenia kwoty odsetek ustawowych lub podatkowych od dowolnego zobowiązania.

Po uruchomieniu kalkulatora poleceniem menu głównego Okna - Kalkulator odsetkowy określamy:

  • Do zapłaty - kwota jaka powinna być zapłacona

  • Termin płatności - termin płatności, czyli do kiedy powinna być zapłacona wpisana wyżej kwota

  • Data zapłaty - data uregulowania należności

  • Odsetki - rodzaj odsetek: ustawowe lub podatkowe

  • Dni wolne przy obliczaniu odsetek - parametr ten umożliwia określenie, w jaki sposób naliczać odsetki i dni zwłoki w przypadku, gdy termin płatności przypada w dzień wolny lub sobotę. Do wyboru są 3 możliwości:

    • nie uwzględniaj dni wolnych - tak liczył program do wersji 6.08.11

    • uwzględniaj dni wolne, ale bez sobót - wartość domyślna, właściwa przy naliczaniu odsetek za zwłokę w płatnościach za faktury

    • uwzględniaj dni wolne wraz z sobotami - przy zwłoce w zobowiązaniach podatkowych.

    Przykłady:
    1. Gdy terminem płatności był dzień 13.08.2011 (sobota), a płatność została uregulowana dnia 16.08.2011, to przy wyborze nie uwzględniaj dni wolnych lub uwzględniaj dni wolne, ale bez sobót odsetki zostaną naliczone dla 3 dni zwłoki, natomiast przy wyborze uwzględniaj dni wolne wraz z sobotami płatność nie będzie przeterminowana (dni zwłoki i odsetki będą równe 0).
    2. Gdy terminem płatności był dzień 04.09.2011 (niedziela), a płatność została uregulowana dnia 05.09.2011, to przy wyborze nie uwzględniaj dni wolnych zostanie wyliczony 1 dzień zwłoki, natomiast przy wyborze uwzględniaj dni wolne, ale bez sobót lub uwzględniaj dni wolne wraz z sobotami płatność nie będzie przeterminowana (dni zwłoki i odsetki będą równe 0).

Po wpisaniu tych parametrów i ewentualnym kliknięciu w przycisk Oblicz kalkulator wyliczy:

  • Dni zwłoki - ile dni upłynęło pomiędzy datą zapłaty a terminem płatności

  • Odsetki - wysokość odsetek

  • Razem do zapłaty - łączną kwotę należności, czyli Do zapłaty plus Odsetki.

Odsetki obliczane są w oparciu o tabelę procentową określoną w oknie Odsetki.

Kalkulator odsetkowy jest narzędziem pomocniczym, służącym głównie do obliczania odsetek od należności lub zobowiązań nie związanych bezpośrednio z dokumentami wystawionymi w programie. Odsetki związane z płatnościami do dokumentów wystawionych w programie obliczane są automatycznie na tych dokumentach, bez konieczności używania kalkulatora.


PRZELEWY BANKOWE

INSTRUKCJA UŻYTKOWNIKA

Moduł PRZELEWY BANKOWE służy do sporządzania bankowych poleceń przelewu oraz dowodów wpłat. Wprowadzone do ewidencji przelewy można wydrukować lub wyeksportować do wybranego systemu bankowego (w formie pliku w formacie akceptowanym przez te systemy).

Jeśli chcemy korzystać z tego modułu, należy go włączyć tzn. zaznaczyć pole Przelewy bankowe w ustawieniach bieżącej firmy [image] na zakładce Ustawienia - Ogólne w grupie Moduły.

Program umożliwia sporządzanie wszystkich niezbędnych rodzajów poleceń przelewów, tzn.:

  • standardowych

  • do urzędów skarbowych

  • do ZUS.

Ewidencja przelewów dostępna jest po kliknięciu w głównym oknie programu w przycisk [image].


Ewidencja przelewów

PRZELEWY BANKOWE

W oknie z przelewami ręcznie możemy wprowadzić nowy przelew. W tym celu naciskamy Ins lub klikamy [image]. Wybieramy:

  • 1. Zwykły - przelewy standardowe

  • 2. Podatki - przelewy podatków do urzędów skarbowych

  • 3. ZUS - przelewy składek ZUS.

Każdy przelew możemy poprawić [image] wciskając klawisz F6 lub wykasować [image] Del.

Program pokazuje tylko te przelewy, których data zawiera się w wybranym (w menu głównym Ustawienia - Bieżąca data i okres) okresie (F12).

Możliwe jest szybkie wyszukanie [image] Ctrl F7 konkretnego przelewu poprzez wpisanie szukanej nazwy kontrahenta, nr rachunku itp. Pojawi się okienko Szukaj, w którym przy pierwszym poszukiwaniu musimy określić, jakie pola ma brać pod uwagę przy wyszukiwaniu (Szukaj po). Kursor automatycznie ustawi się na właściwej pozycji. Żeby wyszukać kolejną pozycję z danym fragmentem - należy wcisnąć Ctrl L.


Przelew standardowy

PRZELEWY BANKOWE - Ewidencja przelewów

Standardowy przelew służy do dokonania dowolnej płatności za wyjątkiem należności z tytułu składek ZUS oraz należności z tytułu podatków.

Naciskamy klawisz Ins (albo przycisk [image]) i z menu wybieramy pozycję 1. Zwykły.

Wprowadzamy następujące dane:

  • nazwa odbiorcy - nazwa i adres odbiorcy - można wpisać pełne dane lub wybrać odbiorcę z biblioteki kontrahentów (naciskając klawisze Ctrl Enter lub klikając w przycisk [image] znajdujący się po prawej stronie tego pola); jeśli odbiorca przelewu nie jest jednorazowy warto go wpisać do biblioteki kontrahentów, żeby ułatwić wystawianie kolejnych przelewów dla tego kontrahenta; program nie zapamiętuje w bibliotece danych kontrahenta wpisanych bezpośrednio na przelewie w tym polu; standardowo program podstawia w tym polu nazwę naszej firmy, co umożliwia wystawienie dowodu wpłaty na własny rachunek bankowy

  • l.k. - liczba kontrolna (czyli dwie pierwsze cyfry) numeru rachunku odbiorcy; przelew z nieprawidłową liczbą kontrolną będzie zaznaczony na liście przelewów na czerwono; prawidłową, tzn. wyliczoną przez program na podstawie dalszej części numeru rachunku, liczbę kontrolną można sprawdzić ustawiając się myszą na polu l.k. takiego przelewu

  • nr banku - nr banku odbiorcy; standardowo podstawia się nr banku domyślnego rachunku naszej firmy, jeśli mamy kilka rachunków można wybrać inny klikając w przycisk znajdujący się po prawej stronie tego pola lub naciskając klawisze Ctrl Enter; ustawiając się myszą na tym polu, można sprawdzić nazwę banku, który posiada taki numer

  • nr rachunku – właściwy nr rachunku odbiorcy w danym banku, czyli wszystko bez liczby kontrolnej i nr banku (czyli pomijamy pierwszych 10 cyfr)
    Np. jeśli rachunek odbiorcy to: 26 2030 2081 1254 8723 5698 1245 powinniśmy wprowadzić: l.k.: 26, nr banku: 20302081, nr rachunku: 1254 8723 5698 1245 lub 1254872356981245

  • W / P - klikamy odpowiedni przycisk, żeby wystawić W - dowód wpłaty, P - przelew; rodzaj formularza można również zmienić naciskając na dowolnym polu Alt W - wpłata lub Alt P - przelew

  • waluta - trzyliterowy skrót waluty, w której ma być wykonany przelew/wpłata (np. PLN, USD, DEM, EUR, GBP itp.); waluta ma znaczenie tylko przy wydrukach na czystych kartkach, przy nadrukach symbol waluty nie jest w ogóle drukowany

  • kwota - kwota, którą przelewamy lub wpłacamy

  • l.k. - liczba kontrolna numeru rachunku zleceniodawcy

  • nr rachunku zleceniodawcy - tylko na przelewach; pełny numer rachunku zleceniodawcy łącznie z numerem banku; standardowo podstawia się domyślny rachunek naszej firmy, jeśli mamy kilka rachunków można wybrać inny klikając w przycisk znajdujący się po prawej stronie tego pola lub naciskając klawisze Ctrl Enter; ustawiając się myszą na tym polu, można sprawdzić nazwę banku, w którym jest prowadzony ten rachunek

  • kwota słownie - tylko na dowodach wpłaty, wypełniane automatycznie przez program; sposób generowania kwoty słownie można ustawić w menu Ustawienia - Konfiguracja przelewów (patrz INSTRUKCJA ADMINISTRATORA - PARAMETRYZACJA SYSTEMU - Konfiguracja przelewów)

  • nazwa zleceniodawcy - nazwa i adres zleceniodawcy - domyślnie podstawia się nazwa i adres naszej firmy, ale można wpisać lub wybrać z biblioteki innego zleceniodawcę

  • tytułem - tytuł wpłaty, można wpisać lub wybrać z biblioteki treści (naciskając klawisze Ctrl Enter lub klikając w przycisk znajdujący się po prawej stronie tego pola)

  • data - data wystawienia przelewu; jest drukowana na ostatnim odcinku przelewu (dla banku zleceniodawcy).

Po wpisaniu wszystkich danych zatwierdzamy przelew naciskając klawisz PgDn lub klikając w przycisk [image]. Jeśli rozmyśliliśmy się i chcemy przerwać wypisywanie tego przelewu naciskamy z dowolnego pola klawisz Esc lub klikamy w przycisk [image].

Wprowadzony przelew można F2 [image] wydrukować lub [image] wyeksportować do systemu bankowego. Po wyeksportowaniu przelewu pojawi się pole Wyeksportowany. Jeśli jest ono zaznaczone oznacza to, że ten przelew został już wyeksportowany. Przelew wyeksportowany nie może być wyeksportowany ponownie, chyba że sami odznaczymy to pole.


Przelew do urzędu skarbowego

PRZELEWY BANKOWE - Ewidencja przelewów

Przelew do urzędów skarbowych służy do dokonania płatności z tytułu należności podatkowych na rachunki organów skarbowych.

Naciskamy klawisz Ins (albo przycisk [image]) i z menu wybieramy pozycję 2. Podatki.

Wprowadzamy następujące dane:

  • nazwa i adres organu podatkowego - można wpisać pełne dane lub wybrać pozycję z biblioteki urzędów skarbowych (naciskając klawisze Ctrl Enter lub klikając w przycisk [image] znajdujący się po prawej stronie tego pola); standardowo program podstawia w tym miejscu dane z ostatniego przelewu z podatkami

  • l.k. - liczba kontrolna numeru rachunku organu podatkowego

  • nr banku - nr banku organu podatkowego; standardowo podstawia się nr banku z ostatniego przelewu z podatkami

  • nr rachunku - nr rachunku organu podatkowego, czyli część pełnego nr rachunku organu podatkowego pozostała po odjęciu nr banku

  • Rodzaj rachunku – w zależności od wybranego rodzaju rachunku (CIT, PIT, VAT, INNE) podstawia się odpowiedni numer rachunku bankowego; rodzaj rachunku powinien być zgodny z symbolem formularza wybranym w polu Symbol formularza lub płatności

  • W / P - klikamy odpowiedni przycisk, żeby wystawić W - dowód wpłaty, P - przelew; rodzaj formularza można również zmienić naciskając na dowolnym polu Alt W - wpłata lub Alt P - przelew

  • waluta - trzyliterowy skrót waluty, zawsze PLN

  • kwota - kwota, którą przelewamy lub wpłacamy

  • l.k. - liczba kontrolna numeru rachunku bankowego zobowiązanego

  • nr rachunku bankowego zobowiązanego - tylko na przelewach; pełny numer rachunku zobowiązanego łącznie z numerem banku; standardowo podstawia się domyślny rachunek naszej firmy, jeśli mamy kilka rachunków można wybrać inny klikając w przycisk znajdujący się po prawej stronie tego pola lub naciskając klawisze Ctrl Enter

  • kwota słownie - tylko na dowodach wpłaty, wypełniane automatycznie przez program; sposób generowania kwoty słownie można ustawić w konfiguracji przelewów (patrz INSTRUKCJA ADMINISTRATORA - PARAMETRYZACJA SYSTEMU - Konfiguracja przelewów)

  • nazwa i adres zobowiązanego - domyślnie podstawia się nazwa i adres wybranej firmy, ale można wpisać lub wybrać z biblioteki innego zobowiązanego (kontrahenta),

  • NIP lub identyfikator uzupełniający zobowiązanego - NIP zobowiązanego bez znaków rozdzielających (bez kresek); jeżeli zobowiązany nie posiada Numeru Identyfikacji Podatkowej należy wpisać identyfikator uzupełniający:

    • numer REGON, gdy zobowiązany jest osobą prawną lub jednostką organizacyjną nie mającą osobowości prawnej ale posiadającą numer REGON
    • numer PESEL, gdy zobowiązany jest osobą fizyczną posiadającą numer PESEL

  • Typ.ident. - typ wpisanego w poprzednim polu identyfikatora, wybieramy odpowiednio:

    • N - NIP

    • R - REGON

    • P - PESEL

    • 1 - seria i numer dowodu osobistego

    • 2 - seria i numer paszportu

    • 3 - inny dokument potwierdzający tożsamość

  • Rok - rok, którego dotyczy wpłata

  • Typ okresu - jakiego okresu dotyczy wpłata:

    • R - rok, np. kwota do zapłaty wynikająca z PIT-37 stanowiąca różnicę pomiędzy podatkiem należnym a sumą zaliczek (01R)

    • P - półrocze

    • K - kwartał, np. wpłata zryczałtowanego podatku dochodowego od przychodów osób duchownych za 3 kwartał 2001 roku (01K03)

    • M - miesiąc, np. wpłata podatku wynikająca z decyzji ustalającej wysokość zryczałtowanego podatku dochodowego w formie karty podatkowej za maj 2001 roku (01M05)

    • D - dekada, np. podatek za 2 dekadę 7 miesiąca 2001 roku w podatku od gier (01D0207)

    • J - dzień, np. 6 lutego 2004 (04J0602).

  • Nr okresu - nr kwartału, miesiąca lub dekady (jak w przykładach powyżej)

  • Symbol formularza lub płatności - należy wpisać odpowiedni symbol w zależności od tytułu płatności; symbol należy wpisać lub wybrać z biblioteki (Ctrl Enter lub przycisk [image]).
    Wyjaśnienie:

    • jeżeli wysokość regulowanej należności wynika z określonego formularza (zeznania, deklaracji, informacji) złożonego przez podatnika płatnika lub inkasenta należy wpisać symbol formularza np. PIT37, VAT7, CIT2, AKC2A
    • jeżeli wpłata należności wynika z decyzji (postanowienia lub innego aktu) organu podatkowego należy wpisać symbol płatności np. PIT, CIT, VAT, AKC, GL, KP, PPE, PN, SD, PCC, OS, INNE

  • Identyfikacja zobowiązania (rodzaj dokumentu) - pole wypełnia się jeżeli:

    • wpłata należności wynika z decyzji, postanowienia, tytułu wykonawczego lub innego aktu organu podatkowego, wówczas należy wpisać w skrócie rodzaj aktu administracyjnego i rodzaj należności np. DEC.RYCZAŁT jeśli wpłata wynika z decyzji ustalającej wysokość zryczałtowanego podatku dochodowego w formie karty podatkowej lub TYT.WYK.POD.DOCH. jeśli wpłata wynika z tytułu wykonawczego wystawionego na podstawie deklaracji PIT-5 (w polu Symbol formularza lub płatności wpisać PIT5)
    • wysokość wpłaty nie wynika z decyzji, postanowienia, tytułu wykonawczego lub innego aktu bądź też określonego formularza (zeznania, deklaracji, informacji) należy wówczas wpisać w skrócie rodzaj należności np.: POD.OD POS.PSÓW jeśli wpłata dotyczy podatku od posiadania psów

  • data - data wystawienia przelewu; jest drukowana na ostatnim odcinku przelewu (dla banku zleceniodawcy).

Po wpisaniu wszystkich danych zatwierdzamy przelew naciskając klawisz PgDn lub klikając w przycisk [image]. Jeśli rozmyśliliśmy się i chcemy przerwać wypisywanie tego przelewu naciskamy z dowolnego pola klawisz Esc lub klikamy w przycisk [image].

Wprowadzony przelew można F2 [image] wydrukować lub [image] wyeksportować do systemu bankowego. Po wyeksportowaniu przelewu pojawi się pole Wyeksportowany. Jeśli jest ono zaznaczone oznacza to, że ten przelew został już wyeksportowany. Przelew wyeksportowany nie może być wyeksportowany ponownie, chyba że sami odznaczymy to pole.


Przelew do ZUS

PRZELEWY BANKOWE - Ewidencja przelewów

Przelew do ZUS służy do dokonania płatności z należnościami z tytułu składek na ubezpieczenia ZUS.

Naciskamy klawisz Ins (albo przycisk [image]) i z menu wybieramy pozycję 3. ZUS.

Wprowadzamy następujące dane:

  • Rodzaj składki - wybieramy rodzaj ubezpieczenia, którego dotyczy przelew

  • Nr rachunku ZUS - określany automatycznie na podstawie wybranego wyżej rodzaju ubezpieczenia

  • W / P - klikamy odpowiedni przycisk, żeby wystawić W - dowód wpłaty, P - przelew; rodzaj formularza można również zmienić naciskając na dowolnym polu Alt W - wpłata lub Alt P - przelew,

  • Kwota - kwota, którą przelewamy lub wpłacamy

  • l.k. - liczba kontrolna numeru rachunku zleceniodawcy

  • nr rachunku zleceniodawcy - tylko na przelewach; pełny numer rachunku zleceniodawcy łącznie z numerem banku; standardowo podstawia się domyślny rachunek naszej firmy, jeśli mamy kilka rachunków można wybrać inny klikając w przycisk znajdujący się po prawej stronie tego pola lub naciskając klawisze Ctrl Enter

  • kwota słownie - tylko na dowodach wpłaty, wypełniane automatycznie przez program

  • Nazwa skrócona płatnika lub nazwisko i imię płatnika – domyślnie podstawia się skrócona nazwa firmy wpisana w oknie z firmami, ale można wpisać lub wybrać z biblioteki innego płatnika (kontrahenta)

  • NIP płatnika - domyślnie podstawia się NIP wpisany w danych firmy, można wpisać inny NIP; po wyborze płatnika z listy kontrahentów podstawi się jego NIP

  • Typ. 2 ident. - typ drugiego identyfikatora:

    • R - regon

    • P - pesel

    • 1 - dowód osobisty

    • 2 - paszport

  • Drugi identyfikator płatnika - regon, pesel, numer dowodu osobistego lub paszportu w zależności od określonego wcześniej typu identyfikatora

  • Typ wpł. - typ wpłaty

    • S - składka za 1 miesiąc

    • M - składka dłuższa niż 1-miesiąc

    • U - układ ratalny

    • T - odroczenie terminu

    • D - opłata dodatkowa

    • E - egzekucja

    • A - dodatkowa opłata za błędy płatnika

  • Nr dekl. - numer deklaracji

  • Deklaracja - jakiego miesiąca dotyczy deklaracja

  • Nr decyzji/umowy/tytułu wykonawczego - należy wpisać odpowiednio:

    • numer decyzji o nałożeniu dodatkowej opłaty - jeżeli w polu Typ wpł. wpisano A lub D

    • numer tytułu wykonawczego - jeżeli w polu Typ wpł. wpisano E

    • numer decyzji/umowy o odroczeniu terminu płatności składek - jeżeli w polu Typ wpł. wpisano T

    • numer decyzji/umowy, na podstawie której płatnik składek uzyskał układ ratalny - jeżeli w polu Typ wpł. wpisano U

  • data - data wystawienia przelewu; nie jest drukowana.

Po wpisaniu wszystkich danych zatwierdzamy przelew naciskając klawisz PgDn lub klikając w przycisk [image]. Jeśli rozmyśliliśmy się i chcemy przerwać wypisywanie tego przelewu naciskamy z dowolnego pola klawisz Esc lub klikamy w przycisk [image].

Wprowadzony przelew można F2 [image] wydrukować lub [image] wyeksportować do systemu bankowego. Po wyeksportowaniu przelewu pojawi się pole Wyeksportowany. Jeśli jest ono zaznaczone oznacza to, że ten przelew został już wyeksportowany. Przelew wyeksportowany nie może być wyeksportowany ponownie, chyba że sami odznaczymy to pole.


Wydruki

PRZELEWY BANKOWE

Wprowadzone w ewidencji przelewy możemy wydrukować na czystych kartkach lub na gotowych formularzach przelewów.

Przed pierwszymi wydrukami musimy zapoznać się z parametrami wydruku poleceń przelewów (patrz INSTRUKCJA ADMINISTRATORA - PARAMETRYZACJA SYSTEMU - Konfiguracja przelewów).

Żeby wydrukować indywidualny przelew, ustawiamy się na konkretnej pozycji, wciskamy klawisz F2 lub klikamy w [image] i wybieramy pozycję Polecenie przelewu lub Wpłata gotówkowa.

Ukaże się okienko Polecenie przelewu lub Wpłata gotówkowa, w którym możemy określić:

  • Zakres drukowanych pozycji:

    • Aktualna - zostanie wydrukowane polecenie przelewu/dowód wpłaty taki jak aktualnie wybrany w okienku

    • Podświetlone - zostaną wydrukowane przelewy/wpłaty ze wszystkich podświetlonych pozycji

    • Wszystkie - zostaną wydrukowane przelewy/wpłaty ze wszystkich pozycji wprowadzonych w wybranym okresie

  • Definicję - czyli które elementy przelewu mają być drukowane:

    • z datą - wyłączamy jeśli np. nie jesteśmy pewni kiedy wykonamy przelew, bo nie ma chwilowo środków na koncie, a już teraz chcemy wydrukować przelewy

    • z kwotą - wyłączamy jeśli np. nie wiemy dokładnie ile środków jest na koncie - po uzyskaniu dokładnej informacji w banku wpisujemy na miejscu kwotę ręcznie

    • z nr rachunku zleceniodawcy - wyłączamy jeśli np. mamy kilka rachunków bankowych a przed wizytą w banku nie wiemy dokładnie ile środków jest na poszczególnych rachunkach.

Oprócz przelewu lub dowodu wpłaty możemy również wydrukować:

  • Zbiorcze polecenie przelewu - zbiorcze polecenie przelewu do kilku przelewów z tego samego dnia i rachunku zleceniodawcy. Przed wywołaniem funkcji drukowania [image] należy ustawić się na jednym z tych przelewów (z danego dnia i rachunku). Przed wydrukiem możemy jeszcze określić pole z datą, jeśli wyłączymy to pole, wydruk będzie zawierał wszystkie informacje oprócz daty, którą dzięki temu można wpisać ręcznie.

  • Wydruk listy - lista wszystkich dokumentów zawierających się w aktualnym oknie

  • Wydruk pozycji - wydruk szczegółowych informacji na temat konkretnej pozycji znajdującej się w oknie Przelewy.


Eksport do systemów bankowych

PRZELEWY BANKOWE

Wprowadzone w ewidencji przelewy możemy, zamiast drukować, wyeksportować bezpośrednio do systemu bankowego pracującego w banku, w którym firma posiada rachunek. System bankowy określiliśmy dla każdego rachunku firmy oddzielnie przy wprowadzaniu danych firmy.

Wynikiem eksportu danej paczki przelewów powinien być plik z zawartością przelewów oraz wydrukowana lista kontrolna, informująca w skondensowanej formie o zawartości przelewów w wysyłanym pliku. Taki plik można przesłać bezpośrednio do banku lub wczytać do programu bankowego, jeśli korzystamy z usługi "home banking" i nasz bank przyjmuje pliki w odpowiednim formacie.

Eksport przelewów z całej paczki przygotowujemy klikając w przycisk [image] i wybierając:

  • właściwy system bankowy, określony w oknie Rachunki bankowe firmy - przygotowujemy plik z zawartością paczki przelewów, lokalizację i pełną nazwę tworzonego pliku podajemy w pozycji Plik docelowy. Przy eksporcie do niektórych systemów bankowych musimy ponadto określić różne dodatkowe parametry, w tym m.in.:

    • wspólny plik dla wszystkich numerów banków - jeśli w eksportowanych przelewach znajdują się przelewy z różnym numerem banku zleceniodawcy, to w zależności od ustawienia tego pola będą one wyeksportowane do wspólnego pliku bądź podzielone na tyle plików ile numerów banków zleceniodawcy (w tym przypadku pliki będą się nazywały tak jak numery oddziałów, a utworzone zostaną w tym katalogu, jaki został określony w Pliku docelowym)

    • Bank Śląski - zaznaczamy, jeśli mamy rachunek w tym banku (Bank Śląski stosuje nieco zmodyfikowany standard Eliksir)

    • Nr rachunku z powtórzonym numerem banku - należy zaznaczyć, jeśli bank wymaga w miejscu numeru rachunku odbiorcy cały numer rachunku łącznie z numerem banku; bez względu na ustawienie tego pola, nowe rachunki (w formacie IBAN) eksportowane są w całości

    • Nr rachunku zleceniodawcy z powtórzonym numerem banku - należy zaznaczyć, jeśli bank wymaga w miejscu numeru rachunku zleceniodawcy cały numer rachunku łącznie z numerem banku; bez względu na ustawienie tego pola, nowe rachunki (w formacie IBAN) eksportowane są w całości

  • Lista kontrolna - drukujemy listę przedstawiającą zawartość pliku eksportowego.

Po eksporcie, w każdym wyeksportowanym przelewie ustawia się znacznik Wyeksportowany. Przy kolejnym eksporcie takich przelewów pojawi się komunikat z odpowiednim ostrzeżeniem. Jeśli celowo chcemy ponownie wyeksportować te same przelewy, możemy przed eksportem skorzystać z funkcji Wyzeruj znacznik.

Jeśli rachunek zleceniodawcy wpisany na przelewie jest taki sam jak jeden z rachunków bankowych firmy, to na liście dostępnych systemów bankowych będzie tylko ten system, który został przypisany do tego rachunku bankowego. Jeśli przy rachunku określono, że przelewy z tego rachunku będą drukowane, to eksport nie będzie w ogóle dostępny.

UWAGA. Jeśli chcemy wyeksportować (lub wyzerować znacznik) tylko dla części przelewów, należy je podświetlić (Shift áâ ), a następnie zawęzić listę do tylko podświetlonych - polecenie Pokaż tylko podświetlone w menu podręcznym (prawy klawisz myszy lub Alt F3) albo Ctrl +- z klawiatury numerycznej.

Dodatkowo, jeśli przed eksportem albo wydrukiem stwierdzimy, że wystawiliśmy przelewy ze złego rachunku (jeśli mamy kilka własnych rachunków bankowych) lub ze złą datą, możemy zmienić te dane korzystając z poleceń menu podręcznego (prawy klawisz myszy lub Alt F3):

  • Podświetlenia - Zmień nr rachunku zleceniodawcy - zmienia nr rachunku zleceniodawcy we wszystkich podświetlonych przelewach, ale tylko w takich, w których nazwa zleceniodawcy jest identyczna jak nazwa firmy określona w okienku z firmami

  • Podświetlenia - Zmień datę - zmienia datę wszystkim podświetlonym przelewom.


CRM

INSTRUKCJA UŻYTKOWNIKA

Moduł CRM służy do zarządzania relacjami z klientami (z ang. Customer Relationship Management). Korzystanie z niego porządkuje i ułatwia kontakt z klientami, zwłaszcza gdy w firmie pracuje wiele osób mających bezpośredni kontakt z klientem. Dzięki temu modułowi klient będzie miał przekonanie, że nasza firma pracuje jako jeden spójny mechanizm, a informacje udzielane klientom są spójne i kompetentne.

Moduł CRM jest dostępny w wersji MAXI (tylko Kontakty) oraz w wersji PRO.

Jeśli chcemy korzystać z modułu CRM, należy go wstępnie skonfigurować.

Po skonfigurowaniu możemy korzystać ze wszystkich elementów modułu CRM:

  • kontakty - ewidencja kontaktów z kontrahentem

  • kontrakty/sprawy - ewidencja kontraktów sprzedażowych i spraw serwisowych

  • kampanie - ewidencja i rozliczenie kampanii sprzedażowych.

W zależności od potrzeb możemy wykorzystywać moduł CRM jako:

  • ewidencję kontaktów z klientami
    W oknie Kontakty wpisujemy jako notatki wszystkie rozmowy z kontrahentem. Dodatkowo ustalamy sobie zadania do wykonania. Każdy użytkownik programu rozmawiając z kontrahentem może sprawdzić historię dotychczasowych kontaktów. Dzięki temu klient nie musi wielokrotnie powtarzać swojego problemu różnym osobom. Lista zadań do wykonania w danym dniu pojawia się automatycznie przy uruchomieniu programu.

  • system obsługi działu serwisu
    Jeśli w naszej firmie prowadzimy serwis sprzedawanych towarów, możemy:

    • przyjąć towar do serwisu
      W oknie Kontakty tworzymy notatkę (Typ=notatka) serwisową (Cel=serwis). W polu Klient wpisujemy dane przyjmowanego towaru oraz opis problemu. W polu Rezultat wybieramy S1 przyjęty do naprawy.

    • utworzyć sprawę serwisową
      Sprawa serwisowa (albo inaczej zlecenie serwisowe) posiada nr kolejny i zawiera informacje o serwisowanym towarze, termin realizacji oraz aktualny status. Sprawa serwisowa założy się automatycznie przy akceptacji notatki z przyjęciem towaru. Sprawy serwisowe są ewidencjonowane w oknie Kontrakty/Sprawy.

    • wydrukować potwierdzenie
      Protokół otwarcia usługi serwisowej drukujemy [image] F2 w oknie Kontakty stojąc na notatce otwierającej sprawę.

    • ewidencjonować wszystkie kontakty związane z załatwianiem danej sprawy
      W oknie Kontakty wpisujemy dowolne notatki (i zadania). W każdej z nich w polu Powiązany z - Kontrakt/Sprawa wybieramy sprawę, której dotyczy dana notatka. W razie potrzeby w każdej notatce na zakładce Historia sprawdzamy szybko inne notatki dotyczące bieżącej sprawy.

    • zakończyć sprawę
      W oknie Kontakty tworzymy notatkę serwisową powiązaną z bieżącą sprawą. W polu Rezultat wybieramy S2 załatwiony. W sprawie powiązanej z tą notatką automatycznie zmieni się status z otwarty na sukces, czyli zostanie ona zamknięta.

    • wydrukować protokół wykonania zlecenia
      Protokół otwarcia usługi serwisowej drukujemy [image] F2 w oknie Kontakty stojąc na notatce zamykającej sprawę.

    • zarządzać pracą działu serwisu
      Wszystkie prowadzone sprawy serwisowe oglądamy w oknie Kontrakty/Sprawy. Wybierając we [image] F4 właściwościach tego okna odpowiedni filtr przeglądamy sprawy w toku (Status=otwarty) lub sprawy już zakończone (Status=sukces). Widzimy Wiek danej sprawy, czyli ilość dni pozostałych na wykonanie danej sprawy (na zielono) lub ilość dni, o które termin wykonania został przekroczony (na czerwono).

  • system obsługi działu sprzedaży
    Jeśli sprzedajemy towary lub usługi o stosunkowo dużej wartości, możemy:

    • tworzyć kontrakty sprzedażowe
      Kontrakty sprzedażowe (albo leady sprzedażowe), to towary i usługi, którymi wyrażają zainteresowanie nasi klienci. Aby takie kontrakty doprowadzić do faktycznej sprzedaży, warto je ewidencjonować i aktywnie wpływać na działania klienta. Kontrakt tworzymy w oknie Kontrakty/Sprawy. Nadajemy mu Cel=sprzedaż (żeby odróżnić go od spraw serwisowych) i podajemy wszystkie niezbędne dane czyli kontrahenta orazy towary/usługi którymi jest zainteresowany.

    • ewidencjonować wszystkie kontakty związane z danym kontraktem
      W oknie Kontakty wpisujemy notatki dotyczące odbytych rozmów, przekazanych ofert i dowolnych innych kontaktów. W każdej z nich w polu Powiązany z - Kontrakt/Sprawa wybieramy kontrakt, którego dotyczy dana notatka. W razie potrzeby w każdej notatce na zakładce Historia sprawdzamy szybko inne notatki dotyczące bieżącej kontraktu lub innych wcześniejszych kontraktów z tym kontrahentem. W zależności od postępu w rozmowach możemy w oknie Kontrakty/Sprawy zmieniać poziom kontraktu oraz prawdopodobieństwo sukcesu.

    • aktywnie wpływać na klienta
      W oknie Kontakty ustalamy dowolne zadania do wykonania, np. terminy ustalonych kontaktów z klientem wraz z opisem tematu rozmowy. Zadania do wykonania w danym dniu pokazują się każdemu użytkownikowi zaraz po uruchomieniu programu.

    • zakończyć kontrakt
      Jeśli udało nam się doprowadzić do faktycznej sprzedaży, zmieniamy w oknie Kontrakty/Sprawy status kontraktu na sukces. Jeśli klient zrezygnował zmieniamy status na fiasko i wpisujemy przyczyny rezygnacji.

    • zarządzać pracą działu sprzedaży
      Wszystkie prowadzone kontrakty sprzedażowe oglądamy w oknie Kontrakty/Sprawy. Wybierając we [image] F4 właściwościach tego okna odpowiedni filtr przeglądamy kontrakty w toku (Status=otwarty) lub kontrakty już zakończone sprzedażą (Status=sukces) albo rezygnacją klienta (Status=fiasko). Dla kontraktów w toku analizujemy wartość, poziom i prawdopodobieństwo kontraktów. Dla kontraktów zakończonych fiaskiem analizujemy przyczyny porażki.

    • rozliczać kampanie sprzedażowe
      Jeśli kontrakty zdobywamy w ramach określonych kampanii sprzedażowych, możemy kontrolować koszty oraz przychody uzyskane ze wszystkich kontraktów związanych z daną kampanią. W tym celu w oknie Kampanie tworzymy odpowiednie kampanie, które następnie przypisujemy do wszystkich kontraktów związanych z daną kampanią. W oknie Kampanie na zakładce Statystyka sprawdzamy na bieżąco rozliczenie tej kampanii, czyli: koszt, przychody i zysk, sumaryczną ilość kontraktów z podziałem na statusy oraz średni czas trwania kontraktu zakończonego sukcesem. W zależności od ustawienia filtra F4 Przychody z okresu oglądamy rozliczenie całej kampanii (pole wyłączone) lub tylko przychody z wybranego okresu (pole włączone).

Nic nie stoi na przeszkodzie, żeby korzystać jednocześnie z kilku wyżej wymienionych zastosowań modułu CRM. Każdemu użytkownikowi programu można określić domyślny dział (biblioteka użytkowników - zakładka Inne - pole CRM: sprzedaż/serwis/inny), w którym pracuje ten użytkownik. Będzie on podpowiadany jako cel kontaktu/kontraktu/sprawy w oknach KONTAKTY oraz KONTRAKTY/SPRAWY.


Kontakty

CRM

Ewidencja kontaktów jest jednym z elementów modułu CRM. Jest ona dostępna w wersji MAXI i PRO.

Pojęcie "kontakt" obejmuje dowolną formę kontaktu z kontrahentem: spotkanie, rozmowę telefoniczną, e-mail, fax, itp. W ewidencji kontaktów zapisujemy notatki dotyczące kontaktów z danym kontrahentem. Ponadto możemy wpisywać zadania do wykonania, np. przypomnienia o konieczności zadzwonienia do kontrahenta w konkretnej sprawie. Każdy użytkownik programu rozmawiając z kontrahentem może sprawdzić historię dotychczasowych kontaktów. Dzięki temu klient nie musi wielokrotnie powtarzać swojego problemu różnym osobom. Lista zadań do wykonania w danym dniu przez zalogowanego użytkownika pojawia się automatycznie przy uruchomieniu programu.

Okno Kontakty możemy wywołać bezpośrednio z menu Okna - CRM - Kontakty lub korzystając z menu podręcznego w oknach Kontrahenci, PZ, Faktury. W tym drugim przypadku zawiera ono wyłącznie kontakty dotyczące wybranego kontrahenta.

Wprowadzając [image] nowy kontakt (Ins) określamy następujące pola:

  • Od, Do - okres trwania kontaktu, czyli np. data i godzina rozpoczęcia Od i zakończenia Do spotkania albo rozmowy telefonicznej

  • Cel - cel któremu służy ten kontakt

    • inny - dowolny kontakt

    • sprzedaż - kontakt w ramach realizacji kontraktu sprzedażowego

    • serwis - kontakt w ramach obsługi serwisowej

    Domyślnie ustawia się cel zależny od działu CRM, do którego został przypisany użytkownik programu (biblioteka użytkowników - zakładka Inne - pole CRM). W zależności od wybranego celu ustawiają się domyślne wartości niektórych kolejnych pól.

  • Typ - typ kontaktu

    • notatka - notatka z odbytej rozmowy, spotkania itp.

    • zadanie - zadanie do wykonania w określonym dniu/godzinie

  • Od kogo - kto zainicjował kontakt

    • od klienta - np. jeśli klient zadzwonił do nas

    • od nas - np. jeśli spotkanie odbyło się z naszej inicjatywy

    • wewnętrzny - np. jeśli wpisujemy notatkę z wewnętrznego spotkania w naszej firmie odbytego w ramach załatwiania jakiegoś problemu dotyczącego danego klienta lub na zadaniu zleconym przez innego użytkownika programu

  • Rodzaj - wybieramny z biblioteki rodzaj kontaktu

    • e-mail, fax, poczta, telefon, wizyta u klienta, wizyta u nas

  • Kontrahent - wyszukujemy po skrócie nazwy lub nipie kontrahenta związanego z tym kontaktem. Przyciskiem Telefon możemy szybko sprawdzić numery telefonów i inne dane kontakowe tego kontrahenta.

  • Powiązany z

    • Kontrakt/Sprawa - zaznaczany automatycznie jeśli Cel kontaktu to sprzedaż albo serwis. W polu poniżej wybieramy z ewidencji konkretny kontrakt/sprawę. Nazwa wybieranego kontraktu/sprawy składa się z trzech części. Pierwszy od lewej jest numer, potem data i opis. Gwiazdka * przed numerem oznacza, że kontrakt jest aktywny (otwarty). Jeśli kontraktu/sprawy jeszcze nie ma, to pozostawiamy pole z wyborem kontraktu/sprawy puste. Kontrakt/sprawa zostanie założony przy akceptacji kontaktu.

    • Bez powiązania - zaznaczany automatycznie jeśli Cel kontaktu to inny, czyli jeśli wprowadzamy "luźną" notatkę lub zadanie, niepowiązaną z żadnym kontraktem ani sprawą.

  • Restrykcje - restrykcje nałożone na obroty z wybranym kontrahentem. Pole pojawia się tylko w przypadku, gdy restrykcje występują.

  • zakładka Opis

    • Klient - z biblioteki osób pracujących u kontrahenta wybieramy osobę, której dotyczy ten kontakt. W polu poniżej wpisujemy treść kontaktu, czyli np. to co powiedziała nam ta osoba w trakcie rozmowy telefonicznej.

    • Zlecający - tylko jesli w polu Od kogo wybrano wewnętrzny. Użytkownik zlecający wykonanie zadania oraz w polu poniżej opis tego zadania.

    • Prowadzący - z biblioteki użytkowników programu wybieramy osobę, która prowadzi ten kontakt. Domyślnie podstawia się bieżący użytkownik programu. W polu poniżej wpisujemy treść kontaktu, czyli np. to co osoba prowadząca kontakt powiedziała klientowi w trakcie rozmowy telefonicznej.

    • Rezultat - dostępne tylko dla notatek serwisowych. Jeśli w rezultacie tego kontaktu należy podjąć jakieś działanie, to wybieramy je w polu 1 z biblioteki podstawowych rezultatów. W zależności od wybranego rezultatu mogą pojawić się dodatkowe pola:

      • 2, 3 - dodatkowe sprecyzowania działania, które należy podjąć

      • jeśli w definicji wybranych rezultatów 1, 2 lub 3 zaznaczono odpowiednie pola:

        • Kwota - kwota do zapłaty za usługę serwisową

        • Opis - dodatkowy opis

        • Komu - komu zlecane jest zadanie do wykonania

    • Jaki rezultat? - dostępne tylko dla zadań serwisowych. Umożliwia łatwą zamianę zadania na notatkę serwisową. Jeśli wykonujemy zlecone zadanie, to nie tworzymy dodatkowej notatki z wykonania tego zadania, tylko bezpośrednio na zadaniu naciskamy przycisk Jaki rezultat?, który zamienia zadanie w notatkę i pozwala na wpisanie jej rezultatu.

    • Kwalifikacja - wybieramy z biblioteki kwalifikację sprawy serwisowej. Może się podstawiać automatycznie na podstawie wybranych wyżej rezultatów.

    • Czas - czas (liczba dni) na załatwienie sprawy serwisowe. Podstawia się taka liczba dni, jaką określono w bibliotece kwalifikacji.

    • Do - do kiedy (data) należy załatwić sprawę

  • zakładka Historia

    • Kontrakty / Sprawy - lista wszystkich kontraktów i spraw związanych z bieżącym kontrahentem

    • Kontakty - lista kontaktów dotyczących wybranego powyżej kontraktu/sprawy.

Wprowadzone dane akceptujemy przyciskiem [image] OK. Do szybkiej akceptacji służy również klawisz PgDn.

Poprawę danych [image] umożliwia klawisz F6, natomiast usunięcie [image] kontaktu klawisz Del.

Dla kontaktów serwisowych możemy wydrukować protokół otwarcia i zakończenia usługi serwisowej. Wydruki [image] F2 te są dostępne dla notatek (Typ=notatka) serwisowych (Cel=serwis) z odpowiednim rezultatem zdefiniowanym w konfiguracji modułu CRM. Domyślnie są to rezultaty:

  • S1 przyjęty do naprawy - protokół otwarcia

  • S2 załatwiony - protokół zakończenia.

Dodatkowa funkcja [image] F4 umożliwia ustawienie stałego filtru na kontakty spełniające zadane kryteria:

  • Data - pokazane zostaną kontakty należące do podanego tu zakresu dat

  • Typ,
    Cel,
    Rodzaj,
    Rezultat,
    Kwalifikacja,
    Kontrahent,
    Kontrakt,
    Prowadzący - opis znaczenia tych kryteriów podano wyżej opisując wprowadzanie kontaktu.


Kontrakty/Sprawy

CRM

Ewidencja kontraktów/spraw jest jednym z elementów modułu CRM.

Pojęcie "kontrakt" dotyczy kontraktów sprzedażowych. Jeśli sprzedajemy towary lub usługi o stosunkowo dużej wartości, możemy prowadzić ewidencję potencjalnych klientów i tzw. kontraktów czyli towarów i usług, którymi ci klienci są zainteresowani. Kontrakt ma określoną wartość, datę rozpoczęcia, przewidywaną datę finalizacji, poziom, prawdopodobieństwo osiągnięcia sukcesu oraz aktualny status. Jeśli kontrakty zdobywamy w ramach określonych kampanii sprzedażowych, możemy kontrolować koszty oraz przychody uzyskane ze wszystkich kontraktów związanych z daną kampanią.

Pojęcie "sprawa" dotyczy spraw (lub zleceń) serwisowych. Jeśli w naszej firmie prowadzimy serwis sprzedawanych towarów, możemy przyjąć towar do serwisu, tzn. utworzyć sprawę serwisową (zlecenie serwisowe). Sprawa serwisowa posiada nr kolejny i zawiera informacje o serwisowanym towarze, termin realizacji oraz aktualny status.

Okno Kontrakty/Sprawy zawiera ewidencję zarówno kontraktów sprzedażowych jak i spraw serwisowych (stąd jego dwuczłonowa nazwa). W zależności od potrzeb możemy pracować tylko na kontraktach, tylko na sprawach lub na obu tych obiektach łącznie.

W ramach każdego kontraktu/sprawy możemy prowadzić ewidencję kontaktów z klientem i zadań do wykonania, np. telefonów w umówionym z klientem terminie.

Okno Kontrakty/Sprawy możemy wywołać bezpośrednio z menu Okna - CRM - Kontrakty/Sprawy.

Wprowadzając [image] nowy kontrakt lub sprawę (Ins) określamy następujące pola:

  • zakładka Kontrakt/Sprawa

    • Numer - nadawany automatycznie numer kolejny (bez podziału na kontrakty i sprawy)

    • Cel - cel któremu służy ten kontakt

      • inny - dowolny kontrakt

      • sprzedaż - kontrakt sprzedażowy

      • serwis - sprawa serwisowa

    • Rodzaj - w przypadku spraw serwisowych wybieramy z biblioteki rodzaj kontaktu, czyli sposób w jaki rozpoczęto tę sprawę:

      • e-mail, fax, poczta, telefon, wizyta u klienta, wizyta u nas

    • Rezultat - w przypadku spraw serwisowych - rezultat jakim zakończył się ostatni kontakt w danej sprawie. Można go traktować jako aktualny status bieżącej sprawy serwisowej.

    • Kwalifikacja - w przypadku spraw serwisowych - jak zakwalifikowano tę sprawę w ostatnim kontakcie dotyczącym tej sprawy

    • Kontrahent, Nip - wyszukujemy po skrócie nazwy lub nipie kontrahenta związanego z tym kontraktem/sprawą

    • Status

      • otwarty - kontrakt jest rozpoczęty, klient jeszcze nie dokonał zakupu, ale też jeszcze nie zrezygnował. W przypadku sprawy serwisowej - sprawa została otwarta, towar jest w trakcie serwisowania.

      • fiasko - kontrakt zakończony niepomyślnie, klient zrezygnował. W przypadku sprawy serwisowej - albo nie korzystamy w ogóle z takiego statusu, albo traktujemy go np. jako odmowę wykonania usługi, np. ze względu na nieprzestrzeganie warunków gwarancji.

      • sukces - kontrakt zakończony pomyślnie, klient dokonał zakupu. W przypadku sprawy serwisowej - sprzęt został naprawiony i odebrany przez klienta, sprawa została zamknięta.

    • Kampania - w przypadku kontraktu sprzedażowego wybieramy z biblioteki kampanię, w trakcie której ten kontrakt został pozyskany (rozpoczęty). Jeśli nie chcemy korzystać z kampanii, należy utworzyć sztuczną kampanię o nazwie np. nieokreślona i wybierać ją w kontrakcie

    • Poziom - w przypadku kontraktu sprzedażowego wybieramy z biblioteki aktualny poziom kontraktu. Poziomy definiuje się samodzielnie, mogą to być np. wstępne rozmowy, oferta, zaawansowane rozmowy, negocjacje, ..., faktura .

    • Sukces - w przypadku kontraktu sprzedażowego określamy jakie jest wg nas prawdopodobieństwo uzyskania sukcesu

    • Nazwa - w przypadku kontraktu sprzedażowego nazwa towaru/usługi, którym jest potencjalnie zainteresowany klient. W przypadku sprawy serwisowej - skrócony opis sprawy. W sprawach tworzonych automatycznie przy akceptacji pierwszego kontaktu, w polu Nazwa podstawia się opis z kontaktu z pola Klient.

    • Wartość - w przypadku kontraktu sprzedażowego wartość towaru/usługi, którym jest zainteresowany klient

    • Uwagi - dowolne uwagi lub przyczyny rezygnacji

  • zakładka Pozycje - w przypadku kontraktu sprzedażowego tabelka umożliwiająca wyszczególnienie asortymentów, którymi jest zainteresowany klient. Ich nazwa oraz sumaryczna wartość przepisuje się automatycznie do pól Nazwa i Wartość na zakładce Kontrakty/Sprawy.

  • Początek - data rozpoczęcia kontrakt/sprawy, zwykle jest to data pierwszego kontaktu

  • Finalizacja - data zakończenia kontraktu/sprawy, zwykle jest to data ostatniego kontaktu

  • Prowadzący - z biblioteki użytkowników programu wybieramy osobę, która prowadzi(nadzoruje) ten kontrakt lub sprawę.

Wprowadzone dane akceptujemy przyciskiem [image] OK. Do szybkiej akceptacji służy również klawisz PgDn.

Na zakładce Lista przy poszczególnych sprawach dostępna jest między innymi kolumna Wiek. W przypadku spraw serwisowych pokazuje ona ilość dni pozostałych na wykonanie danej sprawy (na zielono) lub ilość dni, o które termin wykonania został przekroczony (na czerwono). W przypadku kontraktów sprzedażowych oraz zamkniętych spraw serwisowych Wiek to ilość dni, jaka upłynęła od rozpoczęcia kontraktu (na biało).

Poprawę danych [image] umożliwia klawisz F6, natomiast usunięcie [image] kontraktu klawisz Del.
UWAGA. Razem z kontraktem/sprawą usuwane są wszystkie kontakty z nim związane.

Możliwe jest szybkie wyszukanie dowolnego kontraktu [image] Ctrl F7 poprzez wpisanie numeru kontraktu lub np. nazwy kontrahenta. Pojawi się okienko Szukaj, w którym należy określić, jakie pola ma brać pod uwagę przy wyszukiwaniu (Szukaj po). Kursor automatycznie ustawi się na właściwej pozycji.

Dodatkowa funkcja [image] F4 umożliwia ustawienie stałego filtru na kontrakty spełniające zadane kryteria:

  • Początek - pokazane zostaną kontrakty rozpoczynające się w podanym tu zakresie dat

  • Finalizacja - pokazane zostaną kontrakty zakończone w podanym tu zakresie dat

  • Cel,
    Status,
    Poziom,
    Rezultat,
    Kwalifikacja,
    Kontrahent,
    Kampania,
    Prowadzący - opis znaczenia tych kryteriów podano wyżej opisując wprowadzanie kontraktu/sprawy.


Kampanie

CRM

Ewidencja kampanii jest jednym z elementów modułu CRM.

Pojęcie "kampania" możemy traktować jako kampanię reklamową mającą na celu pozyskanie nowych kontraktów.

Wprowadzone do ewidencji kampanie należy przypisywać do odpowiednich kontraktów. Dzięki temu można szybko rozliczać poszczególne kampanie.

Okno Kampanie możemy wywołać bezpośrednio z menu Okna - CRM - Kampanie.

Wprowadzając [image] nową kampanię (Ins) określamy następujące pola:

  • zakładka Ogólne

    • Grupa - wybieramy grupę kampanii z biblioteki. Bibliotekę definiujemy sami. Możemy np. wpisać rodzaje mediów z których korzystamy reklamując się (prasa, internet, TV, radio itp.)

    • Podgrupa - wybieramy podgrupę kampanii z biblioteki. Bibliotekę definiujemy sami. Możemy np. wpisać konkretne tytuły prasowe, programy radiowe lub telewizyjne, w których się reklamujemy.

    • Data - data rozpoczęcia kampanii

    • Nazwa - nazwa kampanii, automatycznie ustawia się jako złożenie wybranej grupy, podgrupy i daty. Można ją zmienić na dowolną inną.

    • Koszt - koszt kampanii, przydatny do porównania z przychodami z zakończonych sukcesem kontraktów.

    • Uwagi - dowolne uwagi

  • zakładka Statystyka - rozliczenie kampanii, zakładka dostępna tylko jeśli w bieżącym [image] F4 fltrze zaznaczono pole Statystyka

    • Wartość - rozliczenie przychodów

      • Koszt - koszt kampanii przepisany z zakładki Ogólne

      • Pzychód - łączna wartość wszystkich kontraktów, które są przypisane do tej kampanii i zakończyły się sukcesem

      • Zysk - zysk osiągnięty na tej kampanii, czyli nadwyżka przychodów nad kosztami

    • Ilość - liczba kontraktów uzyskanych z tej kampanii

      • Sukces, Otwarte, Zysk - liczba kontraktów powiązanych z tą kampanią z podziałem na aktualny status kontraktu

      • Razem - łączna liczba kontraktów uzyskanych w ramach tej kampanii

    • Dni - liczba dni od rozpoczęcia do zamknięcia z sukcesem kontraktu

      • Min - liczba dni z kontraktu, który się zakończył najszybciej. Zero oznacza zakończenie w tym samym dniu co data kampanii.

      • Średnio - średni czas trwania kontraktu zakończonego sukcesem

      • Max - liczba dni z kontraktu, który trwał najdłużej.

Wprowadzone dane akceptujemy przyciskiem [image] OK. Do szybkiej akceptacji służy również klawisz PgDn.

Poprawę danych [image] umożliwia klawisz F6, natomiast usunięcie [image] kontraktu klawisz Del.

Możliwe jest szybkie wyszukanie dowolnej kampanii [image] Ctrl F7 poprzez wpisanie jej nazwy. Pojawi się okienko Szukaj, w którym należy określić, jakie pola ma brać pod uwagę przy wyszukiwaniu (Szukaj po). Kursor automatycznie ustawi się na właściwej pozycji.

Dodatkowa funkcja [image] F4 umożliwia:

  • włączenie zakładki Statystyka, zawierającej rozliczenie poszczególnych kampanii. Wszystkie pola z zakładki Statystyka są również dostępne w [image] Ctrl F4 kolumnach okna, więc można z nich korzystać na zakładce Lista.

  • ustawienie stałego filtru na kontrakty spełniające zadane kryteria:

    • Grupa - pokazane zostaną kontrakty rozpoczynające się w podanym tu zakresie dat

    • Podgrupa - pokazane zostaną kontrakty zakończone w podanym tu zakresie dat.


ZESTAWIENIA I STATYSTYKI

INSTRUKCJA UŻYTKOWNIKA

Program dostarcza wiele gotowych zestawień i raportów oraz rozbudowane narzędzia do tworzenia własnych zestawień. W efekcie uzyskujemy możliwość sporządzenia praktycznie dowolnych zestawień i raportów niezbędnych w naszej firmie.

Zestawienia i raporty dostępne są w dwóch miejscach:

  • w menu drukowania [image] F2 w najważniejszych oknach programu (PZ, Faktury, itp.). W ten sposób szybko znajdziemy wszystkie zestawienia dotyczące danego okna programu. Np. w oknie Faktury dostępne są wszystkie zestawienia dotyczące sprzedaży i wydań towarów.

  • w pozycji menu głównego Raporty. Znajdują się tam:

    • najważniejsze zestawienia i raporty z poszczególnych okien programu

    • raporty dotyczące wielu okien, np. Należności i zobowiązania albo Rozliczenie kontraktów.

W obu przypadkach zestawienia i raporty są wyświetlane w tym samym menu. Ich nazwy są uporządkowane alfabetycznie, co umożliwia szybkie odszukanie właściwej pozycji.

W kolejnych rozdziałach opiszemy wszystkie dostępne zestawienia i raporty.

Oprócz wspomnianych wyżej zestawień, program oferuje dostęp do aktualnej statystyki umożliwiającej szybkie sprawdzenie najważniejszych parametrów naszej firmy, m.in.: aktualnych obrotów, zapłat za terminowe faktury oraz stanu kasy i rachunków bankowych. Statystyka zawiera również wykresy porównujące sprzedaż z bieżącego roku z poprzednim, które służą wykryciu tendencji występujących w naszej dotychczasowej działalności.

W bardzo indywidualnych przypadkach możemy również posłużyć się zewnętrznym programem do generowania raportów i za jego pomocą utworzyć specyficzny raport bezpośrednio z programu (patrz INSTRUKCJA ADMINISTRATORA - PARAMETRYZACJA SYSTEMU - Zewnętrzny generator raportów).


Zestawienia

Zestawienia i raporty

ZESTAWIENIA I STATYSTYKI

Program umożliwia sporządzanie różnych zestawień i raportów.

Zestawienia są wydrukami z prowadzonych w programie ewidencji. Można je samodzielnie modyfikować, można również zdefiniować w całości nowe własne zestawienia odpowiadające lepiej naszym specyficznym potrzebom. Niektóre zestawienia, np. Sprzedaż - pozycje dokumentów, dostępne są w postaci okna co umożliwia wykonanie przed wydrukiem dodatkowych operacji, np. wyszukania konkretnej pozycji. Pozostałe zestawienia są przygotowywane od razu jako wydruk.

Raporty różnią się od zestawień tym, że zwykle mają bardziej skomplikowaną formę i zawierają więcej danych. Raportów w odróżnieniu od zestawień nie można modyfikować.

Program oferuje następujące zestawienia i raporty:

  • w oknie PZ

    • Rejestr zakupów VAT - pomocniczy raport do rozliczenia naliczonego podatku VAT. Przed wydrukiem należy wybrać odpowiedni okres (menu główne Ustawienia - Bieżąca data i okres lub klawisz F12). Bez względu na ustawienia filtru [image] F4 rejestr będzie zawierał tylko dokumenty związane z faktycznym zakupem (bez BO, zamówień itp). Na wydruk rejestru ma wpływ wybrany przez użytkownika sposób rozliczenia vat. Wydruk ma charakter pomocniczy, gdyż obejmuje tylko zakupy handlowe oraz sporządzany jest wg stawek vat a nie celów zakupu. Pełny rejestr zakupów VAT można wydrukować z programu R2fk lub R2księga po zaimportowaniu dokumentów PZ.

    • Zakup - asortymenty - zestawienie zakupów poszczególnych asortymentów uporządkowane wg wielkości obrotów

    • Zakup - asortymenty z podziałem na grupy - jak wyżej, tylko że z podziałem na grupy

    • Zakup - dokumenty - lista dokumentów

    • Zakup - dokumenty z podziałem na dostawców - lista dokumentów podzielona alfabetycznie na poszczególnych dostawców

    • Zakup - dostawcy - sumaryczne obroty z dostawcami uporządkowane wg wielkości obrotów

    • Zakup - grupy - sumaryczne zestawienia zakupów poszczególnych grup asortymentowych

    • Zakup - PKWiU - sumaryczne zakupy z podziałem na grupy PKWiU

    • Zakup - pozycje dokumentów - pozycje z dokumentów PZ

    • Zakup - stawki vat - sumaryczne zakupy z podziałem na stawki VAT

    • Zakup - wierzyciele wg kwot - lista niezapłaconych PZ uporządkowana w kolejności kwot do zapłaty

    • Zakup - wierzyciele wg terminów płatności - lista niezapłaconych PZ uporządkowana w kolejności terminów płatności

  • w oknie Faktury

    • Rejestr sprzedaży VAT - raport, który może służyć jako podstawa do rozliczenia należnego podatku VAT. Przed wydrukiem należy wybrać odpowiedni okres (menu główne Ustawienia - Bieżąca data i okres lub klawisz F12). Bez względu na ustawienia filtru [image] F4 rejestr będzie zawierał tylko dokumenty związane z faktyczną sprzedażą oraz faktury wewnętrzne (bez proform itp). Na wydruk rejestru ma wpływ wybrany przez użytkownika sposób rozliczenia vat.

    • Zestawienie sprzedaży VAT - raport z uproszczoną wersją rejestru vat (wydruk pionowy, jedna linijka odpowiada jednemu dokumentowi, możliwość wyboru stawek).

    • Sprzedaż - asortymenty - zestawienie sprzedaży poszczególnych asortymentów uporządkowane wg wielkości obrotów

    • Sprzedaż - asortymenty z podziałem na grupy - jak wyżej, tylko że z podziałem na grupy

    • Sprzedaż - dłużnicy wg kwot - lista niezapłaconych faktur uporządkowana w kolejności kwot do zapłaty

    • Sprzedaż - dłużnicy wg terminów płatności - lista niezapłaconych faktur uporządkowana w kolejności terminów płatności

    • Sprzedaż - dokumenty - lista dokumentów wystawionych w wybranym okresie

    • Sprzedaż - dokumenty z podziałem na nabywców - lista dokumentów podzielona alfabetycznie na poszczególnych nabywców

    • Sprzedaż - grupy - sumaryczne zestawienia sprzedaży poszczególnych grup asortymentowych

    • Sprzedaż - nabywcy - sumaryczne obroty z nabywcami uporządkowane wg wielkości obrotów

    • Sprzedaż - PKWiU - sumaryczna sprzedaż z podziałem na grupy PKWiU

    • Sprzedaż - pozycje dokumentów - pozycje z dokumentów sprzedaży (faktury, paragony)

    • Sprzedaż - stawki vat - sumaryczne obroty z podziałem na stawki Vat

    • Sprzedaż - średnia cena sprzedaży - średnia cena sprzedaży poszczególnych asortymentów

    • Wydania - asortymenty - zestawienie wydań poszczególnych asortymentów uporządkowane wg wielkości obrotów

    • Wydania - asortymenty z podziałem na grupy - jak wyżej, tylko że z podziałem na grupy

    • Wydania - dokumenty - lista dokumentów WZ wystawionych w wybranym okresie

    • Wydania - grupy - sumaryczne zestawienia wydań poszczególnych grup asortymentowych

    • Wydania - pozycje dokumentów - pozycje z dokumentów WZ

    • Wydania - pozycje z podziałem na dokumenty - pozycje poszczególnych dokumentów WZ, zestawienie przydatne do rozliczania kosztu własnego sprzedaży

  • w oknie MM

    • Przesunięcia - dokumenty - lista wystawionych w wybranym okresie dokumentów MM

    • Przesunięcia - dokumenty z podziałem na magazyn docelowy - lista dokumentów MM wystawionych w wybranym okresie z podziałem na magazyn docelowy, czyli pole "Do magazynu"

    • Przesunięcia - dokumenty z podziałem na magazyn źródłowy - lista dokumentów MM wystawionych w wybranym okresie z podziałem na magazyn źródłowy, czyli pole "Z magazynu"

    • Przesunięcia - pozycje dokumentów - pozycje z dokumentów MM

  • w oknie Kontrahenci

    • Lista Kontrahentów - lista kontrahentów zawierająca nazwę, dane, nip, telefon i uwagi

    • Obroty magazynowe - rozbudowany raport umożliwiający wydrukowanie obrotów magazynowych związanych z danym kontrahentem

    • Sprzedaż - pozycje dokumentów - pozycje z dokumentów sprzedaży (faktury, paragony) wystawionych dla tego kontrahenta

    • Wydania - pozycje dokumentów - pozycje z dokumentów WZ wystawionych dla tego kontrahenta

    • Zakup - pozycje dokumentów - pozycje z dokumentów PZ wystawionych dla tego kontrahenta

  • w oknie Asortymenty

    • Cennik - cennik asortymentów

    • Cennik - grupy - jak wyżej, tylko że z podziałem na grupy

    • Cennik dedykowany - asortymenty - cennik dedykowany dla konkretnego asortymentu, czyli lista cen ustalonych dla poszczególnych nabywców

    • Cennik dedykowany - grupy - cennik dedykowany dla grupy asortymentów, czyli lista rabatów na poszczególne grupy asortymentowe ustalonych dla poszczególnych nabywców

    • Cennik dedykowany - nabywcy - cennik dedykowany dla konkretnego nabywcy, czyli lista cen na poszczególne asortymenty i rabatów na grupy asortymentowe określonych dla poszczególnych nabywców

    • Metki - wydruk metek asortymentowych

    • Obroty magazynowe - rozbudowany raport umożliwiający wydrukowanie obrotów magazynowych w wybranym okresie wg różnych kryteriów

    • Sprzedaż - pozycje dokumentów - pozycje z dokumentów sprzedaży (faktury, paragony), na których figuruje dany asortyment

    • Stan magazynu - rozbudowany raport umożliwiający wydrukowanie stanu magazynu (bieżącego lub historycznego na zadany dzień) wg różnych kryteriów

    • Wydania - pozycje dokumentów - pozycje z dokumentów WZ, na których figuruje dany asortyment

    • Zakup - pozycje dokumentów - pozycje z dokumentów PZ, na których figuruje dany asortyment

  • w oknie Stan magazynu

    • Stan magazynu - rozbudowany raport umożliwiający wydrukowanie bieżącego stanu magazynu wg różnych kryteriów

  • w pozycji menu głównego Raporty - najważniejsze z zestawień i raportów wyszczególnionych powyżej oraz:

    • Należności i zobowiązania - raport z przeterminowanymi należnościami i zobowiązaniami

    • Rozliczenie kontraktów - raport z bilansem kontraktów (zakup, wydania, stan bieżący, zysk i marża)

    • Rozliczenie płatności - raport zawierający płatności z rozrachunków dla wszystkich kontrahentów

    • Rozliczenie płatności (zbiorcze) - raport zawierający sumaryczne płatności z rozrachunków dla wszystkich kontrahentów

    • Rozrachunki - raport zawierający rozrachunki dla wszystkich kontrahentów.


Zestawienia

Zakres drukowanych pozycji

ZESTAWIENIA I STATYSTYKI - Zestawienia i raporty

Zakres pozycji ujmowanych na raportach zależy od konkretnego raportu oraz parametrów określonych przed jego wykonaniem.

W przypadku zestawień zakres pozycji zależy od sposobu wywołania zestawienia:

  • wywołanie z menu Raporty
    Podajemy szczegółowe kryteria filtrowania, tak jak w opisanym niżej przypadku wg własnego filtra.

  • wywołanie z menu drukowania [image] F2 w określonym oknie

    Mamy do wyboru 3 sposoby określenia zakresu drukowanych pozycji:

    • takie jak w oknie - tylko pozycje widoczne aktualnie w oknie, czyli spełniające aktualnie wybrane ustawienia filtrowania określone we właściwościach [image] F4 okna

    • tylko podświetlone - tylko pozycje, które są aktualnie podświetlone w oknie (bez względu na to czy w oknie pokazywane są wszystkie, czy tylko podświetlone pozycje)

    • wg własnego filtra - podajemy szczegółowe kryteria filtrowania określone w definicji zestawienia (w razie potrzeby można je zmodyfikować)


RAPORTY

Należności i zobowiązania

ZESTAWIENIA I STATYSTYKI - Zestawienia i raporty

Należności i zobowiązania to raport pokazujący przeterminowane płatności do faktur sprzedaży i zakupu (PZ). Jest przydatny na własne potrzeby, ale również np. przy sporządzaniu wniosków kredytowych.

W zależności od wybranego rodzaju (wg dni po terminie, wg terminów płatności, wg kontrahentów) przed wydrukiem określamy:

  • wg dni po terminie - zestawienie pogrupowane wg dni, o które przekroczono termin płatności. Przed sporządzeniem zestawienia określamy jego parametry:

    • Zakres

      • Rodzaj - wybierając sposród dostępnych 2 wariantów: należności zobowiązania - określamy, czy zestawienie ma zawierać listę przeterminowanych płatności związanych z fakturami sprzedaży - należności , czy też z fakturami zakupu (PZ) - zobowiązania

      • Na dzień - zestawienie będzie zawierało płatności przeterminowane w stosunku do tego dnia. Możemy wpisać dowolną datę z przeszłości, żeby sprawdzić stan płatności na wybrany dzień.

      • Typ - zestawienie będzie zawierało płatności przeterminowane lub nieprzeterminowane, albo jedne i drugie jeśli pozostawimy to pole puste

      • Grupa - zestawienie będzie zawierało płatności przeterminowane dla wybranej grupy kontrahentów

      • Forma płatności - zestawienie będzie zawierało płatności przeterminowane dla wybranej formy płatności

    • Definicja

      • Pomiń kontrahentów "inny" - zaznaczamy jeśli nie chcemy uwzględniać w zestawieniu kontrahentów określonych jako "Inny" (patrz BIBLIOTEKI - Kontrahenci)

      • Wpłaty niepowiązane - płatności niepowiązane z dokumentami

      • Grupy dni terminów przeterminowanych płatności - zestawienie będzie zawierało listę przeterminowanych faktur pogrupowanych w zależności od liczby dni, o które został przekroczony termin płatności. Standardowo są to grupy: do 60 dni, od 61 do 180 i powyżej 180 dni. Możemy zmienić standardowe progi lub zrezygnować z którejś z grup.

  • wg terminów płatności - zestawienie pogrupowane wg przyznanych terminów płatności. Przed wydrukiem określamy następujące parametry:

    • Zakres

      • Rodzaj - wybierając sposród dostępnych 2 wariantów: należności, zobowiązania - określamy, czy zestawienie ma zawierać listę przeterminowanych płatności związanych z fakturami sprzedaży - należności , czy też z fakturami zakupu (PZ) - zobowiązania

      • Na dzień - zestawienie będzie zawierało płatności przeterminowane w stosunku do tego dnia. Możemy wpisać dowolną datę z przeszłości, żeby sprawdzić stan płatności na wybrany dzień.

      • Typ - zestawienie będzie zawierało płatności przeterminowane lub nieprzeterminowane, albo jedne i drugie jeśli pozostawimy to pole puste

      • Grupa - zestawienie będzie zawierało płatności przeterminowane dla wybranej grupy kontrahentów

      • Forma płatności - zestawienie będzie zawierało płatności przeterminowane dla wybranej formy płatności

    • Definicja

      • Pomiń kontrahentów "inny" - zaznaczamy jeśli nie chcemy uwzględniać w zestawieniu kontrahentów określonych jako "Inny" (patrz BIBLIOTEKI - Kontrahenci)

      • Wpłaty niepowiązane - płatności niepowiązane z dokumentami

  • wg kontrahentów - zestawienie pogrupowane wg kontrahentów. Przed wydrukiem określamy następujące parametry:

    • Zakres

      • Rodzaj - wybierając sposród dostępnych 3 wariantów: należności, zobowiązania lub należności i zobowiązania - określamy, czy zestawienie ma zawierać listę przeterminowanych płatności związanych z fakturami sprzedaży - należności , czy też z fakturami zakupu (PZ) - zobowiązania, albo jedne i drugie - należności i zobowiązania

      • Na dzień - zestawienie będzie zawierało płatności przeterminowane w stosunku do tego dnia. Możemy wpisać dowolną datę z przeszłości, żeby sprawdzić stan płatności na wybrany dzień.

      • Typ - zestawienie będzie zawierało płatności przeterminowane lub nieprzeterminowane, albo jedne i drugie jeśli pozostawimy to pole puste

      • Grupa - zestawienie będzie zawierało płatności przeterminowane dla wybranej grupy kontrahentów

      • Forma płatności - zestawienie będzie zawierało płatności przeterminowane dla wybranej formy płatności

    • Definicja

      • Pomiń kontrahentów "inny" - zaznaczamy jeśli nie chcemy uwzględniać w zestawieniu kontrahentów określonych jako "Inny" (patrz BIBLIOTEKI - Kontrahenci)

      • Wpłaty niepowiązane - płatności niepowiązane z dokumentami.


RAPORTY

Stan magazynu

ZESTAWIENIA I STATYSTYKI - Zestawienia i raporty

Stan magazynu to raport pokazujący stan magazynu (bieżący lub na zadany dzień).

Przed wydrukiem określamy:

  • Zakres

    • Wydruk - rodzaj wydruku

      • bieżący - wydruk bieżącego stanu magazynu. Bieżącego, czyli bez żadnego przeliczania, wg stanu po wszystkich operacjach magazynowych wykonanych w programie, bez względu na ich datę. Jeśli np. ustawimy datę bieżącą na 10.09.2012, a wcześniej wykonaliśmy przyjęcia/wydania z datą 30.09.2012, to wydruk bieżącego stanu magazynu będzie odpowiadał wydrukowi na dzień 30.09.2012, a nie na 10.09.2012.

      • na dzień - wydruk stanu magazynu na zadany dzień. Ta opcja umożliwia wydruk stanu magazynu na dowolny zadany dzień z przeszłości. Dla każdego drukowanego asortymentu program sprawdza wszystkie operacje magazynowe (PZ, WZ, MM) do zadanej daty włącznie i na tej podstawie wylicza stan magazynu.

    • Data - zestawienie będzie zawierało stan magazynu na wybrany tu dzień. Możemy wpisać dowolną datę z przeszłości. Pole dostępne tylko po wybraniu opcji na dzień.

    • Magazyn - wypełniamy jeśli zestawienie ma dotyczyć konkretnego magazynu

    • Nr dostawy - wypełniamy jeśli zestawienie ma być wykonane dla konkretnego numeru dostawy

    • Tylko asortymenty z niezerowymi obrotami - zaznaczamy jeśli zestawienie ma uwzględniać tylko asortymenty z niezerowymi obrotami.

  • Definicja

    • Typ

      • zbiorczy (bez rozbicia na dostawy) - każdy asortyment jest drukowany jako jedna pozycja. Jeśli towar pochodzi z kilku dostaw, to ilości z poszczególnych dostaw są sumowane a cena nabycia jest uśredniana.

      • szczegółowy (każda dostawa osobno) - każda dostawa jest drukowana jako osobna pozycja z wyszczególnieniem numeru dostawy i ceny nabycia dostawy. Jeśli dla danego asortymentu towar pochodzi z kilku dostaw, to będzie on występował na wydruku w kilku linijkach.

    • Cena - możemy sporządzić wydruk zawierający tylko stany magazynowe (cena brak) lub wg ceny nabycia, ewidencyjnej, sprzedaży - 1, sprzedaży - 2 i sprzedaży - 3. W przypadku ceny nabycia i wydruku zbiorczego, ceny nabycia będą średnimi cenami nabycia, wynikającymi z cen nabycia poszczególnych dostaw danego asortymentu.

    • Indeksy - jeśli chcemy na wydruku wyszczególnić indeksy asortymentowe, wybieramy wydruk z indeksem. W takim przypadku możemy dodatkowo określić Uporządkowanie asortymentów wg

      • nazw

      • indeksów

    • Każdy magazyn osobno - jeśli chcemy aby stany magazynowe były wyszczególnione i zsumowane osobno dla każdego magazynu

    • Waga - jeśli chcemy, aby wydruk zawierał dodatkową kolumnę z łączną wagą asortymentów będących na stanie magazynu.

  • Nagłówek/Stopka - określamy nagłówek i stopkę wydruku. Korzystając z menu podręcznego (prawy klawisz myszy) możemy wstawić do treści nagłówka/stopki tekst, który zostanie zamieniony na odpowiednią wartości w trakcie wydruku:

    • {DB} - data bieżąca

    • {DEFINICJA} - ustawienia z zakładki Definicja

    • {WYDRUK} - bieżący / na dzień

    • {ZAKRES} - ustawienia z zakładki Zakres.


RAPORTY

Obroty magazynowe

ZESTAWIENIA I STATYSTYKI - Zestawienia i raporty

Obroty magazynowe to raport pokazujący historię operacji (przyjęć, wydań i przesunięć) wykonanych na wszystkich asortymentach lub wybranej pozycji. Służy do wyjaśniania ewentualnych wątpliwości związanych ze stanem bieżącym całego magazynu lub konkretnego asortymentu.

Przed wydrukiem określamy:

  • Zakres

    • Data - zestawienie będzie zawierało obroty magazynowe zawierające się w wybranym tu okresie. Możemy wpisać dowolną datę z przeszłości, żeby sprawdzić obroty magazynowe na wybrany dzień.

      • Rok - rok, dla którego zostanie sporządzone zestawienie

      • Mies - miesiąc, w którym miały miejsce obroty magazynowe

      • Od, Do - pola te umożliwiają określenie dowolnego okresu, np. kwartału. Dostępne tylko, jeśli w polu Mies wybrano opcję Od - Do.

    • Asortyment - wypełniamy jeśli zestawienie ma być wykonane dla konkretnego asortymentu

    • Kontrahent - wypełniamy jeśli zestawienie ma być wykonane dla konkretnego kontrahenta

    • Magazyn - wypełniamy jeśli zestawienie ma dotyczyć konkretnego magazynu

    • Nr dostawy - wypełniamy jeśli zestawienie ma być wykonane dla konkretnego numeru dostawy

    • Pz - zaznaczamy jeśli zestawienie ma zawierać dokumenty przyjęcia magazynowego. W polu obok możemy zawęzić jakie dokładnie dokumenty mają zostać ujęte w zestawieniu wybierając konkretną definicję dokumentu.

    • Faktura/Wz - zaznaczamy jeśli zestawienie ma zawierać faktury i dokumenty wydania magazynowego. W polu obok możemy zawęzić jakie dokładnie dokumenty mają zostać ujęte w zestawieniu wybierając konkretną definicję dokumentu.

    • MM - zaznaczamy jeśli zestawienie ma zawierać dokumenty przesunięcia magazynowego. W polu obok możemy zawęzić jakie dokładnie dokumenty mają zostać ujęte w zestawieniu wybierając konkretną definicję dokumentu.

    • Tylko asortymenty z niezerowymi obrotami - zaznaczamy jeśli zestawienie ma uwzględniać tylko asortymenty z niezerowymi obrotami

  • Definicja

    • Typ

      • zbiorczy (bez rozbicia na dostawy) - każdy asortyment jest drukowany jako jedna pozycja. Jeśli towar pochodzi z kilku dostaw, to ilości z poszczególnych dostaw są sumowane a cena nabycia jest uśredniana.

      • szczegółowy (każda dostawa osobno) - każda dostawa jest drukowana jako osobna pozycja z wyszczególnieniem numeru dostawy i ceny nabycia dostawy. Jeśli dla danego asortymentu towar pochodzi z kilku dostaw, to będzie on występował na wydruku w kilku linijkach.

      • ilościowy - obroty magazynowe przedstawione są w ujęciu ilościowym

      • ilościowo-wartościowy - obok obrotu ilościowego widoczne są różnież jego wartości pieniężne

    • Cena - możemy sporządzić wydruk zawierający obroty magazynowe wg ceny nabycia, ewidencyjnej, sprzedaży - 1, sprzedaży - 2 i sprzedaży - 3. W przypadku ceny nabycia i wydruku zbiorczego, ceny nabycia będą średnimi cenami nabycia, wynikającymi z cen nabycia poszczególnych dostaw danego asortymentu.

    • Indeksy - jeśli chcemy na wydruku wyszczególnić indeksy asortymentowe, wybieramy wydruk z indeksem. W takim przypadku możemy dodatkowo określić Uporządkowanie asortymentów wg

      • nazw

      • indeksów

  • Nagłówek/Stopka - określamy nagłówek i stopkę wydruku. Korzystając z menu podręcznego (prawy klawisz myszy) możemy wstawić do treści nagłówka/stopki tekst, który zostanie zamieniony na odpowiednią wartości w trakcie wydruku:

    • {DB} - data bieżąca

    • {DEFINICJA} - ustawienia z zakładki Definicja

    • {ZAKRES} - ustawienia z zakładki Zakres.


RAPORTY

Zestawienie sprzedaży VAT

ZESTAWIENIA I STATYSTYKI - Zestawienia i raporty

Zestawienie sprzedaży VAT to raport z uproszczoną wersją rejestru vat (wydruk pionowy, jedna linijka odpowiada jednemu dokumentowi, możliwość wyboru stawek).

Przed wydrukiem w okienku Ewidencja sprzedaży VAT określamy:

  • Zakres

    • Okres od, do - zestawienie będzie sporządzone za wybrany tu okres. Możemy wpisać dowolny okres z przeszłości.

    • Oddział - wypełniamy jeśli zestawienie ma zostać wygenerowane dla konkretnego oddziału

  • Definicja

    • Agregowanie poszczególnych dni - jeśli chcemy drukować wszystkie wpisy z danego dnia jednym wpisem z sumą dokumentów w poszczególnych dniach.

    • Paragony jako sprzedaż dzienna - jeśli chcemy drukować paragony jednym wpisem z sumą paragonów w poszczególnych dniach. Wszystkie dokumenty inne niż paragony drukowane są pojedynczo. Wybierając tę opcję zaoszczędzimy papier na wydruk zestawienia oraz będzie ono bardziej przejrzyste.

    • Podział dokumentów na rodzaje - zestawienie zostanie sporządzone z podziałem na poszczególne rodzaje (definicje) dokumentów

    • Zapłacone dokumenty osobno - zestawienie zostanie wygenerowane z podziałem na dokumenty zapłacone i niezapłacone

    • Drukowanie stawek - możemy określić, które stawki Vat mają być uwzględnione podczas generowania zestawienia

      • 23%

      • 8%

      • 5%

      • Eksport towarów

      • Np

      • 0%

      • Vat zwolniony

      • WDT 0%

      • Eksport usług.


Metki

ZESTAWIENIA I STATYSTYKI - Zestawienia i raporty

W menu drukowania w oknie Asortymenty dostępna jest pozycja Metki.

Umożliwia ona wydrukowanie zestawienia nazw i cen wybranych asortymentów w postaci metek asortymentowych. Metki można przykleić na odpowiednich towarach lub w dowolnym innym miejscu w magazynie, wzorcowni itp.

Wygląd, rozmiar i zawartość metki zależy od wybranej makiety. Makietę określamy w menu głównym Ustawienia - Makiety dokumentów. Możemy wybrać jedną z kilku makiet proponowanych przez program. Jeśli żadna z nich nie odpowiada naszym potrzebom, możemy je dowolnie zmodyfikować lub utworzyć własną makietę. Wyboru właściwej makiety dokonujemy korzystając z przycisku Ustaw jako aktywną w oknie Makiety dokumentów.

Program proponuje makiety umożliwiające wydruk 14 wierszy po 4 metki na jednej kartce formatu A4. W handlu dostępny jest papier samoprzylepny A4 ponacinany właśnie na 14 wierszy po 4 kolumny. Makiety te są oznaczone symbolem 14x4. Makieta o nazwie Standard odpowiada makiecie Indeks, Nazwa, Netto, Vat - 14x4.

Dodatkowo przygotowano makiety do wydruku dużych metek w formacie 1 asortyment na 1 kartce A4. Takie makiety są oznaczone symbolem 1x1.

Przed wydrukiem określamy:

  • Zakres

    • Asortymenty - jakie asortymenty zostaną uwzględnione na wydruku

  • Definicja

    • Liczba wierszy, Liczba kolumn - ustawiamy odpowiednio do wybranej makiety.
      UWAGA. Dla makiet ... 14x4 ustawiamy 12 wierszy a nie 14. Ze względu na marginesy dolny i górny, wynikające z ograniczeń technicznych drukarki, nie jest możliwe prawidłowe zadrukowanie pierwszego i ostatniego wiersza.

    • Rozpocznij od - jeśli drukujemy na kartce z papierem samoprzylepnym, z której odkleiliśmy już wcześniej jakieś metki, to określamy tu numer pierwszej metki, którą można zadrukować.

UWAGA. Makieta odpowiada jednej metce. W czasie wydruku jest ona powielana tyle razy ile wybrano asortymentów. Przygotowując makietę należy określić odpowiednio marginesy wydruku. Ma to szczególne znaczenie, gdy chcemy się "wstrzelić" w odpowiednie miejsca na ponacinanym papierze samoprzylepnym. Np. w makietach standardowych ... 14x4 górny i dolny margines określono na 21 mm, bo taką wysokość ma jeden wiersz naklejek, którego nie jesteśmy w stanie zadrukować ze względu na marginesy drukarki. Z kolei marginesy lewy i prawy określono na 6 mm co odpowiada minimalnym marginesom drukarki. Jeśli nasza drukarka ma szersze marginesy, to należy je odpowiednio powiększyć w makiecie. Marginesy makiety określamy przyciskiem F4 (Właściwości) w czasie edycji makiety. Nie wolno ich zmieniać we właściwościach okna Przegląd wydruku.


Statystyka

ZESTAWIENIA I STATYSTYKI

Statystyka umożliwia szybkie sprawdzenie najważniejszych parametrów naszej firmy, tzn.: aktualnych obrotów, zapłat za terminowe faktury oraz stanu kasy i rachunków bankowych. Wykresy porównujące sprzedaż z bieżącego roku z poprzednim służą wykryciu tendencji występujących w naszej dotychczasowej działalności.

Okno ze statystyką wywołujemy z menu Raporty - Statystyka.

Dostępne dane podzielone są na dwie części:

  • Sprzedaż:

    • Do wyboru przychód lub zysk w poszczególnych miesiącach określany jest dla roku, do którego należy data bieżąca (kolor różowy) oraz z roku poprzedniego (kolor zielony). Z roku bieżącego uwzględniane są tylko miesiące do bieżącej daty włącznie, z poprzedniego roku brane są pod uwagę wszystkie miesiące.
      Ostatni wiersz tabelki zawiera podsumowanie Razem. Sposób obliczania podsumowania zależy od parametru [image] F4 Sprzedaż - Sumuj cały poprzedni rok. Jeśli jest on zaznaczony, to wiersz Razem w kolumnie dotyczącej poprzedniego roku zawiera sumę z całego roku. Podobnie wartości w kolumnach dotyczących wzrostu sprzedaży, policzone są jako różnica przychodu z bieżącego roku (do daty bieżącej) i przychodu za cały zeszły rok.
      Bardziej wartościowe informacje uzyskamy w wierszu Razem jeśli parametr Sumuj cały poprzedni rok będzie wyłączony. Wtedy podsumowanie poprzedniego roku będzie obliczone analogicznie jak podsumowanie bieżącego roku, czyli będzie uwzględniało tylko miesiące do miesiąca obejmującego taki sam dzień jak w dacie bieżącej. Dzięki temu kolumny ze wzrostem przychodów odnoszą się do analogicznych okresów roku bieżącego i poprzedniego.

    • W zależności od wyboru dokonanego powyżej PRZYCHÓD - WYKRESY lub ZYSK - WYKRESY tworzone są na podstawie wartości obliczonych w tabelce PRZYCHÓD lub ZYSK

  • Kasa/Bank

    • Należności - nieuregulowane na taki dzień jak data bieżąca należności (za faktury sprzedaży i ewentualnie korekty na minus faktur zakupu (PZ)) z podziałem na okresy przeterminowania. Dla porównania to samo na taki sam dzień z roku poprzedniego. Grupy na które podzielone są należności możemy zmienić we właściwościach okna [image] F4 określając odpowiedni podział. Jeśli chcielibyśmy sprawdzić z jakich faktur wynikają kwoty w poszczególnych grupach, możemy skorzystać z raportu Przeterminowane płatności.

    • Zobowiązania - nieuregulowane na taki dzień jak data bieżąca zobowiązania (za faktury zakupu (PZ) i ewentualnie korekty na minus faktur sprzedaży) z podziałem na okresy przeterminowania. Dla porównania to samo na taki sam dzień z roku poprzedniego.

    • KASA/BANK - stan kasy i rachunków bankowych na taki dzień jak data bieżąca i dla porównania na taki sam dzień z roku poprzedniego

    • PODSUMOWANIE - podsumowanie kondycji finansowej firmy na taki dzień jak data bieżąca, czyli: Kasa/Bank + Należności - Zobowiązania. Dla porównania na taki sam dzień z roku poprzedniego. Oczywiście należy mieć na względzie, że pełna kondycja finansowa firmy zależy również od zobowiązań związanych z fakturami kosztowymi, a tych informacji z oczywistych względów w programie nie ma.

  • Kategorie/Grupy - analiza sprzedaży z podziałem na kategorie lub grupy asortymentowe za bieżący i poprzedni rok. Równocześnie można w celach porównawczych pokazać statystykę z dwóch niezależnych kategorii/grup. Po dwukrotnym kliknięciu na wykresie pokaże się tabelka z wartościami, na podstawie których ten wykres został sporządzony.

Nic nie stoi na przeszkodzie, aby przed wywołaniem statystyki ustawić datę bieżąca na interesującą nas inną datę (np. z innego roku lub miesiąca) i właśnie dla niej sporządzić statystykę.

Okno STATYSTYKA może być otwarte niezależnie od innych okien programu. Jeśli od czasu otwarcia tego okna wprowadzono w programie jakieś dane lub zmieniono datę bieżącą, to można zaktualizować statystykę klikając w przycisk [image].

Dostęp do statystyki można ograniczyć wyłączając prawo Inne - Statystyka odpowiednim grupom użytkowników.

Okienko ze statystyką można wydrukować wciskając klawisz F2 lub klikając w ikonkę [image].


EKSPORT DANYCH

INSTRUKCJA UŻYTKOWNIKA

Program R2faktury współpracuje z programami księgowymi R2księga (księga przychodów i rozchodów lub ryczałt ewidencjonowany) i R2fk (pełna księgowość).

Współpraca polega na przesyłaniu informacji o wystawionych fakturach i RW oraz PZ (faktury zakupu), a także o płatnościach (raporty kasowe i bankowe).

Bazy danych programów R2faktury i R2księga/R2fk są oddzielnymi bazami, dlatego przesyłanie informacji pomiędzy tymi programami odbywa się za pośrednictwem plików buforowych, do których R2faktury najpierw eksportują dane, a później program księgowy te dane importuje.

Eksport danych powinien odbywać się w następującej kolejności:

  1. eksport faktur zakupu - PZ (patrz MAGAZYN - PRZYJĘCIA DO MAGAZYNU - Eksport PZ do programu księgowego)

  2. eksport faktur sprzedaży oraz RW (patrz SPRZEDAŻ - Eksport faktur do programu księgowego)

  3. eksport płatności (patrz KASA/BANK - Eksport raportów do programu księgowego).

Dane można eksportować raz na miesiąc lub częściej w dowolnym momencie - w zależności od potrzeb.

Aby opisany wyżej sposób wymiany dokumentów pomiędzy programami funkcjonował optymalnie warto zapoznać się z kilkoma uwagami:

  1. w związku z tym, że bazy programów R2faktury i R2księga/R2fk są odrębne, kontrahenci założeni w R2fakturach są w trakcie importu zakładani w bazie danych programu księgowego. Aby zachować spójność biblioteki kontrahentów należy dane kontrahentów (adresy, telefony, nip) modyfikować tylko w programie R2faktury. Przy imporcie dokumentów w programie księgowym dane kontrahentów zostaną zaktualizowane. Jeśli będziemy aktualizować dane kontrahentów tylko w programie księgowym, to zmienione dane nie będą widoczne w programie R2faktury, gdyż komunikacja odbywa się zawsze w kierunku od R2faktury do R2księga/R2fk, a nie odwrotnie. Dotyczy to również zakładania nowych kontrahentów. Wyjątkiem są kontrahenci kosztowi, którzy nie pojawiają się w ogóle w programie do fakturowania. Takich kontrahentów możemy jak najbardziej tworzyć i aktualizować w programie księgowym, chyba że w programie R2faktury księgujemy ich płatności - patrz poniżej.

  2. raporty kasowe i bankowe prowadzone w programie R2faktury powinny obejmować tylko i wyłącznie operacje związane z dokumentami wystawianymi w programie R2faktury, tzn. płatności do faktur sprzedaży i za faktury zakupu. Pozostałe operacje (wypłaty wynagrodzeń, zapłaty za faktury kosztowe) powinny się odbywać w ramach odrębnych raportów kasowych i/lub rachunków bankowych obsługiwanych bezpośrednio w programie księgowym. Odrębnych tzn. w przypadku raportów bankowych, związanych z odrębnymi rachunkami bankowymi, czyli jeden rachunek firmowy wykorzystujemy do zapłat za faktury kosztowe, wynagrodzenia itp., a drugi rachunek podajemy klientom, żeby wpłacali na niego należności za otrzymane faktury. Jeśli nie możemy lub nie chcemy skorzystać z takiego rozwiązania, to mamy dwie możliwości:

    • w programie do fakturowania należy wprowadzać również kontrahentów kosztowych i księgować im odpowiednie płatności na raportach. Po zaimportowaniu w R2księdze/R2fk raportów kasowych/bankowych należy w rozrachunkach tych kontrahentów skojarzyć płatności z zaksięgowanymi wcześniej fakturami kosztowymi. Jeśli prowadzimy pełną księgowość, to w przypadku pracowników i wypłaty wynagrodzeń możemy utworzyć pracowników jako kontrahentów i wskazywać ich na raporcie bankowym albo bezpośrednio na pozycjach raportu wskazywać konkretne konta, na które mają być zaksięgowane wynagrodzenia po imporcie w R2fk. W zaimportowanym w programie księgowym raporcie kasowym/bankowym nie można wprowadzać żadnych modyfikacji, za wyjątkiem ewentualnych korekt dekretów.

    • w R2fakturach wpisujemy tylko przychody związane z fakturami sprzedaży i rozchody wynikające z faktur zakupu. Taki raport eksportujemy do R2fk/R2księgi. Pozostałe operacje dopisujemy w tym raporcie bezpośrednio w R2fk/R2księdze.

  3. numery kont przy eksporcie do R2fk

    • sprzedaż i zakup - konta rozrachunkowe kontrahentów - grupa "2". Mamy dwie możliwości:

      • numery kont będą nadawane automatycznie przez program R2fk, w momencie księgowania pierwszej faktury sprzedaży(zakupu) dla(od) danego kontrahenta. Będą to subkonta kont syntetycznych określonych w R2fk w menu Ustawienia - Ustawienia kont na zakładce Ogólne jako Domyślne syntetyczne konto odbiorców oraz Domyślne syntetyczne konto dostawców. W takiej sytuacji nie określamy żadnych kont rozrachunkowych w programie R2faktury.
        Jest to rozwiązanie optymalne. Nie przejmujemy się w R2fakturach numerami kont rozrachunkowych poszczególnych kontrahentów, a w razie potrzeby możemy w programie R2fk w każdej chwili odszukać danego kontrahenta w bibliotece kontrahentów (wyszukując go po nr NIP lub skrócie nazwy) lub na planie kont (wyszukując konto po nazwie).

      • numery kont będziemy nadawać w programie R2faktury w bibliotece kontrahentów na zakładce FK. Ma to sens jedynie w przypadku nowych kontrahentów (takich, których nie ma jeszcze w programie R2fk). Jeśli program R2fk importując dane stwierdzi, że dany kontrahent jest już założony w R2fk (istnieje kontrahent z takim samym NIPem i/lub skrótem nazwy) i ma przypisane konta rozrachunkowe, to nie będzie tych kont zmieniał, czyli zignoruje konta określone w R2fakturach. Natomiast jeśli program R2fk stwierdzi, że takiego kontrahenta nie ma jeszcze w bibliotece, to utworzy go i założy mu konta rozrachunkowe o numerze zależnym od konfiguracji programu R2fk lub takim właśnie jaki określono w R2fakturach.
        Takie rozwiązanie ma sens jedynie przy rozpoczęciu pracy z programem, gdy chcemy pozakładać konta kontrahentów z takimi numerami jak w dotychczasowym systemie FK. W takiej sytuacji mamy jednak również dwie możliwości, bo jeśli przed rozpoczęciem pracy pozakładamy kontrahentów w programie R2fk z odpowiednimi numerami kont, to nie musimy ich określać w R2fakturach. Jeśli nie chcemy jednak zakładać kontrahentów w R2fk i chcemy żeby się pozakładali w trakcie importu z R2faktur, to konta nadajemy w bibliotece kontrahentów w R2faktury.

    • sprzedaż - konta sprzedaży - grupa "7" (Ma). Mamy trzy możliwości:

      • numer konta sprzedaży będzie nadawany automatycznie przez program R2fk. Będzie to konto określone w R2fk w menu Ustawienia - Ustawienia kont na zakładce Ogólne jako Domyślne konto sprzedaży lub w bibliotece kontrahentów przy danym kontrahencie jako Domyślne konto - sprzedaż. W takiej sytuacji kwoty wynikające z poszczególnych pozycji faktury nie będą rozdzielane, tylko jako jedna kwota pojawią się na określonym w R2fk koncie sprzedaży.
        Zaleta - nie trzeba nic określać w R2fakturach. Wada - brak możliwości analizy przychodów w R2fk.

      • numery kont sprzedaży będziemy nadawać w R2fakturach, dla każdej faktury, na zakładce FK w polu Konto sprzedaży. Możemy je tam wpisać bezpośrednio lub zostanie ustawione na podstawie takiego samego parametru określonego dla danego kontrahenta w bibliotece kontrahentów. Łączna wartość netto z faktury będzie księgowana na zadanym koncie bez względu na domyślne konta sprzedaży określone w R2fk.

      • numery kont sprzedaży będziemy nadawać w R2fakturach, ale nie dla każdej faktury, tylko dla każdej pozycji faktury. Dzięki temu każda pozycja faktury zostanie zaksięgowana na oddzielnym koncie umożliwiając dogłębną analizę struktury sprzedaży. Aby skorzystać z tej możliwości, musimy w trakcie eksportu danych zaznaczyć parametr Księguj każdą pozycję dokumentu osobno. Konta możemy określić albo w grupach asortymentowych (kolumna Konto sprz. - wtedy sprzedaż asortymentów należących do danej grupy będzie księgowana na koncie grupy), albo w asortymentach (Konto sprzedaży na zakładce FK - sprzedaż asortymentu będzie zawsze księgowana na jego koncie), albo bezpośrednio na pozycji faktury (Konto sprzedaży na zakładce FK - wtedy na każdej pozycji możemy określić dowolne konta, niezwiązane ani z asortymentem ani z grupą).

    • zakup - konta zakupów - grupa "3" (Wn). Podobnie jak przy koncie sprzedaży mamy trzy możliwości:

      • numer konta zakupów będzie nadawany automatycznie przez program R2fk - analogicznie jak przy opisanych wyżej kontach sprzedaży.

      • numery kont zakupów będziemy nadawać w R2fakturach, dla każdego PZ, na zakładce FK w polu Konto zakupów. Możemy je tam wpisać bezpośrednio lub zostanie ustawione na podstawie konta zakupów okreslonego w definicji PZ (na zakładce Zawartość) albo zostanie ustawione na podstawie takiego samego parametru określonego dla danego kontrahenta w bibliotece kontrahentów. Możemy korzystać z symbolu [M] oznaczającego konto określone w bibliotece magazynów dla magazynu wybranego na tym PZ.

      • numery kont zakupów będziemy nadawać w R2fakturach, ale nie dla każdego PZ, tylko dla każdej pozycji PZ. Jeśli konta zakupu określiliśmy w bibliotece asortymentów, to możemy dodatkowo przypisać je automatycznie do poszczególnych magazynów na jakie będzie przyjmowany dany asortyment. Tzn. jeśli w bibliotece asortymentów na zakładce FK określimy Konto zakupów jako np. [M]-123 i w bibliotece magazynów określiliśmy głowny numer konta danego magazynu (kolumna Konto zak.) jako np. 301 dla magazynu Główny oraz 302 dla magazynu Dodatkowy, to przyjęcie tego asortymentu na magazyn "Główny" zostanie zaksięgowane na koncie 301-123, a na magazyn "Dodakowy" na koncie 302-123.

    • rozchód wewnętrzny - konta zakupu - grupa "3" (Ma), konta kosztów - grupa "4" (Wn). W przypadku dokumentów RW musimy określić zawsze dwa konta. Konto zakupów, na którym rozchód zostanie zaksięgowany po stronie Ma (to samo konto na którym został przyjęty dany asortyment, tylko że przyjęcie było na nim księgowane po stronie Wn) oraz konto kosztów, na którym będziemy księgować po stronie Wn. Podobnie jak w opisanych wyżej przypadkach mamy trzy możliwości:

      • numer konta zakupów i kosztów będzie nadawany automatycznie przez program R2fk. Będą to konta określone w R2fk w menu Ustawienia - Ustawienia kont na zakładce Ogólne jako Import RW Wn oraz Import RW Ma. W takiej sytuacji kwoty wynikające z poszczególnych pozycji RW nie będą rozdzielane, tylko jako jedna kwota pojawią się na określonych w R2fk kontach.

      • numery kont zakupów i kosztów będziemy nadawać w R2fakturach, dla każdego RW, na zakładce FK w polach Konto zakupów i Konto kosztów. Konto zakupów zostanie ustawione na podstawie konta zakupów określonego w definicji RW (na zakładce Zawartość), ale można je równiez określić ręcznie. Łączna wartość RW będzie księgowana na zadanym koncie bez względu na domyślne konta określone w R2fk.

      • numery kont zakupów i kosztów będziemy nadawać w R2fakturach, ale nie dla każdego RW, tylko dla każdej pozycji RW. Dzięki temu każda pozycja RW zostanie zaksięgowana na oddzielnym koncie. Aby skorzystać z tej możliwości, musimy w trakcie eksportu danych zaznaczyć parametr Księguj każdą pozycję dokumentu osobno. Konta możemy określić albo w grupach asortymentowych (kolumny Konto zak., Konto koszt.), albo w asortymentach (Konto zakupów, Konto kosztów na zakładce FK), albo bezpośrednio na pozycji RW (Konto zakupów, Konto kosztów na zakładce FK. W przypadku konta zakupów możemy korzystać z zakodowanego symbolu konta magazynu [M], analogicznie jak w przypadku konta zakupów na PZ.


URZĄDZENIA ZEWNĘTRZNE

INSTRUKCJA UŻYTKOWNIKA

Program R2faktury współpracuje z różnymi urządzeniami zewnętrznymi, z którymi potrafi wymieniać informacje.

Są to:

  • drukarki i kasy fiskalne opisane w rozdziale SPRZEDAŻ - Urządzenia fiskalne

  • kolektory danych opisane w rozdziałach ELZAB Kolektor CE i ARGOX Kolektor.

Współpraca programu R2fakturyPRO z kolektorami danych

Tam gdzie priorytetem jest mobilność i niezależność idealnym rozwiązaniem jest kolektor danych (terminal mobilny). Urządzenia tego typu zawierają laserowy czytnik kodów kreskowych oraz odpowiednie oprogramowanie, które umożliwia łatwe zbieranie i przetwarzanie danych.

Pracownik, dzięki posiadaniu przenośnego skanera kodów kreskowych z pamięcią danych, nie musi już przemieszczać wydawanych lub przyjmowanych przedmiotów w pobliże komputera ze stacjonarnym czytnikiem kodów kreskowych. Może poruszać się swobodnie po magazynie, rampie załadunkowej lub całym terenie firmy by skanować kody kreskowe i wprowadzać ilości.

Po wprowadzeniu danych do kolektora następuje synchronizacja z programem magazynowym oraz wystawienie stosownego dokumentu magazynowego. Dzięki takiemu rozwiązaniu oszczędzamy czas i zmniejszamy ryzyko pomyłek. Jeżeli zatem prowadzimy komputerową ewidencję stanów magazynowych w kilku magazynach np. oddalonych od siebie, bądź magazyn, w którym pracujemy oddalony jest od komputera zawierającego oprogramowanie magazynowe, pomocne będzie wykorzystanie kolektora danych.

Współpraca z kolektorami danych dostępna jest tylko w wersji PRO.


ELZAB Kolektor CE

URZĄDZENIA ZEWNĘTRZNE

Program [image] współpracuje z programem ELZAB Kolektor CE, który jest dostarczany wraz z wieloma kolektorami dostępnymi na rynku. Dzięki temu za pomocą tego samego mechanizmu możemy współpracować z urządzeniami, które najbardziej odpowiadają naszym potrzebom.

Wymiana danych między programem magazynowym i kolektorem odbywa się poprzez tzw. serwer terminali, który instaluje się wraz z programem ELZAB Kolektor CE. Aby połączyć kolektor danych z serwerem terminali trzeba jedynie wprowadzić do programu w kolektorze atrybuty gniazda serwera: adres sieciowy (IP) i numer portu (identyfikujący proces). Współpraca kolektora z komputerem może odbywać się niezależnie od rodzaju połączenia (np. WiFi, USB...). Serwer terminali umożliwia współpracę programu magazynowego z wieloma kolektorami, zapewnia jednoczesną obsługę wielu baz towarowych i wielu dokumentów. Dokumenty utworzone na kolektorach danych można przesyłać na serwer terminali bez konieczności uruchomienia funkcji ich pobierania w programie magazynowym, ponieważ program magazynowy może je wczytać dopiero wtedy, kiedy będzie ich potrzebował. Użytkownik chcąc wczytać konkretny dokument z serwera terminali do swojego programu, wybiera go z listy przesłanych na serwer dokumentów. Zawartość każdego z dokumentów oczekujących na serwerze terminali można obejrzeć przed pobraniem go do programu magazynowego.

UWAGA. Cały obieg informacji odbywa się poprzez serwer terminali. Do serwera wysyłamy bazę danych towarów, następnie bazę tą z serwera importujemy na kolektor danych, dzięki czemu możemy rozpocząć pracę z kolektorem. Po zakończeniu pracy z kolektorem dane zawarte na urządzeniu należy przesłać do serwera terminali. W następnym kroku będą one pobrane z serwera terminali do programu [image] i na ich podstawie zostaną utworzone odpowiednie dokumenty magazynowe. Obieg informacji przedstawia poniższy rysunek.

Aby uzyskać dostęp do modułu obsługującego komunikację z programem ELZAB Kolektor CE, należy wybrać z menu głównego opcję Zbiory - Urządzenia zewnętrzne - ELZAB Kolektor CE.

Ukaże się wówczas okno Elzab Kolektor CE, które pozwala na wybór spośród następujących możliwości:

  • Odczytaj z urządzenia - odczyt danych z urządzenia

  • Wyślij na urządzenie - wysyłka danych na urządzenie

  • Konfiguracja - konfiguracja parametrów wymiany danych pomiędzy ELZAB kolektor CE a programem R2fakturyPRO.

  • Zamknij - zakończenie pracy modułu.

Współpraca z programem ELZAB kolektor dostępna jest tylko w wersji PRO.


Odczyt danych

URZĄDZENIA ZEWNĘTRZNE - ELZAB Kolektor CE

Po odpowiednim skonfigurowaniu pliku wymiany danych można przystąpić do odczytu danych z urządzenia. W tym celu należy w oknie ELAZB Kolektor CE wybrać opcję Odczytaj z urządzenia. Ukaże się wówczas okno Odczytaj z urządzenia ELZAB Kolektor CE, w którym musimy określić:

  • Podaj nazwę pliku do odczytu danych z urządzenia - lokalizacja i nazwa pliku zawierającego dane wyeksportowane z serwera terminali, np. C:\RESET2\dane.txt. Plik ten można również odnaleźć klikając [image]. Przycisk Podgląd umożliwia obejrzenie zawartości wybranego pliku.
    UWAGA. Plik z danymi importowanymi z serwera terminali powinien być kodowany w formacie UTF-8.

  • Zawartość pliku - dokumenty, które chcemy zaimportować do programu.

    Magazyny podane w kolumnach Magazyn oraz Magazyn źródłowy określane są na podstawie nazwy importowanych dokumentów oraz ustawień domyślnych w konfiguracji. Przed rozpoczęciem odczytu można je zmienić na inne.

    W przypadku dokumentu INW w kolumnie Nr arkusza INW wybieramy numer przygotowanego wcześniej arkusza inwentaryzacyjnego, do którego będziemy wczytywać z kolektora stan faktyczny.

    Jeśli w pliku znajduje się więcej niż jeden dokument, to do szybkiego określenia wybranych do importu dokumentów można wykorzystać przyciski Zaznacz wszystkie i Odznacz wszystkie.

Po kliknięciu w przycisk Start w programie zostaną utworzone zaznaczone dokumenty. Po pomyślnym imporcie w pliku wymiany danych zostaną tylko pozycje dotyczące niezaznaczonych dokumentów lub dotyczące dokumentów, przy których wystąpił w trakcie odczytu jakiś błąd.

Współpraca z programem ELZAB kolektor dostępna jest tylko w wersji PRO.


Wysyłka danych

URZĄDZENIA ZEWNĘTRZNE - ELZAB Kolektor CE

Przed rozpoczęciem tworzenia dokumentów na kolektorze warto wysłać na niego listę asortymentów, które później będą skanowane. W tym celu należy skorzystać z opcji Wyślij na urządzenie dostępnej w oknie ELZAB Kolektor CE.

W oknie Wyślij na urządzenie ELZAB Kolektor CE określamy:

  • Podaj nazwę pliku do zapisu danych na urządzenie - lokalizacja i nazwa pliku zawierającego dane wyeksportowane do serwera terminali, np. C:\RESET2\baza.txt. Plik ten można również odnaleźć klikając [image]. Przycisk Podgląd umożliwia obejrzenie zawartości wybranego pliku.
    UWAGA. Plik z danymi eksportowanymi z programu [image] do serwera terminali będzie kodowany w formacie UTF-8.

  • Zakres pozycji - mamy do wyboru 3 sposoby określenia zakresu eksportowanych pozycji:

    • takie jak w oknie - tylko pozycje widoczne aktualnie w oknie, czyli spełniające aktualnie wybrane ustawienia filtrowania określone we właściwościach [image] F4 okna

    • tylko podświetlone - tylko pozycje, które są aktualnie podświetlone w oknie (bez względu na to czy w oknie pokazywane są wszystkie, czy tylko podświetlone pozycje)

    • wszystkie - wszystkie pozycje niezależnie od filtrów i podświetleń.

    UWAGA. Opcje dostępne są tylko wówczas, gdy przed wywołaniem wysyłki danych otwarte zostało okienko Asortymenty.

Po kliknięciu w przycisk Start zostanie utworzony plik tekstowy, który można za pomocą serwera terminali przesłać na kolektor.

Współpraca z programem ELZAB kolektor dostępna jest tylko w wersji PRO.


Konfiguracja

URZĄDZENIA ZEWNĘTRZNE - ELZAB Kolektor CE

Przed przystąpieniem do wymiany danych należy wstępnie przygotować odpowiednie biblioteki oraz skonfigurować plik wymiany danych korzystając z przycisku Konfiguracja. Ukaże się wówczas okno Konfiguracja ELZAB Kolektor CE, w którym określamy:

  • Prefiksy dokumentów
    Skanowane asortymenty możemy zapisywać na kolektorze w osobnych dokumentach. Dokument ma swoją nazwę oraz listę zeskanowanych pozycji zawierającą kod kresowy oraz ilość. W nazwie dokumentu musimy podać jego typ oraz magazyn, którego dokument dotyczy. Wpisujemy np. MM-SKLEP2, co oznacza dokument MM (prefiks MM-) przesuwający skanowane pozycje z domyślnego magazynu na magazyn SKLEP2. Listę dokumentów, które chcemy tworzyć przy pomocy kolektora określamy właśnie tutaj.

    • Rodzaj - rodzaj dokumentu jaki zostanie utworzony

      • MM - przesunięcie pomiędzy magazynem głównym (Domyślny magazyn główny...) a magazynem określonym w nazwie dokumentu (po prefiksie)

      • PG - paragon z towarem z magazynu określonego w nazwie dokumentu

      • PZ - przyjęcie na magazyn określony w nazwie dokumentu

      • WZ - wydanie z magazynu określonego w nazwie dokumentu

      • INW - stan faktyczny towarów z arkusza inwentaryzacyjnego, którego numer podamy w trakcie odczytu danych

      • PGI - paragon na podstawie inwentaryzacji. Na paragonie znajdą się różnice pomiędzy stanem bieżącym w magazynie określonym w nazwie dokumentu a zeskanowanymi pozycjami. Np. w programie na magazyn SKLEP1 zostały przesunięte dokumentem MM asortymenty: towar A w ilości 7 szt i towar B w ilości 2 szt. W importowanym pliku znajduje się jeden dokument dotyczący magazynu SKLEP1, z prefiksem PGI, zawierający tylko asortyment towar A w ilości 3 szt. W takiej sytuacji program utworzy Paragon zawierający dwie pozycje: towar A w ilości 4 szt oraz towar B w ilości 2 szt.

    • Dokument - wskazujemy definicję dokumentu, która będzie użyta przy jego wystawianiu

    • Prefiks - symbol używany do identyfikacji poszczególnych rodzajów dokumentów tworzonych przez kolektor. W celu ułatwienia i przyspieszenia pracy można wydrukować w postaci kodu kreskowego gotową etykietę identyfikującą konkretny dokument dla wybranego magazynu, dzięki czemu potem wystarczy ją zeskanować rozpoczynając tworzenie dokumentu. Etykieta taka będzie się składała z prefiksu dokumentu i nazwy magazynu. Więcej na temat wydruku etykiet z kodami kreskowymi w rozdziale BIBLIOTEKI - Magazyny.

  • Domyślny magazyn główny przy dokumentach MM - magazyn źródłowy podczas wystawiania dokumentów MM. Wyboru dokonujemy spośród magazynów zdefiniowanych w bibliotece magazynów.

  • Kod kreskowy będzie pobierany z pola o nazwie - podajemy pole, w którym wprowadzaliśmy kody kreskowe asortymentów:

    • Indeks

    • Indeks1

    • Indeks2

  • Pola w pliku wymiany danych:

    • Dostępne - lista pól dostępnych w pliku wymiany danych. Przyciskiem [image] przenosimy podświetlone pole na koniec znajdującej się obok listy Aktywne

    • Aktywne - lista aktywnych, tzn. wybranych pól. Przyciskiem [image] możemy usunąć podświetlone pole. Klikając w przyciski [image] / [image] możemy zmienić pozycję (wyżej/niżej) podświetlonego pola na liście aktywnych pól.
      UWAGA. Pola Kod kreskowy, Ilość oraz Nazwa dokumentu(asortymentu) są polami obowiązkowymi tzn., że nie mogą być usuwane z listy Aktywnych pól.

  • Znaki oddzielające w pliku wymiany danych - należy określić jakim znakiem będzie oddzielony prefiks od nazwy magazynu.

Wprowadzone dane akceptujemy przyciskiem [image].

Współpraca z programem ELZAB kolektor dostępna jest tylko w wersji PRO.


ARGOX Kolektor

URZĄDZENIA ZEWNĘTRZNE

Program [image] współpracuje z programem INWENTARYZATOR firmy Koncept-L, który jest dostarczany wraz z kolektorami PT-20 i PA-20 firmy ARGOX. Dzięki temu za pomocą tego samego mechanizmu możemy współpracować z urządzeniem, które najbardziej odpowiada naszym potrzebom.

Wymiana danych między programem magazynowym i kolektorem może odbywać się bezpośrednio z poziomu programu [image] lub poprzez uniwersalne oprogramowanie dostarczone przez firmę Koncept-L wraz z kolektorem danych. Do pliku wysyłamy bazę danych towarów, następnie bazę tą z pliku importujemy na kolektor danych korzystając z opcji dostępnych na urządzeniu, dzięki czemu możemy rozpocząć pracę z kolektorem. Po zakończeniu pracy z kolektorem dane zawarte na urządzeniu należy przesłać do programu [image] i na ich podstawie zostaną utworzone odpowiednie dokumenty magazynowe. Współpraca kolektora z komputerem następuje przy pomocy dostarczonego wraz z urządzeniem kabla komunikacyjnego poprzez port USB.

Instalacja kolektora PT-20 polega na podłączeniu go do komputera oraz skopiowaniu plików 232_READ.EXE, DLOOKUP.EXE oraz KONCEPT.INI z dostarczonej wraz z urządzeniem płyty z katalogu Instrukcje\KONCEPT-L\R2fakturyPRO\pliki do wybranego folderu, np. C:\RESET2\ARGOX. Następnie folder ten należy wskazać w polu Folder plików ARGOX Kolektor dostępnym w oknie Konfiguracja ARGOX Kolektor. Więcej na ten temat w rozdziale URZĄDZENIA ZEWNĘTRZNE - ARGOX Kolektor - Konfiguracja.

Aby uzyskać dostęp do modułu obsługującego komunikację z Kolektorem ARGOX PT-20, należy wybrać z menu głównego opcję Zbiory - Urządzenia zewnętrzne - ARGOX Kolektor.

Ukaże się wówczas okno ARGOX Kolektor, które pozwala na wybór spośród następujących możliwości:

  • Odczytaj z urządzenia - odczyt danych z urządzenia

  • Wyślij na urządzenie - wysyłka danych na urządzenie

  • Konfiguracja - konfiguracja parametrów wymiany danych pomiędzy ARGOX PT-20 (Koncept-L) a programem R2fakturyPRO.

  • Zamknij - zakończenie pracy modułu.

Współpraca z Kolektorem ARGOX PT-20 (Koncept-L) dostępna jest tylko w wersji PRO.


Odczyt danych

URZĄDZENIA ZEWNĘTRZNE - ARGOX Kolektor

Po odpowiednim skonfigurowaniu pliku wymiany danych można przystąpić do odczytu danych z urządzenia. W tym celu w oknie ARGOX Kolektor wybieramy opcję Odczytaj z urządzenia. Ukaże się okno Potwierdzenie, wówczas przed naciśnięciem TAK należy z menu głównego kolektora wybrać opcję: 2. Transmisja, aby dane zostały pobrane bezpośrednio z urządzenia do programu [image]. Jeśli użytkownik wybierze opcję NIE program umożliwi samodzielne wskazanie pliku z danymi.

Następnie w oknie Odczytaj z urządzenia ARGOX Kolektor musimy określić:

  • Podaj nazwę pliku do odczytu danych z urządzenia - lokalizacja i nazwa pliku zawierającego dane wyeksportowane z kolektora, domyślnie podstawi się C:\RESET2\dane.txt. Przycisk Podgląd umożliwia obejrzenie zawartości wybranego pliku.
    UWAGA. Pole to jest istotne tylko jeśli użytkownik nie korzysta z bezpośredniej wymiany danych pomiędzy kolektorem a programem, wówczas należy samodzielne wskazać plik z danymi (można go odnaleźć klikając [image]). Plik ten należy wcześniej przygotować poprzez odczyt danych z kolektora za pomocą mechanizmu dostępnego po uniwersalnej instalacji urządzenia.

  • Zawartość pliku - dokumenty, które chcemy zaimportować do programu.

    Magazyny podane w kolumnach Magazyn oraz Magazyn źródłowy określane są na podstawie nazwy importowanych dokumentów oraz ustawień domyślnych w konfiguracji. Przed rozpoczęciem odczytu można je zmienić na inne.

    W przypadku dokumentu INW w kolumnie Nr arkusza INW wybieramy numer przygotowanego wcześniej arkusza inwentaryzacyjnego, do którego będziemy wczytywać z kolektora stan faktyczny.

    Jeśli w pliku znajduje się więcej niż jeden dokument, to do szybkiego określenia wybranych do importu dokumentów można wykorzystać przyciski Zaznacz wszystkie i Odznacz wszystkie.

    UWAGA. Kolektor PT-20 nie posiada w menu opcji identyfikującej dokument na jaki chcemy nanosić asortymenty wczytywane na urządzenie. Z tego względu przed zeskanowaniem pierwszego asortymentu dla danego dokumentu należy określić rodzaj dokumentu skanując jego kod. W celu ułatwienia i przyspieszenia pracy gotową etykietę identyfikującą konkretny dokument dla wybranego magazynu można wydrukować w postaci kodu kreskowego. Etykieta taka będzie się składała z prefiksu dokumentu i nazwy magazynu. Więcej na temat wydruku etykiet z kodami kreskowymi w rozdziale BIBLIOTEKI - Magazyny.

Po kliknięciu w przycisk Start w programie zostaną utworzone zaznaczone dokumenty. Po pomyślnym imporcie w pliku wymiany danych zostaną tylko pozycje dotyczące niezaznaczonych dokumentów lub dotyczące dokumentów, przy których wystąpił w trakcie odczytu jakiś błąd.

Współpraca z Kolektorem ARGOX PT-20 (Koncept-L) dostępna jest tylko w wersji PRO.


Wysyłka danych

URZĄDZENIA ZEWNĘTRZNE - ARGOX Kolektor

Przed rozpoczęciem tworzenia dokumentów na kolektorze warto wysłać na niego listę asortymentów, które później będą skanowane. W tym celu należy skorzystać z opcji Wyślij na urządzenie dostępnej w oknie ARGOX Kolektor.

W oknie Wyślij na urządzenie ARGOX Kolektor określamy:

  • Podaj nazwę pliku do zapisu danych na urządzenie - lokalizacja i nazwa pliku zawierającego dane wyeksportowane do kolektora, domyślnie podstawi się C:\RESET2\baza.txt. Przycisk Podgląd umożliwia obejrzenie zawartości wybranego pliku.
    UWAGA. Pole to jest istotne tylko jeśli użytkownik nie korzysta z bezpośredniej wymiany danych pomiędzy kolektorem a programem, wówczas należy samodzielne wskazać plik do zapisu danych (można go odnaleźć klikając [image]). Plik ten należy później wczytać do kolektora za pomocą mechanizmu dostępnego po uniwersalnej instalacji urządzenia.

  • Zakres pozycji - mamy do wyboru 3 sposoby określenia zakresu eksportowanych pozycji:

    • takie jak w oknie - tylko pozycje widoczne aktualnie w oknie, czyli spełniające aktualnie wybrane ustawienia filtrowania określone we właściwościach [image] F4 okna

    • tylko podświetlone - tylko pozycje, które są aktualnie podświetlone w oknie (bez względu na to czy w oknie pokazywane są wszystkie, czy tylko podświetlone pozycje)

    • wszystkie - wszystkie pozycje niezależnie od filtrów i podświetleń.

    UWAGA. Opcje dostępne są tylko wówczas, gdy przed wywołaniem wysyłki danych otwarte zostało okienko Asortymenty.

Po kliknięciu w przycisk Start zostanie utworzony plik tekstowy, gotowy do przesłania na kolektor, po czym pojawi się okno Potwierdzenie. Przed naciśnięciem TAK należy z menu głównego kolektora wybrać opcję: 2. Transmisja, aby dane zostały wczytane bezpośrednio do urządzenia. Jeśli użytkownik wybierze opcję NIE wówczas program tylko utworzy pliczek z danymi.

Współpraca z Kolektorem ARGOX PT-20 (Koncept-L) dostępna jest tylko w wersji PRO.


Konfiguracja

URZĄDZENIA ZEWNĘTRZNE - ARGOX Kolektor

Przed przystąpieniem do wymiany danych należy wstępnie przygotować odpowiednie biblioteki oraz skonfigurować plik wymiany danych korzystając z przycisku Konfiguracja. Ukaże się wówczas okno Konfiguracja ARGOX Kolektor, w którym określamy:

  • Prefiksy dokumentów
    Skanowane asortymenty możemy zapisywać na kolektorze w osobnych dokumentach. Dokument ma swoją nazwę oraz listę zeskanowanych pozycji zawierającą kod kresowy oraz ilość. W nazwie dokumentu musimy podać jego typ oraz magazyn, którego dokument dotyczy. Wpisujemy np. MM-SKLEP2, co oznacza dokument MM (prefiks MM-) przesuwający skanowane pozycje z domyślnego magazynu na magazyn SKLEP2. Listę dokumentów, które chcemy tworzyć przy pomocy kolektora określamy właśnie tutaj.

    • Rodzaj - rodzaj dokumentu jaki zostanie utworzony

      • MM - przesunięcie pomiędzy magazynem głównym (Domyślny magazyn główny...) a magazynem określonym w nazwie dokumentu (po prefiksie)

      • PG - paragon z towarem z magazynu określonego w nazwie dokumentu

      • PZ - przyjęcie na magazyn określony w nazwie dokumentu

      • WZ - wydanie z magazynu określonego w nazwie dokumentu

      • INW - stan faktyczny towarów z arkusza inwentaryzacyjnego, którego numer podamy w trakcie odczytu danych

      • PGI - paragon na podstawie inwentaryzacji. Na paragonie znajdą się różnice pomiędzy stanem bieżącym w magazynie określonym w nazwie dokumentu a zeskanowanymi pozycjami. Np. w programie na magazyn SKLEP1 zostały przesunięte dokumentem MM asortymenty: towar A w ilości 7 szt i towar B w ilości 2 szt. W importowanym pliku znajduje się jeden dokument dotyczący magazynu SKLEP1, z prefiksem PGI, zawierający tylko asortyment towar A w ilości 3 szt. W takiej sytuacji program utworzy Paragon zawierający dwie pozycje: towar A w ilości 4 szt oraz towar B w ilości 2 szt.

    • Dokument - wskazujemy definicję dokumentu, która będzie użyta przy jego wystawianiu

    • Prefiks - symbol używany do identyfikacji poszczególnych rodzajów dokumentów tworzonych przez kolektor. W celu ułatwienia i przyspieszenia pracy można wydrukować w postaci kodu kreskowego gotową etykietę identyfikującą konkretny dokument dla wybranego magazynu, dzięki czemu potem wystarczy ją zeskanować rozpoczynając tworzenie dokumentu. Etykieta taka będzie się składała z prefiksu dokumentu i nazwy magazynu. Więcej na temat wydruku etykiet z kodami kreskowymi w rozdziale BIBLIOTEKI - Magazyny.

  • Domyślny magazyn główny przy dokumentach MM - magazyn źródłowy podczas wystawiania dokumentów MM. Wyboru dokonujemy spośród magazynów zdefiniowanych w bibliotece magazynów.

  • Kod kreskowy będzie pobierany z pola o nazwie - podajemy pole, w którym wprowadzaliśmy kody kreskowe asortymentów:

    • Indeks

    • Indeks1

    • Indeks2

  • Domyślny kontrahent na dokumentach Pz/Wz - kontrahent, który będzie podstawiany na odczytywanych dokumentach Pz/Wz

  • Blokuj Pz po odczycie - znacznik, określający czy pozycje z tego PZ będą widoczne w oknie Stan magazynu, a co za tym idzie czy będzie można na nich wykonywać operacje magazynowe (wydania, przesunięcia), czy też będą zablokowane, tzn. przyjęte, ale jeszcze nie będzie można na nich wykonywać operacji magazynowych

  • Pola w pliku wymiany danych:

    • Dostępne - lista pól dostępnych w pliku wymiany danych. Przyciskiem [image] przenosimy podświetlone pole na koniec znajdującej się obok listy Aktywne

    • Aktywne - lista aktywnych, tzn. wybranych pól. Przyciskiem [image] możemy usunąć podświetlone pole. Klikając w przyciski [image] / [image] możemy zmienić pozycję (wyżej/niżej) podświetlonego pola na liście aktywnych pól.
      UWAGA. Pola Kod kreskowy, Ilość oraz Nazwa dokumentu(asortymentu) są polami obowiązkowymi tzn., że nie mogą być usuwane z listy Aktywnych pól.

  • Znaki oddzielające w pliku wymiany danych - należy określić jakim znakiem będzie oddzielony prefiks od nazwy magazynu.

  • Folder plików ARGOX Kolektor - należy określić w jakim folderze znajdują się pliki umożliwiające bezpośrednią wymianę danych pomiędzy kolektorem a programem. Instalacja kolektora PT-20 polega na podłączeniu go do komputera oraz skopiowaniu plików 232_READ.EXE, DLOOKUP.EXE oraz KONCEPT.INI z dostarczonej wraz z urządzeniem płyty z katalogu Instrukcje\KONCEPT-L\R2fakturyPRO\pliki do wybranego folderu, np. C:\RESET2\ARGOX. Program [image] nie pozwoli w tym polu wskazać ścieżki do katalogu, do którego wcześniej nie skopiowano odpowiednich plików.
    UWAGA. Jeśli użytkownik nie skopiował wskazanych plików, wymiana danych pomiędzy kolektorem a programem możliwa będzie, po uniwersalnej instalacji urządzenia, na zasadzie ręcznego wskazywania plików wymiany danych.

Wprowadzone dane akceptujemy przyciskiem [image].

Kolektor jest gotowy do pracy bez żadnych dodatkowych ustawień.

UWAGA. Kolektor PT-20 nie posiada w menu opcji identyfikującej dokument na jaki chcemy nanosić asortymenty skanowane przez urządzenie. Z tego względu przed zeskanowaniem pierwszego asortymentu dla danego dokumentu należy określić rodzaj dokumentu skanując jego kod. W celu ułatwienia i przyspieszenia pracy gotową etykietę identyfikującą konkretny dokument dla wybranego magazynu można wydrukować w postaci kodu kreskowego. Etykieta taka będzie się składała z prefiksu dokumentu i nazwy magazynu. Więcej na temat wydruku etykiet z kodami kreskowymi w rozdziale BIBLIOTEKI - Magazyny.

Współpraca z Kolektorem ARGOX PT-20 (Koncept-L) dostępna jest tylko w wersji PRO.


Instrukcja administratora

Dokumentacja dotyczy następujących systemów:

  • - podstawowy system serii STANDARD zalecany dla małych i średnich firm oraz dla biur rachunkowych.
    UWAGA. Brak kolorowej linii z lewej strony dokumentracji oznacza, że opis dotyczy wszystkich systemów, czyli serii STANDARD i PRO.

  • - rozbudowany system serii PRO rekomendowany dla średnich i dużych przedsiębiorstw oraz dla prężnie rozwijających się małych firm.

    UWAGA. Czerwona linia z lewej strony dokumentacji oznacza, że opis dotyczy tylko systemu serii PRO.

Pełna dokumentacja systemów zawiera:

  • SZYBKI START - skrócona instrukcja obsługi pozwalająca na szybkie rozpoczęcie pracy

  • INSTRUKCJA UŻYTKOWNIKA - zagadnienia związane z obsługą systemu podczas codziennej pracy

  • INSTRUKCJA ADMINISTRATORA - zagadnienia związane z instalacją systemu, wdrożeniem, parametryzacją i nadzorem podczas pracy.

Dołożyliśmy wszelkich starań, by zawarte w dokumentacji informacje opisywały rzetelnie i kompletnie działanie programu, jednakże nie możemy zagwarantować, że instrukcja zaspokoi wszystkie wymagania użytkownika programu oraz że nie zawiera błędów.

W trosce o niezawodność oprogramowania, jego wysoki poziom techniczny oraz zgodność ze zmieniającym sie stanem prawnym zastrzegamy sobie prawo do aktualizowania w pierwszej kolejności programu, a dopiero potem jego dokumentacji.

(C) RESET2 Sp.z o.o. - wszystkie prawa zastrzeżone, łącznie z prawem do reprodukcji części lub całości publikacji w jakiejkolwiek formie.


Wstęp

INSTRUKCJA ADMINISTRATORA

INSTRUKCJA ADMINISTRATORA podzielona została tematycznie na rozdziały, zawierające następujące zagadnienia:

  • Wymagania systemowe

  • Instalowanie programu - instalacja programu, założenie bazy danych, wczytanie licencji oraz import danych początkowych

  • Parametryzacja systemu - użytkownicy oraz parametry związane ze środowiskiem i pracą całego systemu

  • Bezpieczeństwo danych - zabezpieczenie, pielęgnacja i serwisowanie bazy danych

  • Załączniki - specyfikacje plików wymiany danych.

Zagadnienia związane z obsługą systemu podczas codziennej pracy zawarte zostały w INSTRUKCJI UŻYTKOWNIKA.

W trosce o niezawodność oprogramowania, jego wysoki poziom techniczny oraz zgodność ze zmieniającym sie stanem prawnym zastrzegamy sobie prawo do aktualizowania w pierwszej kolejności programu, a dopiero potem jego dokumentacji.


Wymagania systemowe

WSTĘP

Minimalna konfiguracja komputera niezbędna do uruchomienia programu R2faktury to:

  • system operacyjny Windows (8, 7, Vista lub XP)
  • procesor z zegarem przynajmniej 1 GHz
  • pamięć operacyjna RAM: przynajmniej 512 MB
  • przynajmniej 300 MB wolnego miejsca na dysku twardym
  • stacja CD-ROM lub DVD-ROM
  • dostęp do internetu (wczytanie licencji, pobieranie aktualizacji)
  • monitor i karta graficzna o rozdzielczości min. 1024x768
  • drukarka laserowa lub atramentowa.

Zalecana konfiguracja do wydajnej pracy sieciowej przy dużej ilości faktur i innych dokumentów, to:

  • procesor dwurdzeniowy z zegarem przynajmniej 2GHz,
  • pamięć operacyjna RAM 2GB,
  • stabilny system operacyjny, najlepiej Windows 8, 7, Vista lub XP
  • karta i osprzęt sieciowy w technologii 1Gb lub przynajmniej 100Mb.
  • do drukowania dokumentów (faktury, PZ, MM, WZ, RW, RK, KP, KW, potwierdzenie sald) można - zamiast drukarki laserowej lub atramentowej - użyć drukarki igłowej w trybie znakowym (patrz ROZPOCZĘCIE PRACY - Okno główne - Przegląd wydruku - Wydruki znakowe).

Połączenie internetowe.
Jeśli w trakcie pracy z programem napotkamy błędy przy próbie korzystania z funkcji internetowych programu, należy się przyjrzeć konfiguracji połączenia internetowego.

Jeśli na komputerze zainstalowane jest oprogramowanie zapory internetowej (firewall), to należy:

  • upewnić się, czy program zapory nie wpisał programu Rfaktury.exe na listę programów z zablokowanym dostępem do internetu

  • skonfigurować program zapory tak, żeby były dostępne odpowiednie porty i możliwość połączenia z konkretnymi numerami IP:

    • aktualizacja programu (z menu Zbiory - Narzędzia - Aktualizacja programu):
      Host: www.reset2.pl, IP: 194.0.211.176, port 80 protokół HTTP

    • aktualizacja wysokości odsetek (z menu Ustawienia - Odsetki - ikona telefonu):
      Host: ftp.reset.pl, IP: 194.0.211.131, port 21 protokół FTP

    • wysyłanie danych do serwisu (z menu Zbiory - Narzędzia - Serwisowanie danych):
      IP: 80.53.206.34, port 21 protokół FTP.

W przypadku, gdy komputer korzysta z internetu za pośrednictwem serwera proxy, należy w programie w menu Ustawienia - Środowisko na zakładce Internet w grupie FTP zaznaczyć pole Użyj serwera proxy i wprowadzić odpowiednią nazwę hosta (np. 192.144.0.1) oraz numer portu (np. 4421).


Instalowanie programu

INSTRUKCJA ADMINISTRATORA

System wymaga instalacji właściwej aplikacji R2faktury oraz serwera bazy danych SQL firmy Microsoft. Płyta instalacyjna zawiera bezpłatną wersję serwera Microsoft SQL, który standardowo instaluje się razem z programem. Jeśli serwer bazy danych SQL (Microsoft SQL Server 2005, 2008, 2008R2 lub 2012) został już wcześniej zainstalowany, to podczas instalacji programu pomijamy instalację serwera SQL (gdyż bazę danych utworzymy na już istniejącym serwerze).

Możliwych jest kilka rodzajów instalacji:

  1. instalacja jednostanowiskowa - aplikacja oraz serwer SQL instalowane są na komputerze użytkownika (stacji roboczej)
  2. instalacja sieciowa - aplikacja instalowana jest na wszystkich stacjach roboczych, natomiast serwer SQL instalowany jest na komputerze głównym (serwerze)
  3. instalacja sieciowa trójwarstwowa - na komputerze głównym (lub dwóch połączonych w sieć) instalowany jest serwer SQL oraz serwer aplikacji, natomiast na stacjach roboczych instalowany jest klient aplikacji.

Należy wybrać właściwy rodzaj instalacji w zależności od wymagań, wersji programu oraz konfiguracji sieci:

  • Instalacja wersji demonstracyjnej w celu przejrzenia możliwości systemu - wybieramy najprostszy rodzaj instalacji jednostanowiskowej, łatwa konfiguracja, możliwość przekonania się o przydatności programu, szybkie odinstalowanie
  • Instalacja wersji demonstracyjnej w celu rozpoczęcia właściwej pracy - wybieramy od razu właściwy wariant, gdyż wersja demonstracyjna przez 60 dni zachowuje się jak pełna wersja licencjonowana (później blokowane są tylko wydruki), można przetestować właściwe zachowanie programu (konfiguracja i parametryzacja systemu, wprowadzanie danych, szybkość pracy, bezpieczeństwo bazy danych), po zakupie i wgraniu licencji można bez dodatkowych czynności normalnie kontynuować pracę
  • Program będzie pracował na komputerze nie podłączonym w sieć - wybieramy instalację jednostanowiskową
  • Program będzie użytkowany tylko przez jedną osobę - jeśli komputer użytkownika jest wystarczająco szybki to wybieramy instalację jednostanowiskową, w przeciwnym wypadku, jeśli komputer jest w szybkiej sieci i mamy do dyspozycji drugi komputer to wybieramy instalację sieciową, czyli program instalujemy na stacji roboczej a serwer SQL na drugim komputerze
  • Na programie będzie pracować kilku użytkowników, których komputery połączone są w sieć lokalną - wybieramy instalację sieciową, czyli serwer SQL instalujemy na szybkim komputerze w sieci (serwerze), natomiast program na komputerach wszystkich użytkowników.
    UWAGA. Istnieje możliwość wyboru wariantu takiej instalacji sieciowej, że zarówno serwer SQL jak i właściwy program instalowany jest na komputerze serwera. Instalacja taka wymaga udostępnienia katalogu roboczego na serwerze. Zaletą takiego rozwiązania jest możliwość uruchomienia programu z dowolnej stacji roboczej bez dodatkowej instalacji programu na tej stacji, natomiast wadą wolniejsze uruchamianie aplikacji przez głównych użytkowników. Istnieje możliwość połączenia obu wariantów instalacji sieciowej, co oznacza, że program i serwer SQL instalujemy na komputerze głównym (serwerze) i dodatkowo instalujemy już sam program na stacjach roboczych wykorzystywanych przez głównych użytkowników programu.
  • Mamy już w firmie zainstalowany serwer SQL - wybieramy wariant instalacji sieciowej (bez instalacji serwera SQL), czyli instalujemy program na stacjach roboczych, następnie podłączamy się i tworzymy bazę na istniejącym już serwerze SQL
  • Pracujemy w trybie terminalowym - wybieramy wariant instalacji jednostanowiskowej, czyli instalujemy program i serwer SQL na komputerze głównym, do którego użytkownicy mają dostęp za pomocą terminali
  • Dostęp do danych wymagany będzie przez użytkowników odległych (np. przez internet) - wybieramy wariant instalacji sieciowej trójwarstwowej, czyli serwer sql i serwer aplikacji na szybkim komputerze, przeznaczonym do tego celu (lub na dwóch oddzielnych połączonych w sieć), wystawiając na zewnątrz serwer aplikacji, natomiast na komputerach użytkowników odległych instalujemy klienta aplikacji.
    UWAGA. Istnieje również możliwość instalacji sieciowej podobnie jak w sieci lokalnej, ale wiąże się to z wystawieniem serwera bazy danych SQL na zewnątrz, co nie jest za bardzo polecane.
  • Praca oddziałowa, czyli w centrali w sieci lokalnej z możliwością zdalnego dostępu w oddziałach - wybieramy wariant instalacji sieciowej w połączeniu z instalacją sieciową trójwarstwową, czyli instalujemy serwer SQL w sieci lokalnej oraz aplikacje na stacjach roboczych i dodatkowo serwer aplikacji w tej samej sieci, na zewnątrz wystawiamy serwer aplikacji, do którego będą się łączyć klienci aplikacji, zainstalowani w oddziałach.


Instalacja jednostanowiskowa

INSTALOWANIE PROGRAMU

Opisany poniżej sposób instalacji jednostanowiskowej umożliwia zainstalowanie programu wraz z serwerem bazy danych SQL na komputerze użytkownika.

Przed instalacją systemu upewniamy się, czy na twardym dysku jest przynajmniej 300 MB wolnego miejsca. Następnie wkładamy do napędu CD-ROM firmową płytę z wersjami demonstracyjnymi programów. Po chwili obrazek z płytą powinien się pojawić na ekranie.

UWAGA. Jeśli obraz płyty się nie ukaże, należy samodzielnie uruchomić program INSTALUJ.EXE (znajdujący się w katalogu głównym CD-ROM) klikając: Start - Uruchom… - w pozycji Otwórz wpisać: D:\Instaluj i nacisnąć OK (Enter).

Po kliknięciu w pozycję R2faktury (lub R2fakturyPRO) uruchomi się właściwy program instalacyjny, który w przypadku instalacji szczegółowej poprowadzi nas Dalej przez kolejne etapy instalacji:

  • Wybierz docelową lokalizację - określamy folder, w którym program ma zostać zainstalowany, standardowo podpowiada się katalog C:\RESET2\R2faktury.7xx

  • Zaznacz komponenty - zaznaczamy właściwe składniki instalacji, po wyborze sposobu instalacji Instalacja jednostanowiskowa standardowo zaznaczą się:

    • R2faktury (lub R2fakturyPRO) - system obsługi sprzedaży - właściwy program, który chcemy zainstalować

    • MSSQLExpress2005 - serwer bazy danych SQL - bezpłatna wersja serwera SQL firmy Microsoft (Microsoft SQL Server 2005), serwer MS SQL jest konieczny do pracy z właściwym programem, tak więc zaznaczamy ten składnik, jeśli na komputerze nie mamy jeszcze zainstalowanego serwera MS SQL (mógł już zostać zainstalowany wraz z innym programem, np. z programem Płatnik ZUS w opcji z bazą SQL) lub jeśli tak czy owak chcemy zainstalować nowy serwer SQL o innej nazwie na potrzeby naszego programu

    • PDF-XChange 4 - sterownik wydruków w formacie pdf - dodatkowy składnik umożliwiający eksport wydruku do pliku w formacie PDF

  • Tworzenie serwera bazy danych - przy instalacji serwera SQL podajemy następujące parametry:

    • Nazwa instancji serwera - na jednym komputerze może być zainstalowanych maksymalnie 16 instancji, czyli 16 niezależnych serwerów SQL, standardowo instaluje się instancja o nazwie RESET2, możemy nazwę pozostawić pustą - wtedy zainstaluje się instancja główna lub wprowadzić własną nazwę

    • Hasło administratora, Potwierdzenie hasła - hasło dostępu administratora (sa) do serwera SQL, można pozostawić puste jednak dla bezpieczeństwa danych hasło powinno zawierać przynajmniej 6 znaków.
      UWAGA. Wprowadzone tu hasło należy zapamiętać, gdyż będzie ono potrzebne przy zakładaniu nowej bazy danych na instalowanym serwerze SQL.

Po właściwej instalacji systemu możemy przystąpić do pierwszego uruchomienia programu.


Instalacja sieciowa

INSTALOWANIE PROGRAMU

Przy instalacji sieciowej wykorzystamy w programie instalacyjnym dwa różne sposoby instalacji:

  • Instalacja serwera bazy danych - na przeznaczonym do tego celu komputerze zainstalujemy serwer bazy danych SQL

  • Instalacja aplikacji na stacji roboczej - na komputerach użytkowników programu zainstalujemy właściwą aplikację, która będzie łączyć się z serwerem bazy danych.

Szczegółowo proces instalacji powinien przebiegać następująco:

  1. Ustalamy, który komputer będzie serwerem bazy danych. Nazwiemy ten komputer umownie serwerem.

  2. Jeśli na serwerze nie mamy jeszcze zainstalowanego serwera MS SQL, czyli programu zarządzającego bazą danych, instalujemy bezpłatną wersję tego serwera SQL (MSSQLExpress2005). W tym celu uruchamiamy program instalacyjny na serwerze i na etapie instalacji Zaznacz komponenty wybieramy sposób instalacji Instalacja serwera bazy danych, co spowoduje zaznaczenie składnika MSSQLExpress2005 - serwer bazy danych SQL.
    UWAGA. Jeśli na serwerze jest już zainstalowany dowolny serwer SQL firmy Microsoft to nie powinniśmy wykonywać żadnej instalacji na serwerze, jednakże istnieje możliwość zainstalowania kolejnej instancji serwera SQL do obsługi tylko i wyłącznie bazy danych z naszego programu. W tym celu na etapie instalacji Tworzenie serwera bazy danych podajemy taką Nazwę instancji serwera, która jeszcze nie istnieje.

  3. Ustalamy, na których komputerach będzie uruchamiany program. Nazwiemy je umownie stacjami roboczymi.

  4. Na każdej stacji roboczej instalujemy właściwy program, czyli na etapie instalacji Zaznacz komponenty wybieramy sposób instalacji Instalacja aplikacji na stacji roboczej, co spowoduje wybór składników R2faktury - system obsługi sprzedaży oraz PDF-XChange 4 - sterownik wydruków w formacie pdf.

W przyszłości, jeśli będziemy aktualizować program, aktualizację taką wykonujemy tylko na jednej stacji roboczej. Program automatycznie zaktualizuje się na pozostałych stacjach roboczych za pośrednictwem bazy danych na serwerze.

UWAGA. Istnieje możliwość zainstalowania właściwego programu na serwerze i udostępnienie skrótów do programu na wszystkich stacjach roboczych. Wymaga to jednak udostępnienia katalogu roboczego serwera. Praktykowane to jest w przypadku, gdy nie są określone konkretne stacje robocze, na których będzie uruchamiany program. Przegląd wszystkich wariantów instalacji znajduje się w rozdziale Instalowanie programu.

Po właściwej instalacji systemu możemy przystąpić do pierwszego uruchomienia programu kolejno na wszystkich stacjach roboczych.

Należy pamiętać o tym, że dane do programu znajdują się na komputerze serwera i obsługiwane są przez serwer SQL, czyli program pracujący na serwerze. W związku z tym, żeby stacje robocze mogły korzystać z danych, serwer (komputer) musi być włączony oraz serwer SQL (program) musi być uruchomiony.

Jeśli na komputerach (serwerze i stacjach roboczych) zainstalowane jest oprogramowanie zapory internetowej (firewall), to należy je odpowiednio skonfigurować tak, żeby były dostępne odpowiednie porty i możliwość połączenia z konkretnym numerem IP serwera. W przypadku serwera SQL firmy Microsoft do nawiązania połączenia wykorzystywany jest port UDP 1434, natomiast do właściwego połączenie dla domyślnej instancji serwera port TCP 1433. Przy innych instancjach port określony jest we właściwościach instancji (SQL Server Network Utility lub SQL Server Configuration Manager).
UWAGA. Jeżeli nie udostępnimy portu 1434 dla usługi SQL Server Browser wtedy przy określeniu serwera nie możemy podać nazwy instancji (np. 127.0.0.1\reset2) tylko wprost numer portu przydzielonego do instancji (np. 127.0.0.1,1048) z ewentualną nazwą protokołu (np. tcp:127.0.0.1,1048)

Opisaną tu instalację sieciową wykorzystujemy w sieci lokalnej. Można wykorzystać ją przy instalacji w sieci rozległej (internet), jednakże wymaga to udostępnienie serwera bazy danych SQL na zewnątrz, żeby widzialny był z odległych stacji roboczych. Lepszym rozwiązaniem wydaje się wykorzystanie instalacji sieciowej trójwarstwowej.


Instalacja sieciowa trójwarstwowa

INSTALOWANIE PROGRAMU - Instalacja sieciowa

Instalacja sieciowa trójwarstwowa jest rozbudowaną instalacją sieciową o możliwość zdalnego uruchomiania programu przez klienta aplikacji (cienki klient). Klient łączy się z wystawionym w sieci serwerem aplikacji, który zarządza uruchamianiem sesji programu R2fakturyPRO.

Przy instalacji sieciowej trójwarstwowej wykorzystamy w programie instalacyjnym trzy różne sposoby instalacji:

  • Instalacja serwera bazy danych - na przeznaczonym do tego celu komputerze zainstalujemy serwer bazy danych SQL

  • Instalacja serwera aplikacji - na oddzielnym komputerze połączonym w sieci lokalnej z komputerem serwera bazy danych zainstalujemy właściwy program R2fakturyPRO oraz zarządzający nim serwer aplikacji

  • Instalacja klienta aplikacji na stacji roboczej - na komputerach użytkowników programu zainstalujemy klienta aplikacji, który będzie łączyć się z serwerem aplikacji.

Proces instalacji powinien przebiegać następująco:

  1. Ustalamy, który komputer będzie serwerem bazy danych. Jeśli na tym komputerze nie mamy jeszcze zainstalowanego serwera SQL to instalujemy go za pomocą programu instalacyjnego, wybierając sposób instalacji Instalacja serwera bazy danych (składnik MSSQLExpress2005 - serwer bazy danych SQL).

  2. Ustalamy, który komputer będzie serwerem aplikacji. Na tym komputerze uruchamiamy program instalacyjny i wybieramy sposób instalacji Instalacja serwera aplikacji, co spowoduje wybór składników: R2fakturyPRO - system obsługi sprzedaży, R2TCServer - serwer aplikacji i PDF-XChange 4 - sterownik wydruków w formacie pdf.

  3. Ustalamy, na których komputerach będzie uruchamiany program. Na każdym z tych komputerów instalujemy klienta aplikacji, czyli na etapie instalacji Zaznacz komponenty wybieramy sposób instalacji Instalacja klienta na stacji roboczej, co spowoduje wybór składników: R2thinClient - klient aplikacji oraz PDF-XChange 4 - sterownik wydruków w formacie pdf.

Po właściwej instalacji systemu możemy przystąpić do pierwszego uruchomienia programu na serwerze aplikacji, a następnie do uruchomienia klienta aplikacji kolejno na wszystkich komputerach użytkowników.

Należy pamiętać o tym, że wszystkich klientów aplikacji obsługuje serwer aplikacji. W związku z tym, komputer, na którym zainstalowany jest serwer aplikacji musi być włączony i sam serwer aplikacji musi być uruchomiony.

Jeśli na komputerach, gdzie zainstalowany jest serwer i klient aplikacji pracuje firewall, to należy udostępnić odpowiednie porty i możliwość połączenia z konkretnym numerem IP serwera aplikacji. Serwer aplikacji działa na zakresie portów 3000-3016 (TCP). Umożliwia otwarcie maksymalnie 16 sesji dla programu R2fakturyPRO. Aczkolwiek liczba sesji jest ograniczona przez możliwości komputera. Na jedną sesję trzeba liczyć około 100MB pamięci operacyjnej. Port 3000 jest wykorzystywany tylko do nawiązania połączenia klienta z serwerem, zaś wyższe porty służą do komunikacji z klientami. I tak np. sesja nr 1 otworzy port 3001, nr 2 3002 itd.


Uruchomienie programu

INSTALOWANIE PROGRAMU

Aby uruchomić program należy kliknąć: Start - Programy - RESET2 - R2faktury (lub R2fakturyPRO) - R2faktury w.7.xx.

Pierwsze uruchomienie programu wiąże się z wykonaniem następujących czynności:

  1. Wczytanie licencji - licencję pobieramy z internetu, w przypadku wersji demonstracyjnej licencję możemy wczytać później (po zakupie programu), nie tracąc danych wprowadzonych w czasie pracy na wersji demonstracyjnej

  2. Akceptacja warunków licencji - zapoznajemy się i akceptujemy warunki licencji (również w przypadku wersji demonstracyjnej), jeśli warunków licencji nie zaakceptujemy to nie będzie możliwa dalsza praca

  3. Utworzenie bazy danych - tworzenie bazy danych na serwerze SQL wymaga podania jego lokalizacji oraz hasła, jeśli serwer SQL zainstalowany został wraz z programem, parametry dostępowe podstawiają się automatycznie.
    UWAGI:

    1. W przypadku, gdy baza danych jest już utworzona (np. gdy pierwszy raz uruchamiany program z kolejnego komputera), anulujemy tworzenie nowej bazy danych (Anuluj), następnie po uruchomieniu programu wybieramy z menu głównego Zbiory - Narzędzia - Zmiana bazy danych i podajemy lokalizację i hasło serwera SQL oraz nazwę istniejącej już bazy danych (patrz Zmiana bazy danych).

    2. Należy pamiętać o tym, że bazą danych bezpośrednio zarządza serwer SQL i musi on być uruchominy, żeby nasz program mógł się z nim połączyć.

  4. Pobranie z internetu najnowszej aktualizacji programu. Należy taką aktualizację bezwzględnie pobrać, gdyż tylko dzięki temu będziemy mieli pewność, że pracujemy na najnowszej wersji programu zgodnej z aktualnymi przepisami i pozbawionej ewentualnych usterek wykrytych od czasu powstania wersji instalacyjnej programu.

Jeśli chodzi o wprowadzanie danych początkowych to mamy do wyboru następujące możliwości:

  1. Zaimportować z poprzedniej wersji programu R2faktury - jeśli dotychczas korzystaliśmy z programu R2faktury w wersji 6.09 to możemy zaimportować wszystkie dotychczasowe dane (patrz Konwersja danych z wersji 6.09)

  2. Zaimportować z innego systemu - jeśli dotychczas korzystaliśmy z innego programu sprzedażowo-magazynowego, istnieje możliwość importu niektórych danych z tych programów (patrz Inicjalizacja bazy danych)

  3. Wprowadzić je samodzielnie na podstawie dotychczasowych ewidencji.


Uruchomienie klienta aplikacji

INSTALOWANIE PROGRAMU - Uruchomienie programu

W przypadku pracy zdalnej (Instalacji sieciowej trójwarstwowej) użytkownik nie uruchamia bezpośrednio programu, tylko zainstalowanego na jego komputerze klienta aplikacji (cienki klient). Klient aplikacji służy do połączenia z serwerem aplikacji i uruchomienia sesji programu R2fakturyPRO.

Aby uruchomić klienta aplikacji należy kliknąć: Start - Programy - RESET2 - R2fakturyPRO – R2fakturyPRO klient.

Przy pierwszym uruchomieniu określamy następujące parametry połączenia:

  • LOGOWANIE

    • Adres serwera -adres hosta, na którym słucha serwer aplikacji (R2tcserver.exe)

    • Użytkownik - nazwa użytkownika programu, wprowadzonego podczas parametryzacji systemu

    • Hasło - hasło użytkownika programu, takie samo jak przy wyborze użytkownika podczas zwykłego uruchamiania.
      UWAGA. Użytkownik programu musi mieć włączoną opcję Może logować się zdalnie.

  • PARAMETRY

    • Jakość obrazu - im lepsza jakość kolorów tym wolniej będą przesyłać się ekrany

    • Kompresja obrazu - dobra kompresja polepszy szybkość przesyłania ekranów, jednak spadnie wydajność serwera;
      dla dobrych połączeń internetowych na poziomie 1-10 Mbit/s można wybrać 16 bitów i bez kompresji, natomiast poniżej tych wartosci zaleca się 4 bity z włączoną kompresją

    • Przenieś wydruki na ten komputer - wydruki zostaną przeniesione na komputer klienta, co pozwoli na drukowanie na lokalnej drukarce.

UWAGA. Klient jest aplikacją która przejmuje w zasadzie wszystkie podstawowe funkcje programu R2fakturyPRO, jednak odświeżanie ekranów ze względu na optymalność komunikacji może być niepełne. Aby mieć pewność, że mamy aktualny obraz programu można zawsze kliknąć myszą w obszar kontrolki.

Serwer aplikacji

Żeby była możliwa zdalna praca z programem R2fakturyPRO przy wykorzystaniu klienta aplikacji muszą być spełnione następujące warunki:

  • serwer aplikacji musi być zainstalowany w tym samym katalogu, co właściwy program

  • serwer aplikacji musi być uruchomiony

  • serwer aplikacji musi być widoczny przez klienta aplikacji.

Okno serwera pokazuje aktualnie aktywne sesje. Przycisk Zamknij sesję zamyka dowolną działającą sesję.


Wczytanie licencji

INSTALOWANIE PROGRAMU

Przy pierwszym uruchomieniu programu pojawi się okienko zatytułowane Pobierz licencję. Jeśli posiadasz kartkę z numerem seryjnym i kluczem, wypełnij pola numer seryjny oraz klucz i kliknij w przycisk Pobierz licencję. Jeśli nie wczytasz licencji program będzie pracował jako wersja demonstracyjna, tzn. po 60 dniach od daty zainstalowania przestanie drukować i eksportować dane.

Licencję można zaktualizować w dowolnym momencie pracy z programem, korzystając z polecenia menu w okienku głównym programu Pomoc - Pobierz licencję z internetu.


Licencja

INSTALOWANIE PROGRAMU

Po wczytaniu licencji na ekranie pojawi się okno z warunkami licencji. Należy je dokładnie przeczytać i zaakceptować lub nie. Dalsza praca programu możliwa jest po zaakceptowaniu warunków licencji i oznacza, że warunki te zostały przyjęte. W przypadku korzystania z programu w wersji demonstracyjnej również wymagane jest zapoznanie się z warunkami licencji dla tej wersji.

Warunki licencji możesz przejrzeć w dowolnym momencie pracy z programem, korzystając z polecenia menu w okienku głównym programu Pomoc - Licencja.

Obok umowy licencyjnej odczytać możemy dane tego konkretnego egzemplarza programu (zakupionej licencji lub wersji demonstracyjnej):

  • Licencjobiorca - dane nabywcy

  • Nr seryjny - kolejny numer

  • Abonament ważny do - do tej daty można bezpłatnie aktualizować program (patrz Aktualizacja programu)

  • Konfiguracja - główna konfiguracja programu

    • ile firm - limit obsługiwanych firm (Konfiguracja musi obejmować ilość zatrudnionych pracowników w największej firmie)

    • sieć - limit użytkowników jednocześnie pracujących w programie

    • zdalny dostęp - limit użytkowników pracujących zdalnie (terminalowo, przy wykorzystaniu cienkiego klienta), użytkowników pracujących zdalnie należy również uwzględnić w limicie wszystkich użytkowników pracujących jednocześnie w programie

  • Dostawca oprogramowania - dane Partnera RESET2, obsługującego klienta.

W przypadku wersji demonstracyjnej możemy określić konfigurację programu (MINI, STANDARD, MAXI, PRO, magazyn, liczbę użytkowników itp.). Dzięki temu będziemy mieli pewność, że po zakupie programu otrzymamy dokładnie taką wersję jak ta, którą testowaliśmy. Konfigurację wersji demonstracyjnej możemy zmieniać w dowolnym momencie testowania programu (menu Pomoc - Licencja).


Nowa baza danych

INSTALOWANIE PROGRAMU

Nową bazę danych tworzymy przy pierwszym uruchomieniu programu.

Przy tworzeniu nowej bazy danych na serwerze SQL podajemy następujące parametry:

  • Serwer - nazwa lub adres serwera SQL, w sieci lokalnej będzie to nazwa komputera, na którym został zainstalowany serwer SQL w instancji domyślnej (głównej), np. nazwa_komputera, jeśli przy instalacji podana została nazwa instancji, należy ją również umieścić po backslash'u, np. nazwa_komputera\nazwa_instancji, jeżeli dostęp do serwera SQL mamy przez internet, podajemy adres IP i ewentualnie po backslash'u nazwę instancji, np. 99.99.99.99 lub 99.99.99.99\RESET2, możemy również zamiast nazwy instancji podać po przecinku numer portu, na którym słucha dana instancja, np. 127.0.0.1,1048

  • Zaloguj jako użytkownik Windows NT - opcja logowania do serwera SQL jako użytkownik Windows - prawa dostępu ustalane są dla użytkownika lub grupy użytkowników

  • Użytkownik - nazwa użytkownika łączącego się z serwerem SQL (posiadającego odpowiednie uprawnienia), standardowo sa to administrator dla Microsoft SQL Server

  • Hasło - hasło dostępowe wybranego użytkownika, wymagane, jeśli nie logujemy się jako użytkownik Windows, w przypadku administratora sa podajemy hasło ustalone podczas instalacji serwera SQL

  • Baza danych - nazwa tworzonej na podanym serwerze bazy danych (standardowo faktury), fizycznie na serwerze tworzą się następujące bazy:

    • R2T_bazadanych_bin - standardowo R2T_faktury_bin - baza z danymi podstawowymi (firmy, użytkownicy), konfiguracją użytkowników oraz globalnymi bibliotekami (banki)

    • R2T_bazadanych_dane_1 - standardowo R2T_faktury_dane_1 - baza z danymi dotyczącymi pierwszej firmy, czyli faktury, pz, mm, kasa/bank itp.

    • R2T_bazadanych_dane_XX - dane kolejnych firm.

UWAGA. W przypadku jednoczesnej instalacji programu i serwera SQL właściwe parametry podpowiadają się automatycznie.

W szczególnych przypadkach możemy również utworzyć nową bazę danych poleceniem z menu głównego programu Zbiory - Narzędzia - Nowa baza danych. Utworzenie nowej bazy danych nie spowoduje usunięcia dotychczasowych danych, do których powrót umożliwia funkcja Zmiana bazy danych z menu głównego Zbiory - Narzędzia.


Zmiana bazy danych

INSTALOWANIE PROGRAMU - Nowa baza danych

Funkcję zmiany bazy danych (z pozycji menu Zbiory - Narzędzia - Zmiana bazy danych) wywołujemy, jeśli chcemy przejść do utworzonej wcześniej (np. na innej stacji roboczej) bazy.

Przy zmianie bazy danych określamy:

  • Serwer - zmianiamy, jeśli baza danych znajduje się na innym serwerze SQL niż dotychczasowa

  • Zaloguj jako użytkownik Windows NT, Użytkownik, Hasło - opcje logowania do serwera SQL zmieniamy tylko wtedy, gdy baza danych znajduje się na innym serwerze SQL lub dotychczasowy użytkownik nie na odpowiednich uprawnień do nowej bazy danych

  • Baza danych - nazwa utworzonej wcześniej bazy, a faktycznie tylko środkowa część fizycznej nazwy bazy na serwerze, z pominięciem przedrostka R2T_ oraz końcówki _bin, można rozwinąć listę wszystkich baz danych naszego systemu utworzonych na podanym serwerze SQL.

Szczegółowe wyjaśnienia parametrów określanych przy zmianie bazy danych znajdują się w rozdziale Nowa baza danych.


Rejestracja programu

INSTALOWANIE PROGRAMU

Jeśli przy uruchomieniu programu nie wczytamy licencji to pojawi się okno Rejestracja programu. Służy ono do:

  • zarejestrowania wersji demonstracyjnej - jeśli chcemy zapoznać się z możliwościami w pełni funkcjonalnej wersji programu, ale przez ograniczony okres czasu

  • zarejestrowania wersji bezpłatnej - jeśli chcemy rozpocząć normalną pracę na wersji ograniczonej funkcjonalnie, ale bez żadnych limitów czasowych.

W każdym przypadku możemy później wczytać zakupioną licencję, dostosowaną funkcjonalnie do własnych wymagań i bez żadnych ograniczeń czasowych.

Poświęcając chwilę na zarejestrowanie programu nabywamy prawa do:

  • pobierania najnowszych wersji systemu - w przypadku wersji demo możemy przekonać się, jak działają aktualizacje i upewnić się, czy są dostosowane do aktualnych wymogów, w przypadku wersji bezpłatnej (podobnie jak przy zakupionej licencji) jest to praktyka pozwalająca mieć pewność, że funkcje programu działają zgodnie z najnowszymi wytycznymi i wydruki będą zgodne z najnowszymi wzorami

  • telefonicznej pomocy serwisu - w przypadku wersji demo możemy dopytać się o sposób działania pewnych funkcji programu i uzyskać porady dotyczące właściwej parametryzacji, w przypadku wersji bezpłatnej mamy również możliwość serwisowania danych, na których pracujemy

  • aktualizacji parametrów naliczania - w obu przypadkach unikamy uciążliwego ręcznego wprowadzania zmian w zmieniających się okresowo parametrach.

Rejestracja programu nie jest konieczna, więc jeśli nie chcemy korzystać z wymienionych przywilejów to możemy ją pominąć. Rejestrację można wykonać później lub wgrać zakupioną licencję, bez utraty wprowadzonych wcześniej danych. Prosimy pominąć rejestrację, zamiast wprowadzać nieprawdziwe dane.

W formularzu rejestracyjnym wprowadzamy:

  • Logowanie istniejącego klienta - jeśli już wcześniej rejestrowaliśmy lub zakupiliśmy jakiś program to wystarczy podać swój adres E-mail. Jeśli nie pamiętamy hasła to po wciśnięciu przycisku Przypomnij hasło otrzymamy je natychmiast na swoją skrzynkę pocztową. Funkcja Zaloguj umożliwi automatyczne wypełnienia formularza danymi, część danych można zaktualizować przed rejestracją, część wymaga kontaktu z biurem firmy.

  • Rejestracja nowego klienta - w przypadku nowego klienta należy wypełnić dane firmy i dane do kontaktu. Pamiętajmy, że dane te wypełniamy tylko raz. Przy kolejnej rejestracji lub ewentualnym zamówieniu programu podajemy tylko swój adres e-mail i potwierdzamy hasłem.

  • Dostawca oprogramowania - z listy partnerów wybieramy tego, dzięki któremu zainstalowaliśmy program, póżniej w łatwy sposób będzie można zamówić licencję lub abonament na aktualizacje programu; jeśli na liście partnerów nie znaleźliśmy właściwej firmy to jej dane możemy wpisać wprost, jeśli program pochodzi bezpośrednio od producenta to pole pozostawiamy puste

  • Rejestracja wersji DEMO - przez 60 dni od daty instalacji (nie od daty rejestracji) można sprawdzić wszystkie możliwości programu

  • Rejestracja wersji START - bezpłatna wersja ograniczona wymaga rejestracji w celu użytkowania stałego. Dostępna tylko w serii Standard.

  • Zarejestruję się później - zamiast wprowadzać fikcyjne dane można pominąć rejestrację lub uczynić to później, wybierając w menu głównym Pomoc - Rejestracja.


O programie

INSTALOWANIE PROGRAMU

Po uruchomieniu programu możemy w każdej chwili otrzymać podstawowe informacje o programie. W tym celu w menu głównym wybieramy Pomoc - O programie.

Odczytujemy:

  • nazwa programu

  • wersja nr, z dnia - numer i data powstania tej wersji programu

  • nazwa i adres producenta

  • adres strony internetowej i poczty elektronicznej producenta

  • aktualizacja - dokładny numer i data ostatniej aktualizacji programu.


Aktualizacja programu

INSTALOWANIE PROGRAMU

Program objęty jest 12 miesięcznym abonamentem na aktualizacje. Właściwą datę abonamentu możemy odczytać w pozycji Licencja w menu głównym Pomoc. Do tej daty, czyli w okresie ważności abonamentu możemy aktualizować program, jeśli tylko pojawi się nowa wersja.

W przypadku, gdy data ważności abonamentu jest już nieaktualna, należy skontaktować się z dystrybutorem lub producentem w celu przedłużenia abonamentu. Przedłużenie abonamentu odbywa się poprzez wczytanie licencji z nową datą abonamentu (z otrzymanej płyty lub z internetu na podstawie otrzymanego klucza dostępowego).

Aktualizacja programu [image] odbywa się w sposób łatwy i szybki, pod warunkiem dostępu do internetu. Wystarczy z menu głównego Zbiory - Narzędzia wybrać funkcję Aktualizacja programu. Pojawi się okienko, z którego wybieramy następujące funkcje:

  • Pobierz - sprawdzamy, czy jest dostępna aktualizacja programu i jakie zawiera modyfikacje w stosunku do poprzednich wersji

  • Aktualizuj program - pobieramy i wgrywamy nową wersje programu.

Dodatkowo pozycja menu Pomoc - Aktualizacja pomocy umożliwia zaktualizowanie pomocy kontekstowej, zawierającej aktualną instrukcję obsługi.

UWAGA. W przypadku problemów z aktualizacją należy zwrócić uwagę na ustawienia środowiska programu (menu Ustawienia - Środowisko, zakładka Internet, parametry HTTP) oraz na ustawienia zapór internetowych (firewall) i serwerów proxy.

Jeśli nie mamy bezpośredniego dostępu do internetu z komputera, na którym uruchamiamy program, aktualizację możemy wykonać po samodzielnym pobraniu ze strony internetowej www.reset2.pl (w menu programu Jak aktualizować) pliku aktualizującego program (UPDATE.EXE). Pobrany plik należy zapisać w dowolnej lokalizacji (najlepiej w jakimś pustym folderze) i uruchomić. W ten sposób rozpakują się pliki RFAKTURY.EXE, RFAKTURY.CHM (i ewentualnie jakieś inne), które należy skopiować w miejsce dotychczas istniejących (standardowo będzie to katalog C:\RESET2\Faktury.7xx\BIN).

W przypadku wersji sieciowej, zainstalowanej na kilku stacjach roboczych wystarczy zaktualizować program na jednej z nich. Dzięki wbudowanemu mechanizmowi aktualizacji wszystkich stacji roboczych przez bazę danych, program zostanie zaktualizowany na wszystkich stacjach roboczych, które łączą się z tą samą bazą danych.


Konwersja danych z wersji 6.09

INSTALOWANIE PROGRAMU

Jeśli dotychczas używaliśmy program w wersji 6.09, możemy po instalacji programu zaimportować wszystkie dotychczasowe dane. W tym celu wywołujemy funkcję Konwersja danych z wersji 6.09 z menu Zbiory - Narzędzia.

Należy podać katalog, w którym zainstalowana jest wersja 6.09 lub odnaleźć ten katalog automatycznie funkcją Wyszukaj, następnie funkcją Konwertuj uruchomić proces konwersji danych.

UWAGI:

  1. Czas trwania konwersji zależy od ilości danych i parametrów komputera. W przypadku dużej ilości danych w wersji 6.09 (kilkaset tysięcy pozycji faktur) konwersja może potrwać nawet kilka godzin.

  2. Należy mieć świadomość, iż funkcja konwersji danych spowoduje utratę dotychczas wprowadzonych danych w nowej wersji programu (7.xx)

  3. Jeśli korzystaliśmy do tej pory z programu R2faktury w wersji starszej niż 6.09, należy najpierw zaktualizować go do wersji 6.09, a dopiero później wykonać konwersję do 7.xx

  4. Podczas konwersji nie przenoszą się konfiguracje okien (rozmiar, kolumny, czcionka, kolor), po konwersji parametry te zostaną ustawione na domyślne

  5. W nowej wersji programu zostały trochę rozszerzone prawa dostępu w stosunku do wersji 6.09, zatem należy je sprawdzić przed rozpoczęciem pracy.


Inicjalizacja bazy danych

INSTALOWANIE PROGRAMU

Program R2faktury umożliwia wstępną inicjalizację bazy danych na podstawie danych znajdujących się w innym programie podobnego typu. Dla programu Subiekt firmy INSERT możliwy jest bezpośredni odczyt bazy danych (patrz Inicjalizacja na podstawie bazy danych programu Subiekt). Dla pozostałych programów należy skorzystać z mechanizmu inicjalizacji na podstawie pliku buforowego (patrz Inicjalizacja na podstawie pliku buforowego).


Inicjalizacja bazy danych na podstawie pliku buforowego

Inicjalizacja na podstawie pliku buforowego

INSTALOWANIE PROGRAMU - Inicjalizacja bazy danych

Program R2faktury umożliwia wstępną inicjalizację bazy danych na podstawie danych znajdujących się w innym programie podobnego typu.

Inicjalizacji tej dokonujemy poleceniem menu głównego Zbiory - Narzędzia - Inicjalizacja bazy danych - Inicjalizacja na podstawie pliku buforowego.

Aby import danych był możliwy, muszą one zostać wcześniej zapisane w pliku o określonym formacie. Format ten opisano szczegółowo w specyfikacji inicjalizacji bazy danych, znajdującej się w załączniku do instrukcji wywoływanej w programie. Jeżeli chcemy przenieść dane z jednego z programów: , [image] lub [image], to do przygotowania pliku buforowego powinniśmy użyć funkcji Eksport bazy danych do pliku buforowego. Funkcja ta utworzy gotowy plik z danymi w odpowiednim formacie. Jeżeli chcemy przenieść dane z innego używanego do tej pory systemu, to przygotowanie pliku buforowego najlepiej zlecić informatykowi.

Inicjalizacja bazy obejmuje następujące dane:

  • dane firmy (lub wielu firm w przypadku biura rachunkowego)

  • dane kontrahentów

  • dane asortymentów

  • stany magazynowe.

Przed wykonaniem inicjalizacji należy określić odpowiednie parametry:

  • Standard polskich liter w pliku źródłowym - ustawiamy zgodnie ze standardem użytym w przygotowanym pliku

  • Importuj tylko dane bieżącej firmy - zaznaczając ten parametr spowodujemy, że dane z pliku zostaną dołączone do tej firmy, z którą aktualnie pracujemy w programie. Dzięki temu plik buforowy może mieć nieco prostszą strukturę - nie są w nim wtedy potrzebne sekcje dotyczące firm (patrz Specyfikacja pliku buforowego). Może się również zdarzyć, że dysponujemy plikiem z wieloma firmami, ale z jakichś powodów w danym momencie chcemy ograniczyć odczytywanie danych tylko do tej firmy, na której aktualnie pracujemy w programie. W takiej sytuacji, jeżeli parametr zostanie zaznaczony, to dane z pliku buforowego dotyczące wszystkich firm innych niż aktualna zostaną pominięte.
    UWAGA. Program uzna, że dane w pliku buforowym dotyczą danej firmy tylko w dwóch przypadkach:

    • wtedy, gdy podane w pliku Nazwa, NIP i REGON firmy będą zgodne z tymi, które znajdują się w bazie danych, tzn. gdy w pliku w linii znajdującej się po linii oznaczonej *F znajdą się odpowiednie dane w komórce nr 1 - Nazwa firmy, nr 3 - NIP i nr 4 - REGON (patrz Specyfikacja pliku buforowego)

    • wtedy, gdy w pliku buforowym w ogóle nie będzie sekcji *F.

  • Import asortymentów - należy zaznaczyć, jeżeli chcemy do bazy dołączyć dane asortymentów

  • Identyfikacja - jeżeli z pliku buforowego dołączamy dane asortymentów, to należy wypełnić pole Identyfikacja. Pole to służy do określenia jednoznacznego identyfikatora asortymentu, aby nie dublować asortymentów już istniejących w kartotece. Np. jeżeli w polu Identyfikacja wybierzemy Skrót nazwy, to czytając plik buforowy program będzie pomijał te asortymenty, których Skrót nazwy będzie zgodny z wartościa pola Skrót nazwy któregoś z asortymentów już znajdujących się w kartotece. Analogicznie program pomijał będzie asortymenty ze zgodnym polem Indeks.

  • Import kontrahentów - należy zaznaczyć, jeżeli chcemy do bazy dołączyć dane kontrahentów

  • Identyfikacja - jeżeli z pliku buforowego dołączamy dane kontrahentów, to należy wypełnić pole Identyfikacja. Pole to służy do określenia jednoznacznego identyfikatora kontrahenta, aby nie dublować kontrahentów już istniejących w kartotece. Np. jeżeli w polu Identyfikacja wybierzemy NIP, to czytając plik buforowy program będzie pomijał tych kontrahentów, których NIP będzie zgodny z wartościa pola NIP któregoś z kontrahentów już znajdujących się w kartotece. Analogicznie program pomijał będzie kontrahentów ze zgodnym polem Skrót. Natomiast jeżeli w parametrze Identyfikacja wybierzemy NIP,Skrót, wówczas kontrahent zostanie pominięty tylko wtedy, gdy zarówno pole NIP jak i Skrót będzie takie same, jak inny kontrahent w kartotece.
    UWAGI:

    1. W przypadku, gdy wybierzemy opcję NIP lub NIP,Skrót może się zdarzyć, że program dopisze kontrahenta, którego NIP co prawda jest unikalny, ale jego Skrót jest identyczny z jakimś już istniejącym w kartotece kontrahentem. Ze względu na to, że w programie R2faktury pole Skrót musi być polem jednoznacznym (dwaj różni kontrahenci nie mogą mieć takiej samej wartości w polu Skrót), to w takim przypadku program wyświetli komunikat i do pola Skrót tego kontrahenta dodany zostanie przyrostek z kolejnym numerem (_1, _2 itd).

    2. Podczas porównywania pól NIP brane są pod uwagę tylko cyfry, czyli np. 652-111-22-33 i 6521112233 zostaną uznane za jednakowe pola NIP.

  • Import stanów magazynowych - należy zaznaczyć, jeżeli chcemy wraz z bazą asortymentów zainicjować stany magazynowe

  • Dokument BO - jeżeli z pliku buforowego dołączamy asortymenty wraz ze stanami magazynowymi, to należy wypełnić pole Dokument BO. Pole to służy do jednoznacznego określenia definicji dokumentu, na który zostaną wpisane stany magazynowe.

Polecenie menu głównego Zbiory - Narzędzia - Eksport bazy danych do pliku buforowego eksportuje bazę danych do pliku buforowego o formacie wymaganym przez funkcję Inicjalizacja na podstawie pliku buforowego w programach [image], [image] i [image]. Eksportowane są dane ze wszystkich firm lub Tylko dane bieżącej firmy. Dzięki tej opcji można np. w prosty sposób "przerzucić" kontrahentów i/lub asortymenty z jednej firmy do innej, (lub do innego programu) - wystarczy wyeksportować dane z firmy źródłowej, a następnie zaimportować je w firmie docelowej (lub docelowym programie).


Inicjalizacja bazy danych na podstawie bazy programu SUBIEKT

Inicjalizacja na podstawie bazy danych programu Subiekt

INSTALOWANIE PROGRAMU - Inicjalizacja bazy danych

Program R2faktury umożliwia wstępną inicjalizację bazy danych na podstawie danych programu Subiekt firmy INSERT. Aby dokonać tej inicjalizacji, należy wybrać opcję Zbiory - Narzędzia - Inicjalizacja bazy danych - Inicjalizacja na podstawie danych z Subiekta. Ukaże się wówczas okno przedstawione poniżej, w którym należy kolejno określić wszystkie parametry niezbędne do wykonania operacji przeniesienia danych.

Pierwsza grupa parametrów zgrupowana jest w okienku Parametry bazy danych programu Subiekt. Są to dane umożliwiające poprawne podłączenie się do tej bazy.

  • Serwer - nazwa serwera MS SQL, na którym znajduje się baza danych programu Subiekt. Nazwa ta jest wyświetlana w oknie logowania do programu Subiekt w polu Serwer.
    W sytuacji, gdy dostęp do serwera SQL mamy przez internet, możemy również podać adres IP i ewentualnie - po backslash'u - nazwę instancji, np. 99.99.99.99 lub 99.99.99.99\INSERTGT. Możemy też zamiast nazwy instancji podać po przecinku numer portu, na którym słucha dana instancja, np. 127.0.0.1,1048.

  • Zaloguj jako użytkownik Windows NT - opcja logowania do serwera SQL jako użytkownik Windows - prawa dostępu ustalane są dla użytkownika lub grupy użytkowników

  • Użytkownik - nazwa użytkownika łączącego się z serwerem SQL (posiadającego odpowiednie uprawnienia). Standardowo użytkownik sa to administrator dla Microsoft SQL Server.

  • Hasło - hasło dostępowe wybranego użytkownika, wymagane, jeśli nie logujemy się jako użytkownik Windows. W przypadku administratora sa podajemy hasło ustalone podczas instalacji serwera SQL.

  • Baza danych - nazwa bazy danych programu Subiekt. Nazwa ta wyświetlana jest w oknie logowania do programu Subiekt w polu Podmiot.

Pozostałe parametry określają, które dane z programu Subiekt mają być przeniesione do programu R2faktury oraz w jaki sposób. Możemy zaznaczyć następujące opcje:

  • Przenieś asortymenty - zostaną wówczas przeniesione dane dotyczące kartoteki Towarów i Usług z programu Subiekt. Na ich podstawie w programie R2faktury utworzone zostaną kartoteki:

    • Asortymenty

    • Jednostki miary

    • Grupy asortymentowe

    • PKWiU (2008), wraz ze skojarzonymi z nimi stawkami VAT. Jeżeli w programie Subiekt nie zostały określone dane PKWiU dla poszczególnych asortymentów, to program R2faktury utworzy w kartotece PKWiU osobny rekord dla każdej ze stawek VAT, którą napotka podczas przenoszenia asortymentów. W tak utworzonych pozycjach pole Nazwa pozostanie puste, natomiast pole Nr będzie identyczne jak stawka VAT, (czyli np. dla stawki VAT 8% numerem PKWiU będzie 8). Wyjątkiem będzie podstawowa stawka VAT, czyli 23% - dla tej stawki numerem PKWiU będzie znak myślnika.

    Kluczowymi polami kartoteki Asortymentów są pola Indeks, Nazwa oraz Nazwa - ciąg dalszy. Pola Indeks i Nazwa umożliwiają szybkie wyszukiwanie asortymentu podczas wypisywania dokumentów, natomiast pole Nazwa - ciąg dalszy służy do przechowywania nazw asortymentów dłuższych niż 50 znaków (jeżeli pole to jest wypełnione, to drukowane jest na fakturze zamiast pola Nazwa). Ze względu na ważność tych pól, dla każdego z nich można określić, które dokładnie pola z kartoteki Towarów i Usług mają zostać do nich przepisane. Np. do pola Indeks możemy wpisać pole Symbol, Nazwa lub Podstawowy kod kreskowy. Domyślnie, do pola Indeks zostanie przeniesione pole Symbol, do pola Nazwa - pole Nazwa, a do pola Nazwa - ciąg dalszy - pole Opis.

  • Przenieś kontrahentów - zostaną wówczas przeniesione dane dotyczące kartoteki Kontrahentów z programu Subiekt. Na ich podstawie w programie R2faktury utworzone zostaną następujące kartoteki:

    • Kontrahenci

    • Grupy kontrahentów

    • Opiekunowie kontrahentów

  • Przenieś stany magazynowe - zaznaczenie tej opcji spowoduje, że w programie R2Faktury zostaną utworzone:

    • biblioteka Magazyny, zawierająca magazyny z programu Subiekt

    • dokumenty bilansu otwarcia zawierające aktualne stany magazynowe towarów i usług przeniesionych z programu Subiekt. W tym celu w polu Dokument BO należy wybrać rodzaj dokumentu BO, na który zostaną wpisane stany magazynowe. Można wybrać dokument BO, który tworzy się standardowo podczas instalacji programu R2faktury, albo zdefiniować go samemu (patrz INSTRUKCJA ADMINISTRATORA - PARAMETRYZACJA SYSTEMU - Definicje dokumentów, oraz Magazyn - Przyjęcia do magazynu). Dla każdego magazynu zostanie utworzony osobny dokument BO.

UWAGA. Dane z programu Subiekt należy przenosić do takiej firmy w programie R2faktury, w której nie ma jeszcze wprowadzonych żadnych asortymentów ani kontrahentów.


Inicjalizacja bazy danych na podstawie bazy programu mikroSubiekt

Inicjalizacja na podstawie bazy danych programu mikroSubiekt

INSTALOWANIE PROGRAMU - Inicjalizacja bazy danych

Program R2faktury umożliwia wstępną inicjalizację bazy danych na podstawie danych programu mikroSubiekt firmy INSERT. Aby dokonać tej inicjalizacji, należy wybrać opcję Zbiory - Narzędzia - Inicjalizacja bazy danych - Inicjalizacja na podstawie danych z mikroSubiekta. Ukaże się wówczas okno przedstawione poniżej, w którym należy kolejno określić wszystkie parametry niezbędne do wykonania operacji przeniesienia danych.

Pierwsza grupa parametrów zgrupowana jest w okienku Parametry bazy danych programu mikroSubiekt. Są to dane umożliwiające poprawne podłączenie się do tej bazy.

  • Serwer - nazwa serwera MS SQL, na którym znajduje się baza danych programu mikroSubiekt. Nazwa ta jest wyświetlana w oknie logowania do programu mikroSubiekt w polu Serwer.
    W sytuacji, gdy dostęp do serwera SQL mamy przez internet, możemy również podać adres IP i ewentualnie - po backslash'u - nazwę instancji, np. 99.99.99.99 lub 99.99.99.99\INSERTGT. Możemy też zamiast nazwy instancji podać po przecinku numer portu, na którym słucha dana instancja, np. 127.0.0.1,1048.

  • Zaloguj jako użytkownik Windows NT - opcja logowania do serwera SQL jako użytkownik Windows - prawa dostępu ustalane są dla użytkownika lub grupy użytkowników

  • Użytkownik - nazwa użytkownika łączącego się z serwerem SQL (posiadającego odpowiednie uprawnienia). Standardowo użytkownik sa to administrator dla Microsoft SQL Server.

  • Hasło - hasło dostępowe wybranego użytkownika, wymagane, jeśli nie logujemy się jako użytkownik Windows. W przypadku administratora sa podajemy hasło ustalone podczas instalacji serwera SQL.

  • Baza danych - nazwa bazy danych programu mikroSubiekt. Nazwa ta wyświetlana jest w oknie logowania do programu mikroSubiekt w polu Podmiot.

Pozostałe parametry określają, które dane z programu mikroSubiekt mają być przeniesione do programu R2faktury oraz w jaki sposób. Możemy zaznaczyć następujące opcje:

  • Przenieś asortymenty - zostaną wówczas przeniesione dane dotyczące kartoteki Towarów i Usług z programu mikroSubiekt. Na ich podstawie w programie R2faktury utworzone zostaną kartoteki:

    • Asortymenty

    • Jednostki miary

    • Grupy asortymentowe

    • PKWiU (2008), wraz ze skojarzonymi z nimi stawkami VAT. Jeżeli w programie mikroSubiekt nie zostały określone dane PKWiU dla poszczególnych asortymentów, to program R2faktury utworzy w kartotece PKWiU osobny rekord dla każdej ze stawek VAT, którą napotka podczas przenoszenia asortymentów. W tak utworzonych pozycjach pole Nazwa pozostanie puste, natomiast pole Nr będzie identyczne jak stawka VAT, (czyli np. dla stawki VAT 8% numerem PKWiU będzie 8). Wyjątkiem będzie podstawowa stawka VAT, czyli 23% - dla tej stawki numerem PKWiU będzie znak myślnika.

    Kluczowymi polami kartoteki Asortymentów są pola Indeks, Nazwa oraz Nazwa - ciąg dalszy. Pola Indeks i Nazwa umożliwiają szybkie wyszukiwanie asortymentu podczas wypisywania dokumentów, natomiast pole Nazwa - ciąg dalszy służy do przechowywania nazw asortymentów dłuższych niż 50 znaków (jeżeli pole to jest wypełnione, to drukowane jest na fakturze zamiast pola Nazwa). Ze względu na ważność tych pól, dla każdego z nich można określić, które dokładnie pola z kartoteki Towarów i Usług mają zostać do nich przepisane. Np. do pola Indeks możemy wpisać pole Symbol, Nazwa lub Podstawowy kod kreskowy. Domyślnie, do pola Indeks zostanie przeniesione pole Symbol, do pola Nazwa - pole Nazwa, a do pola Nazwa - ciąg dalszy - pole Opis.

  • Przenieś kontrahentów - zostaną wówczas przeniesione dane dotyczące kartoteki Kontrahentów z programu mikroSubiekt. Na ich podstawie w programie R2faktury utworzone zostaną następujące kartoteki:

    • Kontrahenci

    • Grupy kontrahentów.

UWAGA. Dane z programu mikroSubiekt należy przenosić do takiej firmy w programie R2faktury, w której nie ma jeszcze wprowadzonych żadnych asortymentów ani kontrahentów.


R2firma - integracja modułów

INSTALOWANIE PROGRAMU

Jeśli oprócz programu R2faktury korzystamy jeszcze z innych systemów firmy RESET2, tj. z programu R2fk i R2płatnik, to warto zintegrować je ze sobą. Po zintegrowaniu bedziemy mogli je traktować jako moduły systemu R2firma, obejmującego swoim zastosowaniem wszystkie potrzeby naszej firmy.

Zintegrowane moduły synchronizują automatycznie część danych, tak aby wyeliminować konieczność wielokrotnego wprowadzania tych samych informacji w oknach Firmy, Rachunki bankowe i Użytkownicy.

Ponadto oferują łatwe księgowanie faktur, kasy oraz dekretów, które nie wymaga korzystania z pośredniczących plików buforowych.

Integrację modułów systemu R2firma umożliwia polecenie menu głównego Zbiory - Narzędzia - R2firma - integracja modułów.

W wywołanym w ten sposób okienku R2firma - integracja modułów podajemy parametry dostępowe do baz danych poszczególnych modułów. Po kliknięciu [image] wykonana zostanie inicjalizacja bazy danych bieżącego programu na podstawie bazy danych zaznaczonego modułu.

Oznacza to, że jeśli zainstalowaliśmy właśnie program R2faktury, a wcześniej korzystaliśmy już np. z programu R2płatnik, to po zatwierdzeniu integracji w programie R2faktury pojawią się automatycznie wszystkie firmy, rachunki bankowe oraz użytkownicy wprowadzeni wcześniej w R2płatniku. Ponadto od tej pory wszystkie zmiany wprowadzane w jednym module będą od razu widoczne w pozostałych.

UWAGI:

  1. Integrację należy wykonywać w programie świeżo zainstalowanym, wskazując jednorazowo tylko jeden zainstalowany wcześniej moduł. Np. Jeśli pierwotnie na komputerze był zainstalowany R2płatnik, to po zainstalowaniu programu R2faktury integrujemy go z tym R2płatnikiem. Później jeśli zainstalujemy jeszcze program R2fk, to integrujemy go albo z R2faktury albo z R2płatnikiem (nie ma znaczenia, z którym z nich, bo pamiętają one, że zostały już wcześniej ze soba zintegrowane).

  2. Integrację można wykonać również bez konieczności uruchamiania okna R2firma - integracja modułów. Po otwarciu okna Firmy bądź Użytkownicy program sprawdzi czy na bieżącym serwerze SQL znajdują się już bazy danych innych programów RESET2 i zaproponuje integrację z nimi.


Konsolidacja baz danych

INSTALOWANIE PROGRAMU

Funkcja Konsolidacja baz danych, dostępna w menu Zbiory - Narzędzia, umożliwia samodzielne skonsolidowanie danych różnych firm, obsługiwanych dotychczas w osobnych programach, w jedną bazę danych. W przypadku biur rachunkowych można w ten sposób np. dołączyć do swojego programu całą bazę danych prowadzoną wcześniej bezpośrednio przez klienta.

Konsolidację można wykonywać tylko na komputerze, na którym znajdują się fizycznie obie bazy danych: bieżąca i konsolidowana.

W oknie KONSOLIDACJA BAZ DANYCH musimy określić następujące parametry:

  • Baza danych do skonsolidowania z bieżącą bazą - wskazujemy która baza danych będzie konsolidowana z bieżącą bazą danych

    • Serwer - nazwa lub adres serwera SQL. Serwer ten musi się znajdować fizycznie na tym samym komputerze co serwer bieżącej bazy danych.

    • Zaloguj jako użytkownik Windows, Użytkownik, Hasło - parametry dostępowe do serwera SQL

    • Baza danych - nazwa bazy danych, którą będziemy konsolidować z bieżącą bazą danych (czyli dołączać do bieżącej bazy danych).

  • Jeśli istnieje już taka firma, to

    • kopiuj konsolidowaną w miejsce istniejącej - firma istniejąca zostanie zastąpiona przez konsolidowaną

    • utwórz jako nową - w bazie danych zostanie utworzona nowa firma, a zatem po konsolidacji w oknie z firmami dostępne będą obie firmy

    • pytaj - podczas przeprowadzania konsolidacji program będzie pytał czy zastąpić istniejącą firmę, czy dopisać nową.

Po naciśnięciu przycisku Konsoliduj rozpocznie się konsolidacja wskazanych baz danych. Opcja dostępna od wersji STANDARD.


Parametryzacja systemu

INSTRUKCJA ADMINISTRATORA

Ustawienia konfiguracyjne w programie możemy podzielić na kilka grup:

  • Użytkownicy - prawa dostępu użytkowników do poszczególnych funkcji programu

  • Konfiguracja modułów programu - włączenie i konfiguracja modułów programu w zależności od potrzeb

  • Definicje dokumentów - definicje dokumentów używanych w programie (PZ, faktura VAT, rachunek, MM, WZ, RK itp.)

  • Definicje zestawień - definicje zestawień standardowych oraz własnych

  • Makiety dokumentów - modyfikowalne wzory dokumentów drukowanych z programu

  • Języki - tłumaczenia faktur i dokumentów windykacyjnych na języki obce (dostępne tylko w wersji MAXI i PRO)

  • Waluty - waluty wraz z ewidencją średnich kursów NBP (dostępne tylko w wersji MAXI i PRO)

  • Odsetki - parametry związane z naliczaniem odsetek

  • Środowisko - parametry związane z samym działaniem programu

  • Konfiguracja - ustawienia związane z poszczególnymi oknami (Faktury, Kontrahenci, itp.)

  • Konfiguracja CRM - ustawienia związane z obsługą CRM

  • Konfiguracja przelewów - parametry wydruku bankowych poleceń przelewów

  • Restrykcje - parametry związane z restrykcjami w obrotach z nierzetelnymi kontrahentami

  • Formy płatności - parametry związane z formami płatności

  • Wydruki znakowe - konfiguracja drukarek igłowych (dostępne tylko w wersji MAXI i PRO)

  • Urządzenia fiskalne - konfiguracja drukarek i kas fiskalnych

  • Zewnętrzny generator raportów - wywołanie zewnętrznego modułu bezpośrednio z programu

  • Harmonogram zadań - obsługa długich lub powtarzających się operacji

  • Modyfikacja interfejsu - dostosowanie interfejsu do własnych potrzeb

  • Konfiguracja bazy danych - dostosowanie struktury bazy danych do własnych potrzeb.

Ważną funkcją jest ustawienie bieżącej daty (niezależnie od ustawienia w systemie operacyjnym) oraz okresu pracy w programie (F12), a także zmiana hasła wejścia do programu.

Dodatkowo korzystając z menu Ustawienia możemy funkcją Domyślne konfiguracje okien przywrócić standardowe ułożenie oraz właściwości wszystkich okien, a funkcją Zamknij wszystkie okna zamknąć wszystkie otwarte okna programu.


Użytkownicy

PARAMETRYZACJA SYSTEMU

Przed rozpoczęciem normalnej pracy należy określić listę osób obsługujących program. W przypadku, gdy program jest obsługiwany przez więcej niż jedną osobę, można każdemu użytkownikowi przyporządkować własne ustawienia parametrów i ustalić, jakie operacje i przez kogo mogą być wykonywane.

UWAGA. W przypadku wersji jednostanowiskowej, jeśli program będzie użytkowany najczęściej przez tą samą osobę, rozdziały dotyczące użytkowników możemy w całości pominąć.

Do listy użytkowników wchodzimy po kliknięciu w oknie głównym w przycisk [image] lub w menu Zbiory - Wybór użytkownika. Nowego użytkownika wprowadzamy klawiszem Ins lub klikając [image]. Wpisujemy:

  • Nazwa - symboliczny identyfikator użytkownika wprowadzany podczas wyboru użytkownika (czyli uruchomienia programu lub zmiany użytkownika)

  • Nazwisko, Imię - nie jest wymagane, gdyż wszędzie posługujemy się symboliczną nazwą użytkownika

  • Hasło - hasło dostępu, które każdy użytkownik może później samodzielnie zmieniać z pozycji menu głównego Ustawienia - Hasło użytkownika

  • Wymuszaj zmianę hasła co 30 dni - po zaznaczeniu tej opcji program będzie żądał zmiany hasła co 30 dni

  • Użyj silnych haseł - po zaznaczeniu tej opcji program będzie wymuszał wprowadzenie hasła co najmniej 8 znakowego zawierającego małe i duże litery

  • Grupa praw dostępu - przydzielamy użytkownika do grupy użytkowników, dla której określone są prawa dostępu do poszczególnych okien i funkcji programu, zmiany praw dostępu danej grupy lub wprowadzenie nowej grupy możemy dokonać, wchodząc do pozycji Grupy użytkowników z poziomu menu głównego Zbiory - Narzędzia.

Dodatkowo określamy:

  • na zakładce Właściwości:

    • Może logować się zdalnie - udostępnienie temu użytkownikowi zdalnego dostępu do programu, czyli możliwość pracy za pośrednictwem modułu WWW lub uruchamiania klienta aplikacji jako ten użytkownik

    • Zalogowany na - informacja o użytkownikach podłączonych do bazy, podana jest nazwa komputera użytkownika aktualnie pracującego w programie

    • Zakończ sesję - w szczególnych przypadkach można odłączyć pracującego już (zalogowanego) użytkownika

    • Żądania zakończenia sesji - informacja, że użytkownik jest w trakcie odłączania (żądanie zostało wysłane lecz nie zostało jeszcze wykonane)

    • Zablokowany przez administratora - zaznaczenie tej opcji uniemożliwi zalogowanie się danego użytkownika do programu.
      UWAGI:

      1. W przypadku prac konserwacyjnych można zablokować wszystkich użytkowników (oprócz administratora) jednocześnie, wybierając funkcję Zablokuj wszystkich użytkowników z menu kontekstowego. Po zakończeniu prac funkcja Odblokuj wszystkich użytkowników przywróci możliwość logowania wszystkim użytkownikom.

      2. Zablokowanie użytkowników nie spowoduje odłączenia użytkowników już pracujących, ale po ich odłączeniu (Zakończ sesję) nie pozwoli na ich powtórne wejście.

    • Włącz śledzenie operacji bazodanowych - po zaznaczeniu w ewidencji operacji wykonywanych przez użytkownika zapisywane będą informacje o wprowadzaniu (F7), modyfikacji (F6) i kasowaniu (F8) rekordów w bazie danych

    • Konto nie jest używane - zaznaczamy jeśli konto nie jest już używane, dzięki temu korzystając w oknie Użytkownicy z filtra dostępnego pod F4 możemy ukryć użytkowników nieużywanych, wówczas nie będą oni widoczni na liście użytkowników programu

    • Pokaż log użytkownika - ewidencja głównych operacji wykonywanych przez użytkowników

  • na zakładce Inne

    • Symbol - symbol użytkownika używany w układzie numeru we współdzielonych definicjach dokumentów (patrz DEFINICJE DOKUMENTÓW - Współdzielenie definicji)

    • Miejscowość - miejscowość wystawienia dokumentów. Pole przydatne przy pracy w trybie terminalowym, gdy użytkownicy logują się do programu z różnych oddziałów firmy, znajdujących się w różnych miejscowościach.

    • CRM - dział, w którym pracuje ten użytkownik. Będzie podpowiadany jak cel kontaktu/kontraktu/sprawy w oknach KONTAKTY oraz KONTRAKTY/SPRAWY.

Lista użytkowników (wraz z możliwością jej modyfikacji) dostępna jest tylko dla Administratora i innych użytkowników należących do grupy Administratorzy. Pozostali użytkownicy wybierając z menu głównego funkcję Zbiory - Wybór użytkownika mają tylko możliwość zmiany użytkownika.

Oprócz wspomnianych wyżej funkcji Zablokuj/Odblokuj wszystkich użytkowników Administrator może skorzystać z pozostałych funkcji menu podręcznego (prawy klawisz myszy lub klawisze Alt F3):

  • Sprawdź czy na pewno pracują - mogło się zdarzyć, że przed zakończeniem pracy w programie komputer został wyłączony lub wystąpiła jakaś awaria i program pokazuje, że jakiś użytkownik pracuje w programie, chociaż w rzeczywistości już tak nie jest. Do upewnienia się kto rzeczywiście pracuje w danym momencie w programie służy właśnie ta funkcja.

  • Odłącz wszystkich użytkowników - w szczególnych przypadkach administrator może odłączyć wszystkich użytkowników pracujących w programie. Funkcja to jest równoznaczna wykonaniu operacji Zakończ sesję dla wszystkich zalogowanych użytkowników.

UWAGA. Jeśli mamy już zainstalowany inny program firmy RESET2, np. R2fk lub R2płatnik, to zamiast wprowadzać od nowa użytkowników programu, możemy skorzystać z biblioteki użytkowników wprowadzonej np. w R2płatniku. W momencie otwarcia okna Użytkownicy program R2faktury automatycznie wykrywa czy na bieżącym serwerze SQL znajdują się bazy danych programów R2fk i R2płatnik, a jeśli tak, to proponuje integrację z nimi. W zintegrowanym programie R2faktury pojawią się automatycznie użytkownicy wprowadzeni wcześniej np. w R2płatniku. Zmiany wprowadzane w użytkownikach w dowolnym ze zintegrowanych programów, będą od razu widoczne w pozostałych programch. Integrację można również skonfigurować ręcznie (patrz INSTALOWANIE PROGRAMU - R2firma - integracja modułów).


Operacje użytkowników

PARAMETRYZACJA SYSTEMU - Użytkownicy

Ewidencja operacji [image] użytkowników pozwala prześledzić główne zdarzenia wykonywane przez poszczeglnych użytkowników. Jest to okno pomocnicze służące do serwisowania danych. Zdarzenia podzielone zostały na:

  • Logged On, Logged Off - zalogowanie i wylogowanie z bazy, czyli uruchomienie i zakończenie pracy z programem

  • Error Message, Exception - ostrzeżenia i komunikaty, czyli co pojawiło się użytkownikowi podczas pracy

  • F6, F7, F8 - zmiany w bazie danych, czyli kto, kiedy wprowadził (F7), zmodyfikował (F6) lub skasował (F8) dany rekord - operacje tego typu będą ewidencjonowane tylko wtedy, jeśli przy użytkowniku włączona będzie opcja Włącz śledzenie operacji bazodanowych.

Dla każdego rodzaju zdarzenia uwidoczniony jest inny zakres informacji szczegółowych.

Operacje możemy wyfiltrować dla konkretnego rodzaju zdarzenia (Pokaż zdarzenia) i w konkretnym okresie (Od daty, Do daty) dla konkretnej firmy (Firma).


Grupy użytkowników

PARAMETRYZACJA SYSTEMU - Użytkownicy

Grupy praw dostępu szczególnie przydatne są przy pracy sieciowej. W przypadku wersji jednostanowiskowej też możemy korzystać z ich właściwości, lecz nie jest to konieczne.

Grupy użytkowników są to grupy praw dostępu, czyli służą do ustalenia praw dostępu dla poszczególnych osób. Prawa przydzielamy do grupy osób (np. dla osób wprowadzających dane, czy osób sprawdzających i zamykających okresy rozliczeniowe), następnie przy użytkowniku ustalamy do jakiej grupy należy. Jeśli jakiś pracownik ma inne prawa niż dana grupa, wprowadzamy nową grupę i przydzielamy ją jemu.

UWAGA. Do modyfikowania [image] listy użytkowników i przypisywania ich do grup użytkowników dostęp ma tylko Administrator (ADMIN).

Przez prawa dostępu rozumiemy prawo danego użytkownika programu do przeglądania i wprowadzania danych oraz do wykonywania poszczególnych funkcji (np. przeliczenia, raporty).

Do wprowadzania i modyfikacji grup użytkowników wchodzimy z pozycji menu głównego Zbiory - Narzędzia - Grupy użytkowników.

UWAGA. Dostęp do modyfikacji grup użytkowników mają tylko użytkownicy przypisani do grupy, w której zaznaczone są prawa Narzędzia i Grupy użytkowników na zakładce Nadzór.

Nową grupę i jej prawa wprowadzamy [image] klawiszem Ins. Uzupełniamy:

  • Nazwa - nazwa grupy użytkowników

  • Rodzaj praw - ustawiamy główne prawa dostępu:

    • Nadzór - dostęp do ustawień wszystkich parametrów programu

    • Dostęp do danych - stopniowany dostęp do okien i funkcji:

      • Korygowanie - pełna możliwość wprowadzania, zmian i kasowania danych

      • Wprowadzanie - zmiany i kasowanie danych ograniczone do pozycji wprowadzonych przez użytkowników z własnej grupy

      • Przeglądanie - możliwość przeglądania danych

      • Brak praw - brak wglądu w dane

    • Ustaw prawa dostępu - na podstawie ustawionych głównych praw dostępu ustawiają się prawa dostępu dla poszczególnych okien i funkcji.
      UWAGA. Zaznaczenie głównych praw dostępu bez kliknięcia w ten przycisk nie zmieni żadnych praw.

  • Główne okna - dostęp do podstawowych okien programu

    • PZ - dostęp do okna z ewidencją PZ

    • Faktury - dostęp do okna z ewidencją faktur

      • Windykacja - dostęp do polecenia Windykacja należności i związanych z nią funkcji w menu na prawy klawisz myszy w oknie z fakturami

    • MM - dostęp do okna z ewidencją MM

    • Kasa/Bank - dostęp do okna z raportami kasowymi i bankowymi

      • Modyfik zamk. - możliwość poprawiania zamkniętych raportów kasowych bez konieczności ich otwierania

    • Windykacja - dostęp do globalnej windykacji należności

    • Przelewy - dostęp do listy przelewów bankowych

    • Firmy - dostęp do listy firm

    • Użytkownicy - dostęp do listy użytkowników

    • Kontrahenci - dostęp do biblioteki kontrahentów

      • Rozrachunki - dostęp do rozrachunków kontrahenta - menu podręczne (prawy klawisz myszy), pozycja Rozrachunki

      • Windykacja - dostęp do windykacji z okna Kontrahenci - menu podręczne (prawy klawisz myszy), pozycja Windykacja

    • Asortymenty - dostęp do biblioteki asortymentów

    • Stan magazynu - dostęp do okna z ewidencją stanów magazynowych

    • Kontakty - dostęp do okna z ewidencją kontaktów (CRM)

    • Kontrakty/Sprawy - dostęp do okna z ewidencją kontraktów/spraw (CRM)

    • Kampanie - dostęp do okna z ewidencją kampanii sprzedażowych (CRM)

    • Zlecenia transportowe - dostęp do okna ze zleceniami transportowymi

    • Inwentaryzacja - dostęp do okna z arkuszami inwentaryzacyjnymi

    • Noty korygujące - dostęp do okna z notami korygującymi

    • Biblioteki - dostęp do bibliotek w menu głównym Okna - Biblioteki

  • Nadzór - dostęp do ustawień parametrów związanych z pracą programu

    • Archiwizacja - dostęp do pozycji menu głównego Zbiory - Archiwizacja

    • Narzędzia - dostęp do pozycji menu głównego Zbiory - Narzędzia

    • Grupy użytkowników - dostęp do pozycji menu głównego Zbiory - Narzędzia - Grupy użytkowników

    • Raporty i zestawienia - dostęp do wbudowanych w program raportów i zestawień. Dostęp do poszczególnych zestawień, określony jest dodatkowo w ich definicji na zakładce Dostępność.

    • Statystyka - dostęp do statystyki firmy (menu Raporty - Statystyka)

    • Ustawienia - dostęp do pozycji menu głównego Ustawienia

    • Restrykcje - możliwość ustawiania parametrów restrykcji w menu Ustawienia - Restrykcje oraz na zakładce Restrykcje w bibliotece kontrahentów

    • Wczytaj/pobierz licencję - dostęp do pozycji menu głównego Pomoc - Wczytaj licencję z pliku oraz Pomoc - Pobierz licencję z internetu

    • Zamówienia on-line - możliwość składania zamówień na program, abonament lub rozszerzenie bezpośrednio z programu - pozycja menu głównego Pomoc - Zamówienia on-line

    • Zamykanie, Otwieranie - możliwość zamykania/otwierania okresu w celu zabezpieczenia się przed poprawianiem wprowadzonych dokumentów (patrz ROZPOCZĘCIE PRACY - Okno główne - Bieżąca data i okres)

    • Eksport/import - możliwość eksportu i importu danych. Dotyczy: eksportu dokumentów do programu księgowego, eksportu przelewów bankowych, importu płatności do raportu bankowego oraz dostępnych w każdym oknie funkcji Import danych, Eksport danych oraz Kopiuj do MS Excel

    • Dokumenty załączane - możliwość załączania do bazy danych zeskanowanych dokumentów (patrz ROZPOCZĘCIE PRACY - Okno główne - Funkcje dostępne w każdym oknie - Załączane dokumenty)

    • Tylko własne dokumenty - dostęp tylko do własnych dokumentów, tzn. wystawionych z własnej numeracji

    • Brak dostępu do cen nabycia - włączamy żeby ukryć wszystkie dane dotyczące cen nabycia i pochodnych wartości. We wszystkich oknach programu, w miejscach gdzie wyświetlane są ceny nabycia pokazane zostaną znaki ?. Dotyczy to również wartości pochodnych, np.: wartość nabycia, zysk, marża, wartość sprzedaży w dokumentach wystawionych w cenach nabycia. Dostępne tylko w wersji MAXI i PRO.

  • Raporty

    • Zestawienia - dostęp do zestawień definiowalnych. Dostęp do poszczególnych zestawień, określony jest dodatkowo w ich definicji na zakładce Dostępność.

    • Rejestr sprzedaży vat .. Potwierdzenia sald - dostęp do poszczególnych raportów wbudowanych w program

  • Ustawienia - dostęp do poszczególnych pozycji w menu głównym Ustawienia

  • Zaawansowane - możliwość ustawienia szczegółowych praw dostępu dla każdego okna oddzielnie.

Podsumowując należy zwrócić uwagę, że wprowadzanie nowej grupy użytkowników i ustalenie jej praw dostępu odbywa się w trzech etapach:

  1. Ustawienie głównych praw (Nadzór) i poziomów dostępu (Korygowanie, Wprowadzanie, Przeglądanie, Brak praw) zakończone funkcją Ustaw prawa dostępu.

  2. Ustawienie dostępu do poszczególnych okien i funkcji (Główne okna, Nadzór, Raporty, Ustawienia) programu.

  3. Skorygowanie szczegółowych praw dostępu (Zaawansowane) do poszczególnych okien systemu.

UWAGA. Kliknięcie w przycisk Ustaw prawa dostępu powoduje ustawienie szczegółowych praw dostępu na podstawie ustawionych głównych praw (pkt.1), dlatego nie klikamy już w ten przycisk po szczegółowym dostosowaniu praw (pkt.2 i 3).

Przycisk Zaawansowane umożliwia ustawienie (a raczej korygowanie) praw dostępu na najbardziej szczegółowym poziomie. Po kliknięciu w ten przycisk ukaże się lista wszystkich okien programu (a w zasadzie tabel z danymi, związanych z tymi oknami).

Po ustawieniu się na konkretnym oknie i przejściu na zakładkę Pozycja możemy szczegółowo ustalić prawa do tego okna:

  • Wprowadzanie rekordów - zaznaczamy, jeśli dana grupa użytkowników może wprowadzać nowe pozycje w tym oknie

  • Poprawianie rekordów - zaznaczamy, jeśli dana grupa użytkowników może poprawiać pozycje w tym oknie, wprowadzone przez użytkownika tej samej grupy. Użytkownik z wyłączonym prawem Poprawianie rekordów może poprawiać rekordy będące pozycjami innej tabeli, która jest w trybie tworzenia nowego rekordu. Np. jeśli wyłączono prawo Poprawianie rekordów dla tabeli POZYCJE FAKTUR, to użytkownik może poprawiać pozycje faktury, którą sam wystawia. Od momentu zatwierdzenia tej faktury nie może już jednak poprawiać jej pozycji.

  • Usuwanie rekordów - zaznaczamy, jeśli dana grupa użytkowników może kasować pozycje w tym oknie, wprowadzone przez użytkownika tej samej grupy. Użytkownik z wyłączonym prawem Usuwanie rekordów może usuwać rekordy będące pozycjami innej tabeli, która jest w trybie tworzenia nowego rekordu. Np. jeśli wyłączono prawo Usuwanie rekordów dla tabeli POZYCJE FAKTUR, to użytkownik może usunąć pozycje faktury, którą sam wystawia. Od momentu zatwierdzenia tej faktury nie może już jednak usuwać jej pozycji.

  • Poprawianie cudzych rekordów - zaznaczamy, jeśli dana grupa użytkowników może poprawiać pozycje w tym oknie, wprowadzone przez dowolnych użytkowników

  • Usuwanie cudzych rekordów - zaznaczamy, jeśli dana grupa użytkowników może kasować pozycje w tym oknie, wprowadzone przez dowolnych użytkowników

  • Przeglądanie - warunki przeglądania listy rekordów

    • Pełne prawa - możliwość wglądu w pełną listę

    • Ograniczone filtrem - przeglądanie ograniczonej listy rekordów na podstawie warunku ustalonego w pozycji Filtr przeglądania

    • Brak praw - brak wglądu w pozycje danego okna

  • Filtr przeglądania - formuła ograniczająca wyświetlane pozycje do tych, które spełniają wprowadzony tu warunek, np. wpisując filtr
    [Nazwa] LIKE 'VICTORIA%'
    dla okna (tabeli) FIRMY, ograniczymy dostęp do firm zaczynających się na 'VICTORIA';
    w formule możemy używać nazw pól w nawiasach kwadratowych, instrukcji warunkowych (and, or, =, <>) oraz instrukcji LIKE umożliwiającej częściowe porównanie tekstu (znak % oznacza dowolny tekst).

Na stałe w programie istnieje już grupa Administratorzy z pełnymi prawami dostępu do wszystkich funkcji i okien programu. Grupy tej nie można modyfikować ani usunąć. Standardowy użytkownik ADMIN (administrator) przypisany jest właśnie do tej grupy. Nic nie stoi na przeszkodzie, żeby utworzyć innych użytkowników i przypisać ich do tej grupy (przypisać im pełne prawa), lecz tylko i wyłącznie ADMIN będzie miał prawa do:

  • zmiany lub tworzenia nowej bazy danych

  • konwersji danych z wersji 6.09.


Wysyłanie wiadomości

PARAMETRYZACJA SYSTEMU - Użytkownicy

System umożliwia wysyłanie krótkich wiadomości do wybranego lub wszystkich użytkowników. Żeby wysłać powiadomienie, należy z menu Zbiory wybrać pozycję Krótka wiadomość. Użytkownicy pracujący w systemie otrzymają tą wiadomość natychmiast. Jeśli powiadomienie jest adresowane do użytkownika, który nie jest aktualnie w programie, wiadomość tą otrzyma zaraz po zalogowaniu.

UWAGA. W przypadku wysłania kilku wiadomości użytkownicy pracujący otrzymają je wszystkie, natomiast nowo zalogowani tylko ostatnią z nich.


Moduły programu

Konfiguracja modułów programu

PARAMETRYZACJA SYSTEMU

Program [image] składa się z kilku modułów. Wybierając i prawidłowo konfigurując odpowiednie moduły możemy w pełni przystosować program do specyfiki naszej firmy i naszych potrzeb. Dzięki temu skrócimy do minimum czas niezbędny na wdrożenie programu i wykorzystamy optymalnie jego możliwości.

Przede wszystkim musimy odpowiedzieć sobie na pytanie z jakich modułów i możliwości programu chcemy korzystać i wyłączyć od razu te, które będą dla nas nieprzydatne. Wybraną konfigurację można później w trakcie pracy z programem dostosowywać do naszych rosnących umiejętności i zmieniających się wymagań.

Podstawowe parametry określające konfigurację poszczególnych modułów w większości znajdują się w oknie [image] FIRMY na zakładce Ustawienia, a szczegółowo opisane są w kolejnych rozdziałach:

  • Magazyn

  • Sprzedaż

  • Kasa/Bank

  • Należności i zobowiązania

  • CRM.

Wersja demonstracyjna programu zawiera wszystkie moduły. Decydując się na zakup należy wybrać wersję programu zawierającą interesujące nas moduły i funkcjonalność.


Konfiguracja

Magazyn

PARAMETRYZACJA SYSTEMU - Konfiguracja modułów programu

Przed rozpoczęciem korzystania z modułu MAGAZYN, należy go wstępnie skonfigurować, tzn.:

  1. włączyć moduł MAGAZYN, czyli zaznaczyć pole Magazyn w ustawieniach bieżącej firmy [image] na zakładce Ustawienia - Ogólne w grupie Moduły

  2. sprawdzić w ustawieniach bieżącej firmy [image] na zakładce Ustawienia - Ogólne opcje wspólne dla modułu MAGAZYN i SPRZEDAŻ:

    • Precyzja - z dokładnością do ilu cyfr po przecinku można wpisać ilości w polu "Ile" w pozycjach faktur, pz, mm itd. Precyzja jest bardzo istotna dla bilansowania stanów magazynowych (suma przyjęć minus suma wydań musi być równa aktualnej ilości na stanie magazynu). Jej zmiana w trakcie pracy z programem może doprowadzić do utraty spójności danych i nie bilansowania się magazynu.

    • Indeksy asortymentowe - włączamy jeśli mamy dużo asortymentów i chcemy korzystać z indeksów do szybkiego wyszukiwania i identyfikacji asortymentów. Po włączeniu tego pola w oknach Faktury, PZ i MM pojawią się na zakładkach Pozycje kolumny z indeksami, podobnie jak na wydrukach faktury, WZ, RW, PZ i MM.

    • Marża - sposób obliczania marży

      • na "sto" - stosunek zysku do ceny nabycia: Marża=(WS-WN)/WN*100

      • w "stu" - stosunek zysku do ceny sprzedaży: Marża=(WS-WN)/WS*100

      gdzie WN - wartość nabycia, WS - wartość sprzedaży

    • Nr seryjne - włączamy jeśli chcemy kontrolować obrót pojedynczych sztuk towarów opatrzonych unikalnym numerem seryjnym. Nr seryjny określa się na PZ w momencie przyjęcia dostawy do magazynu. Wydając lub przesuwając towar z tej dostawy będziemy widzieć jej numer seryjny w tabelce z pozycjami dokumentu. Wydrukuje się on również na PZ, MM, WZ, RW i fakturze. Będzie także widoczny przy poszczególnych dostawach w stanie magazynu.

      • Nazwa - możemy zmienić nazwę "Nr seryjny" na dowolną inną, np. jeśli handlujemy telefonami komórkowymi możemy tu wpisać "Nr IMEI". Nowa nazwa będzie wszędzie używana zamiast standardowego "Nr seryjny"

      • Szerokość - szerokość kolumny (w pikselach) w tabelce z pozycjami na dokumentach PZ, MM, WZ, RW i fakturach. Ustawiamy w zależności od długości numerów seryjnych, którymi operujemy. Standardowo 80.

  3. wybrać odpowiednie opcje w ustawieniach bieżącej firmy [image] na zakładce Ustawienia - Magazyn:

    • Algorytm - algorytm wydawania/przesuwania towaru z magazynu. Towar przyjmowany do magazynu dzielony jest na tzw. dostawy. Dostawa odpowiada jednej pozycji dokumentu PZ. Z dostawą związana jest konkretna cena nabycia, dostawca, data nabycia, nr PZ oraz inne cechy, jak np. numer seryjny. W trakcie wydawania lub przesuwania towaru program odszukuje wg ustawionego tu algorytmu dostawy znajdujące się w wybranym magazynie i odpowiednio je modyfikuje.

      • FIFO - z ang. First In First Out, czyli to co pierwsze przyszło, pierwsze wychodzi, tzn. że jeśli mamy w magazynie kilka dostaw z tego samego asortymentu, ale przyjętych do magazynu w różnym czasie, to najpierw będą wydawane/przesuwane pozycje przyjęte najwcześniej - jest to najczęściej spotykany sposób prowadzenia magazynu

      • LIFO - z ang. Last In First Out, czyli to co ostatnie przyszło, pierwsze wychodzi, tzn. że najpierw wydajemy/przesuwamy dostawy przyjęte najpóźniej (w ramach tego samego asortymentu) - obecnie rzadko spotykany sposób prowadzenia magazynu, nadaje się najlepiej do wykorzystania w warunkach wzrastających cen nabycia, gdyż w porównaniu z FIFO daje przy tych samych operacjach magazynowych niższą wartość magazynu

      Bez względu na wybrany algorytm, program pilnuje cen nabycia konkretnych dostaw towaru i umożliwia wybór na dokumencie wydania lub przesunięcia konkretnej dostawy, niekoniecznie zgodnej z aktualnym algorytmem.
      UWAGA. Wyboru algorytmu należy dokonać przed rozpoczęciem operacji magazynowych. Zmiana algorytmu w trakcie pracy może spowodować utratę spójności danych.

    • Przesunięcia MM - włączamy jeśli chcemy korzystać z przesunięć międzymagazynowych MM

    • Kontrakty - włączamy jeśli chcemy kontrolować obrót wybraną partią towarów.

    • Faktury RR - włączamy jeśli chcemy przyjmować towar od rolników ryczałtowych i wystawiać w ich imieniu faktury RR

    • Transport - dostęp do zleceń transportowych (wersja PRO) oraz możliwość rozliczania jednostkowych kosztów transportu (wersja MAXI lub PRO)

      • Zysk uwzględnia transport - czy obliczany przez program zysk i marża mają uwzględniać koszty transportu nieujęte w cenie nabycia - dotyczy wartości pokazywanych w kolumnach Zysk oraz Marża w oknie Faktury na liście faktur oraz na zakładce WZ, w oknie Pozycje dokumentu na zakładce Wz, w oknie PZ w kolumnie Marża% na zakładce Pozycje oraz w statystyce firmy.

    • Chronologia wydań - parametr umożliwiający zablokowanie wydawania towaru przyjętego po dacie wystawienia faktury/WZ (towaru, którego nie było na stanie w momencie wystawiania faktury/Wz). Do tej pory pojawiał się jedynie komunikat ostrzegawczy.

  4. dostosować sposób numerowania oraz inne elementy definicji dokumentów magazynowych dostępnych w programie do dokumentów używanych w naszej firmie.


Konfiguracja

Sprzedaż

PARAMETRYZACJA SYSTEMU - Konfiguracja modułów programu

Przed rozpoczęciem korzystania z modułu SPRZEDAŻ, należy go wstępnie skonfigurować, tzn.:

  1. włączyć moduł SPRZEDAŻ, czyli zaznaczyć pole Sprzedaż w ustawieniach bieżącej firmy [image] na zakładce Ustawienia - Ogólne w grupie Moduły

  2. jeśli wystawiamy faktury eksportowe w walucie obcej lub w PLN albo krajowe w walucie obcej - włączyć obsługę transakcji zagranicznych, czyli zaznaczyć pole Transakcje zagraniczne w ustawieniach bieżącej firmy [image] na zakładce Ustawienia - Ogólne pod grupą Moduły - pole dostępne tylko w wersji MAXI i PRO

  3. sprawdzić w ustawieniach bieżącej firmy [image] na zakładce Ustawienia - Ogólne opcje wspólne dla modułu MAGAZYN i SPRZEDAŻ:

    • Precyzja - z dokładnością do ilu cyfr po przecinku można wpisać ilości w polu "Ile" w pozycjach faktur, pz, mm itd. Jeśli prowadzimy magazyn, to Precyzja jest bardzo istotna dla bilansowania stanów magazynowych (suma przyjęć minus suma wydań musi być równa aktualnej ilości na stanie magazynu). Jej zmiana w trakcie pracy z programem może doprowadzić do utraty spójności danych i nie bilansowania się magazynu.

    • Indeksy asortymentowe - włączamy jeśli mamy dużo asortymentów i chcemy korzystać z indeksów do szybkiego wyszukiwania i identyfikacji asortymentów. Po włączeniu tego pola w oknach Faktury, PZ i MM pojawią się na zakładkach Pozycje kolumny z indeksami, podobnie jak na wydrukach faktury, WZ, RW, PZ i MM.

    • Marża - sposób obliczania marży

      • na "sto" - stosunek zysku do ceny nabycia: Marża=(WS-WN)/WN*100

      • w "stu" - stosunek zysku do ceny sprzedaży: Marża=(WS-WN)/WS*100

      gdzie WN - wartość nabycia, WS - wartość sprzedaży

    • Nr seryjne - włączamy jeśli chcemy kontrolować obrót pojedynczych sztuk towarów opatrzonych unikalnym numerem seryjnym. Nr seryjny określa się na PZ w momencie przyjęcia dostawy do magazynu. Wydając lub przesuwając towar z tej dostawy będziemy widzieć jej numer seryjny w tabelce z pozycjami dokumentu. Wydrukuje się on również na PZ, MM, WZ, RW i fakturze. Będzie również widoczny przy poszczególnych dostawach w stanie magazynu. Jeśli nie korzystamy z modułu MAGAZYN, włączenie obsługi numerów seryjnych umożliwi nam wpisywanie nr seryjnych bezpośrednio na pozycji faktury.

      • Nazwa - możemy zmienić nazwę "Nr seryjny" na dowolną inną, np. jeśli handlujemy telefonami komórkowymi możemy tu wpisać "Nr IMEI". Nowa nazwa będzie wszędzie używana zamiast standardowego "Nr seryjny"

      • Szerokość - szerokość kolumny (w pikslach) w tabelce z pozycjami na dokumentach PZ, MM, WZ, RW i fakturach. Ustawiamy w zależności od długości numerów seryjnych, którymi operujemy. Standardowo 80.

  4. wybrać odpowiednie opcje w ustawieniach bieżącej firmy [image] na zakładce Ustawienia - Sprzedaż:

    • e-Faktury - uaktywnienie mechanizmu e-Faktur (pole dostępne tylko w wersji MAXI i PRO)

    • Faktury zaliczkowe - uaktywnienie mechanizmu faktur zaliczkowych (pole dostępne tylko w wersji MAXI i PRO)

    • Dane dedykowane - uaktywnienie mechanizmu danych dedykowanych (pole dostępne tylko w wersji MAXI i PRO)

    • Walutowe ceny sprzedaży - jeśli cennik sprzedaży prowadzimy w walucie obcej, niezależnie od tego czy sprzedajemy w kraju czy za granicą (pole dostępne tylko w wersji MAXI i PRO)

      • wg średniego kursu NBP - jeśli chcemy aktualizować cennik na bieżąco (wg średniego kursu NBP w momencie wstawienia asortymentu na fakturę) ustawiamy ten parametr. Jeśli natomiast chcemy aktualizować cennik "na żądanie", tzn. w momencie, który uznamy za stosowny, wówczas parametr wyłączamy, a cennik przeliczamy sami w dogodnym momencie korzystając z dostępnej w oknie Asortymenty funkcji F3 - Przelicz ceny walutowe.

    • Dokumenty powtarzalne - parametry do mechanizmu automatycznego wystawiania faktur powtarzalnych

      • Włączone - zaznaczamy, jeśli chcemy korzystać z tego mechanizmu

      • Pomiń weekendy i święta - jeśli dzień wystawienia faktury przypadnie w weekend lub święto, to zostanie on automatycznie przesunięty na pierwszy kolejny dzień pracujący. Uwzględniane są święta stałe oraz ruchome.

    • przycisk Akcyza wyrobów węglowych (patrz SPRZEDAŻ - Akcyza wyrobów węglowych). Dostępny tylko w wersji MAXI i PRO.

  5. dostosować sposób numerowania oraz inne elementy definicji dokumentów sprzedaży dostępnych w programie do dokumentów używanych w naszej firmie.


Konfiguracja

Kasa/Bank

PARAMETRYZACJA SYSTEMU - Konfiguracja modułów programu

Przed rozpoczęciem korzystania z modułu KASA/BANK, należy go wstępnie skonfigurować, tzn.:

  1. włączyć moduł KASA/BANK, czyli zaznaczyć pole Kasa/Bank w ustawieniach bieżącej firmy [image] na zakładce Ustawienia - Ogólne w grupie Moduły

  2. wybrać odpowiednie opcje w ustawieniach bieżącej firmy [image] na zakładce Ustawienia - Kasa/Bank:

    • Godziny - zaznaczamy jeśli chcemy prowadzić kilka raportów kasowych, np. w przypadku pracy zmianowej kasjerów, tak żeby każdy kasjer odpowiadał za stworzony przez siebie raport. Po zaznaczeniu tej opcji będziemy mogli określać datę początkową i końcową raportu z dokładnością do jednej minuty. Z taką samą dokładnością będzie określana data sporządzenia dokumentów KP i KW. Dostępne tylko w wersji MAXI i PRO.

  3. skonfigurować odpowiednie rachunki bankowe dla raportów bankowych (przelew) w danych firmy [image] na zakładce Przelewy przycisk Rachunki bankowe

  4. w oknie z definicjami dokumentów (menu główne Ustawienia - Definicje dokumentów):

    • utworzyć odpowiednie definicje dokumentów dla raportów kasowych (gotówka, karta płatnicza)

    • określić w jakich definicjach dokumentów chcemy korzystać z rozliczania płatności przy pomocy raportów kasowych lub bankowych

      • włączyć pole Rozrachunki

      • w części Kasa/Bank określić rodzaje raportów kasowych, na które będą księgowane odpowiednie formy płatności

  5. jeśli chcemy korzystać z modułu KASA/BANK w powiązaniu z dokumentami zakupu i sprzedaży, to należy w oknach PZ oraz Faktury włączyć kolumnę Kasa/Bank informującą o zaksięgowaniu w raporcie kasowym lub bankowym płatności dotyczących poszczególnych dokumentów. Takich dokumentów nie da się usunąć, a poprawiać można je tylko w ograniczonym zakresie.


Konfiguracja

Należności i zobowiązania

PARAMETRYZACJA SYSTEMU - Konfiguracja modułów programu

Przed rozpoczęciem korzystania z modułu NALEŻNOŚCI I ZOBOWIĄZANIA, należy go wstępnie skonfigurować, tzn.:

  1. włączyć moduł NALEŻNOŚCI I ZOBOWIĄZANIA, czyli zaznaczyć pole Należności i zobowiązania w ustawieniach bieżącej firmy [image] na zakładce Ustawienia - Ogólne w grupie Moduły

  2. wybrać odpowiednie opcje w ustawieniach bieżącej firmy [image] na zakładce Ustawienia - Należności i zobowiązania:

    • Rozrachunki - włącza dostęp do okna z rozrachunkami w bibliotece kontrahentów oraz w trakcie sporządzania dokumentów kasowych KP lub KW, dzięki czemu będziemy mogli korzystać z mechanizmu rozrachunków

    • Windykacja - włącza dostęp do okna z windykacją w oknie głównym i w bibliotece kontrahentów oraz zakładkę Windykacja na fakturze, dzięki czemu będziemy mogli korzystać z mechanizmu windykacji należności

    • Restrykcje - włącza mechanizm restrykcji w obrotach z nierzetelnymi kontrahentami

    • Minimalna wartość odsetek - kwota sprawdzana przed wystawieniem noty odsetkowej zarówno w oknie Windykacja jak i podczas regulowania przeterminowanych płatności w oknie Kasa/Bank bądź bezpośrednio w oknie Faktury na zakładce Płatność.


CRM

PARAMETRYZACJA SYSTEMU - Konfiguracja modułów programu

Przed rozpoczęciem korzystania z modułu CRM (dostępny tylko w wersji MAXI i PRO), należy go wstępnie skonfigurować, tzn.:

  1. włączyć moduł CRM, czyli zaznaczyć pole CRM w ustawieniach bieżącej firmy [image] na zakładce Ustawienia - Ogólne w grupie Moduły

  2. określić zawartość bibliotek niezbędnych do funkcjonowania modułu CRM:

    • Rodzaje kontaktów - w jaki sposób może powstać kontakt z kontrahentem

    • Poziomy kontraktów - jakie poziomy kontraktów sprzedażowych chcemy wyróżniać

    • Rezultaty - jakim rezultatem mogą się kończyć notatki serwisowe i ewentualnie jakie działania należy w ich efekcie podjąć

    • Kwalifikacje - jakie chcemy kwalifikować sprawy serwisowe

  3. zdefiniować Protokoły serwisowe, które możemy drukować jako potwierdzenie otwarcia i wykonania usługi serwisowej

  4. tym użytkownikom programu, którzy będą często korzystali z modułu CRM należy włączyć pasek CRM w konfiguracji głównego okna programu - dzięki temu uzyskają oni szybki dostęp do poszczególnych okien modułu


Rodzaje kontaktów

PARAMETRYZACJA SYSTEMU - Konfiguracja modułów programu - CRM

Okno Rodzaje kontaktów zawiera wszystkie możliwe sposoby kontaktu z klientami, z których korzystamy w naszej firmie. Można je wywołać z menu Ustawienia - Konfiguracja CRM - Rodzaje kontaktów. Dostępne tylko w wersji MAXI i PRO. Okienko jest wstępnie wypełnione (jak obok), ale można je dowolnie zmienić.

Z rodzajów kontaktów korzystamy przy tworzeniu notatek lub zadań w oknie Kontakty oraz w sprawach serwisowych w oknie Kontrakty/Sprawy.


Poziomy kontraktów

PARAMETRYZACJA SYSTEMU - Konfiguracja modułów programu - CRM

Okno Poziomy kontraktów zawiera wszystkie poziomy kontraktów sprzedażowych, jakie chcemy wyróżniać. Można je wywołać z menu Ustawienia - Konfiguracja CRM - Poziomy kontraktów. Okienko jest wstępnie wypełnione (jak obok), ale można je dowolnie zmienić.

Z poziomów kontraktów korzystamy w kontraktach sprzedażowych w oknie Kontrakty/Sprawy.


Rezultaty

PARAMETRYZACJA SYSTEMU - Konfiguracja modułów programu - CRM

Okna Rezultaty 1, Rezultaty 2 i Rezultaty 3 zawierają definicje rezultatów notatek serwisowych. Podstawowe rezultaty zawiera okno Rezultaty 1. Pozostałe dwa okna są jego ewentualnym uzupełnieniem.

Rezultat określa stan w jakim znajduje się sprawa po bieżącej notatce oraz/lub działania jakie należy podjąć w wyniku tej notatki.

Okna Rezultaty można wywołać z menu Ustawienia - Konfiguracja CRM - Rezultaty. Są one wstępnie wypełnione (jak niżej), ale można je dowolnie zmienić dostosowując dokładnie CRM do naszej specyfiki.

Z rezultatów korzystamy w notatkach serwisowych w oknie Kontakty. Rezultat z ostatniego kontaktu dotyczącego bieżącej sprawy serwisowej pokazywany jest w tej sprawie w oknie Kontrakty/Sprawy.

Wstępnie określone rezultaty w oknie Rezultaty 1 oznaczają:

  • K1 dostarczyć sprzęt
    Klient ma dostarczyć sprzęt. Ten rezultat wybierzemy, jeśli klient np. zgłosi jakiś problem telefonicznie i okaże się, że niezbędne jest dostarczenie wadliwego urządzenia do serwisu. Oglądając taką sprawę serwisową w oknie Kontrakty/Sprawy, będziemy wiedzieli, że mimo iż sprawa jest otwarta (status=otwarty), to możemy się nią nie zajmować, bo to klient ma wykonać jakieś działanie (rezultat zaczyna się od K, czyli klient), czyli właśnie dostarczyć sprzęt.

  • K2 odebrać sprzęt
    Klient ma odebrać sprzęt. Ten rezultat wybierzemy, jeśli sprzęt jest już naprawiony, klient został o tym poinformowany i czekamy, aż odbierze sprzęt. Oglądając taką sprawę serwisową w oknie Kontrakty/Sprawy, będziemy wiedzieli, że mimo iż sprawa jest otwarta (status=otwarty), to możemy się nią nie zajmować (rezultat zaczyna się od K, czyli klient), bo to klient ma wykonać jakieś działanie, czyli właśnie odebrać sprzęt.

  • S1 przyjęty do naprawy
    Sprzęt został przyjęty przez nas do naprawy, możemy wydrukować protokół otwarcia usługi serwisowej. Oglądając sprawę serwisową w oknie Kontrakty/Sprawy, będziemy wiedzieli, że sprawa jest otwarta (status=otwarty) i musimy się nią zajmować (rezultat zaczyna się od S, czyli serwis).

  • S2 załatwiony
    Sprzęt został przez nas naprawiony. Klient go odebrał, sprawa zostaje automatycznie zakończona (status=sukces), można wydrukować protokół wykonania usługi.

Jeśli wybierzemy rezultat S2 załatwiony, to na notatce poniżej tego rezultatu pojawi się pole 2 z możliwością określenia dodatkowego rezultatu (dlatego że w definicji rezultatu S2 załatwiony zaznaczono pole R2). Jeśli jako ten drugi rezultat wybierzemy płatne, to pojawią się pola Kwota i Opis (dlatego że w definicji rezultatu płatne zaznaczono pola Kwota i Opis).

UWAGA. Opisane wyżej rezultaty są jedynie propozycją. Właściwe zdefiniowanie rezultatów należy wykonać na etapie wdrożenia programu.

Wprowadzając [image] definicję nowego rezultatu (Ins), np. zamówienia na części, które trzeba wymienić w serwisowanym urządzeniu, ale nie ma ich w magazynie, określamy następujące pola:

  • Nazwa - nazwa rezultatu, dla porządku i lepszej orientacji warto trzymać się konwencji, że pierwsza litera nazwy oznacza odpowiedzialnego za dalszą realizację sprawy. Np. K to klient a S to nasz serwis. Jeśli w naszej firmie jest odrębny dział zaopatrzenia, to zamówienie brakujących części mogłoby się nazywać Z1 zamówić części.

  • Rezultat 1 - tylko w bibliotekach Rezultaty 2 i Rezultaty 3. Bieżący rezultat będzie dostępny tylko po wybraniu podanego tu rezultatu 1.

  • Rezultat 2 - tylko w bibliotece Rezultaty 3. Bieżący rezultat będzie dostępny tylko po wybraniu podanego tu rezultatu 2.

  • R2, R3 - na notatce pokażą się pola umożliwiające wybór drugiego oraz/lub trzeciego (bardziej szczegółowego) rezultatu

  • Kwota - na notatce pokaże się pole Kwota, w którym można wpisać np. przewidywaną lub faktyczną kwotę za naprawę

  • Opis - na notatce pokaże się pole Opis, w którym można wpisać np. dodatkowe wyjaśnienie podanej kwoty albo dodatkowy opis zlecanego zadania

  • Komu - na notatce pokaże się pole Komu, w którym można określić komu zlecamy wykonanie zadania powiązanego z tą notatką

  • Zadanie 1, Zadanie 2 - do każdej zatwierdzanej notatki możemy automatycznie utworzyć jedno bądź dwa zadania do wykonania przez siebie lub innego użytkownika programu:

    • Kiedy - z jaką datą (Od) ma zostać utworzone zadanie. Możemy skorzystać z tagów systemowych podpowiadanych w menu podręcznym Wstaw (prawy klawisz myszy na tym polu).

    • Do kiedy - z jaką datą końcową (Do) ma zostać utworzone zadanie. Możemy skorzystać z tagów systemowych podpowiadanych w menu podręcznym Wstaw (prawy klawisz myszy na tym polu).

    • Opis - z jakim opisem (Zlecający) ma zostać utworzone zadanie. Możemy skorzystać z tagów systemowych podpowiadanych w menu podręcznym Wstaw (prawy klawisz myszy na tym polu).

    • Dla kogo - dla kogo (Prowadzący) zostanie utworzone zadanie. Możemy skorzystać z tagów systemowych podpowiadanych w menu podręcznym Wstaw (prawy klawisz myszy na tym polu).

    • Rodzaj - zadanie z takim rodzajem kontaku (Rodzaj) zostanie utworzone po wybraniu tego rezultatu.

  • Kwalifikacja - jak zostanie zakwalifikowana bieżąca sprawa serwisowa po wyborze tego rezultatu na notatce. Wybieramy odpowiednią pozycję z biblioteki kwalifikacji.

Po wybraniu w notatce serwisowej rezultatu zdefiniowanego tak jak powyżej, w oknie Kontakty zostaną utworzone automatycznie dwa zadania do wykonania:

  • zadanie 1

    • treść zadania to: "zamówić brakujące części" lub inna określona w polu Opis, które pojawiło się na notatce pod rezultatem

    • okres, w którym należy wykonać zadanie, to najpóźniej jeden dzień począwszy od daty notatki

    • zadanie zostanie zlecone użytkownikowi programu wybranemu w polu Komu, które pojawiło się na notatce po rezultatem

  • zadanie 2

    • treść zadania to: "sprawdzić czy zamówione"

    • data zadania, to jeden dzień późńiej niż data notatki

    • zadanie zostanie zlecone temu samemu użytkownikowi, który zapisał notatkę (Prowadzący).

UWAGA. Jeśli w jednej notatce wybrano kilka rezultatów i w każdym z nich określono zadania do wykonania, to zostanie utworzone zadanie z ostatniego rezultatu, np. jeśli wybrano rezultat 1,2 i 3 i w każdym z nich są określone definicje zadań, to zostanie utworzone zadanie z rezultatu 3. Reguła ta dotyczy niezależnie zadań definiowanych jako Zadanie 1 i Zadanie 2.


Kwalifikacje

PARAMETRYZACJA SYSTEMU - Konfiguracja modułów programu - CRM

Okno Kwalifikacje zawiera kwalifikacje spraw serwisowych. Można je wywołać z menu Ustawienia - Konfiguracja CRM - Kwalifikacje. Okienko jest wstępnie wypełnione (jak obok), ale można je dowolnie zmienić.

Z kwalifikacji korzystamy w kontaktach Kontakty. Kwalifikacja z ostatniego kontaktu w danej sprawie, przepisuje się do okna Kontrakty/Sprawy.

Definiując kwalifikację określamy:

  • Nazwa - nazwa kwalifikacji

  • Czas na wykonanie - czas na zamknięcie sprawy serwisowej o takiej kwalifikacji

  • Można zmienić - czy zadany czas można zmieniać bezpośrednio na notatkach

  • Kolor - kolor w jakim będzie pokazywana nazwa kwalifikacji w kolumnach okna Kontakty i Kontrakty/Sprawy. Dzięki temu można łatwo wyłuskać kontakty i sprawy o szukanej kwalifikacji.


Protokoły serwisowe

PARAMETRYZACJA SYSTEMU - Konfiguracja modułów programu - CRM

Okno Protokoły serwisowe służy do konfigurowania protokołu otwarcia usługi serwisowej i protokołu wykonani usługi serwisowej. Można je wywołać z menu Ustawienia - Konfiguracja CRM - Protokoły serwisowe. Okienko jest wstępnie wypełnione (jak niżej), ale można je dowolnie zmienić.

Protokoły otwarcia i zamknięcia definijemy w osobnych grupach zawierających analogiczne pola:

  • Rezultat - dla notatki serwisowej o wybranym tutaj rezultacie będzie można wydrukować odpowiedni protokół

  • Numer protokołu - sposób numerowania protokołu (patrz wyjaśnienie w definicji dokumentów sprzedaży)

  • Nazwa - nazwa protokołu. Pojawia się w menu drukowania w oknie Kontakty oraz na wydruku protokołu.

Korzystając z przycisku Domyślne możemy w każdej chwili przywrócić domyślne nazwy i sposób numerowania protokołów.


Definicje dokumentów

PARAMETRYZACJA SYSTEMU

Przed rozpoczęciem wystawiania dokumentów należy określić, z jakich dokumentów korzystamy w firmie i które z tych dokumentów będą wystawiane w programie. Chodzi tu o dokumenty sprzedaży (faktury, paragony, proformy) oraz, jeśli chcemy prowadzić magazyn, dokumenty magazynowe (PZ, MM, WZ, RW, faktura VAT RR). Ponadto jeśli zamierzamy korzystać z modułu Kasa/Bank, należy przeprowadzić podobną analizę jeśli chodzi o raporty kasowe.

Dokumenty, z których można korzystać w programie zdefiniowane są w oknie Definicje dokumentów dostępnym przez menu główne Ustawienia - Definicje dokumentów.

Definicje dokumentów można podzielić na:

  • Dokumenty sprzedaży

  • Wydania z magazynu

  • Przyjęcia do magazynu

  • Przesunięcia międzymagazynowe

  • Raporty kasowe

  • Zlecenia transportowe.

Standardowo po zainstalowaniu przygotowane są definicje najczęściej używanych dokumentów. Jeśli są wśród nich te, z których korzystamy w firmie i nie mamy specjalnych wymagań co do ich zawartości i wyglądu, możemy się na razie nie zagłębiać w szczegóły definicji tych dokumentów. W takim wypadku przed rozpoczęciem wystawiania dokumentów musimy jedynie dostosować sposób ich numerowania, tzn. numer kolejny pierwszego dokumentu wystawionego w programie oraz układ tego numeru. Pozostałe właściwości dokumentów będziemy mogli zawsze zmienić później, w miarę potrzeb.

Istniejące definicje można w każdej chwili zmodyfikować dostosowując je do naszych potrzeb. Dokumenty, z których nie będziemy korzystać, można usunąć, żeby niepotrzebnie nie komplikowały nam pracy. W razie potrzeby będzie je można w każdej chwili zdefiniować na nowo, korzystając z przygotowanych wzorców. W zależności od tego czy jesteśmy płatnikiem podatku vat można również skorzystać z [image] F4 właściwości okna i włączyć filtr na dokumenty sprzedaży związane z vatem lub nie.


Dokumenty sprzedaży

PARAMETRYZACJA SYSTEMU - Definicje dokumentów

Są to dokumenty typu:

  • z vatem: Faktura, Paragon, Faktura proforma, Faktura wewnętrzna,

  • bez vatu: Rachunek, Paragon (bez vatu), Rachunek proforma

oraz Zamówienie (sprzedaż) i dodatkowo Inny (sprzedaż).

Podstawowe różnice między tymi rodzajami dokumentów, to sposób automatycznego księgowania do programów księgowych (R2księga lub R2fk) - patrz pole Księgowany jako.

Tworząc definicję nowego dokumentu związanego ze sprzedażą lub modyfikując już istniejącą definicję wypełniamy następujące pola:

  • Ogólne - ogólne informacje o dokumencie

    • Nazwa skrócona - służy do wybierania rodzaju w trakcie wystawiania dokumentu

    • Nazwa pełna - używana na wydrukach

    • Typ - podstawowy/korekta - dokumenty podstawowe tworzy się bezpośrednio w oknie z dokumentami, korekty tworzy się na bazie konkretnego dokumentu podstawowego

    • Dokument korygujący - jeśli definicja dotyczy typu podstawowego, to w tym miejscu określamy jaka definicja dokumentu będzie używana do korygowania tego dokumentu

    • Numer

      • Układ - układ numeru, czyli jak ma wyglądać pełny numer dokumentu; układ może zawierać symbole systemowe, które będą automatycznie zamieniane na odpowiednie wartości oraz dowolne inne cyfry i litery;
        Symbole systemowe:

        • # - wyliczany przez program numer kolejny dokumentu

        • 0 - zero, wstawione przed # oznacza znak do wypełnienia przez numer kolejny

        • RR - rok 2-cyfrowy

        • RRRR - rok 4-cyfrowy

        • MM - miesiąc (numeracja co miesiąc od 1)

        • MC - miesiąc (numeracja w obrębie roku)

        • $U - symbol użytkownika (patrz Współdzielenie definicji)

        • $M - symbol magazynu (patrz Współdzielenie definicji).

        Na przykład, jeśli w dniu 02-04-2012 wystawiliśmy 134-ą fakturę od początku roku (a 6-tą w kwietniu), jej pełny numer będzie dla różnych układów wyglądał następująco:

        Układ

        Numer

        Uwagi

        #/RR

        134/10

        rok dwucyfrowy

        #/RRRR

        134/2012

        rok czterocyfrowy

        #/RR/F

        134/12/F

        dodatkowy symbol na końcu

        G/#/RR

        G/134/12

        dodatkowy symbol na początku

        00#/RR

        134/12

        numer ma przynajmniej 3 znaki

        000#/RR

        0134/12

        numer ma przynajmniej 4 znaki

        0000#/RR

        00134/12

        numer ma przynajmniej 5 znaków

        #/MM/RR

        6/04/12

        numeracja w obrębie bieżącego miesiąca

        #/MC/RR

        134/04/12

        numeracja w obrębie roku z dodanym symbolem miesiąca

        #/RR/F/$U

        134/12/F/KR

        KR to symbol użytkownika określony w bibliotece użytkowników

        #/RR/F/$M

        134/12/F/M1

        M1 to symbol magazynu określony w bibliotece magazynów

      • Pierwszy - numer pierwszego dokumentu, który będziemy wystawiać w programie, np. jeśli dotychczas (ręcznie lub w innym programie) wystawiliśmy 210 faktur musimy w tym polu wpisać 211

      • W roku - w którym roku rozpoczynamy wystawianie dokumentów

      • W miesiącu - w którym miesiącu rozpoczynamy wystawianie dokumentów (istotne tylko, jeśli w układzie numeru jest symbol systemowy MM)

      • Pozwól na luki - standardowo dokumenty są numerowane tak, aby zachować ciągłość numeracji. Po zaznaczeniu tej opcji program pozwoli na ręczne nadawanie numerów, pozwalając na ewentualne luki w numeracji, a pilnując jedynie aby numery się nie powtarzały.

      • Kontrola chronologii - po zaznaczeniu tego pola program uniemożliwi wystawienie faktury z datą wcześniejszą niż data istniejących już dokumentów wystawionych wg tej samej definicji. Zabezpieczymy się w ten sposób przed przypadkowym bałaganem w numerowaniu faktur. Przy wyłączonym polu kontrola chronologii też jest prowadzona, ale w formie ostrzegawczych komunikatów, które użytkownik może zignorować. Kontrola chronologii dostępna jest tylko dla dokumentów dotyczących sprzedaży (faktury, faktury proforma, paragony, rachunki).

    • Waluta - waluta dokumentu. Dostępne tylko w wersji MAXI i PRO. Jeśli wybierzemy PLN i zaznaczymy pole Zagraniczny (patrz niżej), to będziemy mogli zmieniać walutę w trakcie wystawiania kolejnych dokumentów, tzn. będziemy mogli wystawiać faktury krajowe oraz eksportowe w walucie obcej w ramach jednej numeracji faktur. Jeśli wybierzemy inną walutę np. EUR, to faktury wystawiane w ramach tej definicji będą zawsze w EUR, bez możliwości zmiany na inną walutę.

    • Powtarzalny - jeśli chcemy, aby z tego rodzaju dokumentów była możliwość wystawiania dokumentów powtarzalnych

    • Rozrachunki - jeśli chcemy, aby tego rodzaju dokumenty były uwzględniane w rozrachunkach z kontrahentem

    • Windykacja - jeśli chcemy, aby z tego rodzaju dokumentów była możliwość automatycznej windykacji należności

    • Zagraniczny - jeśli chcemy, aby tego rodzaju dokumenty były wystawiane jako faktury eksportowe (patrz niżej - pole Księgowany jako), w PLN lub w walutach obcych. Dostępne tylko w wersji MAXI i PRO.

    • Uproszczony - jeśli chcemy, aby tego rodzaju dokumenty były wystawiane jako faktury uproszczone, czyli bez pełnych danych nabywcy (wystarczy jego NIP). Zgodnie z obowiązującymi przepisami faktura może mieć formę uproszczoną jeśli wartość brutto faktury nie przekracza 450 PLN lub 100 EUR.

    • Kasa/Bank - określamy do jakich raportów mają wchodzić odpowiednie formy płatności.
      Np. przy ustawieniu jak w zamieszczonym wyżej przykładowym okienku, płatności gotówkowe będą księgowane do raportu kasowego o symbolu RK, przelewy będą księgowane na raporcie bankowym związanym z rachunkiem Główny, a wpłaty kartą płatniczą będą ujmowane w raporcie kasowym RK karta

    • Księgowany jako - określany automatycznie rodzaj dokumentu istotny przy księgowaniu do programu księgowego - R2księga (księga przychodów lub ewidencja ryczałtowa) lub R2fk (pełna księgowość). Faktura proforma i Rachunek proforma oraz Inny (sprzedaż) nie są księgowane, Faktura wewnętrzna jest księgowana jako f-ra wewnętrzna, a pozostałe dokumenty jako S - sprzedaż krajowa. Jeśli zaznaczyliśmy wyżej pole Zagraniczny, to w przypadku dokumentu typu Faktura możemy wybrać typ faktury eksportowej (D - wewnątrzwspólnotowa dostawa towarów, E - eksport towarów, U - eksport usług). Jeśli zaznaczono pole Zagraniczny, a w polu Księgowany jako wybrano S - sprzedaż krajowa, to typ faktury eksportowej będzie można wybrać bezpośrednio w trakcie wystawiania faktury - dzięki temu w ramach jednej definicji dokumentu, a co za tym idzie w ramach jednej numeracji, można wystawiać w zależności od potrzeb zarówno faktury krajowe jak i zagraniczne odpowiedniego typu. Jeśli natomiast wybierzemy inną opcję niż Sprzedaż krajowa, to wszystkie dokumenty wystawiane w ramach tej definicji będą wybranego typu.

  • Zawartość - jakie dane powinien zawierać ten dokument; dotyczy zarówno wprowadzania danych jak i wydruku

    • Elementy dokumentu

      • Nabywca - dane nabywcy

      • NIP - nip nabywcy

      • Odbiorca - dane odbiorcy

      • Rabat - rabat procentowy i kwotowy do całej faktury

      • Płatność, Uwagi, Notatki - odpowiednie zakładki dokumentu

    • WZ - aktywne jeśli włączyliśmy moduł MAGAZYN (w danych bieżącej firmy zakładka Ustawienia - Ogólne grupa Moduły pole Magazyn)

      • Włączony - jeśli z tym rodzajem dokumentu ma być skojarzony automatyczny dokument WZ, czyli wydanie towarów z magazynu

      • WZ - definicja dokumentu WZ skojarzonego z bieżącym dokumentem sprzedaży, z tej definicji będą pobierane dane do numerowania skojarzonego, automatycznego dokumentu WZ

    • VAT

      • Włączony - jeśli wyłączymy, to kolumny dotyczące podatku Vat oraz podsumowanie z rozbiciem na stawki nie będą drukowane

      • Stawki VAT - włączenie na dokumencie zakładki Stawki Vat

      • Podstawa przeliczeń

        • netto - ceny i wartości na pozycji dokumentu oraz na całym dokumencie będą przeliczane od ceny netto, tzn.

          Gdzie

          Netto

          Vat

          Brutto

          na pozycji dokumentu

          wn=cn*ilość

          vat=wn*vat%/100

          wb=wn+vat

          na dokumencie
          (liczone niezależnie dla każdej występującej na dokumencie stawki vat)

          WN=Suma(wn)

          VAT=WN*vat%/100

          WB=WN+VAT

          gdzie:

          • cn - jednostkowa cena netto

          • ilość - ilość jednostek na jednej pozycji dokumentu

          • wn - wartość netto jednej pozycji dokumentu

          • vat - vat od jednej pozycji dokumentu

          • wb - wartość brutto jednej pozycji dokumentu

          • WN - wartość netto wszystkich pozycji dokumentu z tą samą stawką vat

          • VAT - vat od wszystkich pozycji dokumentu z tą samą stawką vat

          • WB - wartość brutto wszystkich pozycji dokumentu z tą samą stawką vat

          • vat% - stawka vat

        • brutto - ceny i wartości na pozycji dokumentu oraz na całym dokumencie będą przeliczane od ceny brutto, tzn.

          Gdzie

          Netto

          Vat

          Brutto

          na pozycji dokumentu

          wn=wb-vat

          vat=wb*vat%/(100+vat%)

          wb=cb*ilość

          na dokumencie
          (liczone niezależnie dla każdej występującej na dokumencie stawki vat)

          WN=WB-VAT

          VAT=WB*vat%/(100+vat%)

          WB=Suma(wb)

          Podstawę brutto wybiera się zwykle dla wszystkich dokumentów, do których będą drukowane paragony fiskalne, żeby uniknąć rozbieżności między drukarką fiskalną, która liczy właśnie od cen brutto, a programem.

        Niezależnie od podstawy przeliczeń łączne wartości netto, vat i brutto całego dokumentu są sumami kwot WN, VAT i WB wyliczonych niezależnie dla wszystkich stawek vat występujących na dokumencie.

      • Fiskalny - jeśli mamy obowiązek korzystania z drukarki fiskalnej, należy zaznaczyć to pole we wszystkich dokumentach, do których będą drukowane paragony fiskalne (patrz Urządzenia fiskalne)

      • Oddział - jeśli chcemy dzielić wydruki rejestrów vat na oddziały (różne miejsca prowadzenia sprzedaży), należy dla każdego oddziału utworzyć odrębną definicję każdego dokumentu sprzedaży i określić w tych definicjach odpowiedni oddział.

      • VAT w PLN - istotne dla dokumentów dotyczących sprzedaży krajowej w walucie obcej. Na takich dokumentach podatek VAT może być naliczany w PLN lub w walucie dokumentu. Wybrana tu wartość będzie domyślnie ustawiana na dokumentach. W razie potrzeby można ją zmienić bezpośrednio na dokumencie na zakładce Stawki VAT w polu VAT w PLN.

      • Odwrotne obciążenie - zaznaczamy jeśli VAT z tego dokumentu ma być rozliczany przez nabywcę. Wybrana tu wartość będzie domyślnie ustawiana na dokumentach. W zależności od potrzeb możemy korzystać z osobnej definicji przeznaczonej tylko dla tego typu transakcji (Odwrotne obciążenie włączony w definicji dokumentu) lub wystawiać z jednej definicji (i numeracji) faktury zwykłe (z naliczonym podatkiem VAT) oraz faktury, dla których nabywca jest podatnikiem (pole Odwrotne obciążenie włączamy/wyłączamy na poszczególnych dokumentach). Jeśli zaznaczono to pole, na fakturach wystawionych w ramach tej definicji pod numerem faktury pojawi się adnotacja "odwrotne obciążenie".

      • Kiedy rozliczyć - sposób rozliczenia vat, istotny przy automatycznym księgowaniu dokumentu sprzedaży w programie księgowym oraz wpływający na wydruk rejestru sprzedaży vat i zestawienia sprzedaży vat. Wybieramy jeśli ten rodzaj dokumentu ma być księgowany w szczególny sposób. Jeśli ma być księgowany z domyślnym sposobem rozliczenia vat (data sprzedaży (data dost.tow. lub wykon.usł.)), pozostawiamy to pole puste.

    • Księgowany wg daty sprzedaży - istotne tylko przy automatycznym księgowaniu dokumentu w programie księgowym. Jeśli zaznaczone, to wszystkie dokumenty wystawione wg tej definicji będą ksiegowane wg daty sprzedaży, a nie wg daty wystawienia faktury.

    • Termin od daty sprzedaży - jeśli zaznaczone, to wszystkie dokumenty wystawione wg tej definicji będą miały naliczany termin płatności od daty sprzedaży, a nie od daty wystawienia

  • Wydruk - co ma być drukowane, opcje przydatne przy definiowaniu niestandardowych dokumentów

    • Język - wybór języka, w jakim zostanie wydrukowana faktura. Opcja dostępna tylko w wersji MAXI i PRO.

    • Sprzedawca

      • Dane - nazwa, adres oraz NIP sprzedawcy

      • NIP - NIP sprzedawcy

      • Bank/Konto - Bank i nr rachunku bankowego sprzedawcy

    • Logo - graficzne logo firmy (wprowadzone w oknie FIRMY)

    • Nr dokumentu - numer dokumentu

    • Oryginał / Kopia - w świetle przepisów obowiązujących od 2013 roku nie ma obowiązku oznaczania dokumentów tekstem Oryginał/Kopia, w takim przypadku można to pole wyłączyć

    • Miejscowość

    • Sprzedawca, Nabywca, Odbiorca - nagłówki odpowiednich części dokumentu, standardowo SPRZEDAWCA:, NABYWCA: i ODBIORCA:

    • PKWiU - nagłówek kolumny PKWiU; jeśli pusty tzn. że "PKWiU". Pole PKWiU można wyłączyć, gdyż w świetle obowiązujących przepisów nie ma obowiązku podawania go przy podstawowej stawce VAT. Jeśli jednak stawka VAT jest różna od podstawowej, warto skorzystać z tego pola w celu wskazania podstawy obniżenia stawki, wówczas pole PKWiU należy włączyć.

    • Indeksy asortymentowe - jeśli na wydruku ma się pojawiać oprócz nazwy asortymentu również jego indeks. Wartość tego pola jest standardowo taka sama jak pola Indeksy w danych firmy na zakładce Ustawienia - Ogólne. Jeśli akurat ten dokument chcemy drukować inaczej niż ustawiono w danych firmy, możemy tutaj włączyć lub wyłączyć drukowanie indeksów.

    • Dodatkowe marginesy drukarki - dodatkowe marginesy dotyczące wydruku nagłówka (Górny) i stopki (Dolny). Jeśli chcemy drukować ten dokument na papierze firmowym, musimy ustawić odpowiednie marginesy, tak żeby nie drukować na zadrukowanym już obszarze papieru firmowego. Oprócz tych ustawień należy jeszcze odpowiednio dostosować marginesy właściwego wydruku we właściwościach [image] F4 okna Przegląd wydruku.

    • Daty

      • wystawienia - włącza wydruk daty wystawienia

      • Data sprzedaży

        • włączona - włącza wydruk daty sprzedaży, będzie ona drukowana na fakturze tylko wówczas, gdy będzie różna od Daty wystawienia

        • Tekst - standardowo zgodnie z przepisami na fakturze będzie drukowany tekst Data dokonania lub zakończenia dostawy towarów lub wykonania usługi, nic nie stoi jednak na przeszkodzie, by wpisać w tym polu dowolny tekst, który ma się drukować zamiast standardowego

        • Miesiąc - jeśli chcemy, żeby drukował się tylko miesiąc sprzedaży np. wrzesień 2012 zamiast pełnej daty np. 10-09-2012

    • Uwagi - czy mają być drukowane odpowiednie uwagi

    • Płatność od daty - czy przy nieuregulowanych płatnościach ma się pojawiać informacja:

      • wystawienia - np. DO ZAPŁATY 200,00 zł PRZELEWEM do dnia 24-09-2012 (14 dni od daty wystawienia)

      • otrzymania - np. DO ZAPŁATY 200,00 zł PRZELEWEM w ciągu 14 dni od daty otrzymania

    • Wystawione WZ - czy na fakturze/paragonie ma się drukować lista powiązanych dokumentów WZ

    • Wystawione paragony - czy na fakturze ma się drukować lista powiązanych paragonów

    • Data zapłaty - czy na dokumencie ma być drukowana data zapłaty w sytuacji, gdy data zapłaty i data wystawienia dokumentu są jednakowe (za wyjątkiem zapłaty gotówką)

    • Zabezpiecz PDF - czy plik PDF otrzymany z tego wydruku ma być zaszyfrowany i zabezpieczony przed kopiowaniem i modyfikacją

    • To nie jest faktura - czy na fakturze proforma ma się drukować uwaga "UWAGA! TEGO DOKUMENTU NIE WOLNO KSIĘGOWAĆ, GDYŻ NIE STANOWI ON FAKTURY W MYŚL PRZEPISÓW USTAWY O PODATKU OD TOWARÓW I USŁUG."

  • Nagłówek/Stopka

    • Podpis sprz. - czy i jaki tekst ma się pojawić na wydruku pod miejscem przewidzianym na podpis sprzedawcy; na dokumentach związanych z podatkiem VAT pole powinno być włączone z tekstem podpis / pieczęć osoby upoważnionej do wystawiania faktur VAT.

    • Podpis nab. - czy i jaki tekst ma się pojawić na wydruku pod miejscem przewidzianym na podpis nabywcy; na dokumentach związanych z podatkiem VAT pole powinno być włączone z tekstem czytelny podpis osoby upoważnionej do odbioru faktur VAT.

    • Nagłówek - dodatkowy tekst, który pojawi się w nagłówku faktury; dodatkowo może być otoczony ramką (Ramka)

    • Stopka - dodatkowy tekst, który pojawi się w stopce faktury; dodatkowo może być otoczony ramką (Ramka)

  • Makiety

    • Dokument - wybór makiety, określającej wygląd wydrukowanego dokumentu

    • Eksport, Krajowy w walucie, Nabywca podat. - w definicji faktury - wybór makiety dla faktury eksportowej, dla faktury krajowej w walucie obcej oraz dla faktury, w której VAT ma być rozliczany przez nabywcę

    • KP, KW - w definicji raportu kasowego - wybór makiet dla KP i KW.


Wydania z magazynu

PARAMETRYZACJA SYSTEMU - Definicje dokumentów

Wydanie towaru z magazynu umożliwiają dwa rodzaje dokumentów: WZ (wydanie zewnętrzne) oraz RW (rozchód wewnętrzny). Innym dokumentem o podobnym charakterze jest protokół rozbieżności PR-, ale służy on do uzgadniania stanu faktycznego ze stanem w programie, a nie do wydania towaru.

Dokumenty RW - Rozchód wewnętrzny i PR- są niezależne od vatu, natomiast WZ występuje w wersjach z vatem i bez vatu:

  • z vatem: WZ - Wydanie

  • bez vatu: WZ - Wydanie (bez vatu).

Tworząc definicję nowego dokumentu wydania z magazynu WZ (lub RW albo PR-) albo modyfikując już istniejącą definicję wypełniamy następujące pola:

  • Ogólne - ogólne informacje o dokumencie

    • Nazwa skrócona - służy do wybierania rodzaju w trakcie wystawiania dokumentu

    • Nazwa pełna - używana na wydrukach

    • Numer - sposób numerowania dokumentu (patrz wyjaśnienie w dokumentach sprzedaży)

  • Zawartość - jakie dane powinien zawierać ten dokument; dotyczy zarówno wprowadzania danych jak i wydruku

    • Elementy dokumentu

      • Nabywca - dane nabywcy

      • NIP - nip nabywcy

      • Odbiorca - dane odbiorcy

      • Rabat - rabat procentowy i kwotowy do całej faktury

      • Płatność, Uwagi, Notatki - odpowiednie zakładki dokumentu

    • VAT - opcje związane z vatem (patrz wyjaśnienie w dokumentach sprzedaży). Dokument WZ, chociaż służy głównie do wydania towaru z magazynu, może również stanowić podstawę do wystawienia faktury VAT (jeśli WZ wystawiamy przed fakturą a nie na odwrót) - stąd na WZ opcje związane z vatem i płatnościami.

      • Fiskalny - jeśli mamy obowiązek korzystania z drukarki fiskalnej, należy zaznaczyć to pole we wszystkich dokumentach, do których będą drukowane paragony fiskalne (patrz Urządzenia fiskalne).

    • Nabywca podatnikiem - zaznaczamy jeśli VAT z tego dokumentu ma być rozliczany przez nabywcę. Wybrana tu wartość będzie domyślnie ustawiana na dokumentach Wz. W zależności od potrzeb możemy korzystać z osobnej definicji przeznaczonej tylko dla tego typu transakcji (Nabywca podatnikiem włączony w definicji dokumentu) lub wystawiać z jednej definicji (i numeracji) dokumenty Wz zwykłe (z naliczonym podatkiem VAT) oraz Wz, dla których nabywca jest podatnikiem (pole Nabywca podatnikiem włączamy/wyłączamy na poszczególnych dokumentach). Jeśli zaznaczono to pole, na dokumentach Wz wystawionych w ramach tej definicji pojawi się adnotacja "odwrotne obciążenie".

    • Termin od daty sprzedaży - jeśli zaznaczone, to wszystkie dokumenty wystawione wg tej definicji będą miały naliczany termin płatności od daty sprzedaży, a nie od daty wystawienia

    • Konto zakupów - konto jakie będzie podstawiane na dokumentach RW jako konto magazynu (MA). Można wpisać konkretne konto albo symbol [M], który spowoduje podstawienie konta związanego z wybranym na dokumencie magazynem (kolumna Konto zak. w bibliotece magazynów). Dotyczy tylko pełnej księgowości.

  • Wydruk - co ma być drukowane, opcje przydatne przy definiowaniu niestandardowych dokumentów

    • Dostawca

      • Dane - nazwa, adres oraz NIP sprzedawcy

      • NIP - NIP sprzedawcy

      • Bank/Konto - Bank i nr rachunku bankowego sprzedawcy

    • Logo - graficzne logo firmy (wprowadzone w oknie FIRMY)

    • Nr dokumentu - numer dokumentu

    • Oryginał / Kopia - w świetle przepisów obowiązujących od 2013 roku nie ma obowiązku oznaczania dokumentów tekstem Oryginał/Kopia, w takim przypadku można to pole wyłączyć

    • Miejscowość

    • PKWiU - nagłówek kolumny PKWiU; jeśli pusty tzn. że "PKWiU". Pole PKWiU można wyłączyć, gdyż w świetle obowiązujących przepisów nie ma obowiązku podawania go przy podstawowej stawce VAT. Jeśli jednak stawka VAT jest różna od podstawowej, warto skorzystać z tego pola w celu wskazania podstawy obniżenia stawki, wówczas pole PKWiU należy włączyć.

    • Daty

      • wystawienia - włącza wydruk daty wystawienia

      • Data sprzedaży

        • włączona - włącza wydruk daty sprzedaży, będzie ona drukowana na fakturze tylko wówczas, gdy będzie różna od Daty wystawienia

        • Tekst - standardowo zgodnie z przepisami na fakturze będzie drukowany tekst Data dokonania lub zakończenia dostawy towarów lub wykonania usługi, nic nie stoi jednak na przeszkodzie, by wpisać w tym polu dowolny tekst, który ma się drukować zamiast standardowego

        • Miesiąc - jeśli chcemy, żeby drukował się tylko miesiąc sprzedaży np. wrzesień 2012 zamiast pełnej daty np. 10-09-2012

    • Dodatkowe marginesy drukarki - marginesy do ustawienia przy wydruku na papierze firmowym (patrz wyjaśnienie w dokumentach sprzedaży)

    • Dodatkowe ceny - możliwość wydruku dokumentu wycenionego w cenach ewidencyjnych lub w cenach sprzedaży (1, 2 lub 3-ciej)

    • Data zapłaty - czy na dokumencie ma być drukowana data zapłaty w sytuacji, gdy data zapłaty i data wystawienia dokumentu są jednakowe (za wyjątkiem zapłaty gotówką)

    • To nie jest faktura - czy na WZ w cenach sprzedaży ma się drukować uwaga "UWAGA! TEGO DOKUMENTU NIE WOLNO KSIĘGOWAĆ, GDYŻ NIE STANOWI ON FAKTURY W MYŚL PRZEPISÓW USTAWY O PODATKU OD TOWARÓW I USŁUG."

  • Nagłówek/Stopka

    • Podpis wyst. - czy i jaki tekst ma się pojawić na wydruku pod miejscem przewidzianym na podpis wystawcy dokumentu

    • Podpis odb. - czy i jaki tekst ma się pojawić na wydruku pod miejscem przewidzianym na podpis odbiorcy dokumentu

    • Nagłówek - dodatkowy tekst, który pojawi się w nagłówku WZ; dodatkowo może być otoczony ramką (Ramka)

    • Stopka - dodatkowy tekst, który pojawi się w stopce WZ; dodatkowo może być otoczony ramką (Ramka)

  • Makiety - wybór makiety, określającej wygląd wydrukowanego dokumentu.


Przyjęcia do magazynu

PARAMETRYZACJA SYSTEMU - Definicje dokumentów

Do przyjmowania towaru do magazynu służą dokumenty typu:

  • z vatem: PZ - Przyjęcie

  • bez vatu: PZ - Przyjęcie (bez vatu)

oraz Faktura VAT RR (zakup od rolnika ryczałtowego) i dodatkowo Inny (zakup). Innym dokumentem o podobnym charakterze jest protokół rozbieżności PR+, ale służy on do uzgadniania stanu faktycznego ze stanem w programie, a nie do przyjmowania towaru.

Tworząc definicję nowego dokumentu związanego z przyjęciem do magazynu lub modyfikując już istniejącą definicję wypełniamy następujące pola:

  • Ogólne - ogólne informacje o dokumencie - patrz wyjaśnienie w dokumentach sprzedaży

    • Nazwa skrócona

    • Nazwa pełna

    • Typ

    • Dokument korygujący

    • Numer

      • Układ

      • Pierwszy

      • W roku

      • W miesiącu

      • Pozwól na luki

    • Rozrachunki

    • Zmienia cenę nabycia - czy dokumenty tego typu mają zmieniać ostatnią cenę nabycia zapamiętaną w bibliotece asortymentów. Jest to istotne, bo w przypadku gdy ceny sprzedaży są określone jako liczone wg marży od ceny nabycia - zostaną one zmienione w przypadku zmiany ceny nabycia. Dla dokumentów typu PZ oraz faktura RR parametr ten powinien być włączony, a dla PR+ oraz innych - wyłączony.

    • Kasa/Bank

    • Księgowany jako - określany automatycznie rodzaj dokumentu istotny przy księgowaniu do programu R2księga (księga przychodów lub ewidencja ryczałtowa) lub R2fk (pełna księgowość). Dokumenty typu PZ oraz Faktura VAT RR są księgowane jako zakup, natomiast Inny (zakup) oraz PR+ nie są księgowane.

  • Zawartość - jakie dane powinien zawierać ten dokument; dotyczy zarówno wprowadzania danych jak i wydruku (patrz wyjaśnienie w dokumentach sprzedaży)

    • Elementy dokumentu

      • Dostawca - dane dostawcy

      • NIP - nip dostawcy

      • Rabat - rabat procentowy i kwotowy do całego PZ

      • Płatność, Uwagi, Notatki

    • VAT

      • Włączony

      • Stawki VAT

      • Podstawa przeliczeń

        • netto

        • brutto

      • Oddział

      • Kiedy rozliczyć - sposób rozliczenia vat, istotny tylko przy automatycznym księgowaniu dokumentu zakupu w programie księgowym. Wybieramy jeśli ten rodzaj dokumentu ma być księgowany w szczególny sposób. Jeśli ma być księgowany z domyślnym sposobem rozliczenia vat, pozostawiamy to pole puste.

    • Termin od daty sprzedaży - jeśli zaznaczone, to wszystkie dokumenty wystawione wg tej definicji będą miały naliczany termin płatności od daty sprzedaży, a nie od daty wystawienia

    • Konto zakupów - konto jakie będzie podstawiane na dokumentach PZ jako konto magazynu (WN). Można wpisać konkretne konto albo symbol [M], który spowoduje podstawienie konta związanego z wybranym na dokumencie magazynem (kolumna Konto zak. w bibliotece magazynów). Dotyczy tylko pełnej księgowości.

  • Wydruk - co ma być drukowane, opcje przydatne przy definiowaniu niestandardowych dokumentów (patrz wyjaśnienie w dokumentach sprzedaży)

    • Dostawca

      • Dane

      • NIP

    • Logo

    • Nr dokumentu

    • Oryginał / Kopia - w świetle przepisów obowiązujących od 2013 roku nie ma obowiązku oznaczania dokumentów tekstem Oryginał/Kopia, w takim przypadku można to pole wyłączyć

    • Miejscowość

    • Nabywca, Dostawca - nagłówki odpowiednich części dokumentu, standardowo NABYWCA:, DOSTAWCA:

    • PKWiU - nagłówek kolumny PKWiU; jeśli pusty tzn. że "PKWiU". Pole PKWiU można wyłączyć, gdyż w świetle obowiązujących przepisów nie ma obowiązku podawania go przy podstawowej stawce VAT. Jeśli jednak stawka VAT jest różna od podstawowej, warto skorzystać z tego pola w celu wskazania podstawy obniżenia stawki, wówczas pole PKWiU należy włączyć.

    • Indeksy asortymentowe

    • Dodatkowa kolumna z indeksem - jeśli oprócz indeksu głównego chcemy jeszcze drukować kolumnę Indeks1 lub Indeks2

    • Daty

      • wystawienia - włącza wydruk daty wystawienia

    • Uwagi

    • Dodatkowe marginesy drukarki

    • Dodatkowe ceny - możliwość wydruku dokumentu wycenionego w cenach ewidencyjnych lub w cenach sprzedaży (1, 2 lub 3-ciej)

    • Data zapłaty - czy na dokumencie ma być drukowana data zapłaty w sytuacji, gdy data zapłaty i data wystawienia dokumentu są jednakowe (za wyjątkiem zapłaty gotówką)

  • Nagłówek/Stopka (patrz wyjaśnienie w dokumentach sprzedaży)

  • Makiety - wybór makiety dokumentu.


Przesunięcia międzymagazynowe

PARAMETRYZACJA SYSTEMU - Definicje dokumentów

Są to dokumenty typu:

  • z vatem: MM - przesunięcie

  • bez vatu: MM - przesunięcie (bez vatu).

Tworząc definicję nowego dokumentu związanego z przesunięciem lub modyfikując już istniejącą definicję wypełniamy następujące pola:

  • Ogólne - ogólne informacje o dokumencie (patrz wyjaśnienie w dokumentach sprzedaży)

    • Nazwa skrócona

    • Nazwa pełna

    • Numer

  • Zawartość - jakie dane powinien zawierać ten dokument; dotyczy zarówno wprowadzania danych jak i wydruku (patrz wyjaśnienie w dokumentach sprzedaży)

    • Elementy dokumentu

      • Uwagi, Notatki

    • VAT

      • Włączony

      • Stawki VAT

      • Podstawa przeliczeń

  • Wydruk - co ma być drukowane, opcje przydatne przy definiowaniu niestandardowych dokumentów

    • Dodatkowe marginesy drukarki - marginesy do ustawienia przy wydruku na papierze firmowym (patrz wyjaśnienie w dokumentach sprzedaży)

  • Nagłówek/Stopka (patrz wyjaśnienie w dokumentach sprzedaży)

  • Makiety - wybór makiety, określającej wygląd wydrukowanego dokumentu.


Raporty kasowe

PARAMETRYZACJA SYSTEMU - Definicje dokumentów
Tworząc definicję nowego dokumentu kasowego lub modyfikując już istniejącą definicję wypełniamy następujące pola:

  • Ogólne - ogólne informacje o dokumencie (patrz wyjaśnienie w dokumentach sprzedaży)

    • Nazwa skrócona - służy do wybierania rodzaju w trakcie wystawiania dokumentu

    • Nazwa pełna - używana na wydrukach

    • Forma płatności - jakiej formy płatności (np.: gotówka, karta płatnicza) dotyczy ten raport

    • Numer - sposób numerowania kolejnych raportów (patrz wyjaśnienie w dokumentach sprzedaży)

    • Waluta - symbol waluty, standardowo PLN

  • Wydruk - co ma być drukowane, opcje przydatne przy definiowaniu niestandardowych dokumentów

    • Dodatkowe marginesy drukarki - marginesy do ustawienia przy wydruku na papierze firmowym (patrz wyjaśnienie w dokumentach sprzedaży)

  • KP/KW

    • Numer KP - sposób numerowania kolejnych KP (patrz wyjaśnienie w dokumentach sprzedaży)

    • Numer KW - sposób numerowania kolejnych KW (patrz wyjaśnienie w dokumentach sprzedaży)

  • Makiety - wybór makiety, określającej wygląd wydrukowanego dokumentu

    • Makieta KP - wybór makiety, określającej wygląd wydrukowanego KP

    • Makieta KW - wybór makiety, określającej wygląd wydrukowanego KW.


Współdzielenie definicji

PARAMETRYZACJA SYSTEMU - Definicje dokumentów

Jeśli firma wystawia dużo faktur, to zdarza się, że dla utrzymania porządku w dokumentach dzieli się je na kilka niezależnie numerowanych serii. W takim wypadku należy w programie zdefiniować kilka definicji faktur, nazwać je np.: Faktura A, Faktura B i Faktura C, a w układach numerów dodać odpowiednie litery np.: #/RR/A, #/RR/B, #/RR/C. Dla każdej z tych definicji należy określić niezależnie wszystkie parametry (sposób księgowania, elementy wydruku, nagłówek stopkę itp.).

Sytuacja robi się bardziej skomplikowana, gdy wszystkie dokumenty wystawiane w firmie chcemy podzielić na kilku użytkowników. W takim wypadku oprócz faktur musielibyśmy jeszcze zdefiniować wielokrotnie wszystkie pozostałe dokumenty używane w firmie (PZ, WZ, MM, RW, itd.). Podobny problem mielibyśmy gdybyśmy chcieli podzielić wystawiane dokumenty magazynowe (PZ, WZ, RW) na magazyny, których te dokumenty dotyczą. W obu przypadkach aby ułatwić sobie pracę możemy skorzystać z mechanizmu współdzielenia definicji dokumentów:

  • Współdzielenie przez użytkowników

    Wystarczy w układzie numeru wstawić znaki $U i dzięki temu korzystać z niezależnego numerowania dokumentów należących do tej samej definicji, ale wystawionych przez różnych użytkowników programu. Wystawiane przez nich dokumenty będą niezależnie numerowane, a w miejsce znaków $U podstawi się symbol użytkownika określony w bibliotece użytkowników. Czyli każdy użytkownik wystawiając fakturę będzie wybierał tę samą definicję o nazwie np. Faktura, ale numer tej faktury będzie nadawany tylko w obrębie faktur wystawionych przez tego użytkownika.

    Ponadto użytkownik będzie miał dostęp tylko do własnych (wystawionych przez siebie) dokumentów (pole Tylko własne we właściwościach F4 poszczególnych okien z dokumentami). Wybranym użytkownikom (administrator, szef) można ustawić dostęp do wszystkich dokumentów (wyłączyć pole Tylko własne dokumenty na zakładce Inne w oknie Grupy użytkowników).

  • Współdzielenie przez magazyny

    W przypadku dokumentów magazynowych PZ, WZ, RW wystarczy w układzie numeru wstawić znaki $M i dzięki temu korzystać z niezależnego numerowania dokumentów należących do tej samej definicji, ale dotyczących różnych magazynów. Dokumenty dotyczące różnych magazynów będą niezależnie numerowane, a w miejsce znaków $M podstawi się symbol magazynu określony w bibliotece magazynów. Czyli wystawiając np. PZ wybieramy tę samą definicję o nazwie np. PZ, ale numer tego dokumentu PZ będzie nadawany tylko w obrębie PZ dotyczących wybranego magazynu. Jeśli zmienimy magazyn na istniejącym już dokumencie, to automatycznie zmieni się również jego numer.

    Dokumenty dotyczące wybranego magazynu możemy łatwo wyfiltrować ustawiając odpowiednio pole Magazyn we właściwościach F4 w oknach PZ.

Korzystając z mechanizmu współdzielenia definicji, wszelkie zmiany wprowadzamy w jednej definicji (np. układ numeru, wybór specjalnej makiety, nagłówek wydruku), a obowiązują one od razu wszystkich użytkowników.

Współdzielenie definicji dostępne jest tylko w wersji PRO.


Definicje zestawień

PARAMETRYZACJA SYSTEMU

Wszystkie zestawienia dostępne w programie (patrz INSTRUKCJA UŻYTKOWNIKA - ZESTAWIENIA I STATYSTYKI) wykonywane są na podstawie przgotowanej wcześniej definicji.

Korzystając z polecenia menu głównego Ustawienia - Definicje zestawień wywołujemy okno DEFINICJE ZESTAWIEŃ, w którym możemy poprawić [image] (F6) definicję istniejącego zestawienia lub utworzyć [image] (Ins) definicję zupełnie nowego zestawienia.

W obu przypadkach określamy pola:

  • Źródło danych - na podstawie jakich danych będzie wykonywane to zestawienie. Źródła danych można rozumieć jako miejsca gdzie te dane są wprowadzane, czyli:

    • Asortymenty są źródłem dla zestawień z biblioteki asortymentów (np. cenniki),

    • Kontrahenci są źródłem dla zestawień z biblioteki kontrahentów (np. lista kontrahentów),

    • Faktury są źródłem dla zestawień wartościowych z danych ogólnych wszystkich dokumentów wprowadzanych w oknie Faktury. Z tego źródła korzystają zestawienia: Sprzedaż - dokumenty, Sprzedaż - nabywcy, Sprzedaż - dłużnicy itp.

    • Faktury - pozycje są źródłem dla zestawień ilościowo-wartościowych. Udostępniają dane ogólne wszystkich dokumentów wprowadzanych w oknie Faktury oraz dane wprowadzone na zakładce Pozycje przy poszczególnych fakturach. Z tego źródła korzystają zestawienia: Sprzedaż - pozycje dokumentów, Sprzedaż - asortymenty, Sprzedaż - grupy itp.

    • WZ - pozycje są źródłem dla zestawień ilościowo-wartościowych. Udostępniają dane ogólne wszystkich dokumentów wprowadzanych w oknie Faktury oraz dane wprowadzone na zakładce WZ przy poszczególnych dokumentach. Z tego źródła korzystają zestawienia: Wydania - pozycje dokumentów, Wydania - asortymenty, Wydania - grupy itp.

    • PZ, PZ - pozycje, MM, MM - pozycje - analogicznie jak Faktury i Faktury - pozycje,

    • Własny SQL - opcja dla zaawansowanych użytkowników wymagająca znajomości języka SQL. Umożliwia wprowadzenie dowolnego zapytania korzystającego z dowolnych elementów bazy danych.
      UWAGA. Tworzenie nowych zestawień z tym źródłem danych dostępne jest tylko w wersji PRO.

  • Wzór - po wyborze źródła danych możemy skorzystać z przygotowanych dla tego źródła gotowych wzorów zestawień lub określić Własny wzór zestawienia (czyli zupełnie nową definicje zestawienia, niekorzystająca z żadnego wzoru). Gotowe wzory zestawień odpowiadają zestawieniom standardowym dostępnym w programie. Wzory przydają się, gdy chcemy zdefiniować nowe zestawienie, które różni się tylko szczegółami od istniejących zestawień standardowych. Dzięki wzorowi możemy szybko określić te szczególne różnice bez konieczności definiowania wszystkich elementów zestawienia.

  • Nazwa - nazwa, pod którą to zestawienie będzie figurować na liście zestawień (nie mylić z nagłówkiem zestawienia).

  • Rezultat - w jak sposób ma zostać przygotowane zestawienie

    • Wydruk - zestawienie zostanie przygotowane w formie gotowego wydruku

    • Okno - zestawienie zostanie przygotowane w oknie. Dzięki temu możemy np. wyszukać odpowiednią pozycję lub sprawdzić inne szczegóły bez konieczności drukowania zestawienia.

  • zakładka Definicja

    • Grupowanie

      • Wg pól - pola przydatne do sumowania, uśredniania, wyliczania najmniejszej lub największej wartości. Jeśli chcemy np. zdefiniować zestawienie ze źródła Faktury - pozycje, które będzie zawierało sumę sprzedaży asortymentów z poszczególnych grup asortymentowych, to wpisujemy tu Grupa. Gdybyśmy dodatkowo chcieli uzyskać sumę sprzedaży poszczególnych asortymentów w tych grupach, to musielibyśmy wybrać Grupa i Nazwa. Jeśli w żadnym z pól nie określimy żadnego pola, zestawienie będzie zawierało listę pojedyńczych pozycji

      • Kwoty - jeśli w części Wg pól są określone jakieś pola, tutaj określamy jak będą obliczane wartości numeryczne w tym zestawieniu, np. jeśli w części Wg pól jest określone pole Grupa, a tu wybierzemy suma to zestawienie będzie zawierało sumę sprzedaży w poszczególnych grupach, jeśli zaznaczymy tu średnia w zestawieniu będzie średnia kwota sprzedaży w poszczególnych grupach (w przeliczeniu na liczbę pozycji z dokumentów sprzedaży zawierających asortyment należący do danej grupy). Analogicznie min - najmniejsza kwota z pozycji należacej do danej grupy, max - największa kwota.

    • Podział na

      • Wg pól - jeśli chcemy np. wydrukować zestawienie sprzedaży asortymentów z podziałem na poszczególne grupy asortymentowe, wybieramy tu pole Grupa (pola w sekcji Grupowanie zostawiamy puste bo nie zależy nam na żadnym sumowaniu, uśrednianiu itp.). Jeśli definiujemy zestawienie, które ma określone jakieś pola w części Grupowanie, musimy tam również dopisać wszystkie pola z części Podział i to na samym początku przed właściwymi polami grupującymi.

      • N - nowa grupa zaczyna się na nowej stronie

      • S - podsumowanie danej grupy

      • U - uporządkowanie malejące

    • Uporządkowanie - sposób uporządkowania pozycji zestawienia

      • Wg pól - wybieramy pole wg którego mają być uporządkowane pozycje zestawienia. Oprócz pól tekstowych (Nazwa) mogą tutaj występować również pola numeryczne (W.netto), co umożliwia np. uporządkowanie zestawienia sprzedaży asortymentów wg wartości obrotów netto na poszczególnych asortymentach.

      • U - uporządkowanie malejące

  • zakładka Kolumny

    • Dostępne - wszystkie dostępne kolumny w danym zestawieniu; naciśnięcie klawisza Ins lub przycisku Dodaj > umieszcza dostępną kolumnę na liście aktywnych kolumn. Przycisk Wszystkie >> uaktywnia wszystkie dostępne kolumny

    • Aktywne - kolumny, które chcesz mieć na wydruku; jeśli ustawiłeś w definicji w części Z podziałem na jakiekolwiek pola powinny one figurować na początku listy aktywnych kolumn. Na właściwym wydruku nie będą one figurować jako kolumny tylko jako grupy dzielące zestawienie. Klawisz Delete lub przycisk Skasuj usuwa kolumnę z listy aktywnych kolumn. Przyciski [image] [image] lub klawisze Shift áâ zmieniają kolejność aktywnych kolumn.

    • Czcionka - czcionka ustawiana we wszystkich kolumnach zestawienia

    • Rozmiar - rozmiar czcionki ustawiany we wszystkich kolumnach zestawienia

    • Właściwości kolumn - przygotowuje próbne zestawienie w oknie USTAWIANIE WŁAŚCIWOŚCI KOLUMN, umożliwiając ustawienie (Ctrl F4 lub przycisk [image]) parametrów poszczególnych kolumn tzn. szerokości, justyfikacji, koloru tła i czcionki.

  • zakładka Filtr - sposób filtrowania pozycji, które mają się znaleźć na zestawieniu

    • Warunki - w wierszach tabelki określamy kolejne warunki, które musi spełnić pozycja występujaca w wybranym Źródle danych, aby znaleźć się na zestawieniu. Dla każdego warunku określamy:

      • Pole - warunek będzie dotyczył tego pola

      • Warunek - wybieramy warunek z listy dostępnych dla tego pola warunków

      • Wartość (lub Od) - wartość do której zostanie porównana faktyczna wartość pola lub (Od) początkowa wartość zakresu dat jeśli wybrano warunek pomiędzy (od-do). Możemy wpisać wartości "sztywne", które będą "zaszyte" w definicji zestawienia. Np. w zestawieniu Sprzedaż - dłużnicy wg kwot znajduje się warunek Do zapłaty > 0, który oznacza, że do tego zestawienia będą brane zawsze tylko niezapłacone pozycje. Możemy również określić w warunkach wartości "elastyczne", które będą podawane przez użytkownika bezpośrednio przed wykonaniem zestawienia. W tym celu korzystamy z menu podręcznego (prawy klawisz myszy), które udostępnia następujące znaczniki systemowe w formacie {X/nazwa kontrolki}, gdzie X to typ znacznika:

        • {S/} Tekst - pole tekstowe, po kresce podajemy nazwę jaka ma identyfikować tę wartość, np. wpisanie {S/Nazwa asortymentu} spowoduje, że użytkownik będzie musiał przed wykonaniem zestawienia podać wartość w polu o nazwie Nazwa asortymentu. Analogicznie znacznik {S/Indeks} pokaże pole tekstowe o nazwie Indeks.

        • {D/} Data - pole do wprowadzenia daty, nazwa pola po kresce, czyli wartość {D/Od} oznacza pole o nazwie Od, w którym użytkownik będzie musiał podać datę.

        • {I/} Numer - liczby całkowite (bez części dziesiętnej)

        • {N/} Liczba - dowolne liczby

        • {L/} Logiczne - pole logiczne przyjmujące wartości Tak lub Nie

        • {C(AsortNazwa)/} - nazwa asortymentu - nazwa asortymentu wybierana z listy dostępnych asortymentów, np. {C(AsortNazwa)/Nazwa asortymentu} oznacza pole o nazwie Nazwa asortymentu, w którym użytkownik będzie mógł wybrać nazwę asortymentu z listy, bez konieczności ręcznego wpisywania jej

        • {C(AsortIndeks)/} - indeks asortymentu,
          {C(DefDok)/} - nazwa definicji dokumentu,
          {C(Grupa)/} - grupa asortymentowa,
          {C(KontrGrupa)/} - grupa kontrahenta,
          {C(KontrNip)/} - NIP kontrahenta,
          {C(KontrSkrót)/} - skrót nazwy kontrahenta,
          {C(Kontrakt)/} - kontrakt,
          {C(Magazyn)/} - magazyn,
          {C(Opiekun)/} - opiekun,
          {C(Województwo)/} - województwo - tak jak w opisanym wyżej przypadku, pola te umożliwiają wybór wartości z odpowiedniej listy, bez konieczności ręcznego wpisywania

        • {C(TakNie)/} - pole logiczne - pole logiczne przyjmujące wartość Tak lub Nie, np. {L/Sprzedaż} oznacza pole o nazwie Sprzedaż, w którym użytkownik może wybrać wartość Tak albo Nie. Może również nie wybrac żadnej wartości, co oznacza że Pole użyte w warunku może przyjmować dowolne wartości.

      • Do - końcowa wartość zakresu dat jeśli wybrano warunek pomiędzy (od-do)

    • Składnia - w jaki sposób mają być traktowane określone wyżej warunki. Standardowa składnia przy np. trzech warunkach wygląda tak:
      {W1} i {W2} i {W3}
      i oznacza, że muszą być spełnione wszystkie 3 warunki. Nie nie stoi na preszkodzie, żeby ją zmodyfikować, np. do postaci:
      {W1} i ({W2} lub {W3})
      co oznacza że musi być spełniony pierwszy warunek i jeden z dwóch pozostałych.
      Symbole {W1}, {W2} itd. oznaczają kolejne warunki, oprócz nich możemy korzystać z nawiasów okrągłych ( ) oraz operatorów i oraz lub.

  • zakładka Wydruk

    • Dane firmy - włącz jeśli chcesz, żeby w lewym górnym rogu pierwszej strony zestawienia drukowały się dane twojej firmy, a w prawym górnym rogu miejscowość oraz aktualna data.

    • Podsumowanie całości - podsumowanie pól numerycznych na końcu zestawienia

    • Ramki - czy wiersze i kolumny zestawienia mają być pooddzielane ramką

    • Orientacja papieru - wydruk poziomy lub pionowy

    • Nagłówek - nagłówek (tytuł) drukowany na początku właściwego zestawienia; oprócz dowolnego tekstu możesz tu wpisać (lub wstawić z menu wywołanego prawym klawiszem myszy) znaki systemowe:

      • {DB} – data bieżąca

      • {FILTR} – wybrane kryteria filtrowania

    • Stopka - stopka drukowana na końcu właściwego zestawienia

    • - edytor umożliwiający określenie wielu atrybutów tekstu, np. wielkości i rodzaju czcionki, koloru, justyfikacji itp.

  • zakładka Dostępność

    • Zestawienie jest dostępne w oknach - wybór miejsca, z którego można wywołać dane zestawienie. W zależności od potrzeb można zaznaczyć jedno lub kilka miejsc.

    • Uprawnienia - grupy użytkowników, które mogą korzystać z tego zestawienia

  • zakładka SQL - zakładka dostępna jedynie dla zaawansowanych użytkowników, którzy jako źródło danych wybrali Własny SQL. Możemy wpisać na niej dowolne zapytanie SQL, na podstawie którego ma zostać wykonane to zestawienie.

    Zapytanie piszemy bezpośrednio w polu SQL. Wprowadzając nazwy pól i tabel możemy skorzystać ze struktury bazy danych podpowiadanej po lewej stronie, gdzie po wybraniu odpowiedniej Bazy danych pokazywane są wszystkie tabele znajdujące się w tej bazie, a po ustawieniu się na wybranej tabeli również pola występujące w tej tabeli. Po dwukrotnym kliknięciu w nazwę tabeli lub pola zostaną one przepisane do pola SQL. Jeśli korzystamy z tabel znajdujących się w bazie BIN należy podać pełną nazwę bazy danych np.: R2T_faktury_Bin.dbo.BANKACC. Zamiast pełnej nazwy bazy danych możemy użyć znacznika <BIN> np. <BIN>BANKACC.

    W sekcji WHERE możemy korzystać z opisanych wyżej (zakładka Filtr) znaczników systemowych.
    UWAGA. Wszystkie znaczniki systemowe (za wyjątkiem {N\}) należy ująć w apostrofy, np. '{D/}'.

    W przypadku wszelkich wątpliwości dobrze jest sprawdzić jak wygladają zapytania SQL w zestawieniach standardowych. Po włączeniu trybu diagnostycznego (menu Ustawienia - Środowisko - Zaawansowane) przy każdym zestawieniu pojawi się zakładka SQL wynikowy z zapytaniem, które powstaje zgodnie z wprowadzonymi w definicji zestawienia ustawieniami.

Wprowadzone dane zatwierdzamy przyciskiem [image].

Zestawienie można wykonać bezpośrednio w oknie DEFINICJE ZESTAWIEŃ korzystając z funkcji [image] Wykonaj zestawienie.

Jeśli stwierdzimy, że niektóre ze standardowych zestawień nie będą nam potrzebne, można je usunąć Del [image] z listy zestawień. W przyszłości w razie potrzeby będzie można te zestawienia łatwo utworzyć tworząc nowe zestawienia wg konkretnego wzoru. Jeśli będziemy chcieli odtworzyć większą liczbę usuniętych wcześniej zestawień standardowych, możemy skorzystać z funkcji menu podręcznego (prawy klawisz myszy) Utwórz standardowe zestawienia.


Makiety dokumentów

PARAMETRYZACJA SYSTEMU

Program umożliwia samodzielną modyfikację makiet większości dokumentów. Makieta to wzór określający formę wydruku danego dokumentu. Np. w przypadku faktury makieta określa informacje o używanych na wydruku czcionkach, o tym w którym miejscu są drukowane dane nabywcy, w którym uwagi, jakie kolumny zawiera tabelka z pozycjami faktury, o dodatkowych informacjach drukowanych na każdej fakturze, itp.).

Jeśli proponowane przez program makiety nie odpowiadają naszym potrzebom albo upodobaniom, nic nie stoi na przeszkodzie, aby je dostosować do własnych potrzeb.

Co więcej, korzystając z mechanizmu makiet, możemy zdefiniować zupełnie nowe dokumenty, których nie ma w programie, a które są nam potrzebne.

Makiety dokumentów określamy w oknie DOKUMENTY dostępnym z menu głównego Ustawienia - Makiety dokumentów.

Zmiana makiety istniejącego dokumentu
Jeśli zajdzie potrzeba modyfikacji standardowej makiety istniejącego dokumentu (np. faktury) należy:

  • ustawić się na dokumencie wymagającym modyfikacji (dla faktury vat będzie to makieta o nazwie Faktura)

  • kliknąć [image] (poprawa) lub przejść na zakładkę Pozycja

  • następnie w okienku Dostępne makiety kliknąć [image] (Nowa makieta)

  • podać nazwę pliku nowej makiety oraz opis zmodyfikowanego dokumentu, po czym kliknąć OK

  • zmodyfikować wzór makiety w edytorze makiet (pojawi się automatycznie po kliknięciu OK w poprzednim kroku) i zaakceptować wprowadzone zmiany

  • w zależności od rodzaju dokumentu, którego makietę modyfikujemy:

    • dla dokumentów Przypomnienie, Wezwanie do zapłaty, Nota odsetkowa oraz Pełne dane kontrahenta:

      1. kliknąć w przycisk Ustaw jako aktywną, żeby wszystkie wydruki tego dokumentu były domyślnie drukowane wg tej nowej makiety lub kliknąć w Dodaj do menu drukowania, jeśli chcemy korzystać z tej makiety sporadycznie, zostawiając sobie przed samym wydrukiem możliwość wyboru aktywnej makiety.

      2. zaakceptować zmiany w całym dokumencie

    • dla wszystkich dokumentów definiowanych dodatkowo w oknie Definicje dokumentów, czyli PZ, WZ, MM, Faktura, RK itp.:

      1. zaakceptować zmiany w całym dokumencie

      2. wybrać przygotowaną makietę w definicji dokumentu w polu Makieta na zakładce Wydruk.

Jeśli zajdzie potrzeba modyfikacji utworzonej wcześniej własnej makiety należy:

  • ustawić się na dokumencie wymagającym modyfikacji

  • kliknąć [image] (poprawa) lub przejść na zakładkę Pozycja

  • następnie w okienku Dostępne makiety kliknąć [image] (Popraw makietę)

  • zmodyfikować wzór makiety w edytorze makiet i zaakceptować wprowadzone zmiany

  • zaakceptować zmiany w całym dokumencie.

Tworzenie nowego dokumentu
Jeśli chcemy utworzyć nowy dokument, taki którego nie ma jeszcze w programie, należy:

  • kliknąć [image] (nowy dokument)

  • w pozycji Dokument jest dostępny w oknach zaznaczyć okno, z którego będziemy drukować dokument

  • klikając dwukrotnie w podgląd dokumentu (lub w Dostępne makiety) określić wzór makiety w edytorze makiet

  • zaakceptować nowy dokument.

Wydruk nowego dokumentu dostępny będzie w wybranym oknie w menu drukowania [image] F2 w pozycji Dokumenty własne. Jeśli wybraliśmy, że Dokument jest dostępny w oknach: Menu główne - Raporty - nowy dokument wydrukujemy z pozycji menu głównego Raporty - Dokumenty własne.

UWAGI OGÓLNE:

  1. Każdy dokument z grupy: Przypomnienie, Wezwanie do zapłaty, Nota odsetkowa, Pełne dane kontrahenta może mieć utworzonych wiele makiet (wzorów), z których kilka jest dostępnych do wydruku (Dodaj do menu drukowania), natomiast jedna jest wybrana jako domyślna (Ustaw jako aktywną). Dotyczy to również samodzielnie określonych nowych dokumentów.

  2. W przypadku makiet pozostałych dokumentów (PZ, WZ, MM, Faktura, RK itp.) powyższe ustawienia, tzn. Dodaj do menu drukowania i Ustaw jako aktywną nie są uwzględniane, a makietę, wg której wydrukuje się dany dokument określamy w definicji dokumentu. Jeśli chcemy dla niektórych kontrahentów drukować faktury wg specjalnych makiet, możemy te makiety określić bezpośrednio w danych tych kontrahentów na zakładce Wydruki.

  3. Dokumenty systemowe, czyli przygotowane przez producenta programu, posiadają standardową makietę, której nie można samemu modyfikować. Makieta ta może być modyfikowana tylko poprzez wgranie nowej wersji programu. Wgranie nowej wersji nie powoduje natomiast zmian w dodatkowych makietach (nawet tych utworzonych na podstawie standardowej), co znaczy, że przygotowane przez nas samodzielnie makiety na pewno zostaną zachowane w kolejnych wersjach programu.

  4. Wszystkie utworzone samemu makiety archiwizowane są wraz z danymi ogólnymi programu i mogą być w razie potrzeby (awarii) odtworzone. Standardowe makiety wszystkich dokumentów systemowych zależą tylko i wyłącznie od wersji programu.

Jeśli nie chcemy lub nie potrafimy samodzielnie zmodyfikować lub utworzyć makiety, możemy zlecić taką operację wykwalifikowanym pracownikom dystrybutora lub producenta programu.


Edytor makiet

PARAMETRYZACJA SYSTEMU - Makiety dokumentów

Edytor makiet służy do modyfikacji makiety określającej wzór wydruku danego dokumentu. Dostęp do edytora jest możliwy z okna DOKUMENTY wywoływanego z menu Ustawienia - Makiety dokumentów (patrz PARAMETRYZACJA SYSTEMU - Makiety dokumentów).

Wzór makiety przygotowujemy w języku HTML. Jest to popularny język służący do tworzenia stron internetowych - podstawy tego języka są w przystępny sposób wyjaśnione w internecie np. w poradniku webmastera pod adresem http://webmaster.helion.pl/kurshtml/. Oprócz standardowego języka HTML program wymaga pewnych dodatkowych danych:

  • 20 pierwszych linii przeznaczonych jest na ustawienie konfiguracji wydruku w programie

  • między znakami # wstawiane są instrukcje interpretowane przez program.

Makietę modyfikujemy na zakładce Źródło.

Przy modyfikacji i tworzeniu nowych dokumentów trzymamy się następujących zasad:

  • wzorujemy się na wcześniej utworzonych lub standardowych makietach

  • używamy standardowego języka HTML,

  • niestandardowe instrukcje interpretowane przez program (#...#) wstawiamy klikając w zaplanowanym miejscu prawym klawiszem myszy

  • przechodząc na zakładkę Podgląd możemy od razu zobaczyć efekt swojej modyfikacji.

W przygotowywanym wzorze oprócz układu ramek i stałych tekstów chcielibyśmy umieścić jakieś dane wypełniane w momencie wydruku przez program. W tym celu w wybranym miejscu klikamy prawym klawiszem myszy i wybieramy odpowiednio:

  • Wstaw dane - podczas wydruku symboliczny znacznik zastąpiony zostanie odpowiednią wartością, np. w miejscu #F_Nazwa# podstawi się nazwa aktualnej firmy.

    • Znacznik z danymi składa się z:
    • prefiksu oznaczającego z jakiej tabeli z danymi będą podstawiane dane
    • właściwej nazwy pola z danymi
    • znaków '#' na początku i na końcu
    np.
    • #F_NIP# - nip naszej firmy (F_ oznacza firmę)
    • #KON_NIP# - nip kontrahenta, który jest nabywcą na fakturze (KON_ oznacza kontrahenta)
    • #DKP_Ile# - ilość na pozycji faktury (DKP_ oznacza dokumenty-pozycje).

    Niektóre znaczniki (Wstaw dane - Inne) udostępniają dane, które nie są dostępne bezpośrednio w tabelach z danymi. Takie znaczniki nie mają na początku nazwy żadnego prefiksu, np. na dokumencie w miejsce znacznika #KwotaSłownie# zostanie podstawiona przygotowana wstępnie reprezentacja słowna kwoty brutto razem z symbolem waluty. Tego typu znaczniki zależą od rodzaju edytowanej makiety, tzn. np., że będą inne w czasie edycji makiety faktury, a inne w trakcie edycji makiety raportu kasowego.

  • Wstaw znaki sterujące - podczas wydruku symboliczny znak sterujący ustawi np. kolor systemowy (#bgCiemny#). Kolory systemowe określa się w menu Ustawienia - Środowisko na zakładce Wydruki. Część znaków sterujących dotyczy tylko wydruków w trybie znakowym (patrz ROZPOCZĘCIE PRACY - Okno główne - Przegląd wydruku - Wydruki znakowe).

  • Wstaw pętle - jeśli we wstawionej pętli wstawimy dane, np.

    #LOOP Asortymenty#
        Indeks: #AS_Indeks# Nazwa: #AS_Nazwa#
    #ENDLOOP#
     otrzymamy listę indeksów i nazw asortymentów

  • Wstaw warunek - używamy, np. jeśli chcemy umieścić fragment tekstu drukowany tylko wtedy, gdy spełniony zostanie odpowiedni warunek

    • Z polem logicznym - np. jeśli chcemy uzależnić fragment wydruku od określonego w definicji dokumentu parametru Z indeksem:
      #IF DKD_xZIndeksem#
          indeks włączony
      #ELSE#
          bez indeksu
      #ENDIF#

    • Z innym polem - możemy przyrównać pole do konkretnej wartości (koniecznie w cudzysłowiach), np. jeśli chcemy coś wydrukować w zależności od tego czy na fakturze został udzielony rabat (pole #DK_rabat#):
      #IF DK_Rabat="0,00"#
          nie ma rabatu
      #ELSE#
          jest rabat
      #ENDIF#

  • Wstaw funkcję - możemy wykonywać proste operacje na kwotach i wyrazach

    • Duże litery - np. jeśli chcemy zawsze drukować dane nabywcy dużymi literami:
      #KON_Dane#$Dużymi

    • Oblicz - np. jeśli chcemy wydrukować na fakturze kwotę rabatu netto (czyli różnicę wartości netto sprzed rabatu i po rabacie):
      $Oblicz{#DK__Netto#-#DK_Netto#}

    • Słownie - np. jeśli chcemy wydrukować tekst ze słowną reprezentacją kwoty brutto dokumentu:
      #DK_Brutto#$Slownie

    • Wartość bezwzględna - np. jeśli na fakturze korygującej chcemy pokazać wartość bezwzględną kwoty brutto (czyli zawsze dodatnią nawet jeśli jest ujemna):
      #DK_Brutto#$Abs

    • Zaokrąglij - jeśli chcemy zaokrąglić do 2 miejsc po przecinku wartość niezaokrągloną, np. #DKP_Rabat_łączny#$Zaokrąglij.

    UWAGA. wszystkie znaczniki funkcji oprócz znacznika $Oblicz muszą występować bezpośrednio po polu, na którym mają działać odpowiednie funkcje.

Zmodyfikowaną makietę zapisujemy klikając w przycisk [image].

Jeśli nie chcemy lub nie potrafimy samodzielnie zmodyfikować makiety, możemy zlecić taką modyfikację wykwalifikowanym pracownikom dystrybutora lub producenta programu.


Języki

PARAMETRYZACJA SYSTEMU

Jeśli wystawiamy faktury kontrahentom zagranicznym (dostępne tylko w wersji MAXI i PRO), to możemy skorzystać z możliwości automatycznego tłumaczenia faktur oraz przypomnień, wezwań i not wystawianych tym kontrahentom na język, którym się posługują.

W tym celu wystarczy zakupić wersję programu umożliwiającą rozliczanie transakcji zagranicznych i określić w danych kontrahenta właściwy Język na zakładce Inne. Faktury, przypomnienia, wezwania i noty będą automatycznie tłumaczone na wybrany język na podstawie słowników przygotowanych w oknie Języki (menu Ustawienia - Języki).

Okno zawiera listę języków. Języki możemy dodawać i usuwać samodzielnie. Dla każdego języka na zakładce Tłumaczenia należy przygotować tłumaczenia zwrotów używanych przez program. Tłumaczenia na język angielski oraz częściowo na niemiecki (tylko faktury) są przygotowane przez producenta programu. Tłumaczenia na inne języki można przygotować samodzielnie. W tłumaczeniach nie można używać znaków diaktrycznych kodowanych w standardzie Unicode.

Jeśli dodamy lub usuniemy jakiś zwrot na zakładce Tłumaczenia, program będzie chciał przy akceptacji zmian zsynchronizować listę zwrotów w pozostałych językach, tak aby dla każdego języka była ona taka sama.

Powrót do standardowych tłumaczeń umożliwia funkcja Przywróć domyślne tłumaczenia w menu pomocniczym (prawy klawisz myszy lub F3).

Biblioteka języków jest wspólna dla programów R2księga, R2fk i R2faktury, dlatego może zawierać zwroty nieużywane w programie R2faktury.


Waluty

PARAMETRYZACJA SYSTEMU

W oknie z walutami wpisujemy wszystkie waluty, w których będziemy wystawiali faktury. Dla każdej waluty musimy wprowadzić średnie kursy NBP z wszystkich dni, w których wystawiamy faktury w danej walucie. Kursy można pobrać automatycznie [image] z internetu ze strony NBP.

Okno jest dostępne tylko w wersji MAXI i PRO.


Odsetki

PARAMETRYZACJA SYSTEMU

Okno z odsetkami służy do wpisania odsetek za zwłokę obowiązujących w różnych okresach. Wpisy powinny być dokonywane w okresach rozłącznych, ale z zachowaniem ciągłości.

Na podstawie wprowadzonych tu stawek obliczają się m.in. odsetki za zwłokę w oknie z fakturami na zakładce Płatności, w oknie Windykacja, na notach odsetkowych oraz w kalkulatorze odsetkowym (menu Okna - Kalkulator odsetkowy).

Odsetki podatkowe są wykorzystywane jedynie w kalkulatorze odsetkowym.

Przycisk [image] umożliwia automatyczne pobranie aktualnej tabeli odsetek z serwisu internetowego. Jeśli przy próbie pobrania odsetek pojawiają się błędy, należy sprawdzić konfigurację połączenia internetowego.


Środowisko

PARAMETRYZACJA SYSTEMU

Ogólne parametry wpływające na pracę programu zgrupowane są w pozycji Środowisko w menu głównym Ustawienia.

Parametry pogrupowane są na kilku opisanych niżej zakładkach.

INTERFEJS

  • Domyślny interfejs - umożliwia zmianę koloru okienek i przycisków poprzez wybór jednej z dwóch opcji interfejsu Klasyczny lub Standard 2012

  • Ekran - standardowo czcionka i jej rozmiar określona jest we właściwościach ekranu systemu Windows, w szczególnym przypadku mamy możliwość wyboru innej czcionki, wykorzystywanej przez program oraz jej rozmiaru. Zwiększenie rozmiaru czcionki spowoduje powiększenie wszystkich okien programu. Wszystkie zmiany dotyczące interfejsu zostaną uwzględnione po ponownym uruchomieniu programu.

  • Kolor - standardowo kolor okien określony jest we właściwościach ekranu systemu Windows, w szczególnym przypadku mamy możliwość wyboru innego koloru dla wszystkich okien w programie

  • Dźwięki - wszystkim komunikatom występującym w programie mogą być przypisane sygnały dźwiękowe. Jeśli posiadasz w komputerze kartę dźwiękową, będą to dźwięki określone w Panelu Sterowania Windows (Start - Ustawienia - Panel Sterowania - Dźwięki). Jeśli nie posiadasz karty dźwiękowej lub jeśli wyłączyłeś w Panelu Sterowania domyślne dźwięki (tzn. ustawiłeś Start - Ustawienia - Panel Sterowania - Dźwięki - Schematy - Brak dźwięków) możesz przypisać do każdego typu komunikatów (błąd, ostrzeżenie, informacja, potwierdzenie) krótki sygnał dźwiękowy. Jeśli dźwięki ustawione są już w systemie, dźwięki dla poszczególnych typów komunikatów należy wyłączyć, gdyż będą się podwajać.

  • Nawigacja - standardowo w systemie Windows klawisz Enter zatwierdza informację wprowadzoną w danym okienku, a klawisz Tab służy do przejścia do kolejnego pola. Niektórzy użytkownicy wolą jednak, aby klawisz Enter zachowywał się tak jak klawisz Tab, czyli powodował przejście do następnego pola. Należy wybrać odpowiednią opcję, gdzie klawisz Enter:

    • zatwierdza całe okienko

    • powoduje przejście do następnego pola - jest to ustawienie domyślne.

  • Szukanie wg bieżącej kolumny - czy pole wg którego będzie się odbywało wyszukiwanie, ma się ustawiać na nazwę bieżącej kolumny na zakładce Lista. Włączenie tego parametru ułatwia sprawne wyszukiwanie, gdyż zwykle szukamy pozycji o zadanej wartości w jednej z kolumn widocznych na ekranie. Zamiast wyszukiwać nazwę tej kolumny w okienku Szukaj w polu Szukaj po z długiej listy wszystkich dostępnych kolumn, wystarczy ustawić się w dowolnym polu w tej kolumnie i rozpocząć wpisywanie szukanego tekstu.

WYDRUKI
Wszystkie wydruki składają się z tabel (przedzielonych liniami), zawierających komórki różnego rodzaju wyróżnione odcieniami szarości:

  • Biały - tło komórek bez odcieni szarości

  • Jasny - zawiera najczęściej opis danych

  • Pośredni - nagłówki i stopki

  • Ciemny - nagłówki pośrednie oddzielające poszczególne części wydruku oraz ramki tabeli

  • Czarny - ramki tabeli bez odcieni szarości (na niektórych wydrukach).

Kolory tych komórek można określić na podstawie wcześniej zdefiniowanych odcieni szarości. Przycisk Domyślne określa standardowe dostępne kolory w formie odcieni szarości.

Formę wszystkich wydruków możemy określić:

  • Indywidualnie dla każdego wydruku - parametry każdego rodzaju wydruku możemy określić indywidualnie bezpośrednio przed wydrukiem, wciskając [image] w oknie Przegląd wydruku

  • Wszystkie wydruki domyślnie - ustalamy, że wszystkie wydruki będą w formie oryginalnie zaprojektowanej, czyli z odcieniami szarości (nagłówki będą szare, opisy jasnoszare, a oddzielenia ciemnoszare); forma ta zalecana jest przy wydrukach na drukarce laserowej

  • Wszystkie wydruki bez odcieni szarości - wszystkie wydruki będą miały formę tabel (z liniami oddzielającymi w kolorze ciemnym lub czarnym i tłem w kolorze białym), nastawione będą na oszczędność atramentu; opcja ta zalecana jest przy dużej ilości wydruków na drukarce atramentowej.

Parametr Odcienie na wydrukach działa na wydruki, które sporządzono już chociaż raz od czasu zainstalowania programu. Wydruki sporządzane po raz pierwszy będą zawsze korzystały z własnych ustawień domyślnych.

Dodatkowo możemy zaznaczyć następujące parametry:

  • Data i czas w stopce - po zaznaczeniu tej opcji na każdym wydruku pojawi się rzeczywista data i czas drukowania

  • Nie używaj obrazków - opcja przydatna w przypadku niektórych drukarek i nie najnowszych sterowników do nich, gdy może wystąpić problem przy wydruku graficznych fragmentów wydruku. Po jej zaznaczeniu graficzne fragmenty zastąpione zostaną wyjaśnieniami literowymi.

  • Edytuj na podglądzie wydruku pojedyncze słowa - na podglądzie każdego wydruku można dwuklikiem myszki wejść w tryb edycji pojedynczych słów, dzięki czemu przed wydrukiem możemy dokonać niewielkich poprawek.

Na zakładce Nagłówek/Stopka możemy określić, czy w nagłówku większości wydruków widoczne będą dane firmy, czy też dane licencjobiorcy.

Przycisk Wydruki igłowe - tryb znakowy wywołuje dodatkowe okienko umożliwiające określenie parametrów dotyczących wydruków w trybie znakowym (patrz INSTRUKCJA UŻYTKOWNIKA - ROZPOCZĘCIE PRACY - Okno główne - Przegląd wydruku - Wydruki znakowe).

EKSPORT

  • Edytor wydruków - ścieżka do pliku wykonywalnego zewnętrznego edytora tekstu (np. MS Word) w formacie HTML (patrz INSTRUKCJA UŻYTKOWNIKA - ROZPOCZĘCIE PRACY - Okno główne - Przegląd wydruku). Przykładowa ścieżka dla edytora Microsoft Word może mieć postać: C:\Program Files\Microsoft Office\Office\Word.exe

  • Ark. kalkulacyjny - ścieżka do pliku wykonywalnego zwenętrznego arkusza kalkulacyjnego (np. MS Excel). Przykładowa ścieżka dla edytora Microsoft Word może mieć postać: C:\Program Files\Microsoft Office\Office\Excel.exe.

  • Dokumenty załączane - ścieżka do katalogu, w którym będą przechowywane dokumenty załączane. Dokumenty te można przechowywać w bazie lub na dysku, miejsce ich przechowywania określamy w oknie Firmy na zakładce Dokumenty.

INTERNET

  • SMTP - w programie istnieje możliwość bezpośredniego przesłania dowolnego wydruku pocztą internetową (e-mail). Żeby wysłać przygotowany wydruk należy w oknie Przegląd wydruku kliknąć ikonę [image] - Wyślij jako e-mail. Wcześniej jednak musimy prawidłowo określić parametry skrzynki pocztowej:

    • W jaki sposób - w jaki sposób chcemy wysyłać wiadomości e-mail

      • Serwer RESET2 - poczta będzie wysyłana za pomocą serwera pocztowego firmy RESET2. Wybieramy tę opcję jeśli nie mamy własnego adresu e-mail.

      • Ustawienia własne - poczta będzie wysyłana przez program R2faktury z posiadanego przez nas konta e-mail. Wybieramy tę opcję, jeśli nie zależy nam na ewidencjonowaniu wysyłanych wiadomości i serwer obsługujący nasze konto pocztowe nie wymaga połączenia szyfrowanego. Każdy użytkownik programu może mieć określone własne konto. Dla bieżącego użytkownika podajemy adres i inne parametry konta pocztowego:

        • Host - serwer poczty wychodzącej;
          możemy odczytać go w programie do obsługi poczty (np. Outlook Express) we właściwościach konta (menu Narzędzia - Konta... - Właściwości - Serwery), parametr Poczta wychodząca (SMTP)

        • Port - nr portu - standardowo 25, przy połączeniu za pośrednictwem serwera proxy, można tu wpisać odpowiedni nr portu

        • Nazwa użytkownika - wprowadzona w programie pocztowym Nazwa użytkownika

        • Nazwa konta - nazwa konta pocztowego

        • E-mail użytkownika - adres poczty internetowej

        • Hasło - hasło do poczty internetowej

        • Serwer wymaga szyfrowania - zaznaczamy tak jak w parametrach naszej skrzynki pocztowej w programie pocztowym

      • Domyślny program pocztowy - poczta będzie wysyłana za pomocą domyślnego programu pocztowego zainstalowanego w systemie Windows, czyli np. Microsoft Outlook, Mozilla Thunderbird itp. Wybieramy te opcję jeśli chcemy korzystać z własnego konta pocztowego, a serwer pocztowy wymaga połączenia szyfrowanego lub innych parametrów, których nie można określić bezpośrednio w programie R2faktury. Dodatkowo uzyskamy automatyczne zapamiętywanie przez program pocztowy wysyłanych wiadomości w folderze "Elementy wysłane". Mankamentem takiego ustawienia może być konieczność kazdorazowego potwierdzania wysyłanych maili w programie pocztowym (w zależności od zainstalowanego programu i jego poziomu zabezpieczeń).

    Parametry skrzynki pocztowej pamiętane są niezależnie dla każdego użytkownika programu. W związku z tym możemy wybrać, czy chcemy wszystkim użytkownikom zdefiniować parametry tej samej skrzynki pocztowej, czy też każdemu innej.

  • FTP - parametry dotyczące pobierania aktualizacji odsetek oraz wysyłania/odbierania danych do serwisu producenta

    • Pasywny FTP - zaznaczamy w zależności od parametrów naszego połączenia internetowego lub jeśli pojawia się jakiś błąd przy próbie komunikacji

    • Użyj serwera proxy - zaznaczamy gdy nie mamy bezpośredniego dostępu do internetu, lecz pośrednio poprzez serwer proxy. Ponadto musimy ustawić dodatkowe parametry w grupie Ustawienia proxy.

  • HTTP - parametry dotyczące pobierania aktualizacji programu

    • Użyj serwera proxy - zaznaczamy gdy nie mamy bezpośredniego dostępu do internetu, lecz pośrednio poprzez serwer proxy. Ponadto musimy ustawić dodatkowe parametry w grupie Ustawienia proxy.

  • Sprawdzaj automatycznie czy jest dostępna nowa wersja - po zaznaczeniu tej opcji przy wejściu do programu (ale tylko przy pierwszym wejściu danego dnia) pojawiać się będzie dodatkowa informacja o możliwości pobrania nowej wersji, jeśli oczywiście taka wersja będzie dostępna. Włączenie tej opcji może opóźnić uruchamianie programu o czas dostępu do internetu.

  • Sprawdzaj automatycznie komunikaty z serwisu - po zaznaczeniu tej opcji przy wejściu do programu (ale tylko przy pierwszym wejściu danego dnia) pojawiać się będzie okienko z komunikatami redagowanymi przez serwis producenta, mającymi na celu odpowiedzi na najczęściej zadawane pytania przez klientów. Nic jednak nie stoi na przeszkodzie, by okienko to wywołać w dowolnym momencie pracy w programie z menu Pomoc - Komunikaty serwisu.

INNE

  • Podpis elektroniczny - opcje służące do podpisu i wysyłki e-Faktur

    • Sterownik karty - określamy ścieżkę do sterownika karty kryptograficznej, umożliwiającego dostęp do znajdującego się na karcie certyfikatu. Najprawdopodobniej jest to plik o nazwie CCPkiP11.dll (dla kart z firm KIR oraz Sigillum PCCE), pliki cryptoCertum3PKCS.dll albo cryptoCertumPKCS11.dll (dla kart z firmy Certum Unizeto) lub pliki enigmap11.dll albo enigmap11-x64.dll dla systemów 64-bitowych (dla kart z firmy CenCert) i domyślnie powinien znajdować się w folderze C:\WINDOWS\SYSTEM32.

  • Moduł WWW - opcje służące współpracy z modułem WWW

    • Hasło klucza prywatnego - wprowadzamy hasło niezbędne do korzystania z modułu WWW w trybie szyfrowanym (protokół https).

  • Kopie e-Faktur - folder do przechowywania kopii wystawionych e-Faktur.

ZAAWANSOWANE

  • System - dodatkowe opcje systemowe

    • Tryb diagnostyczny - używany m.in. do zdiagnozowania szybkości działania pewnych funkcji w programie. Należy go włączać tylko w porozumieniu z pracownikiem serwisu producenta, w celu zdiagnozowania ewentualnych nieprawidłowości w działaniu programu.

    • Przypominaj o archiwizacji co X dni - po włączeniu tej opcji program przy wyjściu będzie monitował o wykonanie archiwizacji danych (patrz Bezpieczeństwo danych - Archiwizacja danych)

    • Włącz raportowanie błędów - włączona opcja powoduje wysyłanie raportu do producenta o wystąpieniu ewentualnego błędu podczas pracy programu, warunkiem jest podłączenie do internetu.
      UWAGA. Jeśli nie mamy stałego dostępu do internetu to włączenie tej opcji może spowodować niepotrzebne wydłużenie czasu pracy programu.

  • Archiwum - ustawienia katalogu pośredniczącego w wykonaniu bezpośrednio z programu następujących funkcji: archiwizacja danych, odtwarzanie danych, serwisowanie danych oraz podświetlania dużej ilości pozycji w oknach

    • Serwer na stacji roboczej - w przypadku gdy serwer SQL i właściwy program uruchomione są na tym samym komputerze, funkcje te są dostępne zawsze, gdyż przy ich wykonywaniu program korzysta z ustawionego w systemie katalogu tymczasowego

    • Katalog serwera - udostępniony stacji roboczej katalog serwera widziany przez serwer, np. C:\Temp

    • Katalog lokalny - fizycznie ten sam katalog na serwerze widziany przez stację roboczą, np. \\Serwer\C\Temp

    • Data archiwum - określa format daty dopisywanej do nazwy pliku archiwum.

  • Klient-serwer - obsługa dłuższych zadań przez oddzielnie uruchomiony program (serwer R2T) (patrz Harmonogram zadań)

    • Włącz obsługę niektórych funkcji przez serwer R2T - możliwość zaplanowania zadania do wykonania wg harmonogramu

    • Powiadamiaj stacje robocze o zakończeniu sesji - komunikat informujący użytkownika zlecającego zadanie o jego wykonaniu.

NARZĘDZIA

Pozwala na ewidencję i późniejsze wywołanie bezpośrednio z programu (Menu - Narzędzia) zewnętrznych aplikacji (w tym aplikacji API) wspomagających działanie programu R2faktury. Przyciskiem [image] wprowadzamy:

  • Nazwa - nazwa pod jaką pojawi się dana aplikacja w Menu - Narzędzia

  • Ścieżka do pliku - ścieżka do pliku wykonywalnego .exe danej aplikacji.


Konfiguracja

PARAMETRYZACJA SYSTEMU

Aby ułatwić i przyspieszyć pracę ustalamy domyślne parametry związane z różnymi oknami:

  • Asortymenty

    • J.m. - jednostka miary występująca w większości asortymentów

    • Rodzaj - rodzaj (towar/produkt/usługa) większości asortymentów

    • PKWiU - symbol PKWiU występujący w większości asortymentów

    • Ilość - ilość jednostek jaka jest zwykle wystawiana na fakturach

    • Cena - Każdy asortyment ma 3 ceny sprzedaży. Tutaj określamy, która z nich ma być widoczna w kolumnach Cena netto, Cena brutto okna Asortymenty bez konieczności zaglądania do danych poszczególnych asortymentów.

    • Podstawa - podstawa przeliczeń netto/brutto dla cen sprzedaży. Domyślnie Netto, jeśli podstawową ceną sprzedaży jest dla nas cena brutto, bo np. prowadzimy głównie sprzedaż detaliczną, przestawiamy podstawę na Brutto.

    • Rodzaje cen - nazwy rodzajów cen sprzedaży, np. Detal, Hurt, Inna. Jeśli chcemy zmienić standardowe nazwy rodzajów cen sprzedaży (1, 2, 3) na inne, dobrze jest zachować ich numery tzn. wpisać np. 1 - Detal, 2 - Hurt, 3 - Inna. Dzięki temu będzie nam łatwiej wybierać rodzaj ceny w trakcie wystawiania faktury (w kolumnie Rodzaj w tabelce z pozycjami faktury).

    • Obliczanie marży - sposób obliczania marży, tzn. procentowego stosunku zysku do ceny nabycia lub sprzedaży. Obliczanie marży ma sens przede wszystkim wtedy, gdy zajmujemy się handlem, czyli korzystamy ze sprzedaży i prowadzenia magazynu.

      • Przeliczenia

        • marża -> cena - ustawiamy tę opcję jeśli najistotniejsza jest dla nas marża. Dla każdego rodzaju cen określamy (w tabelce obok) marżę procentową w stosunku do (Marża od) ceny nabycia lub ceny ewidencyjnej. Ceny sprzedaży obliczą się same. Jeśli w polu Marża od wybierzemy cenę nabycia, to wraz ze zmianą tej ceny w trakcie kolejnych przyjęć będą automatycznie przeliczane ceny sprzedaży tak, żeby zachować zadaną przy asortymencie marżę.

        • cena -> marża - ustawiamy jeśli najważniejsze są dla nas ceny, a marże traktujemy tylko informacyjnie. Marże wyliczą się same jako stosunek cen sprzedaży do ceny nabycia lub ceny ewidencyjnej.

      • Marża od - podstawa do wyliczenia marży

        • c.nabycia - cena nabycia. Marża będzie wyliczana w stosunku do ostatniej ceny nabycia danego asortymentu.

        • c.ewidenc. - cena ewidencyjna. Marża będzie wyliczana w stosunku do ceny ewidencyjnej określonej dla każdego asortymentu w bibliotece asortymentów.

      • Marża% - procent marży dla poszczególnych cen sprzedaży. Marża liczona będzie wg algorytmu określonego w ustawienia firmy (Ustawienia - Ogólne - Marża (patrz PARAMETRYZACJA SYSTEMU - KONFIGURACJA MODUŁÓW PROGRAMU - Sprzedaż)).

      Określone tu ustawienia będą obowiązywały wszystkie asortymenty, za wyjątkiem tych, które mają ustawione indywidualne ustawienia (tzn. mają zaznaczone pole Marża ind. - marża indywidualna).
      UWAGA. Każda zmiana tych ustawień spowoduje przeliczenie marż lub cen sprzedaży we wszystkich asortymentach znajdujących się w bibliotece (za wyjątkiem tych, które mają włączone ustawienia indywidualne).

    • Indeks

      • Ustawiaj automatycznie - tworząc asortymenty możemy nadawać im indeksy wg własnego klucza lub nadawać je automatycznie jako kolejne liczby od 1 w górę. W tym drugim przypadku należy włączyć pole Ustawiaj automatycznie. Indeks będzie ustawiany jako kolejny po największym z dotychczasowych indeksów (ale tylko numerycznych). Tzn. jeśli mamy już wpisane asortymenty z indeksami 10, 100M i MAGH, to kolejny asortyment będzie miał indeks 11 - asortymenty 100M i MAGH zostaną pominięte przy obliczaniu, bo albo w ogóle nie zawierają cyfr (MAGH), albo oprócz cyfr zawierają litery (100M).

      • Uwzględniaj X cyfr - do wyliczania największego dotychczasowego indeksu brane będą indeksy numeryczne zawierające nie więcej niż X cyfr. W ten sposób możemy korzystać zarówno z indeksów odpowiadających kodom kreskowym składającym się z 13 cyfr (EAN) jak i z własnych indeksów numerowanych od 1. Domyślnie ten parametr ma wartość 6. Możemy ją zmienić w zależności od długości indeksów, z których korzystamy.

    • Grupa obowiązkowa - zaznaczamy, jeśli zależy nam na określaniu grup asortymentowych przy każdym asortymencie. Dzięki temu będziemy mieli pewność, że zestawienia korzystające z podziału na grupy (w tym również statystyka sprzedaży) będą zawsze zawierały całość obrotów. Po zaznaczeniu tego parametru program:

      1. nie pozwoli zatwierdzić asortymentu z nieokreśloną grupą
      2. nie pozwoli zatwiedzić pozycji faktury, PZ i MM, na której wybrano asortyment, który ma nieokreśloną grupę
      3. w trakcie generowania statystyki sprzedaży będzie sprawdzał grupy w pozycjach dokumentów sprzedaży. W przypadku znalezienia pozycji faktur z asortymentami posiadającymi nieokreśloną grupę, pojawi się odpowiedni komunikat ostrzegawczy.

  • PZ

    • Przelew X dni - jeśli chcemy, aby dokumenty PZ, czyli odpowiedniki faktury zakupu, były zawsze wystawiane jako Do zapłaty przelewem w terminie X dni. X to oczywiście liczba dni przeznaczonych na zapłatę PZ. Jeśli wyłączymy ten parametr to PZ będą domyślnie ustawiane jako Zapłacono gotówką.

  • Faktury

    • Rodzaj cen sprzedaży - taki rodzaj ceny będzie automatycznie podstawiany w momencie wybrania asortymentu na pozycję faktury

    • Uporządkowanie pozycji - sposób uporządkowania pozycji na wydruku faktury i WZ

    • Fakt.zagraniczna księg.jako - domyślny sposób księgowania faktury zagranicznej, czyli na jaką fakturę zmieni się faktura krajowa po zmianie waluty na obcą (jeśli konkretny sposób księgowania nie będzie określony w definicji dokumentu). Dostępne tylko w wersji MAXI i PRO.

    • Przelew X dni - jeśli chcemy aby faktury były zawsze wystawiane jako Do zapłaty przelewem w terminie X dni, X to oczywiście liczba dni przeznaczonych na zapłatę faktury; jeśli wyłączymy ten parametr to faktury będą domyślnie ustawiane jako Zapłacono gotówką

    • Sprawdzaj powtarzalne - jeśli program ma sprawdzać przy każdym otwarciu okna z fakturami czy należy wystawić jakieś faktury powtarzalne

    • Skaner kodów kreskowych - zaznaczamy, jeśli chcemy korzystać z wystawiania faktur przy pomocy skanera kodów kreskowych (patrz SPRZEDAŻ - Wystawianie faktur - Skaner kodów kreskowych)

      • Domyślna ilość czy pozycje faktury tworzone automatycznie po zeskanowaniu kodu kreskowego będą miały podstawioną jedną jednostkę czy taką ilość jak ilość domyślna określona w danych asortymentu

    • Sumować pozycje na bieżąco - sumować wartość netto, vat i brutto całej faktury po dodaniu/usunięciu każdej pozycji (spowalnia wystawianie faktury), czy tylko przy akceptacji całej faktury lub przed określeniem płatności

    • Sprawdź czy pozycja już istnieje - przy zatwierdzaniu nowej pozycji faktury lub innego dokumentu sprzedaży albo wydania program będzie ostrzegał, jeśli asortyment wybrany w tej pozycji został już użyty we wcześniejszych pozycjach faktury

    • Kontrolować tryb "Odwrotne obciążenie" - pozwala na wystawianie faktur typu "Odwrotne obciążenie", tylko dla wybranych kontrahentów i asortymentów, tzn:

      • nabywca musi być uprawniony do otrzymywania faktur z odwrotnym obciążeniem (pole "Uprawniony do odwr.obc.VAT" w danych kontrahenta)
      • na takich fakturach mogą występować tylko odpowiednie asortymenty (pole "Odwrotne obciążenie" w danych asortymentu na zakładce "Inne")
      • faktura musi być przeliczana od podstawy netto
      • faktura nie może być fiskalna, tzn. taka, do której drukowane są paragony fiskalne.

    • Paragony fiskalne

      • Potwierdzać wydruk na drukarkę fiskalną - czy pytać o potwierdzenie przed każdym wydrukiem na drukarkę fiskalną

      • Edycja zafiskalizowanych dokumentów - czy umożliwiać poprawę i/lub ponowny wydruk zafiskalizowanych dokumentów - tylko na wypadek ewentualnych kłopotów z drukarką (np. wyczerpania się papieru w drukarce w trakcie wydruku paragonu)

      • Przypisywanie drukarek fiskalnych do użytkownika - wybieramy model obsługi drukarek fiskalnych (istotne jeśli korzystamy z sieciowej wersji programu i z kilku drukarek fiskalnych)

        • odznaczone - drukarka fiskalna jest przypisana do komputera, do którego jest podłączona. Każdy użytkownik może się logować na dowolnym komputerze i drukować z niego bez problemu paragony fiskalne.

        • zaznaczone - drukarka fiskalna jest przypisana do użytkownika. Każdy użytkownik pracuje zawsze na tym samym komputerze. Jeśli zaloguje się do programu na innym komputerze, to próba wydruku paragonu fiskalnego zakończy się błędem. Z tego ustawienia korzystamy tylko w sytuacji, gdy mamy problem ze skonfigurowaniem drukarek fiskalnych np. przy pracy w trybie terminalowym.

    • Domyślne uwagi - uwagi, które mają być dołączane do wystawianej faktury; można wybrać 3 uwagi i dodatkowo dla każdej z nich określić czy ma się pojawiać na dokumencie, który jest zapłacony, do zapłaty czy zawsze, tzn. bez względu na płatności.

  • Kasa/Bank

    • Podpowiadać liczbę automatycznych KP/KW - wyłączamy jeśli nie chcemy, aby program podpowiadał po wciśnięciu Ins w oknie KP liczbę automatycznych KP/KW

    • Kurs waluty z dnia poprzedniego - jeśli zaznaczymy, program będzie podpowiadał na raportach kasowych/bankowych średni kurs NBP danej waluty z dnia poprzedzającego datę operacji (wpłaty/wypłaty). Jeśli odznaczymy, będzie to kurs z dnia operacji. Dostępne tylko w wersji MAXI i PRO.

    • Kontrahent (import płatności) - tymczasowy kontrahent, który zostanie przypisany do odczytanej płatności do czasu, aż nie ustalimy o którego kontrahenta chodzi. Należy pamiętać, że wybrany kontrahent musi posiadać konta odbiorcy i dostawcy.

  • Ogólne

    • Podpowiadać dostawcę/nabywcę - na nowym dokumencie PZ/fakturze będzie podpowiadany dostawca/nabywca z ostatnio wystawionego PZ/faktury. Opcja może być pomocna np. przy wystawianiu większej ilości dokumentów wg przygotowanej wcześniej listy.

    • Pobieranie kursów walut z internetu - w jaki sposób mają być pobierane z internetu brakujące (wg daty wystawienia faktury) kursy walut

    • Zapamiętywać DW - zapamiętywać adres DW - Do Wiadomości wpisany w trakcie wysyłania wydruków e-mailem i podpowiadać go przy wysyłaniu kolejnych wydruków - w ten sposób można łatwo skierować kopie wszystkich wysyłanych wydruków na własny adres e-mail

    • Eksport danych do programu księgowego - określa sposób eksportowania paragonów i faktur nieterminowych (czyli zapłaconych w dniu wystawienia, zwykle gotówką, ale niekoniecznie) oraz zapłat za te dokumenty.

      • Wszystkie dokumenty pojedynczo - jeśli nie wystawiamy paragonów lub wystawiamy je sporadycznie. Podobnie z dokumentami gotówkowymi, chyba że mimo iż wystawiamy ich dużo, to i tak chcemy je księgować pojedynczo.

      • Paragony jako sprzedaż dzienna - jeśli chcemy księgować paragony jednym wpisem z sumą paragonów w poszczególnych dniach. Zapłata za paragony zostanie zaksięgowana również zbiorczo jednym wpisem za każdy dzień. Wszystkie dokumenty inne niż paragony księgowane są pojedynczo. Wybierając tę opcję zaoszczędzimy papier na wydruk księgi lub dziennika dekretów, a prowadzona księgowość będzie bardziej przejrzysta.

      • Dokumenty nieterminowe jako sprzedaż dzienna - jeśli całą sprzedaż gotówkową (paragony oraz faktury zapłacone w dniu wystawienia) chcemy zaksięgować jednym wpisem jako łączną sprzedaż dzienną, bez prowadzenia rozrachunków z poszczególnymi kontrahentami (faktury są od razu zapłacone więc nie powstają żadne należności). W takim wypadku rejestr sprzedaży vat musimy drukować z programu R2faktury, gdyż będzie on obejmował wszystkie wystawione faktury, bez względu na ich sposób płatności. Rejestr sprzedaży VAT wydrukowany w R2fk lub R2księga po imporcie danych z R2faktur nie będzie już obejmował faktur nieterminowych.

    • Dni wolne przy obliczaniu odsetek - parametr ten umożliwia określenie, w jaki sposób naliczać odsetki i dni zwłoki w przypadku, gdy termin płatności przypada w dzień wolny lub sobotę. Do wyboru są 3 możliwości:

      • nie uwzględniaj dni wolnych - tak liczył program do wersji 6.08.11

      • uwzględniaj dni wolne, ale bez sobót - wartość domyślna, właściwa przy naliczaniu odsetek za zwłokę w płatnościach za faktury

      • uwzględniaj dni wolne wraz z sobotami - przy zwłoce w zobowiązaniach podatkowych.

      Przykłady:
      1. Gdy terminem płatności był dzień 13.08.2011 (sobota), a płatność została uregulowana dnia 16.08.2011, to przy wyborze nie uwzględniaj dni wolnych lub uwzględniaj dni wolne, ale bez sobót odsetki zostaną naliczone dla 3 dni zwłoki, natomiast przy wyborze uwzględniaj dni wolne wraz z sobotami płatność nie będzie przeterminowana (dni zwłoki i odsetki będą równe 0).
      2. Gdy terminem płatności był dzień 04.09.2011 (niedziela), a płatność została uregulowana dnia 05.09.2011, to przy wyborze nie uwzględniaj dni wolnych zostanie wyliczony 1 dzień zwłoki, natomiast przy wyborze uwzględniaj dni wolne, ale bez sobót lub uwzględniaj dni wolne wraz z sobotami płatność nie będzie przeterminowana (dni zwłoki i odsetki będą równe 0).

W każdej chwili możemy przywrócić domyślne ustawienia wszystkich parametrów wydruków klikając w przycisk Domyślne.


Konfiguracja przelewów

PARAMETRYZACJA SYSTEMU

W zależności od ustawienia parametrów wydruku, przelewy możemy wydrukować w następujących formach:

  • na czystych kartkach papieru wydruk czerwonego lub czarnego formularza przelewu wraz z wdrukowaną zawartością w trybie:

    • ręcznym - każda litera drukowana w oddzielnej kratce, tak jak wypisany ręcznie

    • maszynowym - poszczególne pola przelewu są wypełniane bez uwzględniania kratek

  • nadruk na gotowych formularzach przelewów formatu A4.

Parametry przelewów możemy ustawiać, wybierając w pozycji menu głównego Ustawienia - Konfiguracja przelewów. Oddzielnie określamy parametry wydruku przelewów zwykłych (Zwykły), do ZUSu (ZUS) i do urzędu skarbowego (Podatki). Przycisk [image] przywraca domyślne parametry dla wszystkich rodzajów przelewów.

Możemy również umożliwić indywidualne ustawienia dla każdego użytkownika, zaznaczając opcję Użytkownicy mogą zmieniać. Wtedy zmiany parametrów dla konkretnego użytkownika możemy dokonać będąc w oknie Ewidencja przelewów klikając w ikonę [image] właściwości (F4), natomiast przyciskiem [image] przypisujemy ustawione tutaj parametry wszystkim użytkownikom.

Dla wydruków przelewów określamy parametry:

  • Tryb

    • Ręczny - każda litera w osobnej kratce

    • Maszynowy – przelew wypełniany pismem maszynowy, bez uwzględniania kratek formularza

  • Typ wydruku

    • pełny wydruk (na czystej kartce) – wydruk na czystej kartce formatu A4

      • Kolor formularza – w jakim kolorze maja być drukowane polecenia przelewu, do wyboru mamy dwa kolory szary i czerwony (oczywiście czerwone formularze zostaną wydrukowane tylko na drukarkach kolorowych)

      • Odcień – pozwala dostosować wydruk do państwa drukarki (1-jasny, 2-standard, 3-ciemny)

      • Układ

        • 2 duże odcinki - na jednej stronie A4 mieszczą się 2 odcinki przelewu, tzn. że jeden przelew drukuje się na dwóch kartkach, wymiar odcinków jest zgodny z Polską Normą PN-F-001102

        • 4 duże odcinki - na jednej stronie A4 mieszczą się 4 odcinki przelewu czyli cały jeden przelew, wymiar odcinków jest NIEZGODNY z Polską Normą PN-F-001102, ale przelewy takie są jeszcze akceptowane przez część banków, ich zaletą jest oszczędność papieru

      • Drukować odcinek – możemy wyłączyć drukowanie konkretnego odcinka

      • Litery – możemy zmienić sposób przypisania liter do odcinków

      • Data – zaznaczamy, na którym odcinku ma być wydrukowana data

      • Drukować litery odcinków (A,B,C,D) – czy program ma drukować w prawym górnym rogu każdego odcinka jego literę

      • W / P

        • zawsze W i P – bez względu na rodzaj operacji (wpłata/przelew) na odcinkach drukują się zawsze litery W i P (przelew) – do ręcznego skreślenia

        • W lub P – w zależności od rodzaju operacji (wpłata/przelew) na odcinkach drukują się litery W lub P

        • skreślone – w zależności od rodzaju operacji (wpłata/przelew) na odcinkach drukują się zawsze litery W i P, z tym że niewłaściwa z nich jest skreślona

    • nadruk (na kartce z gotowym formularzem)

      • Układ – w obecnej wersji program jest przystosowany do nadruku na trzech rodzajach formularzy: 4 duże odcinki poziomo, 2 małe + 2 duże pionowo oraz 2 duże + 4 małe poziomo

      • Nr rachunku ZUS – jeśli nadrukowujemy przelewy do ZUS na formularzach z wydrukowanym już numerem rachunku ZUS zaznaczamy tylko końcówka, a w przeciwnym wypadku pełny numer

      • Współrzędne formularza – jeśli nadruk nie mieści się dokładnie w formularzu możesz przystosować nadruk do tego formularza korygując w (milimetrach) położenie poszczególnych odcinków

      • Drukować odcinek – możemy wyłączyć drukowanie konkretnego odcinka; opcja ta jest pomocna jeśli mamy niestandardowy formularz, na którym chcemy nadrukować treść polecenia przelewu

      • Data – zaznaczamy, na którym odcinku ma być wydrukowana data

      • Nie skreślać WP – jeśli nie chcemy aby litery określające rodzaj operacji (W-wpłata P-przelew) były automatycznie skreślane w zależności od rodzaju operacji.

      • Drukować symbol waluty – jeśli formularz, na którym drukujemy nie ma wydrukowanego symbolu waluty (PLN)

  • Ogólne – parametry dotyczące wydruku na czystej kartce oraz nadruku na gotowym formularzu

    • Słownie – wybierz sposób generowania kwoty słownie

    • Format kwoty – zmień, jeśli Twój bank wymaga innych ustawień.

W każdej chwili możemy przywrócić domyślne ustawienia wszystkich parametrów wydruków klikając w przycisk Domyślne parametry.


Restrykcje w obrotach

Restrykcje

PARAMETRYZACJA SYSTEMU

Restrykcje w obrotach z nierzetelnymi kontrahentami są jednym z elementów mechanizmu rozliczania należności.

Konfigurację restrykcji umożliwia polecenie menu głównego Ustawienia - Restrykcje:

  • OBSŁUGA WARUNKOWA - zaznaczamy odpowiednie kryteria. Wystarczy, że chociaż jedno z zaznaczonych kryteriów będzie spełnione. Standardowo termin przekroczony o 7 dni lub wystawione przypomnienie.

    • termin płatności przekroczony o dni

    • wystawiono przypomnienie o zapłacie

    • wystawiono notę odsetkową

  • NIE OBSŁUGIWAĆ - standardowo termin przekroczony o 60 dni lub wystawione wezwanie do zapłaty lub wystawiona i niezapłacona nota odsetkowa.

    • termin płatności przekroczony o dni

    • wystawiono wezwanie do zapłaty

    • wystawiono notę odsetkową

  • Uwzględniać należności powyżej - standardowo 5 zł, poniżej takiej kwoty zaległości nie opłaca nam się stosować mechanizmu restrykcji.

  • Pokaż w oknie KONTRAHENCI - jeśli chcemy wyróżniać nierzetelnych kontrahentów kolorami szarym i czarnym w bibliotece kontrahentów.

  • Pokaż w oknie FAKTURY - jeśli chcemy wyróżniać faktury spełniające podane wyżej kryteria kolorami szarym i czarnym w oknie z fakturami.


Formy płatności

PARAMETRYZACJA SYSTEMU

Biblioteka form płatności, z których będziemy korzystać w programie.

Uzupełniamy pola:

  • Forma - tak pojawi się w oknie z fakturami na zakładce Płatność

  • Forma (zapłacono) - tak pojawi się na wydruku faktury w zdaniu np. "do zapłaty gotówką".


Wydruki znakowe

PARAMETRYZACJA SYSTEMU

Zanim rozpoczniemy drukowanie w trybie znakowym, które dostępne jest tylko w wersji MAXI i PRO, należy koniecznie ustawić parametry wydruku na drukarce igłowej (patrz INSTRUKCJA UŻYTKOWNIKA - ROZPOCZĘCIE PRACY - Okno główne - Przegląd wydruku - Wydruki znakowe). Parametry te znajdują się w oknie Wydruki igłowe - tryb znakowy, do którego wchodzimy, naciskając przycisk Wydruki igłowe w oknie Ustawienia - Środowisko - Wydruki.

W oknie tym należy określić następujące parametry:

  • Sterownik
    Jest to zestaw znaków sterujących obsługiwanych przez daną drukarkę. Program posiada dwa standardowe sterowniki o nazwach EPSON i IBM. Są to najczęściej spotykane zestawy znaków sterujących drukami w trybie znakowym.
    UWAGA. Nazwy niekoniecznie muszą zgadzać się z modelem drukarki - np. drukarka wyprodukowana przez firmę EPSON może być ustawiona w tryb pracy ze sterownikiem IBM i odwrotnie.
    Zdecydowana większość drukarek obsługuje co najmniej jeden z tych dwóch standardów. Jeżeli jednak chcemy używać innego sterownika, to należy go najpierw wpisać do tabeli sterowników (lub zmodyfikować już istniejący). Edycję tej tabeli uruchamia przycisk Sterowniki drukarek. W tabeli należy podać kody sterujące dla każdej komendy, posługując się liczbami dziesiętnymi oddzielonymi przecinkiem, np. jeżeli nasza drukarka zaczyna drukować znaki podwójnej szerokości po sekwencji znaków Esc, W, #01 (bajt o wartości 1), to w pole Podwójna szerokość - Włącz należy wpisać 27,81,1, czyli kody znaków Esc, W i 1. Sekwencja określona w polu Sekwencja początkowa wywołana zostanie na początku każdego wydruku, co umożliwia ustawienie drukarki w odpowiedni tryb pracy. Ze względu na to, że wydruki w programie są dość szerokie zaleca się, aby w polu tym znajdowała się komenda ustawiająca wąską czcionkę, zwłaszcza jeżeli używamy drukarki z tzw. wąskim wałkiem, czyli wałkiem o szerokości kartki formatu A4.

  • Szerokość (w znakach)
    Określa, ile maksymalnie znaków może wydrukować drukarka w jednym wierszu. Np. drukarki z wąskim wałkiem mogą wydrukować maksymalnie 136 znaków w jednej linii czcionką zagęszczoną, tzn. PICA - CONDENSED. Ponieważ standardowa makieta faktury wymaga szerokości 136 znaków w linii, to czcionka PICA - CONDENSED jest domyślnie ustawiana w sekwencji początkowej w standardowych sterownikach EPSON i IBM. Pozostałe wydruki przewidziane do wydruku na drukarce igłowej, tzn. wydruki dokumentów MM, WZ, PZ, RW, RK, KP/KW i potwierdzenia sald dla kontrahentów, mieszczą się również w tej szerokości.
    UWAGI:

    1. Parametr ten powinien dotyczyć tej czcionki, której właśnie używamy (tzn. jeżeli zamierzamy wykonać wydruk czcionką wąską, to parametr powinien dotyczyć liczby znaków mieszczących się w linii drukowanej czcionką wąską). Jeżeli podamy zbyt dużą wartość, to wydruk będzie się "zawijał" lub drukował poza kartką papieru, natomiast jeżeli podamy wartość zbyt małą, to wydruk będzie wypełniał tylko część kartki.

    2. W pewnych przypadkach wydruk może nie zmieścić się w ramach podanej przez nas szerokości. Jeżeli na przykład określimy w definicji dokumentu, że na wydruku faktury dla każdej pozycji ma być drukowany indeks asortymentowy, cena przed rabatem, procent rabatu, cena walutowa, a pozycja zawiera dodatkowo długą nazwę asortymentu, to wydruk takiej pozycji może nie zmieścić się w ramach 136 znaków. W takim przypadku możemy użyć jeszcze bardziej zagęszczonej czcionki, czyli ELITE - CONDENSED, która umożliwa wydruk 160 znaków w jednej linii. Sekwencję tę (dla trybu EPSON będzie to 27,77,15) należy wpisać w pole Sekwencja początkowa opisane wyżej. Jeżeli posiadamy wersję z możliwością edycji własnych makiet, (patrz PARAMETRYZACJA SYSTEMU - Makiety dokumentów - Edytor makiet) to zamiast zmieniać sekwencję początkową, możemy wymusić użycie tej czcionki tylko na danej konkretnej makiecie (za pomocą znaczników #txtELI# i #txtZW1# opisanych niżej). Bardziej zaawansowani użytkownicy mogą pójść jeszcze dalej i zmodyfikować makietę w taki sposób, aby ograniczyć użycie wąskiej - mało czytelnej czcionki - tylko do tabelki z asortymentami. W tym celu należy ustawić parametr szerokość (w znakach) na 136, a w makiecie faktury wpisać znaczniki #txtELI# i #txtZW1# nie na początku, ale tuż za tagiem <table nagłówka tabelki z asortymentami, (czyli w makiecie powinno się znaleźć: <table #txtELI##txtZW1#), natomiast po zakończeniu wydruku tabelki należy wpisać znaczniki #txtPIC# i #txtZW1#, przywracające domyślną czcionkę (czyli w makiecie powinno się znaleźć: #txtPIC##txtZW1# </table>). W takim przypadku program automatycznie dostosuje do czcionki szerokość strony w znakach - czyli dla czcionki ELITE - CONDENSED ustawi szerokość na 160, a dla czcionki PICA - CONDENSED na 136 znaków (czyli szerokość będzie zmieniała się w trakcie drukowania - co jest konieczne ze względu na zmieniającą się szerokość czcionki).

  • Wysokość (w znakach)
    Określa, ile fizycznie wierszy jest w stanie wydrukować posiadana przez nas drukarka na jednej kartce papieru. Należy uwzględnić niezbędne marginesy, nagłówki oraz stopki. Parametr ten najlepiej wyznaczyć doświadczalnie, drukując kilkustronicowy wydruk. Dla większości drukarek mieści się on w zakresie 60-70.

  • Lewy margines - liczba kolumn odstępu z lewej strony wydruku

  • Standard polskich liter - standard polskich znaków diakrytycznych (ą,ć,ę itd), które obsługuje nasza drukarka

  • Dodatkowy wysuw - liczba pustych wierszy, o które ma się przesunąć papier po zakończeniu wydruku (za stopką)

  • Dopełnij automatycznie do końca strony
    Zaznaczenie tego parametru spowoduje, że ostatnia strona wydruku zostanie dopełniona na końcu znakami nowej linii w taki sposób, aby stopka wydruku wydrukowała się na samym dole.
    UWAGA. Wyłączenie tego parametru spowoduje, że stopka wydrukuje się tuż pod wydrukiem, ale nie spowoduje automatycznie, że drukarka zatrzyma się w miejscu, w którym wydrukowany został ostatni znak stopki. Drukarki mają zazwyczaj niezależny mechanizm, który powoduje wysuw papieru do początku następnej strony po zakończeniu każdego wydruku. Aby wyłączyć ten mechanizm, należy zajrzeć do instrukcji drukarki.

  • Pomiń linie rozdzielające w tabelach
    Jeżeli parametr ten pozostawimy niezaznaczony, to poszczególne wiersze w drukowanych tabelach (np. pozycje na wydruku faktury) będą zawsze rozdzielone poziomymi liniami składającymi się z kresek (tzn. ----------). Natomiast zaznaczenie tego parametru spowoduje, że linie rozdzielające zostaną pominięte, z wyjątkiem kilku pierwszych (tytuły kolumn) i ostatnich (podsumowanie). Dzięki pominięciu linii rozdzielających wydruki będą znacznie krótsze, choć mogą stracić na przejrzystości. W wydrukach tworzonych na podstawie makiet możemy samodzielnie ustalić, które linie rozdzielające mają się drukować a które nie za pomocą znaczników #txt__0# i #txt__1# (patrz niżej).

  • Nie stronicuj wydruku
    Zaznaczenie tego parametru spowoduje, że wielostronicowe wydruki będą drukowały się w sposób ciągły, bez żadnych przerw między stronami. Nagłówek firmowy zostanie wydrukowany tylko na pierwszej, a stopka tylko na ostatniej stronie wydruku.

UWAGA. Parametry wydruków igłowych przypisane są do użytkownika programu, więc w sytuacji gdy chcemy drukować na różnych drukarkach igłowych, wymagających różnych ustawień, należy te ustawienia określić dla innego użytkownika programu.

Program daje możliwość samodzielnego tworzenia definicji wydruków za pomocą edytora makiet (patrz PARAMETRYZACJA SYSTEMU - Makiety dokumentów - Edytor makiet). Jeżeli chcemy utworzyć makietę wydruku, który będzie drukowany w trybie znakowym, to nie można w niej używać zagnieżdżonych tabel (tzn. pomiędzy markerami <TABLE> i </TABLE> nie można użyć ponownie użyć <TABLE>), a linia wydruku nie może przekraczać szerokości podanej w parametrze Szerokość (w znakach). Należy przy tym pamiętać, że wydruk znakowy nie "zawinie" w kilku liniach długiego tekstu, jeżeli nie mieści się on w komórce. W makiecie takiej możemy natomiast użyć znaków sterujących dedykowanych specjalnie dla wydruków znakowych. Są to:

  • #txtPIC# - powoduje, że drukarka zacznie drukować czcionką PICA (wywołana zostanie sekwencja podana w sterowniku drukarki w polu PICA)

  • #txtELI# - powoduje, że drukarka zacznie drukować czcionką ELITE (wywołana zostanie sekwencja podana w sterowniku drukarki w polu ELITE)

  • #txtZW1# - powoduje, że drukarka zacznie drukować czcionką wąską (wywołana zostanie sekwencja podana w sterowniku drukarki w polu Wąska - Włącz)

  • #txtZW0# - powoduje, że drukarka zakończy drukowanie czcionką wąską (wywołana zostanie sekwencja podana w sterowniku drukarki w polu Wąska - Wyłącz)
    UWAGA. W trybie EPSON nie istnieje sekwencja wyłączająca drukowanie wąską czcionką. Zamiast niej należy po prostu włączyć ponownie właściwy tryb, czyli #txtPIC# (PICA) lub #txtELI# (ELITE)

  • #txtSZ1# - powoduje, że drukarka zacznie drukować czcionką podwójnej szerokości (wywołana zostanie sekwencja podana w sterowniku drukarki w polu Podwójna szerokość - Włącz)

  • #txtSZ0# - powoduje, że drukarka zakończy drukowanie czcionką podwójnej szerokości (wywołana zostanie sekwencja podana w sterowniku drukarki w polu Podwójna szerokość - Wyłącz)

  • #txt__1# - powoduje, że drukarka rozpocznie drukować linie rozdzielające poszczególne wiersze w tabelach

  • #txt__0# - powoduje, że drukarka przestanie drukować linie rozdzielające poszczególne wiersze w tabelach
    UWAGI:

    1. Znaki sterujące #txt__0# nie mają znaczenia, jeżeli opisany wyżej parametr Pomiń linie rozdzielające w tabelach pozostał niezaznaczony.

    2. Jeżeli chcemy użyć czcionki pogrubionej (tzw. bold), to należy do jej włączenia i wyłączenia użyć standardowych znaczników HTML, czyli <b> i </b>.


Urządzenia fiskalne

PARAMETRYZACJA SYSTEMU

Program umożliwia współpracę z:

  • drukarkami fiskalnymi Posnet Thermal firmy POSNET oraz drukarkami Mera, Omega i FP600 firmy ELZAB lub kompatybilnymi

  • kasą fiskalną Posnet NEO

Zasady współpracy z tymi urządzeniami opisano w INSTRUKCJA UŻYTKOWNIKA - SPRZEDAŻ - Urządzenia fiskalne.

Urządzenia fiskalne konfigurujemy w oknie Urządzenia fiskalne dostępnym w menu Ustawienia.

Drukarki fiskalne

Aby skonfigurować program do współpracy z drukarką fiskalną należy (na przykładzie drukarki POSNET):

  1. skonfigurować parametry drukarki, tzn.:

    1. utworzyć ją w oknie Urządzenia fiskalne

    2. określić jej parametry

      • Nazwa własna - dowolna nazwa, istotna jeśli korzystamy z kilku drukarek

      • Nr portu - nr portu COM, do którego jest podłączona drukarka (zwykle 1 lub 2)

      • Wersja oprogramowania drukarki - ustawiamy w zależności od posiadanej drukarki.
        Drukarki o nazwach: Posnet Thermal FV EJ, Posnet Thermal FV, Posnet Thermal 5V, Posnet Thermal 2.03, Posnet Thermal 2.01, Posnet Thermal 1.02, Posnet Thermal 1.01 obsługują wyłącznie tzw. protokół Thermal. Dla tych drukarek należy wybrać wersję oprogramowania 2.xx.
        Drukarki o nazwach: Posnet Thermal HS FV i Posnet Thermal HS EJ obsługują zarówno protokół 2.xx, jak i i protokół Posnet. Najnowsza drukarka - Posnet Thermal HS FV EJ - pracuje wyłącznie z protokołem Posnet.

      • Stawki VAT - przyporządkowanie liter stawkom VAT; musi odpowiadać dokładnie analogicznemu przyporządkowaniu w oprogramowaniu serwisowym drukarki, w razie wątpliwości najlepiej zapytać osobę odpowiedzialną za serwis drukarki. Zamiast wprowadzać stawki ręcznie możemy odczytać ustawienia stawek zapisane w drukarce - służy do tego przycisk Pobierz.

      • Dodatkowe linie w NAGŁÓWKU paragonu - dodatkowe linie, np. z reklamą, które pojawią się w nagłówku paragonu fiskalnego. Dostępne tylko dla wersji 1.xx oprogramowania drukarki.

      • Dodatkowe linie w STOPCE paragonu - dodatkowe linie, np. z reklamą, które pojawią się w stopce paragonu fiskalnego

      • Do dokumentu nr - czy na paragonie fiskalnym ma się pojawić nr dokumentu wystawionego w programie. Numer będzie drukowany w nagłówku paragonu (wersja 1.xx) lub w stopce (2.xx).

      • Indeks i nazwa asortymentu - zaznaczamy, jeśli chcemy drukować na paragonie indeks i nazwę asortymentu, w przeciwnym wypadku wydrukuje się tylko nazwa

      • Pełna nazwa asortymentu - zaznaczamy, jeśli chcemy drukować na paragonie nazwę asortymentu z pola opisowego (taka sama, jak nazwa drukowana na fakturze). Jeśli pole to nie będzie zaznaczone na paragonie będzie drukowana skrócona nazwa asortymentu. Domyślnie pole to jest zaznaczone.

      • Timeout - czas oczekiwania programu na reakcję drukarki, w milisekundach. Domyślnie 200ms, można zwiększyć w przypadku problemów z komunikacją z drukarką

      • Raporty - korzystając z tej opcji możemy wydrukować na drukarce fiskalnej raport Dobowy lub Okresowy - równie dobrze można te raporty wydrukować bezpośrednio z panelu drukarki

      • Podłączona bezpośrednio - zaznaczamy, jeśli drukarka jest podłączona kablem bezpośrednio z tym komputerem, na którym dokonujemy konfiguracji. Jeśli jest połączona bezpośrednio kablem, ale z innym komputerem, to musimy uruchomić program i okno Urządzenia fiskalne na właściwym komputerze i ustawiwszy się na tej drukarce wybrać z menu podręcznego (prawy klawisz myszy lub klawisz F3) polecenie Przypisz do tego komputera - bezpośrednio.
        UWAGA. Niniejszy parametr pokaże się nam tylko wówczas, gdy parametr Przypisywanie drukarek fiskalnych do użytkownika w menu Ustawienia - Konfiguracja na zakładce Faktury pozostaje niezaznaczony (patrz PARAMETRY SYSTEMU - Konfiguracja). W przeciwnym wypadku zamiast niego pokaże się parametr opisany poniżej.

      • Przypisana wyłącznie do użytkownika - parametr ten jest zaznaczony, jeśli dana drukarka została przypisana tylko i wyłącznie dla konkretnego użytkownika. (W tym przypadku wyświetlona jest nazwa tego użytkownika.) Aby przypisać użytkownikowi daną drukarkę na wyłączność, należy wejść do programu za pomocą hasła tego użytkownika i zaznaczyć niniejszy parameter na odpowiedniej drukarce.
        UWAGA. Niniejszy parametr pokaże się nam tylko wówczas, gdy parametr Przypisywanie drukarek fiskalnych do użytkownika w menu Ustawienia - Konfiguracja na zakładce Faktury został zaznaczony (patrz PARAMETRY SYSTEMU - Konfiguracja). W przeciwnym wypadku zamiast niego pokaże się parametr opisany powyżej.

      • Współdzielona - zaznaczamy jeśli drukarka jest połączona z tym komputerem za pomocą przełącznika elektronicznego umożliwiającego współpracę kilku komputerów z jedną drukarką. W takim wypadku musimy uruchomić program i okno Urządzenia fiskalne na każdym komputerze, który będzie współpracował z tą drukarką i ustawiwszy się na tej drukarce wybrać z menu podręcznego (prawy klawisz myszy lub klawisz F3) polecenie Przypisz do tego komputera - współdzielona. W przypadku, gdy parametr Przypisywanie drukarek fiskalnych do użytkownika w menu Ustawienia - Konfiguracja na zakładce Faktury został zaznaczony, zaznaczenie parametru Współdzielona oznacza, że aktualny użytkownik jest jednym z kilku użytkowników mających dostęp do danej drukarki.

      • Nieużywana - jeśli nie korzystamy już z tej drukarki. Nie można jej całkowicie usuwać z listy urządzeń fiskalnych, gdyż jest powiązana z wydrukowanymi na niej paragonami.

    UWAGI:

    1. Informacja na drukarkę fiskalną wysyłana jest z kodowaniem znaków Mazovia. Taki sam system kodowania należy ustawić na drukarce fiskalnej, aby wydruki zawierały polskie znaki diaktryczne.

    2. Jeśli chcemy przetestować współpracę programu z nową drukarką fiskalną, która pracuje jeszcze w trybie niefiskalnym, należy się upewnić, czy drukarka ma zaprogramowany nagłówek paragonu oraz stawki vat.

  2. w definicji dokumentów, do których będą drukowane paragony fiskalne (faktura Vat, paragon) należy na zakładce Zawartość w grupie VAT:

    • zaznaczyć Podstawa przeliczeń - Brutto

    • włączyć parametr Fiskalny

  3. w oknie Faktury należy włączyć kolumnę Fiskalny i ewentualnie Drukarka fiskalna (Ctrl F4)

Kasa fiskalna

Aby skonfigurować program do współpracy z kasą fiskalną należy:

  1. skonfigurować parametry kasy, tzn.:

    1. utworzyć ją w oknie Urządzenia fiskalne

    2. określić jej parametry

      • Nazwa własna - dowolna nazwa, istotna jeśli korzystamy z kilku kas

      • Nr portu - nr portu COM, do którego jest podłączona drukarka (zwykle 1 lub 2)

      • Prędkość komunikacji, Kontrola transmisji, Parzystość - parametry komunikacji z kasą, można zostawić jako domyślne, a w przypadku problemów z komunikacją z kasą zmienić na inne - zgodnie z dokumentacją kasy.

      • Podłączona bezpośrednio - zaznaczamy jeśli kasa jest podłączona kablem bezpośrednio z tym komputerem, na którym dokonujemy konfiguracji. Jeśli jest połączona bezpośrednio kablem, ale z innym komputerem, to musimy uruchomić program i okno Urządzenia fiskalne na właściwym komputerze i ustawiwszy się na tej kasie wybrać z menu podręcznego (prawy klawisz myszy lub klawisz F3) polecenie Przypisz do tego komputera - bezpośrednio.

      • Nieużywana - jeśli nie korzystamy już z tej kasy.


Zewnętrzny generator raportów

PARAMETRYZACJA SYSTEMU

W menu głównym Ustawienia może się również pojawić pozycja Wzory raportów, umożliwiająca parametryzację raportów tworzonych w zewnętrznym generatorze raportów (np. Cristal Reports). Warunkiem jest wgranie zewnętrznego programu raportującego (reporter.exe) do podkatalogu REPORTER utworzonego w katalogu, w którym został zainstalowany nasz system. W tym samym katalogu należy zapisać pliki z definicjami raportów (*.frf).

Wygenerowanie zdefiniowanych raportów możliwe jest wtedy z menu Raporty - Raporty własne. Do wyboru będziemy mieli raporty o takich samych nazwach, jak nazwy plików definiujących raporty (*.frf).


Harmonogram zadań

PARAMETRYZACJA SYSTEMU

Harmonogram zadań służy do wykonywania niektórych dłuższych operacji w przypadku obsługi dużej bazy danych. Operacje takie to m.in. archiwizacja.

Wykorzystanie harmonogramu zadań polega zlecaniu dłuższych operacji (z programu uruchomionego przez użytkownika) do wykonania przez równolegle uruchomiony program w trybie serwera R2T. Zlecone zadanie może rozpocząć się natychmiast lub o określonej porze. Zaletą takiego rozwiązania jest:

  • możliwość kontynuacji pracy przez użytkownika natychmiast po zleceniu wykonania zadania bez konieczności czekania na zakończenie operacji, zadanie wykonuje się równolegle i jego wynik użytkownik uzyskuje natychmiast po ukończeniu

  • możliwość wykonania zadania w czasie najmniejszego obciążenia serwera

  • możliwość zaplanowania powtarzających się operacji, na przykład codziennej archiwizacji bazy danych.

Żeby uruchomić mechanizm kolejkowania zadań należy:

  1. utworzyć użytkownika z grupą praw dostępu Serwery R2T

  2. uruchomić program i zalogować się jako ten użytkownik - program uruchomi się w trybie aplikacji przyjmującej zlecenia innych użytkowników, program ten może zostać uruchomiony na dowolnym komputerze (ważne jest żeby był podłączony do właściwej bazy)

  3. we własnym programie (zalogowanym jako właściwy użytkownik) włączyć opcję Włącz obsługę niektórych funkcji przez serwer R2T (oraz ewentualnie Powiadamiaj stacje robocze o zakończeniu zadania) w menu Ustawienia - Środowisko na zakładce Zaawansowane

  4. wywołać operację do wykonania, np. menu Ustawienia - Archiwizacja

Po wywołaniu operacji przewidzianej do uwzględnienia przez harmonogram określamy sposób wykonania zadania:

  • Stacja robocza - zadanie wykonane zostanie natychmiast na aktualnej stacji roboczej w sposób standardowy, czyli bez wykorzystania serwera R2T

  • Serwer R2T - zadanie wykonane zostanie natychmiast przez aplikację uruchomioną w trybie serwer R2T

  • Zaplanuj zadanie - zadanie zostanie wykonane przez serwer R2T o ustalonym wg harmonogramu czasie

  • Nie wykonuj - zadanie nie zostanie wykonane.


Modyfikacja interfejsu

Parametryzacja systemu

W programie istnieje możliwość zmodyfikowania interfejsu użytkownika. W dowolnych istniejących oknach programu można dokładać nowe kontrolki, modyfikować stare (czyli zmieniać ich położenie względem okna lub innych kontrolek), a także zmieniać rozmiar okna, aby pomieściło nowe elementy. Dotyczy to zarówno pól użytkownika, które aby je edytować wymagają swoich kontrolek, jak i dowolnych innych elementów okna. W podanym poniżej przykładzie zdefiniujemy dwie kontrolki, które następnie wykorzystamy podczas tworzenia wyzwalacza. Kontrolki te wraz z polem użytkownika i wyzwalaczem stanowią mechanizm, dzięki któremu w oknie Kontrahenci na zakładce Inne automatycznie będzie uzupełniana data ostatnio wystawionej danemu klientowi faktury.

Opisane poniżej operacje działają tylko w trybie diagnostycznym (menu Ustawienia - Środowisko - Zaawansowane).

ZMIANA POŁOŻENIA, ROZMIARU I WŁAŚCIWOŚCI ISTNIEJĄCEJ KONTROLKI

W trybie diagnostycznym, na aktywnym oknie, w którym chcemy dokonać zmian, trzymając wciśnięte klawisze Alt Ctrl Shift, naciskamy na dowolnej kontrolce prawy przycisk myszy.

Otrzymujemy okienko do zmiany właściwości kontrolki, gdzie:

  • Name - unikalna nazwa kontrolki; informacyjnie, nie można jej zmienić

  • CType - typ kontrolki; nie można go zmieniać; możliwe wartości:

    • button - przycisk (np. OK, Anuluj)
    • checkbox - pole zaznaczenia Tak/Nie
    • dateedit - okienko edycyjne daty
    • dbcheckbox - pole zaznaczenia Tak/Nie dla pola z bazy danych
    • dbdateedit - okienko edycyjne daty dla pola z bazy danych
    • dbedit - okienko edycyjne dla pola z bazy danych
    • dblabel - etykieta dla pola z bazy danych
    • dblookupcombo - okienko edycyjne dla pola z bazy danych typu Lookup
    • dbmemo - okienko edycyjne dla pola z bazy danych typu Text (Memo)
    • edit - okienko edycyjne
    • filenameedit - okienko edycyjne wybory pliku
    • groupbox - okienko grupy kontrolek
    • label - etykieta
    • dbmemo - okienko edycyjne (Memo)
    • pagecontrol - okienko, na którym można umieszczać strony dla innych kontrolek
    • radiogroup - okienko grupy przycisków typu radiobutton (kropka)
    • spinedit - okienko edycyjne ze zwiększaniem/zmniejszaniem wartości
    • tabsheet - strona do umieszczania kontrolek (do umieszczenia na kontrolce typu pagecontrol)

  • Parent - "rodzic" kontrolki; określa gdzie kontrolka leży; jeśli bezpośrednio na oknie będzie to nazwa okna; jeśli leży na innej kontrolce, będzie to nazwa tej kontrolki. Kontrolkę można "przestawić" zmieniając nazwę rodzica.

  • Caption - tytuł kontrolki; tylko dla kontrolek typu label, groupbox, radiogroup, checkbox, dbcheckbox i tabsheet

  • TableName - nazwa tabeli w bazie danych, z którą jest skojarzona kontrolka; tylko dla typów dblabel, dbedit, dbdateedit, dbcheckbox, dblookupcombo i dbmemo (można nie podawać, wtedy domyślną tabelą jest tabela skojarzona z oknem)

  • FieldName - nazwa pola w tabeli TableName w bazie danych, z którym jest skojarzona kontrolka; tylko dla typów dblabel, dbedit, dbdateedit, dbcheckbox, dblookupcombo i dbmemo

  • Left, Top - odpowiednio: położenie lewej i górnej krawędzi kontrolki względem jej rodzica

  • Width, Height - odpowiednio: szerokość i wysokość kontrolki (niektóre kontrolki np. typu edit mają standardową wysokość i nie można jej zmienić)

  • Enabled - czy kontrolka jest aktywna

  • ReadOnly - czy kontrolka jest tylko do odczytu - dla kontrolek typu bazodanowego (db..).

Naciskając przycisk OK zatwierdzamy nowe właściwości kontrolki. Przycisk Kopiuj służy do umieszczenia kontrolki w schowku, w celu jej późniejszego wykorzystania. Pozycję kontrolki możemy również zmieniać trzymając wciśnięte klawisze Alt Ctrl Shift i ciągnąc myszą kontrolkę w nowe miejsce.
UWAGA. Nazwę, położenie i rodzica kontrolki można także poznać trzymając wciśnięte klawisze Alt Ctrl Shift i naciskająć lewy przycisk myszy. Wtedy na górze okna pokaże się informacja w formacie Form.Parent.Control; X=x ;Y=y ;W=w ;H=h , gdzie:

  • Form.Parent.Control - nazwa okna, po kropce nazwa rodzica i po kropce nazwa kontrolki

  • X=x ;Y=y - względne położenie lewej i górnej krawędzi kontrolki

  • W=x ;H=y - szerokość i wysokość kontrolki.

NOWA KONTROLKA

W trybie diagnostycznym, na aktywnym oknie, w którym chcemy dokonać zmian, trzymając wciśnięte klawisze Alt Ctrl Shift, naciskamy klawisz N.

Otrzymujemy okienko do wprowadzania nowej kontrolki, gdzie:

  • Name - unikalna nazwa kontrolki; program automatycznie doda przedrostek NewUsrCntrl_, ale trzeba uważać, żeby nazwa się nie powtarzała

  • CType - typ kontrolki; możliwe wartości jak w punkcie Zmiana położenia ...

  • Parent - "rodzic" kontrolki; określa gdzie kontrolka leży; jeśli bezpośrednio na oknie będzie to nazwa okna; jeśli leży na innej kontrolce, będzie to nazwa tej kontrolki. Nazwę rodzica należy wpisać z dokładnością do wielkich/małych liter.

  • Caption - tytuł kontrolki; tylko dla kontrolek typu label,groupbox,radiogroup,checkbox,dbcheckbox i tabsheet

  • TableName - nazwa tabeli w bazie danych, z którą jest skojarzona kontrolka; tylko dla typów dblabel,dbedit,dbdateedit,dbcheckbox, dblookupcombo i dbmemo (można nie podawać, wtedy domyślną tabelą jest tabela skojarzona z oknem.

  • FieldName - nazwa pola w tabeli TableName w bazie danych, z którym jest skojarzona kontrolka; tylko dla typów dblabel,dbedit,dbdateedit,dbcheckbox, dblookupcombo i dbmemo.

  • Left, Top - odpowiednio: położenie lewej i górnej krawędzi kontrolki względem jej rodzica; należy uważać żeby współrzędne nie wykraczały poza rozmiar kontrolki rodzica, albo okna, gdyż w przeciwnym wypadku kontrolki nie będzie widać. Rozmiar i nazwę rodzica można łatwo wyświetlić naciskając Alt Ctrl Shift i lewy przycisk myszy (zobacz uwagę do punktu Zmiana położenia ...)

  • Width, Height - odpowiednio: szerokość i wysokość kontrolki (niektóre kontrolki np. typu edit mają standardową wysokość i nie można jej zmienić)

  • Enabled - czy kontrolka jest aktywna

  • ReadOnly - czy kontrolka jest tylko do odczytu - dla kontrolek typu bazodanowego (db..).

Jeśli nowe kontrolki nie mieszczą się w oknie, można zmienić jego rozmiary trzymając wciśnięte klawisze Alt Ctrl Shift i ciągnąć myszą za prawą lub dolną krawędź okna. Jednakże dotyczy to tylko okien bazodanowych typu formatka z pozycjami (tam gdzie są zakładki Lista/Pozycja/Razem, lub tylko niewidoczna zakładka Pozycja, np. Adresy).

KOPIOWANIE KONTROLKI

W trybie diagnostycznym, na aktywnym oknie, w którym chcemy dokonać zmian, trzymając wciśnięte klawisze Alt Ctrl Shift, naciskamy na dowolnej kontrolce prawy przycisk myszy. Następnie w oknie "Właściwości" przycisk Kopiuj, zamykamy okno "Właściwości" i trzymając wciśnięte klawisze Alt Ctrl Shift, naciskamy klawisz V . Pojawi się okno "Nowa kontrolka" z właściwościami skopiowanej kontrolki.

USUWANIE KONTROLKI

W trybie diagnostycznym, na aktywnym oknie, w którym chcemy dokonać zmian, trzymając wciśnięte klawisze Alt Ctrl Shift, naciskamy klawisz C.

Otrzymujemy okienko, w którym widzimy wszystkie nowe i modyfikowane kontrolki, gdzie:

  • Name - nazwa kontrolki

  • Parent - nazwa rodzica kontrolki

  • CType - typ kontrolki

  • New - określa, czy jest to nowa kontrolka (założona przez użytkownika), czy tylko rekord dotyczący zmiany właściwości istniejącej kontrolki.

Nacikając przycisk Usuń albo usuwamy całkowicie nową kontrolkę (New=True) albo usuwamy wpis dotyczący istniejącej kontrolki (New=False), wtedy przywracają się jej domyślne właściwości (położenie, rozmiar, itd.). Nacikając przycisk Popraw można zmienić właściwości kontrolki (patrz punkt Zmiana położenia, rozmiaru ...).


Pola użytkownika

Konfiguracja bazy danych

PARAMETRYZACJA SYSTEMU

Istnieje możliwość samodzielnej konfiguracji bazy danych na której pracuje program, tak aby dostosować ją dokładnie do naszych specyficznych wymagań.

Możemy samodzielnie:

  • dodać nowe pola do istniejących tabel

    W ten sposób uzupełniamy prowadzone w programie ewidencje o potrzebne nam pola. Możemy np. dodać w bibliotece asortymentów pole Gwarancja, w którym będziemy wprowadzać okres gwarancji udzielanej przez producenta na dany asortyment. Samodzielnie dodawane pola nazywane są polami użytkownika. Dodawanie tych pól zostało szczegółowo opisane w rodziale Pola użytkownika.

  • utworzyć własne tabele danych

    W ten sposób możemy uzupełnić program o potrzebne nam dodatkowe biblioteki i ewidencje. Samodzielnie tworzone tabele nazywane są tabelami użytkownika. Tworzenie tych tabel zostało szczegółowo opisane w rodziale Tabele użytkownika.

  • podać źródła danych (biblioteki) ułatwiające wypełnianie istniejących pól

    Dla każdego pola tekstowego (nie tylko dla nowo wprowadzonego pola użytkownika) możemy określić listę wartości do wyboru z dowolnej tabeli w bazie. W tym celu klikamy w zawartość tego pola, z wciśniętymi klawiszami Ctrl i Alt. Określamy dowolne zapytanie SQL, które określi bibliotekę, z której będziemy wybierać wartości do bieżącego pola. Należy pamiętać, że przepisywać się będzie zawartość pierwszej kolumny. Tabele z innej bazy danych musimy poprzedzić nazwą bazy danych, natomiast w przypadku sięgania do tabeli na innym serwerze SQL dodatkowo określamy parametry dostępowe tego serwera.

    Po właściwym skonfigurowaniu zapytania użytkownik może wypełniać pole poprzez wybór z tabeli, która ukaże się po kliknięciu myszą w zawartość pola z wciśniętym klawiszem Ctrl.

  • dodać wyzwalacze

    W ten sposób możemy utworzyć wyzwalacze modyfikujące wartości pól w aplikacji i bazie, których zadaniem będzie wywołanie jakiejś procedury składowanej, lub tylko pokazanie dowolnego komunikatu. Tworzenie wyzwalaczy zostało szczegółowo opisane w rodziale Wyzwalacze użytkownika.


Pola użytkownika

PARAMETRYZACJA SYSTEMU - Konfiguracja bazy danych

System umożliwia ewidencjonowanie zawartości dodatkowych (własnych) informacji w bazie danych. Oznacza to, że w każdym oknie, w którym wprowadzamy dane możemy wprowadzić własne pola. Przykładowo w bibliotece kontrahentów wymagamy dodatkowego pola, w którym wpisywać będziemy datę ostatniej faktury powiązanej z tym kontrahentem. W tym celu skorzystamy z mechanizmu wyzwalaczy, aby pole to uzupełniane było automatycznie podczas generowania dokumentu sprzedaży. Na początek stworzymy sobie pole użytkownika typu Date, w które będzie wstawiana data oraz dwie kontrolki, aby pole to było widoczne w interfejsie programu.

W celu ustawienia własnego pola w bazie danych wybieramy z menu Ustawienia pozycję Pola użytkownika.

Dla nowego pola [image] określamy:

  • Zakładka DANE

    • Tabela - Nazwa tabeli, do której będzie dostawione nowe pole użytkownika

    • Pole - Nazwa nowego pola - nazwa ta nie może zawierać polskich liter ani znaków specjalnych

    • Typ pola - Typ:

      • String - pole znakowe
      • Integer - liczba całkowita
      • SmallInt - mała liczba całkowita (-65536 .. 65535)
      • Currency - kwota
      • Float - liczba zmiennoprzecinkowa
      • Date - data
      • Time - czas
      • DateTime - data i czas
      • Boolean - logiczne
      • Text - memo (długi tekst)
      • Graphic - graficzne (np.do przechowywania obrazków)

    • Rozmiar - Rozmiar pola typu String (liczba znaków)

    • Rodzaj pola - Rodzaj:

      • Data - pole danych umieszczone w bazie
      • Lookup - pole wglądu do innej tabeli
      • Calculated - pole kalkulowane, tzn. takie, które nie znajduje się w bazie danych, a jego wartość jest generowana podczas wykonywania zapytania do bazy na podstawie wartości innych pól.
      Poniższe cztery właściwości występują tylko dla pola rodzaju Lookup.

    • Tabela lookup - Tabela, do której ma wgląd pole rodzaju Lookup

    • Pole kluczowe - Nazwa pola w tabeli, wg którego następuje wgląd do 'tabeli lookup' (klucz obcy - z reguły należy wcześniej należy utworzyć takie pole typu Integer np."X_IDowolnejBiblioteki")

    • Klucz lookup - Nazwa pola w 'tabeli lookup', wg którego następuje do niej wgląd (klucz podstawowy - z reguły będzie to pole "X_I")

    • Rezultat lookup - Nazwa pola w 'tabeli lookup', które ma być rezultatem wglądu

      • Poniższa właściwość jest dostępna tylko dla pola rodzaju Calculated

    • Definicja - Zapytanie SQL, które definiuje wartość pola kalkulowanego, np. [Nazwisko]+[Imie]

    • Tylko do odczytu - Czy pole ma być edytowane, czy tylko widoczne do odczytu na formatce powiązanej z tabelą

  • Zakładka DEFINICJA, widoczna tylko dla pola rodzaju Data

    • Wartość domyślna - wartość domyślna pola dla nowego rekordu, np 1, 'alamakota'

    • Rodzaj

      • Obliczenie - umożliwia zdefiniowanie wartości pola w zależności od innych pól tabeli, za pomocą prostych działań arytmetycznych. Nazwy pól tabeli należy pisać w nawiasach kwadratowych np. [Stawka]*[Ilosc]/100.

      • SQL - pozwala na zdefiniowanie wartości pola za pomocą zapytania SQL, które zwróci pojedyńczy wynik. Wartości pól aktualnego rekordu można pobrać używając nawiasów klamrowych, np. {X_I} oznacza wartość pola X_I bieżącego rekordu.

    • Definicja - definicja obliczenia lub zapytania SQL

    • Wykonaj - określa moment, kiedy obliczenie lub zapytanie SQL, które modyfikuje wartość pola, ma się wykonać. Do wyboru:

      • AfterInsert - po utworzeniu nowego rekordu

      • OnNewRecord - po utworzeniu nowego rekordu

      • AfterEdit - po edycji istniejącego rekordu

      • BeforePost - przed zatwierdzeniem zmian nowego lub istniejącego rekordu.

Okno to służy także do definiowania pól w nowo utworzonych tabelach użytkownika.

Jeżeli chcemy pokazać w wybranym oknie kontrolkę z dodanym polem użytkownika, musimy utworzyć odpowiednią kontrolkę korzystając z funkcji Nowa kontrolka (patrz Modyfikacja interfejsu).


Tabele użytkownika

PARAMETRYZACJA SYSTEMU - Konfiguracja bazy danych

Tabele użytkownika służą do ewidencjonowania szczególnych danych użytkownika: bibliotek oraz innych ewidencji.

Na zakładce DEFINICJA wpisujemy:

  • Nazwa - nazwa identyfikująca nową tabelę w programie (będzie to również nazwa okna skojarzonego z tą tabelą, podpowiedź na przycisku, pozycja w menu, itd.)

  • Tabela - nazwa tabeli w bazie danych (musi to być nazwa unikalna, niezawierająca polskich liter ani znaków specjalnych)

  • Rodzaj - do wyboru:

    • Biblioteka - skojarzone z tabelą okno zostanie utworzone w menu Biblioteki użytkownika

    • Do tabeli - tabela będzie w relacji master-detail, do tabeli, którą należy podać niżej. W oknie bazodanowym, do którego tabeli nowa tabela pozostaje w relacji master-detail, pojawi się ikonka z rozwijalnym menu

  • Do tabeli - jeśli w polu Rodzaj wybrano wartość "Do tabeli", należy tutaj podać z jaką tabelą nadrzędną (master) należy połączyć nową tabelę (detail)

  • Bin - zaznaczenie tej opcji spowoduje umieszczenie nowej tabeli w bazie danych ogólnych, a nie w bazie firmy. Używane w przypadku bibliotek wspólnych dla wielu firm (np. biblioteka walut)

  • AutoTransact - oznacza, że tabela, która jest w relacji master-detail z tabelą (bądź tabelami) podrzędną, będzie działać w trybie transakcyjnym, tzn. wszystkie zmiany wprowadzone w tabeli podrzędnej (detail) zostaną zatwierdzone dopiero po zatwierdzeniu rekordu tabeli nadrzędnej (master). Dodatkowo pole identyfikatora w tej tabeli (X_I) będzie typu ftInteger, a nie ftAutoInc (czyli będzie wyłączone IDENTITY).

  • Widoczna - tabela (okno skojarzone z tą tabelą) będzie widoczne na paskach zadań bądź w menu bibliotek użytkownika

  • Formatka z pozycjami - zostanie utworzone okno skojarzone z tą tabelą w formie formatki typu 'Lista-Pozycja-Razem'.

Na zakładce UPRAWNIENIA wpisujemy grupy użytkowników, które mogą mieć dostęp do nowej tabeli.

Listę pól nowej tabeli uzupełniamy w polach użytkownika.


Wyzwalacze użytkownika

PARAMETRYZACJA SYSTEMU - Konfiguracja bazy danych

Wyzwalacze służą do wykonywania określonej akcji podczas tworzenia, modyfikowania lub usuwania rekordów dowolnej tabeli. Może to być np. polecenie SQL typu UPDATE, INSERT bądź DELETE, wywołanie konkretnej procedury składowanej, lub tylko pokazanie dowolnego komunikatu. W poniższym przykładzie zdefiniowany zostanie wyzwalacz, który będzie wstawiał w utworzone pole użytkownika (widoczne w oknie Kontrahenci na zakładce Inne) datę ostatniej wystawionej kontrahentowi faktury.

W celu utworzenia własnego wyzwalacza wybieramy z menu Ustawienia pozycję Wyzwalacze użytkownika.

Dla nowego wyzwalacza [image] określamy:

  • Tabela - nazwa tabeli w aplikacji, na której będzie działać wyzwalacz użytkownika

  • Wyzwalacz - moment uruchomienia wyzwalacza:

    • BeforeInsert - przed utworzeniem nowego rekordu

    • AfterInsert - po utworzeniu nowego rekordu

    • BeforeEdit - przed edycją istniejącego rekordu

    • AfterEdit - po edycji istniejącego rekordu

    • BeforePost - przed zatwierdzeniem zmian nowego lub istniejącego rekordu, uruchamiany tylko gdy jest widoczny interfejs użytkownika

    • AlwaysBeforePost - przed zatwierdzeniem zmian nowego lub istniejącego rekordu, uruchamiany zawsze

    • AfterPost - po zatwierdzeniu zmian nowego lub istniejącego rekordu, uruchamiany tylko gdy jest widoczny interfejs użytkownika

    • AlwaysAfterPost - po zatwierdzeniu zmian nowego lub istniejącego rekordu, uruchamiany zawsze

    • BeforeDelete - przed kasowaniem rekordu

    • AfterDelete - po kasowaniu rekordu

    • OnChangeField - gdy wartość jakiegoś pola w rekordzie (kontrolki) została zmieniona.

    UWAGA. Wszystkie rodzaje wyzwalaczy za wyjątkiem Always... są uruchamiane tylko wtedy, gdy jest widoczny interfejs użytkownika (tzn. jest widoczne okno i w nim wprowadzamy dane).

  • Typ - typ wyzwalacza:

    • Akcja - zostanie wykonanie polecenie SQL podane w Definicji

    • Akcja warunkowa - po zatwierdzeniu komunikatu na 'Tak', zostanie wykonanie polecenie SQL podane w Definicji

    • Komunikat (Info) - zostanie wywołany komunikat typu 'Info', jeśli zapytanie SQL podane w Definicji zwróci choć jeden rekord

    • Komunikat (Ostrzeżenie) - zostanie wywołany komunikat typu 'Ostrzeżenie', jeśli zapytanie SQL podane w Definicji zwróci choć jeden rekord

    • Błąd - zostanie wywołany komunikat błędu, jeśli zapytanie SQL podane w Definicji zwróci choć jeden rekord, a dalsza akcja zostanie przerwana

  • Definicja - definicja zapytania lub polecenia SQL. Wartości pól aktualnego rekordu można pobrać używając nawiasów klamrowych, np. {X_I} oznacza wartość pola X_I bieżącego rekordu; np. update kontrah set [OstatniaSprzedaz]={DataW} where [X_I]={X_INabywca} wykonane na zdarzeniu AfterPost tabeli FAKTURY uaktualni pole OstatniaSprzedaz w tabeli KONTRAHENCI tak by pole to było równe polu DataW (Data wystawienia). Można odwoływać się także do pól z innych tabel w następujący sposób {NAZWA_TABELI_W_APLIKACJI.Pole}; np. {KONTRAHENCI.X_I}.
    UWAGA. Nie mylić nazwy tabeli w bazie z nazwą tabeli w aplikacji. Dwuklik myszy na tym polu powoduje otwarcie okna wygodnego edytora zapytań SQL.

  • Komunikat - treść komunikatu

  • Aktywny - czy wyzwalacz ma działać.

UWAGI:

  1. Aby wykonać wyzwalaczem wiele poleceń SQL za jadnym razem, należy w definicji użyć klauzuli go, która rozdziela zapytania SQL; np:
    update tabela_1 set [pole_1]=1
    go
    update tabela_2 set [pole_1]=1
    go

  2. Ponieważ wyzwalacz OnChangeField jest wyzwalany zawsze, gdy wartość dowolnego pola w rekordzie (kontrolki) została zmieniona, przy dużej ilości pól w tabeli będzie on wykonywany wielokrotnie, co może spowolnić działanie programu. Aby tego uniknąć można w definicji wyzwalacza zastosować klauzulę onchange={nazwa_pola_1},{nazwa_pola_1},...,{nazwa_pola_n}, wtedy będzie on wyzwalany tylko przy zmianie wartości pól wymienionych w klauzuli.

  3. Jeśli chcemy wykryć, czy tabela jest w danej chwili w trybie Insert (nowy rekord został dostawiony); np. w AfterPost chcemy aby wyzwalacz inaczej zachowywał się przy wstawieniu rekordu niż przy edycji, można użyć zmiennej specjalnej <INS>, która zwraca wtedy True; np:
    if <INS> begin
    zrób coś, bo wstawiono nowy rekord
    end
    else begin
    zrób coś, bo istniejący rekord został zmieniony
    end

  4. Jeśli po usunięciu rekordu w AfterDelete chcemy zmodyfikować jakieś powiązania skasowanego rekordu z innymi tabelami (np. usunąć z nich jego Ide), to można wykorzystać zmienną specjalną <DEL_IDE>, która zwraca identyfikator usuniętego rekordu; np:
    update TABELA set [X_IRec]=0 where [X_IRec]=<DEL_IDE> .


Edytor zapytań SQL

PARAMETRYZACJA SYSTEMU - Konfiguracja bazy danych

Edytor zapytań SQL jest wywoływany podczas definiowania obiektów użytkownika oraz przy tworzeniu zestawień SQL lub makiet dokumentów. Pozwala na wygodne zapisywanie poleceń SQL, używając kolorów do zaznaczania słów kluczowych, nazw tabel i pól, zmiennych oraz różnych znaków sterujących.

Składnia zapytań SQL w aplikacji zasadniczo nie różni się od języka SQL; wprowadzono jedynie kilka zmian umożliwiających dostęp do tabel i pól aplikacji oraz do zmiennych specjalnych:

  • W nawiasach kwadratowych [...] piszemy nazwy pól z tabel z bazy danych np. [X_INabywca]

  • W nawiasach klamrowych {...} piszemy nazwy pól z tabel z aplikacji np. {X_I}, przy czym można odwoływać się także do pól z tabeli, która nie jest aktualnie w kontekście zapytania np. {FAKTURY.X_I} poprzedzając nazwę pola nazwą tabeli z kropką

  • W nawiasach ostrych <...> piszemy nazwy zmiennych specjalnych np. <INS>.

Pod prawym przyciskiem myszy dostępne są polecenia, które można wykorzystać w tworzonym zapytaniu SQL:

  • Ide użytkownika <USERIDE> - identyfikator zalogowanego użytkownika

  • Nazwa użytkownika <USERNAME> - nazwa zalogowanego użytkownika

  • Ide firmy <FIRMIDE> - identyfikator firmy

  • Nazwa bazy danych <DB> - nazwa bazy danych np.R2T_fakturyPRO

  • Nazwa bazy danych Bin <BIN> - nazwa bazy danych np.R2T_fakturyPRO_bin

  • Tabela w trybie Insert <INS> - jeśli tabela jest w trybie Insert (dostawiono nowy rekord), to wartość tej zmiennej będzie True (1>0) w przeciwnym wypadku False (1<0)

  • Identyfikator skasowanego rekordu <DEL_IDE> - identyfikator skasowanego rekordu

  • Tabele i pola - lista tabel i pól aplikacji.


BEZPIECZEŃSTWO DANYCH

INSTRUKCJA ADMINISTRATORA

Rozdział ten poświęcimy grupie funkcji, służących do obsługi bazy danych oraz zabezpieczenia i odzyskania danych w razie ewentualnej awarii:

  • archiwizacja danych

  • odtwarzanie danych z archiwum

  • serwisowanie danych.


Archiwizacja danych

BEZPIECZEŃSTWO DANYCH

Archiwizacja danych służy do tworzenia zapasowych kopii danych. Służą one do odzyskania danych zgromadzonych w programie w przypadku awarii komputera, działania wirusa, zaniku zasilania w trakcie pracy z programem, awarii programu, kradzieży komputera i wielu innych zdarzeń losowych. W skrajnym przypadku, aby rozpocząć normalną pracę, wystarczy wówczas zainstalować program na innym komputerze, odtworzyć archiwum i ewentualnie uzupełnić dane wprowadzone do programu w okresie od wykonania archiwum do wystąpienia awarii. Archiwa mogą się również przydać do przechowywania danych archiwalnych z poprzednich lat.

Archiwum danych ma postać jednego skompresowanego pliku zawierającego wszystkie dane zgromadzone w programie. Plik ten można przechowywać na dysku twardym komputera, ale w innej lokalizacji niż dane robocze, na których pracuje program. Można go również utworzyć na zewnętrznym dysku typu pendrive, na płycie CD-ROM, dyskietkach itp. Wybór nośnika, na którym będziemy przechowywać archiwum zależy tylko od nas, ale trzeba sobie zdawać sprawę z wad i zalet dokonanego wyboru. Np.:

  • dysk twardy komputera - archiwizacja wykonuje się bardzo szybko, ale jeśli jest to dysk twardy tego samego komputera na którym pracuje program, to niestety w przypadku awarii dysku twardego, kradzieży komputera, pożaru itp. utracimy zarówno dane robocze, na których normalnie pracujemy jak i wszystkie archiwa danych. Lepszym rozwiązaniem byłoby wybranie dysku twardego innego komputera widocznego w sieci komputerowej, jeśli oczywiście dysponujemy taką siecią.

  • zewnętrzny dysk np. typu pendrive - trochę wolniejsza archiwizacja, ale stosunkowo duża pewność odzyskania danych, zwłaszcza jeśli pendrive będzie przechowywany gdzie indziej niż komputer (najlepiej poza firmą). Przy obecnych (2007 r.) cenach i pojemnościach pendrive'ów jest to bardzo dobre rozwiązanie.

  • płyta CD-ROM lub DVD-ROM - najpewniejszy nośnik jeśli chodzi o długoterminowe przechowywanie danych. Wada: nie da się utworzyć archiwum bezpośrednio na płycie, trzeba je utworzyć na dysku twardym i nagrać na płytę przy pomocy odpowiedniego programu. Jest to niestety czasochłonne i skutecznie zniechęca do regularnego (np. codziennego) archiwizowania na tym nośniku. Ale okresowo, np. raz na miesiąc - jak najbardziej.

Wybór sposobu przechowywania danych, a także częstotliwości archiwizowania danych zależy przede wszystkim od charakteru naszej działalności. Jeśli wystawiamy miesięcznie kilka faktur, możemy spokojnie poprzestać np. na comiesięcznym archiwizowaniu danych na dysku twardym. W przypadku awarii odtworzenie na podstawie papierowych kopii kilkunastu brakujących dokumentów nie powinno stanowić większego problemu. Natomiast jeśli np. wystawiamy dziennie sto faktur, powinniśmy się zdecydować na codzienną (lub nawet co kilka godzin) archiwizację na dysku twardym lub pendrivie, i np. co tydzień na płycie CD-ROM. Wtedy w najgorszym wypadku po odtworzeniu ostatniego archiwum będziemy musieli wpisać ponownie dokumenty z ostatniego dnia (lub z ostatnich paru godzin).

Nic nie stoi na przeszkodzie, żeby ten sam plik archiwalny przechowywać w różnych miejscach. Możemy również przechowywać równocześnie kilka plików archiwalnych, utworzonych w różnych okresach, gdyż czasem zdarza się, że skutki awarii zauważymy dopiero po jakimś czasie i ostatnie posiadane archiwum będzie już zawierało uszkodzone dane.

Reasumując: im częstsza i pewniejsza do odzyskania archiwizacja, tym mniej problemów w przypadku awarii.

W okienku Archiwizacja wywołanym z menu głównego poleceniem Zbiory - Archiwizacja określamy:

  • Zawartość archiwum - możemy zarchiwizować:

    • Dane ogólne - globalne dane programu, czyli użytkownicy, firmy, rachunki bankowe, formy płatności itp.

    • Dane firmy (1), Dane firmy (2)... - dane wszystkich firm obsługiwanych w programie (PZ, faktury, kontrahenci, asortymenty itp.)

    Jeśli program jest wykorzystywany do obsługi wielu firm, to do szybkiego określenia żądanej zawartości archiwum można wykorzystać przyciski Zaznacz wszystkie i Odznacz wszystkie.
    Jeśli korzystamy z programu do obsługi wielu firm, to w przypadku archiwizowania danych jednej z tych firm program zaproponuje archiwizację danych ogólnych dotyczących tylko tej wybranej firmy. Dzięki temu, po odtworzeniu archiwum w programie jednofirmowym, będą widoczne dane dotyczące tylko i wyłącznie tej jednej firmy.

  • Usuń z archiwum dane poufne - zaznaczenie tej opcji spowoduje, że dane firmy oraz wszystkich kontrahentów i asortymentów zostaną pozamieniane na ciągi gwiazdek '*', uniemożliwiające identyfikacje oryginalnych nazw, adresów, telefonów, numerów NIP itp. Takie dane można w razie potrzeby wysłać do serwisu bez obawy o ewentualne ujawnienie własnych tajemnic handlowych.

  • Opis - dowolne uwagi, dzięki którym będziemy mogli łatwo określić czy chodzi nam o to właśnie archiwum w momencie odtwarzania danych

  • Hasło - wprowadzamy hasło zabezpieczające archiwum przed odtworzeniem przez osobę nieupoważnioną; odtwarzanie danych z archiwum bez podania wprowadzonego tu hasła będzie niemożliwe; jeśli nie wprowadzimy hasła to przy odtwarzaniu program nie będzie o nie pytał

  • Powtórz hasło - jeszcze raz wpisujemy to samo hasło w celu uniknięcia pomyłki

  • Zapamiętaj hasło - po zaznaczeniu tej opcji przy kolejnej archiwizacji program będzie podpowiadał poprzednio wprowadzone hasło; jeśli nie zaznaczymy tej opcji, każdorazowo będziemy określać hasło podczas archiwizacji

  • Plik archiwum - gdzie ma zostać utworzony plik archiwum, w przypadku archiwizacji na dysk twardy to np. C:\RFaktury.spq; jeśli plik archiwum ma zostać utworzony w jakimś folderze (katalogu) np. C:\ARCHIWUM, to folder ten musi zostać wcześniej utworzony; jeśli podamy plik, który już istnieje, to zostanie on w trakcie archiwizacji nadpisany (tzn. zapisany w całości na nowo).

  • Dodaj datę do nazwy pliku - dodaje do wybranej wyżej nazwy pliku archiwalnego koncówkę [RRRR.MM.DD_GG.NN], gdzie RRRR to rok, MM miesiąc, DD to dzień bieżącej daty, a GG i NN to bieżąca godzina i minuta. Opisany wyżej format można zmienić w menu Ustawienia - Środowisko - Zaawansowane - Archiwum - Data archiwum. Dzięki dołączeniu daty do nazwy pliku unikamy nadpisywania zapisanego wcześniej archiwum kolejnym archiwum o tej samej nazwie. W przypadku awarii bardzo istotne jest posiadanie właściwego pliku archiwalnego umożliwiającego odtworzenie danych sprzed momentu wystąpienia awarii.

  • Rozmiar woluminu - czy ma zostać utworzony jeden plik archiwalny bez względu na jego rozmiar (Bez limitu) czy też plik archiwalny ma zostać podzielony na pliki o zadanym rozmiarze np. 650 MB, dzięki czemu poszczególne pliki zmieszczą się na płytach CD-ROM; w przypadku plików dzielonych wg rozmiaru kolejne pliki archiwalne znajdą się tam, gdzie wskazany Plik archiwum z tym że będą miały inne rozszerzenia, np. jeśli Plik archiwum to c:\archiwum\rfaktury.spq, to w przypadku podziału powstaną pliki c:\archiwum\rfaktury.001, c:\archiwum\rfaktury.002 itp.

UWAGI:

  1. Jeśli funkcja archiwizacji danych nie jest dostępna, oznacza to, że serwer SQL zainstalowany jest na innym komputerze niż właściwy program. W takim przypadku należy w menu głównym wybrać Ustawienia - Środowisko i na zakładce Zaawansowane właściwie określić parametry w sekcji Archiwum (patrz PARAMETRYZACJA SYSTEMU - Środowisko).

  2. Dane można również archiwizować samodzielnie bezpośrednio funkcjami serwera SQL (backup). Przy bezpośredniej archiwizacji należy wybrać odpowiednie bazy np. R2T_faktury_bin i R2T_faktury_dane_1 (patrz INSTALOWANIE PROGRAMU - Nowa baza danych).

Do odtworzenia archiwalnych kopii danych z momentu archiwizacji służy odtwarzanie danych.

W zależności od ustawień środowiska programu (menu Ustawienia - Środowisko, zakładka Zaawansowane, parametr Przypominaj o archiwizacji) program będzie co jakiś czas monitował (przypominał) o wykonaniu kopii zapasowych danych.


Odtwarzanie danych

BEZPIECZEŃSTWO DANYCH

Odtwarzanie danych (Zbiory - Narzędzia - Odtwarzanie z archiwum - Odtwarzanie) jest czynnością odwrotną do archiwizacji, pozwala odtworzyć zarchiwizowane wcześniej dane.

Przy odtwarzaniu danych, podobnie jak przy archiwizacji, określamy:

  • Plik archiwum - gdzie znajduję się plik zawierający archiwum danych, np. C:\RFaktury.spq, C:\ARCHIWUM\RFaktury.spq.

  • Informacje - po określeniu pliku archiwalnego pojawiają się podstawowe informacje dotyczące archiwum, w szczególności data archiwizacji i licencja programu, w którym ją wykonano.
    UWAGA. Należy zwrócić uwagę na informację Dane z serwera, gdyż nie da się odtworzyć archiwizacji na innym rodzaju serwera SQL.

  • Zawartość archiwum - jakie dane z istniejących w archiwum chcemy odtworzyć:

    • Dane ogólne - globalne dane programu, czyli użytkownicy, firmy, rachunki bankowe, formy płatności itp.

    • Dane firmy (1),Dane firmy (2)... - dane wszystkich firm obsługiwanych w programie (PZ, faktury, kontrahenci, asortymenty itp.).

    Jeśli program jest wykorzystywany do obsługi wielu firm, pomocne mogą się okazać przyciski Zaznacz wszystko i Odznacz wszystko

  • Opis - opis archiwum

  • Hasło - jeśli w trakcie archiwizacji podano hasło musimy podać takie same hasło.

UWAGA. Odtwarzanie pozwala na odtworzenie stanu danych z momentu archiwizacji. Po odtworzeniu bieżące dane giną bezpowrotnie, dlatego funkcji tej należy używać tylko po awarii i w ostateczności, gdy inne sposoby naprawy danych (serwis) nie dają rezultatu.

Jeśli funkcja odtwarzania danych nie jest dostępna, oznacza to, że serwer SQL zainstalowany jest na innym komputerze niż właściwy program. W takim przypadku należy w menu głównym wybrać Ustawienia - Środowisko i na zakładce Zaawansowane właściwie określić parametry w sekcji Archiwum (patrz PARAMETRYZACJA SYSTEMU - Środowisko).


Serwisowanie danych

BEZPIECZEŃSTWO DANYCH

W razie jakichkolwiek problemów lub wątpliwości związanych z działaniem systemu zawsze mamy możliwość konsultacji telefonicznej z dystrybutorem lub producentem (tel. 071 3771202). Jeśli rozmowa telefoniczna jest niewystarczająca możemy uzyskać pomoc techniczną również w biurze dystrybutora lub producenta (Wrocław, ul.Jesionowa 23-25) lub na życzenie w siedzibie użytkownika.

Niektóre awarie komputera lub bazy danych wymagają dostarczenia danych do serwisu. Obecnie, jeśli mamy dostęp do Internetu, możemy to zrobić przesyłając archiwum danych pocztą elektroniczną na adres serwis@reset2.pl lub skorzystać z możliwości automatycznego przesłania danych do serwisu producenta bezpośrednio z programu. Korzystając z tego drugiego rozwiązania możemy w prosty sposób zarówno przedstawić występujące problemy, jak również przesłać załączoną bazę danych do konsultacji lub naprawy.

Do funkcji serwisowych należą:

  • wysyłanie danych do serwisu

  • pobieranie danych z serwisu.

UWAGA. Jeśli funkcje związane z serwisowaniem danych nie są dostępne, oznacza to, że serwer SQL zainstalowany jest na innym komputerze niż właściwy program. W takim przypadku należy w menu głównym wybrać Ustawienia - Środowisko i na zakładce Zaawansowane właściwie określić parametry w sekcji Archiwum (patrz PARAMETRYZACJA SYSTEMU - Środowisko).


Wysyłanie danych do serwisu

BEZPIECZEŃSTWO DANYCH - Serwisowanie danych

Funkcja automatycznego wysyłania danych do serwisu (Zbiory - Narzędzia - Serwisowanie danych - Wysyłanie danych do serwisu) umożliwia w prosty sposób przesłanie do serwisu bazy danych wraz z opisem awarii. Warunkiem jest dostęp do Internetu.

Przed wysłaniem określamy:

  • Opis problemu: - próbujemy dość szczegółowo określić nieprawidłowości

  • Kontakt - osoba do ewentualnych konsultacji telefonicznych

  • Dane ogólne - wysyłane są globalne dane programu, czyli lista użytkowników, lista firm, wspólne biblioteki

  • Dane aktualnej firmy - załączone zostaną dane dotyczące wybranej firmy, czyli faktury, kontrahenci, asortymenty i inne lokalne biblioteki.

  • Usuń z archiwum dane poufne - zaznaczenie tej opcji spowoduje, że dane firmy oraz wszystkich kontrahentów i asortymentów zostaną pozamieniane na ciągi gwiazdek '*', uniemożliwiające identyfikacje oryginalnych nazw, adresów, telefonów, numerów NIP itp. Takie dane można w razie potrzeby wysłać do serwisu bez obawy o ewentualne ujawnienie własnych tajemnic handlowych.

UWAGA. W przypadku problemów z wysyłaniem danych do serwisu należy sprawdzić konfigurację połączenia internetowego i zwrócić uwagę na ustawienia środowiska programu (menu Ustawienia - Środowisko, zakładka Internet, parametry FTP) oraz na ustawienia zapór internetowych (firewall).

Po wysłaniu danych czekamy na odpowiedź serwisu. Wyjaśnienia i ewentualnie naprawione dane możemy odebrać za pomocą funkcji Pobieranie danych z serwisu (Zbiory - Narzędzia - Serwisowanie danych).


Pobieranie danych z serwisu

BEZPIECZEŃSTWO DANYCH - Serwisowanie danych

Funkcja automatycznego pobrania danych z serwisu (Zbiory - Narzędzia - Serwisowanie danych - Pobieranie danych z serwisu) umożliwia zapoznanie się z opisem wyjaśnienia problemu oraz ewentualnie wgranie naprawionych danych. Oczywiście oczekiwać odpowiedzi możemy, jeśli wcześniej wysłaliśmy pytania lub opis problemu za pomocą funkcji Wysyłanie danych do serwisu.

Wywołując funkcję Pobieranie danych z serwisu pojawi się okienko, z którego wybieramy następujące polecenia:

  • Odbierz - sprawdzamy, czy jest już przygotowana odpowiedź serwisu

  • Odtwórz dane - ewentualnie pobieramy i wgrywamy naprawione przez serwis dane.

Przed pobraniem danych możemy na wszelki wypadek zarchiwizować dotychczasowe dane, zaznaczając opcję Zarchiwizuj dane przed odtworzeniem.

UWAGA. W przypadku problemów z wysyłaniem danych do serwisu należy sprawdzić konfigurację połączenia internetowego i zwrócić uwagę na ustawienia środowiska programu (menu Ustawienia - Środowisko, zakładka Internet, parametry FTP) oraz na ustawienia zapór internetowych (firewall).


Załączniki

Załączniki (poza instrukcją)

INSTRUKCJA ADMINISTRATORA

Dostępne załączniki:

  • Inicjalizacja na podstawie pliku buforowego - specyfikacja.


Specyfikacja inicjalizacji bazy danych

ZAŁĄCZNIKI

Funkcja Inicjalizacja na podstawie pliku buforowego (w pozycji menu głównego Zbiory - Narzędzia) wykorzystuje przygotowany wcześniej plik buforowy zawierający dane do zaimportowania.

Plik ten można wygenerować opierając się na opisie jego struktury. Format pliku oparty jest na następujących założeniach:

  • Jest to plik tekstowy

  • Plik może zawierać dane jednej lub wielu firm. Jeżeli firm jest więcej niż jedna, to dane każdej z nich znajdują się w osobnych sekcjach następujących kolejno po sobie (tzn. najpierw wszystkie dane dotyczące pierwszej firmy, potem wszystkie dane kolejnej firmy itd.)

  • Na początku każdej sekcji znajduje się osobna linia zawierająca znacznik rodzaju danych, których dotyczy dana sekcja, np. *F - dane firm, *K - dane kontrahentów, *A - dane asortymentów.

  • Po linii identyfikującej sekcję następują linie danych. Jedna linia odpowiada jednemu obiektowi, tzn. jednej firmie, kontrahentowi, asortymentowi itd.

  • Poszczególne dane (pola) w linii oddzielone są średnikiem (;). Jeśli w polu z danymi występuje średnik, np. w danych adresowych kontrahenta, należy całe pole ograniczyć znakami cudzysłowia ("). Jeśli w polu z danymi występuje na początku (zaraz po średniku) cudzysłów, np. w danych adresowych kontrahenta, należy cudzysłów zamienić na dwa cudzysłowia i dodatkowo całe pole ograniczyć znakami cudzysłowia (").

  • W polach znakowych typu memo, tzn. takich, w których występuje kilka linii tekstu (np. nazwa firmy), znaczniki nowej linii należy zastąpić ciągiem znaków @$%

  • Każdą linię kończy znacznik nowej linii (CR LF)

  • Polskie znaki diakrytyczne zapisane są w formacie Windows-1250 lub Latin-2. Właściwy format należy wybrać przed rozpoczęciem importu.

  • Daty zapisane są w formacie DD-MM-RRRR (np. 31-01-2002)

  • Separatorem dziesiętnym w polach liczbowych jest kropka (np. 1201.25)

  • Plik nie może zawierać pustych linii.

Sekcja Firmy ma następującą strukturę:

  • linia *F - identyfikator początku sekcji

  • linia z danymi pierwszej firmy (nazwa, adres, NIP itd.)

  • linie (jedna lub więcej) z rachunkami bankowymi tej firmy. Każda z tych linii rozpoczyna się znakami R;

  • sekcja kontrahentów *K danej firmy

  • sekcja kategorii *KTG danej firmy

  • sekcja grup asortymentowych *GAS danej firmy

  • sekcja PKWiU *PKW danej firmy

  • sekcja jednostek miary *JM danej firmy

  • sekcja asortymentów *A danej firmy

  • jeżeli mamy kolejne firmy, to wszystko zaczyna się teraz od początku, tzn. ponownie należy teraz umieścić w pliku linię *F, a za nią dane kolejnej firmy, itd.

UWAGA. W najprostszym przypadku, jeśli chcemy tylko dane z jednej firmy, sekcja Firmy nie jest potrzebna. Wystarczy, że przed wykonaniem importu pliku zaznaczymy parametr Importuj tylko dane bieżącej firmy (patrz Inicjalizacja na podstawie pliku buforowego). Dzięki temu plik buforowy może mieć dużo prostszą strukturę - wystarczy w nim wtedy np. tylko sekcja kontrahentów. Z kolei, jeżeli chcemy importować asortymenty, to wraz z sekcją *A (dane o asortymentach) konieczna jest też sekcja *PKW, zawierająca bibliotekę PKWiU. Sekcja ta jest konieczna, gdyż w programie Rfaktury dane o stawce VAT danego asortymentu wynikają z przypisanego do niego PKWiU (patrz BIBLIOTEKI - Asortymenty - PKWiU.) Pozostałe sekcje powiązane z kartoteką asortymentów (czyli kategorie, grupy asortymentowe i jednostki miary) nie są obowiązkowe. Biblioteki te utworzą się automatycznie na podstawie danych zawartych w sekcji *A. Na przykład jeżeli w danych asortymentów pojawią się jednostki miary kg i m2, to jednostki te automatycznie znajdą się w bibliotece Jednostki miary.

PRZYKŁADY.
W rozwikłaniu ewentualnych problemów z przygotowaniem pliku może pomóc przykładowy plik zawierający dane kilku firm oraz przykładowy plik zawierający dane tylko jednej firmy.
Tego typu przykładowe pliki z danymi można łatwo wygenerować samodzielnie. Wystarczy zainstalować wersję demonstracyjną programu i wprowadzić do niej kilku kontrahentów i/lub asortymentów. Eksport wprowadzonych danych umożliwi polecenie menu Zbiory - Narzędzia - Eksport danych do pliku buforowego.

OPIS STRUKTURY.
Poniżej znajduje się szczegółowy opis struktury pliku buforowego. W opisie uwidoczniono znacznik sekcji oraz wyliczono poszczególne pola w linii danych w tej sekcji. W nawiasach zaznaczono rodzaj pola:

  • (Z): tekst jednolinijkowy

  • (D): data (DD-MM-RRRR)

  • (W): wybór z listy dostępnych zawartości

  • (K): kwota (NNNNNNNNNNNN.GG)

  • (I): liczba całkowita (NNNNN)

  • (M): memo, tzn. pole tekstowe z możliwością wpisania kilku linii tekstu. Nową linię w takich polach należy oznaczyć ciągiem znaków: małpa-dolar-procent (@$%)

*F |  | Firmy
1. | Skrócona nazwa firmy | (Z)
2. | Nagłówek dokumentów | (M)
3. | NIP | (Z)
4. | REGON | (Z)
5. | Płatnik VAT | (W: Tak / Nie)
6. | Płatnik VAT-7(K) | (W: Tak / Nie)
7. | Płatnik VAT-12 | (W: Tak / Nie)
8. | Data rozp. działaln. | (D)
9. | Rodzaj podatnika | (W: osoba fizyczna / spółka cywilna)
10. | Rozliczenia | (W: księga przychodów / ewidencja sprzedaży / najem lub dzierżawa / pełna księgowość (FK))
11. | Nazwa | (Z)
12. | Adres | (M)
13. | Kraj | (Z)
14. | Miejscowość | (Z)
15. | Gmina | (Z)
16. | Kod gminy GUS | (Z)
17. | Powiat | (Z)
18. | Województwo | (W: dolnośląskie / kujawsko-pomorskie / lubelskie / lubuskie / łódzkie / małopolskie / mazowieckie / opolskie / podkarpackie / podlaskie / pomorskie / śląskie / świętokrzyskie / warmińsko-mazurskie / wielkopolskie / zachodnio-pomorskie)
19. | Ulica | (Z)
20. | Nr domu | (Z)
21. | Nr lokalu | (Z)
22. | Kod pocztowy | (Z)
23. | Poczta | (Z)
24. | Telefon | (Z)
25. | Fax | (Z)
26. | E-mail | (Z)
27. | Urząd skarbowy | (Z)
28. | Pełna nazwa (używana na formularzach VAT/CIT) | (M)
29. | Nazwa org. rejestr. | (Z)
30. | Nazwa rejestru | (Z)
31. | Data rejestracji | (D)
32. | Numer w rejestrze | (Z)
33. | Rodzaj działaln. | (Z)
34. | Miejsce działaln. | (Z)
35. | Kod EKD | (Z)
36. | Imię osoby reprezentującej | (Z)
37. | Nazwisko osoby reprezentującej | (Z)
38. | Imię osoby wypełniającej PITy | (Z)
39. | Nazwisko osoby wypełniającej PITy | (Z)
40. | VAT kwartalnie | (W: Tak / Nie)
41. | Pierwszy wpis | (I)
42. | Pierwsza strona | (I)
43. | W roku | (I)
44. | Transakcje zagraniczne | (W: Tak / Nie)
45. | Waluty | (W: Tak / Nie)
46. | Rachunek zysków i strat w wersji kalkulacyjnej | (W: Tak / Nie)
Rachunki bankowe danej firmy |  |
1. | R | Litera R oznaczająca linię dotyczącą konta bankowego firmy
2. | Nazwa rachunku | (Z)
3. | Bank | (Z)
4. | Konto | (Z)
5. | Ustaw jako domyślny | (W: Tak / Nie)

*K |  | Kontrahenci
1. | Skrót | (Z)
2. | NIP | (Z)
3. | Dostawca | (W: Tak / Nie)
4. | Odbiorca | (W: Tak / Nie)
5. | Płatnik VAT | (W: Tak / Nie)
6. | Pełna nazwa | (Z)
7. | Kraj | (W: _ / PL / AT / BE / CY / CZ / DK / EE / FI / FR / EL / ES / NL / IE / LT / LU / LV / MT / DE / IT / PT / SK / SI / SE / HU / GB)
8. | Inny | (W: Tak / Nie)
9. | Stały | (W: Tak / Nie)
10. | Z UE | (W: Tak / Nie)
11. | Termin zapłaty (liczba dni) | (I)
12. | Forma zapłaty | (Z)
13. | Grupa kontrahentów | (Z)
14. | Opis zdarzenia (nieużywane) | (Z)
15. | Kolumna (nieużywane) | (W)
16. | Vat % | (W: np / zw / 0 / 3 / 4 / 5 / 6 / 7 / 8 / 22 / 23)
17. | Telefon 1 | (Z)
18. | Telefon 2 | (Z)
19. | Telefon 3 | (Z)
20. | Fax | (Z)
21. | E-mail | (Z)
22. | WWW | (Z)
23. | Dane do przelewu 1 | (Z)
24. | Dane do przelewu 2 | (Z)
25. | Konto bankowe | (Z)
26. | Uwagi | (M)
27. | Nazwa i adres do korespondencji | (M)
28. | Waluta | (W PLN/ AFA/ ALL/ DZD/ AON ANG/ SAR/ ARS/ AMD/ AWG AUD/ AZM/ BSD/ BHD/ BDT BBD/ BZD/ BTN/ BYR/ BOB BAM/ BWP/ BRL/ BND/ BGN BIF/ CLP/ CNY/ HRK/ CYP CZK/ DKK/ DOP/ DJF/ EGP ERN/ EEK/ ETB/ FJD/ PHP GMD/ GHC/ GIP/ XCD/ GEL GYD/ GTQ/ GNF/ HTG/ HNL HKD/ INR/ IDR/ IQD/ IRR ISK/ ILS/ JMD/ JPY/ YER JOD/ KHR/ XAF/ CAD/ QAR KZT/ KES/ KGS/ COP/ KMF CDF/ KRW WN/ CRC/ CUP KWD/ LAK/ LSL/ LBP/ LRD LYD/ LTL/ LVL/ MKD/ MGF MOP/ MWK/ MVR/ MYR/ MTL MAD/ MRO/ MUR/ MXN/ MDL MNT/ MZM/ MMK/ NAD/ NPR NGN/ NIO/ NOK/ NZD/ OMR PKR/ PAB/ PGK/ PYG/ PEN XPF/ CVE/ RUB/ ZAR/ RON RWF/ SVC/ WST/ STD/ XOF CSD/ SCR/ SLL/ SGD/ SKK SIT/ SOS/ LKR/ SZL/ SDD SRG/ SYP/ CHF/ SEK/ TJS THB/ TWD/ TZS/ TOP/ TTD TND/ TRL/ TMM/ SLL/ EUR UGX/ UAH/ UYU/ USD/ UZS VUV/ VEB/ HUF/ GBP/ VND)
29. | Konto rozrach. odbiorcy | (Z)
30. | Konto rozrach. dostawcy | (Z)
31. | Domyślne konto - sprzedaż | (Z)
32. | Domyślne konto - zakup | (Z)
33. | Bank Swift | (Z)
34. | Limit kredytu | (K)
35. | Rabat | (K)
36. | E-faktury | (W: Tak / Nie)
37. | Cecha 1 | (Z)
38. | Cecha 2 | (Z)
39. | Język | (W: _ / PL / AT / BE / CY / CZ / DK / EE / FI / FR / EL / ES / NL / IE / LT / LU / LV / MT / DE / IT / PT / SK / SI / SE / HU / GB)
40. | Rolnik ryczałtowy (RR) | (W: Tak / Nie)
41. | RR - Dow. os. nr | (Z)
42. | RR - Data wydania dowodu | (D)
43. | RR - Dow. os. wydany przez | (Z)

*KTG |  | Kategorie
1. | Kategoria | (Z)
2. | Konto Wn | (Z)
3. | Konto Ma | (Z)

*GAS |  | Grupy
1. | Grupa | (Z)
2. | Konto zakupów | (Z)
3. | Konto sprzedaży | (Z)
4. | Kategoria1 | (Z)
5. | Kategoria2 | (Z)
6. | Konto kosztów | (Z)

*PKW |  | PKWiU
1. | Numer | (Z)
2. | Nazwa | (Z)
3. | Vat % | (W: np / zw / 0 / 3 / 4 / 5 / 6 / 7 / 8 / 22 / 23)

*JM |  | Jednostka
1. | Jednostka | (Z)

*A |  | Asortymenty
1. | Indeks | (Z)
2. | Nazwa | (Z)
3. | Stały | (W: Tak / Nie)
4. | Nazwa - Opis | (M)
5. | Rodzaj | (W: towar / produkt / usługa)
6. | Marża indywidualna | (W: Tak / Nie)
7. | Cena nabycia netto | (K)
8. | Cena ewidencyjna | (K)
9. | Cena nabycia brutto | (K)
10. | Kurs | (K)
11. | Ilość | (K)
12. | Ilość na palecie | (K)
13. | Waga (kg) | (K)
14. | Www | (Z)
15. | Indeks1 | (Z)
16. | Indeks2 | (Z)
17. | Tekst dodatkowy | (M)
18. | Konto zakupów | (Z)
19. | Konto sprzedaży | (Z)
20. | Konto kosztów | (Z)
21. | Marża od | (W: ceny nabycia / ceny ewidencyjnej)
22. | Przeliczenia | (W: cena->marża / marża->cena)
23. | Precyzja | (W: 2 / 4)
24. | J.m. | (Z)
25. | Grupa | (Z)
26. | PKWiU | (Z)
27. | SWW (nieużywane) | (Z)
28. | Cena sprzedaży 1 - Netto | (K)
29. | Cena sprzedaży 1 - Brutto | (K)
30. | Cena sprzedaży 1 - Netto wal. | (K)
31. | Cena sprzedaży 1 - Brutto wal. | (K)
32. | Cena sprzedaży 2 - Netto | (K)
33. | Cena sprzedaży 2 - Brutto | (K)
34. | Cena sprzedaży 2 - Netto wal. | (K)
35. | Cena sprzedaży 2 - Brutto wal. | (K)
36. | Cena sprzedaży 3 - Netto | (K)
37. | Cena sprzedaży 3 - Brutto | (K)
38. | Cena sprzedaży 3 - Netto wal. | (K)
39. | Cena sprzedaży 3 - Brutto wal. | (K)
40. | Waluta | (W)


Specyfikacja importu faktur

ZAŁĄCZNIKI

Funkcja Import/Eksport faktur korzysta z pliku XML o określonej strukturze. Struktura ta jest określona za pomocą pliku SCHEMAFAK.XSD w standarcie XML Schema. Plik SCHEMAFAK.XSD umieszczony jest w podfolderze BIN\XSD\Fakt folderu głównego programu R2faktury.

Plik XML składa się z kilku sekcji. W sekcji ParametryTransmisji znajdują się dane informacyjne, takie jak m.in. data i czas wykonania wysyłki danych, firma której dotyczą, osoba dokonująca wysyłki itd. Parametry podane w tej sekcji (tzn. np. BlokujPZ, AsortymentyIdentyfikacja) również mają znaczenie wyłącznie informacyjne i nie są brane pod uwagę podczas odczytu a ich wystąpienie nie jest konieczne. W sekcji Dokument powinny znaleźć się kolejno dane wszystkich przesyłanych dokumenty. Dane te powinny znaleźć się w układzie zgodnym ze strukturą określoną w pliku XSD. Oprócz pól których zawartość i znaczenie jest oczywiste (np. pole DataWystawienia) znajduje się tam kilka pól, które mogą sprawić pewne trudności. Pola te zostały omówione poniżej.

  • DofakturyFak - zazwyczaj pole to powinno pozostać puste. Czasami jednak w tym polu możemy chcieć umieścić oryginalny numer dokumentu, aby zabezpieczyć się przed powtórnym importem tego samego dokumentu. Numer dokumentu po zaimportowaniu może być bowiem w wielu wypadkach inny niż numer oryginalny (np. wtedy, gdy do faktur importujemy dokumenty PZ, albo gdy importu używamy do zamiany zamówień na faktury)

  • X_Nr - zazwyczaj pole to powinno pozostać puste. Program umieszcza w nim (tylko informacyjnie) numer kolejny danego dokumentu w ramach danej definicji numeracji

  • NazwaIAdres - w tym polu należy podać pełną nazwę i adres kontrahenta. Nową linię w takich polach należy oznaczyć ciągiem znaków: małpa-dolar-procent (@$%)

  • Nazwa1 - pole to powinno być wypełnione wyłącznie wtedy, gdy nie chemy, aby dany asortyment został umieszczony podczas odczytu w kartotece asortymentów (mimo zaznaczenia parametru Twórz brakujące asortymenty). Chodzi np. o sytuację, gdy sprzedajemy coś jednarozowego, np. jakąś nietypową usługę. Asortyment ten zostanie umieszczony wtedy tylko na pozycji dokumentu. Uwaga - w sytuacji gdy określimy pole Nazwa1, konieczne jest określenie dla tego asortymentu pól PKWiU i Jm.

  • NazwaPelna - w polu tym należy podać pełną nazwę asortymentu (tylko wtedy, gdy jest ona inna niż podana w polu Nazwa). Nową linię w takich polach należy oznaczyć ciągiem znaków: małpa-dolar-procent (@$%).

PRZYKŁADY.
W rozwikłaniu ewentualnych problemów z przygotowaniem pliku może pomóc przykładowy plik.
Tego typu przykładowe pliki z danymi można łatwo wygenerować samodzielnie. Wystarczy zainstalować wersję demonstracyjną programu, wprowadzić do niej kilka faktur i wykonać polecenie menu głównego Zbiory - Eksport danych - Eksport faktur do programu RESET2 - R2faktury.


Specyfikacja importu PZ

ZAŁĄCZNIKI

Funkcja Import/Eksport PZ korzysta z pliku XML o określonej strukturze. Struktura ta jest określona za pomocą pliku SCHEMAPZ.XSD w standarcie Schema XML. Plik SCHEMAPZ.XSD umieszczony jest w podfolderze BIN\XSD\PZ folderu głównego programu R2faktury.

Plik XML składa się z kilku sekcji. W sekcji ParametryTransmisji znajdują się dane informacyjne, takie jak m.in. data i czas wykonania wysyłki danych, firma której dotyczą, osoba dokonująca wysyłki itd. Parametry podane w tej sekcji (tzn. np. BlokujPZ, AsortymentyIdentyfikacja) również mają znaczenie wyłącznie informacyjne i nie są brane pod uwagę podczas odczytu a ich wystąpienie nie jest konieczne. W sekcji Dokument powinny znaleźć się kolejno dane wszystkich przesyłanych dokumentów. Dane te powinny znaleźć się w układzie zgodnym ze strukturą określoną w pliku XSD. Oprócz pól których zawartość i znaczenie jest oczywiste (np. pole DataWystawienia) znajduje się tam kilka pól, które mogą sprawić pewne trudności. Pola te zostały omówione poniżej.

  • Dofaktury - pole to służy do tego, aby zabezpieczyć się przed powtórnym importem tego samego dokumentu. Należy w nim umieścić oryginalny numer dokumentu, którego dotyczy dany PZ (np. numer otrzymanej od dostawcy faktury zakupu, na podstawie której wpisujemy przychód towaru do magazynu). Jeżeli dokument PZ sam jest dokumentem źródłowym (np. jest dokument PW lub PR+), to w polu tym należy wpisać jego własny numer.

  • X_Nr - zazwyczaj pole to powinno pozostać puste. Program umieszcza w nim (tylko informacyjnie) numer kolejny danego dokumentu w ramach danej definicji numeracji

  • NazwaIAdres - w tym polu należy podać pełną nazwę i adres kontrahenta. Nową linię w takich polach należy oznaczyć ciągiem znaków: małpa-dolar-procent (@$%)

  • Nazwa1 - pole to powinno pozostać puste. Jego obecność w strukturze jest uzasadniona wyłącznie koniecznością zapewnienia zgodności ze strukturą dla Import/Eksport faktur

  • NazwaPelna - w polu tym należy podać pełną nazwę asortymentu (tylko wtedy, gdy jest ona inna niż podana w polu Nazwa). Nową linię w takich polach należy oznaczyć ciągiem znaków: małpa-dolar-procent (@$%).

PRZYKŁADY.
W rozwikłaniu ewentualnych problemów z przygotowaniem pliku może pomóc przykładowy plik.
Tego typu przykładowe pliki z danymi można łatwo wygenerować samodzielnie. Wystarczy zainstalować wersję demonstracyjną programu, wprowadzić do niej kilka PZ i wykonać polecenie menu głównego Zbiory - Eksport danych - Eksport PZ do programu RESET2 - R2faktury.


MODUŁ

MODUŁ WWW

Programy R2fakturyPRO i R2faktury wyposażone są w moduł WWW umożliwiający zdalny dostęp do funkcjonalności systemu poprzez przeglądarkę internetową uruchomioną na dowolnym komputerze/tablecie/smartfonie z dowolnego miejsca na świecie.

W zależności od wersji programu moduł WWW oferuje:

  • wersja PRO - wystawianie faktur, wprowadzanie kontrahentów i asortymentów, ewidencjonowanie płatności oraz przeglądanie rozrachunków i stanów magazynowych, a także drukowanie dokumentów i zestawień. Innymi słowy, funkcjonalność bardzo zbliżoną do tej dostępnej w programie R2fakturyPRO w oknach Faktury, Kontrahenci, Asortymenty, Kasa, Rozrachunki i Stan magazynu.

  • wersja MAXI - przeglądanie danych systemu oraz drukowanie dokumentów i zestawień.

Moduł WWW ma kilka różnych obszarów zastosowań:

  • dla pracowników firmy - stanowi narzędzie do zdalnej (wyjazdowej) pracy w programie R2faktury - bez problemu można wystawić fakturę lub przyjąć płatność i wydrukować stosowne dokumenty będąc w siedzibie klienta

  • dla zarządu firmy - stanowi narzędzie do kontroli sytuacji w firmie z dowolnego miejsca na świecie - wystarczy laptop, tablet lub nawet smartfon z dostępem do internetu, żeby sprawdzić sprzedaż w danym okresie lub stan kasy albo rachunków bankowych

  • dla kontrahentów firmy - umożliwia samodzielny wgląd we własne dane oraz faktury i rozrachunki - wygoda dla kontrahentów oraz odciążenie naszego działu księgowości.

Moduł WWW dostępny jest w wersjach MAXI i PRO.


Instalacja

MODUŁ WWW

Moduł WWW dołączony jest do wersji instalacyjnej programu R2faktury. Podczas instalacji należy wybrać sposób INSTALACJA SZCZEGÓŁOWA i zaznaczyć komponent Moduł WWW - dostęp do programu przez internet. Wymagane pliki pojawią się w podkatalogu WWW.

Pliki te można później pobrać i aktualizować ze strony http://www.reset2.pl/oferta/pro/r2fakturypro/jak-aktualizowac - do pobrania wybieramy Moduł WWW - dostęp do programu przez internet i rozpakowujemy je w podkatalogu WWW (równoległym do podkatalogu BIN).
UWAGA. Zawsze przed aktualizacją modułu WWW należy najpierw zaktualizować sam program R2fakturyPRO/R2faktury.

Moduł WWW musi zostać zainstalowany na komputerze pełniącym rolę serwera WWW. Taki komputer musi być widoczny poza siecią lokalną firmy, tzn. mieć przydzielony publiczny numer IP oraz mieć otwarte odpowiednie porty.

Moduł WWW można uruchomić w trybie:

  1. wolnostojącej aplikacji z wbudowanym serwerem WWW
    Korzystamy z niego przy pierwszych uruchomieniach modułu. Umożliwia łatwą weryfikację prawidłowej konfiguracji systemu. Aby go uruchomić korzystamy z pliku wR2faktury GUI.bat znajdującego się w folderze WWW.

  2. usługi (service) z wbudowanym serwerem WWW
    To jest docelowy tryb pracy modułu WWW. Po sprawdzeniu konfiguracji w opisanym wyżej trybie aplikacji, możemy zainstalować usługę wR2faktury korzystając z pliku wR2faktury SERVICE INSTALL.bat znajdującego się w folderze WWW. Zainstalowanie usługi jest czynnością jednorazową. Przy kolejnych restartach komputera usługa będzie już uruchamiana automatycznie, bez konieczności ingerencji ze strony użytkownika. Ewentualne błędy, które pojawią się w trakcie pracy modułu, zapisywane są do pliku wR2faktury.log. W razie konieczności odinstalowania usługi korzystamy z pliku wR2faktury SERVICE UNINSTALL.bat znajdującego się w folderze WWW.

Aby korzystać z modułu WWW na tym samym komputerze, na którym go zainstalowano, należy w przeglądarce internetowej wpisać adres http://127.0.0.1 lub http://localhost.

Aby korzystać z modułu WWW na zewnątrz firmy, należy w oknie przeglądarki wpisać adres naszego serwera WWW, widoczny z zewnątrz, czyli np. http://80.53.206.100 (adres IP uzyskany od dostawcy internetu) lub http://r2faktury.naszafirma.pl (adres symboliczny posiadany przez naszą firmę).

W przypadku, gdy na komputerze jest już uruchomiony inny serwer WWW (słuchający na standardowym porcie 80), moduł WWW można skonfigurować do pracy na innym porcie. W tym celu w pliku konfiguracyjnym RFaktury.ini (znajdującym się w równoległym do WWW podkatalogu BIN) należy dopisać sekcję [www] z parametrem Port=NowyNumerPortu, przykładowo:
[www]
Port=81
wtedy w przeglądarce należy wpisać adres http://localhost:81 lub http://127.0.0.1:81

Jeśli chcemy łączyć się z modułem WWW połączeniem szyfrowanym (protokół https) należy:

  • w pliku konfiguracyjnym RFaktury.ini w sekcję [www] wyzerować parametr Port i określić odpowiednio parametr SSLPort, przykładowo:
    [www]
    Port=0
    SSLPort=443

  • wgrać do folderu WWW uzyskane od zewnętrznego dostawcy pliki certyfikatów SSL (Cert.pem, Key.pem, Root.pem)

  • uruchomić program R2faktury i wprowadzić hasło klucza prywatnego (menu Ustawienia - Środowisko zakładka Inne).

Moduł WWW testowany był na następujących przeglądarkach:

  • Mozilla Firefox (ver. 35.0 i nowsze)

  • Microsoft Internet Explorer (ver. 10 i nowsze)

  • Google Chrome (ver.40.0 i nowsze).


Konfiguracja

MODUŁ WWW

Przed rozpoczęciem pracy w module WWW należy udostępnić dla tego modułu odpowiednie zasoby programu R2faktury.

Firmy

W celu włączenia dostępu do wybranej firmy, należy w oknie FIRMY zaznaczyć pole Dostęp przez moduł WWW oraz określić:

  • Identyfikator firmy - identyfikator firmy pod którym będzie ona dostępna w module WWW. W przykładzie powyżej, dla wybranej firmy został włączony dostęp zdalny na firmę o nazwie VICTORIA. Tej nazwy należy użyć podczas logowania do modułu WWW.

  • Konfiguracja dla użytkownika typu "kontrahent" - jeżeli z systemu mają korzystać nie tylko użytkownicy, ale rownież kontrahenci wybranej firmy, należy podać nazwę użytkownika, z którego brane będą konfiguracje kolumn w oknach Faktury, Kontrahenci i Rozrachunki. Może to być realny użytkownik systemu R2faktury, jak i stworzony tylko na te potrzeby. W tym drugim przypadku, po założeniu takiego użytkownika, administrator musi się jednorazowo zalogować jako ten użytkownik i skonfigurować widoczność poszczególnych kolumn w wymienionych wcześniej oknach.

    UWAGA. Należy koniecznie sprawdzić czy wybrany tu użytkownik ma włączone tylko takie kolumny, które mogą oglądać kontrahenci. W szczególności chodzi o wyłączenie w oknie Faktury kolumn dotyczących cen nabycia i zysku.

Użytkownicy

Każdy użytkownik, który ma mieć dostęp przez WWW, musi mieć włączoną opcję Może logować się zdalnie w oknie UŻYTKOWNICY (patrz INSTRUKCJA ADMINISTRATORA - PARAMETRYZACJA SYSTEMU - Użytkownicy).

Kontrahenci

Jeżeli z systemu mają korzystać kontrahenci firmy, w oknie KONTRAHENCI, na zakładce Udostępnianie, należy zaznaczyć opcję Dostęp przez WWW oraz zdefiniować Login i Hasło dostępowe (patrz INSTRUKCJA UŻYTKOWNIKA - BIBLIOTEKI - Kontrahenci).

Zestawienia

W zależności od trybu uruchomienia modułu WWW dostępne są w nim różne zestawienia:

  • uruchomienie w trybie użytkownik - dostępne są wszystkie zestawienia zdefiniowane w programie R2faktury w menu Ustawienia - Definicje zestawień, które spełniają obydwa poniższe warunki:

    1. są dostępne w oknach Faktury, Kontrahenci, Asortymenty, Kasa, Stan magazynu, Rozrachunki - patrz zakładka Dostępność

    2. są udostępnione dla danego użytkownika, tzn. że w tabelce Uprawnienia jest wymieniona grupa użytkowników, do której należy ten użytkownik lub nie ma tam wymienionej żadnej grupy, co znaczy że dostęp mają wszyscy użytkownicy

  • uruchomienie w trybie kontrahent - dostępne są wszystkie zestawienia zdefiniowane w programie R2faktury w menu Ustawienia - Definicje zestawień, które spełniają obydwa poniższe warunki:

    1. są dostępne w oknach Faktury i Rozrachunki - patrz zakładka Dostępność

    2. są udostępnione dla grupy Użytkownicy WWW, tzn. że w tabelce Uprawnienia jest wymieniona ta właśnie grupa.

    UWAGA. W wersji Maxi nie można udostępnić kontrahentom żadnych zestawień, gdyż w tej wersji nie można korzystać z tabelki Uprawnienia.


Rozpoczęcie pracy

MODUŁ WWW

Z modułu WWW można korzystać w dowolnej przeglądarce internetowej (np. FireFox, Internet Explorer, Chrome). Po uruchomieniu przeglądarki należy wpisać adres, pod którym jest on dostępny. Może to być np. https://r2faktury.naszafirma.pl (patrz Instalacja).

Po zatwierdzeniu adresu pojawi się w przeglądarce ekran logowania do modułu WWW systemu R2faktury:

Aby zalogować się w systemie podajemy następujące dane:

  • Firma - nazwa firmy (patrz Konfiguracja)

  • tryb pracy systemu:

    • kontrahent - kontrahent firmy (dostęp do własnych danych, faktur i rozrachunków)

    • użytkownik - pracownik firmy (pełna funkcjonalność systemu w wersji PRO lub tylko przeglądanie danych i wydruki w wersji MAXI)

  • Użytkownik

    • w trybie użytkownik: nazwa użytkownika systemu, taka sama jak w programie R2faktury

    • w trybie kontrahent: nazwa pod jaką został temu kontrahentowi włączony dostęp do modułu WWW

  • Hasło

    • w trybie użytkownik: hasło użytkownika systemu, takie samo jak w programie R2faktury

    • w trybie kontrahent: hasło do modułu WWW przydzielone kontrahentowi

  • Zapamiętaj parametry - zaznaczamy w celu zapamiętania nazwy Firmy oraz nazwy Użytkownika. Przy następnym uruchomieniu strony, aplikacja wstawi podane wartości.

  • Przypomnij hasło - system wysyła wiadomość e-mail z przypomnieniem parametrów logowania. Wiadomość jest wysyłana ze skrzynki pocztowej administratora (skonfigurowanej w systemie R2faktury w menu Ustawienia - Środowisko - Internet - SMTP) na:

    • w trybie użytkownik: adres e-mail określony przez tego użytkownika w systemie R2faktury w menu Ustawienia - Środowisko - Internet - SMTP

    • w trybie kontrahent: na adres e-mail określony w danych kontrahenta


Interfejs użytkownika

MODUŁ WWW

Moduł WWW został zaprojektowany tak aby jak najbardziej przypominał właściwy system R2faktury. Ma podobny układ podstawowych elementów ekranu oraz podobny sposób użytkowania. Jednakże ze względu na specyfikę środowiska (przeglądarka internetowa) niektóre elementy różnią się od pierwowzoru.

Powyższy obraz przedstawia ogólny wygląd oraz podstawowe elementy sterujące programem:

  1. Menu główne - pozwala na poruszanie się pomiędzy poszczególnymi oknami programu

  2. Bieżąca data i okres pracy - odpowiednik daty i okresu ustawianych w programie R2faktury

    • Data bieżąca - data z którą będa wystawiane faktury, kp i kw (po edycji daty bieżącej należy nacisnąć klawisz ENTER)

    • Rok, Miesiąc - pozycje wyświetlane w oknach Faktury i Kasa będą pochodziły z określonego tutaj roku i miesiąca

    • Tylko bieżący dzień - dodatkowe pole po prawej stronie pola Data bieżąca - powoduje ustawienie okresu przeglądania równego Dacie bieżącej. Z takiego ustawienia korzystamy przy dużej ilości dokumentów (faktur) wystawianych w programie. Dzięki niemu w oknie faktury będą pokazywane dokumenty tylko z bieżącego dnia. Przyśpieszy to znacznie działanie całego modułu.

    W powyższym przykładzie, ustawiono datę bieżącą na dzień 24-06-2015 (z taką datą będą wystawiane nowe faktury) oraz ustawiono wyświetlanie faktur z czerwca 2015 roku.

  3. Kryteria filtrowania - kryteria filtrowania zawartości okna. Przy pierwszym uruchomieniu okna lista główna danego okna jest pusta. Dane pojawią się dopiero po wybraniu odpowiedniego filtra. Kryteria filtrowania różnią się w każdym oknie. Skrajne prawe pole umożliwia wyszukiwanie [image] dowolnego tekstu i wyświetlenie jedynie tych pozycji które zawierają ten tekst.

    UWAGA. Kryteria filtrowania stanowią główną różnicę pomiędzy sposobem działania modułu WWW i programu R2faktury. W programie domyślnie zawsze pokazywane są jakieś pozycje w danym oknie np. faktury, a kryteria filtrowania F4 służą tam do ograniczania listy pokazywanych pozycji. W module WWW domyślnie każda lista jest pusta, a dane pokazywane są dopiero po określeniu kryteriów filtrowania. Różnica ta spowodowana jest koniecznością zapewnienia jak największej szybkości działania modułu WWW, tak żeby mógł wydajnie działać nawet przy wolnym dostępie do internetu.

  4. Dostępne wydruki - jeżeli wybrane okno (w tym przypadku Kontrahenci) umożliwia wydrukowanie odpowiednich dokumentów, można wybrać stosowny dokument z widocznej tu listy

  5. Edycja - przyciski umożliwiające dopisanie, usunięcie, poprawienie oraz odświeżenie wybranej pozycji

  6. Nazwa bieżącego okna - wskazuje obecnie otwarte okno. Zawartość okna pokazywana jest poniżej nazwy. Po lewej stronie ekranu umieszczona jest lista główna danego okna (w tym przypadku lista kontrahentów) a po prawej szczegóły wybranej pozycji (w tym przypadku szczegółowe dane wybranego kontrahenta). Jak łatwo zauważyć taki układ odpowiada układowi zakładki Razem w programie.

  7. Następna/poprzednia strona - przyciski umożliwiające przejście do następnej lub poprzedniej strony, przydatne gdy główna lista okna zawiera dużo pozycji i ich ilość została podzielona na strony. W danym momencie wyświetlana jest tylko jedna strona.

  8. Szczegóły zaznaczonej pozycji - zakładki prezentujące szczegóły pozycji, na której znajduje się kursor.

UWAGI:

  1. Układ kolumn każdego okna definiowany jest w programie R2faktury. Każdy użytkownik programu bez względu na to czy pracuje w programie czy w module WWW widzi zawsze taki sam układ kolumn. Jeśli w module WWW zalogowany jest kontrahent a nie użytkownik, to widzi on taki układ kolumn jak użytkownik określony w programie w danych firmy na zakładce Udostępnianie.

  2. W przeciwieństwie do programu R2faktury, w module WWW nie ma możliwości dopisywania niektórych informacji na listach wybieralnych poprzez użycie funkcji Biblioteka F2. I tak, np. przed dopisaniem nowej faktury, najpierw należy dopisać nowego kontrahenta (jeżeli nie istnieje lub trzeba go poprawić) i/lub nowy asortyment (jeżeli nie istnieje lub trzeba go poprawić). Jeżeli kontrahent i asortyment są już poprawnie wpisane, nie trzeba korzystać z okien Kontrahenci i Asortymenty.

  3. Kolejne podrozdziały instrukcji nie zawierają szczegółowego opisu sposobu korzystania z modułu WWW. Skupiają się jedynie na różnicach pomiędzy wersją WWW a podstawową wersją programu, której wszystkie możliwości zostały dokładnie opisane w głównej części instrukcji.


Faktury

MODUŁ WWW

Okno Faktury służy do ewidencjonowania sprzedaży w sposób podobny do analogicznego okna w systemie R2faktury. Zawiera większość kontrolek pierwowzoru.

Zawartość głównej listy okna Faktury może być filtrowana wg pól Rodzaj dokumentu oraz Nabywca.

W trakcie wystawiania lub poprawiania faktury warto zwrócić uwagę na następujące elementy:

  1. dopisanie Nabywcy, Odbiorcy oraz Asortymentu - należy podać część nazwy lub NIPu/Indeksu asortymentu oraz nacisnąć klawisz Enter lub skorzystać z funkcji [image] Odśwież. Następnie z listy rozwijalnej należy wybrać odpowiednią pozycję. W przykładnie jak na rysunku, użytkownik wpisał słowo towar w polu Nazwa po czym nacisnął klawisz Enter. Z listy rozwijalnej, na której znajdują się wszystkie asortymenty zawierające w nazwie słowo towar wybrany został towar A o Indeksie 1 i Stanie 24. Wcześniej, podobną metodą wybrał kontrahenta dla tej faktury - Odbiorca A.

  2. edycja danych - przyciski [image], [image] i [image] umożliwiają dopisanie, poprawę lub skasowanie pozycji znajdujących się na poszczególnych zakładkach (na przykładzie powyżej jest to zakładka Pozycje). Po wprowadzeniu zmian korzystamy ze znajdujących się tutaj przycisków OK/Anuluj.

  3. zatwierdzenie/anulowanie - po uzupełnieniu wszystkich danych, całą edytowaną fakturę można zapisać (lub odrzucić)

  4. odświeżanie danych - przyciski [image] służą do bieżącego pobrania nowych danych do listy wybieralnej (np. nazwy asortymentów) lub przeliczenia odpowiednich wartości (np. nastąpiła zmiana ilości asortymentu i użytkownik chce wiedzieć jaka jest całkowita cena brutto). Zamiast korzystania z tych przycisków można każdorazowo zatwierdzać wprowadzone w danym polu zmiany naciskając klawisz Enter.

W obecnej wersji programu nie ma możliwości wystawiania faktur zaliczkowych i końcowych oraz automatycznych faktur do Wz/paragonów.


Kontrahenci

MODUŁ WWW

Okno Kontrahenci praktycznie nie różni się od swojego pierwowzoru z systemu R2faktury.

Wszystkie dane kontrahenta można edytować jak w R2faktury. Rachunki bankowe edytowalne są na swojej zakładce (w R2faktury, edycja odbywa się w osobnym oknie).

Filtrowanie zawartości okna odbywa się po polach Dostawca/Odbiorca/Inny oraz Grupa kontrahentów.


Asortymenty

MODUŁ WWW

Okno Asortymenty praktycznie nie różni się od swojego pierwowzoru z systemu R2faktury.

Wszystkie dane asortymentów można edytować jak w R2faktury.

Filtrowanie zawartości okna odbywa się po następujących kryteriach: Magazyn, Stan, Grupa oraz Rodzaj (czyli towar/produkt/usługa).


Kasa/Bank

MODUŁ WWW

Okno KASA/BANK najbardziej odbiega od swojego oryginału w systemie R2faktury, jednak zawiera wszystkie jego funkcjonalności.

W systemie R2faktury, funkcjonalność odpowiedzialna za sporządzanie raportów kasowych/bankowych podzielona jest na dwie części: nagłówek raportu (okno KASA/BANK) oraz pozycje raportu (okno POZYCJE RAPORTU). W module WWW funkcjonalność obydwu części została umieszczona w jednym, wspólnym oknie KASA/BANK.

Przy dopisywaniu kolejnego raportu, okno nagłówka wygląda następująco:

W celu dopisania pozycji raportu, należy najpierw wybrać rodzaj pozycji (zaznaczanie na zielono na powyższym obrazie). Następnie można już dopisywać poszczególne dokumenty.

Na powyższym obrazku na uwagę zasługują pola służące do:

  1. zatwierdzania/anulowania całego raportu

  2. edycji poszczególnych pozycji raportu

  3. edycji poszczególnych dokumentów.


Stan magazynu

MODUŁ WWW

Okno Stan magazynu, podobnie jak pierwowzór z systemu R2faktury, nie ma możliwości edycji danych, a jedynie wyświetla listę stanów magazynowych.

Posiada możliwość filtrowania wg pól Grupa asortymentowa lub Magazyn oraz umożliwia wybranie pozycji należących do konkretnego Asortymentu.


Rozrachunki

MODUŁ WWW

Okno Rozrachunki, podobnie jak pierwowzór z systemu R2faktury, nie ma możliwości edycji danych, a jedynie wyświetla listę rozrachunków.

Posiada możliwość filtrowania wg pól Zakres lub Kontrahent oraz umożliwia wybranie do przeglądnięcia konkretnego Rozrachunku.


Zestawienia

MODUŁ WWW

W większości okien istnieje możliwość wykonania wydruków, np. faktury. Dostępna lista wydruków znajduje się zawsze po prawej stronie okna w polu oznaczonym [image]. Niektóre z tych wydruków wymagają zawężenia kryteriów wyszukiwania. Po wybraniu takiego wydruku (zestawienia) ukazuje się okno jak poniżej:

Zestawienie Zakup - pozycje dokumentów umożliwia podanie powyższych danych. Jednak nie wszystkie pola muszą być wypełnione. W przykładzie powyżej, użytkownik wybrał asortyment, którego Nazwa zawiera słowo towar. Chciałby także określić konkretny Indeks asortymentowy. W tym celu nacisnął ikonę odświeżenia obok pola Indeks zawiera i ma obecnie dostęp do listy indeksów asortymentowych. Ze względu na dużą ilość asortymentów, lista ta musiała być pobrana z serwera oddzielnie. Inna lista - Nazwa dokumentu zawiera tylko kilka pozycji, dlatego została udostępniona bez konieczności dodatkowego pobierania listy.

Wygenerowanie wydruku następuje po naciśnięciu przycisku Wykonaj.

Także Wydruk listy pozycji zawiera konieczność podania parametrów początkowych, tj. Tytuł wydruku, określenia czy mają być drukowane Ramki w tabelce oraz czy ma być dodrukowana Bieżąca data.


INSTALOWANIE PROGRAMU

Rozdział jest poświęcony czynnościom związanym z zainstalowaniem i uruchomieniem programu. Dowiemy się w nim:

  • jak zainstalować program [image] - w zależności od potrzeb i zakupionej wersji programu mamy dwie możliwości:

    • instalacja wersji jednostanowiskowej - jeśli zamierzamy pracować na jednym komputerze
    • instalacja wersji sieciowej - jeśli chcemy pracować w tym samym czasie na wielu komputerach połączonych w sieć lub na różnych komputerach połączonych w sieć, ale tylko na jednym z nich jednocześnie

  • jakie czynności wykonać przy pierwszym uruchomieniu programu

  • jak do wersji demonstracyjnej (bo taka właśnie się zawsze instaluje) wczytać licencję z naszymi danymi, potwierdzającą, że jesteśmy legalnym użytkownikiem programu oraz co oznaczają poszczególne informacje, które zawiera licencja

  • jak sprawdzić numer i datę wydania posiadanej wersji programu i jak zaktualizować program do najnowszej wersji

  • jak dokonać konwersji danych z wcześniejszej wersji programu [image] lub z innych systemów


Wersja jednostanowiskowa

INSTALOWANIE PROGRAMU

Poniższy opis dotyczy instalacji wersji jednostanowiskowej, tzn. takiej, która będzie uruchamiana tylko na jednym komputerze. Jeśli chcemy korzystać z programu na kilku komputerach połączonych w sieć, należy zapoznać się z opisem instalacji wersji sieciowej.

Przed zainstalowaniem programu należy zapoznać się z jego wymaganiami systemowymi.

Aby zainstalować program:

  • Upewnić się czy na twardym dysku jest przynajmniej 64MB wolnego miejsca (64MB jest potrzebne dla programu, ale w praktyce wolnego miejsca na dysku powinno być o wiele więcej, gdyż Windows potrzebuje miejsca na tymczasowe pliki systemowe).

  • Włożyć firmową płytę z wersjami demonstracyjnymi do napędu CD-ROM, po chwili na ekranie powinien się pojawić obrazek z firmową płytą.
    UWAGA. Jeśli obraz płyty się nie ukaże, należy samodzielnie uruchomić program INSTALUJ.EXE (znajdujący się w katalogu głównym CD-ROM) klikając:
    Start - Uruchom… - w pozycji Otwórz wpisać:
    D:\Instaluj
    i nacisnąć OK (Enter). Uruchomi się program instalacyjny.

  • Na pierwszym ekranie klikamy w pozycję [image] .

  • Standardowo program R2faktury instaluje się w katalogu C:\Program Files\Reset2\Faktury.XXX (gdzie XXX to numer wersji). Jeśli chcemy podać inny katalog, należy w oknie Sposób instalacji wybrać Instalacja szczegółowa i na kolejnym ekranie określić katalog (folder), w którym ma zostać zainstalowany program (przycisk Dalej kontynuuje instalację).

Aby uruchomić program należy kliknąć:
Start - Programy - RESET2 – R2faktury - R2faktury w.6.0x (numer wersji może być inny)


Wersja sieciowa

INSTALOWANIE PROGRAMU

Poniższy opis dotyczy instalacji sieciowej i ma sens jeśli:

  • testujemy wersję demonstracyjną i zamierzamy w przyszłości nabyć wersję sieciową,

  • posiadamy wersję sieciową programu i chcemy z niego korzystać jednocześnie na wielu komputerach połączonych w sieć,

  • posiadamy wersję jednostanowiskową programu i chcemy z niego korzystać na różnych komputerach połączonych w sieć, ale tylko na jednym z nich jednocześnie.

W innych przypadkach należy zapoznać się z opisem instalacji wersji jednostanowiskowej.

Aby zainstalować sieciowo program:

  1. Ustalamy, który komputer będzie pracował jako główny, tzn. taki, na którym będą przechowywane dane naszego programu. Nazwiemy ten komputer umownie serwerem.

  2. Instalujemy program [image] na serwerze (instalacja standardowa wersji jednostanowiskowej, jeśli zamiast standardowej wybierzemy Instalację szczegółową to w oknie Zaznacz składniki należy wybrać Pełna instalacja).

  3. Dysk (lub folder), na którym został zainstalowany program [image] (standardowo C:), udostępniamy innym komputerom.

  4. Na pozostałych komputerach (nazwiemy je umownie końcówkami) instalujemy w sposób następujący:

    • w oknie Sposób instalacji wybieramy Instalacja szczegółowa

    • w oknie Zaznacz składniki wybieramy Instalacja sieciowa na końcówce

      • (zaznaczony zostanie tylko moduł Borland Database Engine - biblioteki obsługi baz danych)

  5. Na końcówkach tworzymy skróty do pliku RFAKTURY.EXE znajdującego się na dysku serwera w katalogu C:\Program Files\Reset2\Faktury.60x\BIN (lub w innym, jeśli zmieniliśmy katalog w trakcie instalacji lub wgrywamy inną wersję niż 6.0x).

  6. Uruchamiamy program z dowolnej końcówki i w pozycji menu głównego Zbiory-Narzędzia-Zmiana bazy danych zmieniamy katalog bazy danych na taki, który zawiera symboliczną nazwę serwera, na przykład jeśli:

    • katalog, w którym program został zainstalowany na serwerze to C:\Program Files\Reset2\Faktury.60x

    • serwer nazwaliśmy symbolicznie SERWER (w momencie konfigurowania serwera do pracy w sieci)

    • dysk C: serwera został udostępniony jako Dysk_C
      to katalog bazy danych zmieniamy na:
      \\SERWER\Dysk_c\Program Files\Reset2\Faktury.60x

  7. Korzystając z pozycji menu głównego Zbiory-Wybór użytkownika tworzymy użytkowników, którzy będą mieli dostęp do programu

To wszystko. Możemy przystąpić do normalnej pracy. W przyszłości, jeśli będziemy wgrywać jakieś nowe wersje programu [image] , wgrywamy je tylko na dysku serwera.

Należy pamiętać o tym, że program i dane wgrane są na dysk serwera, w związku z czym jeśli serwer nie będzie uruchomiony końcówki nie będą mogły korzystać z programu.

Jeśli przy próbie wejścia do programu pojawi się komunikat Użytkownik zablokowany oznacza to, że program uważa, że taki użytkownik pracuje aktualnie w programie. Jeśli tak nie jest (np. zabrakło zasilania i komputer się zresetował) należy wejść do programu jako Administrator (w skrócie Admin) i w oknie z użytkownikami odłączyć zablokowanego użytkownika.


Licencja

INSTALOWANIE PROGRAMU

Po wczytaniu licencji na ekranie pojawi się okno z warunkami licencji. Należy je dokładnie przeczytać i zaakceptować lub nie. Dalsza praca programu możliwa jest po zaakceptowaniu warunków licencji i oznacza, że warunki te zostały przyjęte. W przypadku korzystania z programu w wersji demonstracyjnej również wymagane jest zapoznanie się z warunkami licencji dla tej wersji. Dodatkowo w licencji wersji demonstracyjnej możemy klikając w przycisk Konfiguracja określić konfigurację programu (Mini, Standard, Maxi, Extra, magazyn, transakcje zagraniczne, liczbę użytkowników itp.). Dzięki temu będziemy mieli pewność, że po zakupie programu otrzymamy dokładnie taką wersję jak ta, którą testowaliśmy.

Warunki licencji można przejrzeć w dowolnym momencie pracy z programem korzystając z polecenia menu w okienku głównym programu Pomoc - Licencja. Tam również można w każdej chwili zmienić konfigurację wersji demonstracyjnej (przycisk Konfiguracja), jeśli stwierdzimy, że konfiguracja wybrana przy pierwszym uruchomieniu programu nie odpowiada naszym potrzebom.

Nad umową licencyjną odczytać możemy dane tego konkretnego egzemplarza programu:

  • Licencjobiorca - dane nabywcy

  • Nr seryjny - numer seryjny nadany przez producenta temu egzemplarzowi programu

  • Abonament ważny do - do tej daty można bezpłatnie aktualizować program (patrz: Aktualizacja programu)

  • Konfiguracja - informacja o zakupionej wersji konfiguracji (wersja jednostanowiskowa, sieciowa, wersja dla biura rachunkowego...)


O programie

INSTALOWANIE PROGRAMU

Po uruchomieniu programu możemy w każdej chwili odczytać podstawowe informacje o programie. W tym celu w menu głównym wybieramy Pomoc - O programie.

Odczytujemy:

  • nazwa programu

  • wersja nr, z dnia - numer i data powstania tej wersji programu

  • nazwa i adres producenta

  • adres strony internetowej i poczty elektronicznej producenta

  • aktualizacja - dokładny numer i data ostatniej aktualizacji programu


Aktualizacja programu

INSTALOWANIE PROGRAMU

Program [image] objęty jest 12 miesięcznym abonamentem na uaktualnienia. Datę ważności posiadanego abonamentu można sprawdzić w menu głównym Pomoc-Licencja w polu Abonament ważny do. Wszystkie nowe wersje programu, opublikowane w serwisie internetowym producenta z datą nie większą niż data ważności abonamentu, można samodzielnie pobrać na swój komputer.

Istnieją dwa rodzaje aktualizacji programu i związane z nimi dwa sposoby pobierania:

  1. aktualizacje zawierające drobne ulepszenia i poprawki:
    Takie aktualizacje pojawiają się stosunkowo często (przynajmniej raz w miesiącu) i możemy je pobierać bezpośrednio z programu. Poleceniem menu głównego Zbiory - Narzędzia - Aktualizacja programu wywołamy okienko (takie jak obok), z którego wybieramy następujące funkcje:

    • Pobierz - po kliknięciu w ten przycisk pojawi się okienko Pobieranie aktualizacji zawierające szczegółowe informacje o dostępnych aktualizacjach programu i jego instrukcji obsługi (pomocy kontekstowej). Aktualizację programu możemy pobrać tylko wtedy, gdy data jej wydania mieści się w okresie ważności naszego abonamentu. Klikając w przycisk Pobierz pobierzemy wybrane aktualizacje z internetu na nasz komputer.

    • Aktualizuj program i pomoc - pobrana aktualizacja zostanie rozpakowana i zastąpi nasz aktualny program. Po zamknięciu programu i ponownym uruchomieniu, uruchomi się już zaktualizowany program.

    UWAGI:

    1. Jeśli przy próbie pobrania aktualizacji programu pojawiają się błędy, należy sprawdzić konfigurację połączenia internetowego.

    2. Aktualizację można pobrać w powyższy sposób tylko wtedy, jeśli komputer, na którym jest uruchomiony program ma połączenie z internetem. Jeśli nie ma połączenia, to możemy na dowolnym innym komputerze posiadającym takie połączenie otworzyć stronę www.reset2.pl/oferta/standard/r2faktury/jak-aktualizowac i zgodnie z opisem pobrać plik UPDATE.EXE. Plik ten należy przenieść na komputer, na którym jest zainstalowany program R2faktury, wgrać do podkatalogu BIN katalogu bazy danych i uruchomić. Wcześniej należy wyłączyć program R2faktury.

    3. Jeśli korzystamy z wersji sieciowej programu, aktualizację możemy pobrać z dowolnej końcówki, pod warunkiem, że w czasie pobierania żaden inny użytkownik nie pracuje w programie.

    4. W opisany tu sposób możemy pobierać takie nowe wersje programu, których numer jest zgodny na pierwszych dwóch cyfrach z numerem naszej bieżącej wersji programu (Pomoc - O programie - Aktualizacja), czyli np. mamy wersję 6.00.15 i pobieramy 6.00.20, 6.01.0 lub 6.01.5. W momencie gdy ukaże się wersja np. 6.10.0 lub nowsza w okienku z opisem aktualizacji pojawi sie stosowna informacja i będziemy musieli skorzystać z drugiego, opisanego dalej, sposobu aktualizacji.

  2. nowe wersje programu związane z większymi zmianami
    Takie aktualizacje pojawiają się stosunkowo rzadko (mniej więcej raz na rok). Mają one zmienioną pierwszą lub drugą cyfrę numeru wersji i publikowane są na stronie internetowej producenta. Aby zainstalować taką aktualizację należy postępować zgodnie z opisem zamieszczonym w internecie na stronie http://www.reset2.pl/oferta/standard/r2faktury/jak-aktualizowac. Po zainstalowaniu nowej wersji programu będziemy mieli w komputerze dwa programy np.: R2faktury w.6.0x (dotychczasowy) i R2faktury w.7.0x (nowy). Nowy program będzie wersją demonstracyjną bez żadnych danych. Dane i licencję należy wczytać z dotychczasowej wersji programu - patrz: Konwersja danych z wcześniejszej wersji.

    3. UWAGI:

    1. Po upewnieniu się, że nowa wersja programu zawiera wszystkie nasze dotychczasowe dane i pracuje prawidłowo, możemy starą wersję usunąć z komputera, żeby nie zajmowała niepotrzebnie miejsca na dysku. Przed usunięciem starego programu należy na wszelki wypadek wykonać w nim archiwizację danych i zachować plik archiwum w bezpiecznym miejscu.
    2. Jeśli korzystamy z wersji sieciowej programu, aktualizację wykonujemy na serwerze lub z dowolnej końcówki, ale na dysku serwera.
    3. Jeśli instalujemy w ten sposób wersję programu, której numer jest zgodny z numerem naszego dotychczasowego programu na pierwszej cyfrze, to w przypadku nieważnego abonamentu, zaktualizowany program będzie miał zablokowane wydruki i eksport danych.

W przypadku, gdy data ważności abonamentu jest już nieaktualna, należy skontaktować się z dystrybutorem lub producentem w celu przedłużenia abonamentu na kolejne 12-miesięcy. Po otrzymaniu płyty CD-ROM lub klucza z licencją zawierającą przedłużoną datę abonamentu wczytujemy nową licencję do dotychczasowego programu - patrz: Wczytanie licencji. Posiadając ważny już abonament możemy przystąpić do zaktualizowania programu.

Aktualizację programu należy wykonywać regularnie w trakcie pracy z programem. Najlepszym rozwiązaniem jest zautomatyzowanie tej czynności poprzez ustawienie w menu Ustawienia - Środowisko - Internet parametru Sprawdzaj automatycznie czy jest dostępna nowa wersja. Po włączeniu tego parametru program będzie sprawdzał przy pierwszym uruchomieniu każdego dnia czy jest dostępna aktualizacja programu.


Konwersja danych z wcześniejszej wersji

INSTALOWANIE PROGRAMU

Jeśli aktualizujemy program wersją demonstracyjną i numer tej wersji różni się od numeru dotychczasowej wersji na pierwszych dwóch cyfrach, to po uruchomieniu nowej wersji pokaże nam się "czysty" program, bez naszej licencji i wprowadzonych do tej pory danych. Po uruchomieniu funkcji menu głównego Zbiory - Narzędzia - Konwersja danych z wcześniejszej wersji licencja i dotychczasowe dane pojawią się w programie.

W okienku Konwerter program będzie nas prowadził przez proces konwersji i w pewnym momencie zapyta o katalog z danymi źródłowymi, czyli o miejsce instalacji poprzedniej wersji. Domyślnie program podpowie standardowy folder instalacyjny poprzedniej wersji programu. Jeśli zainstalowaliśmy dotychczasową wersję do innego katalogu niż standardowy, to musimy go wskazać klikając [image] albo program zrobi to za nas po wybraniu funkcji Wyszukaj. W przypadku problemów ze zlokalizowaniem dotychczasowej bazy danych możemy ją odczytać, wywołując w poprzedniej wersji programu funkcję Zmiana bazy danych (w menu Zbiory - Narzędzia).


Konwersja danych z programów TURBO... dla DOS

INSTALOWANIE PROGRAMU

Jeśli dotychczas korzystaliśmy z systemów RESET2 serii TURBO... dla DOS, np.: TurboFirma, TurboSprzedaż, TurboFaktury lub TurboKasa, możemy po instalacji programu dokonać konwersji danych z tych programów. Konwersja dotyczy tylko biblioteki kontrahentów i asortymentów oraz w przypadku Turbo Sprzedaży ewidencji stanów magazynowych, która jest przenoszona jako bilans otwarcia.

UWAGA. Jeżeli zamierzamy konwertować stany magazynowe, należy przed uruchomieniem konwertera odpowiednio ustawić wartość parametru Precyzja (dane bieżącej firmy [image] zakładka Ustawienia - Ogólne parametr Precyzja). Powinien on odpowiadać liczbie literek G wpisanych w TurboSprzedaży w menu F9 Opcje - Środowisko - Układ ilości.

Konwerter danych uruchamia się poleceniem menu głównego Zbiory - Narzędzia - Konwersja danych z programów TURBO... dla DOS.

Klikając w przycisk Dalej >>, na kolejnych ekranach konwertera:

  1. wybieramy rodzaj posiadanego programu

  2. wskazujemy folder (katalog) zawierający dane. Jeżeli nie jesteśmy pewni jaki to folder, możemy skorzystać z automatycznego wyszukania odpowiednich danych (przycisk Wyszukaj)

  3. rozpoczynamy konwersję klikając w przycisk Start

Po wykonaniu konwersji, przed rozpoczęciem normalnej pracy, wskazane jest:

  • wykonanie weryfikacji bazy danych (poleceniem menu głównego Zbiory - Narzędzia - Weryfikacja bazy danych) z zaznaczoną opcją Odbudowa powiązań relacyjnych. Zabezpieczy nas to przed ewentualnym późniejszym przypadkowym usunięciem asortymentów lub magazynów wykorzystanych na bilansie otwarcia.

  • wykonanie w oknie z asortymentami funkcji menu podręcznego (prawy klawisz myszy) Dodatkowe funkcje - Aktualizuj stany magazynowe dla wszystkich magazynów dostępnych w bibliotece magazynów. Tzn.: ustawiamy magazyn we [image] F4 właściwościach okna w polu Filtr - Magazyn, wykonujemy funkcję Aktualizuj stany magazynowe, zmieniamy we właściwościach magazyn na kolejny z listy, ponownie wykonujemy Aktualizuj... i tak dla wszystkich magazynów.

  • wykonanie w oknie z asortymentami funkcji menu podręcznego (prawy klawisz myszy) Dodatkowe funkcje - Aktualizuj ceny sprzedaży


Pierwsze uruchomienie programu

INSTALOWANIE PROGRAMU

Podczas pierwszego uruchomienia po zainstalowaniu program zaproponuje wykonanie trzech dodatkowych czynności:

  1. wczytanie licencji - patrz rozdział Wczytanie licencji

  2. pobranie z internetu najnowszej aktualizacji programu. Należy taką aktualizację bezwzględnie pobrać, gdyż tylko dzięki temu będziemy mieli pewność, że pracujemy na najnowszej wersji programu zgodnej z aktualnymi przepisami i pozbawionej ewentualnych usterek wykrytych od czasu powstania wersji instalacyjnej programu.

Aktualizację programu należy wykonywać regularnie w trakcie pracy z programem. Najlepszym rozwiązaniem jest zautomatyzowanie tej czynności poprzez ustawienie w menu Ustawienia - Środowisko - Internet parametru Sprawdzaj automatycznie czy jest dostępna nowa wersja. Po włączeniu tego parametru program będzie sprawdzał przy pierwszym uruchomieniu każdego dnia czy jest dostępna aktualizacja programu.


< Miejscowości >

Biblioteki ogólne

Biblioteka miejscowości zawiera listę wszystkich miejscowości w Polsce. Służy ona wyłącznie do celów pomocniczych, dzięki niej przy uzupełnianiu adresu firmy lub właściciela automatycznie wypełnią się w adresie pola Gmina, Powiat i Województwo.

Biblioteka miejscowości przygotowana jest przez producenta programu. Jeśli w bibliotece brakuje jakiejś miejscowości, należy przy wprowadzaniu adresu podać ją ręcznie.

W wykazie miejscowości znajdują się następujące dane:

  • Miejscowość

  • Gmina

  • Kod gminy - według GUS

  • Powiat

  • Województwo


< Przygotowanie bibliotek >

FAKTURY I INNE DOKUMENTY

Wstępne przygotowanie bibliotek przyspieszy nam wystawianie faktur. Raz wprowadzone pozycje istnieją na liście, z której są później już tylko wybierane. Nic jednak nie stoi na przeszkodzie, żeby uzupełniać podane biblioteki bezpośrednio podczas sporządzania dokumentów.

Do bibliotek związanych z fakturami należą:

  • Kontrahenci

  • Asortymenty

  • Uwagi

Biblioteki te rządzą się tymi samymi prawami, co biblioteki ogólne, czyli wszystkie funkcje działają w podobny sposób.


Obroty

BIBLIOTEKI - Asortymenty

Okno OBROTY pokazuje historię operacji (przyjęć, wydań i przesunięć) wykonanych na wybranym asortymencie. Służy do wyjaśniania ewentualnych wątpliwości związanych ze stanem bieżącym asortymentu.

Kolumna Ile pokazuje ilość przyjętą, wydaną lub przesuniętą na danym dokumencie. Przyjęcia do magazynu mają znak dodatni (PZ, faktury korygujące ilość na mniejszą). Wydania z magazynu mają znak ujemny (faktury, WZ, RW, PZ korygujące ilość na mniejszą). Przesunięcia międzymagazynowe mają znak dodatni jeśli przesuwamy na wybrany magazyn i ujemny jeśli przesuwamy z wybranego magazynu na jakiś inny.

Kolumna Stan pokazuje stan magazynu po wykonaniu każdej operacji. Stan po wykonaniu ostatniej operacji powinien się zgadzać z sumą z kolumny Ile pokazaną w polu Ilość w dolnej części okna.

Kolumny z cenami i wartościami zawierają:

  • w przypadku dokumentów PZ, MM i RW - ceny i wartości netto nabycia
  • w przypadku faktur i WZ - ceny i wartości netto sprzedaży.

W związku z tym sumy wartości Netto, Vat i Brutto pokazane w dolnej części okna należy traktować odpowiednio jako zysk lub stratę uzyskaną ze sprzedaży tego asortymentu. Zysk, jeśli kwoty mają znak ujemny, bo to znaczy, że wartość sprzedaży przewyższa wartość zakupu. Stratę, jeśli kwoty mają znak dodatni, bo to znaczy, że więcej wydaliśmy na zakup niż uzyskaliśmy ze sprzedaży. Pojęcia zysku lub straty mają sens tylko wtedy, jeśli sprzedaliśmy już cały towar.

Trochę inaczej zachowuje się kolumna _C.netto. Zawiera ona:

  • w przypadku dokumentów PZ, MM, RW i WZ - cenę nabycia
  • w przypadku faktur - cenę sprzedaży przed ewentualnym rabatem.

Jeśli chcemy zmienić zakres operacji pokazywanych w oknie, możemy określić odpowiednio właściwości okna [image] F4:

  • PZ - zaznaczamy jeśli chcemy zobaczyć przyjęcia magazynowe, dodatkowo możemy określić jakie dokumenty przyjęć mają być uwzględniane: Zakup (te które dotyczą faktycznych przyjęć z pominięciem np. zamówień) oraz Dokument (konkretny rodzaj dokumentu)

  • Faktury/WZ - zaznaczamy jeśli chcemy zobaczyć sprzedaż i wydania z magazynu. W polu Pozycje określamy czy interesują nas pozycje z faktur i innych dokumentów sprzedaży, czy też z WZ związanych z fakturami (lub nie). Jeśli zależy nam na kontroli stanów magazynowych należy wybrać WZ, gdyż nie zawsze występowanie danego asortymentu na pozycji faktury oznacza jego wydanie z magazynu (np. faktura może mieć wyłączony automatyczny WZ). Dodatkowo możemy określić jakie dokumenty mają być uwzględniane: Sprzedaż (te które dotyczą faktycznej sprzedaży z pominięciem np. WZ oraz zamówień) oraz Dokument (konkretny rodzaj dokumentu)

  • MM - zaznaczamy jeśli chcemy zobaczyć przesunięcia międzymagazynowe

  • Tylko własne - dotyczy dokumentów wystawionych ze współdzielonych definicji, w oknie będą dostępne tylko te, które wystawił aktualny użytkownik programu. W zależności od uprawnień nadanych użytkownikowi (pole Tylko własne dokumenty w uprawnieniach grupy użytkowników) będzie on mógł zmienić wartość tego parametru i przeglądać również współdzielone dokumenty wystawione przez innych użytkowników.

  • Magazyn - historia operacji będzie dotyczyć tylko tego magazynu. Podstawia się automatycznie na taki magazyn jaki wybrano we właściwościach [image] F4 okna Asortymenty. Jeśli wybraliśmy jakiś magazyn, ale chcemy ponownie zobaczyć operacje dotyczące wszystkich magazynów naciskamy klawisz Del lub Backspace.

  • Nr dost. - możemy sprawdzić przychód i rozchody wybranej dostawy

  • Kontrahent - tylko operacje dotyczące tego kontrahenta.

  • Data wystawienia - tylko dokumenty wystawione w wybranym okresie

  • Selekcja - jeśli podświetliliśmy wybrane pozycje, to możemy zobaczyć tylko te podświetlone

  • Uporządkowanie - pokazuje czy pozycje są uporządkowane w sposób domyślny Data wyst./Kolejn.pozycji (tylko przy tym uporządkowaniu kolumna Stan zawiera sensowne wartości) lub wg wybranej kolumny (aby uporządkować wg jakiejś kolumny należy kliknąć w jej nagłówek).

Historię operacji możemy wydrukować korzystając z pozycji dostępnej w menu wydruków [image] F2 Wydruk listy - zostanie wydrukowana zawartość okna.


Parametry systemu

PARAMETRYZACJA SYSTEMU

Instrukcja administratora

Ustawienia konfiguracyjne możemy podzielić na kilka grup.

Pierwsza z nich obejmuje podstawowe parametry określające konfigurację poszczególnych modułów programu. W większości znajdują się one w oknie [image] FIRMY na zakładce Ustawienia, a szczegółowo opisane są w rozdziałach dotyczących konfiguracji poszczególnych modułów, tzn.:

  • MAGAZYN - Konfiguracja

  • SPRZEDAŻ - Konfiguracja

  • KASA/BANK - Konfiguracja

  • NALEŻNOŚCI I ZOBOWIĄZANIA - Konfiguracja

Pozostałe parametry zgrupowane są w menu głównym w pozycji Ustawienia:

  • Definicje dokumentów - definicje dokumentów używanych w programie (PZ, faktura VAT, rachunek, MM, WZ, RK itp.) - patrz rozdział DEFINICJE DOKUMENTÓW

  • Makiety dokumentów - modyfikowalne wzory dokumentów drukowanych z programu

  • Języki - tłumaczenia faktur i dokumentów windykacyjnych na języki obce

  • Waluty - waluty wraz z ewidencją średnich kursów NBP

  • Odsetki - parametry związane z naliczaniem odsetek

  • Środowisko - parametry związane z samym działaniem programu

  • Konfiguracja - ustawienia związane z poszczególnymi oknami (Faktury, Kontrahenci, itp.)

  • Konfiguracja przelewów - parametry wydruku bankowych poleceń przelewów

  • Restrykcje - parametry związane z restrykcjami w obrotach z nierzetelnymi kontrahentami - patrz rozdział NALEŻNOŚCI I ZOBOWIĄZANIA - Restrykcje w obrotach

  • Formy płatności - parametry związane z formami płatności

  • Urządzenia fiskalne - konfiguracja drukarek i kas fiskalnych - patrz rozdział SPRZEDAŻ - Urządzenia fiskalne

Ważną funkcją jest ustawienie bieżącej daty (niezależnie od ustawienia w systemie operacyjnym) oraz okresu pracy w programie (F12), a także zmiana hasła wejścia do programu.

Dodatkowo korzystając z menu Ustawienia możemy funkcją Domyślne konfiguracje okien przywrócić standardowe ułożenie oraz właściwości wszystkich okien, a funkcją Zamknij wszystkie okna zamknąć wszystkie otwarte okna programu.


< Definicje dokumentów >

PARAMETRY SYSTEMU

Definicje dokumentów, z których będziemy korzystać w programie - patrz: FAKTURY I INNE DOKUMENTY - Rodzaje dokumentów.


Baza danych

BEZPIECZEŃSTWO DANYCH

Fizyczną lokalizację bazy danych możemy odczytać w pozycji menu Zbiory - Narzędzia - Zmiana bazy danych.

Katalog bazy danych podzielony jest na podkatalogi, które zawierają:

  • BIN - pliki z aplikacją, konfiguracją systemu, dane podstawowe (firmy, użytkownicy), globalne biblioteki (banki, urzędy skarbowe), makiety dokumentów

  • DANE.1 - dane dotyczące pierwszej firmy, czyli PZ, MM, faktury, kontrahenci, asortymenty i wszystkie lokalne biblioteki

  • DANE.X - dane kolejnych firm

  • DB

    • - pliki nagłówkowe danych, służące do weryfikacji i konwersji danych

  • DEF1 - dane początkowe, wykorzystywane przy pierwszym uruchomieniu programu i przy tworzeniu nowej firmy

  • IMAGES - część rysunków i tekstów używanych przez program

  • PREFILES - predefiniowane biblioteki banków i urzędów skarbowych

  • TEMP - tymczasowe dane operacyjne, tworzone i usuwane podczas wykonywania niektórych operacji

Katalog bazy danych jest istotny podczas konwersji danych z wcześniejszych wersji. Jeśli po wgraniu nowej wersji nie potrafimy zlokalizować dotychczasowych danych, możemy w poprzedniej wersji wywołać tę funkcję i zapamiętać dotychczasową lokalizację, potrzebną do konwersji danych do nowej wersji.

UWAGA. Lokalizację (folder, katalog) bazy danych możemy w szczególnych wypadkach zmieniać. Nie jest to jednak zalecane i służy tylko do celów serwisowych, dlatego wszelkie zmiany wykonujemy na własną odpowiedzialność.

W szczególnych przypadkach możemy również utworzyć nową bazę danych. Służy do tego pozycja menu głównego Zbiory - Narzędzia - Nowa baza danych.


Weryfikacja bazy danych

BEZPIECZEŃSTWO DANYCH

Przy kłopotach z danymi związanymi z nieoczekiwanymi błędami pokazującymi się zwykle w trakcie otwierania programu lub otwierania poszczególnych okien w pierwszej kolejności powinniśmy wywołać funkcję Weryfikacja bazy danych z pozycji menu Zbiory - Narzędzia. Funkcja ta potrafi odbudować nagłówki plików bazy danych, odtworzyć zbiory indeksowe oraz odbudować powiązania pomiędzy poszczególnymi plikami danych.

Przed rozpoczęciem weryfikacji ustawiamy:

  • Rodzaj danych - jakie dane chcemy zweryfikować

    • Ogólne - globalne dane programu

    • Aktualna firma - dane wybranej firmy

    • Wszystkie firmy - dane wszystkich firm

  • Zakres weryfikacji - co chcemy zweryfikować

    • Weryfikacja struktury plików i indeksów - aktualizowane są nagłówki plików na podstawie nagłówków wzorcowych (znajdujących się w podkatalogu DB)

    • Odbudowa powiązań relacyjnych - aktualizowana jest informacja o ilości odwołań jednych rekordów do drugich (dzięki czemu nie możemy np. usunąć z biblioteki asortymentu wykorzystanego na jakiejkolwiek fakturze)

    • Zabezpiecz bazę danych hasłem - dane wprowadzone do programu są pamiętane w plikach o odpowiedniej strukturze w katalogu bazy danych; jeśli chcemy zabezpieczyć się przed możliwością przeglądania tych plików przez osoby niepowołane możemy zabezpieczyć dostęp do nich przez założenie niejawnego hasła; każda próba otwarcia tych plików za pomocą różnych zewnętrznych programów będzie wymagała podania tego hasła; należy sobie zdawać sprawę, że w ten sposób jedynie utrudniamy dostęp do tych plików, gdyż istnieją mechanizmy złamania istniejącego hasła;
      jeśli zdecydujemy się na takie zabezpieczenie bazy danych, to należy pamiętać o włączaniu tego parametru przy każdej kolejnej weryfikacji, w przeciwnym wypadku weryfikacja spowoduje usunięcie założonego wcześniej hasła.


Kodowanie danych

BEZPIECZEŃSTWO DANYCH - Serwisowanie danych

Z funkcji tej korzystamy tylko wtedy, gdy nie możemy przekazać danych do serwisu za pomocą funkcji Wysyłanie danych do serwisu, na przykład dlatego, że nie mamy z tego komputera dostępu do internetu. W takim wypadku zakodowane kopie danych możemy przekazać do serwisu e-mailem lub pocztą na jakimś nośniku (CD-ROM, dyskietki).

Po wywołaniu funkcji Kodowanie danych (z menu Zbiory - Narzędzia - Serwisowanie danych) program utworzy zakodowane kopie danych. Kodowanie przebiega w dwóch etapach:

  • Dane ogólne - kodowane są globalne dane programu, czyli lista użytkowników, lista firm i wspólne biblioteki

  • Aktualna firma - kodowane są dane dotyczące wybranej firmy, czyli faktury, kontrahenci, asortymenty i inne lokalne biblioteki

Przy tworzeniu zakodowanych kopii danych na dyskietki wybieramy A:\ lub B:\, przy kopiowaniu na dysk twardy wybieramy katalog docelowy (np. C:\SERWIS), podany katalog musi być wcześniej utworzony.

Standardowo przy kodowaniu danych ogólnych tworzy się plik BIN.APK, a przy kodowaniu danych aktualnej firmy DANE1.APK (lub DaneX.apk dla firmy o numerze X).

UWAGA. Odkodowanie zakodowanych kopii danych jest możliwe tylko w powiązaniu z pełnymi danymi. Odkodowanie w inny sposób jest absolutnie niemożliwe. Wynika z tego, że po wczytaniu przez serwis zakodowanych danych nie będą osiągalne żadne faktyczne treści danych. Jedynie posiadając oryginalne (niezakodowane dane) można zdekodować tak zakodowane dane.

Do odczytania zakodowanych kopii danych służą dwie funkcje:

  • dekodowanie danych

  • odtworzenie zakodowanych danych bez dekodowania


Dekodowanie danych

BEZPIECZEŃSTWO DANYCH - Serwisowanie danych

Z funkcji dekodowania danych (Zbiory - Narzędzia - Serwisowanie danych - Dekodowanie danych) korzystamy tylko wtedy, gdy wcześniej wysłaliśmy dane do serwisu, korzystając z funkcji kodowania danych.

UWAGA. Dekodowanie danych zakończy się pomyślnie tylko w przypadku, gdy w bieżącej bazie danych posiadamy faktyczne dane. W zakodowanym archiwum fizycznie nie istnieją treści danych i tylko mając oryginalne dane możemy wgrać zakodowane archiwum otrzymując pełne dane. Nie posiadając u siebie prawdziwych danych odkodowanie danych jest fizycznie niemożliwe.

Jeśli chcemy odczytać zakodowane dane nie posiadając oryginalnych danych, możemy posłużyć się funkcją odtwarzanie zakodowanych danych. Po odtworzeniu jednak, nie będziemy posiadali żadnych treści.

Funkcja dekodowania danych udostępniona jest w celu wgrania naprawionej przez serwis bazy danych. Serwis nie mając wglądu w treść danych może naprawić strukturę zakodowanej bazy danych, a użytkownik dekodując naprawione dane otrzyma u siebie prawidłową bazę danych.

Podobnie jak kodowanie, dekodowanie danych składa się z dwóch etapach:

  • Dane ogólne - odtwarzane są globalne dane programu

  • Aktualna firma - dane dotyczące konkretnej firmy

UWAGA. Dekodowanie pozwala na odtworzenie stanu danych z momentu kodowania. Po odtworzeniu bieżące dane giną bezpowrotnie, dlatego funkcji tej należy używać tylko po awarii i w ostateczności, gdy inne sposoby nie dają rezultatu.

Przy dekodowaniu danych z dyskietek wybieramy A:\ lub B:\, przy dekodowaniu z twardego dysku wybieramy katalog źródłowy, w którym wcześnie zarchiwizowaliśmy dane (np. C:\SERWIS).

Przy dekodowaniu danych ogólnych podajemy utworzony plik APK. Standardowo przy kodowaniu danych ogólnych tworzy się plik BIN.APK, (jeśli nie podamy innej nazwy), w związku z czym ten właśnie plik wybieramy.

Przy odtwarzaniu danych aktualnej firmy odnajdujemy odpowiedni (podany podczas kodowania) plik APK. Standardowo, jeśli nie zmienialiśmy nazwy, będzie to plik DANE1.APK (lub DaneX.apk dla firmy o numerze X).


Odtwarzanie zakodowanych danych

BEZPIECZEŃSTWO DANYCH - Serwisowanie danych

Funkcja odtwarzania zakodowanych danych (Zbiory - Narzędzia - Serwisowanie danych - Odtwarzanie zakodowanych danych BEZ DEKODOWANIA) jest udostępniona tylko i wyłącznie po to, aby użytkownik mógł się upewnić, że wysłane do serwisu zakodowane dane rzeczywiście nie zawierają żadnych danych, umożliwiających np. identyfikację kontrahentów i innych treści.

UWAGA. Ewentualne odtworzenie należy wykonać w dodatkowo zainstalowanej kopii programu, aby nie stracić bezpowrotnie właściwych danych.

Odtwarzanie zakodowanych danych (BEZ DEKODOWANIA) jest (podobnie jak dekodowanie danych) czynnością odwrotną do kodowania danych, pozwala wykorzystać zakodowane wcześniej dane. Różnica polega na tym, że przy odtwarzaniu zakodowanych danych otrzymamy bazę danych bez żadnych treści danych, natomiast przy dekodowaniu danych otrzymamy pełną bazę danych (ale tylko w przypadku, jeśli przed dekodowaniem posiadaliśmy już wszystkie dane.

Podobnie jak kodowanie danych, odtwarzanie zakodowanych danych składa się z dwóch etapach:

  • Dane ogólne - odtwarzane są globalne dane programu

  • Aktualna firma - dane dotyczące konkretnej firmy

UWAGA. Odtwarzanie pozwala na odtworzeniu stanu danych z momentu archiwizacji. Po odtworzeniu bieżące dane giną bezpowrotnie. W odtworzonych danych nie będzie żadnych treści danych. Funkcja ta służy tylko i wyłącznie do tego, żeby mieć możliwość przekonania się, że w utworzonych zakodowanych kopiach danych fizycznie nie istnieją w nich żadne treści.

Przy odtwarzaniu danych z dyskietek wybieramy A:\ lub B:\, przy odtwarzaniu z twardego dysku wybieramy katalog źródłowy, w którym wcześnie zarchiwizowaliśmy dane (np. C:\SERWIS).

Przy odtwarzaniu danych ogólnych podajemy utworzony plik APK. Standardowo przy archiwizowaniu danych ogólnych tworzy się plik BIN.APK, (jeśli nie podamy innej nazwy), w związku z czym ten właśnie plik wybieramy.

Przy odtwarzaniu danych aktualnej firmy odnajdujemy odpowiedni (podany podczas archiwizacji) plik APK. Standardowo, jeśli nie zmienialiśmy nazwy, będzie to plik DANE1.APK (lub DaneX.apk dla firmy o numerze X).


Weryfikacja spójności danych

BEZPIECZEŃSTWO DANYCH

Program [image] wykonany jest w technologii, która zapewnia spójności danych w przypadku awarii komputera lub programu, braku zasilania, zrestartowania lub zawieszenia komputera itp. Tym nie mniej w niektórych nieprzewidzianych sytuacjach może się okazać, że dane zgromadzone w programie mogą w wyniku awarii utracić logiczną spójność. Oznacza to np. że istnieją pozycje faktury, ale nie ma właściwej faktury, stany magazynowe wybranej dostawy nie zgadzają się z rozchodami tej dostawy itp.

Do sprawdzenia i ewentualnej naprawy spójności danych służy mechanizm weryfikacji spójności danych dostępny w menu głównym Zbiory-Narzędzia-Weryfikacja spójności danych lub pod skrótem klawiszowym Ctrl Alt W. Należy go uruchomić zawsze po nieprawidłowym zakończeniu pracy komputera (brak zasilania, zawieszenie, przypadkowy restart itp.).

Po wybraniu z menu głównego odpowiedniej pozycji pokazuje się okno Weryfikacja spójności danych i zostaje automatycznie uruchomiona weryfikacja (bez konieczności klikania w przycisk Start). Zostaną sprawdzone wszystkie newralgiczne punkty spójności danych. Jeśli dane są spójne, weryfikacja zakończy się pokazując napis OK w liniach statusu wszystkich sprawdzonych punktów spójności - jak na pokazanym okienku.

W przypadku wystąpienia ewentualnych błędów odpowiednia informacja pokaże się w jednej z (lub kilku) linii statusu i program będzie chciał przystąpić do automatycznej naprawy wykrytego problemu (lub problemów). Po wyrażeniu zgody przez użytkownika zostanie uruchomiona automatycznie funkcja Napraw, która po kolei spróbuje naprawić wykryte błędy w spójności danych. Po zakończeniu naprawy program będzie chciał wykonać automatycznie kontrolną weryfikację spójności, aby sprawdzić czy w wyniku naprawy błędów nie powstały problemy ze spójnością w innych punktach. W wypadku ich wystąpienia nastąpi ponowna naprawa danych, a następnie znowu weryfikacja spójności i tak aż do momentu, w którym albo nie występują już żadne błędy albo wykrytych błędów nie da się automatycznie naprawić. W tej drugiej, bardzo rzadkiej, sytuacji możemy albo skontaktować się z serwisem producenta albo odtworzyć ostatnie dobre archiwum danych i wprowadzić ponownie dokumenty wystawione w programie od czasu sporządzenia tego archiwum.

Poszczególne punkty spójności dotyczą:

  • Zagubione pozycje PZ

    • wyjaśnienie: w danych występują pozycje dokumentów PZ, ale brak jest dokumentów PZ, do których należą te pozycje.

    • przyczyna: np. przerwanie programu przed zaakceptowaniem nowego dokumentu PZ, na którym wpisano już pozycje.

    • naprawa: utworzenie dokumentów PZ, do których będą przypisane zagubione pozycje. Odtworzone dokumenty mają oryginalną datę, tzn. taką z którą były tworzone, ale nie mają określonego numeru kolejnego, a zamiast oryginalnego dostawcy mają przypisanego kontrahenta o skrócie nazwy '!!!'.

    • uwagi: po zamknięciu okna z weryfikacją spójności należy przejść do okna PZ, odnaleźć odtworzone PZ (najprościej ustawiając okres przeglądania F12 na Wszystko i włączając filtr [image] F4 z wybranym w polu Kontrahent kontrahentem o skrócie nazwy '!!!') i albo określić brakujące dane (numer, kontrahent itd.) albo usunąć te dokumenty.

  • Zagubione pozycje MM

    • wyjaśnienie: w danych występują pozycje dokumentów MM, ale brak jest dokumentów MM, do których należą te pozycje.

    • przyczyna: np. przerwanie programu przed zaakceptowaniem nowego dokumentu MM, na którym wpisano już pozycje.

    • naprawa: utworzenie dokumentów MM, do których będą przypisane zagubione pozycje. Odtworzone dokumenty mają oryginalną datę, tzn. taką z którą były tworzone oraz magazyny źródłowy i docelowy, ale nie mają określonego numeru kolejnego.

    • uwagi: po zamknięciu okna z weryfikacją spójności należy przejść do okna MM, odnaleźć odtworzone MM (najprościej ustawiając okres przeglądania F12 na Wszystko i włączając filtr [image] z wybranym kryterium @Nr = 0) i albo określić brakujące dane (numer itd.) albo usunąć te dokumenty.

  • Zagubione pozycje faktur

    • wyjaśnienie: w danych występują pozycje faktur (lub innych dokumentów sprzedaży/wydania), ale brak jest faktur (lub innych dokumentów sprzedaży/wydania, do których należą te pozycje.

    • przyczyna: np. przerwanie programu przed zaakceptowaniem nowej faktury, na której wpisano już pozycje.

    • naprawa: utworzenie faktur, do których będą przypisane zagubione pozycje. Odtworzone dokumenty mają oryginalną datę, tzn. taką z którą były tworzone, ale nie mają określonego numeru kolejnego, a zamiast oryginalnego nabywcy mają przypisanego kontrahenta o skrócie nazwy '!!!'.

    • uwagi: po zamknięciu okna z weryfikacją spójności należy przejść do okna Faktury, odnaleźć odtworzone dokumenty (najprościej ustawiając okres przeglądania F12 na Wszystko i włączając filtr [image] F4 z wybranym w polu Kontrahent kontrahentem o skrócie nazwy '!!!') i albo określić brakujące dane (numer, kontrahent itd.) albo usunąć te dokumenty.

  • Zagubione pozycje WZ

    • wyjaśnienie: w danych występują pozycje WZ (te które normalnie pojawiają sie na zakładce "WZ" faktury lub innego dokumentu sprzedaży/wydania), ale:

      • brak jest dokumentów, do których należą te pozycje.
      • na dokumencie, z którym są związane te pozycje, jest wyłączone pole WZ, co oznacza, że nie powinno być tych pozycji
      • brak jest pozycji dokumentu (tych z zakładki "Pozycje"), z którymi powinny być związane te pozycje
      • są związane z pozycjami dokumentu (tymi z zakładki "Pozycje"), na których ręcznie wpisano asortyment (bez powiązania z biblioteką)
      • są związane z pozycjami dokumentu (tymi z zakładki "Pozycje"), które są usługami

    • przyczyna: np. przerwanie programu w trakcie włączania/wyłączania pola WZ na fakturze.

    • naprawa: usunięcie błędnych pozycji.

  • WZ niezgodny z fakturą

    • wyjaśnienie: w danych występują pozycje WZ (te które normalnie pojawiają sie na zakładce "WZ" faktury lub innego dokumentu sprzedaży/wydania), ale wydana na nich ilość nie zgadza się z ilością sprzedaną na fakturze (tzn. z ilością na odpowiedniej pozycji na zakładce "Pozycja")

    • przyczyna: np. przerwanie programu w trakcie akceptowania pozycji faktury

    • naprawa: dopasowanie ilości na pozycjach WZ do pozycji faktury

  • Kwoty wg stawek vat niezgodne z fakturą

    • wyjaśnienie: w danych występują faktury których wartość netto (zakładka "Pozycje") różni się od sumy netto wg stawek vat (zakładka "Stawki VAT")

    • przyczyna: np. przerwanie programu w trakcie akceptowania pozycji faktury

    • naprawa: nie da się automatycznie naprawić tego błędu. Należy odszukać błędne dokumenty i przeliczyć je.

  • Bilans magazynu

    • wyjaśnienie: w danych występują dostawy, dla których różnica przyjętej i wydanej/przesuniętej ilości nie jest równa ilości znajdującej się aktualnie na stanie magazynu

    • przyczyna: np. przerwanie programu w trakcie akceptowania pozycji PZ, MM lub faktury

    • naprawa: skorygowanie ilości znajdującej się w magazynie, tak żeby była równa różnicy przyjętej i wydanej/przesuniętej ilości

  • Zagubione dostawy

    • wyjaśnienie: w stanie magazynu występują dostawy, które nie mają swojego odpowiednika w pozycjach PZ

    • przyczyna: np. przerwanie programu w trakcie usuwania pozycji PZ

    • naprawa: usunięcie tych dostaw z magazynu

  • Stany w bibliotece asortymentów

    • wyjaśnienie: stany asortymentów w danych magazynach zapamiętywane są na bieżąco w bibliotece asortymentów, po to, aby ich obliczanie nie spowalniało programu. Jeśli te stany nie zgadzają się z aktualnymi ilościami w stanie magazynu, powstaje niespójność.

    • przyczyna: wystąpienie jednej z powyższych niespójności lub przerwanie programu w trakcie obliczania stanów magazynowych do zapamiętania w bibliotece asortymentów

    • naprawa: skorygowanie błędnych stanów w bibliotece asortymentów

UWAGA. Wyniki weryfikacji są w pełni wiarygodne, jeśli w czasie jej wykonania żaden z użytkowników zalogowanych do programu nie tworzył żadnych dokumentów.


Zestawienia SQL

ZESTAWIENIA I STATYSTYKI

Jeśli dostępne w programie standardowe zestawienia i raporty nie zaspokajają naszych potrzeb, możemy skorzystać z możliwości oferowanych przez zestawienia SQL.

Są to zestawienia odpowiadające zapytaniom SQL. Ich zdefiniowanie wymaga znajomości języka SQL oraz struktury bazy danych programu, w związku z tym najlepiej zlecić je wykwalifikowanym pracownikom dystrybutora lub producenta programu. Korzystać ze zdefiniowanych już zestawień może oczywiście każdy użytkownik.

Korzystając z polecenia menu głównego Raporty - Zestawienia SQL otwieramy okno ZESTAWIENIA SQL, które umożliwia zarówno zdefiniowanie nowego zestawienia, jak i wykonanie zestawienia już zdefiniowanego.

DEFINIOWANIE
Aby zdefiniować nowe zestawienie naciskamy [image] Ins i w okienku EDYCJA ZESTAWIENIA SQL wpisujemy odpowiednie zapytanie SQL. Np. jeśli chcemy zdefiniować zestawienie, które pokaże nam wszystkie faktury wystawione w roku 2007, które były niezapłacone do dnia 10.07.2007 włącznie (bez względu na to, czy są teraz zapłacone, czy nie), możemy wpisać:

Aby ułatwić sobie tworzenie zapytania, możemy skorzystać z przygotowanych list:

  • Tabele - wszystkie tabele z danymi, z których korzysta program. Wymienione w porządku alfabetycznym. Przed tymi, które odpowiadają plikom przechowywanym w podkatalogu BIN (a nie w DANE.X, gdzie X to identyfikator firmy), znajduje się prefix {BIN} - po to, żeby program wiedział skąd ma brać dane. Podwójne kliknięcie w nazwę tabeli powoduje przepisanie jej do okienka z tekstem zapytania.

  • Kolumny - alfabetyczna lista pól występujących w wybranej wyżej tabeli. Podwójne kliknięcie w nazwę pola powoduje przepisanie jej do okienka z tekstem zapytania.

  • Indeksy - alfabetyczna lista indeksów utrzymywanych w wybranej wyżej tabeli. Przydatna informacyjnie przy optymalizowaniu szybkości działania zestawienia.

Zaznaczając pole Zapisz przed wykonaniem zabezpieczamy się przed utratą wpisanego tekstu zapytania, co może się zdarzyć przy "powieszeniu się" programu przy próbie wykonania niezoptymalizowanego lub zawierającego błędy zapytania SQL.

Przycisk Wykonaj zapisuje zapytanie we wskazanej lokalizacji w pliku z rozszerzeniem .sql (jeśli zaznaczono Zapisz przed wykonaniem) i wykonuje zapytanie.

Po wykonaniu zapytania możemy ewentualnie zmienić nadaną mu wcześniej nazwę zapisując [image] je pod inną nazwą.

WYKONYWANIE
Aby wykonać zdefiniowane wcześniej zestawienie naciskamy [image] Wczytaj definicję zestawienia i wskazujemy plik z utworzoną wcześniej definicją zestawienia. Wybrane zestawienie możemy od razu wykonać Wykonaj lub przed wykonaniem zmodyfikować Edytuj. Po wykonaniu zestawienia możemy ewentualnie określić właściwości jego kolumn [image] Ctrl F4 lub od razu [image] F2 wydrukować.


ZMIANA STAWEK VAT W 2011

Program R2faktury począwszy od wersji 6.08 umożliwia obsługę nowych stawek vat obowiązujących w 2011 roku.

  1. Po wgraniu tej wersji w grudniu 2010 możemy do końca roku pracować zgodnie z przepisami obowiązującymi w 2010 roku, czyli tak jak do tej pory. Jedyną dodatkową czynnością, którą możemy wykonać już w grudniu jest przygotowanie biblioteki PKWIU 2008 wraz z nowymi stawkami VAT i powiązanie asortymentów z pozycjami z tej biblioteki. Jeśli mamy dużo asortymentów, to wręcz musimy przygotować tę bibliotekę jeszcze w grudniu, po to aby bez zbędnej zwłoki rozpocząć pracę w styczniu 2011.

    Klasyfikacja "PKWIU 2008" to jedna z nowości obowiązujących od 01.01.2011. Zastępuje ona obowiązującą do końca 2010 klasyfikację "PKWIU 2004". W programie dostępne są obie biblioteki w menu Okna - PKWIU - 2004/2008. Biblioteka PKWIU 2008 jest wstępnie zainicjowana pozycjami używanymi do tej pory w PKWIU 2004. W każdej pozycji biblioteki na początku pola Nr został dodany znak ? (pytajnik) symbolizujący konieczność zweryfikowania tego numeru wg nowej klasyfikacji. Powiązane z pozycjami PKWIU 2008 stawki VAT zostały zamienione odpowiednio: z 3% na 5%, z 7% na 8% oraz z 22% na 23%. Weryfikację numerów PKWIU 2008 należy przeprowadzić samodzielnie. Program nie udostępnia gotowej całej klasyfikacji PKWIU 2008 (podobnie jak nie udostępniał PKWIU 2004).

    Asortymenty są powiązane zarówno ze starą pozycją z PKWIU 2004 (pole PKWiU 2004 na zakładce Inne), jak i z nową z PKWIU 2008 w polu PKWiU. Jeśli używane w naszej w firmie pozycje PKWiU 2008 odpowiadają w sposób jednoznaczny pozycjom z PKWIU 2004 (tzn. jednej starej odpowiada jedna nowa), to poza określeniem nowego numeru i sprawdzeniem czy stawka vat jest właściwa nie trzeba nic więcej robić. Można jedynie w oknie Asortymenty włączyć kolumny PKWIU 2004, VAT% 2004, PKWIU 2008, VAT% (2008) i sprawdzić poprawność przypisania PKWiU oraz stawek VAT do poszczególnych asortymentów. Jeśli natomiast stara pozycja z PKWIU 2004 rozdzieliła się teraz np. na dwie nowe, to trzeba brakującą pozycję dopisać do PKWIU 2008 i przypisać ją do asortymentu w polu PKWiU.

    Jeśli uporządkujemy biblotekę PKWIU 2008 i praktykujemy wystawianie faktur z datą sprzedaży z przyszłego miesiąca, to możemy wystawiać w grudniu 2010 faktury z datą sprzedaży z 2011. Program zastosuje automatycznie nową stawkę vat. Ustawienie zastosowanej stawki vat można sprawdzić/zmienić w trakcie wystawiania faktury w oknie Pozycje na zakładce Inne w polu Aktywne PKWiU.

  2. Przed rozpoczęciem pracy w 2011 należy wykonać kilka dodatkowych czynności. Aby żadnej nie pominąć i wykonać je wszystkie w odpowiedniej kolejności, przygotowany został odpowiedni kreator zmiany stawek VAT. Okno kreatora pojawi się przy próbie wystawienia pierwszego dokumentu w 2011 roku (faktury, wz, pz lub mm):

    Postępując zgodnie z kolejnością (punkty od 1 do 4) wykonujemy odpowiednie czynności. Wykonanie każdej czynności zaznaczamy w odpowiednim polu:

    1. Archiwizacja danych - aby umożliwić sobie anulowanie zmian i powrót do dotychczasowych danych, przed rozpoczęciem zmian należy koniecznie wykonać archwizację bazy danych.

    2. Weryfikacja biblioteki PKWiU 2008 - jeśli nie wykonaliśmy jeszcze czynności opisanych wyżej w punkcie I. to wykonujemy je teraz.

    3. Przeliczenie cen sprzedaży wg nowych stawek VAT - przed rozpoczęciem pracy w 2011 należy zaktualizować ceny sprzedaży, tak aby uwzględniały odpowiednio nowe stawki VAT. Możemy to zrobić na dwa sposoby:

      1. samodzielnie - wchodząc do każdego asortymentu w bibliotece asortymentów i poprawiając jego ceny

      2. automatycznie - program automatycznie przeliczy wszystkie ceny sprzedaży, łącznie z cenami dedykowanymi

        • Jeśli chcemy, aby to klient poniósł koszt podwyższenia stawek vat, musimy zachować ceny netto i podwyższyć ceny brutto z uwzględnieniem nowych stawek. W tym celu klikamy w przycisk Zachowaj ceny netto, PRZELICZ BRUTTO.

        • Jeśli chcemy, aby klient nie odczuł podwyższenia stawek vat i zgadzamy się na obniżenie naszego zysku, musimy zachować ceny brutto i obniżyć ceny netto z uwzględnieniem nowych stawek. W tym celu klikamy w przycisk Zachowaj ceny brutto, PRZELICZ NETTO.

    4. Przeliczenie wzorców fasktur powtarzalnych wg nowych stawek VAT - przed rozpoczęciem pracy w 2011 należy zaktualizować ceny i wartości we wzorcach faktur powtarzalnych, tak aby uwzględniały odpowiednio nowe stawki VAT. Jeśli nie korzystamy z faktur powtarzalnych, pomijamy ten krok. Przeliczenie odbywa się automatycznie. Należy tylko w zależności od przyjętej strategii kliknąć w przycisk Zachowaj wartości netto, PRZELICZ BRUTTO lub w Zachowaj wartości brutto, PRZELICZ NETTO.

    5. Konfiguracja urządzeń fiskalnych - na koniec musimy jeszcze przystosować do nowych stawek vat nasze drukarki i kasy fiskalne. Jeśli nie korzystamy z urządzeń fiskalnych, pomijamy ten krok.

      1. w drukarkach i kasach musimy wprowadzić nowe stawki vat. Wykonujemy tę czynność samodzielnie lub zlecamy ją firmie serwisującej nasze urządzenia fiskalne.

      2. po wprowadzeniu nowych stawek vat do drukarek fiskalnych musimy analogicznie skonfigurować te urządzenia w programie. W tym celu wybieramy z menu Ustawienia - Urządzenia fiskalne i wchodząc do każdej drukarki określamy nowe Stawki VAT ręcznie lub klikając w przycisk Pobierz.

      3. ostatnią czynnością jaka została do wykonania jest ewentualne zmodyfikowanie nazw asortymentów, tak aby drukarki fiskalne nie sygnalizowały błędu w trakcie wydruku asortymentów ze zmienioną stawką VAT. Problem ten może się pojawić w przypadku, gdy dla jakiegoś asortymentu obniżono wcześniej stawkę vat a teraz w 2011 ją podwyższymy. Zabezpieczeniem przed tego typu problemami jest dodanie do nazwy asortymentu dowolnego znaku, np. "." (kropki). Taki asortyment jest traktowany przez drukarkę jako nowy asortyment i na pewno nie będzie z nim żadnego problemu w trakcie wydruku. Cała ta operacja ma charakter profilaktyczny, gdyż wspomniane problemy niekoniecznie muszą wystąpić w każdym przypadku. Jeśli nie chcemy zmieniać nazw asortymentów zaznaczamy pozycję a). W przeciwnym wypadku, jeśli chcemy z góry zapobiec ewentualnym problemom, wybieramy b) i klikamy w przycisk Zmodyfikuj nazwy. W tym drugim przypadku sprawa może się nieco skomplikować, gdy korzystamy z asortymentów o nazwach dłuższych niż 40 znaków. Drukarki fiskalne rozróżniają włąśnie tylko tyle znaków i dodawanie "." na końcu nazwy takiego asortymentu nie spełni swojego zadania. Takie asortymenty zostaną wskazane przez program i niezbędne będzie samodzielne zmodyfikowanie ich nazwy.

    Po wykonaniu wszystkich czynności klikamy OK i już bez dalszych komplikacji rozpoczynamy pracę w 2011 roku.

    UWAGA: Jeśli dopiero rozpoczynamy pracę z programem i w 2010 nie wystawiliśmy jeszcze żadnych dokumentów, to opisane powyżej okienko Zmiana stawek VAT w 2011 roku nie będzie dostępne. W takim wypadku jeżeli przygotowaliśmy już w grudniu listę asortymentów wraz z odpowiednimi numerami PKWiU 2008 i stawkami vat, należy przed rozpoczęciem pracy w 2011 wykonać przeliczenie cen sprzedaży wg stawek vat obowiązujących w 2011 roku. Służy do tego funkcja Dodatkowe funkcje - Przelicz ceny wg stawek VAT 2011 dostępna w menu pomocniczym (prawy klawisz myszy) w oknie Asortymenty.

  3. Warto wymienić jeszcze pozostałe nowości wynikające ze zmienionych przepisów:

    1. faktury RR wystawiane w 2011 roku korzystają ze stawki 7% zamiast dotychczasowych 6%

    2. korekty do faktur z 2010 wystawiane w 2011 operują na PKWIU 2004 i starych stawkach VAT

    3. faktury wystawiane w 2011 do paragonów i WZ z 2010 operują na PKWIU 2004 i starych stawkach VAT

    4. na fakturze wystawianej w 2011 można używać starych stawek VAT, np. w przypadku fakturowania usługi wykonanej w 2010 roku (data sprzedaży z 2010 roku). W tym celu należy na pozycji faktury (przycisk Pozycje) wybrać wartość 2004 w polu Aktywne PKWiU na zakładce Inne. Domyślna wartość tego parametru dostosowuje się automatycznie do użytej na fakturze daty sprzedaży (jeśli data sprzedaży z 2011 lub nowsza to PKWiU2008, przy starszych datach PKWiU2004). W zależności od potrzeb możemy zmieniać wartość tego parametru.